Русский

Mole`s Smart Version Patch Constructor 1.7

Copyright © Mole, 2015


Общие сведения

Русский ››

Mole`s SVPC (Конструктор Патчей)

Конструктор предназначен для сравнения двух файлов и построения на основе полученных результатов

готовых к применению исполняемых файлов (Патчей).

За основу взята консольная утилита из проекта SmartVersion 3.0

Идеология Патчей

Для примера возьмем образ DVD-диска (4.7Gb) с сложным программным обеспечением.

Разработчик регулярно вносит обновления или изменения в образ и выкладывает его для скачивания (4.7Gb).

В действительности же "чистый" размер вносимых изменений может насчитывать от 100 до 500Mb,

а приходится скачивать полноразмерный образ (4.7Gb).

Конструктор Патчей позволяет сравнить исходный и обновленный файлы, извлечь из них ТОЛЬКО разницу и

изготовить исполняемый файл, умеющий её обрабатывать. Но это будут, например, те же 100 или 500Mb а не целых 4.7Gb, что очень ощутимо для

пользователей с "медленным" интернетом. После применения Патча к исходному файлу добавляется разница и формируется обновленный файл.

То есть, вместо скачивания полноразмерного файла можно своевременно скачивать только Патчи и применять их.

При таком подходе исходный (4.7Gb) файл скачивается только один раз.

Особенности Конструктора

1. Автоопределение наличия "Исходного файла" в одном каталоге с Патчем.

2. Расположение Патча в одном каталоге с "Исходным файлом" не обязательно.

3. Корректное создание Патчей с размером более 2Gb.

4. Проверка хеша MD5 "Исходного" и "Измененного" файлов, как на стадии сборки Патча, так и при его применении.

5. Поддержка "Drag&Drop" (перетаскивания) для выбора сравниваемых файлов и пути сохранения Патча.

6. Наглядность процесса и простота использования на всех этапах сборки и применения Патча.

7. Для нормальной работы программы не требуется ".Net Framework" и подключение к Интернет.

8. Поддерживает подключение внешних "языковых пакетов", с языком отличным от Русского.

9. Программа не содержит Spyware, Adware и.т.п, при сомнениях проверяем на: https://www.virustotal.com


Системные требования

Минимальные требования:

1. Операционная система: Windows XP/7/8/8.1

2. На системном разделе HDD свободное место должно быть:

а.) При создании Патча - не менее чем: (размер самого большого из сравниваемых файлов) х 2

б.) При применении Патчей: (размер исходного файла) + (размер самого Патча)

3. Следует понимать, что минимальные требования по свободному месту на HDD имеют весьма приблизительные границы.

Известные ограничения:

1. Работа на ОС, отличных от Windows не проверялась, не гарантируется и не рекомендуется.

2. При работе в Windows 7/8/8.1 запуск программы должен происходить с Административными правами.

3. Поведение программы в среде WinPE может отличаться в худшую сторону от поведения в полноценной ОС.

4. Работа утилиты может быть нарушена особо бдительными антивирусными программами (т.н "проактивная" защита и.т.п).

5. При применении Патчей не рекомендуется единовременная работа двух и более Патчей.

6. Изменять внутреннюю структуру готового Патча НЕЛЬЗЯ, сменить имя исполняемого файла МОЖНО.

Примечание: На Windows XP(x64) и на Windows Vista (x86/x64) работа Конструктора и Патчера по известным причинам не проверялась.


Работа с программой

Как работать с программой:

1. Основные термины

Конструктор - программа, которая создает готовый к применению Патч (см. Рис.1).

Патч - исполняемый файл, созданный Конструктором (см. Рис.2 и 3).

Исходный файл - оригинальный файл.

Измененный файл - исходный файл после внесённых в него изменений или дополнений.

Файл-результат - файл, получившийся после применения Патча.

2. Внешний вид

Рис.1

Рис.2

Рис.3

3. Создание патча

Рекомендуется придерживаться очередности:

3.1. Выбрать "Исходный файл".

3.2. Выбрать "Измененный файл".

3.3. Выбрать место сохранения Патча.

3.4. Изменить заголовок окна будущего Патча (при необходимости).

3.5.Нажать кнопку "Собрать" и дождаться полного окончания сборки Патча.

Примечания:

3.1. Если место сохранения Патча не будет выбрано, то Патч создастся в одном каталоге с Конструктором.

3.2. Zlib-сжатие эффективно при обработке текстовых файлов, а так же файлов, не сжатых архиваторами с

применением Solid (непрерывного) метода архивации. (По умолчанию выключено).

3.3. Для пунктов 3.1-3.3 при создании Патча работает "Drag&Drop" (перетаскивание).

4. Применение патча

4.1. Скопировать Патч на раздел HDD, независимо от местоположения "Файла-источника".

4.2. Запустить Патч, после распаковки файлов нажать кнопку "Применить" в окне Патча.

4.3. Необходимо дождаться полного окончания работы Патча.

Примечание:

4.1. Если Патч не сможет самостоятельно найти "Исходный файл", то будет показан диалог для его выбора.

5. Патчи размером свыше 2Gb

5.1. Если при сравнении файлов выяснится, что разница между ними превышает 2Gb, то Патч

получает соответствующую "добавку" к имени: "Patch_<Исходный файл>_2Gb.exe".

Предупреждение об этом программа покажет перед сборкой файла.

5.2. Структура Патча будет изменена на: небольшой исполняемый файл + многотомный архив с размером тома 2000 Мб,

что позволит без проблем записывать патчи на DVD-R/RW носитель.

5.3. Место сохранения Патча остается таким же, каким было выбрано до начала сборки Патча.

6. Разное

6.1. Два почти одинаковых по размеру файла могут иметь как 5% отличий, так и более 50% отличий.

6.2. Процесс сравнения файлов, а также процесс применения Патча могут длиться довольно долго.

В основном это зависит от кол-ва различий между файлами и размера самих файлов.

6.3. Если Вы не понимаете целевое назначение этой программы, то не рекомедуется запускать её

как на своём, так и на чужом PC.


Языковой пакет

Дополнительные языковые пакеты

1. Общая информация

Начиная с верcии 1.7 в программе появилась возможность подключать внешний языковой пакет.

Пакет представляет собой текстовый файл с несложной структурой типа: "ключ=значение".

Ниже приводится точная копия Русского языкового пакета, используемого в программе Mole`s SVPC 1.7

[DEFAULT]

1=Укажите исходный файл ...

2=Укажите измененный файл ...

3=Укажите каталог для сохранения патча ...

4=Укажите заголовок окна патча ...

5=Обзор

6=Очистить

7=Собрать

8=Скрыть путь

9=Zlib сжатие

10=Нажмите на кнопку "Обзор" и сделайте выбор ...

11=Выбрать файл

12=Образы

13=Все файлы

14=Выбрать каталог

15=Внимание!

16=Ошибка!

17=Информация!

18=Необходимые поля ввода не были заполнены!

19=Выбранный путь не ведёт к файлу!

20=Выбранный путь не ведёт к каталогу!

21=Исходный файл не был выбран!

22=Измененный файл не был выбран!

23=Патч для

24=Нажмите кнопку "Собрать" для сборки патча ...

25=Одинаковые имена файлов недопустимы!

26=Файлы одинаковы по размеру, хотите продолжить?

27=Расчёт хеша MD5 для исходного файла, ожидайте ...

28=Расчёт хеша MD5 для обновлённого файла, ожидайте ...

29=Невозможно вычислить хеш MD5.

30=Возможно ваш антивирус работает в "параноидальном" режиме.

31=Продолжение работы невозможно.

32=Результат вычисления хеша MD5: файлы идентичны.

33=Идёт сравнение файлов, ожидайте ...

34=Разница между файлами превышает 2Gb.

35=Процесс сборки Патча может быть долгим.

36=Следите за индикатором процесса.

37=Идёт процесс сборки Патча, ожидайте...

38=Все задачи завершены, программу можно закрыть.

39=Извлечение

40=Идёт извлечение файлов, ожидайте ...

41=На диске:

42=осталось менее 10% свободного места.

43=Успешное выполнение задачи не гарантируется.

44=Продолжить работу программы?

45=О программе

46=Автор:

47=Служит для сравнения двух файлов и оформления разницы между ними в готовый к применению исполняемый файл.

48=В основе - консольная утилита от проекта SmartVersion 3.0.

49=Обнаружена запущенная копия программы.

50=Недостаточно места на диске:

51=Освободите как минимум:

52=МБ

53=ГБ

54=Свободное место:

55=Исходный файл не найден, выберите файл ...

56=Неизвестное имя файла.

57=Правильное имя:

58=Нажмите на кнопку "Применить" ...

59=Файл c именем:

60=уже существует.

61=Переименуйте его, или переместите в другой каталог.

62=Хеш MD5 исходного файла не совпадает!

63=Хеш MD5 обновленного файла не совпадает!

64=Возможно это не тот файл, или файл поврежден.

65=Имя:

66=Все задачи завершены, подготовка "Отчёта" ...

67=Применение Патча успешно завершено.

68=Для просмотра результата нажмите ДА.

69=Для выхода из программы нажмите НЕТ.

70=Рекомендуется выйти из программы и попробовать снова.

71=Идет подготовка файлов, ожидайте ...

72=Применение патча, ожидайте ...

73=Обнаружена ошибка процесса SMV.EXE!

74=Отчёт сохранен в файл:

75=Не найден файл конфигурации:

76=Поврежден файл конфигурации:

77=Применить

78=Поздравляем!

79=Основные настройки сделаны ...

80=Не найден языковой файл:

81=Языковой файл поврежден:

82=Справка

2. Создание и подключение внешнего языкового пакета

2.1. Выделить ВЕСЬ текст между горизонтальными линиями (см. выше) и скопировать его в буфер обмена.

2.2. Посетить онлайн переводчик https://translate.google.com/ или http://www.bing.com/translator/ и сделать перевод содержимого буфера обмена.

2.3. Создать текстовый файл с именем например: lang_en.ini и добавить в него содержимое буфера обмена с преводом, сохранить изменения.

2.4. Скопировать получившийся файл lang_en.ini в каталог с исполняемым файлом Mole`s SVPC 1.7. При запуске программа сама обнаружит файл и подключит его.

2.5. В процессе построения Патч наследует текущий языковой файл из Конструктора.

Примечания:

2.1. Если Вы в состоянии самостоятельно сделать перевод, то пункты 2.1-2.2 (см. выше) можно пропустить.

2.2. Язык интерфейса при создании патча автоматически наследуется в готовый к применению Патч.

2.3. Имя языкового файла обязательно должно содержать маркер: lang_ и буквы, обозначающие страну.

2.4. Пробелы в имени языкового файла недопустимы, расширение файла (.ini) изменять нельзя.

2.5. Пример готового Английского языкового пакета можно посмотреть здесь .


Решение проблем

Если при работе Конструктора или Патча возникают ошибки

1. Очистить временные каталоги Windows, используя (например) бесплатную утилиту CCleaner

2. Перезагрузить компьютер.

3. Еще раз перечитать раздел справки Требования

4. Убедиться, что на системном разделе Вашего HDD после очистки достаточно свободного места.

5. Временно отключить защиту Вашего антивируса.

6. Запустить программу от имени Администратора.

Примечание: Особого внимания к наличию свободного места на HDD требует применение патчей с пометкой: 2Gb.

Определение версии Конструктора

Рис.1

Цифры после сокращённого имени программы обозначают версию, на данном примере: 1.7 (см. Рис.1)

Определение версии Патча

Рис. 2

Для определения версии Патча достаточно посмотреть свойства файла Патча (см. Рис. 2)

На данном примере: 1.7.0.0

Copyright © Mole, 2015


От Автора

О программе

1. Программа бесплатна, использовать программу может любой желающий.

2. Разработка программы прекращена, появление очередной версии возможно только при обнаружении "фатальных" ошибок в коде,

которые делают невозможным использование программы по назначению.

Надеюсь, Конструктор Патчей будем Вам полезен.

Mole, 2015

Copyright © Mole, 2015


English

Mole`s Smart Version Patch Constructor 1.7


Language Pack

English ››

Additional Language Packs (LP)

1. Common information

The LP works only with Mole`s SVPC 1.7 and it looks like common configuration file, with a simple structure such as: "key=value".

The following text is an example of the English LP:

[DEFAULT]

1=Select a source file ...

2=Select a modified file ...

3=Select a destination folder ...

4=Set the dialog box title ...

5=Browse

6=Clear

7=Build

8=Hide path

9=Zlib compression

10=Click on the "Browse" button ...

11=Select a file

12=Images

13=All files

14=Select a folder

15=Warning!

16=Error!

17=Info!

18=Required fields have not been filled in.

19=The selected object is not a file!

20=The selected object is not a directory!

21=The source file has not been selected!

22=The modified file has not been selected!

23=Patch for

24=Click "Build" button to create a patch ...

25=The same file names are not allowed!

26=Files are the same size, do you want to continue?

27=Calculate MD5 hash for source file, please wait ...

28=Calculate MD5 hash for modified file, please wait ...

29=Unable to calculate MD5 hash!

30=Maybe your antivirus software running in "paranoid" mode.

31=Task sequence cannot continue.

32=Both file have the same MD5 hash.

33=Please wait while the files are compared ...

34=The difference between files exceed 2Gb.

35=The build process can take a long time to complete.

36=Watch the progress bar to check state.

37=Preparing required files, please wait ...

38=All tasks have been completed, the app could be closed

39=Extracting

40=Extracting files, please wait ...

41=On disk:

42=remain less than 10% free space.

43=Successful completion of the task can not be guaranteed.

44=Do you want to continue?

45=About

46=Author:

47=Designed to compare two files and building a results-based "ready-to-use" executable file.

48=Based on command line utility from the SmartVersion 3.0 project.

49=Multiple instances of Patch detected.

50=Not enough free space on disk:

51=Free up at least:

52=MB

53=GB

54=Free space:

55=Source file not found, select the file ...

56=Unknown file name.

57=Proper file name:

58=Click on the "Apply" button ...

59=File with name:

60=already exists.

61=Rename it, or move to another folder.

62=MD5 hash of the source file does not match!

63=MD5 hash of the updated file does not match!

64=Maybe wrong file or the file is corrupted.

65=Name:

66=All tasks completed, prepare the "Report" ...

67=The patch have been successfully applied.

68=Click YES to display the result.

69=Click NO to exit.

70=Close the application and try again.

71=Preparing files, please wait ...

72=Applying the patch, please wait ...

73=An error occurred while processing SMV.EXE!

74=The report was written to file:

75=Missing configuration file:

76=Damaged configuration file:

77=Apply

78=Congratulations!

79=The settings are almost done ...

80=Missing language file:

81=Damaged language file:

82=Help

2. Creating and connecting the LP

2.1. Select all text between the horizontal lines (see above) and copy it to the clipboard.

2.2. Visit online translator https://translate.google.com or http://www.bing.com/translator to translate the content of the clipboard.

2.3. Create a blank text file named (for example): lang_en.ini. Then write content of the clipboard to that file and save the changes.

2.4. Copy lang_en.ini to the directory with SVPC executable. When you next start the program, it will automatically detect the file.

Notes:

2.1. If you are able to make your own translation, the items 2.1-2.2 (see above) can be skipped.

2.2. LP automatically redirected to "ready-to-use" patch from Constructor (SVPC).

2.3. The name of the language file must contain a marker: lang_ and letters, what indicating the country.

2.4. Spaces in the name of the language file are not allowed. File extension (.ini) can not be changed.

2.5. The original description of the Russian LP can be found here .