Конфигурационный файл

Все настраиваемые параметры Syslinux могут быть изменены с помощью файла syslinux.cfg, находящегося в корне загрузочного устройства.

Это текстовый файл в формате UNIX или DOS, содержащий одну или несколько из следующих строк (ключевые слова нечувствительны к регистру; слова набранные CapsLock-ом означают, что их надо писать точно так же, как они написаны здесь):

Начиная с версии 3.35, конфигурационный файл может быть также в директории /boot/syslinux или /syslinux (поиск выполняется именно в таком порядке.)
В этом случае имена файлов считаются от места расположения конфигурационного файла, если они не начинаются с \ или /.

Все опции ниже подходят для SYSLINUX, ISOLINUX, PXELINUX и EXTLINUX, если не указано иное; подробнее см. их документацию.

Вот пример пункта загрузки:

DEFAULT linux
LABEL linux
SAY Now booting the kernel from SYSLINUX...
KERNEL vmlinuz.img
APPEND ro root=/dev/sda1 initrd=initrd.img

Компоненты конфигурационного файла

# comment

Комментарий. Все символы от # до перевода на новую строку игнорируются.

INCLUDE имя_файла

Вставляет содержимое другого файла в этом же месте
этого конфигурационного файла. Друг в друга можно вставлять до 16
файлов, но нормальная работа гарантирована при не более чем 8-кратной вставке.

DEFAULT ядро параметры...

Устанавливает командную строку по умолчанию. Если Syslinux загружается автоматически,
он будет работать как если бы строка после DEFAULT была введена в командную строку Syslinux.

Если конфигурационного файла нет или директива DEFAULT отсутствует,
DEFAULT становится "linux auto".

UI модуль параметры...

Устанавливает специальный модуль для пользовательского интерфейса
(обычно menu.c32 или vesamenu.c32). Эта опция перекрывает директивы DEFAULT и PROMPT.

APPEND параметры...

Добавить один или несколько параметров к ядру. Это применяется и к
автоматической, и к ручной загрузке. Опция эквивалентна опции APPEND
загрузчика LILO.

LABEL

LABEL имя
KERNEL файл_ядра
APPEND опции...
IPAPPEND flag_val [PXELINUX only]

Если "имя" введено как имя ядра для загрузки, Syslinux запускает
указанный файл ядра с указанными параметрами в APPEND.
Если APPEND не указан, используется глобальный (при наличии).

Начиная с версии 3.62, количество LABEL не ограничено.

Обратите внимание, что LILO использует синтаксис:

image = файл_ядра
label = имя
append = "опции"

... а Syslinux работает по-другому:

label имя
kernel файл_ядра
append опции

NB: "ядро" не обязательно является ядром Linux; оно может быть
загрузочным сектором или даже файлом COMBOOT (см. ниже)

Начиная с версии 3.32 "имена" больше не переводятся в формат DOS (для SYSLINUX.)

Следующие команды могут быть использованы после директивы LABEL:

LINUX image
BOOT image
BSS image
PXE image
FDIMAGE image
COMBOOT image
COM32 image
CONFIG image
- Ядро Linux (по умолчанию)
- Программа-загрузчик (bootstrap program) (.bs, .bin)
- файл BSS (.bss)
- PXE Network Bootstrap Program (.0)
- Несжатый образ дискеты (.img)
- программа COMBOOT (.com, .cbt)
- программа COM32 (.c32)
- другой конфигурационный файл

Использование этих директив вместо KERNEL устанавливает заданный тип файла, не взирая на имя файла.
CONFIG означает перезапуск Syslinux с использование нового конфигурационного файла.

APPEND - Не добавлять опции. APPEND - с одним дефисом в качестве аргумента может быть использован для обхода глобального APPEND.

INITRD файл initrd

Начиная с версии 3.71, initrd может быть указан отдельной директивой
(INITRD) вместо части директивы APPEND;
INITRD также добавляет initrd=initrd_file к параметрам ядра.

Можно указать несколько имён файлов, разделив их запятыми.
В основном это полезно для initramfs, которая может
состоять из нескольких отдельных архивов cpio или cpio.gz.

IMPLICIT значение

Если значение = 0, не загружать ядро, если оно не указано в LABEL.
Значение по умолчанию = 1.

ALLOWOPTIONS значение

Если значение = 0, пользователь не может указывать параметров ядра в командной строке.
Применяться будут только опции, указанные директивой APPEND. Значение по умолчанию = 1.

TIMEOUT время

Задаёт время ожидания командной строки перед автоматической загрузкой в условных единицах = 0,1 с.
Таймаут отключается как только пользователь нажимает какую-либо клавишу.
Нулевой таймаут вовсе отключает эту функцию (по умолчанию).

TOTALTIMEOUT время

Задаёт время ожидания пред автоматической загрузкой.
Не отменяется нажатием клавиши.
TIMEOUT и TOTALTIMEOUT могут быть использованы вместе, например:

# Подождать 5 секунд, пока пользователь не нажмёт клавишу
# через 15 минут загрузиться в любом случае
TIMEOUT 50
TOTALTIMEOUT 9000

ONTIMEOUT ядро параметры...

Устанавливает команду, выполняемую по таймауту. Обычно она совпадает с DEFAULT.
Если ONTIMEOUT задан, DEFAULT используется только для случая, когда пользователь
нажимает в пустой строке.

ONERROR ядро параметры...

Если ядро не найдено (файл не существует, или запуск запрещён)- выполнять указанную команду.
Несработавшая команда добавляется к параметрам ядра, т.е. Если в конфигурации указано:

ONERROR xyzzy plugh

... а пользователь ввёл:

foo bar baz

... Syslinux выполнит следующую команду:

xyzzy plugh foo bar baz

CONSOLE значение

Если значение равно 0, консоль не будет отображаться. Если значение равно 1, то консоль будет видна (это по умолчанию)
У некоторых BIOS-ов случаются проблемы с отображением "Видео" консоли. Если такие проблемы возникнут, вы этой опцией сможете отключить показ консоли.

FONT имя_файла

Загрузить шрифт в формате .psf перед тем, как выводить на экран что-либо (кроме копирайта, "зашитого" в ldlinux.sys)
Syslinux просто загружает шрифт в видеокарту; если .psf содержит Unicode таблицу, она игнорируется.
Это работает только на видеокартах EGA и VGA; мы надеемся, на остальных
картах ничего не произойдёт.

KBDMAP имя_файла

Устанавливает простейшую раскладку клавиатуры. Алгоритм переназначения клавиш *очень* прост
(он переназначает коды клавиш, полученные от BIOS, то есть переназначать можно только клавиши от стандартной клавиатуры США).
Это может помочь людям с QWERTZ или AZERTY клавиатурой, (эти символы часто используются в параметрах ядра)

DISPLAY имя_файла

Выводит содержимое указанного файла на экран (перед командной строкой, если есть).
Пожалуйста, прочитайте дополнительно секцию "формат файла DISPLAY".
NB: Если файл отсутствует, директива просто игнорируется.

SAY текст

Печатает на экране текст.
Пожалуйста, прочитайте дополнительно секцию "формат файла DISPLAY".

PROMPT значение

Если значение = 0, показывать boot: только если нажат Shift или Alt
или если включён Caps Lock или Scroll (значение по умолчанию).
Если значение = 1, показывать boot: всегда.

NOESCAPE значение

Если значение = 1, будут игнорироваться Shift/Alt/Caps Lock/Scroll Lock.
Используйте это (вместе с PROMPT 0) для указания единственно возможного варианта загрузки.

NOCOMPLETE значение

Если значение = 1, Клавиша Tab не показывает возможных значений label в командной строке (boot:).

F[1-12] имя_файла

F1 имя_файла
F2 имя_файла
...и.т.д...
F9 имя_файла
F10 имя_файла
F11 имя_файла
F12 имя_файла

Отображает указанный файл на экране, если нажать функциональную клавишу в командной строке.
Это можно использовать для вызова вспомогательной информации (опции загрузки ядра и.т.д)

Пустые и закоментированные строки (#) игнорируются.

Конфигурационный файл может быть прочитан не полностью. Синтаксис, отличающийся от указанного,
может нормально работать в этой версии Syslinux, но перестать работать в будущих версиях.

Оглавление Предыдущая Следующая Проект GreenFlash Форум

Copyright GreenFlash (c) 2007-2010


Параметры командной строки

Здесь перечислены команды применимые для установщика Syslinux.

Следующие опции подходят к любой версии Syslinux:

  • -s Безопасно, медленно, тупо (Safe, Slow, Stupid); более простой код, загружается лучше
  • -f Игнорировать некоторые не фатальные ошибки (force installing)
  • -r Режим Raid. Если загрузиться не удаётся, сообщить BIOS загрузить следующее загрузочное устройство (обычно следующий жёсткий диск) вместо остановки с отображением сообщения об ошибке. Можно использовать для загрузки с RAID-1.

Следующие опции подходят только для Windows:

  • -m MBR; установить загрузчик в MBR.
  • -a Active; пометить раздел на устройстве как загружаемый (=bootable)

Эта команда, осуществима только в Linux:

  • -o Указывает байт смещения образа файловой системы в файле. Она должна быть использована с файлом образа диска.


Формат файла DISPLAY

DISPLAY и файлы F1-F12 - текстовые файлы в формате DOS или UNIX.

Плюс к этому, работают следующие специальные коды:

Экран и Курсор:

Очистить экран, поместить курсор в начало:

<FF> <FF> = <Ctrl-L> = ASCII 12

NB! Экран заполняется текущим фоновым цветом:

Установка цветов фона и переднего плана:

<SI><bg><fg> <SI> = <Ctrl-O> = ASCII 15

Где <bg> и <fg> - шестнадцатеричные цифры,
подходящие под атрибуты экрана стандартного PC:

0 = чёрный
1 = тёмно-синий
2 = тёмно-зелёный
3 = темно-бирюзовый
4 = темно-красный
5 = темно-фиолетовый
6 = коричневый
7 = светло-серый;
8 = темно-серый
9 = ярко-синий
a = ярко-зеленый
b = ярко-бирюзовый
c = ярко-красный
d = ярко-фиолетовый
e = жёлтый
f = белый

При выборе яркого цвета (8-f) для фона получается тёмный цвет фона (0-7) с мигающими буквами.

Пример файла color.txt:

# xxd color.txt
0000000: 0f39 6542 6c69 6e6b 696e 6720 5965 6c6c
0000010: 6f77 206f 6e20 426c 7565 2042 6163 6b67
0000020: 726f 756e 640a

Мигание жёлтым на синем фоне.

Отображение графики:

<CAN>имя_файла<newline> <CAN> = <Ctrl-X> = ASCII 24

Если доступен VGA, перейти в графический режим и показать картинку из указанного файла.
Формат файла - LSS16;
Perl программу - "ppmtolss16" можно использовать для получения таких файлов.

Картинка показана в режиме 640x480 16 цветов.
В графическом режиме цвета фона и текста (указанные кодом <SI>) работают по-другому:
фоновый цвет игнорируется, а цвет текста берётся из палитры картинки.
Таким образом, ppmtolss16 даёт возможность использовать цвета, отличающиеся от стандартных.

Цветовые индексы 0 и 7, следует выбирать с осторожностью, т.к 0 - это цвет фона, а 7 - цвет текста используемый Syslinux.

Возвращение в текстовый режим:

<EM> <EM> = <Ctrl-Y> = ASCII 25

Если мы в графическом режиме, вернуться в текстовый:

<DLE>..<ETB> <Ctrl-P>..<Ctrl-W> = ASCII 16-23

Эти коды могут быть использованы для указания сообщений, печатаемых в разных режимах:

Символ                       Текст.    Графич.   Консоль
------------------------------------------------------
<DLE> = <Ctrl-P> = ASCII 16     No      No      No
<DC1> = <Ctrl-Q> = ASCII 17     Yes     No      No
<DC2> = <Ctrl-R> = ASCII 18     No      Yes     No
<DC3> = <Ctrl-S> = ASCII 19     Yes     Yes     No
<DC4> = <Ctrl-T> = ASCII 20     No      No      Yes
<NAK> = <Ctrl-U> = ASCII 21     Yes     No      Yes
<SYN> = <Ctrl-V> = ASCII 22     No      Yes     Yes
<ETB> = <Ctrl-W> = ASCII 23     Yes     Yes     Yes

Например:

<DC1>Текстовый режим<DC2>Графический режим<DC4>Последовательный порт<ETB>

... напишет, в каком режиме работает консоль!

Конец файла (DOS):

<SUB> <SUB> = <Ctrl-Z> = ASCII 26

Издать звук PC-Speaker'ом (Пищать):

<BEL> <BEL> = <Ctrl-G> = ASCII 7


Пример

Давайте рассмотрим здесь пример создания Мультизагрузочной флешки на основе Syslinux.
Начнём сначала и сделаем всё по порядку.

Подготовка к Установке

1. Для начала скачаем весь комплект Syslinux

2. Пока скачивается, форматируем флешку программой HPUSBFW в файловую систему FAT 32
(или FAT 16 если флешка 2 Gb)

Установка

3. Допустим вы работаете в Среде Windows. Если так, то рассмотрим установку Syslinux в этой ОС.

Опишем всё пошагово:

3.1 Распакуйте скачанный архив и найдите папку win32, скопируйте её в корень диска C:\

3.2 Запустите Консоль. Пуск => Выполнить => Пишите в поле cmd нажимаете Enter. Появится Консоль Windows. (чёрное окно)

3.3 Пишите в Консоли: cd c:\win32 затем Enter. Далее пишите команду установки: syslinux.exe -ma x:
Где х - буква вашей флешки (посмотрите в "Мой Компьютер") Этой командой вы установили Syslinux на флешку,
но этого для полноценной работы ещё не достаточно.

3.4 Создаём папки и файлы как это показано ниже:

boot\syslinux - Помещаем туда файл syslinux.cfg

boot\syslinux\fonts - помещаем туда файл шрифта 866_8x16.psf

boot\syslinux\modules - Найдите в комплекте Syslinux файл vesamenu.c32 и положите его сюда.

В папку boot\syslinux\images помещаем картинку которая станет фоном при загрузке с флешки.
Формат её должен быть *.png 640x480 например makabe.png

Можно считать, что установка загрузчика завершена, теперь нужно наполнить флешку содержимым
и отобразить его запуск в конфигурационном файле syslinux.cfg

Не будем здесь углубляться во все тонкости настроек файла syslinux.cfg, изучите тот, что здесь прикреплён
и многое вам станет понятно, например вы поймёте как устанавливается таймер, картинка, файл шрифта и.т.д
некоторые места в этом файле снабжены комментариями.

Уделим внимание загрузке 3х различных сред, - DOS, Linux, Windows.

4. В следующих действиях нам нужно будет редактировать файл syslinux.cfg, чтобы делать это в Windows
используйте редактор Notepad++. Для корректного отображения Русских букв используйте кодировку:
Кириллица OEM 866.

Загрузка DOS Систем

5. ДОС Системы обычно *.IMA или *.VFD файлы, это образы загрузочных дискет.
Стоит заметить, что в таком образе может быть не только ДОС (Дисковая Операционная Система),
но и другие менее популярные ОС (Например Колибри)

При загрузке таких вещей нам не обойтись без файла memdisk, найдите его в комплекте и поместите в папку /boot

Поместите на флешку нужный образ - /boot/dos/dos.ima

Пункт запуска в конфигурационном файле будет выглядеть вот так:

LABEL -
MENU LABEL MS DOS
KERNEL /boot/memdisk
APPEND initrd=/boot/dos/dos.ima
TEXT HELP
В место этого текста, вставьте описание пункта загрузки.
ENDTEXT

Добавляем Linux

6. Linux системы. Большинство таких систем запускаются через 2 основных файла - vmlinuz и initrd.

vmlinuz - ядро системы.

initrd - диск в оперативной памяти для начальной инициализации.

К примеру добавим на флешку PuppyRus.

Файл pup_ХХХХ.sfs вомещаем в корень флешки, а все остальные файлы складываем в /boot/puppy.

Добавляем в syslinux.cfg пункт загрузки:

LABEL -
MENU LABEL PuppyRus
KERNEL /boot/Puppy/vmlinuz
APPEND ramdisk_size=100000 initrd=/boot/Puppy/initrd.gz
TEXT HELP
Вместо этого текста, вставьте описание пункта загрузки.
ENDTEXT

Windows Системы.

7. Здесь дело обстоит немного сложнее и может возникнуть больше отказов, чем в предыдущих вариантах.

Поместите на флешку дистрибутив какого-нибудь BartPE или XPE.
Эти дистрибутивы загружаются через файл setupldr.bin или peldr с использованием модуля chain.c32
и указанием диска hd0 1.

Файл chain.c32 берём из комплекта и помещаем в /boot/syslinux/modules

В syslinux.cfg пишем:

LABEL -
MENU BartPE
KERNEL /boot/syslinux/modules/chain.c32 hd0 1 ntldr=/minitn/setupldr.bin
TEXT HELP
В место этого текста, вставьте описание пункта загрузки.
ENDTEXT

Мультизагрузочная флешка на основе Syslinux готова.

Спасибо за внимание и Успехов вам в дальнейших экспериментах :-)

Оглавление Предыдущая Проект GreenFlash Форум


Установка Syslinux

Опишем установку в разных ОС

Установка в среде NT/2K/XP

Используйте "syslinux.exe" (в папке win32) для WinNT/2000/XP.
В инсталляторах для DOS и Windows можно использовать опции -m и -a для жёстких дисков, чтобы записать Master Boot Record (MBR) или сделать раздел "активным".

Синтаксис установки

  • syslinux.exe [-sfmar] [-d папка] : [файл с загрузочным сектором]

Установка на Floppy

  • syslinux.exe a:

Установка на: Жёсткий диск или Флешку. Z - это буква диска.

  • syslinux.exe -m -a -d /boot/syslinux z:

*В приведенном выше примере syslinux.cfg должен быть в z:\boot\syslinux

Примечание: В среде NT/2K вы можете получить сообщение о невыполненной установке и будет предложен выбор
Abort/Retry/Ignore. Выбор Ignore корректно завершает программу.

Установка в среде DOS

Используйте "syslinux.com" (в папке dos) для "чистого" DOS (MS-DOS, DR-DOS, PC-DOS, FreeDOS...) или Win9x/ME.

Синтаксис установки

  • syslinux.com [-sfmar] [-d папка] : [файл с загрузочным сектором]

Пример

  • syslinux.com a:

Установка в Linux

Чтобы создать загружаемую дискету Linux с использованием Syslinux, подготовьте обычную форматированную MS-DOS дискету. Скопируйте один или несколько файлов ядра Linux и выполните команду:

  • syslinux [-sfrma] [-d папка] a: [файл с загрузочным сектором]

(вместо a: поставьте букву своей дискеты; [] означает необязательный параметр.)

Пример

  • syslinux [-sfr] [-d папка] [-o offset] /dev/fd0

(опять же, замените /dev/fd0 на файл Вашей дискеты)

Эта команда создаст на дискете загрузочный сектор и скопирует Ldlinux.sys в корень дискеты (или в поддиректорию, если указан параметр -d.)

Параметр даст Вам "безопасную, медленную и тупую" версию SYSLINUX. Она может заработать на очень тупых BIOS'ах, на которых обычная версия загрузчика может не заработать. Если Вы найдёте компьютер, для загрузки которого необходима опция -s, пожалуйста, отправьте нам максимально возможное количество информации о нём и включите код ошибки.

Опция -o используется для образов жёстких дисков и используется для указания смещения, на котором находится файловая система.

При загрузке, по умолчанию, ядро будет загружено из файла с именем LINUX на загрузочной дискете. Это может быть изменено, см. раздел конфигурационного файла.

Если при загрузке нажаты клавиши Shift или Alt, или включён Caps или Scroll lock, Syslinux покажет командную строку "boot:". Пользователь может написать туда имя ядра и его параметры. Файл ядра должен быть расположен в корне загрузочного устройства.

Существует две версии установщика syslinux для Linux; одна в папке "mtools" и не требует никаких привилегий (кроме права на запись на целевое устройство) но зависит от программы mtools, другая в папке "unix" и требует права root'а.

Copyright GeenFlash (c) 2007-2008


Введение

На протяжении всего руководства любой текст с (зелёным) (например C:\syslinux), представляет собой файл и / или путь. Он может также указать папку, которая должна быть создана.

Любой текст выделенный вот так (жёлтым) (например syslinux -sfrma a:), является командой.

Набор Syslinux содержит следующие загрузчики ("derivatives"), каждый ориентирован на определённый загрузочный носитель:

SYSLINUX - файловая система MS-DOS/Windows FAT
PXELINUX - сетевая загрузка через PXE
ISOLINUX - ISO9660 CD-ROM
EXTLINUX - Файловая система Linux ext2/ext3

По историческим причинам некоторые части этого документа применимы только к загрузчику FAT (Syslinux);
см. pxelinux.txt, isolinux.txt и extlinux.txt для более подробной информации. Термин "Syslinux" относится к FAT загрузчику, а "Syslinux" - к проекту в целом.

Оглавление Следующая Проект GreenFlash Форум


Использование Syslinux

Сочетание клавиш

Командная строка поддерживает следующие сочетания клавиш:

<Enter>
<BackSpace>
<Ctrl-U>
<Ctrl-V>
<Ctrl-W>
<Ctrl-X>
<Tab>
<F1>..<F12>
<Ctrl-F><digit>
<Ctrl-C>
<Esc>
<Ctrl-N>
выполнить указанную команду
стереть один символ
стереть строку целиком
показать версию Syslinux
стереть одно слово
перейти в текстовый режим
показать подходящие LABEL
показать файлы (если настроено)
аналогично F1..F10
прервать загрузку
прервать загрузку
показать информацию о сети (PXELINUX only)

Программы COMBOOT IMAGES и другие операционные системы

Эта версия Syslinux поддерживает загрузку других операционных систем
(в частности, MS-DOS и его варианты, включая Windows 95/98),
как и COMBOOT исполняемые файлы (подвид DOS *.COM файлов; см. ниже)

Для определения типа файла Syslinux пользуется его расширением.
Следующие расширения/форматы файлов поддерживаются (нечувствительно к регистру):

другое
.0
.bin
.bs
.bss
.c32
.cbt
.com
.img
Linux kernel image
программа PXE (NBP) [только PXELINUX]
"загрузочный сектор CD" [только ISOLINUX]
Загрузочный сектор [только SYSLINUX]
Загрузочный сектор, DOS superblock will be patched in [SYSLINUX]
программа COM32 (32-bit COMBOOT)
программа COMBOOT (не запускаемая под DOS)
программа COMBOOT (запускаемая под DOS)
Образ диска [только ISOLINUX; для SYSLINUX см. memdisk]

Для введённого в командную строку имени файла Syslinux будет искать файл,
добавляя к имени расширения в порядке, указанном выше, если сам файл не найден.

Если используется директива LINUX, BOOT, BSS, FDIMAGE, COMBOOT, COM32, или CONFIG
вместо KERNEL, тип файла не определяется по расширению.

COMBOOT

Syslinux поддерживает небольшие отдельные программы, используя формат файлов, аналогичный
DOS'овским "*.com" файлам. Их 32-битная версия называется COM32 и тоже поддерживается.
Простой API даёт доступ к ограниченному набору функций файловой системы и консоли.

Подробнее см. comboot.txt (техническая информация).

Защита от Дурака

Syslinux при загрузке определяет машины, на которых слишком мало памяти, где загрузка Linux невозможна.
Если это случилось, выводится сообщение об ошибке и загрузка прерывается.
Если держать нажатым клавишу Ctrl, эта функция отключается.

Любой файл, используемый Syslinux`ом, может быть помечен скрытым, системным или "только для чтения"; Syslinux игнорирует любые атрибуты.

Автоматически установленный Syslinux устанавливает атрибуты readonly/hidden/system на файл LDLINUX.SYS.

Загрузка с раздела жёсткого диска

Syslinux может загружаться с файловой системы FAT на разделе жёсткого диска (включая FAT32).
Процедура установки идентична установке на дискету и должна работать из-под DOS или Linux.
Для того, чтобы загрузиться, Syslinux должен быть запущен из MBR или другого загрузчика.

Из-под DOS вы можете установить стандартную MBR на первый жёсткий диск,
выполнив эту команду:

FDISK /MBR

После этого используйте FDISK для включения флага "active" на нужном разделе.

Простая MBR, почти совпадающая с DOS'овской (но несколько менее усложнённая), включена в комплект Syslinux.
Для установки из-под Linux, введите [с правами root - прим. перев.]:

cat mbr.bin > /dev/XXX

... где /dev/XXX есть целевое устройство.

Из-под DOS или Win32 можно установить Syslinux MBR с помощью опции -m,
переданной установщику Syslinux, и использовать опцию -a для того, чтобы поставить на текущем разделе флаг "active":

syslinux -ma c:

Эта команда также установит Syslinux на данный раздел.


Русскоязычное руководство по загрузчику Syslinux

Руководство по Syslinux

Добро пожаловать в руководство по Syslinux на Русском языке (Version 1.0 от 15.02.2010).

SYSLINUX Project - это целый набор загрузчиков, но в этом руководстве мы заострим внимание на одном из них.

Если вы заметите неточности перевода, ошибки или опечатки, пожалуйста отправьте их копию используя
форму обратной связи.

Если вам есть, что добавить к этому руководству (примеры, дополнения) - связывайтесь с нами.

Благодарим - Sh1td0wn, за перевод, тестирование и помощь людям.

Содержание

  • Введение
  • Параметры командной строки
  • Установка Syslinux
    • Установка в среде NT/2K/XP
    • Установка в DOS
    • Установка в Linux
  • Конфигурационный файл
    • INCLUDE имя_файла
    • DEFAULT ядро параметры
    • UI модуль параметры
    • APPEND параметры
    • LABEL
    • INITRD файл initrd
    • IMPLICIT значение
    • ALLOWOPTIONS значение
    • TIMEOUT время
    • TOTALTIMEOUT время
    • ONTIMEOUT ядро параметры
    • ONERROR ядро параметры
    • CONSOLE значение
    • FONT имя_файла
    • KBDMAP имя_файла
    • DISPLAY имя_файла
    • SAY текст
    • PROMPT значение
    • NOESCAPE значение
    • NOCOMPLETE значение
    • F[1-12] имя_файла

  • Формат файла DISPLAY
    • Экран и Курсор
    • Отображение графики
    • Возвращение в текстовый режим
    • Конец файла
    • Издать звук

  • Пример создания Мультизагрузочной флешки