Введение в R-Studio

R-Studio это группа надежных, эффективных и рентабельных утилит для восстановления данных с жестких дисков, а также других устройств - таких, как CD, DVD, дискет, USB дисков, ZIP дисков и устройств флеш-памяти (Compact Flash Card, Memory Sticks). Основанная на новейшей уникальной технологии анализа информации на носителе и обработки данных, R-Studio является наиболее исчерпывающим программным решением из доступных на рынке утилит восстановления для файловых систем FAT12/16/32, NTFS, NTFS5 (созданных или изменненых в Windows 2000/XP/2003/Vista/Windows 7), HFS/HFS+ (Macintosh), Ext2/3/4FS (файловые системы LINUX), а также разделов UFS1/UFS2 (Little and Big Endian variants, файловые системы FreeBSD/OpenBSD/NetBSD/Solaris) и exFAT. Программа функционирует как на локальных, так и на удаленных компьютерах по сети, даже если разделы дисков были форматированы, повреждены или удалены. Удобный в установке параметров интерфейс программы дает пользователю абсолютный контроль над процессом восстановления данных.

Возможности R-Studio

Контакты и Техническая Поддержка

Восстановление Данных при помощи R-Studio

Восстановление Данных. Основные Операции

Восстановление Данных. Дополнительные Операции

Массовое Восстановление Файлов

Наборы Томов и RAID

Восстановление Данных по Сети

Текстовый/шестнадцатиричный Редактор

Техническая Информация

R-Studio Emergency

R-Studio Agent Emergency


Возможности R-Studio

R-Studio это семейство утилит для восстановления файлов. Программа функционирует как на локальных, так и на удаленных компьютерах по сети, даже если разделы дисков были форматированы, повреждены или удалены. Уникальная технология сканирования IntelligentScan и удобный в установке параметров интерфейс программы дают пользователю абсолютный контроль над процессом восстановления данных.

Возможности R-Studio:

· Стандартный пользовательский интерфейс "Windows Explorer".
· Операционная система (ОС) хоста: Windows 9x, ME, NT, 2000, XP, 2003, Vista, 2008, Windows 7.
· Восстановление данных по сети. Файлы могут быть восстановлены по сети с удаленных компьютеров, на которых установлены ОС Win95/98/ME/NT/2000/XP/2003/Vista/Windows 7, Macintosh, Linux и UNIX.
· Поддерживаемые файловые системы: FAT12, FAT16, FAT32, NTFS, NTFS5 (созданных или измененных в Win2000 или XP), exFAT, Ext2/3/4FS (созданных Linux или другими ОС), HFS, HFS+, HFSX и UFS1, UFS2, UFS BigEndian (используемых ОС FreeBSD, OpenBSD и NetBSD) и exFAT.

Обратите внимание, если файл удален на файловых системах HFS, HFS+, HFSX , то будет удалена и вся системная информация о данном файле; найти и восстановить его можно только проведя Поиск Файлов Известных Типов. Тем не менее R-Studio способна прочесть существующие файлы на дисках HFS, HFS+ и HFSX.

· Поддержка файлов известных типов. R-Studio производит поиск файлов известных типов используя типовые характеристики их структур, что позволяет пользователю восстановить файлы с устройств, где файловая система неизвестна: HD, CD, DVD, дискет, Compact Flash Card, USB дисков, ZIP дисков и устройств флеш-памяти (Compact Flash Card, Memory Sticks).
· Визуализация процесса сканирования. В процессе сканирования объекта R-Studio графически отображает найденную информацию, включая файлы известных типов, FAT и NTFS MFT записи, записи загрузки и т.п.
· Поддержка Массового восстановления файлов.
· Создание списков файлов на восстановление - списки найденных на диске файлов, которые можно экспортировать из R-Studio, редактировать вручную, затем импортировать обратно, и эти файлы будут автоматически помечены для восстановления.
· Поддержка Динамических дисков.
· Поддержка программных RAID, наборов томов и чередующихся томов. Поддержка схем RAID6, RAID5 и RAID4. Поддержка пользовательских схем RAID. Возможно явно указать такие параметры, как размер и порядок блока, смещение и даже число чередующихся блоков. Сохранение пользовательских конфигураций RAID.
· Проверка целостности данных RAID'а (можно проверить правильность блоков четности на RAID'е).
· Поддержка аппаратных RAID, наборов томов и чередующихся томов .
· Создание Файла-образа для целого Физического Диска (HD), Раздела или его части. Такие файлы образов диска могут обрабатываться программой как обычный диск. Возможны два вида образов: 1) Образы, являющиеся точной побайтовой копией объекта (Несжатые образы) - такие образы совместимы с предыдущими версиями R-Studio; 2) Сжатые образы - могут быть сжаты, разбиты на несколько файлов и защищены паролем. Такие образы полностью совместимы с образами, создаваемыми програмой R-Drive Image, но несовместимы с предыдущими версиями R-Studio. Файлы образов можно сохранять на локальном или удаленном компьютере.
· Модуль копирования диска. Возможно побайтное копирование любого объекта панели Диски, а также копирование разделов и жестких дисков.
· Восстановление файлов с поврежденных или удаленных разделов.
· Восстановление сжатых файлов (NTFS, NTFS5).
· Восстановление зашифрованных файлов (NTFS5).
· Восстановление альтернативных потоков данных (NTFS, NTFS5).
· Распознавание локализованных имен.
· Восстановленные файлы могут быть сохранены на любой, включая сетевой, диск доступный локальной операционной системой.
· Файлы или содержимое диска может быть просмотрено и отредактировано с помощью встроенного шестнадцатиричного редактора. Редактор поддерживает редактирование свойств NTFS файлов.
· Шаблоны шестнадцатиричного редактора для анализа файлов и файловых систем. Пользователи могут создавать собственные шаблоны.
· Просмотр содержания файлов. Может быть просмотрено содержание файлов большинства распространенных типов (форматов) для оценки шансов восстановления.
· Расширенные возможности сканирования удаленного хоста. В новой сетевой версии R-Studio данные анализируются на удаленном хосте вместо предварительной загрузки на локальный хост, что резко увеличивает скорость процедуры восстановления с удаленного компьютера. Информацию о сканировании можно сохранять на локальном или удаленном компьютере.
· При восстановлении данных по сети на удаленном компьютере восстановленные файлы могут быть сохранены на другом диске того же самого компьютера. Это полезно в случае, когда на удаленном компьютере имеется исправный диск (например, внешний USB-диск), при этом вам не нужно будет передавать файлы по сети.
· Режим компьютерно-технической (криминалистической) экспертизы (только в версии Technician (Техническая Лицензия)).
· Утилита R-Studio Emergency*. R-Studio Emergency запускается с CD/DVD, комплекта дискет или съемного диска, когда необходимо восстановить данные с компьютера, на котором не загружается Windows по причине повреждения загрузочного раздела или системных файлов.

*R-Studio Emergency является частью программы R-Studio. Когда вы покупаете одну лицензию R-Studio вы можете запустить R-Studio Emergency и инсталлировать программу R-Studio только на одном и том же компьютере, для которого куплена лицензия. Вы не можете переносить лицензию с одного компьютера на другой.

R-Studio восстанавливает файлы:

· Удаленные вне Корзины или когда Корзина была очищена;
· Удаленные вирусной атакой или сбоем питания компьютера;
· После того, как раздел с файлами был переформатирован, даже в раздел с другой файловой системой;
· Когда структура раздела на жестком диске были изменена или повреждена. В этом случае с помощью программы R-Studio можно отсканировать жесткий диск, найти удаленный или поврежденный раздел, а уже потом восстановить данные с найденного раздела.
· С жестких дисков, на которых имеется большое число поврежденных секторов. Программа восстановления R-Studio может сначала скопировать информацию и создать образ целого диска или его части, а уже затем работать с файлом образа, сохраненным на другом носителе, как с оригинальным диском.

При помощи R-Studio можно создавать файл-образ жесткого диска, логического диска или его части. Файлы образов диска могут обрабатываться программой как обычный диск. Образы весьма полезны тогда, когда существует вероятность полной утраты данных вследствие неисправности аппаратной части компьютера. При постоянном появлении на жестком диске неисправных блоков, создание образа диска - единственный способ не допустить полной утраты информации.

Получить дополнительную информацию о технологии сканирования IntelligentScan можно в разделе Технология Сканирования IntelligentScan .


Системные Требования
· Windows 9x/ME/NT4.0/2000/XP/2003/Vista/Windows 7 на Intel совместимой платформе.
· Минимум 32 MB оперативной памяти, мышь и достаточное пространство на диске для сохранения требуемой информации (файлов, образов дисков и т.д.).
· Сетевое соединение для восстановления данных по сети.


Контакты и Техническая Поддержка

Для загрузки последней версии R-Studio посетите:

Официальный Сайт: http://www.r-tt.com

Отдел Продаж: sales@r-tt.com

Специалисты нашей круглосуточной службы технической поддержки R-Studio ответят на ваш запрос в течение ближайших 4 часов.

Техническая поддержка: support@r-tt.com

Запрос технической поддержки: http://www.r-tt.com/SupportRequest.shtml

Форум R-tt: http://forum.r-tt.com/ru


Главное Окно R-Studio

При запуске R-Studio на рабочем столе Windows откроется главное окно (пользовательский интерфейс) программы. Главное окно состоит из нескольких частей. Для получения более подробной информации о каждой из них, нажмите на соответствующую часть главного окна на рисунке.

Connect to RemoteRefresh (Control+R)ScanOpen ImageCreate ImageCreate Region (F4)Create virtual volume sets of RAIDsDelete (F8)Stop (Esc)Open Drive Files (F5)

Изменение языка интерфейса программы

Вы можете выбрать язык интерфейса R-Studio и язык справки. Для этого воспользуйтесь пунктом Язык меню Помощь.

Варианты показа панелей

Вы можете задать, какие панели (вкладки) будут показываться в главном окне.

Для этого выполните следующее:
Панель инструментов | Установите/снимите флажок пункта меню Просмотр/Панель инструментов
Строка состояния | Установите/снимите флажок пункта меню Просмотр/Строка состояния
Панель дисков | Установите/снимите флажок пункта меню Просмотр/Окно дисков
Панель свойств | Установите/снимите флажок пункта меню Просмотр/Окно свойств
Панель Журнала | Установите/снимите флажок пункта меню Просмотр/Журнал
Если в правой части окна (панель свойств) имеются несколько вкладок, то переключиться между ними можно при помощи пунктов меню Просмотр
Закладка свойств | показать вкладку Свойства
Закладка результатов сканирования | показать вкладку Информация о сканировании
Закладка родительских устройств | показать вкладку Родительские объекты
Свойства | Выбор способа представления данных

Иногда на панели Диски присутствует большое количество одинаковых объектов. Например, это могут быть компоненты RAID. Для лучшего отличия данных объектов можно включить показ их индексов (numerical indexes), которые будут показаны слева от названия объекта на панели Диски .

Чтобы включить/отключить показ индексов установить/снимите флажок соответствующего подпункта пункта Устройства меню Просмотр:

Показывать номера физических дисков | показывать индексы только для жестких дисков
Показывать номера всех объектов | показывать индексы для всех объектов панели Диски

Вы можете выбрать единицы, в которых будет отображаться начало и размер объектов.

Чтобы выбрать единицы

1. Выберите пункт Устройства меню Просмотр

2. Выберите единицы, в которых будет отображаться размер объектов.

Вы можете выбрать

Отображать в байтах

Отображать в секторах

Отображать в байтах и секторах

Панели (вкладки) главного окна R-Studio изменяются в зависимости от выполняемой задачи. Они описаны в соответствующих разделах. Параметры и значения параметров вкладки Свойства подробно описаны в разделе Вкладка Свойств.

Общие настройки задаются в диалоговом окне Настройки.

R-Studio работает в двух режимах:

Поиск файлов на существующем разделе (либо на найденном разделе после сканирования диска).

В этом режиме R-Studio анализирует MFT на разделах NTFS, [image] FAT на разделах FAT и SuperBlocks на разделах Ext2FS [image] . После этого программа отображает все файлы, информация о которых была найдена - такие файлы можно восстановить. Если же файлы не найдены, то это означает, что информация о них была удалена. В этом случае необходимо сканировать диск.

Поиск файлов поддерживает маски файлов и регулярные выражения. Возможно восстановление большого числа файлов из различных папок за один раз.

R-Studio поддерживает массовое восстановление файлов. За один раз может быть восстановлено неограниченное число файлов.

Содержание файла может быть просмотрено для оценки шансов восстановления.

Файлы или содержимое диска может быть просмотрено и отредактировано с помощью встроенного шестнадцатиричного редактора. Редактор поддерживает редактирование свойств NTFS файлов.

Сканирование диска, поиск разделов с файлами.

В этом режиме R-Studio сканирует весь диск или его часть. По определенному числу статистических и детерминированных критериев, известных как технология сканирования IntelligentScan, программа определяет имеющиеся и имевшиеся разделы на диске, а также их файловые системы. Вы также можете добавять новые разделы, задав все необходимые параметры.

Диск может быть отсканирован несколько раз, могут быть заданы различные параметры сканирования. R-Studio накапливает информацию о результатах различных процедур сканирования. Информация о сканировании диска может быть сохранена в файл. Затем она может быть загружена и обработана в любое удобное время.


Настройки R-Studio

Общие настройки R-Studio задаются в диалоговом окне Настройки. Для открытия данного диалогового окна выберите пункт Настройки меню Инструменты.

Вкладка Главная

Диалоговое окно Настройки. Вкладка Главная
Главные настройки
Системные Параметры
Разрешить запись | Если установить данный флажок, то R-Studio позволит сохранять любые изменения, сделанные в Текстовом/шестнадцатиричном Редакторе.
Отладочный режим | Если установить данный флажок, то в контекстном меню каждого объекта с файловой системы будет присутствовать дополнительная команда Сохранить состояние файловой системы. Информация о системе это только системные данные файловой системы (описания файлов без их содержимого). При возникновении проблемы данный файл состояния файловой системы может быть послан в службу технической поддержки R-Studio для идентификации проблемы. При установке данного флажка R-Studio будет работать значительно медленнее.
Уведомления
Отображать все предупреждения | При нажатии на данную кнопку будут показываться ранее отключенные предупреждающие сообщения.
Пользовательские типы файлов
Имя файла | Указывает имя и путь к файлу, в котором хранятся описания пользовательских Известных Типов Файлов
Пользовательские конфигурации RAID
Имя файла | Указывает имя и путь к файлу, в котором хранятся описания пользовательских схем RAID
Пользовательские шаблоны к текстовому/шестнадцатиричному редактору
Расположение | Указывает путь к файлам с шаблонами Текстового/шестнадцатиричного Редактора

Вкладка Файловые системы

Диалоговое окно Настройки. Вкладка Файловые системы
Настройки Файловых Систем
Кодировка по умолчанию для томов HFS | Позволяет выбрать национальную кодировку разделов HFS
Кодировка по умолчанию для томов Ext2/Ext3/Ext4/UFS | Позволяет выбрать национальную кодировку разделов Ext2, Ext3, Ext4 и UFS .
Отключить сортировку файлов при отображении | Позволяет отключить сотировку файлов, если она занимает слишком много времени в связи с большим количеством файлов на диске
Минимизировать доступ к диску | Установите данный флажок, если на жестком диске имеется большое количество неисправных секторов. В этом случае будет снижен доступ к внутренним данным файловой системы для ускорения процесса обработки системных данных.
Показывать удаленные пустые каталоги | Установить данный флажок для отображения пустых удаленных папок.

Вкладка Известные типы файлов

Диалоговое окно Настройки. Вкладка Известные типы файлов

Вы можете выбрать, какие типы файлов из списка Известных Типов Файлов будут установлены по умолчанию. Также вы можете задать поиск файлов известных типов для конкретного сеанса сканирования в диалоговом окне Сканировать.

Известные Типы Файлов
Сбросить | Нажмите данную кнопку, чтобы отменить сделанные изменения. Данная кнопка активна до нажатия кнопки Применить .
Выделить все | Нажмите данную кнопку, чтобы выбрать все типы файлов из списка.
Очистить все | Нажмите данную кнопку, чтобы оставить выбранными только предопределенные типы файлов .
Перезагрузить файл определения известных типов файлов | Нажмите данную кнопку, чтобы загрузить из файла, заданного на вкладке Главная, новые или измененные пользовательские известные типы файлов.
Редактировать | Нажмите данную кнопку, чтобы добавить новый пользовательский Известный Тип Файлов или редактировать имеющиеся. Более подробно см. в разделе Добавление Типов Файлов .

Вкладка Журнал

Диалоговое окно Настройки. Вкладка Журнал

Настройки фильтра журнала

Ведение журнала |
Максимальное количество сообщений в журнале | В данном поле задается максимальное число сообщений в журнале.
Сохранить журнал в файл | Если установить данный флажок, то R-Studio сохранит журнал в файл, заданный в поле Имя файла:.
Имя файла | Указывает файл, в который R-Studio сохраняет журнал.
Тип |
Файл | Если установить данный флажок, то R-Studio запишет в журнал все действия с восстановленными файлами.
Файловая система | Если установить данный флажок, то R-Studio запишет в журнал все действия с файловой системой.
Раздел | Если установить данный флажок, то R-Studio запишет в журнал все действия с разделами.
Восстановить | Если установить данный флажок, то R-Studio запишет в журнал все действия по восстановлению.
Диск | Если установить данный флажок, то R-Studio запишет в журнал все действия с дисками.
Сеть | Если установить данный флажок, то R-Studio запишет в журнал все сетевые операции.
Важность |
Ошибка | Если установить данный флажок, то R-Studio запишет в журнал сообщения об ошибках.
Предупреждение | Если установить данный флажок, то R-Studio запишет в журнал предупреждения.
Информация | Если установить данный флажок, то R-Studio запишет в журнал информационные сообщения.
Успешно | Если установить данный флажок, то R-Studio запишет в журнал сообщения об успешном завершении действий.
НИКОГДА НА СОХРАНЯЙТЕ ФАЙЛ ЖУРНАЛА НА ЛОГИЧЕСКИЙ ДИСК, С КОТОРОГО ВЫ ВОССТАНАВЛИВАЕТЕ ДАННЫЕ!!! Это может стать причиной полной утраты данных.
Внимание: Если в диалогом окне Восстановить установлен флажок Не выводить подробную информацию об успешно восстановленный файлах, то в Журнал будут записываться только Ошибки, Предупреждения и Информационные сообщения.

Вкладка Неисправные сектора

Диалоговое окно Настройки. Вкладка Неисправные сектора
Настройки Неисправных секторов

Количество попыток чтения по умолчанию

Значение величины Попыток В/В по умолчанию, определяющее, сколько раз R-Studio будет пытаться прочесть неисправный сектор. Вы можете установить значение данного параметра для каждого диска индивидуально на вкладке Свойства .

Установить для всех дисков

Нажмите данную кнопку, чтобы установить для всех дисков значение величины Попыток В/В по умолчанию.

Образец для заполнения неисправных блоков

Шаблон, которым R-Studio будет заполнять неисправные сектора в восстанавливаемых файлах, образах или при просмотре данных в Текстовом/шестнадцатиричном Редакторе. Данный шаблон может быть задан в форматах данных ANSI или Hex (Шестн.).

Внимание: R-Studio никогда не модифицирует что-либо на диске, с которого восстанавливаются данные или образ которого создается.

Вкладка Использование памяти

Диалоговое окно Настройки. Вкладка Использование памяти

Данные настройки позволяют управлять используемой R-Studio памятью при выполнении задач по восстановлению данных. Их использование предотвращает возможные зависания R-Studio при выполнении задач, требующих огромного количества ресурсов (например, при сканировании дисков большого объема или при обработке файловых систем с большим количеством файлов).

Настройки Использования памяти
Отключить контроль памяти | Если выбрать данный параметр, то контроль памяти будет отключен.
Автоматически | Если выбрать данный параметр, то выполнение задачи R-Studio будет автоматически приостановлено, если приложению потребуется больше установленного лимита памяти. Можно задать лимит виртуальной или физической памяти.

Вы можете посмотреть сколько памяти использует R-Studio в диалоговом окне Использование памяти .


Восстановление Данных при помощи R-Studio

В зависимости от ситуации, восстанавливать данные следует одним из нескольких способов:

1. Восстановление удаленных файлов, которые находились на существующем логическом диске

Для этого случая смотри раздел Восстановления Данных. Основные Операции.

2. Восстановление файлов, расположенных на диске с поврежденной файловой системой или на ранее удаленных или переформатированных разделах

Если файловая система логического диска повреждена, то операционная система не покажет такой диск как раздел. Поэтому сначала необходимо сканировать диск. Также необходимо сканировать диск при восстановлении данных с ранее удаленных или переформатированных разделов.

При сканировании будет найдено некоторое число найденных разделов (Recognized). R-Studio покажет такие разделы различным цветом в зависимости от того, какие были найдены элементы разделов.

Существующий логический диск или раздел

На таком разделе были найдены как загрузочные записи, так и файлы

На таком разделе были найдены только файлы

На таком разделе были найдены только загрузочные записи

Свободное пространство объекта

Хотя такие найденные разделы и являются виртуальными объектами, на них можно искать и восстанавливать файлы как на обычных логических дисках, как описано в разделе Восстановление Файлов. Основные Операции.

Для успешного восстановления файлов с найденного раздела необходимо найти такой раздел, который соответствует реальному логическому диску, на котором были расположены файлы. Для этого не существует каких-либо правил, однако необходимо принять во внимание следующее:

· Если вам нужно восстановить файлы с диска с поврежденной файловой системой, то скорее всего нужный вам раздел будет зеленого цвета.
· Если вы хотите восстановить файлы с ранее удаленного или переформатированного раздела, то скорее всего нужный вам раздел будет желтого цвета.

Также обязательно проверьте файловую систему, начало и размер найденного раздела. Они должны совпадать с файловой системой, началом и размером реального логического диска/раздела. Если вы точно не уверены, то попробуйте просмотреть пару файлов с найденного раздела. Если файлы откроются и у них будет корректное содержание, то это правильный раздел.

3. Восстановление данных с поврежденного системного диска. Не загружается компьютер.
· Если компьютер находится в сети, то создайти загрузочный диск R-Studio Agent Emergency , инсталлируйте R-Studio на другом компьютере и восстановите данные по сети.
· Если компьютер не связан с другими компьютерами в сети, то создайте загрузочный диск R-Studio Emergency , загрузите с него компьютер и восстановите данные. Для сохранения восстановленных файлов можно использовать внешний USB диск.

Возможности R-Studio Features

Контакты и Техническая Поддержка

Восстановление Данных. Основные Операции

Восстановление Данных. Дополнительные Операции

Массовое Восстановление Файлов

Наборы Томов и RAID

Восстановление Данных по Сети

Текстовый/шестнадцатиричный Редактор

Техническая Информация

R-Studio Emergency

R-Studio Agent Emergency


Восстановление Данных. Основные Операции

НИКОГДА НЕ СОХРАНЯЙТЕ ВОССТАНАВЛИВАЕМЫЕ ФАЙЛЫ/ПАПКИ НА ОРИГИНАЛЬНЫЙ ДИСК!!!

Это может стать причиной полной утраты данных.

Более подробно смотри в разделе Особенности Восстановления Данных.

Основные операции по восстановлению данных применимы к удаленным файлам, которые были расположены на существующих логических дисках доступных локальной ОС. Для других случаев смотри раздел Восстановление Данных. Дополнительные Операции.

Для восстановления удаленных файлов с логического диска (найденного раздела):

1 Дважды щелкните левой кнопкой мыши по логическому диску на панели Диски R-Studio, чтобы перечитать файлы диска

Другие способы перечитать файлы

· Выберите диск и нажмите кнопку Показать содержимое диска,

или

· Щелкните правой кнопкой мыши по диску и выберите пункт контекстного меню Показать содержимое диска

или

· Выберите диск и нажмите клавишу F5

или

· Выберите пункт Показать содержимое диска меню Диск

При попытке перечитать файлы жесткого диска или другого объекта без определенной файловой системы появится сообщение Дважды щелкните левой кнопкой мыши по логическому диску... Выберите логический диск объекта или отсканируйте объект.

> Панели R-Studio изменятся и будет показана структура папок/файлов диска

R-Studio анализирует данные объекта и отображает все файлы, информация о которых была найдена. Если же файлы не найдены, то это означает, что информация о них была удалена. Для более подробной информации о восстановлении таких файлов смотри раздел Восстановление Данных. Дополнительные Операции.

Обратите внимание, что R-Studio показывает только те файлы/папки, которые соответствуют заданной маске файлов.

Главное окно R-Studio

Нажмите на область окна для получения более подробной информации.

Back (Select Drive)Reopen Drive FilesRecoverRecover MarkedFindFind NextFind PreviousFile MaskUpStop (Esc)Preview (Control+Q)

Варианты показа панелей

Вы можете задать, какие панели (вкладки) будут показываться в главном окне. Для этого выполните следующие действия

Панель инструментов

Установите/снимите флажок Панель инструментов меню Просмотр

Панель состояния

Установите/снимите флажок Строка состояния меню Просмотр

Панель Папки

Установите/снимите флажок Окно структуры меню Просмотр

Панель Содержимое

Установите/снимите флажок Окно содержимого меню Просмотр

Панель Журнал

Установите/снимите флажок Журнал меню Просмотр

Панель Результаты поиска

Установите/снимите флажок Результаты поиска меню Просмотр

Вы можете сортировать данные желаемым образом. В меню Просмотр выберите пункт Упорядочить и далее желаемую сортировку данных.

Вы также можете задать, какие колонки будут показаны на панели Содержимое. Для этого выберите соответствующие колонки в пункте Колонка содержимого меню Просмотр.

На панели Журнал будет показано, сколько файлов и папок имеются в данном объекте и их размер. В фильтре журнала вы можете задать, какие типы событий будут отображаться в панели журнала.

Обратите внимание: Метафайлы это внутренние системные файлы (данные файловой системы), невидимые пользователем, которые R-Studio показывает как файлы. Такие файлы не содержат данные пользователя и используются только при восстановлении файловой системы диска.

При появлении сообщения Too many files... вы можете временно прекратить вывод файлов и просмотреть найденные файлы. Затем вы можете продолжить вывод файлов. Вы также можете продолжить вывод файлов без просмотра. R-Studio сохранит информацию о внутренней структуре файла.

2 Выберите файл/папку для восстановления

Вы можете выбрать несколько файлов/папок в одной родительской папке удерживая при выборе объектов клавишу Shift .

Пометить файлы/папки в различных родительских папках:

Пометьте файл/папку, установив слева флажок или выбрав пункт Отметить контекстного меню. Вы можете пометить насколько файлов/папок в различных родительских папках. Вы можете пометить все объекты в папке, выбрав пункт Отметить все меню Инструменты или контекстного меню. Для снятия пометки снимите флажок слева от объекта или выберите пункт Снять пометки контекстного меню. Вы можете снять пометку со всех объектов в папке, выбрав пункт Снять все пометки меню Инструменты или контекстного меню.

На панели Журнал будет показано, сколько помечено файлов и папок и их общий размер.

R-Studio позволяет найти определенный файл. Более подробно смотри в разделе Поиск Файла . Если вам необходимо за раз найти и пометить большое число файлов, то смотрите раздел Найти и Пометить Множественные Файлы.

Содержание файла может быть просмотрено для оценки шансов восстановления. Более подробно смотри в разделе Просмотр Файлов .

Если файлы, которые вы хотите восстановить, не найдены:

Иногда R-Studio находит файлы, но не может найти полный путь к ним. Такие файлы будут находиться в папке Дополнительно Найденные Файлы - попробуйте произвести поиск необходимых файлов в этой папке. Если же это не поможет, то попробуйте произвести поиск файлов на всем диске. Более подробно смотри в разделе Поиск Файла.

Если вы не нашли файлы, которые хотите восстановить, но знаете, что они находились на логическом диске, то смотрите раздел Восстановление Данных. Дополнительные Операции .

3 Нажмите кнопку Восстановить или Восстановить помеченные

Другие способы восстановить выбранные файлы

· Щелкните правой кнопкой мыши по выбранному файлу/папке и выберите пункт контекстного меню Восстановить или Восстановить помеченные

или

· Выберите пункт Восстановить или Восстановить помеченные меню Файл

или

· Нажмите клавишу F2.
4 Задайте параметры восстановления и папку для сохранения восстановленных файлов в диалоговом окне Восстановить и нажмите кнопку Да
Диалоговое окно Восстановить

Параметры восстановления

Не выводить подробную информацию о успешно восстановленных файлах

Если установить данный флажок, то R-Studio будет записывать в Журнал только ошибки и предупреждения.

Восстановить структуру папкок

Если установить данный флажок, то R-Studio восстановит полный путь к выбранному объекту.

Восстанавливать путь от корневой директории

Если установить данный флажок, то R-Studio восстановит полный путь к выбранному объекту от корневой папки диска.

Восстанавливать метафайлы

Если установить данный флажок, то R-Studio восстановит метафайлы диска. Метафайлы это внутренние скрытые системные файлы, которые R-Studio показывает как файлы. Такие файлы не содержат данные пользователя и используются только при восстановлении файловой системы диска.

Восстанавливать альтернативные потоки данных

Если установить данный флажок, то R-Studio восстановит альтернативные потоки данных для файлов NTFS . Данный флажок не влияет на восстановление файлов FAT. Для более подробной информации смотри раздел Восстановление Дополнительной Информации.

Восстанавливать атрибуты безопасности

Если установить данный флажок, то R-Studio восстановит атрибуты безопасности для файлов NTFS . Данный флажок не влияет на восстановление файлов FAT. Для более подробной информации смотри раздел Восстановление Дополнительной Информации.

Восстанавливать расширенные атрибуты

Если установить данный флажок, то R-Studio восстановит дополнительные (HPFS) атрибуты файлов.

Восстанавливать реальную структуру папок

Данный флажок применим только тогда, когда файлы сортированы по расширениям или дате. Для более подробной информации смотри раздел Найти и Пометить Множественные Файлы. Если установить данный флажок, то R-Studio восстановит подлинную структуру папок/файлов на диске для сортированных таким образом файлов.

Пропускать файлы с неисправными секторами

Если установить данный флажок, то R-Studio пропустит при восстановление файлы с неисправными секторами и отобразит их список в диалоговом окне Файлы с неисправными секторами после завершения процесса восстановления. Далее вы сами можете решить, как поступать с данными файлами. Для более подробной информации смотри раздел Неисправные сектора.

Если данный флажок не установлен, то R-Studio пытается прочесть данные сектора несколько раз (число раз задается в диалоговом окне Настройки/Неисправные сектора) и если прочесть данные сектора не удается, то заполняет их образцом, который задается в том же окне. Информация о таких файлах будет отображена в Журнале.

Игнорировать файловую маску

Если установить данный флажок, то R-Studio восстановит все содержимое выбранной папки, игнорируя заданную Маску Файла.

Дополнительно

Задаются параметры для массового восстановления файлов

Если вы хотите восстановить большое число файлов за один раз, то для более подробной информации смотрите раздел Восстановление Множественных Файлов

НИКОГДА НЕ СОХРАНЯЙТЕ ВОССТАНАВЛИВАЕМЫЕ ФАЙЛЫ/ПАПКИ НА ОРИГИНАЛЬНЫЙ ДИСК!!!

Это может стать причиной полной утраты данных.

Если у восстановленного файла неверное имя, по появится диалоговое окно Поврежденное имя файла . Вы можете исправить имя и продолжить восстановление файла.

Диалоговое окно Поврежденное имя файла

Параметры диалогового окна Поврежденное имя файла

Имя файла | Показывает текущее поврежденное имя файла.
Новое Имя | Поле для нового имени файла.
Изменять только неверные символы | Если установить данный флажок, то редактировать можно будет только неверные символы
Изменить все неверные символы на | Если установить данный флажок, то все неверные символы будут изменены на символы, заданные в соответствующем поле
Кнопки
Переименовать | Нажмите эту кнопку, чтобы возобновить восстановление файлов
Переименовать все | Нажмите эту кнопку, чтобы возобновить восстановление файлов. Все другие файлы будут переименованы в соответствие с установленным правилом.
Пропустить | Нажмите эту кнопку, чтобы пропустить данный файл
Пропустить все | Нажмите эту кнопку, чтобы пропустить все файлы и остановить процесс восстановления

Если на диске будет недостаточно места для сохранения восстановленных файлов, то появится диалоговое окно Недостаточно места на диске . Вы можете выбрать другое место для сохранения файлов, пропустить данный файл или прервать процесс восстановления.

Диалоговое окно Недостаточно места на диске
> R-Studio восстанавливает выбранные/помеченные файлы/папки в заданную папку и показывает результаты в панели Журнал

Ход выполнения восстановления (прогресс) и его результаты (Лог) будут показаны в отдельном окне Прогресс восстановления .

Обратите внимание: R-Studio восстанавливает файлы с разделов Ext2/3/4FS , но сохраняет их на локальные диски FAT или NTFS . Также вы можете сохранить такие файлы на сетевые диски. R-Studio успешно восстанавливает файлы с разделов Ext2/3/4FS за исключением их атрибутов безопасности. R-Studio восстанавливает символьные ссылки как файлы, содержащие путь к файлам, на которые имеются ссылки в символьных ссылках.

Смотри раздел Восстановление Данных на Файловых Систем HFS/HFS+ с подробным описанием восстановления данных на дисках с файловыми системами HFS/HFS+.

Просмотр Файлов

Маски Файлов

Регулярные Выражения

Журнал


Поиск Файла

R-Studio может найти заданный файл, если его не удается найти на панелях Папки или Содержимое. Также можно автоматически пометить/снять пометку со всех найденных файлов.

Чтобы найти файл:

1 Нажмите кнопку Найти/Отметить

Другие способы

· Щелкните правой кнопкой мыши по папке и выберите пункт контекстного меню Найти/Отметить

или

· Выберите папку и выберите пункт Найти/Отметить меню Инструменты
2 Задайте файл (файлы), которые необходимо найти, в диалоговом окне Найти/Пометить и нажмите кнопку Да

Обратите внимание, вы можете использовать Маску Файла.

Диалоговое окно Найти/Пометить

Параметры Поиска/Маркировки

Вы можете задать, как обрабатывать введенное для поиска/маркировки выражение. Обратите внимание, что R-Studio сохраняет введенное ранее выражение.

Файлы

В этом случае R-Studio будет искать/помечать все файлы, совпадающие со выражением в поле поиска. Для задания маски файла можно использовать символы со специальным значением: ? - любой символ повторяется один раз и * - любой символ повторяется неограниченное число раз.

Расширения файлов

В этом случае R-Studio будет искать/помечать все файлы с расширением, заданном в поле поиска

Регулярное выражение

В этом случае R-Studio будет искать/помечать все файлы, соответствующие регулярному выражению, заданному в поле поиска

Все файлы

В этом случае R-Studio применит Дополнительные Параметры ко всем файлам.

Параметры

Учитывать регистр

Если установить данный флажок, то R-Studio произведет поиск/маркировку с учетом регистра

Смотреть в

Задает, где R-Studio будет искать и помечать файлы. Искать и помечать файлы можно: на Всем диска, с Текущей папки, в Текущей папке и подпапках и только в Текущей папке. Если выбрано С текущей папки, то можно также задать Направление поиска с текущей позиции в текущей папке.

Удаленные файлы

Если установить данный флажок, то R-Studio произведет поиск среди удаленных файлов/папок.

Существующие файлы

Если установить данный флажок, то R-Studio произведет поиск среди имеющихся файлов/папок.

Режим поиска/пометки

Задает, что R-Studio делает с найденными файлами. Возможно:

Найти все совпадающие файлы. R-Studio ищет все совпадающие файлы. Результаты поиска будут представлены на панели Результаты поиска.

Найти первый совпадающий файл. R-Studio прекратит поиск, найдя первый файл.

Пометить совпадающие файлы. R-Studio пометит все найденные файлы.

Снять пометку с совпадающих файлов. R-Studio снимет пометку со всех найденных файлов.

Обратите внимание, что при выполнение каждой новой задачи по маркировке файлов, R-Studio сохраняет ранее сделанную маркировку. Например, если вы сначала пометили все файлы с расширением doc , а потом все файлы с расширением txt , то все файлы с расширением doc также останутся помеченными. Для снятия с них пометки необходимо еще раз задать файлы с расширением doc и выбрать режим Снять пометку с совпадающих файлов.

Просматривать при поиске

Файлы

Если установить данный флажок, то R-Studio будет искать среди файлов.

Каталоги

Если установить данный флажок, то R-Studio будет искать среди папок.

Направление

Задает направление поиска с текущей позиции. Параметр доступен только тогда, когда параметр Искать имеет значение С текущей папки.

Дополнительные Параметры

Размер от/До

Определяет пределы размеров файлов.

Id файла

Определяет Id, который R-Studio присваивает файлу.

Дата

Определяет временные границы файла. Файлы в заданные даты могут быть Изменены/Созданы/Открыты.
> R-Studio покажет/пометит найденный файл (файлы)

Если вам необходимо найти и пометить большое количество файлов, то более подробную информацию смотрите в разделе Найти и Пометить Множественные Файлы.

Для продолжения поиска

* Нажмите кнопки Найти следующее или Найти предыдущее

Другие способы продолжить поиск

· Щелкните правой кнопкой мыши по папке и выберите пункт контекстного меню Найти следующее или Найти предыдущее

или

· Выберите папку и выберите пункт Найти следующее или Найти предыдущее меню Инструменты

Для поиска всех файлов и показа их в панели Результаты поиска,

* Выберите Найти все совпадающие файлы в диалоговом окне Найти/Пометить

или

выберите пункт Найти все меню Инструменты

> R-Studio покажет найденные файлы в панели Результаты поиска

Найденные файлы из панели Результаты поиска можно:

Восстановить, Пометить, Просмотреть

щелкнув правой кнопкой мыши по найденному файлу и выбрав соответствующий пункт контекстного меню.


Просмотр Файлов

R-Studio имеет встроенный просмотрщик, позволяющий просматривать содержание как существующих, так и удаленных файлов. Вы можете его использовать для оценки шансов восстановления файлов.

Для просмотра содержания файла

1 Щелкните правой кнопкой мыши по файлу на панели Содержимое и выберите пункт контекстного меню Предпросмотр

Другие способы просмотра содержания файла

· Выберите файл на панели Содержимое и нажмите кнопку Предпросмотр

или

· Выберите файл на панели Содержимое и выберите пункт Предпросмотр меню Файл
> R-Studio покажет содержание файла

Если у вас открыто несколько файлов в просмотрщике, вы можете сразу закрыть их всех, выбрав пункт Закрыть все окна предпросмотра меню Файл.

Список поддерживаемых файловых форматов

Файлы MS Office : документы Word и таблицы Excel (должны быть инсталлированы Microsoft Word и Excel ) Video/Audio файлы: должны быть инсталлированы соответствующие программы и кодеки Графические файлы:
Формат | Расширение | Сжатие
Adobe Photoshop Document | psd |
Alias Image | pix als alias |
Amiga IFF | iff blk | Rle
Bob Ray-Tracer | bob |
CALS Raster Goup 1 | cal cals |
Canon PowerShot | crw |
Casio QV-10/100 Camera | cam |
Chinon ES-1000 digital camera | cmt |
Cloe Ray-tracer | clo |
CompuServe GIF | gif giff |
DKB Ray-tracer | dis |
DPX | dpx |
Deluxe Paint, Electronic Arts | lbm |
Digital F/X | tdim graf |
EPS Interchange Format | epi |
Electric Image | ei eidi |
Encapsulated Postscript (Preview) | eps |
Explore (TDI) & Maya | tdi iff |
Gimp Bitmap | xcf |
Gimp Brush | gbr |
Gimp Icon | ico |
Gimp Pattern | pat |
Image Magick | mif miff |
Imaging Fax | g3n |
Intergraph Format | itg cit rle |
Joint Photographic Experts Group | jpg jpeg jif jfif |
Jeff's Image Format | jif |
Kodak Cineon | cin dpx |
Kodak DC120 Digital Camera | kdc |
Kodak DC25 Camera | k25 |
Kodak Photo CD | pcd |
Konica Camera File | kqp |
LucasFilm Format | lff |
MTV Ray-tracer | mtv |
Macintosh Quickdraw/Pict | pic pict pct |
Mayura Draw | pdx |
Multiple Network Graphics | mng |
OS/2 Bitmap | bmp bga | Rle 4 & 8 bits
Open Image Library Format | oil |
PaintShopPro Browser Cache File | jbf |
PaintShopPro Frame | pfr |
PaintShopPro Image | psp |
PaintShopPro Mask | msk |
PaintShopPro Pattern | pat |
PaintShopPro Picture Tube | tub |
PaintShopPro Texture | tex |
Palm Pilot | pdb |
Pegs | pxa pxs |
Photopaint Image | apx |
Picture Gear Pocket | prc |
Pixar picture file | pic pxr picio pixar |
Pixibox | pxb |
Portable Bitmap | pbm rpbm |
Portable Document Format | pdf |
Portable Greyscale | pgm rpgm |
Portable Image | pnm rpnm |
Portable Network Graphics | png |
Portable Pixmap | ppm rppm |
Postscript | ps |
Psion Series 3 | pic |
Psion Series 5 | mbm |
Qrt Ray-tracer | qrt |
Quantel VPB | vpb |
Quicktime Picture | qtif qti |
Rayshade | pic |
Ricoh Digital Camera | j6i |
SciTex Continuous Tone | sct sc |
Seattle Film Works | sfw |
Seattle Film Works multi-image | pwp |
Sega SJ-1 DIGIO | sj1 |
Silicon Graphics RGB | rgb bw iris sgi | Rle
Softimage bitmap | pic si | Rle
Sony DSC-F1 Cyber-shot | pmp |
Sony Playstation TIM PSX | tim |
Sun Icon/Cursor | icon cursor pr |
Sun Raster Images | ras rast sun sr scr rs |
Sun TAAC file format | iff vff suniff taac |
Synthetic Universe | synu syn |
TIFF Revision 6 | tif tim tiff | Rle LZW LZW + Prediction
TrueVision Targa | tga pix bpx vda icb vst | Rle
Utah Raster image | Rle |
Vista | vst |
Vivid Ray-tracer | img |
Wavefront Raster file | rla rlb |
Webshots | wbc wbp wbz |
Winfax | fxs fxo |
Windows & Aldus Metafile | wmf |
Windows Bitmap | bmp rle rl4 rl8 sys | Rle 4 & 8 bits
Windows Clipboard | clp |
Windows Cursor | cur |
Windows DIB | dib |
Windows Enhanced Metafile | emf |
Windows Icon | ico |
Wireless Bitmap (level 0) | wbmp wbm wap |
X11 BitMap | xbm bm |
X11 PixMap | xpm pm |
XV Visual Schnauzer | p7 |
Zsoft Multi-page Paintbrush | dcx |
Zsoft Publisher's Paintbrush | pcx pcc dcx | Rle


Маски Файлов

R-Studio покажет только те файлы/папки, которые будут соответствовать заданной маске файла. Маска файла будет влиять на обработку файлов/папок командами Восстановить и Найти/Отметить.

Чтобы задать маску файла

1 Нажмите кнопку Файловая маска

Другие способы задать маску файла

· Шелкните правой кнопкой мыши по папке и выберите пункт контекстного меню Файловая маска

или

· Выберите папку и выберите пункт Файловая маска меню Инструменты
2 Задайте маску файла в диалоговом окне Определить Файловую Маску и нажмите кнопку Да
Диалоговое окно Определить Файловую Маску

Параметры Маски файла

Параметры маски файла можно задать для Всех файлов, Расширений файлов, Файлов и Регулярных выражений
Учитывать регистр | Если установить данный флажок, то R-Studio произведет поиск с учетом регистра.
Показывать пустые папки | Если установить данный флажок, то R-Studio покажет папки, в которых отсутствуют файлы с заданной маской.
Удаленные файлы | Если установить данный флажок, то R-Studio произведет поиск среди удаленных файлов/папок.
Существующие файлы | Если установить данный флажок, то R-Studio произведет поиск среди имеющихся файлов/папок.
Дополнительные Параметры
Размер от/До | Определяет пределы размеров файлов.
Дата | Определяет временные границы файла. Файлы в заданные даты могут быть Изменены/Созданы/Открыты.
> R-Studio покажет только те файлы, которые совпали с заданными масками файлов


Регулярные Выражения

Регулярные выражения это система обозначений текстовых образцов, сопоставляемых с точными значениями строковых переменных. В регулярных выражениях используются как обычные символы, так и метасимволы. Каждый символ, не имеющий специального значения в синтаксисе регулярных выражений, является обычным символом и сопоставляется с таким же символом анализируемого текстового фрагмента. Например, буквы и цифры являются обычными символами. Метасимвол это символ со специальным значением (оператор или разделитель) в синтаксисе регулярных выражений.

. | Любой символ
* | Повторение: предыдущий символ или класс символов повторяется ноль или большее число раз
^ | Позиция строки: начало строки
$ | Позиция строки: конец строки
[class] | Класс символов: любой набор символов
[^class] | Обратный класс символов: любой набор символов, кроме указанных
[x-y] | Диапазон: любые символы в указанном диапазоне
\x | Исключение: метасимвол x считается обычным символом
\<xyz | Позиция слова: начало слова
xyz\> | Позиция слова: конец слова

Например, регулярное выражение .* обозначает любую строковую переменную, регулярное выражение ^a обозначает любую стоковую переменную с символом a.


Журнал

R-Studio протоколирует и отображает выполненные действия в панели Журнал. Можно задать Фильтр журнала, чтобы отображать, записывать в файл журнала или копировать в буфер обмена только необходимые действия. Задать параметры журнала можно в диалоговом окне Настройки.

Вы можете очистить или сохранить журнал.

Чтобы очистить журнал

* Щелкните правой кнопкой мыши на панели Журнал и выберите пункт контекстного меню Очистить журнал.

Чтобы сохранить журнал в файл

* Щелкните правой кнопкой мыши на панели Журнал и выберите пункт контекстного меню Сохранить журнал в файл.


Восстановление Данных. Дополнительные Операции

В этой главе рассматриваются дополнительные операции по восстановлению данных.

· Сканирование Диска
· Добавление Типов Файлов
· Добавление Типов Файлов-I
· Добавление Типов Файлов-II
· Области
· Исключающие Области
· Образы
· Копирование Объектов


Сканирование Диска

Для полного анализа структуры данных объекта его необходимо отсканировать. Любой объект на панели Устройство/Диск может быть отсканирован. Кроме того, вы можете отсканировать часть объекта, создав регион . В разделе Регионы рассматривается, как создавать и работать с регионами.

Вы можете выбрать область и другие параметры сканирования. Результаты сканирования могут быть сохранены в файл, который затем может быть открыт.

Внимание: Сканирования больших областей может занять очень много времени!

НИКОГДА НЕ ПЫТАЙТЕСЬ СОХРАНИТЬ ОТСКАНИРОВАННОЕ НА СКАНИРУЕМЫЙ ОБЪЕКТ!!!

Это может стать причиной полной утраты данных.

Чтобы сканировать объект

1 Выберите объект на панели Устройство/Диск
2 Нажмите кнопку Сканировать

Другие способы начать сканирование

· Щелкните правой кнопкой мыши по выбранному диску и выберите пункт Сканировать контекстного меню

или

· Выберите пункт Сканировать меню Диск
3 Задайте необходимые параметры в диалоговом окне Сканировать и нажмите кнопку Сканирование
Диалоговое окно Сканировать

Параметры сканирования

Размер диска: | Показывает размер сканируемого объекта
Старт: | Точка начала сканируемой области.
Размер: | Размер сканируемой области объекта.
Значения указанных полей могут быть выражены в байтах или секторах. Значения указанных полей выражены в байтах, если кроме цифровых значений в полях ничего нет. Для более подробной информации смотри раздел Форматы Данных.
Файловая система: | Определяет файловые системы объектов, поиск которых производится. Поддерживаются следующие файловые системы: FAT, NTFS, exFAT, Ext2/3/4FS, HFS и UFS. Обратите внимание, если вам нужно сканировать диск с файловыми системами HFS, HFS+ или HFSX, то вы должны обязательно установить флажок Искать известные типы файлов, так как при удалении файлов на данных файловых системах на компьютере полностью удаляется вся информация о файлах и единственный способ их восстановить - использовать параметр Искать известные типы файлов. Для более подробной информации смотрите раздел Восстановление Данных на файловых системах HFS/HFS+.
Искать известные типы файлов | Позволяет искать Файлы Известных Типов.
Сохранить отсканированное в файл: | Если установить данный флажок, то R-Studio сохранит отсканированное в заданный файл, который затем может быть открыт. Обратите внимание, что в результате этой операции сохраняются не данные на диске, а только информация о структуре данных на диске, полученная в результате сканирования диска.
Простой вид | Если выбран данный параметр, то R-Studio покажет только сам процесс сканирования.
Подробный вид | Если выбран данный параметр, то R-Studio покажет процесс сканирования и информацию о найденных объектах.
Нет | Если выбран данный параметр, то R-Studio не покажет вкладку Информация о сканировании во время сканирования.
Кнопки
Сканирование | Начало сканирования
Дополнительно | Позволяет задать дополнителные параметры сканирования
Известные типы файлов... | Позволяет выбрать типы файлов, с которыми R-Studio будет отождествлять данные во время сканирования.
Отмена | Закрытие диалогового окна
НИКОГДА НЕ ПЫТАЙТЕСЬ СОХРАНИТЬ ОТСКАНИРОВАННОЕ НА СКАНИРУЕМЫЙ ОБЪЕКТ!!! Это может стать причиной полной утраты данных.

Известные Типы Файлов: При сканировании R-Studio может установить, к какому конкретно типу файлов принадлежат данные. Это позволит R-Studio получить дополнительную информацию о структуре данных/файлов сканируемого объекта. По умолчанию R-Studio пытается установить все поддерживаемые типы файлов, заданные на вкладке Известные типы файлов диалогового окна Настройки, однако при этом время сканирования значительно возрастает. Вы можете сократить время сканирования, выбрав только необходимые типы файлов. Нажмите кнопку Известные типы файлов... и выберите необходимые типы файлов в диалоговом окне Известные типы файлов. Эти настройки будут применимы только к данной сессии сканирования.

Диалоговое окно Известные типы файлов

Известные Типы Файлов

Назначить по умолчанию | Нажмите данную кнопку, чтобы установить текущий список в качестве списка файлов известных типов, используемого по умолчанию.
Восстановить по умолчанию | Нажмите данную кнопку, чтобы вернуть настройки по умолчанию, заданные на вкладке Известные типы файлов диалогового окна Настройки.
Выделить все | Нажмите данную кнопку, чтобы выбрать все типы файлов из списка.
Очистить все | Нажмите данную кнопку, чтобы оставить выбранными только предопределенные типы файлов.

Список известных типов файлов

* Файлы данного типа не выбраны по умолчанию. При необходимости выберите их вручную
Документ
Adobe PDF document | Microsoft Word2 document | Microsoft WordPad document | OLE Storage
PostScript document | Rich Text document | TEX document | Word for Macintosh document
WordPerfect document |  |  |
Документ: Таблица
Lotus worksheet | Lotus3 worksheet * | Microsoft Excel2 worksheet | Microsoft Excel3/4 worksheet
Quattro Pro worksheet |  |  |
Document: Database
Data Interchange Format file | Microsoft Access database | dBase III database | Microsoft SQL database
Microsoft SQL Log |  |  |
Документ: MS Office (OLE MS) (Word/Excel/PowerPoint)
Microsoft Word document | Microsoft Excel document | Microsoft PowerPoint document
Файлы Интернета
Compiled HTML file | HTML document | Internet shortcut | Outlook Express Messages
Windows Address Book | XML document | XML document (Unicode) | The Bat! Address book
The Bat! Message Base | The Bat! Message Index |  |
Шрифт
Adobe PostScript Font | Adobe Printer Font | BDF Unix font | BGI font
CPI DOS font | TrueType font |  |
Графика/Рисунок
AVHRR Satellite image | Adobe Photoshop image | Agfa/Matrix Scodl image | Alias Wavefront Raster image
AutoCAD Binary image | AutoCAD image | Autodesc Animator Pro color map | Autodesc Animator Pro image
Autodesc Animator image | Autologic image | BMF image | ColoRIX image
CompuServe GIF image | ComputerEyes Raw image | Continuous Edge Graphic image | Corel Texture image
CorelDraw CMX image | CorelDraw image | Cubicomp Picture Maker image | Dr. Halo palette
Enhanced MetaFile image | Epson Stylus image | Erdas LAN/GIS image | Fractal Image Format
GEM Raster image * | GEM VDI image | GOES Satellite image | Gridded Binary image
HP Command Language image | HP Raster image | Hitachi Raster image | IBM Picture Maker image
JPEG image | JPEG-LS image | HSI JPEG image | Jovian Logic image
LBM/IFF image | Lotus PIC image | Macintosh PICT image | Macintosh PICT image
Macintosh Paint image | Macintosh Paint image | Microsoft Paint image | PBM image
PGM image | PIX image | PM image | PNG image
PPM image | Pictor PC Paint image | Quick Link II fax image | RenderMan image
SGI image | STAD image | Sketch image | Sun Raster image
Tagged Image Format File | TrueVision image | Utah Raster Toolkit image | VITec image
Windows Animated cursor | Windows Bitmap image | Windows Fax Cover image | Windows MetaFile image
Windows cursor | Windows icon | WordPerfect Graphics image | X PixMap image
X Window Dump image | ZSoft PCX image |  |
Мультимедиа: Аудио Файлы
AIFF sound | AVR sound | Advanced Streaming Format file | AudioCD file
CMF music | Creative Voice file | DiamondWare sound | EA ASF/MUS audio file
Extended M3U playlist | MIDI Instrument definition | MIDI music | MIDI stream
MPEG Layer I audio file * | MPEG Layer II audio file * | MPEG Layer III audio file | MUS music
Next/Sun sound | Ogg Vorbis audio file | RIFF MIDI music | RK Audio sound
Sierra AUD sound | VQF sound | Westwood AUD sound | Windows Media Audio File
Windows WAVE sound | X-MIDI music | ZyXEL sound |
Мультимедиа: Видео Файлы
ANIM animation | Adobe Filmstrip animation | BINK video | DVM video
DeluxePaint animation | Director video | Intel DVI video | Interplay MVE video
LZA animation | MPEG video | NEOchrome animation | Nullsoft Video
QV-10 video | QuickTime video | RPL video | Shockwave video
Smacker video | VideoCD video | Windows AVI video |
Мультимедиа Файлы
RIFF Multimedia File | Real Networks audio/video |  |
Файлы Архива
7-Zip archive | ACE archive | AIN archive | ARJ archive
ARX archive | Aladdin Systems StuffIt archive | BAG archive | BIX archive
BOA archive | BZip2 archive | BlackHole archive | Blink archive
CPIO archive | CRUSH archive | ChArc archive | Compress archive
FOXSQZ archive | GZip archive | HA archive * | HAP archive
HPACK archive | Hyper archive | InstallShield Cabinet archive | InstallShield Data archive
InstallShield archive | JAM archive | JAR archive | JRC archive
LHA/LZARK archive | LIMIT archive | LZA archive | LZOParchive
LZSH archive | LZX archive | Microsoft Cabinet archive | Microsoft Compress 5 archive
Microsoft Compress 6 archive | PAKLEO archive | Pack archive * | QFC archive
Quantum archive * | Quark archive | RAR archive | RPM archive
ReSOF archive | SAR archive | SBC archive | SCO archive *
SQZ archive | SZip archive | StuffIt archive | TAR archive
UFA archive | UHArc archive | UltraCompressor 2 archive | UltraCrypt 2 archive
WIN-Freeze archive * | WRAptor archive | WinImp archive | YAC archive
YBS archive | ZIP archive | ZOO archive | ZZip archive
Исполняемые/Библиотека/DLL
DOS Style Executable | ELF Executable (UNIX) | ELF Library (UNIX) | ELF Module (UNIX)
Java Bytecode | Novell NetWare executable | RDOFF executable |
Файлы проектов
COM Type library Library | Microsoft ClassWizard file | Microsoft Linker database | Microsoft Precompiled header
Microsoft Program database | Microsoft Visual C++ project | Microsoft Visual Studio project | Microsoft Visual Studio workspace
OMF Object library | Windows Compiled resource (16bit) * | Windows Compiled resource (32bit) |
Другие типы файлов
RegEdit file | RegEdit file (UNICODE) | WinHelp | WinHelp Contents
Windows Clipboard file * | Windows Color Profile | Windows National locale | Windows Password file
Windows Policy file | Windows Registry file | Windows Registry hive | Windows shortcut

Обратите внимание: При сканировании Файлов Известных Типов R-Studio может успешно восстановить только нефрагментированные файлы.

Вы также можете задать собственный тип файлов, анализируемый при сканирование. Для более подробной информации смотри раздел Добавление Типов Файлов .

Вернуться к настройком по умолчанию можно в диалоговом окне Настройки R-Studio.

> R-Studio начнет сканировать объект, и в его главном окне будет показана информация о новых найденных объектах:

Главное окно R-Studio

Нажмите на соответствующую часть главного окна на рисунке для получения более подробной информации.

Connect to RemoteRefresh (Control+R)Open Drive Files (F5)ScanOpen ImageCreate ImageCreate Region (F4)Create virtual volume sets or RAIDsDelete (F8)Stop (Esc)

В панели Журнал будет отображаться ход процесса сканирования. Сканирование можно остановить, нажав кнопку Остановить . Затем процесс сканирования может быть продолжен, при этом можно изменить параметры сканирования.

Можно посмотреть, какой файловый объект (объекты) является (являются) данной частью диска. Нажмите на соответствующий прямоугольник панели Информация о сканировании и посмотрите информацию в диалоговом окне Информация о сканировании.

Диалоговое окно Информация о сканировании

Выберите файловый объект и нажмите кнопку Открыть в шестнадцатиричном редакторе или дважды щелкните мышью, чтобы просмотреть его в Текстовом/шестнадцатиричном Редакторе.

При сканировании будет найдено некоторое число Найденных разделов (Recognized) . R-Studio покажет такие разделы различным цветом в зависимости от того, какие были найдены элементы разделов.

Существующий логический диск или раздел

На таком разделе были найдены как загрузочные записи, так и файлы

На таком разделе были найдены только файлы

На таком разделе были найдены только загрузочные записи

Свободное пространство объекта

Хотя такие найденные разделы и являются виртуальными объектами, на них можно искать и восстанавливать файлы как на обычных логических дисках, как описано в разделе Восстановление Файлов. Основные Операции.

Для просмотра информации о найденных объектах щелкните по ним на панели Диски. Нажмите на следующую ссылку, чтобы посмотреть информацию об объекте Recognized3 на логическом диске F:.

Всю информацию о сканировании можно удалить, выбрав соответствующую команду контекстного меню.

Информация о сканировании может быть сохранена в файл. Также можно загрузить из файла ранее сохраненную информацию о сканировании. Для этого необходимо выбрать соответствующий пункт меню Диск или контекстного меню.

Многократное сканирование

Если выбранный объект уже был полностью сканирован, то вы можете сканировать его повторно либо полностью, либо задав новые параметры сканирования. Если выбранный объект был сканирован только частично, то вы можете сканировать оставшуюся часть объекта, пересканировать заново весь объект без учета существующей информации о его сканировании или задать параметры сканирования вручную.

R-Studio накапливает информацию об успешных сканированиях с учетом изменений, полученных при разных процессах сканирования.

Вы можете выполнить несколько сканирований как отдельных, так и перекрывающихся областей. Нажмите кнопку Дополнительно, задайте смещение и размер новой сканируемой области в области Области Сканирования и нажмите кнопку Добавить . Вы можете задать и добавить несколько сканируемых областей. Вы можете выбрать сканируемые области. Сканируемые области можно объединять. Щелкните правой кнопкой мыши на область и выберите Объединить вниз, Объединить вниз все и Объединить выделенные.

Диалоговое окно Сканировать

Действия, которые можно выполнить с информацией о сканировании

Информация о сканировании может быть сохранена в файл. Также можно загрузить из файла ранее сохраненную информацию о сканировании.

Чтобы сохранить информацию о сканировании

1 Выберите объект на панели R-Studio Устройство/Диск
2 Выберите пункт Сохранить отсканированное меню Диск или контекстного меню и сохраните отсканированное в файл

По умолчанию расширение файла *.scn.

Если подключен удаленный компьютер для Восстановления Данных по Сети, то при выборе места сохранения информации о сканировании откроется диалоговое окно Сохранить отсканированное . Вы можете сохранить отсканированное на локальном или удаленном компьютере.

Чтобы загрузить информацию о сканировании

1 Выберите объект на панели R-Studio Устройство/Диск
2 Выберите пункт Открыть отсканированное меню Диск или контекстного меню и выберите необходимый файл с информацией о сканировании

По умолчанию расширение файла *.scn.

Если подключен удаленный компьютер для Восстановления Данных по Сети, то при выборе файла с информацией о сканировании откроется диалоговое окно Открыть отсканированное . Вы можете загрузить отсканированное с локального или удаленного компьютера.

> Информация о сканировании будет отображена в панели Устройство/Диск

Чтобы удалить информацию о сканировании

1 Выберите объект на панели R-Studio Устройство/Диск
2 Выберите пункт Удалить информацию о сканировании меню Диск или контекстного меню
> Информация о сканировании будет удалена с панели Устройство/Диск

НИКОГДА НЕ ПЫТАЙТЕСЬ СОХРАНИТЬ ОТСКАНИРОВАННОЕ НА СКАНИРУЕМЫЙ ОБЪЕКТ!!!

Это может стать причиной полной утраты данных.


Добавление Типов Файлов

Пользователь может добавлять новые типы файлов в состав R-Studio (добавлять собственные (пользовательские) сигнатуры в состав файлов известных типов). Они будут добавляться в соответствующие папки диалогового окна Известные типы файлов.

Добавлять собственные сигнатуры можно либо при помощи графического редактора файловых сигнатур R-Studio, либо непосредственно редактируя файл описания пользовательских сигнатур, заданный на вкладке Главная диалогового окна Настройки .

Добавление Пользовательских Известных Типов Файлов при помощи Графического Редактора Файловых Сигнатур

Проще всего добавить сигнатуру файлов известных типов при помощи графического редактора файловых сигнатур R-Studio.

Чтобы добавить Известный Тип Файлов

1 В диалоговом окне Настройки/Известные типы файлов нажмите кнопку Редактировать
> Откроется диалоговое окно Редактирование пользовательских типов
Диалоговое окно Редактирование пользовательских типов
2 Нажмите кнопку Создать тип файла и задайте параметры Типа файлов
Диалоговое окно Редактирование пользовательских типов

Параметры Типов Файлов

id

digit

Обязательный

Уникальный цифровой идентификатор типа файла. Не должен совпадать с цифровым идентификатором какого-либо другого типа файлов.

описание группы

string

Необязательный

Группа, в которой будут находиться найденные файлы в R-Studio. Можно задать либо новую группу, либо выбрать одну из тех, которые уже определены в диалоговом окне Настройки/Известные типы файлов.

описание

string

Необязательный

Краткое описание типа файлов

свойства

NO_SCAN

TXT_ANSI

TXT_UNICODE

Необязательный

Дополнительные свойства типа файлов. Если необходимо задать несколько свойств, то между ними следует оставлять пробел.

NO_SCAN: Не для сканирования. При использовании данного флага R-Studio не будет искать данный тип файлов. Файлы данного типа будут показаны при сортировке файлов по расширениям.

TXT_ANSI: Файл можно просмотреть как текст в кодировке ANSI. При использовании данного флага файл может быть корректно представлен как текст в кодировке ANSI. При просмотре файлы данного типа будут сразу открываться в Текстовом/Шестнадцатиричном Редакторе.

TXT_UNICODE: Файл можно просмотреть как текст в кодировке UNICODE. При использовании данного флага файл может быть корректно представлен как текст в кодировке UNICODE. При просмотре файлы данного типа будут сразу открываться в Текстовом/Шестнадцатиричном Редакторе.

расширение

<string>

Необязательный

Расширение файлов.
1 Нажмите кнопку Добавить сигнатуру, задайте параметры сигнатуры и нажмите кнопку Сохранить
Диалоговое окно Редактирование пользовательских типов

Параметры Файловой Сигнатуры

Начало Конец | Определяет начало файловой сигнатуры. Если задан параметр Конец, то смещение рассчитывается с конца файла до первого байта сигнатуры. Это означает, что если длина сигнатуры равна двум байтам, то величина смещения должна быть равна 2.
И ИЛИ | Показывает порядок логической операции (объединение или пересечение)
От | Десятичное число, определяющее крайнее слева из возможных смещений сигнатуры файла.
До | Десятичное число, определяющее крайнее справа из возможных смещений сигнатуры файла.

Вы можете добавить любое количество сигнатур в состав файлов известных типов. Более того, при помощи кнопки Добавить подгруппу можно задать подгруппы файловой сигнатуры. Структура таких возможных подгрупп описана в разделе Добавление Типов Файлов-II .

> Добавленный известный тип файлов появится в диалоговом окне Редактирование пользовательских типов и в диалоговом окне Настройки/Известные типы файлов
Диалоговое окно Редактирование пользовательских типов


Добавление Типов Файлов-I

Синтаксис файла описания пользовательских сигнатур схож с языком XML. Хранятся пользовательские сигнатуры в файле, заданном на вкладке Главная диалогового окна Настройки .

Дополнительные возможности при создании собственных сигнатур Файлов Известных Типов описаны в разделе Добавление Типов Файлов-II.

Пример файла сигнатуры

<?xml version="1.0" encoding="utf-8"?>

<FileTypeList>

<!-- Search for NTFS MFT -->

<FileType id="5626" group="System Files" description="MFT" features="TXT_ANSI TXT_UNICODE">

<Signature offset="0" from="begin" count="1">FILE</Signature>

<Signature offset="4" from="end" count="1">$\x00M\x00F\x00T</Signature>

</FileType>

</FileTypeList>

Структура файла

Заголовок Файла

Файл начинается со стандартного заголовка XML

<?xml version="1.0" encoding="utf-8"?>

Элемент FileTypeList

<FileTypeList>

В конце обязательно должен находиться закрывающий тег </FileTypeList>.

Элемент FileType

Ниже приведено описание атрибутов данного элемента.

Атрибуты:

id | <u32> | Обязательный | Уникальный цифровой идентификатор для каждого типа файла. |
group | <string> | Необязательный | Задает группу типа файлов, в которой будут находиться найденные файлы. Можно задать либо новую группу, либо выбрать одну из тех, которые уже имеются в диалоговом окне Известные типы файлов. | По умолчанию: unknown
description | <string> | Необязательный | Краткое описание | По умолчанию: null (без описания)
features | NO_SCAN TXT_ANSI TXT_UNICODE | Необязательный | Дополнительные свойства типа файлов. Если необходимо задать несколько свойств, то между ними следует оставлять пробел. | По умолчанию: 0
extension | <string> | Необязательный | Расширение файла. | По умолчанию: null (без расширения)

Флаги свойств типа файлов

NO_SCAN | Не для сканирования. При использовании данного флага R-Studio не будет искать данный тип файлов. Файлы данного типа будут показаны при сортировке файлов по расширениям.
TXT_ANSI | Файл можно просмотреть как текст в кодировке ANSI. При использовании данного флага файл может быть корректно представлен как текст в кодировке ANSI. При просмотре файлы данного типа будут сразу открываться в Текстовом/Шестнадцатиричном Редакторе.
TXT_UNICODE | Файл можно просмотреть как текст в кодировке UNICODE. При использовании данного флага файл может быть корректно представлен как текст в кодировке UNICODE. При просмотре файлы данного типа будут сразу открываться в Текстовом/Шестнадцатиричном Редакторе.

Данный элемент может содержать неограниченное число элементов Signature. Если есть несколько элементов Signature, то это означает, что все эти сигнатуры одновременно присутствуют в файле. Данные сигнатуры должны иметь различные атрибуты offset и они не должны пересекаться.

Элемент Signature

Элемент содержит строковую величину сигнатуры файла, состоящую из символов ASCII, и шестнадцатиричные байты в формате \xhh , где hh - шестнадцатиричный байтовый код. Если после \x отсутствует шестнадцатиричное число, то \x обрабатывается как часть строковых символов.

Атрибуты:

offset

<u16>

Необязательный

Десятичное смещение сигнатуры

По умолчанию: 0

count

<u16>

Необязательный

Десятичное число, определяющее число сигнатур одинаковой длины. Используется в том случае, если в файле могут присутствовать несколько сигнатур одной и той же длины, начинающиеся с одного смещения. В этом случае они должны быть последовательно записаны в элемент, а атрибур size задает длину сигнатуры. Значение count*size должно быть равно числу байт в элементе.

Если с одного смещения может начинаться только одна сигнатура, то значение атрибута count должно быть равно "1" и size должен быть равен длине (число байт) сигнатуры.

По умолчанию: 1

size

<u16>

Необязательный

Десятичное число, определяющее число байт в сигнатуре.

По умолчанию: число байт в элементе.

from

begin

end

Необязательный

Определяет, откуда рассчитывается offset.

Если значение атрибута равно end, то offset рассчитывается с конца файла до первого байта сигнатуры. Это означает, что если длина сигнатуры равна двум байтам, то величина offset должна быть равна 2.

По умолчанию: begin

Комментарии

<!-- Comment string -->

Стандартная строка комментария XML .


Добавление Типов Файлов-II

В настоящее время R-Studio поддерживает две Версии описания типа файлов. Версия 2 отличается от Версии 1 добавлением возможности смещения сигнатуры и возможности комбинации нескольких сигнатур (при помощи элементов AND/OR) в одном типе файлов. Версия описания типа файлов определяется атрибутом Version элемента FileTypeList . По умолчанию используется Версия1.

Структура файла

Общие элементы для Версии 1 и Версии 2 описания типа файлов

Заголовок Файла

Файл начинается со стандартного заголовка XML

<?xml version="1.0" encoding="utf-8"?>

Элемент FileTypeList

<FileTypeList>

Атрибуты:

Version

1.0

2.0

Необязательный

Версия описания типа файлов

По умолчанию: 1.0

В конце обязательно должен находиться закрывающий тег </FileTypeList>.

Комментарии

<!-- Comment string -->

Стандартная строка комментария XML .

Версия 1 описания типа файлов

Пример файла сигнатуры

<FileTypeList>

<FileType id="2" group="archive" description="ARJ Archive" extension="arj">

<Signature offset="3" count="1">Abc\x5c\x00\x04</Signature>

<Signature offset="9" count="2">\x23\x01\xf4</Signature>

</FileType>

</FileTypeList>

Элемент FileType

Ниже приведено описание атрибутов данного элемента.

Атрибуты:

id | <u32> | Обязательный | Уникальный цифровой идентификатор для каждого типа файлов. |
group | <string> | Необязательный | Задает группу типа файлов, в которой будут находиться найденные файлы. Можно задать либо новую группу, либо выбрать одну из тех, которые уже имеются в диалоговом окне Известные типы файлов. | По умолчанию: unknown
description | <string> | Необязательный | Краткое описание | По умолчанию: null (без описания)
features | NO_SCAN TXT_ANSI TXT_UNICODE | Необязательный | Дополнительные свойства типа файлов. Если необходимо задать несколько свойств, то между ними следует оставлять пробел. | По умолчанию: 0
extension | <string> | Необязательный | Расширение файла. | По умолчанию: null (без расширения)

Флаги свойств типа файлов (features)

NO_SCAN | Не для сканирования. При использовании данного флага R-Studio не будет искать данный тип файлов. Файлы данного типа будут показаны при сортировке файлов по расширениям.
TXT_ANSI | Файл можно просмотреть как текст в кодировке ANSI. При использовании данного флага файл может быть корректно представлен как текст в кодировке ANSI. При просмотре файлы данного типа будут сразу открываться в Текстовом/Шестнадцатиричном Редакторе.
TXT_UNICODE | Файл можно просмотреть как текст в кодировке UNICODE. При использовании данного флага файл может быть корректно представлен как текст в кодировке UNICODE. При просмотре файлы данного типа будут сразу открываться в Текстовом/Шестнадцатиричном Редакторе.

Список групп предопределенных типов файлов

Группа | Название группы в диалоговом окне Типы Файлов.
archive | Архив
graphics | Графика/Рисунок
internet | Интернет файлы
multimedia | Мультимедиа
audio | Мультимедиа: Аудио
video | Мультимедиа: Видео
font | Шрифт
document | Документ
doc_database | Документ: База данных
doc_sheet | Документ: Таблица
exe | Исполняемые/Библиотека/DLL
unknown | Другие файлы

Элемент FileType может содержать неограниченное число элементов Signature. Если элемент FileType содержит несколько элементов Signature, то это означает, что все они одновременно присутствуют в файле. Эти сигнатуры должны иметь различные смещения и не должны пересекаться.

Элемент Signature

Элемент содержит строковую величину сигнатуры файла, состоящую из символов ASCII, и шестнадцатиричные байты в формате \xhh , где hh - шестнадцатиричный байтовый код. Если после \x отсутствует шестнадцатиричное число, то \x обрабатывается как часть строковых символов.

Атрибуты:

offset

<u16>

Необязательный

Десятичное смещение сигнатуры

По умолчанию: 0

count

<u16>

Необязательный

Десятичное число, определяющее число сигнатур одинаковой длины. Используется в том случае, если в файле могут присутствовать несколько сигнатур одной и той же длины, начинающиеся с одного смещения. В этом случае они должны быть последовательно записаны в элемент, а атрибур size задает длину сигнатуры. Значение count*size должно быть равно числу байт в элементе.

Если с одного смещения может начинаться только одна сигнатура, то значение атрибута count должно быть равно "1" и size должен быть равен длине (числу байт) сигнатуры.

По умолчанию: 1

size

<u16>

Необязательный

Десятичное число, определяющее число байт в сигнатуре.

По умолчанию: число байт в элементе.

from

begin

end

Необязательный

Определяет, откуда рассчитывается offset.

Если значение атрибута равно end, то offset рассчитывается с конца файла до первого байта сигнатуры. Это означает, что если длина сигнатуры равна двум байтам, то величина offset должна быть равна 2.

По умолчанию: begin

Версия 2 описания типа файлов

Пример файла сигнатуры

<?xml version="1.0" encoding="utf-8"?>

<FileTypeList version="2.0">

<FileType id="5626" group="_Test" description="Test file" extension="tst">

<Begin combine="and">

<Signature from="0" to="20">ABC</Signature>

<Signature offset="1">CDEFG</Signature>

<AND>

<Signature offset="0">DE</Signature>

<Signature offset="0">RTD</Signature>

<OR>

<Signature offset="12">CP</Signature>

<Signature offset="16">RTD</Signature>

</OR>

</AND>

</Begin>

<End combine="or">

<Signature from="3" to="20">ABC</Signature>

<Signature offset="5">CDEFG</Signature>

<AND>

<Signature offset="2">DE</Signature>

<Signature offset="3">RTD</Signature>

<OR>

<Signature offset="12">CP</Signature>

<Signature offset="16">RTD</Signature>

</OR>

</AND>

</End>

</FileType>

</FileTypeList>

Элемент FileType

Ниже приведено описание атрибутов данного элемента.

Атрибуты:

Схожи с атрибутами в Версии 1.

Элемент FileType может содержать один элемент Begin и один элемент End. Он должен содержать по крайней мере один из этих элементов.

Пример

<FileTypeList version=”2.0”>

<FileType id="2" group="archive" description="ARJ Archive" extension="arj">

<Begin [attributes]>

...

</Begin>

<End [attributes]>

...

</End>

</FileType>

</FileTypeList>

Элементы Begin и End

Определяют позиции сигнатур типа файлов в файле.

Атрибуты:

combine

and

or

Необязательный

Показывает порядок логической операции (объединение или пересечение)

По умолчанию: and

Элементы Begin и End могут содержать один или несколько элементов Signature, а также один или несколько элементов OR или AND. В случае присутствия нескольких из указанных элементов они комбинируются в соответствие с атрибутом combine.

Пример

<FileTypeList version=”2.0”>

<FileType id="2" group="archive" description="ARJ Archive" extension="arj">

<Begin combine="or">

<Signature [attributes]> ... </Signature>

...

<Signature [attributes]> ... </Signature>

<AND>

...

</AND>

<OR>

...

</OR>

</Begin>

<End>

<OR>

...

</OR>

<Signature [attributes]> ... </Signature>

...

<Signature [attributes]> ... </Signature>

</End>

</FileType>

</FileTypeList>

Элементы AND и OR

Данные элементы могут содержать один или несколько элементов Signature, а также один или несколько элементов OR или AND. В случае присутствия нескольких из указанных элементов они комбинируются в соответствие с типом элемента (логическое AND или OR).

Пример

<FileTypeList version=”2.0”>

<FileType id="2" group="archive" description="ARJ Archive" extension="arj">

<Begin>

<Signature [attributes]> ... </Signature>

...

<Signature [attributes]> ... </Signature>

<AND>

<Signature [attributes]> ... </Signature>

<OR>

<Signature [attributes]> ... </Signature>

<AND>

<Signature [attributes]> ... </Signature>

<Signature [attributes]> ... </Signature>

</AND>

<OR>

<Signature [attributes]> ... </Signature>

<Signature [attributes]> ... </Signature>

</OR>

</OR>

<Signature [attributes]> ... </Signature>

</AND>

</Begin>

</FileType>

</FileTypeList>

Элемент Signature

Элемент содержит строковую величину сигнатуры файла, состоящую из символов ASCII, и шестнадцатиричные байты в формате \xhh , где hh - шестнадцатиричный байтовый код. Если после \x отсутствует шестнадцатиричное число, то \x обрабатывается как часть строковых символов.

offset | <u16> | Необязательный | Десятичное смещение сигнатуры | По умолчанию: 0
from | <u16> | Необязательный | Десятичное число, определяющее крайнее слева из возможных смещений сигнатуры файла. Игнорируется, если задан атрибут offset. | По умолчанию: undefined
to | <u16> | Необязательный | Десятичное число, определяющее крайнее справа из возможных смещений сигнатуры файла. Игнорируется, если задан атрибут offset. | По умолчанию: undefined
size | <u16> | Необязательный | Десятичное число, определяющее число байт в сигнатуре. | По умолчанию: число байт в элементе.

Пример

<FileTypeList version=”2.0”>

<FileType id="2" group="archive" description="ARJ Archive" extension="arj">

<Begin>

<Signature offset="3">Abc\x5c\x00\x04</Signature>

<Signature from="9" to="15">\x23\x01\xf4</Signature>

</Begin>

</FileType>

</FileTypeList>


Области

Регионы

Сканирование больших объектов может занять много времени. Иногда требуется отсканировать и произвести поиск файлов только на части диска. Такая часть диска называется регион. Регион может быть создана на любом объекте, имеющимся на панели R-Studio Устройство/Диск.

Созданные регионы можно отсканировать, на них можно восстанавливать файлы как на обычных физических и логических дисках.

Созданные регионы можно удалить.

Обратите внимание: R-Studio не создает чего-либо реального на диске. Регионы это виртуальные объекты, которые не оказывают никакого влияния на данные на диске.

Чтобы создать регион

1 Выберите объект на панели R-Studio Устройство/Диск и нажмите кнопку Создать регион

Другие способы создать область

· Щелкните правой кнопкой мыши по выбранному объекту и выберите пункт Создать регион контекстного меню

или

· Выберите объект и выберите пункт Создать регион меню Создать

or

· Выберите объект и нажмите клавишу F4
2 Задайте необходимые параметры в диалоговом окне Создать регион и нажмите кнопку Да
Диалоговое окно Создать регион

Параметры Региона

Размер диска: | Показывает размер объекта, на котором создается регион. Размер области не может превышать данный размер.
Старт: | Точка начала региона
Размер: | Размер региона. Не может превышать Размер диска.
Значения указанных полей могут быть выражены в байтах или секторах. Значения указанных полях выражены в байтах, если кроме цифровых значений в полях ничего нет. Для более подробной информации смотри раздел Форматы Данных.
> Регион объекта появится на панели Устройство/Диск .

Чтобы удалить регион

* Выберите Регион на панели R-Studio Устройство/Диск и нажмите кнопку Удалить или

щелкните правой кнопкой мыши по выбранному региону и выберите пункт Удалить контекстного меню.

Чтобы изменить размер региона

* Щелкните правой кнопкой мыши по Региону на панели R-Studio Устройство/Диск , выберите пункт Редактировать контекстного меню и в диалоговом окне Редактировать регион введите новый размер.


Исключающие Регионы

Регион любого объекта панели R-Studio Устройство/Диск , не затрагиваемая при выполнении дисковой операции, называется исключающим. При помощи R-Studio нельзя будет прочесть/модифицировать данные на таком регионе. Это весьма полезно, например, тогда, когда на жестком диске есть области с неисправными секторами, которые следует исключить из дисковых операций во избежании дальнейшего повреждения диска и повышения скорости его обработки.

Обратите внимание: R-Studio не создает чего-либо реального на диске. Исключающие регионы это виртуальные объекты, которые не оказывают никакого влияния на данные на диске.

Чтобы создать исключающий регион

1 Щелкните правой кнопкой мыши по выбранному объекту панели R-Studio Устройство/Диск и выберите пункт Создать исключающий регион контекстного меню или

Выберите объект и выберите пункт Создать исключающий регион меню Создать

2 Задайте необходимые параметры в диалоговом окне Создать исключающий регион и нажмите кнопку Добавить
Диалоговое окно Создать исключающий регион

Параметры Исключающего Региона

Смещение: | Точка начала исключающего региона
Размер: | Размер исключающего региона. Не может превышать Размер диска.
Значения указанных полей могут быть выражены в байтах или секторах. Значения указанных полях выражены в байтах, если кроме цифровых значений в полях ничего нет. Для более подробной информации смотри раздел Форматы Данных.
> Исключающий регион появится на панели Устройство/Диск.

Его свойства можно просмотреть на вкладке Исключенные области .

Чтобы удалить исключающий регион

* Выберите Исключающий регион на панели R-Studio Устройство/Диск и нажмите кнопку Удалить или

щелкните правой кнопкой мыши по выбранной области и выберите пункт Удалить контекстного меню.

Чтобы изменить размер исключающего региона

* Щелкните правой кнопкой мыши по Исключающему региону на панели R-Studio Устройство/Диск , выберите пункт Редактировать контекстного меню и добавьте/удалите соответствующие исключенные области в диалоговом окне Редактировать исключающий регион.

Вы можете удалить исключенную область щелкнув по ней правой кнопкой мыши и выбрав пункт Удалить контекстного меню.


Образы

Образ это точная, "байт в байт" копия объекта панели Устройство/Диск. Файлы образов могут обрабатываться как обычные диски.

Образы весьма полезны тогда, когда существует вероятность полной утраты данных вследствие неисправности аппаратной части компьютера. При постоянном появлении на жестком диске неисправных блоков, создание образа диска - единственный способ не допустить полной утраты информации. Файлы образов диска могут обрабатываться программой как обычный диск.

Чтобы создать образ

1 Выберите объект на панели R-Studio Устройство/Диск и нажмите кнопку Создать образ

Другие способы создать образ

· Выберите объект и выберите пункт Создать образ меню Диск

или

· Щелкните правой кнопкой мыши по выбранному объекту и выберите пункт Создать образ контекстного меню
2 Задайте параметры образа, имя и местоположение файла образа в диалоговом окне Создать образ

Обратите внимание: Для сохранения файла образа вам понадобится свободное дисковое пространство равное или большее размера объекта.

Диалоговое окно Создать образ. Вкладка Главная
Диалоговое окно Создать образ. Вкладка Информация о сканировании
Диалоговое окно Создать образ. Вкладка Дополнительно

Параметры Образа

Имя файла образа

Задает имя и местоположение файла образа

Несжатый образ

Если выбран данный параметр, то R-Studio создаст точную копию объекта. Данный формат образа совместим с форматами предыдущих версий R-Studio.

Сжатый образ (совместимый с образом R-Drive Image)

Если выбран данный параметр, то R-Studio создаст файл образа, который может быть сжат, разделен на несколько частей и защищен паролем. Такой файл образа полностью совместим с образами, созданными программой R-Drive Image, но несовместим в образами предыдущих версий R-Studio.

Уровень сжатия

Вы можете сжать данные образа для сохранения дискового пространства. Данный параметр доступен только при создании Сжатого образа (совместимого с образом R-Drive Image).

Оценочный размер

Показывает оценочный размер файла образа. Реальный размер образа зависит от того, сколько свободного места имеется на выбранном разделе и файлы какого типа там находятся. Данный параметр доступен только при создании Сжатого образа (совместимого с образом R-Drive Image).

Размер тома многотомного файла образа

Вы можете задать данный параметр Автоматически , при этом размер и разделение файла образа будет определено в Windows автоматически. Главным образом это зависит от файловой системы диска, на котором сохраняется файл образа. Также вы можете явно задать размер файла образа или выбрать шаблонный размер различных съемных носителей. Для этого выберите Фиксированный размер. Данный параметр доступен только при создании Сжатого образа (совместимого с образом R-Drive Image).

Пароль образа

Вы можете защитить файл образа паролем. Обратите внимание: Данный параметр обеспечивает среднюю степень защиты файла образа от неавторизованного доступа. Данный параметр доступен только при создании Сжатого образа (совместимого с образом R-Drive Image).

Создать файл с информацией о сканировании

Если установить данный флажок, то R-Studio выполнит сканирование диска одновременно с созданием образа. Описание параметров сканирования можно найти в разделе Сканирование Диска .

Количество попыток чтения

Значение величины Попыток В/В, определяющее, сколько раз R-Studio будет пытаться прочесть неисправный сектор.

Образец для заполнения неисправных блоков

Шаблон, которым R-Studio будет заполнять неисправные сектора в данном образе. Данный шаблон может быть задан в форматах данных ANSI или Hex (Шестн.).

Внимание: R-Studio никогда не модифицирует что-либо на диске, с которого восстанавливаются данные или образ которого создается.

Если подключен удаленный компьютер для Восстановления Данных по Сети, то при выборе места сохранения образа откроется диалоговое окно Сохранить файл образа . Вы можете сохранить файл образа на локальном или удаленном компьютере.

> R-Studio начнет создавать образ, и откроется Окно , показывающее ход данного процесса.

Для работы с уже созданным Образом файл образа необходимо открыть.

Чтобы открыть образ

1 Нажмите кнопку Открыть образ или

Выберите пункт Открыть образ меню Диск

Если подключен удаленный компьютер для Восстановления Данных по Сети, то при выборе файла образа откроется диалоговое окно Открыть файл образа . Вы можете открыть файл образа с локального или удаленного компьютера.

2 Выберите необходимый файл образа
> Образ объекта будет открыт в панели Устройство/Диск

Вид открытого несжатого и сжатого (совместимого с R-Drive Image) образа в панели Устройство/Диск будет различным. Файлы образы могут обрабатываться программой как обычный диск.


Копирование Объектов

При наличии достаточного дискового пространства вы можете копировать любой объект панели Устройство/Диск .

Необходимо разрешить запись для того, чтобы пункт Копировать объект в... меню Создать стал активным.

Чтобы разрешить запись

1 В главном окне R-Studio выберите пункт Настройки меню Инструменты и далее установите флажок Разрешить запись в диалоговом окне Настройки.
> Пункт Копировать объект в... меню Создать станет активным.

Теперь объекты можно копировать.

В зависимости от копируемых объектов и решаемой задачи возможно:

Бинарное (побайтное) копирование

Это точное копирование любого объекта или части объекта панели Устройство/Диск с возможность изменения его смещения.

Чтобы выполнить бинарное копирование объекта

1 Выберите пункт Копировать объект в меню Создать
2 Выберите объекты на панелях Источник и Приемник диалогового окна Мастер копирования дисков и нажмите кнопку Далее
Диалоговое окно Мастер копирования дисков
3 Установите радиокнопку Бинарное (байт в байт) копирование в диалоговом окне Настройки копирования, задайте параметры копирования и нажмите кнопку Далее

Диалоговое окно Настройки копирования

Настройки копирования

Источник
Скопировать весь объект | Установите данную радиокнопку, если вы хотите копировать объект полностью
Скопировать диапазон | Установите данную радиокнопку, если вы хотите копировать часть объекта
Смещение | Задайте смещение, начиная с которого вы хотите копировать часть объекта
Размер | Задайте размер части объекта, который вы хотите копировать
Приемник
Смещение | Задайте смещение, начиная с которого будут располагаться копируемые данные на конечном объекте
3 Просмотрите заданные параметры копирования в диалоговом окне Мастер копирования дисков и нажмите кнопку Закончить

Диалоговое окно Мастер копирования дисков

Или нажмите кнопку <Назад, чтобы изменить параметры копирования

> R-Studio начнет копирование объекта или его части.

Копирование разделов

Это копирование любого раздела на другой раздел или свободное дисковое пространство с возможность изменения его параметров.

Чтобы выполнить копирование раздела

1 Выберите пункт Копировать объект в... меню Создать
2 Выберите разделы на панелях Источник и Приемник диалогового окна Мастер копирования дисков и нажмите кнопку Далее
Диалоговое окно Мастер копирования дисков
3 Установите радиокнопку Копирование разделов в диалоговом окне Настройки копирования, задайте параметры копирования и нажмите кнопку Далее
Диалоговое окно Настройки копирования

Настройки копирования

Приемник
Копировать без растяжения | Установите данную радиокнопку, если вы хотите копировать раздел без изменения его параметров
Копировать в: | Установите данную радиокнопку, если вы хотите изменить некоторые параметры копируемого раздела
Свободное место до | Задайте свободное дисковое пространство конечного объекта до начала копируемого раздела
Размер раздела | Установите данный флажок и задайте новый размер копируемого раздела
Тип раздела Основной (активный)/ Основной/Логический | Задайте тип копируемого раздела. Не изменяйте данный параметр, если вы в этом не уверены.
3 Просмотрите заданные параметры копирования в диалоговом окне Мастер копирования дисков и нажмите кнопку Закончить
Диалоговое окно Мастер копирования дисков

Или нажмите кнопку <Назад, чтобы изменить параметры копирования

> R-Studio начнет копирование раздела.

Копирование дисков

Это копирование любого диска на другой диск с возможность изменения его параметров.

Чтобы выполнить копирование диска

1 Выберите пункт Копировать объект в... меню Создать
2 Выберите диски на панелях Источник и Приемник диалогового окна Мастер копирования дисков и нажмите кнопку Далее
Диалоговое окно Мастер копирования дисков
3 Установите радиокнопку Копирование дисков в диалоговом окне Настройки копирования, задайте параметры копирования и нажмите кнопку Далее
Диалоговое окно Настройки копирования

Настройки копирования

Режим копирования

Копировать все разделы без изменения

Установите данную радиокнопку, если вы хотите копировать все разделы диска без изменения параметров

Копировать разделы один за другим

Установите данную радиокнопку, если вы хотите копировать последовательно все разделы диска с сохранением их размеров. Если между разделами диска есть свободное пространство, то оно будет пропущено. Если свободное пространство между разделами отсутствует, то данный параметр аналогичен параметру Копировать все разделы без изменения.

Установите флажок Не изменять активный раздел для сохранения оригинального смещения/размера активного раздела (если на него ссылается загрузчик).

Сжать/расширить раздел на весь диск

Установите данную радиокнопку, если вы хотите пропорционально растянуть/сжать выбранные разделы до размера целого диска.

Установите флажок Не изменять активный раздел для сохранения оригинального смещения/размера активного раздела (если на него ссылается загрузчик).
3 Просмотрите заданные параметры копирования в диалоговом окне Мастер копирования дисков и нажмите кнопку Закончить
Диалоговое окно Мастер копирования дисков

Или нажмите кнопку <Назад, чтобы изменить параметры копирования

> R-Studio начнет копирование диска.


Массовое Восстановление Файлов

Восстановление множественных файлов

Если вам необходимо восстановить за раз большое число файлов, то для этого необходимо выполнить следующее:

1 Найти и пометить все необходимые файлы

Для более подробной информации смотри раздел Найти и Пометить Множественные Файлы

2 Восстановить все помеченные файлы за один раз

Для более подробной информации смотри раздел Восстановление Множественных Файлов

R-Studio и память компьютера

R-Studio хранит информацию о найденных файлах в памяти компьютера. При значительном количестве файлов R-Studio может не хватить памяти. Чтобы такого не произошло, можно поступить одним из следующих способов:

Восстановить все файлы

Если вам нужно восстановить полностью данные объекта файловой системы (логического диска, раздела, образа раздела и т.д.), то можно воспользоваться командой Восстановить все файлы меню Диск или контекстного меню. Для выбора команды контекстного меню щелкните правой кнопкой мыши по соответствующему объекту панели Диски . Откроется диалоговое окно Восстановить . Задайте необходимые параметры восстановления, в том числе маску файла. При помощи данной команды можно восстановить неограниченное число файлов без ограничений памяти.

Пошаговый просмотр информации о файлах

Как только R-Studio будет не хватать памяти, появится сообщение Too many files... . Вы можете на время остановить перечисление файлов и просмотреть найденные файлы. После этого вы можете возобновить перечисление файлов. Вы также можете пропустить просмотр файлов и продолжить их перечисление.

В любом случае R-Studio полностью сохранит информацию о файловой структуре.

· Найти и Пометить Множественные Файлы
· Восстановление Множественных Файлов


Найти и Пометить Множественные Файлы

Если вам необходимо за раз найти и пометить большое число файлов, то сделать это можно следующими способами:

Сортируя файлы по расширениям или времени создания/изменения/последнего доступа

Чтобы упорядочить файлы по расширениям или времени создания/изменения/последнего доступа

* В главном окне R-Studio выберите вкладку
Расширению | чтобы упорядочить файлы по расширениям
Времени создания | чтобы упорядочить файлы по времени создания
Времени изменения | чтобы упорядочить файлы по времени изменения
Времени последнего доступа | чтобы упорядочить файлы по времени последнего доступа

Другие способы упорядочить файлы по расширениям или времени создания/изменения/последнего доступа

· Выберите диск на панели Диски, выберите команду Показать содержимое диска упорядоченное по меню Диск или контекстного меню и далее выберите соответствующее упорядочивание файлов

или

· На панели Папки щелкните правой кнопкой мыши по букве соответствующего диска и выберите команду Показать файлы упорядоченные по контекстного меню и далее соответствующее упорядочивание файлов.
> R-Studio покажет упорядоченные файлы на панелях Папки и Содержимое, а также путь к каждому файлу:

Для возврата к обычному режиму просмотра

* На панели Диски щелкните правой кнопкой мыши по логическому диску, выберите пункт Показать содержимое диска контекстного меню или меню Диск

или

На панели Папки, выберите пункт Показать файлы упорядоченные по контекстного меню и далее выберите пункт Реальная структура файловой системы

Ища и маркирую множественные файлы при помощи диалогового окна Найти/Пометить

Пользователь может найти и пометить файлы на всем диске, выбрав режим Поиска/Маркировки Пометить совпадающие файлы. Вы можете задать все необходимые параметры поиска и пометить все найденные файлы. Обратите внимание, что операции по поиску и маркировки/снятию маркировки не зависят от предыдущих. Это означает, что если файл соответствует необходимому критерию, то он будет помечен или с него будет снята пометка независимо от его предыдущего состояния (был он помечен или нет).

Например, если сперва пометить все файлы с расширением doc , а затем все файлы в расширением txt , то все файлы с расширением doc также останутся помеченными. Если после этого снять пометку со всех файлов размером менее 2 kБ, то все doc и txt файлы останутся помеченными, кроме файлов размером менее 2 kБ.


Восстановление Множественных Файлов

Если в процессе восстановления R-Studio попадется уже существующий файл или файл с неверным именем, то процесс восстановления прервется и откроется окно запроса о том, что делать с подобным файлом. При восстановлении множественных файлов необходимо будет не один раз ответить на подобный вопрос. В таком случае удобно использовать Параметры Массового Восстановления Файлов диалогового окна Восстановить .

Диалоговое окно Восстановить (вкладка Дополнительно)

Параметры Массового Восстановления Файлов

Файл уже существует | Данные параметры позволяют выбрать действие в том случае, если файл с найденным именем уже существует.
Предложить действие | В этом случае R-Studio предложит пользователю выбрать действие. До получения ответа процесс восстановления будет прерван.
Переименовать | В этом случае R-Studio добавит ID к имени файла. Если файл с данным именем и ID уже существует, то к ним будет добавлен номер.
Перезаписать | В этом случае R-Studio запишет новый файл на место старого.
Пропустить | В этом случае R-Studio пропустит при восстановлении все файлы с таким именем.
Поврежденное имя файла | Данные параметры позволяют выбрать действие в том случае, если имя найденного файла неверное.
Предложить действие | В этом случае стандартное диалоговое окно Поврежденное имя файла будет открыто для каждого файла с неверным именем. До получения ответа процесс восстановления будет прерван.
Изменить все неверные символы на: | В этом случае все неверные символы в имени файла будут заменены на указанные символы.
Пропустить | В этом случае R-Studio пропустит при восстановлении все файлы с неверным именем.
Скрытые атрибуты | Данные параметры позволяют выбрать действие в том случае, если у восстановленных файлов имеются скрытые и системные атрибуты
Предложить действие | В этом случае R-Studio предложит пользователю выбрать действие. До получения ответа процесс восстановления будет прерван.
Удалить | В этом случае R-Studio удалит скрытые и системные атрибуты у всех восстановленных файлов.
Хранить | В этом случае R-Studio сохранит скрытые и системные атрибуты у всех восстановленных файлов.


Списки Файлов на Восстановление

Вы можете создать файл со списком файлов и папок найденных не диске/разделе. Такой файл можно редактировать вручную чтобы выбрать файлы для восстановления и потом импортировать обратно в R-Studio. R-Studio автоматически пометит эти файлы для восстановления. Эти списки очень полезны когда надо, чтобы кто-то еще решил, какие файлы восстанавливать, а какие - нет.

Вы можете создать список файлов на восстановление для всего диска или для отдельных папок. Более того, можно создать список файлов на восстановление как для всех файлов диска/папки, так и только для помеченных файлов/папок.

Создание списка файлов на восстановление

Чтобы создать список файлов на восстановление

1 Для всего диска выберите команду Сохранить имена файлов в файл меню Файл или

Щелкните правой кнопкой мыши по самой верхней папке (выше папки Root, обычно по букве или имени диска) и выберите команду Сохранить имена файлов в файл контекстного меню.

Для отдельной папки щелкните по ней правой кнопкой мыши и выберите команду Сохранить имена файлов в файл контекстного меню.

2 Задайти место сохранения списка файлов на восстановление и другие необходимые параметры в диалоговом окне Сохранить имена файлов
Диалоговое окно Сохранить имена файлов

Параметры сохранения Списка Файлов на Восстановление

Имя файла: | Задает имя файла со списком файлов на восстановление.
Сохранить только отмеченные файлы/каталоги с диска | Если установить данный флажок, то в список файлов на восстановление будут включены только отмеченные файлы.
Сохранить подкаталоги | Если установить данный флажок, то в список файлов на восстановление будут также включены подкаталоги и их файлы.
Формат файла: | Задает файловый формат, в котом будут сохранены локализованные имена файлов/папок. Вы можете выбрать кодировку UTF-8 или UTF-16. Также можно записать специальный BOM-заголовок к файлу, с помощью которого некоторые текстовые редакторы смогут правильно определить используемую кодировку.

Структура созданного R-Studio списка файлов на восстановление

Пример файла:

:# PathDelim = \

Files to Delete\

Files to Delete\File_2.pst

Files to Delete\Outlook_recovered_by_R_Mail.pst

Files to Recover\

Files to Recover\$est2.arc

Files to Recover\$est4.arc

Files to Recover\$est5.arc

Files to Recover\$est6.arc

Files to Recover\$est7.arc

Files to Recover\~$pe Test 2.doc

Files to Recover\Outlook.pst

Files to Recover\Outlook_recovered_by_R_Mail.pst

Files to Recover\Picture 113.jpg

Files to Recover\Picture 149.jpg

Files to Recover\Picture 237.jpg

Files to Recover\test1.arc

Files to Recover\test3.arc

Files to Recover\Wipe Test 1.doc

Files to Recover\Wipe Test 2.doc

Files to Recover\Wipe Test 3.doc

Files to Recover\Wipe Test 4.doc

Files to Recover\Wipe Test 5.doc

Files to Recover\Wipe Test 6.doc

:# PathDelim = \ это параметр, определяющий разграничитель в файловом пути. Также можно задать разграничитель формата Unix / .

:# PathDelim = \

:# PathDelim = /

Также файлы из виртуальных каталогов (Metafiles, ExtraFoundFiles и т.д.) имеют следующие обозначения:

Metafiles: | ///m/[localized_name_for_Metafiles]/
Extra Found Files: | ///e/[localized_name_for_ExtraFoundFiles]/
Other Virtual Folders: | ///v/[localized_name_for_OtherVirtualFolders]/

Для английского языка это будет выглядеть следующим образом:

///m/Metafiles\

///m/Metafiles\$BOOT

///m/Metafiles\$FAT

///m/Metafiles\$FAT0

///m/Metafiles\$FAT1

Редактирования файла со списком файлов на восстановление

Все файлы из списка файлов на восстановление будут помечены после того как файл с этим списком будет загружен в R-Studio. Если какие-либо файлы из списка не нужно восстанавливать, то удалите их оттуда. Также можно использовать символы, позволяющие задать следующие параметры

:+ | Пометить все файлы и подкаталоги в каталоге.
:* | Пометить только файлы в каталоге.
:- | Снять пометку с файла или со всех файлов и подкаталогов в каталоге.
:= | Снять пометку с файла или только с файлов в каталоге.

которые применяются в порядке их следования. Например, если в файле если строки

:+Files to Delete\

:-Files to Delete\File_2.pst

то файл File_2.pst не будет помечен для восстановления, в то время как если в файле есть строки

:-Files to Delete\File_2.pst

:+Files to Delete\

то файл File_2.pst помечен будет.

Обратите внимание, что записи для папок без пометок не влияют на помеченный файл. Например, если есть строки

:-Files to Delete\File_2.pst

Files to Delete\

то файл File_2.pst помечен не будет.

Загрузка списка файлов на восстановление

Чтобы загрузить список файлов на восстановление в R-Studio

* Выберите пункт Загрузить имена файлов из файла и отметить меню Файл и выберите файл.
> R-Studio загрузит файл и пометит соответствующие файлы.


Наборы Томов и RAID

R-Studio определяет и обрабатывает аппаратные наборы томов и RAID как обычные диски/тома.

При помощи R-Studio можно анализировать и восстанавливать данные с программных наборов томов и RAID. Если в системе присутствует программный набор томов или RAID и R-Studio распознала его, то соответствующий объект появится на панели Устройство/Диск. Такие объекты можно сканировать, искать на них файлы. Найденные файлы восстанавливаются так же, как с обычных дисков/томов.

Если из-за повреждения аппаратной части или утраты информации система не распознает aппаратный или программный набор томов или RAID , но вам известно, что он существовал и какие в нем были жесткие диски, то можно создать Виртуальный набор томов или RAID , который может быть обработан программой как обычный аппаратный набор томов или RAID или программный набор томов или RAID.

Более подробную информацию о структуре данных RAID можно получить в Wikipedia.

· Простые, Зеркальные и Чередующиеся Тома
· Основные Операции с Томами RAID 4 и RAID 5
· Работа со Сложными Схемами RAID 5
· Работа с Томами RAID 6
· Работа с Сложными Схемами RAID 6
· Проверка Целостности Данных RAID
· Синтаксис Файла Описания Конфигураций RAID
· Файл Описания Конфигураций RAID

Управление собственными конфигурациями RAID

Чтобы сохранить собственную конфигурацию RAID

1 Нажмите кнопку Еще... вкладки Родительские объекты и выберите пункт меню Сохранить.
2 В диалоговом окне Новая конфигурация задайте имя конфигурации.
Диалоговое окно Новая конфигурация
> Созданная конфигурация RAID будет сохранена

Конфигурации RAID хранятся в файле, заданном в диалоговом окне Настройки (вкладка Главная).

Чтобы загрузить конфигурацию RAID

1 Нажмите кнопку Еще... вкладки Родительские объекты и выберите необходимую конфигурацию из списка в пункте Заготовки
> Новая конфигурация RAID будет загружена

Чтобы редактировать собственную конфигурацию RAID

1 Нажмите кнопку Еще... вкладки Родительские объекты и выберите Редактирование... в пункте меню Заготовки
2 Выберите необходимую конфигурацию в диалоговом окне Редактировать конфигурацию RAID.
Диалоговое окно Редактировать конфигурацию RAID
4 Отредактируйте параметры конфигурации и сохраните ее
> Новая конфигурация параметров будет сохранена.


Простые, Зеркальные и Чередующиеся Тома

Чтобы создать Простой Том

1 Нажмите кнопку Создать виртуальный RAID и выберите пункт Создать виртуальный набор томов

или выберите пункт Создать виртуальный набор томов меню Создать

> Объект Виртуальный набор томов появится на панели Диски
2 Перетащите при помощи мыши соответствующие разделы с панели Диски на вкладку Родительские объекты

Другие способы добавить разделы

· Щелкните правой кнопкой мыши на вкладке Родительские объекты и выберите соответствующий раздел из контекстного меню

или

· Щелкните правой кнопкой мыши по соответствующему разделу на панели R-Studio Устройство/Диск , выберите команду контекстного меню Добавить к RAID и выберите RAID, в который вы хотите добавить раздел

Обратите внимание: Разделы должны быть размещены в том же порядке, в котором они были в оригинальном томе. В противном случае вы должны изменить порядок их размещения при помощи мыши.

> Теперь объект Виртуальный набор томов может быть обработан программой как обычные диски/тома

Если R-Studio обнаружит на созданном RAID какую-либо файловую систему, то объект, соответствующий данному разделу, появится на панели Диски.

Чтобы создать Чередующийся Том (RAID 0)

1 Нажмите кнопку Создать виртуальный RAID и выберите пункт Создать виртуальный блочный RAID

или выберите пункт Создать виртуальный блочный RAID меню Создать

> Объект Виртуальный RAID появится на панели Диски
2 Выберите RAID 0 (Stripe set) из раскрывающегося списка Тип RAID панели Родительские объекты
3 Перетащите при помощи мыши соответствующие разделы с панели Диски на вкладку Родительские объекты

Другие способы добавить разделы

· Щелкните правой кнопкой мыши на вкладке Родительские объекты и выберите соответствующий раздел из контекстного меню

или

· Щелкните правой кнопкой мыши по соответствующему разделу на панели R-Studio Устройство/Диск , выберите команду контекстного меню Добавить к RAID и выберите RAID, в который вы хотите добавить раздел

Можно либо сразу обработать сделанные изменения при помощи R-Studio, либо продолжить редактирование схемы RAID. В зависимости от этого установите или снимите флажок Сразу применять изменения на вкладке Родительские объекты. После завершения нажмите кнопку Применить.

Обратите внимание: Разделы должны быть размещены в том же порядке, в котором они были в оригинальном наборе томов. В противном случае вы должны изменить порядок их размещения при помощи мыши.

Кнопки управления объектами RAID

Определить | Нажмите данную кнопку чтобы идентифицировать выбранный объект RAID на панели Диски .
Добавить отсутствующий диск | Нажмите данную кнопку чтобы добавить объект Пропущенный диск/Свободное пространство
Удалить | Нажмите данную кнопку чтобы удалить выбранный объект из конфигурации RAID
Вверх | Нажмите данную кнопку чтобы сместить выбранный объект RAID выше
Вниз | Нажмите данную кнопку чтобы сместить выбранный объект RAID ниже
Синхронизировать смещения | Нажмите данную кнопку чтобы установить одинаковое смещение для всех объектов RAID

Размер и смещение блока RAID (в секторах) должны быть установлены такими же, какими они были в оригинальном наборе томов.

Также вам необходимо задать Порядок блоков. Вы можете это сделать через раскрывающийся список Порядок блоков или через контекстное меню.

Если указанные параметры будут заданы неверно, то данные на родительских объектах повреждены не будут, однако восстановить их не удастся.

> Теперь объект Виртуальный RAID может быть обработан программой как обычные диски/тома

Если R-Studio обнаружит на созданном RAID какую-либо файловую систему, то объект, соответствующий данному разделу, появится на панели Диски.

В разделе Файлы Описания Конфигураций RAID приведен файл, описывающий данную конфигурацию RAID .

Чтобы создать Зеркальный Том (RAID 1)

1 Нажмите кнопку Создать виртуальный RAID и выберите пункт Создать виртуальное зеркало

или выберите пункт Создать виртуальное зеркало меню Создать

> Объект Виртуальный зеркальный том появится на панели Диски
2 Перетащите при помощи мыши соответствующие разделы с панели Диски на вкладку Родительские объекты

Другие способы добавить разделы

· Щелкните правой кнопкой мыши на вкладке Родительские объекты и выберите соответствующий раздел из контекстного меню

или

· Щелкните правой кнопкой мыши по соответствующему разделу на панели R-Studio Устройство/Диск , выберите команду контекстного меню Добавить к RAID и выберите RAID, в который вы хотите добавить раздел

Обратите внимание: Разделы должны быть размещены в том же порядке, в котором они были в оригинальном томе. В противном случае вы должны изменить порядок их размещения при помощи мыши.

> Теперь объект Виртуальный зеркальный том может быть обработан программой как обычные диски/тома

Если R-Studio обнаружит на созданном RAID какую-либо файловую систему, то объект, соответствующий данному разделу, появится на панели Диски.


Основные Операции с Томами RAID 4 и RAID 5

Тома RAID 4 и RAID 5 во многом схожи. Создание и редактирования тома RAID 4 происходит так же, как тома RAID 5.

Чтобы создать Том RAID 5

1 Нажмите кнопку Создать виртуальный RAID и выберите пункт Создать виртуальный блочный RAID

или выберите пункт Создать виртуальный блочный RAID меню Создать

> Объект Виртуальный RAID появится на панели Диски
2 Выберите RAID 5 из раскрывающегося списка Тип RAID панели Родительские объекты
3 Перетащите при помощи мыши соответствующие разделы с панели Диски на вкладку Родительские объекты

Другие способы добавить разделы

· Щелкните правой кнопкой мыши на вкладке Родительские объекты и выберите соответствующий раздел из контекстного меню

или

· Щелкните правой кнопкой мыши по соответствующему разделу на панели R-Studio Устройство/Диск , выберите команду контекстного меню Добавить к RAID и выберите RAID, в который вы хотите добавить раздел

Можно либо сразу обработать сделанные изменения при помощи R-Studio, либо продолжить редактирование схемы RAID. В зависимости от этого установите или снимите флажок Сразу применять изменения на вкладке Родительские объекты. После завершения нажмите кнопку Применить.

Обратите внимание: Разделы должны быть размещены в том же порядке, в котором они были в оригинальном наборе томов. В противном случае вы должны изменить порядок их размещения при помощи мыши.

Кнопки управления объектами RAID

Определить | Нажмите данную кнопку чтобы идентифицировать выбранный объект RAID на панели Диски .
Добавить отсутствующий диск | Нажмите данную кнопку чтобы добавить объект Пропущенный диск/Свободное пространство
Удалить | Нажмите данную кнопку чтобы удалить выбранный объект из конфигурации RAID
Вверх | Нажмите данную кнопку чтобы сместить выбранный объект RAID выше
Вниз | Нажмите данную кнопку чтобы сместить выбранный объект RAID ниже
Синхронизировать смещения | Нажмите данную кнопку чтобы установить одинаковое смещение для всех объектов RAID

Размер и смещение блока RAID (в секторах) должны быть установлены такими же, какими они были в оригинальном наборе томов.

Также вам необходимо задать порядок Блоков виртуального тома RAID5. Вы можете это сделать через раскрывающийся список Порядок блоков или через контекстное меню.

Если указанные параметры будут заданы неверно, то данные на родительских объектах повреждены не будут, однако восстановить их не удастся.

Обратите внимание: Вы можете проверить, насколько корректно вы восстановили оригинальный набор томов или RAID. Найдите файл и откройте его в просмоторщике. Если файл имеет правильное содержимое, то значит схема RAID создана правильно.

Если ваш виртуальный том RAID5 имеет какую-либо нестандартную конфигурацию, то вы можете создать их сами. Более подробно смотри в разделе Работа со сложными схемами RAID 5.

> Теперь объект Виртуальный RAID может быть обработан программой как обычные диски/тома

Если R-Studio обнаружит на созданном RAID какую-либо файловую систему, то объект, соответствующий данному разделу, появится на панели Диски.

В разделе Файлы Описания Конфигураций RAID приведен файл, описывающий данную конфигурацию RAID.

Подключение и Отключение Дисков "на лету"

Пользователь может включить/отключить объект в/из состава виртуального RAID или набора томов, установив/сняв соответствующий флажок на вкладке Родительские объекты. Данная возможность позволяет, например, проверить, какой диск на самом деле не является частью RAID5.

R-Studio заменяет отключенный объект объектом Пропущенный диск или Свободное пространство.

Пропущенные Диски и Свободное Пространство

При отсутствии по какой-либо причине (например, из-за повреждения аппаратной части) раздела на аппаратном или программном наборе томов или RAID вам необходимо добавить виртуальный объект пропущенный диск или свободное пространство, чтобы корректно реконструировать аппаратный или программный набор томов или RAID. Пропущенный диск/свободное пространство должны быть размещены в том же месте, где и недостающий раздел.

Обратите внимание: R-Studio никогда не модифицирует что-либо на диске. Свободное пространство является чисто виртуальным объектом, не оказывающим какого-либо влияния на реальные данные на дисках.

Чтобы добавить объект Пропущенный диск/Свободное пространство

1 Выберите объект Виртуальные наборы томов и RAID на панели R-Studio Диски
2 Щелкните правой кнопкой мыши на вкладке Родительские объекты в правой части окна и выберите пункт Добавить отсутствующий диск или Добавить свободное пространство котекстного меню или меню Создать. R-Studio автоматически определит, какой необходим тип объекта.

Для объекта Свободное пространство задайте его размер в диалоговом окне Размер свободного пространства.

Диалоговое окно Размер свободного пространства
> Объект Пропущенный диск или Свободное пространство появится на вкладке Родительские объекты

Создание и сохранение собственной конфигурации RAID

Пользователь может создавать и сохранять собственные конфигурации для нестандартных RAID. Вы можете задать Смещение, Порядок/Размер блока и Число строк. Более подробно смотри в разделе Работа со сложными схемами RAID 5.


Работа со Сложными Схемами RAID 5

R-Studio позволяет создавать и обрабатывать достаточно сложные пользовательские схемы RAID 5.

Например, создадим RAID 5 следующей конфигурации:

· 3 диска,
· Размер блока: 64 КБ
· Смещение: 32768 секторов (64 КБ)
· Порядок блоков:
 | A | B | C
1 | PD | 1 | 2
2 | PD | 3 | 4
3 | PD | 5 | 6
4 | 7 | PD | 8
5 | 9 | PD | 10
6 | 11 | PD | 12
7 | 13 | 14 | PD
8 | 15 | 16 | PD
9 | 17 | 18 | PD

Чтобы создать такой RAID 5

1 Нажмите кнопку Создать виртуальный RAID и выберите Создать виртуальный блочный RAID

или выберите пункт Создать виртуальный блочный RAID меню Создать

Проверьте, чтобы флажок Сразу применять изменения на вкладке Родительские объекты был снят. Это не позволит R-Studio начать обработку RAID до завершения его создания.

2 Перетащите при помощи мыши необходимые объекты с панели Диски на вкладку Родительские объекты и выберите RAID 5 из раскрывающегося списка Тип RAID панели Родительские объекты

Другие способы добавить объекты

· Щелкните правой кнопкой мыши на вкладке Родительские объекты и выберите соответствующий раздел из контекстного меню

или

· Щелкните правой кнопкой мыши по соответствующему разделу на панели R-Studio Устройство/Диск , выберите команду контекстного меню Добавить к RAID и выберите RAID, в который вы хотите добавить раздел

Этими объектами могут быть жесткие диски, логические диски или образы. Проверьте, чтобы объекты были в правильном порядке.

Кнопки управления объектами RAID

Определить | Нажмите данную кнопку чтобы идентифицировать выбранный объект RAID на панели Диски .
Добавить отсутствующий диск | Нажмите данную кнопку чтобы добавить объект Пропущенный диск/Свободное пространство
Удалить | Нажмите данную кнопку чтобы удалить выбранный объект из конфигурации RAID
Вверх | Нажмите данную кнопку чтобы сместить выбранный объект RAID выше
Вниз | Нажмите данную кнопку чтобы сместить выбранный объект RAID ниже
Синхронизировать смещения | Нажмите данную кнопку чтобы установить одинаковое смещение для всех объектов RAID

3 Задайте параметры Размер блока и Смещение на вкладке Родительские объекты

Не изменяйте значение параметра Порядок блоков.

4 В поле Число строк на вкладке Родительские объекты введите значение 9

Значение параметра Порядок блоков изменится на Пользовательский.

5 Задайте порядок блоков при помощи таблицы на вкладке Родительские объекты

Воспользуйтесь окном Последовательности RAID для перехода от одного ряда к другому.

При помощи клавиатуры: используйте клавиши управления курсором для навигации, цифровые клавиши и клавишу "p" для ввода соответствующих значений.

При помощи мыши: щелкнуть правой кнопкой мыши по необходимой ячейке и выбрать из контекстного меню соответствующее значение или четность. Если таблица достаточно большая, то лучше вводить цифровые значения при помощи клавиатуры.

Замечание: Если вы ввели некоторые значения неверно, то R-Studio укажет вам на это. Перейдите к соответствующей ячейке и введите правильное значение. Для удаления содержимого ячейки используйте клавишу Delete.

Удаление содержимого всей таблицы: Щелкните правой кнопкой мыши по таблице и выберите пункт контекстного меню Очистить все.

6 Закончив заполнение таблицы, нажмите кнопку Применить на вкладке Родительские объекты
> Теперь созданный объект Виртуальный RAID 1 может быть обработан программой как обычные диски/тома

Если R-Studio обнаружит на созданном RAID какую-либо файловую систему, то объект, соответствующий данному разделу, появится на панели Диски.

В разделе Файлы Описания Конфигураций RAID приведен файл, описывающий данную конфигурацию RAID.


Работа с Томами RAID 6

R-Studio позволяет создавать и обрабатывать схемы RAID 6. Можно использовать как имеющиеся пресеты для нескольких схем RAID 6, так и собственные.

В R-Studio имеются пресеты для следующих типичных схем RAID 6:

Reed-Solomon

Левый Синхронный (стандартный),

Левый Асинхронный (непрерывный),

Правый Синхронный

Правый Асинхронный

Vertical Xor

EVEBODD

RAID DP

X-Code(2)

X-Code(3)

Также вы можете создавать собственные конфигурации RAID 6.

Создание объекта RAID 6 на основании пресета

В качестве примера используем пресет Reed-Solomon (Левый Синхронный (стандартный)).

Чтобы создать Том RAID 6

1 Нажмите кнопку Создать виртуальный RAID и выберите пункт Создать виртуальный блочный RAID

или выберите пункт Создать виртуальный блочный RAID меню Создать

> Объект Виртуальный RAID появится на панели Диски
2 Выберите RAID 6/Reed-Solomon из раскрывающегося списка Тип RAID панели Родительские объекты
3 Перетащите при помощи мыши соответствующие разделы с панели Диски на вкладку Родительские объекты

Другие способы добавить разделы

· Щелкните правой кнопкой мыши на вкладке Родительские объекты и выберите соответствующий раздел из контекстного меню

или

· Щелкните правой кнопкой мыши по соответствующему разделу на панели R-Studio Устройство/Диск , выберите команду контекстного меню Добавить к RAID и выберите RAID, в который вы хотите добавить раздел

Можно либо сразу обработать сделанные изменения при помощи R-Studio, либо продолжить редактирование схемы RAID. В зависимости от этого установите или снимите флажок Сразу применять изменения на вкладке Родительские объекты. После завершения нажмите кнопку Применить.

Обратите внимание: Разделы должны быть размещены в том же порядке, в котором они были в оригинальном наборе томов. В противном случае вы должны изменить порядок их размещения при помощи мыши.

Кнопки управления объектами RAID

Определить | Нажмите данную кнопку чтобы идентифицировать выбранный объект RAID на панели Диски .
Добавить отсутствующий диск | Нажмите данную кнопку чтобы добавить объект Пропущенный диск/Свободное пространство
Удалить | Нажмите данную кнопку чтобы удалить выбранный объект из конфигурации RAID
Вверх | Нажмите данную кнопку чтобы сместить выбранный объект RAID выше
Вниз | Нажмите данную кнопку чтобы сместить выбранный объект RAID ниже
Синхронизировать смещения | Нажмите данную кнопку чтобы установить одинаковое смещение для всех объектов RAID

Размер и смещение блока RAID (в секторах) должны быть установлены такими же, какими они были в оригинальном наборе томов.

Также вам необходимо задать порядок Блоков (в нашем случае Левый Синхронный (стандартный)) виртуального тома RAID6. Вы можете это сделать через раскрывающийся список Порядок блоков или через контекстное меню.

Если указанные параметры будут заданы неверно, то данные на родительских объектах повреждены не будут, однако восстановить их не удастся.

Обратите внимание: Вы можете проверить, насколько корректно вы восстановили оригинальный набор томов или RAID. Найдите файл и откройте его в просмоторщике. Если файл имеет правильное содержимое, то значит схема RAID создана правильно.

> Теперь объект Виртуальный RAID 1 может быть обработан программой как обычные диски/тома

Если R-Studio обнаружит на созданном RAID какую-либо файловую систему, то объект, соответствующий данному разделу, появится на панели Диски. В разделе Файлы Описания Конфигураций RAID приведен файл, описывающий данную конфигурацию RAID..


Работа со Сложными Схемами RAID 6

R-Studio позволяет создавать и обрабатывать достаточно сложные пользовательские схемы RAID 6.

Например, создадим RAID 6 следующей конфигурации:

· 5 дисков,
· Размер блока: 64 КБ
· Смещение: 0
· Порядок блоков:
 | A | B | C | D | E
1 | RS | 1 | 2 | 3 | PD
2 | 4 | 5 | 6 | PD | RS
3 | 8 | 9 | PD | RS | 7
4 | 12 | PD | RS | 10 | 11
5 | PD | RS | 13 | 14 | 15
6 | PA | PA | PA | PA | PA

где

PD - четность данных;

PA - четность всего;

RS - Reed-Solomon;

В рядах с 1 по 5 используются два типа коррекции ошибок: по четности данных (xor) и Reed-Solomon. То есть, для ряда 1 используются блоки A1 и E1, для ряда 2 - D2 и E2 и т.д.

Ряд 6 используется для коррекции ошибок в колонках. То есть, для колонки A используется блок A6, для колонки B - B6 и т.д. Для коррекции ошибок используется тип четности всего.

1 Нажмите кнопку Создать виртуальный RAID и выберите Создать виртуальный блочный RAID

или выберите пункт Создать виртуальный блочный RAID меню Создать

Проверьте, чтобы флажок Сразу применять изменения на вкладке Родительские объекты был снят. Это не позволит R-Studio начать обработку RAID до завершения его создания.

2 Перетащите при помощи мыши необходимые объекты с панели Диски на вкладку Родительские объекты и выберите Пользовательский из раскрывающегося списка Тип RAID панели Родительские объекты

Другие способы добавить объекты

· Щелкните правой кнопкой мыши на вкладке Родительские объекты и выберите соответствующий раздел из контекстного меню

или

· Щелкните правой кнопкой мыши по соответствующему разделу на панели R-Studio Устройство/Диск , выберите команду контекстного меню Добавить к RAID и выберите RAID, в который вы хотите добавить раздел

Этими объектами могут быть жесткие диски, логические диски или образы. Проверьте, чтобы объекты были в правильном порядке.

Кнопки управления объектами RAID

Определить | Нажмите данную кнопку чтобы идентифицировать выбранный объект RAID на панели Диски .
Добавить отсутствующий диск | Нажмите данную кнопку чтобы добавить объект Пропущенный диск/Свободное пространство
Удалить | Нажмите данную кнопку чтобы удалить выбранный объект из конфигурации RAID
Вверх | Нажмите данную кнопку чтобы сместить выбранный объект RAID выше
Вниз | Нажмите данную кнопку чтобы сместить выбранный объект RAID ниже
Синхронизировать смещения | Нажмите данную кнопку чтобы установить одинаковое смещение для всех объектов RAID
3 Задайте параметры Размер блока и Смещение на вкладке Родительские объекты

Не изменяйте значение параметра Порядок блоков.

4 В поле Число строк на вкладке Родительские объекты введите значение 6
5 Задайте порядок блоков при помощи таблицы на вкладке Родительские объекты

Вы можете ввести либо номер блока, либо блок коррекции ошибок одного из следующих типов:

PD | Четность данных
PA | Четность всего
RS | Reed-Solomon
U | Неизвестный (Unknown)
I | Игнорировать (Ignore)

Обратите внимание: вы должны задать блок коррекции ошибок только после выбора корректной последовательности в окне Последовательности RAID .

При помощи клавиатуры: используйте клавиши управления курсором для навигации; цифровые клавиши, клавиши rs, pd, pa, u и i для ввода порядка блоков.

При помощи мыши: щелкнуть правой кнопкой мыши по необходимой ячейке и выбрать из контекстного меню соответствующее значение или четность. Если таблица достаточно большая, то лучше вводить цифровые значения при помощи клавиатуры.

Для рядов:

Выберите необходимую последовательность рядов в окне Последовательности RAID, выберите ячейку в таблице RAID и введите необходимую величину. R-Studio автоматически генерирует эти последовательности при добавлении родительских объектов RAID.

Для колонок и произвольных последовательностей:

Вы должны сами создать такие последовательности и добавить соответствующие блоки.

Чтобы создать последовательность: нажмите кнопку Добавить пустой в окне Последовательности RAID или выберите пункт Создать новую последовательность контекстного меню на вкладке Родительские объекты.

Чтобы добавить блок к последовательности: щелкните правой кнопкой мыши по соответствующей ячейке и выберите пункт Добавить к последовательности контекстного меню на вкладке Родительские объекты.

Чтобы удалить блок из последовательности: щелкните правой кнопкой мыши по соответствующей ячейке и выберите пункт Удалить из последовательности контекстного меню на вкладке Родительские объекты.

6 Закончив заполнение таблицы, нажмите кнопку Применить на вкладке Родительские объекты
> Теперь созданный объект Виртуальный RAID может быть обработан программой как обычные диски/тома

Если R-Studio обнаружит на созданном RAID какую-либо файловую систему, то объект, соответствующий данному разделу, появится на панели Диски.

В разделе Файлы Описания Конфигураций RAID приведен файл, описывающий данную конфигурацию RAID.


Проверка Целостности Данных RAID

Вы можете проверить целостность данных RAID (правильность блоков четности на RAID).

Чтобы проверить целостность данных RAID

* Щелкните правой кнопкой мыши по RAID и выберите пункт Проверить корректность RAID... контекстного меню
> Откроется окно Проверка корректности RAID, в котором будет отображаться ход выполнения (прогресс) операции.
Окно Проверка корректности RAID

После окончания проверки можно просмотреть ее результаты.

Цвет блока |
Зеленый | Блок четности RAID корректен.
Красный | Блок четности RAID некорректен.
Белый | 0

Если подвести указатель мыши к блоку, то можно будет увидеть номера находящихся в нем секторов, а также число корректных и некорректных секторов. Если дважды щелкнуть по блоку мышью, то он сместится в левый верхний угол и масштаб данных увеличится а 2 раза.

Элементы управления окна Проверка корректности RAID

Секторы | Номер первого сектора в ряде.
Смещение | Смещение данных. Введите адрес, к которому вы хотите перейти, и нажмите клавишу Enter.
Sectors/Bytes/KB... | Задает размерность данных поля Смещение.
Предыдущий/Далее | Переход к предыдущей/следующей порции данных.
+/- | Увеличение/уменьшение масштаба данных.


Синтаксис Файла Описания Конфигураций RAID

Пользователь может создавать и сохранять собственные конфигурации RAID. Синтаксис файлов таких конфигураций схож с языком XML. Они хранятся в файлах .xml.

Примеры файлов конфигурации RAID приведены в разделе Файлы Описания Конфигураций RAID .

Пример файла конфигурации RAID

<RAIDList>

<RAID name="RAID6Complex" parents="5" rows="6" blocksize="16777216">

<Table>

<Block id="A1">ReedSolomon</Block>

<Block id="B1">1</Block>

<Block id="C1">2</Block>

<Block id="D1">3</Block>

<Block id="E1">XorOfData</Block>

<Block id="A2">4</Block>

<Block id="B2">5</Block>

<Block id="C2">6</Block>

<Block id="D2">XorOfData</Block>

<Block id="E2">ReedSolomon</Block>

<Block id="A3">8</Block>

<Block id="B3">9</Block>

<Block id="C3">XorOfData</Block>

<Block id="D3">ReedSolomon</Block>

<Block id="E3">7</Block>

<Block id="A4">12</Block>

<Block id="B4">XorOfData</Block>

<Block id="C4">ReedSolomon</Block>

<Block id="D4">10</Block>

<Block id="E4">11</Block>

<Block id="A5">XorOfData</Block>

<Block id="B5">ReedSolomon</Block>

<Block id="C5">13</Block>

<Block id="D5">14</Block>

<Block id="E5">15</Block>

<Block id="A6" sequence="1">XorOfAll</Block>

<Block id="B6" sequence="2">XorOfAll</Block>

<Block id="C6" sequence="3">XorOfAll</Block>

<Block id="D6" sequence="4">XorOfAll</Block>

<Block id="E6" sequence="5">XorOfAll</Block>

</Table>

<Sequences>

<Sequence id="1">A1 A2 A3 A4 A5 A6</Sequence>

<Sequence id="2">B1 B2 B3 B4 B5 B6</Sequence>

<Sequence id="3">C1 C2 C3 C4 C5 C6</Sequence>

<Sequence id="4">D1 D2 D3 D4 D5 D6</Sequence>

<Sequence id="5">E1 E2 E3 E4 E5 E6</Sequence>

</Sequences>

</RAID>

</RAIDList>

Структура файла

Заголовок Файла

Файл начинается со стандартного заголовка XML

<?xml version="1.0" encoding="utf-8"?>

Элемент RAIDList

<RAIDList>

Данный элемент может содержать любое число элементов <RAID>; в конце обязательно должен находиться закрывающий тег </RAIDList>

Пример структуры элемента:

<RAIDList>

<RAID [attributes]>

...

</RAID>

...

<RAID [attributes]>

...

</RAID>

Элемент RAID

Данный элемент описывает схему RAID.

Он должен содержать по крайней мере один элемент <Table> , а также может содержать один блок <Sequences> и один блок <Offset> .

Атрибуты:

name | <string> | Необязательный | Название схемы RAID
parents | <u16> | Обязательный | Число родительских объектов
rows | <u16> | Обязательный | Число рядов в таблице схемы RAID
blocksize | <u32> | Обязательный | Размер блока RAID в байтах

Пример структуры элемента:

<RAIDList>

<RAID name="example" parents="2" rows="2" blocksize="16777216">

<Table>

...

</Table>

<Sequences>

...

</Sequences>

<Offsets>

...

</Offsets>

</RAID>

</RAIDList>

Элемент Table

Данный элемент описывает таблицу схемы RAID. Он содержит элементы <Block>, число которых определяется двумя атрибутами элемента <RAID> : <parents>x<rows>.

Пример структуры элемента:

<RAIDList>

<RAID name="example" parents="2" rows="2" blocksize="16777216">

<Table>

<Block [attributes]> ... </Block>

<Block [attributes]> ... </Block>

<Block [attributes]> ... </Block>

<Block [attributes]> ... </Block>

</Table>

</RAID>

</RAIDList>

Элемент Block

Данный элемент задает номер блока в таблице схемы RAID (целое положительное число) или блок коррекции ошибок одного из следующих типов:

· PD или ParityOfData
· PA или ParityOfAll
· RS или ReedSolomon
· U или Unknown
· I или Ignore

Любое другое значение обрабатывается как Unknown .

Атрибуты:

id | <string> | Обязательный | Буквенно-цифровой идентификатор блока в таблице схемы RAID. Элемент в третьей колонке второго ряда обозначается как C2. После Z используется AA и т.д.
sequence | <u16> или row | Необязательный | Идентификатор последовательности. Атрибут должен быть задан только для блоков контрольной суммы последовательностей, описанных в элементе <Sequences>. По умолчанию: row

Элемент Sequences

Данный элемент описывает данные контрольной суммы последовательностей, используемые для сохранения целостности данных. Он может содержать любое число элементов <Sequence>.

Пример структуры элемента:

<RAIDList>

<RAID name="example" parents="4" rows="4" blocksize="16777216">

<Table>

...

</Table>

<Sequences>

<Sequence [attributes]> ... </Sequence>

...

<Sequence [attributes]> ... </Sequence>

</Sequences>

</RAID>

</RAIDList>

Элемент Sequence

Данный элемент содержит список принадлежащих последовательности блоков RAID, разделенных пробелом.

Атрибуты:

id

<u16>

Обязательный

Идентификатор последовательности

Пример элемента:

Смотри в разделе Пример файла конфигурации RAID .

Элемент Offsets

Данный элемент описывает смещения каждого родительского объекта. Он содержит элементы <Offset>, число которых не должно превышать значение атрибута parents элемента <RAID>. Если элемент <Offsets> отсутствует, то это означает, что смещения равны нулю.

Пример структуры элемент:

<RAIDList>

<RAID name="example" parents="4" rows="4" blocksize="16777216">

<Table>

...

</Table>

<Offsets>

<Offset [attributes]> ... </Offset>

<Offset [attributes]> ... </Offset>

<Offset [attributes]> ... </Offset>

<Offset [attributes]> ... </Offset>

</Offsets>

</RAID>

</RAIDList>

Элемент Offset

Данный элемент задает смещение родительского объекта в байтах.

Атрибуты:

id

<u16>

Обязательный

Идентификатор родительского объекта RAID (от 1 до атрибута parents элемента <RAID>).

Пример элемента:

<RAIDList>

<RAID name="example" parents="4" rows="4" blocksize="16777216">

<Table>

...

</Table>

<Offsets>

<Offset id="1"> 0x00100</Offset>

<Offset id="3"> 0x01000</Offset>

</Offsets>

</RAID>

</RAIDList>

Комментарии

<!-- Comment string -->

Стандартная строка комментария XML .


Файлы Описания Конфигураций RAID

Ниже приведены примеры файлов, описывающих конфигурацию RAID из главы Наборы Томов и RAID . Их синтаксис описан в разделе Синтаксис Файла Описания Конфигураций RAID .

Чередующийся Том

Схема чередующегося тома описана в разделе Простые, Зеркальные и Чередующиеся Тома

<?xml version="1.0" encoding="UTF-8" ?>

<RAIDList>

<RAID name="StripeSet" parents="2" rows="2" blocksize="16777216">

<Table>

<Block id="A1">1</Block>

<Block id="B1">2</Block>

<Block id="A2">3</Block>

<Block id="B2">4</Block>

</Table>

</RAID>

</RAIDList>

Том RAID 5

Схема тома RAID описана в разделе Основные Операции с Томами RAID 4 и RAID 5

<?xml version="1.0" encoding="UTF-8" ?>

<RAIDList>

<RAID name="RAID5Layout" parents="3" rows="3" blocksize="16777216">

<Table>

<Block id="A1">1</Block>

<Block id="B1">2</Block>

<Block id="C1">XorOfData</Block>

<Block id="A2">3</Block>

<Block id="B2">XorOfData</Block>

<Block id="C2">4</Block>

<Block id="A3">XorOfData</Block>

<Block id="B3">5</Block>

<Block id="C3">6</Block>

</Table>

</RAID>

</RAIDList>

Сложный том RAID 5

Схема тома RAID описана в разделе Работа со Сложными Схемами RAID 5

<?xml version="1.0" encoding="UTF-8" ?>

<RAIDList>

<RAID name="RAID5Complex" parents="3" rows="9" blocksize="16777216">

<Table>

<Block id="A1">XorOfData</Block>

<Block id="B1">1</Block>

<Block id="C1">2</Block>

<Block id="A2">XorOfData</Block>

<Block id="B2">3</Block>

<Block id="C2">4</Block>

<Block id="A3">XorOfData</Block>

<Block id="B3">5</Block>

<Block id="C3">6</Block>

<Block id="A4">7</Block>

<Block id="B4">XorOfData</Block>

<Block id="C4">8</Block>

<Block id="A5">10</Block>

<Block id="B5">XorOfData</Block>

<Block id="C5">9</Block>

<Block id="A6">11</Block>

<Block id="B6">XorOfData</Block>

<Block id="C6">12</Block>

<Block id="A7">13</Block>

<Block id="B7">14</Block>

<Block id="C7">XorOfData</Block>

<Block id="A8">15</Block>

<Block id="B8">16</Block>

<Block id="C8">XorOfData</Block>

<Block id="A9">17</Block>

<Block id="B9">18</Block>

<Block id="C9">XorOfData</Block>

</Table>

<Offsets>

<Offset id="1">16777216</Offset>

<Offset id="2">16777216</Offset>

<Offset id="3">16777216</Offset>

</Offsets>

</RAID>

</RAIDList>

Том RAID 6, Пресет Reed-Solomon (Левый Синхронный (Стандартный))

Схема тома RAID описана в разделе Работа с Томами RAID 6

<?xml version="1.0" encoding="UTF-8" ?>

<RAIDList>

<RAID name="RAID6RS" parents="5" rows="5" blocksize="16777216">

<Table>

<Block id="A1">ReedSolomon</Block>

<Block id="B1">1</Block>

<Block id="C1">2</Block>

<Block id="D1">3</Block>

<Block id="E1">XorOfData</Block>

<Block id="A2">4</Block>

<Block id="B2">5</Block>

<Block id="C2">6</Block>

<Block id="D2">XorOfData</Block>

<Block id="E2">ReedSolomon</Block>

<Block id="A3">8</Block>

<Block id="B3">9</Block>

<Block id="C3">XorOfData</Block>

<Block id="D3">ReedSolomon</Block>

<Block id="E3">7</Block>

<Block id="A4">12</Block>

<Block id="B4">XorOfData</Block>

<Block id="C4">ReedSolomon</Block>

<Block id="D4">10</Block>

<Block id="E4">11</Block>

<Block id="A5">XorOfData</Block>

<Block id="B5">ReedSolomon</Block>

<Block id="C5">13</Block>

<Block id="D5">14</Block>

<Block id="E5">15</Block>

</Table>

</RAID>

</RAIDList>

Сложный том RAID 6

Схема тома RAID описана в разделе Работа со Сложными Схемами RAID 6

<RAIDList>

<RAID name="RAID6Complex" parents="5" rows="6" blocksize="16777216">

<Table>

<Block id="A1">ReedSolomon</Block>

<Block id="B1">1</Block>

<Block id="C1">2</Block>

<Block id="D1">3</Block>

<Block id="E1">XorOfData</Block>

<Block id="A2">4</Block>

<Block id="B2">5</Block>

<Block id="C2">6</Block>

<Block id="D2">XorOfData</Block>

<Block id="E2">ReedSolomon</Block>

<Block id="A3">8</Block>

<Block id="B3">9</Block>

<Block id="C3">XorOfData</Block>

<Block id="D3">ReedSolomon</Block>

<Block id="E3">7</Block>

<Block id="A4">12</Block>

<Block id="B4">XorOfData</Block>

<Block id="C4">ReedSolomon</Block>

<Block id="D4">10</Block>

<Block id="E4">11</Block>

<Block id="A5">XorOfData</Block>

<Block id="B5">ReedSolomon</Block>

<Block id="C5">13</Block>

<Block id="D5">14</Block>

<Block id="E5">15</Block>

<Block id="A6" sequence="1">XorOfAll</Block>

<Block id="B6" sequence="2">XorOfAll</Block>

<Block id="C6" sequence="3">XorOfAll</Block>

<Block id="D6" sequence="4">XorOfAll</Block>

<Block id="E6" sequence="5">XorOfAll</Block>

</Table>

<Sequences>

<Sequence id="1">A1 A2 A3 A4 A5 A6</Sequence>

<Sequence id="2">B1 B2 B3 B4 B5 B6</Sequence>

<Sequence id="3">C1 C2 C3 C4 C5 C6</Sequence>

<Sequence id="4">D1 D2 D3 D4 D5 D6</Sequence>

<Sequence id="5">E1 E2 E3 E4 E5 E6</Sequence>

</Sequences>

</RAID>

</RAIDList>


Восстановление Данных по Сети

В данной главе рассказывается о том, как восстанавливать данные по сети.

Сетевые возможности R-Studio позволяют системному администратору на одном хосте быстро и легко восстановить файлы с многочисленных сетевых компьютеров.

R-Studio поддерживает протокол TCP/IP или любой другой, поддерживаемый в Microsoft Network.

R-Studio Agent инсталлируется на удаленный компьютер, когда необходимо восстановить файлы по сети. Данная вспомогательная утилита позволяет R-Studio получить доступ к локальным дискам удаленных компьютеров по сети.

Если необходимо восстановить данные по сети с удаленного компьютера, на котором не загружается Windows по причине повреждения загрузочного раздела или системных файлов, то для загрузки удаленного компьютера можно использовать вспомогательную утилиту R-Studio Agent Emergency .

Файлы с доступного по сети удаленного компьютера могут быть восстановлены без использования R-Studio Agent , если на обоих компьютерах установлены WinNT/2000/XP/2003/Vista/Windows 7. В этом случае пользователь должен обладать правами администратора на удаленном компьютере.

Все передаваемые по сети данные зашифрованы при помощи надежного алгоритма. Восстановление данных по сети аналогично восстановлению данных на локальном компьютере.

· R-Studio Agent
· Восстановление Данных по Сети
· Подключение через Интернет


R-Studio Agent

R-Studio Agent инсталлируется на удаленный компьютер, когда необходимо восстановить данные по сети и позволяет R-Studio получить доступ к локальным дискам удаленного компьютера. R-Studio Agent должен быть зарегистрирован.

Если на удаленном компьютере, с которого необходимо восстановить данные, не загружается Windows по причине повреждения загрузочного раздела или системных файлов, то вы можете воспользоваться R-Studio Agent Emergency для его загрузки.

Внимание пользователей Windows NT/2000/XP/2003/Vista/Windows 7: для инсталляции R-Studio Agent необходима учетная запись с правами администратора.

После инсталляции R-Studio Agent запускается автоматически как служба. Для настройки необходимо запустить R-Studio Agent вручную.

Возможны следующие ключи запуска:

-? | вызов справки;
-install | инсталлирует R-Studio Agent как службу
-remove | удаляет службу R-Studio Agent
-console | запускает R-Studio Agent как консольное приложение

Если R-Studio Agent запустить без ключа, то он запускается как приложение и его значок будет находиться в системном лотке Windows. В этом режиме можно просмотреть журнал и настроить R-Studio Agent.

Подключитесь к удаленному компьютеру, введя пароль R-Studio Agent в диалоговом окне Подключение к удаленному компьютеру. R-Studio проверит, запущен ли на удаленном компьютере R-Studio Agent. Если он не запущен, то появится сообщение Невозможно подключиться к... .

Нажмите кнопку Да, и R-Studio инсталлирует R-Studio Agent с локального компьютера на удаленный по сети.

Внимание пользователей Windows NT/2000/XP/2003/Vista/Windows 7: R-Studio Agent может быть инсталлирован с локального компьютера на удаленный по сети, если на обоих компьютерах установлены Windows NT/2000/XP/2003/Vista/Windows 7. В этом случае пользователь должен обладать правами администратора на обоих компьютерах.

Чтобы открыть главное окно R-Studio Agent

1 Щелкните левой кнопкой мыши по его значку в системном лотке
> Откроется главное окно. Вы можете просмотреть журнал
Главное окно R-Studio Agent

Чтобы настроить R-Studio Agent

1 Щелкните правой кнопкой мыши по его значку в системном лотке и выберите пункт Настроить
2 Задайте необходимые параметры в диалоговом окне Пожалуйста настройте R-Studio Agent и нажмите кнопку OK
Диалоговое окно Пожалуйста настройте R-Studio Agent

Параметры R-Studio Agent

Пароль: | Введите пароль, чтобы получить доступ к компьютеру по сети.
Ввести Повторно: | Введите пароль повторно.
Принятые Протоколы
Каналы | поддерживается только Windows NT/2000/XP/2003. Для более высокой степени безопасности данный параметр необходимо отключить.
TCP/IP | поддерживается любой сетевой ОС.
Порт | порт для входящих соединений
Принятые IP Адреса
Адрес IP | задает адреса IP компьютеров, с которых можно подключиться к данному компьютеру.
Маска Подсети | задает маску подсети компьютеров, с которых можно подключиться к данному компьютеру.
> После этого R-Studio Agent будет запущен с заданными параметрами


Восстановление Данных по Сети

Восстановление данных по сети аналогично восстановлению данных на локальном компьютере.

Для получения доступа к удаленным компьютерам, с которых восстанавливаются файлы, на них необходимо инсталлировать и запустить R-Studio Agent .

Чтобы подключиться к удаленному компьютеру

1 Нажмите кнопку Удаленное подключение или выберите пункт Удаленное подключение меню Диск

Список доступных по сети компьютеров появится в Списке компьютеров диалогового окна Подключение к удаленному компьютеру.

Диалоговое окно Подключение к удаленному компьютеру
2 Выберите компьютер из списка в диалоговом окне Подключение к удаленному компьютеру и введите пароль

Вы также можете задать в поле Компьютер: имя или IP адрес удаленного компьютера, на котором необходимо восстановить данные. Порт должен соответствовать порту, заданному в R-Studio Agent.

В поле Пароль: необходимо ввести пароль, заданный в R-Studio Agent на удаленном компьютере.

Обратите внимание: Оставьте поле Пароль: незаполненным, если на удаленном компьютере запущен R-Studio Agent Emergency .

> R-Studio подключится к удаленному компьютеру и покажет структуру его жестких и логических дисков в панели Устройство/Диск локального компьютера

Далее восстановление данных будет аналогично восстановлению данных на локальном компьютере.

Диалоговое окно Восстановить

В диалоговом окне Восстановить можно выбрать, где сохранять восстановленные файлы - на локальном или удаленном компьютере. Сохранение восстановленных файлов на удаленном компьютере полезно в случае, когда на нем имеется исправный диск (например, внешний USB-диск), при этом вам не нужно будет передавать файлы по сети.

Когда R-Studio подключается к удаленному компьютеру, то проверяет на нем наличие R-Studio Agent и его пароль. При отсутствии R-Studio Agent его можно загрузить при помощи R-Studio с локального комьпютера на удаленный по сети. Более подробно смотри в разделе R-Studio Agent .

Вы можете вернуться к дискам локального компьютера, выбрав пункт Назад (выбор диска) меню Диск.


Подключение через Интернет

Подключить R-Studio и R-Studio Agent возможно через Интернет. Подключение может быть установлено либо с использованием IP адресов, либо посредством доменных имен DNS.

Если как хост-компьютер с R-Studio , так и клиентский компьютер с R-Studio Agent имеют публичные IP адреса, то подключение между ними может быть установлено таким же образом, что и в локальной сети, за исключением того, что в поле Компьютер диалогового окна Подключение к удаленному компьютеру должен быть указан IP адрес или доменное имя DNS.

Если какой-либо из компьютеров (или оба компьютера) находятся в частной сети за NAT/брандмауэром и не имеют частный (публичный, локальный) IP адрес, то на них должны быть открыты (перенастроены) соответствующие порты. Помимо этого подключение должно быть установлено либо при помощи R-Studio, либо при помощи R-Studio Agent.

Направления подключения

* Оба компьютера имеют публичные IP адреса (отсутствует NAT/Firewall), либо на них открыты соответствующие порты.

Подключение может быть установлено либо при помощи R-Studio, либо при помощи R-Studio Agent.

* Хост-компьютер с R-Studio находится за устройством NAT, а клиентский компьютер с R-Studio Agent имеет публичный IP адрес, либо не нем открыты соответствующие порты.

Подключение должно быть установлено при помощи R-Studio.

* Хост-компьютер с R-Studio имеет публичный IP address или на нем открыты соответствующие порты, а клиентский компьютер с R-Studio Agent находится за NAT.

Подключение должно быть установлено при помощи R-Studio Agent.

* Оба компьютера находятся в частной сети за устройством NAT/брандмауэром.

В этом случае подключение невозможно.

Подключение при помощи R-Studio Agent к R-Studio

Настройки R-Studio

Если подключение устанавливается при помощи R-Studio Agent, то R-Studio должна ожидать входящего подключения в диалоговом окне Подключение к удаленному компьютеру .

Диалоговое окно Подключение к Удаленному Компьютеру

Установите радиокнопку Ожидать соединения с удаленного компьютера и задайте параметры для входящих подключений.

Параметры R-Studio для Входящего Подключения

Пароль: | Введите пароль для получения доступа к данному компьютеру из сети.
Разрешить соединения с любого адреса | Если установлена данная радиокнопка, то R-Studio будет принимать соединения с любого IP адреса
Разрешить соединения с адреса | Если установлена данная радиокнопка, то R-Studio будет принимать соединения с определенного IP адреса или сети
IP Адрес | Задайте IP адреса, с которых будет доступен данный компьютер.
Маска Подсети | Задайти маску подсети той сети, откуда будет доступен данный компьютер.
Порт | Порт для входящих подключений.

R-Studio будет ожидать входящего подключения.

Диалоговое окно Ожидание подключения с удаленного компьютера

Подключение с R-Studio Agent к R-Studio.

Чтобы установить подключение с R-Studio Agent к R-Studio:

1. Щелкните правой кнопкой мыши по значку R-Studio Agent в системном лотке и выберите пункт Подключиться к

2. Введите необходимую информацию в диалоговом окне Подключение к R-Studio и нажмите кнопку Подключиться

Диалоговое окно Подключение к R-Studio

Параметры R-Studio Agent для подключения к R-Studio
Сервер | Доменное имя DNS или IP адрес хост-компьютера с R-Studio .
Порт | Порт, заданный в диалоговом окне R-Studio Подключение к удаленному компьютеру.
Пароль | Пароль, заданный в диалоговом окне R-Studio Подключение к удаленному компьютеру.
> R-Studio Agent подключится к хост-компьютеру с R-Studio и на нем будет показана структура жестких и логических дисков удаленного компьютера.

Далее восстановление данных будет аналогично восстановлению данных на локальном компьютере.


Текстовый/шестнадцатиричный Редактор

Любой объект в R-Studio может быть просмотрен и отредактирован в Текстовом/шестнадцатиричном Редакторе. Также возможно анализировать данные и представлять их в соответствии с различными шаблонами данных. Вы можете создавать собственные шаблоны для анализа данных.

Вы можете включить показ индексов объектов (numerical indexes) для их лучшего отличия.

· Просмотр и Редактирования Объектов
· Создание Собственных Шаблонов
· Пример Шаблона I
· Пример Шаблона II

Возможности R-Studio

Контакты и Техническая Поддержка

Восстановление Данных при помощи R-Studio

Восстановление Данных. Основные Операции

Восстановление Данных. Дополнительные Операции

Массовое Восстановление Файлов

Наборы Томов и RAID

Восстановление Данных по Сети

Техническая Информация

R-Studio Emergency

R-Studio Agent Emergency


Просмотр и Редактирование Объектов

ВЫ ДОЛЖНЫ БЫТЬ ПОЛНОСТЬЮ УВЕРЕНЫ В ТОМ, ЧТО И КУДА ЗАПИСЫВАЕТЕ!

Иначе вы можете полностью утратить ваши данные.

Прежде чем начать что-либо записывать на диск, вы должны Разрешить запись.

Чтобы разрешить запись

1 В главном окне R-Studio выберите пункт Настройки меню Инструменты и далее установите флажок Разрешить запись в диалоговом окне Настройки.
> Статус Редактируемый: будет изменен с Только чтение на Редактируемый.

Теперь объект можно редактировать.

Заблокированные и разблокированные объекты

R-Studio позволяет вручную заблокировать редактируемый в Текстовом/шестнадцатиричном Редакторе объект.

К заблокированному объекту открыт эксклюзивный доступ в Текстовом/шестнадцатиричном Редакторе и при этом никакие другие программы или Windows не могут вносить в него изменения. На время внесения любых изменений на диске объект блокируется в Текстовом/шестнадцатиричном Редакторе. Поэтому часто бывает полезно заблокировать объект на время его редактирования в Текстовом/шестнадцатиричном Редакторе. Для этого необходимо выбрать команду Заблокировать меню Инструменты.

При блокировании объекта в Текстовом/Шестнадцатиричном Редакторе имейте в виду следующее:

· Начиная с ОС Windows 7 невозможно изменить расположенные на логическом диске данные без его блокировки. Если данные расположены вне логического диска (например, на размонтированном разделе или на свободном дисковом пространстве), то блокировка не обязательна. Подобных ограничений нет на ОС Windows Vista, XP и ниже.
· Команда Эксклюзивный доступ к диску пытается заблокировать все логические диски, на которых расположен редактируемый объект. Для физического диска это все его логические диски, для файла - логический диск, на котором он расположен. Если файл открыт на RAID, созданном из логических дисков, то блокируются все логические диски, на которых данный файл расположен.

Более того:

· Если в Текстовом/Шестнадцатиричном Редакторе открыт логический диск, то команда Эксклюзивный доступ к диску блокирует его, если какие-либо файлы диска не открыты другими программами.
· Если в Текстовом/Шестнадцатиричном Редакторе открыт физический диск, то команда Эксклюзивный доступ к диску блокирует его, если при этом могут быть заблокированы все его логические диски. В данном случае могут возникнуть проблемы, если один из логических дисков является системным.

Чтобы просмотреть/редактировать объект

1 Щелкните правой кнопкой мыши по объекту и выберите пункт Вьювер/Редактор контекстного меню

Другие способы просмотреть/отредактировать объект

· Выберите объект и выберите пункт Вьювер/Редактор меню Файл

или

· Выберите объект и нажмите клавиши Ctrl+E
> Откроется окно Текстового/Шестнадцатиричного редактора

Текстовый/Шестнадцатиричный редактор R-Studio

Нажмите на соответствующую часть окна для получения более подробной информации.

Save ChangesFindFind NextFind PreviousStop (Esc)BackForwardAuto flowPropertiesData Interpreter

Текстовый просмотр данных

Параметры панели просмотра

Вы можете установить, какие панели и вкладки включить/выключить.

Чтобы включить/выключить:

Данные ANSI | Установите/снимите флажок пункта ANSI колонка меню Вид
Данные OEM | Установите/снимите флажок пункта OEM колонка меню Вид
Данные UNICODE | Установите/снимите флажок пункта Колонка UNICODE меню Вид
Данные UNICODE+ | Установите/снимите флажок пункта Колонка UNICODE+ меню Вид
Панель Инструментов | Установите/снимите флажок пункта Панель инструментов меню Вид
Показать Свойства | Установите/снимите флажок пункта Окно свойства меню Вид
Показать Секторы | Установите/снимите флажок пункта Просмотр секторов меню Вид
Показать Интерпретатор Данных | Установите/снимите флажок пункта Интерпретатор данных меню Вид
Показать Шаблоны | Установите/снимите флажок пункта Шаблоны меню Вид
Показать Закладки | Установите/снимите флажок пункта Закладки меню Вид
Показать Результаты Поиска | Установите/снимите флажок пункта Результат Поиска меню Вид
2 Просмотрите информацию и сделайте необходимые изменения

Выберите пункт Сохранить изменения меню Файл для сохранения сделанных изменений.

Просмотр

Существуют четыре вкладки, показывающие данные в различных представлениях. Реальное число вкладок для конкретного объекта зависит от самого объекта и его просматриваемых/редактируемых свойств.

Стандартный | Точные данные объекта. Если объект сжат, то прежде R-Studio извлечет данные.
Неограниченный | Точное представление данных + свободное пространство последнего кластера. Если объект сжат, то прежде R-Studio извлечет данные.
Прямой | Реальные данные, записанные на диск. Если объект не сжат, то такое представление совпадает со Стандартным представлением.
Размещение | Резидентная часть объекта.

Вы можете просматривать данные в 4 различных кодировках: ANSI/OEM/UNICODE/UNICODE+ , включив или выключив страницы с соответствующей кодировкой при помощи кнопок Страницы кодировки или выбрав соответствующие страницы кодировки в меню Вид.

Шаблоны

Вы можете выбрать шаблон, в соответствие с которым данные будут представлены и проанализированы в панели анализа данных. Интерпретатор данных показывает данные, выбранные в панели Шаблон, в различных представлениях.

Вы можете искать следующие или предыдущие данные, совпадающие с шаблонной сигнатурой на диске. Щелкните правой кнопкой мыши по правой панели редактора и выберите пункт контекстного меню Найти сигнатуру шаблона вперед или Найти сигнатуру шаблона назад. Также вы можете выбрать эти пункты в меню Редактировать.

Также вы можете создать свой собственный шаблон для анализа данных различных объектов.

Поиск

Для поиска конкретной строковой переменной нажмите кнопки Поиск, Найти далее или Найти предыдущее или выберите такие же пункты меню Редактировать , затем задайте строковую переменную в диалоговом окне Поиск.

Диалоговое окно Поиск

Параметры поиска

Искать
HEX | Строковая переменная, поиск которой производится, в шестнадцатиричном представлении
ANSI | Строковая переменная, поиск которой производится, в кодировке ANSI
OEM | Строковая переменная, поиск которой производится, в кодировке OEM
UNICODE | Строковая переменная, поиск которой производится, в кодировке UNICODE
Учитывать регистр | Если установить данный флажок, то поиск будет произведен с учетом регистра
Область поиска
С текущей позиции | Выберите данный пункт, чтобы поиск был произведен с текущей позиции
С начальной позиции | Выберите данный пункт, чтобы поиск был произведен с начала объекта
С Позиции (шестн.) | Выберите данный пункт и задайте область, в которой необходимо произвести поиск
Параметры поиска
Полный поиск | Выберите данный пункт, чтобы произвести поиск во всем объекте
Искать по смещению (шестн.) | Выберите данный пункт и укажите смещение, с которого будет начат поиск
Реверс | Если установить данный флажок, по поиск будет произведен в обратном направлении
Найти все | Если установить данный флажок, то будут найдены все случаи присутствия строковой переменной в анализируемом объекте. Результаты поиска будут показаны в панели Результаты поиска.

Результаты поиска будут показаны в панели Результаты поиска. Вы можете перейти к найденному элементу, дважды щелкнув по нему мышью.

Навигация

Вы можете быстро перейти в определенную часть объекта. Для этого введите соответствующее смещение в поле между кнопками панели инструментов.

Закладки

Вы можете создавать закладки для быстрого перехода в нужное место. Щелкните правой кнопкой мыши в месте, которое вы желаете сохранить в закладках, и выберите пункт контекстного меню Добавить/удалить закладку. Список закладок будет отображен в панели Закладки. Вы можете перейти по выбранной закладке, дважды щелкнув по ней мышью в списке.

Вы можете управлять закладками через меню Редактировать.

Заполнение области шаблоном

Чтобы заполнить область шаблоном выберите пункт Заполнить меню Редактировать, задайте шаблон и область заполнения в диалоговом окне Заполнить.

Диалоговое окно Заполнить

Параметры заполнения

Шаблон для заполнения
HEX | Шаблон, которым заполняется область, в шестнадцатиричном представлении
ANSI | Шаблон, которым заполняется область, в кодировке ANSI
OEM | Шаблон, которым заполняется область, в кодировке OEM
UNICODE | Шаблон, которым заполняется область, в кодировке UNICODE
Заполнить область
С (шестн.) | Позиция начала области, заполняемой шаблоном
До (шестн.) | Позиция конца области, заполняемой шаблоном
3 Нажмите кнопку Сохранить изменения, чтобы сохранить сделанные изменения

Другие способы сохранить сделанные изменения

· Выберите пункт Сохранить изменения меню Файл

или

· Нажмите клавишу F2
> Сделанные в Текстовом/Шестнадцатиричном Редакторе изменения объекта будут сохранены

ВЫ ДОЛЖНЫ БЫТЬ ПОЛНОСТЬЮ УВЕРЕНЫ В ТОМ, ЧТО И КУДА ЗАПИСЫВАЕТЕ!

Иначе вы можете полностью утратить ваши данные.

Выделение и сохранение области в Текстовом/шестнадцатиричном Редакторе

Вы можете выделить область объекта в Текстовом/шестнадцатиричном Редакторе и сохранить ее в файл.

Чтобы выделить и сохранить область в Текстовом/шестнадцатиричном Редакторе

1 Выберите пункт Выделить... меню Сервис и задайте область в диалоговом окне Выделение или

Выделите при помощи мыши необходимую область.

Если вы хотите выделить область всего объекта, то выберите пункт Выделить все меню Сервис или нажмите клавиши Ctrl+A

Диалоговое окно Выделение
2 Выберите соответствующий пункт меню Инструменты, чтобы сохранить данные в необходимом формате и задайте имя файла

Выберите пункт:

Сохранить в двоичный файл... | чтобы сохранить данные в двоичном формате (расширение по умолчанию .bin)
Сохранить как шестнадцатиричный файл... | чтобы сохранить данные в шестнадцатиричном формате (расширение по умолчанию .hex)

меню Сервис.

> Ваши данные будут сохранены в файл в Текстовом/шестнадцатиричном Редакторе


Создание Собственных Шаблонов

Вы можете сами создавать шаблоны.

Пример шаблона с комментариями для анализа AVI файла.

Синтаксис описания шаблона схож с языком XML. Файлы с шаблонами должны хранится в папке, заданной на вкладке Главная диалогового окна Настройки .

Структура шаблона

Заголовок шаблона

Каждый шаблон начинается со стандартного заголовка

<?xml version="1.0" encoding="utf-8"?>

Элемент template

Каждый шаблон начинается с элемента, где ему присваивается имя, показанное в области анализируемых данных.

Атрибуты:

name

Определяет имя шаблона, показанное в области анализируемых данных

Пример:

<template name="AVI File LIST">

........

</template>

Элемент signature

Атрибуты:

align <целое положительное число>

Указывается, если адрес структуры данных выровнен (например, по сектору: 512)

Элемент содержит элементы field, значениями которых являются шестнадцатиричные коды сигнатуры. В атрибуте offset указывается смещение относительно начала записи. Длина поля соответствует числу шестнадцатиричных значений.

Пример:

<signature align="1">

<field offset="0">46 49</field>

<field offset="2">4c 45</field>

</signature>

Элемент section

В данном элементе содержатся все выражения и операции, необходимые шаблону для анализа данных. Имя section показано в области анализируемых данных. На самом деле sections это виртуальные объекты, используемые для группировки логически связанных fields. Sections могут составлять гнездо.

Главная section не показана в области анализируемых данных.

В элементе присутствуют элементы field, которые являются реальными объектами с данными. Имена field показаны в области анализируемых данных вместе с их величинами.

Атрибуты:

name

Определяет имя шаблона, показанное в области анализируемых данных

Пример:

<section name="JUNK">

....

</section>

Список Всех Объектов в Шаблонах

Типы данных (поле field)

· integer

Подтипы:

int8

int16

int32

int64

uint8

uint16

uint32

uint64

uintX

Атрибуты:

endian: (be | le | system) | Необязательный. По умолчанию: system.
base: (decimal | hex | octal) | Необязательный. Указывает, в каком виде представлять число. По умолчанию: decimal.
as-offset: <выражение> | Необязательный. Означает, что это поле является смещением и значение этого смещения вычисляется согласно указанному выражению. Специальная переменная this содержит значение этого поля.
purpose: (offset | rsector |sector | cluster | rcluster) | Необязательный. Указывает тип результата в выражении as-offset . Если этот атрибут присутствует, то указывать атрибут offset необходимо только в случае, если значение "смещения" должно отличаться от значения этого поля (переменной this ). rsector и rcluster говорят о том, что смещения указаны относительно абсолютной позиции начала шаблона.
assigned-template: <Имя Темплейта> | Указывает имя шаблона, ассоциированного с данным полем. Игнорируется, если не указан атрибут as-offset или purpose.
var: <Имя> | Необязательный. Позволяет эначению этого поля быть доступным в выражениях по указанному имени.

· binary

Атрибуты:

display-encoding: (hex | binary) | Необязательный. По умолчанию: hex.
size: <bytes> | Обязательный.

· char

Атрибуты:

size: <bytes> | Обязательный.
codepage: (ansi | oem | utf8 | utf16) | Необязательный. Указывает используемую кодировку. По умолчанию: ansi.

· filetime

Показывает время в формате Win32 (64 бита)

· unixtime

Показывает время в формате Unix (секунды с 01/01/1970)

· filetime

Показывает время в формате DOS format (дата: hiword, время: loword)

· bits

Атрибуты:

size: <bytes> | Обязательный.
pos: <comma separated list of bit positions> | Обязательный. Указывает позиции битов в блоке данных.

Команды

· goto

Переход по указанному смещению (абсолютному или относительному)

Атрибуты:

address: <выражение> | Указывает абсолютный адрес перехода.
offset: <выражение> | Указывает относительный адрес перехода.

Всегда указывается только один из этих атрибутов.

· if

Вычисляет условие, заданное в атрибуте test, и читает указанные внутри этого тэга поля, если условие истинное.

Атрибуты:

test: <выражение>

Задает условие.

· repeat

Читает указанные в тэге поля заданное число раз или пока условие выхода не равно нулю

Атрибуты:

count: <выражение> | <выражение> вычисляется один раз при входе в блок. Внутренние элементы читаются указанное число раз.
test: <выражение> | <выражение> условие, вычисляемое при входе в блок. Аналогично C++ конструкции while(...) {}.
test: <выражение> | <выражение> условие, вычисляемое при выходе из блока. Аналогично C++ конструкции do {} while(...).

· setvar

Устанавливает значение внутренней переменной. Например, эту команду удобно использовать для сохранения текущего смещения. Значение текущего смещения хранится в предопределенной переменной offset.

Attributes:

var: <строка> | Указывает имя переменной.
expr: <выражение> | Указывает выражение, результат вычисления которого будет присвоен переменной.

Выражения

Выражения в шаблонах представляют собой арифметическое выражение с синтаксисом, аналогичном языку C (это касается и приотитета операций).

Поддерживаются следующие операции:

+ - * / & | > < <= >= != == || &&

Предопределенные переменные

· offset

Смещение, по которому в настоящий момент осуществляется чтение. В байтах относительно начала шаблона.

· start_position

Абсолютная позиция начала шаблона. offset + start_position = абсолютное смещение.

· this

Данная переменная существует только в контексте вычисления выражения ass-offset и является текущим значением поля данных, для которого задано это выражение


Пример Шаблона I

Ниже приведен пример шаблона с комментариями для анализа AVI файла.

<?xml version="1.0" encoding="utf-8"?>

<!-- A pattern section. The pattern name is AVI File. -->

<template name="AVI File">

<!-- A template signature section. Alignment is 1. -->

<signature align="1">

<!-- A 4-byte signature at offset 0x00. -->

<field offset="0x00">52 49 46 46</field> <!-- ANSI: RIFF -->

<!-- A 4-byte signature at offset 0x08. -->

<field offset="0x08">41 56 49 20</field> <!-- ANSI: LIST -->

</signature>

<!-- A data section. Its name is AVI File. This is the main data section. It is not shown in the parsing tree as a section (its name is ignored). -->

<section name="AVI File">

<!-- The first 4 bytes are read and shown as an ANSI string. -->

<field type="char" size="4" name="Signature: RIFF" var="signature"/>

<!-- The current position is moved to the beginning of the file. -->

<goto offset="-4"/>

<!-- The first 4 bytes in the file are read and shown as an unsigned integer. The internal variable signature gets the value of the field. -->

<field type="uint32" base="hex" name="Signature RIFF as unsigned integer in hex format" var="signature"/>

<!-- A test against the condition (signature == RIFF) -->

<if test="signature == 0x46464952"> <!-- ANSI: RIFF -->

<!-- The next 4 bytes are read and shown as an unsigned integer. The internal variable dataSize gets the value of the field. -->

<field type="uint32" name="Size of the data in file" var="dataSize"/>

<!-- A new internal variable endOfFile is created and the expr field evaluates its value.-->

<setvar var="endOfFile" expr="offset + dataSize - 8"/>

<!-- The next 4 bytes is read and shown as an ANSI string. -->

<field type="char" size="4" name="File type"/>

<!-- A new section named DATA is created -->

<section name="DATA">

<!-- A new internal variable chunksOffset is created, the expr filed evaluating its value. This variable gets the absolute value of template offset. -->

<setvar var="chunksOffset" expr="start_position"/>

<!-- A loop is created. Its condition is set in the test field (while the endOfFile variable is greater then the current position.) -->

<repeat test="endOfFile > offset">

<!-- 4 bytes are read and shown as an ANSI string. -->

<field type="char" size="4" name="Signature"/>

<!-- The current position is moved backwards by 4 bytes. -->

<goto offset="-4"/>

<!-- The same 4 bytes are read and shown as an unsigned integer. The internal variable signature gets this value. -->

<field type="uint32" name="Signature as unsigned integer" var="signature"/>

<!-- A test against the condition (signature == LIST) -->

<if test="signature == 1414744396"> <!-- ANSI: LIST -->

<!-- The section is shown. Its name is LIST -->

<section name="LIST">

<!-- The current position is moved backward by 4 bytes. -->

<goto offset="-4"/>

<!-- The 4 bytes are read and shown as an unsigned hexadecimal integer. This field has the attributes offset and assigned-template. If the user double-clicks this field, the AVI File LIST pattern will be invoked and the current pattern position will be moved to the address specified in as-offset.-->

<field type="uint32" base="hex" name="Signature LIST as unsigned integer in hex format" as-offset="start_position + offset - 4" assigned-template="AVI File LIST"/>

<!-- The next 4 bytes are read and shown as an unsigned integer. The listSize variable gets its value. -->

<field type="uint32" name="Size of the data in the list" var="listSize"/>

<!-- The 4 bytes are read and shown as an ANSI string. -->

<field type="char" size="4" name="List type"/>

<!-- The current position is moved backward by 4 bytes. -->

<goto offset="-4"/>

<!-- The same 4 bytes are shown as an unsigned hexadecimal integer. The listType variable gets its value.-->

<field type="uint32" base="hex" name="List type as unsigned integer in hex format" var="listType"/>

<!-- A test against condition (type == movi) -->

<if test="listType == 0x69766f6d"> <!-- ANSI: movi -->

<!-- The chunksOffset variable gets the value evaluated in the expr attribute. -->

<setvar var="chunksOffset" expr="start_position + offset - 4"/>

</if>

<!-- The current position is moved to the address evaluated in the address attribute. -->

<goto address="offset + listSize - 4"/>

</section>

</if>

<!-- A test against condition (signature == JUNK) -->

<if test="signature == 1263424842"> <!-- ANSI: JUNK -->

<!-- The section is shown with the JUNK name. -->

<section name="JUNK">

<!-- The next 4 bytes are read and shown as an unsigned integer. The internal variable junkSize gets its value. -->

<field type="uint32" name="Size of the data of the junk" var="junkSize"/>

<!-- The current position is moved by junkSize bytes forward. -->

<goto offset="junkSize"/>

</section>

</if>

<!-- A test against condition (signature == idx1) -->

<if test="signature == 829973609"> <!-- ANSI: idx1 -->

<!-- The section is shown with the idx1 name. -->

<section name="idx1">

<!-- The next 4 bytes are read and shown as an unsigned integer. The internal variable idxSize gets its value. -->

<field type="uint32" name="Size of the data of the idx1" var="idxSize"/>

<!-- The section is shown with the First AVIINDEXENTRY name. -->

<section name="First AVIINDEXENTRY">

<!-- The 4 bytes are read and shown as an ANSI string. -->

<field type="char" size="4" name="Chunck id"/>

<!-- The next 4 bytes are read and shown as an unsigned hexadecimal integer. -->

<field type="uint32" base="hex" name="Flags"/>

<!-- The next 4 bytes are read ans shown as an unsigned hexadecimal integer. The offset attribute is evaluated for this field as a sum of the chunksOffset variable and valued of this field. -->

<field type="uint32" base="hex" name="Chunk offset" as-offset="chunksOffset + this"/>

<!-- The next 4 bytes are read and shown as an unsigned integer. -->

<field type="uint32" name="Chunk size"/>

</section>

<!-- The current position is moved by idxSiz bytes forward. -->

<goto offset="idxSize"/>

</section>

</if>

<!-- A test against the condition. &amp;&amp; is a logical AND (&&) -->

<if test="signature != 1414744396 &amp;&amp; signature != 1263424842 &amp;&amp; signature != 829973609">

<!-- An empty section is shown. Its name is Unknown signature found -->

<section name="Unknown signature found">

</section>

<!-- The current position is moved to the address set in the endOfFile variable. -->

<goto address="endOfFile"/>

</if>

</repeat>

</section>

</if>

</section>

</template>


Пример Шаблона II

<?xml version="1.0" encoding="utf-8"?>

<!-- A pattern section. The pattern name is AVI File LIST -->

<template name="AVI File LIST">

<!-- A template signature section. Alignment is 1. -->

<signature align="1">

<!-- A 4-byte signature at offset 0x00. -->

<field offset="0x00">4C 49 53 54</field> <!-- ANSI: LIST -->

</signature>

<!-- A data section. Its name is AVI File LIST. This is the main data section. It is not shown in the parsing tree as a section (its name is ignored).-->

<section name="AVI File LIST">

<!-- The first 4 bytes are read and shown as an ANSI string. -->

<field type="char" size="4" name="Signature: LIST"/>

<!-- The current position is moved to the beginning of the file (4 bytes backward). -->

<goto offset="-4"/>

<!-- The first 4 bytes in the file are read and shown as an unsigned integer. The internal variable signature gets the value of the field. -->

<field type="uint32" name="Signature LIST as unsigned integer" var="signature"/>

<!-- A test against the condition (signature == LIST) -->

<if test="signature == 1414744396"> <!-- ANSI: LIST -->

<!-- The next 4 bytes are read and shown as an unsigned integer. The internal variable listSize gets its value. -->

<field type="uint32" name="Size of the data in the list" var="listSize"/>

<setvar var="endOfList" expr="offset + listSize"/>

<field type="char" size="4" name="List type"/>

<goto offset="-4"/>

<field type="uint32" base="hex" name="List type as unsigned integer in hex format" var="listType"/>

<!-- A test against condition (listType == movi) -->

<if test="listType == 0x69766f6d"> <!-- ANSI: movi -->

<!-- This chunk is not to be parsed. The current position is moved to the end of the chunk. -->

<goto address="endOfList"/>

</if>

<setvar var="mediaType" expr="0"/>

<repeat test="endOfList > offset - 8">

<section name="CHUNK">

<field type="char" size="4" name="Chunk ID"/>

<goto offset="-4"/>

<field type="uint32" name="Chunk ID as unsigned integer" var="chunkId"/>

<if test="chunkId == 1414744396"> <!-- ANSI: LIST -->

<goto offset="-4"/>

<field type="uint32" base="hex" name="LIST chunk ID as unsigned integer in hex format" as-offset="start_position + offset - 4" assigned-template="AVI File LIST"/>

</if>

<field type="uint32" name="Size of the data in the chunk" var="chunkSize"/>

<setvar var="endOfChunk" expr="offset + chunkSize"/>

<!-- Rounding the value of the variable endOfChunk to a number divisible by 2. -->

<if test="endOfChunk &amp; 1">

<setvar var="endOfChunk" expr="endOfChunk &amp; 0xFFFFFFFE"/>

<setvar var="endOfChunk" expr="endOfChunk + 2"/>

</if>

<if test="chunkId == 1751742049"> <!-- ANSI: avih -->

<field type="uint32" name="Number of microseconds between frames"/>

<field type="uint32" name="Approximate maximum data rate of the file"/>

<field type="uint32" name="Alignment for data, in bytes"/>

<field type="uint32" name="Bitwise combination of zero or more of the flags"/>

<field type="uint32" name="Total number of frames of data in the file"/>

<field type="uint32" name="Initial frame for interleaved files"/>

<field type="uint32" name="Number of streams in the file"/>

<field type="uint32" name="Suggested buffer size for reading the file"/>

<field type="uint32" name="Width of the AVI file in pixels"/>

<field type="uint32" name="Height of the AVI file in pixels"/>

<field type="binary" size="16" name="Reserved"/>

</if>

<if test="chunkId == 1852994675"> <!-- ANSI: strn -->

<field type="char" size="chunkSize" name="Stream name"/>

</if>

<if test="chunkId == 1752331379"> <!-- ANSI: strh -->

<field type="char" size="4" name="Type"/>

<goto offset="-4"/>

<field type="uint32" base="hex" name="Type as unsigned integer in hex format" var="type"/>

<setvar var="mediaType" expr="type"/>

<field type="char" size="4" name="Handler (codec)"/>

<field type="uint32" base="hex" name="Flags"/>

<field type="uint32" name="Number of the first block of the stream that is present in the file"/>

<field type="uint32" name="Scale"/>

<field type="uint32" name="Rate"/>

<field type="uint32" name="Start time of stream"/>

<field type="uint32" name="Size of stream in units as defined in Rate and Scale"/>

<field type="uint32" name="Size of buffer necessary to store blocks of that stream"/>

<field type="uint32" name="Quality"/>

<field type="uint32" name="Sample size (number of bytes of one stream atom)"/>

</if>

<if test="chunkId == 1718776947"> <!-- ANSI: strf -->

<if test="mediaType == 0x73646976"> <!-- ANSI: vids -->

<section name="BITMAPINFOHEADER">

<field type="uint32" name="Number of bytes required by the structure"/>

<field type="int32" name="Width of the bitmap, in pixels"/>

<field type="int32" name="Height of the bitmap, in pixels"/>

<field type="uint16" name="Number of planes for the target device"/>

<field type="uint16" name="Number of bits-per-pixel"/>

<field type="uint32" name="Type of compression for a compressed bottom-up bitmap"/>

<field type="uint32" name="Size, in bytes, of the image"/>

<field type="int32" name="Horizontal resolution, in pixels-per-meter, of the target device for the bitmap"/>

<field type="int32" name="Vertical resolution, in pixels-per-meter, of the target device for the bitmap"/>

<field type="uint32" name="Number of color indexes in the color table that are actually used by the bitmap"/>

<field type="uint32" name="Number of color indexes that are required for displaying the bitmap"/>

</section>

</if>

<if test="mediaType == 0x73647561"> <!-- ANSI: auds -->

<section name="WAVEFORMATEX">

<field type="uint16" name="Waveform-audio format type"/>

<field type="uint16" name="Number of channels in the waveform-audio data"/>

<field type="uint32" name="Sample rate, in samples per second (hertz)"/>

<field type="uint32" name="Required average data-transfer rate, in bytes per second, for the format tag"/>

<field type="uint16" name="Block alignment, in bytes"/>

<field type="uint16" name="Bits per sample for the Waveform-audio format type"/>

<field type="uint16" name="Size, in bytes, of extra format information appended to the end of the WAVEFORMATEX structure"/>

</section>

</if>

</if>

<goto address="endOfChunk"/>

</section>

</repeat>

</if>

<if test="signature != 1414744396">

<section name="Invalid LIST signature found">

</section>

</if>

</section>

</template>


Техническая Информация

В этой главе приводится различная техническая информация.

· Технология Сканирования IntelligentScan
· Особенности Восстановления Данных
· Восстановление Дополнительной Информации
· Форматы Данных
· Восстановление Данных на Файловых Системах HFS/HFS+
· Неисправные Сектора
· Использование Памяти
· Режим Компьютерно-Технической (Криминалистической) Экспертизы
· Ключи R-Studio
· Вкладка Свойств

Возможности R-Studio

Контакты и Техническая Поддержка

Восстановление Данных при помощи R-Studio

Восстановление Данных. Основные Операции

Восстановление Данных. Дополнительные Операции

Массовое Восстановление Файлов

Наборы Томов и RAID

Восстановление Данных по Сети

Текстовый/шестнадцатиричный Редактор

R-Studio Emergency

R-Studio Agent Emergency


Технология Сканирования IntelligentScan

В R-Studio для восстановления данных используется уникальная технология сканирования IntelligentScan.

При сканировании выбранной области R-Studio читает, анализирует данные непосредственно с диска, и пытается определить, какому типу записи они принадлежат. Возможны следующие типы:

1. Главная загрузочная запись MBR

2. Запись Загрузочного Сектора NTFS

3. Запись Загрузочного Сектора FAT

4. Запись MFT

5. Запись каталога NTFS

6. Запись FAT

7. Запись каталога FAT

8. Запись Ext2/3/4FS SuperBlocks

9. Запись UFS/FFS SuperBlock

10. HFS/HFS+ Volume Header

11. HFS/HFS+ BTree+ Node

Каждый из указанных типов записей имеет свою уникальную структуру. По известным значениям полей записи и отношениям между ними в каждом типе записи, R-Studio определяет тип записи данных. Если тип записи точно определить невозможно, то данным присваивается наиболее вероятный тип записи. Одним данным могут быть присвоены несколько типов записи с определенной вероятностью. На основании найденных типов записей формируется список возможных файлов.

R-Studio генерирует список записей для каждого типа записи. Этот список содержит ссылки на записи с вероятностью того, что найденная запись принадлежит тому или иному типу. Одни и те же данные могут попасть в различные списки записей с определенной вероятностью. После этого R-Studio анализирует отношения мужду элементами в каждом списке и между различными списками и формирует список найденных разделов и их параметров - начало раздела, вероятный размер раздела, тип файловой системы, размер кластера, вероятность существования раздела.

На основании сформированного списка R-Studio воссоздает файловые системы и восстанавливает файлы на найденных разделах. Один и тот же файл может присутствовать на нескольких разделах.

После сканирования всего диска или его части, R-Studio покажет все найденные разделы. При наличии информации возможна корректировка параметров найденных разделов.

При помощи технологии сканирования IntelligentScan R-Studio может восстановить файлы не только на существующих разделах. Также возможно восстановление данных после того, как раздел диска был удален или переформатирован. Например, если на диске был раздел NTFS, который позднее был переформатирован в раздел FAT, то R-Studio покажет два раздела на одном и том же месте диска: один с файловой системой FAT, а другой - с файловой системой NTFS. После этого можно будет восстановить найденные файлы.

Технология сканирования IntelligentScan позволяет считать R-Studio достаточно эффективной утилитой для восстановления данных, однако ее возможности не безграничны. Так как в ней используется вероятностный подход при восстановлении данных, то положительный результат не может быть гарантирован на 100%. Более того, даже если R-Studio корректно восстановила структуру данных, нельзя со 100-процентной уверенностью сказать о том, что все найденные файлы будут полностью и корректно восстановлены, так как поверх них уже могут быть записаны новые данные. Более подробно смотри в разделе Особенности Восстановления Данных.


Особенности Восстановления Данных

НИКОГДА НЕ СОХРАНЯЙТЕ ВОССТАНАВЛИВАЕМЫЕ ФАЙЛЫ/ПАПКИ НА ОРИГИНАЛЬНЫЙ ДИСК!!!

Это может стать причиной полной утраты данных.

R-Studio может модифицировать что-либо на диске только из шестнадцатиричного редактора в режиме Разрешить Запись или при явном сохранении файла на указанный диск. Во всех режимах при выполнении любой операции R-Studio только читает исходные, обрабатываемые данные и никогда их не модифицирует.

В большинстве операционных систем проходит некоторое время между действиями с файлом и изменением данных на жестком диске. R-Studio анализирует данные только на жестком диске и поэтому не всегда определяет недавние изменения в структуре данных.

Большинство операционных систем постоянно записывают служебную информацию не жесткие диски. Чаще всего это происходит при включении и выключении комьпьютера. При удалении файла или папки место, где они были расположены, для операционной системы становится свободным и на него может быть что-то записано. В этом случае файл или папка могут быть корректно определены, однако их данные будут утрачены.

Папка с именем $$$Folder58448 на разделе NTFS означает, что на диске были найдены только некоторые ссылки не нее. Например, были найдены папки с именами 'Мои документы', 'Работа', 'Фотографии', которые имеют одну родительскую папку, сведения о которой на диске найдены не были, поэтому ее имя неизвестно и она представлена как $$$Folder58448. Возможно описание таких папок находится за пределами области сканирования - попытайтесь расширить область сканирования или отсканируйте весь жесткий диск. Если это не поможет, то описание папки скорее всего было перезаписано.

Папка с именем $ROOT58448 на разделе FAT означает, что были найдены некоторые папки, однако они не могут быть включены в структуру папок для данного раздела FAT. Иногда такие папки могут содержать другие структуры папок.

Если вы восстановили файл, но его содержимое не совпадает с оригинальным, попробуйте выполнить следующее:

· Отсканируйте:

логический диск, если файл был просто удален.

жесткий диск, если структура данных повреждена более серьезно.

· Выполните поиск файла, который вы хотите восстановить, на всех найденных разделах и попытайтесь восстановить его со всех разделов, где он был найден. Проверьте каждый восстановленный файл, имеет ли он верное содержимое. Если содержимое восстановленного файла совпадает с оригинальным, то используйте данный раздел для восстановления остальных удаленных файлов.

Если необходимо восстановить несколько удаленных файлов, то попробуйте восстановить файл размером более 2 КБ для выбора нужного раздела.

Перекрестные Папки

Часто R-Studio находит несколько папок FAT, содержащих одни и те же данные. Такие паки называются перекрестными. R-Studio обозначает такие папки значком со стрелкой:

R-Studio связывает содержимое перекрестных папок с одной папкой, называемой папкой адресатом. При восстановлении R-Studio перекладывает все содержимое в папку адресат.

Чтобы просмотреть список перекрестных папок

1 Щелкните правой кнопкой мыши по перекрестной папки и выберите пункт Перекрестные папки контекстного меню
> Появится список перекрестных папок

Вы можете перейти к любой папке из этого списка, щелкнув по ней мышью.

Чтобы найти папку адресат

* Щелкните правой кнопкой мыши по перекрестной папке и выберите пункт Перейти к папке адресату контекстного меню или

Выберите перекрестную папку и выберите пункт Перейти к папке адресату меню Файл

Если пункт Перейти к папке адресату неактивен, то это означает, что данная папка уже является папкой адресатом.

Чтобы установить папку адресат вручную

* Щелкните правой кнопкой мыши по перекрестной папке и выберите пункт Установить в качестве основной папки контекстного меню или

Выберите перекрестную папку и выберите пункт Установить в качестве основной папки меню Файл.

Если пункт Установить в качестве основной папки неактивен, то это означает, что данная папка уже является папкой адресатом.

Недостоверные Папки

Иногда R-Studio может найти записи FAT , которые выглядят как папки, но имеют неверное содержимое. Например, наверные символы в имени файла, неверная дата, время, размер, другие атрибуты. Обратите внимание, что R-Studio корректно распознает локализованные имена. R-Studio обрабатывает такие записи как папки, однако не анализирует их содержимое и структуру. Вы можете отсканировать такие папки вручную, однако результаты сканирования могут быть непредсказуемыми (обычно, в результате сканирования получаются неверные данные).

R-Studio помечает такие папки знаком вопроса.

Чтобы повторно сканировать объект

* Щелкните правой кнопкой мыши по недостоверной папке на панели R-Studio Папки и выберите пункт Пересканировать папку контекстного меню или

Выберите недостоверную папку и выберите пункт Пересканировать папку меню Файл.


Восстановление Дополнительной Информации

R-Studio поддерживает восстановление сжатых файлов, альтернативных потоков данных, зашифрованных файлов, атрибутов безопасности и дополнительных атрибутов файлов. При восстановлении дополнительная информация о таких файлах будет также восстановлена, если операционная система, на которой инсталлирована R-Studio, и файловая система диска, на который восстанавливаются файлы, поддерживают ее. В противном случае дополнительная информация будет сохранена в отдельный файл с тем же именем и расширением, соответствующим ее типу. Ниже в таблице приведена информация об ОС и файловой системе диска, необходимых для восстановления указанных типов файлов.

Дополнительная Информация | Операционная Система | Файловая Система диска
Зашифрованные файлы | Windows 2000/XP/Vista/Windows 7 | NTFS
Альтернативные потоки данных | Windows NT/2000/XP/Vista/Windows 7 | NTFS
Атрибуты безопасности файлов | Windows NT/2000/XP/Vista/Windows 7 | NTFS
Дополнительные атрибуты файлов | Windows NT/2000/XP/Vista/Windows 7 | NTFS или FAT


Форматы Данных

В любом числовом поле пользователь может вводить данные в секторах или в байтах. Значения указанных полей выражены в байтах, если кроме цифровых значений в полях ничего нет.

Десятичные данные вводятся следующим образом: 2372354

Шестнадцатиричные данные вводятся следующим образом: 0x23Fa67 или 23Fa67 hex.

Возможны следующие обозначения (без учета регистра):

b | 1 байт
kb | 1 кбайт = 2^10=1024 байт
mb | 1 мбайт = 2^20=104857 байт
gb | 1 гбайт = 2^30=1073741824 байт
tb | 1 тбайт = 2^40=1099511627776 байт
eb | 1 эбайт = 2^50=1125899906842624 байт
hex | Шестнадцатиричное число
sec (sector) | Число выражено в секторах


Восстановление Данных на Файловых Системах HFS/HFS+

При удаление файла на Mac OS X также удаляются системные записи о файле BTree+. Поэтому восстановить данные файлы напрямую достаточно сложно. Записи могут остаться в:

1. Файле подкачки (если файл был удален недавно).
2. В журнале (если данная функция включена для HFS+ и файл был СОЗДАН недавно)

На самом деле вероятность найти записи для удаленного файла достаточно мала. Использование во время сканирования Известных Типов Файлов значительно повысит шансы восстановления.

Обратите внимание: Все вышесказанное относится именно к удаленным файлам. В случае повреждения файловая система HFS/HFS+ может быть восстановлена весьма успешно.

При восстановлении файлов с атрибутами HFS+ (ветви ресурсов, finder info и т.д.) R-Studio сохраняет их в т.н. формате AppleDouble. При копировании этих файлов на диск с файловой системой HFS+ под Mac OS X данные атрибуты восстановятся автоматически.


Неисправные Сектора

Очень часто диски, с которых необходимо восстановить данные, имеют либо полностью неисправные сектора, либо сектора, с которых трудно прочесть данные, главным образом из-за неисправности аппаратной части компьютера. R-Studio пытается прочесть такие сектора несколько раз. Число данных попыток устанавливается либо в диалоговом окне Настройки/Неисправные сектора, либо для каждого диска отдельно на вкладке Свойства в разделе Управление Диском.

Если в процессе выполнения какой-либо задачи R-Studio попадаются неисправные сектора, которые невозможно прочесть, то она обрабатывает их следующим образом:

Образы:

R-Studio заполняет пространство в файле-образе с неисправными секторами образцом, заданном в поле Образец для заполнения неисправных блоков диалогового окна Настройки/Неисправные сектора. Обратите внимание, что R-Studio записывает образец в образ, а не на исходный диск.

Файлы

Если в диалоговом окне Восстановить снят флажок Пропускать файлы с неисправными секторами, то R-Studio заполнит неисправные сектора в восстановленных файлах образцом, заданном в диалоговом окне Настройки/Неисправные сектора. Информация о таких файлах будет отображаться в Журнале.

Если флажок Пропускать файлы с неисправными секторами в диалоговом окне Восстановить установлен, то R-Studio пропустит при восстановление файлы с неисправными секторами и отобразит их список в диалоговом окне Файлы с неисправными секторами после окончания процесса восстановления. Вы можете выбрать файлы, которые необходимо восстановить сразу же, или пометить файлы для последующего восстановления. Также можно сохранить данный список в текстовый файл.

Диалоговое окно Файлы с неисправными секторами

Кнопки диалогового окна Файлы с неисправными секторами

Выделить все | Нажмите данную кнопку, чтобы выбрать все файлы в списке.
Очистить все | Нажмите данную кнопку, чтобы отменить ранее сделанный выбор файлов.
Пометить | Нажмите данную кнопку, чтобы пометить все выбранные файлы в списке.
Сохранить в файл | Нажмите данную кнопку, чтобы сохранить список файлов с неисправными секторами в текстовый файл.
Восстановить | Нажмите данную кнопку, чтобы сразу же восстановить выбранные файлы. Неисправные сектора в восстановленных файлах будут заполнены образцом, заданном в поле Образец для заполнения неисправных блоков диалогового окна Настройки/Неисправные сектора .

Объекты с неисправными секторами в Текстовом/шестнадцатиричном Редакторе

При просмотре/редактирование в Текстовом/шестнадцатиричном редакторе неисправные сектора объектов будут заполнены образцом, заданном в поле Образец для заполнения неисправных блоков диалогового окна Настройки/Неисправные сектора.


Использование Памяти

Вы можете посмотреть, сколько памяти использует R-Studio при выполнении задачи по восстановлению данных. Это особенно полезно при сканировании дисков большого объема на компьютере с ограниченными ресурсами. Вы можете задать параметры, позволяющие управлять используемой R-Studio памятью, на вкладке Использование памяти диалогового окна Настройки.

Чтобы посмотреть использование памяти

1 Выберите пункт Использование памяти меню Инструменты
> В диалоговом окне Использование памяти вы увидите общий объем памяти компьютера и объем используемой R-Studio памяти
Диалоговое окно Использование памяти

Использование памяти

Память процесса | Показано, сколько памяти использует R-Studio . Порог это предел памяти, который ОС может выделить виртуально для R-Studio. Реальное распределение памяти зависит также от оперативной памяти и размера файла подкачки.
Физическая системная память | Показывает размер оперативной памяти
Размер файла подкачки | Показывает размер виртуальной памяти


Режим Компьютерно-Технической (Криминалистической) Экспертизы

Обратите внимание: Данный режим имеется только в версии Technician (Техническая Лицензия)!

В этом режиме R-Studio создает специальный отчет по собранным данным для предоставления на слушаниях в суде. В отчет включена информация о конфигурации компьютера, используемого для сбора данных, и MD5 для восстановленных файлов.

Обратите внимание: Каждый раз при изменении аппаратной конфигурации компьютера (подключение/отключение жесткого диска, внешнего USB устройства и т.д.) будет создаваться новый отчет.

Чтобы включить данный режим

1 Установите флажок Включить режим создания журнала отчета на вкладке Главная диалогового окна Настройки.

Каждый раз при восстановлении файлов будет открываться диалоговое окно Настройки журнала отчета .

Диалоговое окно Настройки журнала отчета

Введите необходимую информацию и нажмите кнопку OK , после чего вы перейдете к диалоговому окну Восстановить .

При восстановлении файла R-Studio создаст специальный отчет по собранным данным в заданной папке. Ниже приведен пример данного отчета.

******************************** Forensic Data Collection Audit Log ********************************

R-STUDIO network edition Build 130041/Jan 8 2010

Case Name: Steven v. Christofer

Case Number: 28-S-0205-CR-85763

Operator / Investigator Name: J.F. Lewson

**************************************** Drives Information ****************************************

- Drive Number 0 ---------------------------------

* Drive Type [256 bytes]: Computer,Local Computer

* Name [30 bytes]: Local Computer

* OS [84 bytes]: Windows XP Pro Build 2600, Service Pack 3

* System [122 bytes]: 1 x Intel(R) Pentium(R) 4 CPU 1.80GHz, 1817 MHz, 1023 MB RAM

- Drive Number 2 ---------------------------------

* Drive Type [256 bytes]:

* Name [40 bytes]: ASUSDRW-0402P/D1.05

+ Device Identification [4 bytes]:

* Vendor [32 bytes]: ASUS

* Product [64 bytes]: DRW-0402P/D

* Firmware [16 bytes]: 1.05

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 1

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

- Drive Number 4 ---------------------------------

* Drive Type [256 bytes]:

* Name [48 bytes]: PromiseRAID Console1.00

+ Device Identification [4 bytes]:

* Vendor [32 bytes]: Promise

* Product [64 bytes]: RAID Console

* Firmware [16 bytes]: 1.00

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 3

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 7

* Lun [1 bytes]: 0

- Drive Number 5 ---------------------------------

* Drive Type [256 bytes]: Physical Drive,Disk

* Name [28 bytes]: ST380215A3.AA

* OS Object [38 bytes]: \\.\PhysicalDrive0

* R-Studio Driver [44 bytes]: WinNT\Handle\Physical

* Size [8 bytes]: 74 Gb (156301488 sec)

* Sector Size [4 bytes]: 512 b

* Partition Size [8 bytes]: 74 Gb (156301488 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 131072

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 2

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 9729

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ Device Identification [4 bytes]:

* Vendor [32 bytes]: ST380215

* Product [64 bytes]: A

* Firmware [16 bytes]: 3.AA

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 0

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

* Bus Type [4 bytes]: IDE/ATA

- Drive Number 6 ---------------------------------

* Drive Type [256 bytes]: Physical Drive,Disk

* Name [48 bytes]: QUANTUMFIREBALL EL5A08.

* OS Object [38 bytes]: \\.\PhysicalDrive1

* R-Studio Driver [44 bytes]: WinNT\Handle\Physical

* Size [8 bytes]: 4892 Mb (10018890 sec)

* Sector Size [4 bytes]: 512 b

* Partition Size [8 bytes]: 4892 Mb (10018890 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 65536

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 2

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 623

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ Device Identification [4 bytes]:

* Vendor [32 bytes]: QUANTUM

* Product [64 bytes]: FIREBALL EL5

* Firmware [16 bytes]: A08.

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 2

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

* Bus Type [4 bytes]: IDE/ATA

- Drive Number 7 ---------------------------------

* Drive Type [256 bytes]: Physical Drive,Disk

* Name [36 bytes]: IOMEGAZIP 25032.G

* OS Object [38 bytes]: \\.\PhysicalDrive2

* R-Studio Driver [44 bytes]: WinNT\Handle\Physical

* Size [8 bytes]: 239 Mb (489532 sec)

* Sector Size [4 bytes]: 512 b

* Partition Size [8 bytes]: 239 Mb (489532 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 32768

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 4096

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 30

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ Device Identification [4 bytes]:

* Vendor [32 bytes]: IOMEGA

* Product [64 bytes]: ZIP 250

* Firmware [16 bytes]: 32.G

* Bus Type [4 bytes]: USB

- Drive Number 8 ---------------------------------

* Drive Type [256 bytes]: Physical Drive,Disk

* Name [52 bytes]: USB 2.0Storage Device0100

* OS Object [38 bytes]: \\.\PhysicalDrive3

* R-Studio Driver [44 bytes]: WinNT\Handle\Physical

* Size [8 bytes]: 37 Gb (78242976 sec)

* Sector Size [4 bytes]: 512 b

* Partition Size [8 bytes]: 37 Gb (78242976 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 32768

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 4096

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 4870

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ Device Identification [4 bytes]:

* Vendor [32 bytes]: USB 2.0

* Product [64 bytes]: Storage Device

* Firmware [16 bytes]: 0100

* Bus Type [4 bytes]: USB

- Drive Number 9 ---------------------------------

* Drive Type [256 bytes]: Volume,Disk

* Name [6 bytes]: F:

* Mount Points [8 bytes]: F:\

* OS Object [98 bytes]: \\?\Volume{fc67c7f4-d459-11de-8468-0004e2378b92}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Size [8 bytes]: 1780 Mb (3646628 sec)

* Sector Size [4 bytes]: 512 b

* Partition Offset [8 bytes]: 63 Kb (126 sec)

* Partition Size [8 bytes]: 1780 Mb (3646628 sec)

* Partition Number [4 bytes]: 1

* Partition Type [256 bytes]: NTFS/HPFS

+ NTFS Information [4 bytes]:

* Cluster Size [4 bytes]: 2048 b (4 sec)

* MFT Record Size [4 bytes]: 1024 b

* MFT Position [8 bytes]: 12288 b (24 sec)

* MFT Mirror Position [8 bytes]: 302 Kb (604 sec)

* Index Block Size [4 bytes]: 4096 b

* Sector Size [4 bytes]: 512 b

* Volume Size [8 bytes]: 1780 Mb (3646624 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 65536

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 2

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 623

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 2

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

* Bus Type [4 bytes]: IDE/ATA

- Drive Number 10 --------------------------------

* Drive Type [256 bytes]: Volume,Disk

* Name [6 bytes]: G:

* Mount Points [8 bytes]: G:\

* OS Object [98 bytes]: \\?\Volume{91268e18-d46f-11de-b297-806d6172696f}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Size [8 bytes]: 1270 Mb (2602466 sec)

* Sector Size [4 bytes]: 512 b

* Partition Offset [8 bytes]: 1780 Mb (3646818 sec)

* Partition Size [8 bytes]: 1270 Mb (2602466 sec)

* Partition Number [4 bytes]: 2

* Partition Type [256 bytes]: FAT32

+ FAT Information [4 bytes]:

* FAT Bits (12,16,32) [4 bytes]: 32

* Cluster Size [4 bytes]: 4096 b (8 sec)

* First Cluster Offset [8 bytes]: 2548 Kb (5096 sec)

* Root Directory Cluster [4 bytes]: 2

* First FAT Offset [8 bytes]: 19456 b (38 sec)

* Size of One FAT Table [8 bytes]: 1268 Kb (2537 sec)

* Number of FAT Copies [4 bytes]: 2

# Active FAT copy [4 bytes]: Auto

* Sector Size [4 bytes]: 512 b

* Major Version [1 bytes]: 0

* Minor Version [1 bytes]: 0

* Volume Size [8 bytes]: 1270 Mb (2602466 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 65536

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 2

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 623

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 2

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

* Bus Type [4 bytes]: IDE/ATA

- Drive Number 11 --------------------------------

* Drive Type [256 bytes]: Volume,Disk

* Name [6 bytes]: H:

* Mount Points [8 bytes]: H:\

* OS Object [98 bytes]: \\?\Volume{91268e19-d46f-11de-b297-806d6172696f}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Size [8 bytes]: 1796 Mb (3678821 sec)

* Sector Size [4 bytes]: 512 b

* Partition Offset [8 bytes]: 3051 Mb (6249348 sec)

* Partition Size [8 bytes]: 1796 Mb (3678821 sec)

* Partition Number [4 bytes]: 3

* Partition Type [256 bytes]: FAT16 (big)

+ FAT Information [4 bytes]:

* FAT Bits (12,16,32) [4 bytes]: 16

* Cluster Size [4 bytes]: 32 Kb (64 sec)

* First Cluster Offset [8 bytes]: 178 Kb (356 sec)

* Root Directory Offset [8 bytes]: 231424

* Root Directory Length [4 bytes]: 16384 b

* First FAT Offset [8 bytes]: 1024 b (2 sec)

* Size of One FAT Table [8 bytes]: 112 Kb (225 sec)

* Number of FAT Copies [4 bytes]: 2

# Active FAT copy [4 bytes]: Auto

* Sector Size [4 bytes]: 512 b

* Major Version [1 bytes]: 0

* Minor Version [1 bytes]: 0

* Volume Size [8 bytes]: 1796 Mb (3678821 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 65536

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 2

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 623

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 2

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

* Bus Type [4 bytes]: IDE/ATA

- Drive Number 12 --------------------------------

* Drive Type [256 bytes]: Volume,Disk

* Name [6 bytes]: C:

* Mount Points [8 bytes]: C:\

* OS Object [98 bytes]: \\?\Volume{a380f9d0-c3d6-11de-967c-806d6172696f}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Size [8 bytes]: 21634 Mb (44307206 sec)

* Sector Size [4 bytes]: 512 b

* Partition Offset [8 bytes]: 32256 b (63 sec)

* Partition Size [8 bytes]: 21634 Mb (44307206 sec)

* Partition Number [4 bytes]: 1

* Partition Type [256 bytes]: NTFS/HPFS

+ NTFS Information [4 bytes]:

* Cluster Size [4 bytes]: 4096 b (8 sec)

* MFT Record Size [4 bytes]: 1024 b

* MFT Position [8 bytes]: 624 Mb (1279424 sec)

* MFT Mirror Position [8 bytes]: 1161 Mb (2378048 sec)

* Index Block Size [4 bytes]: 4096 b

* Sector Size [4 bytes]: 512 b

* Volume Size [8 bytes]: 21634 Mb (44307200 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 131072

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 2

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 9729

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 0

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

* Bus Type [4 bytes]: IDE/ATA

- Drive Number 13 --------------------------------

* Drive Type [256 bytes]: Volume,Disk

* Name [6 bytes]: D:

* Mount Points [8 bytes]: D:\

* OS Object [98 bytes]: \\?\Volume{471ed9d0-c3d8-11de-967e-0004e2378b92}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Size [8 bytes]: 53 Gb (111994155 sec)

* Sector Size [4 bytes]: 512 b

* Partition Offset [8 bytes]: 21634 Mb (44307333 sec)

* Partition Size [8 bytes]: 53 Gb (111994155 sec)

* Partition Number [4 bytes]: 2

* Partition Type [256 bytes]: NTFS/HPFS

+ NTFS Information [4 bytes]:

* Cluster Size [4 bytes]: 4096 b (8 sec)

* MFT Record Size [4 bytes]: 1024 b

* MFT Position [8 bytes]: 3072 Mb (6291456 sec)

* MFT Mirror Position [8 bytes]: 14100 Mb (28876800 sec)

* Index Block Size [4 bytes]: 4096 b

* Sector Size [4 bytes]: 512 b

* Volume Size [8 bytes]: 53 Gb (111994152 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 131072

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 2

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 9729

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 0

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

* Bus Type [4 bytes]: IDE/ATA

- Drive Number 14 --------------------------------

* Drive Type [256 bytes]: Volume,CDROM

* Name [6 bytes]: E:

* Mount Points [8 bytes]: E:\

* OS Object [98 bytes]: \\?\Volume{79911e7d-632b-11d9-a2b8-806d6172696f}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Sector Size [4 bytes]: 2048 b

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 131072

# I/O Unit [4 bytes]: 2048

# Buffer Alignment [4 bytes]: 2

+ SCSI Address [4 bytes]:

* Port Number [1 bytes]: 1

* Path Id [1 bytes]: 0

* Target Id [1 bytes]: 0

* Lun [1 bytes]: 0

* Bus Type [4 bytes]: IDE/ATAPI

- Drive Number 15 --------------------------------

* Drive Type [256 bytes]: Volume,Floppy

* Name [6 bytes]: A:

* Mount Points [8 bytes]: A:\

* OS Object [98 bytes]: \\?\Volume{62ef9d58-f9fc-11d8-8e66-806d6172696f}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Sector Size [4 bytes]: 512 b

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 32768

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 4096

- Drive Number 16 --------------------------------

* Drive Type [256 bytes]: Volume,Floppy

* Name [6 bytes]: I:

* Mount Points [8 bytes]: I:\

* OS Object [98 bytes]: \\?\Volume{bd7eac6a-003b-11d9-8214-0004e2378b92}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Size [8 bytes]: 238 Mb (489440 sec)

* Sector Size [4 bytes]: 512 b

* Partition Offset [8 bytes]: 16384 b (32 sec)

* Partition Size [8 bytes]: 238 Mb (489440 sec)

* Partition Number [4 bytes]: 1

+ FAT Information [4 bytes]:

* FAT Bits (12,16,32) [4 bytes]: 16

* Cluster Size [4 bytes]: 4096 b (8 sec)

* First Cluster Offset [8 bytes]: 247 Kb (495 sec)

* Root Directory Offset [8 bytes]: 245248

* Root Directory Length [4 bytes]: 16384 b

* First FAT Offset [8 bytes]: 512 b (1 sec)

* Size of One FAT Table [8 bytes]: 119 Kb (239 sec)

* Number of FAT Copies [4 bytes]: 2

# Active FAT copy [4 bytes]: Auto

* Sector Size [4 bytes]: 512 b

* Major Version [1 bytes]: 0

* Minor Version [1 bytes]: 0

* Volume Size [8 bytes]: 238 Mb (489440 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 32768

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 4096

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 30

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

* Bus Type [4 bytes]: USB

- Drive Number 17 --------------------------------

* Drive Type [256 bytes]: Volume,Disk

* Name [6 bytes]: J:

* Mount Points [8 bytes]: J:\

* OS Object [98 bytes]: \\?\Volume{567e88ce-e0f4-11de-9c8f-806d6172696f}

* R-Studio Driver [42 bytes]: WinNT\Handle\Logical

* Size [8 bytes]: 37 Gb (78220422 sec)

* Sector Size [4 bytes]: 512 b

* Partition Offset [8 bytes]: 8064 Kb (16128 sec)

* Partition Size [8 bytes]: 37 Gb (78220422 sec)

* Partition Number [4 bytes]: 1

* Partition Type [256 bytes]: NTFS/HPFS

+ NTFS Information [4 bytes]:

* Cluster Size [4 bytes]: 4096 b (8 sec)

* MFT Record Size [4 bytes]: 1024 b

* MFT Position [8 bytes]: 3072 Mb (6291456 sec)

* MFT Mirror Position [8 bytes]: 19096 Mb (39110208 sec)

* Index Block Size [4 bytes]: 4096 b

* Sector Size [4 bytes]: 512 b

* Volume Size [8 bytes]: 37 Gb (78220421 sec)

# I/O Tries [4 bytes]: Default

+ Drive Control [4 bytes]:

# Maximum Transfer [4 bytes]: 32768

# I/O Unit [4 bytes]: 512

# Buffer Alignment [4 bytes]: 4096

+ Physical Drive Geometry [4 bytes]:

* Cylinders [8 bytes]: 4870

* Tracks Per Cylinder [4 bytes]: 255

* Sectors Per Track [4 bytes]: 63

* Sector Size [4 bytes]: 512 b

* Bus Type [4 bytes]: USB

- Drive Number 18 --------------------------------

* Drive Type [256 bytes]: Partition,Active

* Name [22 bytes]: Partition1

* Mount Points [8 bytes]: C:\

* Size [8 bytes]: 21634 Mb (44307206 sec)

* Partition Offset [8 bytes]: 32256 b (63 sec)

* Partition Size [8 bytes]: 21634 Mb (44307206 sec)

* Partition Number [4 bytes]: 1

* Partition Type [256 bytes]: NTFS/HPFS

+ NTFS Information [4 bytes]:

* Cluster Size [4 bytes]: 4096 b (8 sec)

* MFT Record Size [4 bytes]: 1024 b

* MFT Position [8 bytes]: 624 Mb (1279424 sec)

* MFT Mirror Position [8 bytes]: 1161 Mb (2378048 sec)

* Index Block Size [4 bytes]: 4096 b

* Sector Size [4 bytes]: 512 b

* Volume Size [8 bytes]: 21634 Mb (44307200 sec)

- Drive Number 19 --------------------------------

* Drive Type [256 bytes]: Partition,Logical

* Name [22 bytes]: Partition2

* Mount Points [8 bytes]: D:\

* Size [8 bytes]: 53 Gb (111994155 sec)

* Partition Offset [8 bytes]: 21634 Mb (44307333 sec)

* Partition Size [8 bytes]: 53 Gb (111994155 sec)

* Partition Number [4 bytes]: 2

* Partition Type [256 bytes]: NTFS/HPFS

+ NTFS Information [4 bytes]:

* Cluster Size [4 bytes]: 4096 b (8 sec)

* MFT Record Size [4 bytes]: 1024 b

* MFT Position [8 bytes]: 3072 Mb (6291456 sec)

* MFT Mirror Position [8 bytes]: 14100 Mb (28876800 sec)

* Index Block Size [4 bytes]: 4096 b

* Sector Size [4 bytes]: 512 b

* Volume Size [8 bytes]: 53 Gb (111994152 sec)

- Drive Number 20 --------------------------------

* Drive Type [256 bytes]: Partition,Logical

* Name [22 bytes]: Partition1

* Mount Points [8 bytes]: F:\

* Size [8 bytes]: 1780 Mb (3646628 sec)

* Partition Offset [8 bytes]: 63 Kb (126 sec)

* Partition Size [8 bytes]: 1780 Mb (3646628 sec)

* Partition Number [4 bytes]: 1

* Partition Type [256 bytes]: NTFS/HPFS

+ NTFS Information [4 bytes]:

* Cluster Size [4 bytes]: 2048 b (4 sec)

* MFT Record Size [4 bytes]: 1024 b

* MFT Position [8 bytes]: 12288 b (24 sec)

* MFT Mirror Position [8 bytes]: 302 Kb (604 sec)

* Index Block Size [4 bytes]: 4096 b

* Sector Size [4 bytes]: 512 b

* Volume Size [8 bytes]: 1780 Mb (3646624 sec)

- Drive Number 21 --------------------------------

* Drive Type [256 bytes]: Partition,Logical

* Name [22 bytes]: Partition2

* Mount Points [8 bytes]: G:\

* Size [8 bytes]: 1270 Mb (2602466 sec)

* Partition Offset [8 bytes]: 1780 Mb (3646818 sec)

* Partition Size [8 bytes]: 1270 Mb (2602466 sec)

* Partition Number [4 bytes]: 2

* Partition Type [256 bytes]: FAT32

+ FAT Information [4 bytes]:

* FAT Bits (12,16,32) [4 bytes]: 32

* Cluster Size [4 bytes]: 4096 b (8 sec)

* First Cluster Offset [8 bytes]: 2548 Kb (5096 sec)

* Root Directory Cluster [4 bytes]: 2

* First FAT Offset [8 bytes]: 19456 b (38 sec)

* Size of One FAT Table [8 bytes]: 1268 Kb (2537 sec)

* Number of FAT Copies [4 bytes]: 2

# Active FAT copy [4 bytes]: Auto

* Sector Size [4 bytes]: 512 b

* Major Version [1 bytes]: 0

* Minor Version [1 bytes]: 0

* Volume Size [8 bytes]: 1270 Mb (2602466 sec)

- Drive Number 22 --------------------------------

* Drive Type [256 bytes]: Partition,Logical

* Name [22 bytes]: Partition3

* Mount Points [8 bytes]: H:\

* Size [8 bytes]: 1796 Mb (3678821 sec)

* Partition Offset [8 bytes]: 3051 Mb (6249348 sec)

* Partition Size [8 bytes]: 1796 Mb (3678821 sec)

* Partition Number [4 bytes]: 3

* Partition Type [256 bytes]: FAT16 (big)

+ FAT Information [4 bytes]:

* FAT Bits (12,16,32) [4 bytes]: 16

* Cluster Size [4 bytes]: 32 Kb (64 sec)

* First Cluster Offset [8 bytes]: 178 Kb (356 sec)

* Root Directory Offset [8 bytes]: 231424

* Root Directory Length [4 bytes]: 16384 b

* First FAT Offset [8 bytes]: 1024 b (2 sec)

* Size of One FAT Table [8 bytes]: 112 Kb (225 sec)

* Number of FAT Copies [4 bytes]: 2

# Active FAT copy [4 bytes]: Auto

* Sector Size [4 bytes]: 512 b

* Major Version [1 bytes]: 0

* Minor Version [1 bytes]: 0

* Volume Size [8 bytes]: 1796 Mb (3678821 sec)

- Drive Number 23 --------------------------------

* Drive Type [256 bytes]: Empty Space

* Name [28 bytes]: Empty Space23

* Size [8 bytes]: 44 Mb (90721 sec)

* Partition Offset [8 bytes]: 4847 Mb (9928169 sec)

* Partition Size [8 bytes]: 44 Mb (90721 sec)

- Drive Number 24 --------------------------------

* Drive Type [256 bytes]: Partition,Active

* Name [22 bytes]: Partition1

* Mount Points [8 bytes]: I:\

* Size [8 bytes]: 238 Mb (489440 sec)

* Partition Offset [8 bytes]: 16384 b (32 sec)

* Partition Size [8 bytes]: 238 Mb (489440 sec)

* Partition Number [4 bytes]: 1

* Partition Type [256 bytes]: FAT16 (big)

+ FAT Information [4 bytes]:

* FAT Bits (12,16,32) [4 bytes]: 16

* Cluster Size [4 bytes]: 4096 b (8 sec)

* First Cluster Offset [8 bytes]: 247 Kb (495 sec)

* Root Directory Offset [8 bytes]: 245248

* Root Directory Length [4 bytes]: 16384 b

* First FAT Offset [8 bytes]: 512 b (1 sec)

* Size of One FAT Table [8 bytes]: 119 Kb (239 sec)

* Number of FAT Copies [4 bytes]: 2

# Active FAT copy [4 bytes]: Auto

* Sector Size [4 bytes]: 512 b

* Major Version [1 bytes]: 0

* Minor Version [1 bytes]: 0

* Volume Size [8 bytes]: 238 Mb (489440 sec)

- Drive Number 25 --------------------------------

* Drive Type [256 bytes]: Partition,Logical

* Name [22 bytes]: Partition1

* Mount Points [8 bytes]: J:\

* Size [8 bytes]: 37 Gb (78220422 sec)

* Partition Offset [8 bytes]: 8064 Kb (16128 sec)

* Partition Size [8 bytes]: 37 Gb (78220422 sec)

* Partition Number [4 bytes]: 1

* Partition Type [256 bytes]: NTFS/HPFS

+ NTFS Information [4 bytes]:

* Cluster Size [4 bytes]: 4096 b (8 sec)

* MFT Record Size [4 bytes]: 1024 b

* MFT Position [8 bytes]: 3072 Mb (6291456 sec)

* MFT Mirror Position [8 bytes]: 19096 Mb (39110208 sec)

* Index Block Size [4 bytes]: 4096 b

* Sector Size [4 bytes]: 512 b

* Volume Size [8 bytes]: 37 Gb (78220421 sec)

- Drive Number 26 --------------------------------

* Drive Type [256 bytes]: Empty Space

* Name [28 bytes]: Empty Space26

* Size [8 bytes]: 8032 Kb (16064 sec)

* Partition Offset [8 bytes]: 512 b (1 sec)

* Partition Size [8 bytes]: 8032 Kb (16064 sec)

****************************************************************************************************

-------------------------------------------- Session 1 ---------------------------------------------

START Date / Time of Collection: 2010-01-09 16:50:24

Source drive:Sector Modification Date MD5 File Name

10: 5112 Root

10: 5184 2007-04-27 09:56:56 Temp

10: 1068664 2009-11-01 19:24:10 Temp\TEMP

10: 287296 2007-04-27 09:56:42 d89b3a219c2b4c6c36ca60dd851b63e4 Temp\1.arc

10: 323576 2007-04-27 10:00:34 f201ccdd36bcb1a87c465fd92a61369e Temp\1.dsk

10: 5208 2005-06-30 23:50:06 TMP

10: 1068704 2009-11-01 19:13:02 TMP\TEMP

10: 5224 2005-06-30 23:50:28 Files to Recover

10: 5232 2005-03-21 21:22:26 bbf288488aa09a013919e7cd4428a828 Files to Recover\test1.arc

10: 406640 2005-03-21 21:23:42 2eceaa06087680171c189f2d60bf32fa Files to Recover\test3.arc

10: 283760 2005-03-21 21:24:58 d65b91fe8e5f3641d2d80d9da1ca00fe Files to Recover\?est5.arc

10: 216176 2003-11-16 23:13:14 3743dc1fef09606b97f2f8af77f0c2fa Files to Recover\Wipe Test 1.doc

10: 1264800 2003-11-16 23:13:20 addc1f7580d14d65e2b65b0fca0dea04 Files to Recover\Wipe Test 2.doc

10: 1264848 2003-11-16 23:13:26 596070fb58cfde5a502a0b44f919ab57 Files to Recover\Wipe Test 3.doc

10: 216320 2003-11-16 23:13:34 70d5bf4c1630cc2d65ffa7f171842c2b Files to Recover\Wipe Test 4.doc

10: 216368 2003-11-16 23:14:04 929fcf3b344b8fd1fee4af24388b622e Files to Recover\Wipe Test 5.doc

10: 1264992 2003-11-16 23:14:08 82bca2611ac7e31ee50da2aea997a41d Files to Recover\Wipe Test 6.doc

10: 83080 2005-07-06 21:24:18 e9f5ca4cad1cea3d5202a74fc69224c0 Files to Recover\~$pe Test 2.doc

10: 83168 2006-05-13 19:39:16 9c6338caa791315f2aadf9a55aab07bb Files to Recover\Outlook_recovered_by_R_Mail.pst

10: 83608 2006-05-14 17:15:32 85af76d9f2e3d5ca4028a8872a0ff12a Files to Recover\Outlook.pst

10: 1053688 2007-04-23 13:13:32 900822f2b78289cea2f62c8cfc3215d8 Files to Recover\Picture 113.jpg

10: 1059648 2007-04-23 13:15:22 4ef0427f18de06755aeb1cc0a9c65e84 Files to Recover\Picture 149.jpg

10: 1062928 2007-04-23 13:20:16 ffd0944df55bc375bda69def5f1d1f5e Files to Recover\Picture 237.jpg

END Date / Time of Collection: 2010-01-09 16:51:48

----------------------------------------------------------------------------------------------------


Ключи R-Studio

Если при запуске и в процессе работы R-Studio возникли некоторые проблемы, то для их устранения вы можете использовать ключи запуска.

Существуют следующие ключи:

-all_drives | При запуске с данным ключом R-Studio покажет все логические диски в системе. При обычном запуске R-Studio показывает только локальные диски в системе. При этом некоторые устройства хранения данных могут быть не опознаны как локальные диски.
-debug | При запуске с данным ключом будет показана дополнительная отладочная информация. При запуске с данным ключом в контекстном меню каждого объекта файловой системы будет присутствовать дополнительная команда Сохранить состояние файловой системы. Состояние Файловой системы это только системные данные файловой системы (описания файлов без их содержимого). При возникновении проблемы данный файл состояния файловой системы может быть послан в службу технической поддержки R-Studio для идентификации проблемы. При запуске с данным ключом R-Studio будет работать значительно медленнее. Также данный режим можно включить, установив флажок Отладочный режим диалогового окна Найстройки.
-flush | Сохраняет файл журнала после каждой операции записи в журнал. Запуск с данным ключом особенно полезен, когда R-Studio заблокирована и ее файл журнала остается в кэш памяти незаписанным на диск. При запуске с данным ключом R-Studio будет работать значительно медленнее.
-log <filename> | При запуске с данным ключом R-Studio сохраняет журнал в заданный файл. Если R-Studio заблокирована и ее файл журнала остается в кэш памяти незаписанным на диск, то используйте ключ -flush.
-mem <size in MB> | При запуске с данным ключом устанавливается предел использования R-Studio памяти в МБ при реконструкции дерева файлов. При превышении заданного предела появляется сообщение Too many files... . Можно временно остановить перечисление файлов и просмотреть найденные файлы. После этого можно продолжить перечисление файлов. Также можно файлы не просматривать и сразу продолжить перечисление файлов. Пример: -mem 400 - устанавливает предел использования памяти в 400 МБ.
-no_ide_ext | При запуске с данным ключом отключается запрос расширенной информации о жестких дисках в Wind9x/ME. Запуск с данным ключом может быть полезен когда R-Studio неверно выводит информацию о жестком диске (неверно определяет геометрию жесткого диска).
-no_int13 | При запуске с данным ключом отключается доступ к диску через Int13 в Wind9x/ME. Запуск с данным ключом может быть полезен при некорректной работе (неверно определяется геометрия жесткого диска, блокируется система).
-no_ios | При запуске с данным ключом отключается защитный режим системы В/В в Wind9x/ME. Запуск с данным ключом может быть полезен при некорректной работе (неверно определяется геометрия жесткого диска, блокируется система).
-reset | При запуске с данным ключом R-Studio возвращает в исходное положение контроллер жесткого диска каждый раз при чтении неисправных секторов. Запуск с данным ключом может быть полезен, когда контролер блокирует доступ при попытке чтения неисправного сектора или при неверном чтении данных.
-safe | При запуске с данным ключом отключаются автоматический поиск разделов на жестком диске, распознание файловых систем разделов и другие операции, которые могут приводить к сбоям. В данном режиме необходимо использовать команду Найти разделы контекстного меню жесткого диска, чтобы найти разделы диска вручную.

При возникновении какой-либо проблемы запустите R-Studio с ключами -debug и -log <filename> и отправьте журнал и вид главного окна (screenshot) R-Studio в службу технической поддержки R-Studio :

Специалисты круглосуточной Службы Технической Поддержки R-Studio ответят на ваш запрос в течение ближайших 4 часов.


Вкладка Свойств

Единицы размера объектов

Вы можете выбрать единицы, в которых будет отображаться размер объектов.

Чтобы выбрать единицы

1 Выберите пункт Свойства меню Вид
2 Выберите единицы, в которых будет отображаться размер объектов.

Вы можете выбрать

Отображать в байтах

Отображать в секторах

Отображать в байтах и секторах

1.Основная информация

В данном разделе приведена основная информация об объекте.

Подробнее...

Тип Диска | Тип устройства/диска и подтипы. Текущая версия R-Studio поддерживает следующие типы: Диск, WORM, CDROM, Оптический, Переключатель, Дискета, RAM Диск, LDM Раздел, LDM Компонента, LDM Том и подтипы: Устройство, Файл операционной системы, Физический Диск, Точка Монтирования, Раздел, Набор Томов, Заркальный том, Чередующийся Том, RAID 4, RAID 5, RAID 6
Имя | Имя устройства/диска
Размер | Размер устройства/диска
Тип Шины | Тип шины устройства/диска. Может быть: IDE/ATA, IDE/ATAPI, SCSI, Floppy, USB, 1394, SSA, FibreChannel, RAID, SMART, ABIOS

2.Информация о жестких и логических дисках

В данном разделе приведена имеющаяся информация о жестких и логических дисках. Данные свойства зависят от типа диска и могут быть не всегда приведены. Под ОС Windows NT/2000/XP/2003/Vista/Windows 7 диск IDE может быть показан как устройство SCSI и поэтому в поле SCSI Адрес для таких дисков будет значение OSes.

Подробнее...

Объект Операционной системы | Применимо для файлов образов под Windows 9x/ME и NT/2000/XP/2003/Vista/Windows 7, для дисков только под Windows NT/2000/XP/2003/Vista/Windows 7. Имя объекта, используемое ОС для доступа к устройству/диску.
Драйвер R-Studio | Имя драйвера (как внутренного, так и драйвера ОС), используемое для доступа к диску.
Размер Сектора | Размер сектора диска
Геометрия Физического Диска | В данном разделе приведена физическая геометрия жесткого диска. Для логического диска в данном разделе приведена физическая геометрия жесткого диска, на котором он расположен
Цилиндров |
Дорожек В Цилиндре |
Секторов В Дорожке |
Размер Сектора |
Идентификация Устройства | В данном разделе приведена информация о поставщике диска
Поставщик |
Продукт |
Микропрограмма |
Шина |
SCSI Адрес | В данном разделе приведена SCSI информация о диске
Номер Порта |
ID пути |
ID Конечного объекта |
Номер Lun |
В Windows 9x/ME добавляются следующие свойства:
Номер Диска Int13 | 128 для первого жесткого диска, доступного через Int13, 129 для второго и т.д. 0...128 для дисков и других устройств, доступных через драйвер защитного режима Windows 9x/ME, если их опция устройства Int13 отключена. R-Studio может использовать доступ к диску Int13; для дисков некоторых типов (например, устройства SCSI) доступ Int13 предпочтителен. Для таких устройств вы можете включить опцию устройства Int13 в Управлении дисками Windows.
Версия Расширенная Int13 | Поддержка Расширенной Версии Int13 для жестких дисков. Поддержка Расширенной Int13 необходима для больших жестких дисков. Если значение данного поля ноль, то Расширенная Int13 не поддерживается.

3.Свойства, контролирующие доступ к жестким и логическим дискам

В данном разделе приводятся свойства, контролирующие доступ к жестким и логическим дискам (чтение и запись). Для них установлены оптимальные значения и изменять из следует только в случае возникновения проблем доступа.

Подробнее...

Управление Диском

Максимум Передачи

Максимальный размер данных, которые могут быть прочтены или записаны в течение однократного доступа к диску. В случае возникновения проблем с доступом к диску уменьшите значение данной величины

Единица В/В

Размер данных, которые могут быть прочтены или записаны в течение однократного доступа к диску, выражен в единицах данной величины. В случае возникновения проблем с доступом к диску уменьшите значение данной величины

Выравнивание Буфера

Буфер передачи данных на диске установлен по адресу, являющемуся единицей данной величины. В случае возникновения проблем с доступом к диску увеличьте значение данной величины.

Значения трех вышеприведенных величин устанавливаются драйвером ОС. Если драйверами установлены неверные величины, то могут возникнуть проблемы при выполнении операций передачи данных. Вы можете изменять данные величины для достижения стабильности передачи данных.

Попытки В/В

Число попыток чтения/записи во время доступа к диску. Если на диске есть неисправные секторы, то увеличьте это число. Это может помочь успешно прочесть эти секторы. Если число Попыток В/В установлено слишком большим и на жестком диске есть нечитаемые сектора, то неудачные попытки чтения/записи на такие сектора могут стать причиной отказа жесткого диска в совокупности с контроллером выполнить успешные операции чтения/записи на жесткий диск. В этом случае установите значения данного параметра равным нулю.

Значение данной величины по умолчанию задается в диалоговом окне Настройки (вкладка Неисправные Сектора).

4.Свойства раздела

Раздел это некоторая непрерывная область жесткого диска, имеющая смещение и размер. Разделы есть на основных дисках, динамических дисках, найденных томах и разделах. R-Studio обрабатывает области как разделы.

Подробнее...

Смещение Раздела | Начальное смещение раздела.
Размер Раздела | Размер раздела.
Тип Раздела | Тип файловой системы раздела. Если запись в таблице разделов диска неверная, то значение данного поля может отличаться от реального типа файловой системы данного раздела. При этом R-Studio будет корректно обрабатывать данный раздел, не используя данное значение.
Номер Раздела | Только под WinNT/2000/XP/2003/Vista/Windows 7. Показывает номер раздела на жестком диске.
Значения Смещения Раздела и Типа Раздела можно вручную корректировать для областей и найденных разделов.

5.Свойства составного тома

Составной том это набор нескольких разделов или других дисковых объектов. Каждый тип набора имеет свои правила, уникальные для каждого типа составного тома. Существуют следующие составные тома: Набор Томов (RAIDs Уровень 0), Зеркальные Тома (RAIDs Уровень 1), Тома RAIDs4/5/6 (RAIDs Уровень 4/5/6) как физические, так и созданные пользователем (Виртуальные Тома, Виртуальные Чередующиеся Тома, Виртуальные Зеркальные Тома, Виртуальные Тома RAID5).

Подробнее...

Главное свойство составных томов это их родительские объекты (дисковые объекты, из которых создан составной том) и их порядок. Эти свойства могут быть просмотрены на вкладке Родительские Объекты. Для составных томов, созданных пользователем, данные свойства могут меняться.

Размер Raid Блока

Размер блока с данными для составных томов типа RAID (Уровень 0-5)

6.LDM диски и тома (Динамические Диски)

LDM диски и тома это тома, контролируемые Диспетчером Логических Дисков (LDM). На жестком диске они представлены чаще как базы данных LDM, чем таблицы разделов. Под Windows 2000/XP/2003/Vista/Windows 7 LDM диски также называются Динамическими Дисками.

Подробнее...

Смещение Логического Диска | Начальное смещение логического диска на жестком диске. Для дисков, первоначально форматированных как LDM, данная величина часто равна 31.5KB, для дисков, позднее форматированных как LDM, она может быть больше.
Поддерживаемое Число Родительских объектов | Поддерживаемое число родительских разделов для составных томов LDM. Если база данных LDM не повреждена, то данная величина должна быть равна числу родительских объектов на вкладке Родительские Объекты для дискового объекта.
GUID Хоста LDM | Глобальный Уникальный Идентификатор компьютерной системы, где была создана данная группа дисков LDM.
GUID Группы Дисков LDM | Глобальный Уникальный Идентификатор группы дисков LDM.
GUID Диска LDM | Глобальный Уникальный Идентификатор жесткого диска.
GUID Тома LDM | Глобальный Уникальный Идентификатор тома.
ID Диска LDM | Идентификатор локального жесткого диска, уникальный для данной группы дисков LDM.
ID Раздела LDM | Идентификатор локального раздела, уникальный для данной группы дисков LDM.
ID Компоненты LDM | Идентификатор локальной компоненты, уникальный для данной группы дисков LDM.
ID Тома LDM | Идентификатор локального тома, уникальный для данной группы дисков LDM.
Альт. Имя Диска LDM | Дополнительное Альтернативное Имя, данное LDM жесткому диску.
Монтирование Диска LDM | Последнее имя тома, под которым он был монтирован в системе. Может быть либо буква (C:, D: и т.д.), либо точка монтирования под Windows 2000/XP/2003.

7.Свойства Тома Файловой Системы

Том Файловой Системы (ФС) это дисковый объект с определенной, поддерживаемой R-Studio, файловой системой. Есть два типа ФС тома: ФС тома обычного дискового объекта и ФС найденного тома при сканировании. Свойства тома ФС зависят от файловой системы и типа тома.

7.1.Свойства Тома NTFS

Данные свойства показаны для всех томов NTFS и отображают их основные свойства. Для найденных томов данные свойства можно изменять.

Подробнее...

Информация NTFS | Обычных томов
Найденная NTFS | Найденных томов
Размер Кластера | Размер кластера тома NTFS.
Размер Записи MFT | Размер одной записи MFT, описывающей один файл тома NTFS. Это важная характеристика любого тома NTFS. Обычно ее значение равно 1КБ. Если данное значение неверно, то многие файлы могут быть восстановлены некорректно.
Размер Сектора | Размер сектора физического диска. Данная величина берется из загрузочного сектора NTFS и не влияет на операции R-Studio .
Размер Индекса Блока | Размер индекса блока для тома NTFS. Данная величина определяет двоичное дерево, используемое для хранения структуры папок NTFS. Данная величина не влияет на работу R-Studio .
Позиция MFT | Смещение MFT от начала тома NTFS.
Зеркальная Позиция MFT | Смещение старой копии MFT от начала тома NTFS.
Размер Тома | Размер тома NTFS. Данная величина не влияет на работу R-Studio .

7.2.Свойства Тома FAT

Данные свойства показаны для всех томов FAT и отображают их основные свойства. Для найденных томов данные свойства можно изменять.

Подробнее...

Информация FAT | Обычных томов
Найденная FAT | Найденных томов
Биты FAT (12,16,32) | Тип FAT. 12 для FAT12, 16 для FAT16, 32 для FAT32.
Размер Кластера | Размер кластера тома FAT.
Смещение Первого Кластера | Смещение первого кластера от начала тома FAT.
Кластер Загрузочной Директории | (Только для FAT32.) Номер кластера, в котором начинается корневая директория тома FAT, на котором расположен логический диск.
Смещение Корневой Директории | (Только для FAT12 и 16.) Смещение корневой директории от начала тома FAT.
Длина Корневой Директории | (Только для FAT12 и 16.) Длина корневой директории тома FAT.
Смещение Первой FAT | Смещение первой таблицы FAT тома. Данная характеристика, а также величина Размер Одной Таблицы FAT являются самыми основными характеристиками тома FAT. Если данное значение неверно, то многие файлы (особенно фрагментированные) могут быть восстановлены некорректно.
Размер Одной Таблицы FAT | Размер одной таблицы FAT тома.
Размер Сектора | Размер сектора жесткого диска. Данная величина читается из загрузочного сектора тома FAT и не влияет на работу R-Studio.
Число Копий FAT | Число копий FAT тома FAT.
Активная копия FAT | Номер таблицы активного FAT тома FAT. Может быть установлен Disabled, Auto, 1 или 2. Если установлено значение Disabled, то R-Studio обрабатывает том как в отсутствии таблицы FAT. Это может быть полезно в том случае, когда том был переформатирован, создана новая таблица FAT, а старая удалена. В этом случае следует восстанавливать файлы с предыдущего тома, не обрабатывая новый и несуществующую таблицу FAT. Все файлы будут восстановлены как непрерывная байтовая цепочка, начиная с их начального кластера. Нефрагментированные файлы будут успешно восстановлены. Если установлено значение 1 или 2, то R-Studio соответственно использует первую или вторую копию таблицы FAT. Если установлено значение Auto, то R-Studio использует обе копии таблицы FAT и решит, какая копия таблицы FAT должна быть использована для конкретного сектора таблицы FAT. Это может быть полезно в том случае, когда обе таблицы FAT частично повреждены.
Главная Версия | Версия FAT.
Малая Версия | Малая версия FAT.
Размер Тома | Размер тома.

7.3.Свойства Тома Ext2/3/4FS

Данные свойства показаны для всех томов Ext2/3/4FS и отображают их основные свойства. Для найденных томов данные свойства можно изменять.

Подробнее...

Информация Ext2FS | Обычных томов
Найденная Ext2FS | Найденных томов
Размер Блока | Размер блока файловой системы Ext2FS. Блок файловой системы Ext2/3/4FS похож на кластер файловой системы FAT.
Смещение Первого Супер-Блока | Смещение первого Супер-Блока от начала тома Ext2/3/4FS.
Блоков В Томе | Число блоков в томе Ext2/3/4FS.
INodes В Томе | Число inodes в томе Ext2/3/4FS. Inode это запись, содержащая информацию о размере, атрибутах, позиции в томе Ext2/3/4FS - т.е. всю информацию о файле, кроме его имени, которая хранится отдельно. Поэтому параметр INodes В Томе равен максимальному числу файлов в томе Ext2/3/4FS.
Созданная ОС | Операционная система, созданная этим Ext2/3/4FS томом. Может быть Linux, Hurd, Masix, FreeBSD, Lites.
Главная Версия | Версия Ext2/3/4FS. Обычно 1.
Малая Версия | Малая версия Ext2/3/4FS. Обычно 0.
Время Последнего Монтирования | Время последнего монтирования данного тома Ext2/3/4FS.
Время Последней Записи | Время последней записи данного тома Ext2/3/4FS.
Время Последней Проверки | Время последней проверки данного тома Ext2/3/4FS.
Размер Тома | Размер тома.

7.4.Свойства Найденных Томов

Данные свойства показаны для всех найденных томов, вне зависимости от типа их файловой системы. По ним можно определить, насколько верно распознаны данные тома. Это особенно полезно для оптимального поиска и выбора найденных томов для восстановления.

Подробнее...

Интерпретированные Элементы Файла | Число файлов, доказывающих, что наденный том существовал. Может принимать любые неотрицательные величины. Основное свойство, характеризующее достоверность распознания тома. Чем данное число больше, тем выше вероятность того, что у найденного тома свойства файловой системы определены корректно.
Интерпретированные Загрузочные Записи | Число загрузочных записей, доказывающих, что найденный том существовал. Может принимать значения 0 или 1. Это второе важное свойства, характеризующее достоверность распознания тома.
Оценочный Размер | Оценочный размер ФС найденного раздела/тома. Это свойство показывает наиболее вероятный размер распознанной ФС раздела/тома. В то же время для Размера и Размера Раздела устанавливаются максимально возможные значения, чтобы восстановить максимальное число файлов.


R-Studio Emergency

R-Studio Emergency это дополнительная утилита, позволяющая загрузить компьютер с поврежденным загрузочным диском и восстановить данные с его жестких дисков. Восстановленные данные могут быть сохранены как на любом диске компьютера с поврежденным загрузочным диском, так и на любом диске другого компьютера по сети.

R-Studio Emergency является частью программы R-Studio.

Когда вы покупаете одну лицензию R-Studio вы можете запускать R-Studio Emergency и инсталлировать программу R-Studio только на одном и том же компьютере, для которого куплена лицензия.

R-Studio Emergency

Контакты и Техническая Поддержка

Инсталляция R-Studio Emergency Startup Media Creator

Создание Загрузочных Устройств

Работа R-Studio Emergency

Загрузка Компьютера при помощи Загрузочного Устройства R-Studio Emergency

Восстановление Файлов

Поиск Файла

Сканирование Диска

Образы

Техническая Информация

Сетевые Диски

Свойства и Текстовый/Шестнадцатиричный Просмоторщик

Журнал

Список Поддерживаемых Устройств


Контакты и Техническая Поддержка

Для загрузки последней версии R-Studio Emergency посетите официальный сайт:

Сайт Продукта: http://www.r-tt.com

Отдел Продаж: sales@r-tt.com

Специалисты круглосуточной службы технической поддержки R-Studio ответят на ваш запрос в течение ближайших 4 часов.

Техническая поддержка: support@r-tt.com

Запрос технической поддержки: http://www.r-tt.com/Support_request.html

Форум R-tt: http://forum.r-tt.com/ru


Инсталляция R-Studio Emergency Startup Media Creator

Внимание пользователей Windows NT/2000/XP/2003/Vista/2008/Windows 7! Вам необходимы права администратора для инсталляции R-Studio Emergency Startup Media Creator.

Обратитесь за помощью к вашему системному администратому, если вам неизвестно, обладаете ли вы правами администратора на вашем компьютере.

1. Запустите инсталляционный файл.
2. Следуйте указаниям на экране вашего компьютера.

Вы можете создать загрузочное устройства даже до завершения процесса инсталляции.


Создание Загрузочных Устройств

Вы можете создать:

· Загрузочный CD/DVD диск. Вы можете создать ISO образ для загрузочного CD/DVD диска или создать CD/DVD диск прямо из R-Studio Emergency Startup Media Creator, если у вас имеется устройство записи CD/DVD.

или

· Загрузочный съемный диск, форматированный в FAT/FAT32 (BIOS компьютера должен поддерживать загрузку с такого диска). Размер данного диска должен быть более 50 MБ.

или

· Комплект из двух загрузочных дискет для версии R-Studio Emergency TUI (Text User Interface) и пяти загрузочных дискет для версии R-Studio Emergency GUI (Graphic User Interface)

Просмотрите Список Поддерживаемых Устройств.

Если вам не удается загрузить компьтер при помощи загрузочного устройства R-Studio Emergency, то необходимо установить флажок Настройка параметров совместимости загрузочного устройства с аппаратной частью ПК в диалоговом окне Выбор типа загрузочного устройства. После этого откроется диалоговое окно Параметры Совместимости Загрузочного Устройства с Аппаратной частью ПК. Для устранения возможных проблем необходимо произвести соответствующие настройки.

При запуске R-Studio Emergency Startup Media Creator открывается диалоговое окно Приветствия:

Диалоговое окно Приветствия R-Studio Emergency Startup Media Creator

Диалоговое окно Приветствия

нажмите кнопку Далее, чтобы увидеть список загрузочных устройств, которые вы можете создать.

Диалоговое окно Выбор типа загрузочного устройства

Чтобы создать загрузочный CD/DVD диск прямо из R-Studio Emergency Startup Media Creator (если у вас имеется устройство записи CD/DVD):

1 Запустите R-Studio Emergency
2 Выберите CD/DVD-RW в диалоговом окне Выбор типа загрузочного устройства и нажмите кнопку Далее
3 Прочтите и примите условия Лицензионного Соглашения, введите регистрационный ключ в диалоговом окне Регистрация R-Studio Emergency и нажмите кнопку Далее
Диалоговое окно Регистрации R-Studio Emergency
4 Вставьте чистый CD/DVD диск в устройство записи CD/DVD и нажмите кнопку Далее
Диалоговое окно Вставьте загрузочный CD/DVD
> R-Studio Emergency Startup Media Creator начнет создавать загрузочный CD/DVD диск, процесс создания будет отображаться в диалоговом окне Создание загрузочного устройства
Диалоговое окно Создание загрузочного устройства

После окончания создания загрузочного CD/DVD диска появится диалоговое окно R-Studio Emergency Создание Загрузочного Устройства Завершено

Вы можете либо выйти из R-Studio Emergency Startup Media Creator, нажав кнопку Готово, либо создать другое загрузочное устройство, нажав кнопку Назад.

Диалоговое окно Создание Загрузочного Устройства Завершено

Чтобы создать ISO образ для загрузочного CD/DVD диска

1 Запустите R-Studio Emergency
2 Выберите ISO образ для загрузочного CD/DVD в диалоговом окне R-Studio Emergency Выбор типа загрузочного устройства и нажмите кнопку Далее
3 Прочтите и примите условия Лицензионного Соглашения, введите регистрационный ключ в диалоговом окне Регистрация R-Studio Emergency и нажмите кнопку Далее
4 Выберите местоположение и имя файла ISO образа для загрузочного CD/DVD и нажмите кнопку Сохранить
> Когда R-Studio Emergency Startup Media Creator закончит создание файла ISO образа, появится диалоговое окно R-Studio Emergency Создание Загрузочного Устройства Завершено

Вы можете либо выйти из R-Studio Emergency Startup Media Creator, нажав кнопку Готово, либо создать другое загрузочное устройство, нажав кнопку Назад.

Диалоговое окно R-Studio Emergency Создание Загрузочного Устройства Завершено
5 Создайте загрузочный CD/DVD, используя любую программу записи ISO образа на CD/DVD диск

Загрузите ISO образ в программу записи ISO образа на CD/DVD диск. Для получения более подробной информации воспользуйтесь справкой к данной программе.

Чтобы создать загрузочный съемный диск FAT/FAT32

1 Запустите R-Studio Emergency
2 Выберите Съемный Диск в диалоговом окне Выбор типа загрузочного устройства и нажмите кнопку Далее
3 Прочтите и примите условия Лицензионного Соглашения, введите регистрационный ключ в диалоговом окне Регистрация R-Studio Emergency и нажмите кнопку Далее
4 Проверьте, что съемный диск, форматированный в FAT/FAT32, готов и нажмите кнопку Далее
Диалоговое окно Вставьте загрузочное устройство
> R-Studio Emergency Startup Media Creator начнет создавать загрузочный диск, процесс создания будет отображаться в диалоговом окне Создание загрузочного устройства

Когда R-Studio Emergency Startup Media Creator закончит создание загрузочного диска, появится диалоговое окно R-Studio Emergency Создание Загрузочного Устройства Завершено

Вы можете либо выйти из R-Studio Emergency Startup Media Creator, нажав кнопку Готово, либо создать другое загрузочное устройство, нажав кнопку Назад.

Диалоговое окно Создание Загрузочного Устройства Завершено

Чтобы создать комплект из загрузочных дискет:

Вам понадобятся две отформатированные дискеты для версии R-Studio Emergency TUI (Text User Interface) и пять отформатированных дискет для версии R-Studio Emergency GUI (Graphic User Interface).

1 Запустите R-Studio Emergency
2 Выберите Дискета в диалоговом окне Выбор типа загрузочного устройства и нажмите кнопку Далее
3 Прочтите и примите условия Лицензионного Соглашения, введите регистрационный ключ в диалоговом окне Регистрация R-Studio Emergency и нажмите кнопку Далее
4 Вставьте первую дискету и нажмите кнопку Далее в диалоговом окне Вставьте загрузочное устройство
> R-Studio Emergency Startup Media Creator начнет создавать первую загрузочную дискету, процесс создания будет отображаться в диалоговом окне Создание загрузочного устройства
5 Вставьте вторую загрузочную дискету и нижмите кнопку OK, когда появится сообщение Вставьте форматированную дискету #2 в дисковод A:
> Когда R-Studio Emergency Startup Media Creator закончит создание второй загрузочной дискеты, появится диалоговое окно R-Studio Emergency Создание Загрузочного Устройства Завершено

Вы можете либо выйти из R-Studio Emergency Startup Media Creator, нажав кнопку Готово, либо создать другое загрузочное устройство, нажав кнопку Назад.

Диалоговое окно Создание Загрузочного Устройства Завершено

Параметры Совместимости Загрузочного Устройства с Аппаратной частью ПК

Настройки данных параметров помогут устранить возможные проблемы при загрузке компьтера при помощи загрузочного устройства R-Studio Emergency. Для получения более подробной информации свяжитесь со специалистами Службы Технической Поддержки R-Studio.

Диалоговое окно Параметры Совместимости Загрузочного Устройства с Аппаратной частью ПК
Показывать сообщения при загрузке ядра | если установлен данный флажок, то R-Studio Emergency отобразит все сообщения во время загрузки компьютера. Это может помочь выявить источник проблемы в случае, если система не загружается при использовании загрузочного устройства R-Studio Emergency.
Отключить ACPI Отключить APIC | Установите данные флажки, если при загрузке компьютера при помощи загрузочного устройства R-Studio Emergency система неверно определяет аппаратные компоненты компьютера и появляются сообщения вида: hda: lost interrupt
Отключить поддержку устройств USB | Установите данный флажок, если при загрузке компьютера при помощи загрузочного устройства R-Studio Emergency возникают проблемы с устройствами USB.
Отключить DMA для всех дисков IDE | Установите данный флажок, если при загрузке компьютера при помощи загрузочного устройства R-Studio Emergency возникают проблемы с дисками IDE.
PCI BIOS | Выберите соответствующий параметр, если при загрузке компьютера при помощи загрузочного устройства R-Studio Emergency возникают проблемы с PCI картами.
BIOS RAIDS | Выберите соответствующий параметр, если при загрузке компьютера при помощи загрузочного устройства R-Studio Emergency возникают проблемы со встроенными устройствами RAID.


Работа R-Studio Emergency

Загрузка Компьютера при помощи Загрузочного Устройства R-Studio Emergency

Восстановление Файлов

Поиск Файла

Сканирование Диска

Образы

Техническая Информация

Свойства и Текстовый/Шестнадцатиричный Просмоторщик

Сетевые Диски

Журнал

Список Поддерживаемых Устройств

R-Studio Emergency

Контакты и Техническая Поддержка

Инсталляция R-Studio Emergency Startup Media Creator

Создание Загрузочных Устройств


Загрузка Компьютера при помощи Загрузочного Устройства R-Studio Emergency

Рекомендуется распечатать эту страницу справки и всегда иметь ее под рукой, выполняя описанные здесь действия.

Если у вас не IDE жесткий диск или вы собираетесь использовать сетевые диски или внешние устройства, то прежде ознакомьтесь со Списком Поддерживаемых Устройств.

Если вы собираетесь использовать внешние устройства, то включите их прежде, чем загружать компьютер.

Если материнская плата вашего компьютера поддерживает устройства Serial ATA (SATA), но у вас также есть IDE диски, то установите в BIOS вашего компьютера Enhanced Mode только для SATA устройств.

Чтобы загрузить компьютер при помощи R-Studio Emergency загрузочного CD/DVD или любого другого съемного устройства

1 Проверьте, чтобы первым загрузочным устройством в BIOS был установлен CD/DVD или съемное устройство.

Для получения более подробной информации обратитесь к руководству вашего компьютера.

2 Вставьте R-Studio Emergency загрузочный CD/DVD и загрузите ваш компьютер
> Запустится R-Studio Emergency и появится панель Device/Disk

Чтобы загрузить компьютер при помощи загрузочных дискет R-Studio Emergency

1 Проверьте, чтобы первым загрузочным устройством в BIOS вашего компьютера был установлен A (Дискета)

Для получения более подробной информации обратитесь к руководству вашего компьютера.

2 Вставьте первую загрузочную дискету и загрузите ваш компьютер
> На экране вашего компьютера появится следующий текст:

Loading

Uncompressing ... OK, starting the kernel

VFS: Insert the second boot disk and press ENTER
3 Вставьте вторую дискету и нажмите клавишу ENTER.
> Запустится R-Studio Emergency и появится панель Device/Disk


Восстановление Файлов

Чтобы восстановить файлы

1 Выберите раздел на панели Device/Disk, на котором были расположены утраченные файлы, и нажмите клавишу Enter
> Появится панель Files View R-Studio, на которой будет показана структура папок/файлов вашего диска
2 Выберите файл, который вы желаете восстановить, на панели Files View. Для переключения между панелями используйте клавишу Tab
3 Нажмите клавишу F2 и выберите папку, в которую вы хотите восстановить файл, в диалоговом окне Recover

Внешние USB диски с файловой системой NTFS: R-Studio Emergency может сохранить восстановленные файлы на таких дисках, если они были правильно отключены от системы под Windows через иконку Безопасное Извлечение Устройств в системном трее или при завершении работы Windows.

Поиск Файла

Подключение Сетевых Дисков

Просмотр свойств объекта


Поиск Файла

Чтобы найти файл

1 Выберите пункт Find меню Tools (или нажмите клавиши Alt+F)
2 Задайте имя файла или маску

Опции Look at диалогового окна Find

Deleted files: | Если установить данный флажок, то R-Studio произведет поиск среди удаленных файлов/папок.
Existing files: | Если установить данный флажок, то R-Studio произведет поиск среди существующих файлов/папок.
Files: | Если установить данный флажок, то R-Studio будет искать среди файлов.
Folders: | Если установить данный флажок, то R-Studio будет искать среди папок.

Чтобы найти следующий файл, соответствующий заданной маске

* Нажмите клавиши Alt+N


Сканирование Диска

Чтобы сканировать объект

1 Выберите объект на панели Device/Disk и нажмите клавишу F6
2 Задайте необходимые параметры в диалоговом окне Scan и нажмите клавишу Enter

Диалоговое окно Scan

Start: | Точка начала сканируемой области.
Size: | Размер сканируемой области объекта.
Значения указанных полей могут быть выражены в байтах или секторах. Значения указанных полей выражены в байтах, если кроме цифровых значений в полях ничего нет. Возможны следующие условные обозначения (без учета регистра):
b kb mb gb tb | Байты Килобайты Мегабайты Гигабайты Терабайты
> На найденных после сканирования объектах можно искать и восстанавливать файлы как на обычном объекте

Найденные объекты:

Extra Found Files | Найдены файлы известного типа
Recognized1 | На таком разделе были найдены как загрузочные записи, так и файлы
Recognized2 | На таком разделе были найдены только файлы
Recognized3 | На таком разделе были найдены только загрузочные записи

Чтобы сохранить информацию о сканировании

1 Выберите объект с информацией о сканировании
2 Нажмите клавиши Alt+D или выберите пункт Save Scan Information меню Drive
3 Задайте папку и имя файла в диалоговом окне Save Scan Information

Подключение Сетевых Дисков

Чтобы открыть информацию о сканировании

1 Выберите объект, для которого необходимо открыть информацию о сканировании
2 Нажмите клавиши Alt+D или выберите пункт Open Scan Information меню Drive
3 Выберите необходимый файл с информацией о сканировании в диалоговом окне Open Scan Information

Подключение Сетевых Дисков

Чтобы удалить информацию о сканировании

1 Выберите объект, для которого необходимо удалить информацию о сканировании
3 Нажмите клавиши Alt+D или выберите пункт Delete Scan Information меню Drive


Образы

Чтобы создать файл образа

1 Выберите объект на панели Device/Disk
2 Нажмите клавиши Alt+D и выберите пункт Create Plain Image File или Create Compressed Image File меню Drive
Plain Image | При выборе данного пункта R-Studio создаст точную копию объекта. Данный формат образа совместим с форматами предыдущих версий R-Studio.
Compressed Image | При выборе данного пункта R-Studio создаст файл образа, совместимый с образами, созданными программой R-Drive Image, но несовместимый в образами предыдущих версий R-Studio.
3 Задайте имя и местоположение файла образа в диалоговом окне Create Image File

Подключение Сетевых Дисков

Чтобы загрузить файл образа

1 Нажмите клавиши Alt+D или выберите пункт Open Image File меню Drive
2 Выберите необходимый файл образа в диалоговом окне Open Image File

Подключение Сетевых Дисков


R-Studio Emergency Техническая Информация

Сетевые Диски

Свойства и Текстовый/Шестнадцатиричный Просмоторщик

Журнал

R-Studio Emergency

Контакты и Техническая Поддержка

Инсталляция R-Studio Emergency Startup Media Creator

Создание Загрузочных Устройств

Работа R-Studio Emergency

Загрузка Компьютера при помощи Загрузочного Устройства R-Studio Emergency

Восстановление Файлов

Поиск Файла

Сканирование Диска

Образы

Список Поддерживаемых Устройств


Свойства и Текстовый/Шестнадцатиричный Просмоторщик

Чтобы просмотреть свойства объекта

1 Выберите объект
2 Нажмите клавишу F7

Чтобы просмотреть объект

1 Выберите объект
2 Нажмите клавишу F3
> Нажмите клавишу F6, чтобы просмотреть и выбрать атрибуты файла

Нажмите клавишу Esc, чтобы закрыть просмоторщик.


Сетевые Диски

Чтобы подключить сетевой диск

1 В диалоговом окне Map Network Drive нажмите клавиши Alt+M
> Появится сообщение Querying DHCP

Если в сети имеется DHCP сервер, то ваш компьютер получит IP адрес автоматически. В диалоговом окне Network Adapters будет отображен список сетевых адаптеров и их IP адреса.

Если в сети не имеется DHCP сервер, то вы должны выбрать сетевой адаптер в диалоговом окне Network Adapters и нажать клавишу F4. Введите IP адрес и маску подсети и нажмите клавишу Enter.

2 Выберите сконфигурированный сетевой адаптер и нажмите клавишу Enter
3 Введите необходимую информацию в диалоговом окне Map Network Drive
Server IP Address: | IP адрес компьютера, на котором расположен сетевой диск.
Server Share Name: | Имя сетевой папки компьютера, на котором расположен сетевой диск.
Login: | Имя пользователя компьютера, на котором расположен сетевой диск.
Password: | Пароль пользователя компьютера, на котором расположен сетевой диск.
> Появится подключенный сетевой диск

Чтобы отключить сетевой диск

1 Выберите подключенный сетевой диск
2 Перейдите на кнопку Disconnect и нажмите клавишу Enter


Журнал

Чтобы очистить журнал

* Выберите пункт Clear Log меню Tools

Чтобы сохранить журнал в файл

* Выберите пункт Save Log To File меню Tools


R-Studio Emergency - Список Поддерживаемых Устройств

R-Studio Emergency поддерживает следующие устройства:

Устройства Хранения Данных

Сетевые Устройства

Serial ATA and Parallel ATA drivers

ACPI firmware driver for PATA

AHCI SATA

ALi PATA

AMD/NVidia PATA

ARTOP 6210/6260 PATA

ARTOP/Acard ATP867X PATA

ATI PATA

CMD / Silicon Image 680 PATA

CMD640 PCI PATA

CMD64x PATA

CS5510/5520 PATA

CS5530 PATA

CS5535 PATA

CS5536 PATA

Compaq Triflex PATA

Cypress CY82C693 PATA

EFAR SLC90E66

Generic ATA

HPT 343/363 PATA

HPT 366/368 PATA

HPT 370/370A/371/372/374/302 PATA

HPT 372N/302N PATA

IT8211/2 PATA

IT8213 PATA

Initio 162x SATA

Intel ESB, ICH, PIIX3, PIIX4 PATA/SATA

Intel PATA MPIIX

Intel PATA old PIIX

Intel SCH PATA

JMicron PATA

Legacy ISA PATA

Marvell PATA support via legacy mode

Marvell SATA

NETCELL Revolution RAID

NVIDIA SATA

Nat Semi NS87410 PATA

Nat Semi NS87415 PATA

Ninja32/Delkin Cardbus ATA

OPTI FireStar PATA

OPTI621/6215 PATA

Older Promise PATA controller

PCMCIA PATA

Pacific Digital ADMA

Pacific Digital SATA QStor

Platform AHCI SATA

Promise PATA 2027x

Promise SATA SX4

Promise SATA TX2/TX4

QDI VLB PATA

RADISYS 82600 PATA

RDC PATA

SC1200 PATA

SERVERWORKS OSB4/CSB5/CSB6/HT1000 PATA

ServerWorks Frodo / Apple K2 SATA

SiS 964/965/966/180 SATA

SiS PATA

Silicon Image 3124/3132 SATA

Silicon Image SATA

ULi Electronics SATA

VIA PATA

VIA SATA

VITESSE VSC-7174 / INTEL 31244 SATA

Winbond SL82C105 PATA

Winbond W83759A VLB PATA

SCSI low-level drivers

3ware 5/6/7/8xxx ATA-RAID

3ware 97xx SAS/SATA-RAID

3ware 9xxx SATA-RAID

7000FASST SCSI

ACARD SCSI

ARECA (ARC11xx/12xx/13xx/16xx) SATA/SAS RAID Host Adapter

Adaptec AACRAID

Adaptec AHA152X/2825

Adaptec AHA1542

Adaptec AIC79xx U320

Adaptec AIC7xxx

Adaptec AIC7xxx Fast -> U160

Adaptec AIC94xx SAS/SATA

Adaptec I2O RAID

AdvanSys SCSI

Always IN2000 SCSI

BusLogic SCSI

DMX3191D SCSI

DTC3180/3280 SCSI

EATA ISA/EISA/PCI (DPT and generic EATA/DMA-compliant boards)

Emulex LightPulse Fibre Channel Support

Future Domain 16xx SCSI/AHA-2920A

Generic NCR5380/53c400 SCSI MMIO

Generic NCR5380/53c400 SCSI PIO

HP Smart Array SCSI driver

HighPoint RocketRAID 3xxx/4xxx Controller

IBM Power Linux RAID adapter

IBM ServeRAID

Initio 9100U(W)

Initio INI-A100U2W

Intel/ICP (former GDT SCSI Disk Array) RAID Controller

LSI Logic Legacy MegaRAID Driver

LSI Logic Management Module

LSI Logic MegaRAID Driver

LSI Logic MegaRAID SAS RAID Module

LSI MPT Fusion SAS 2.0 Device Driver

Marvell 88SE64XX/88SE94XX SAS/SATA

NCR53c406a SCSI

PAS16 SCSI

PMC SIERRA Linux MaxRAID adapter

PMC-Sierra SPC 8001 SAS/SATA Based Host Adapter driver

Promise SuperTrak EX Series

QLogic ISP4XXX host adapter family

QLogic QLA2XXX Fibre Channel Support

Qlogic FAS SCSI

Qlogic QLA 1240/1x80/1x160 SCSI

SYM53C8XX Version 2 SCSI

Symbios 53c416 SCSI

Tekram DC390(T) and Am53/79C974 SCSI

Tekram DC395(U/UW/F) and DC315(U) SCSI

Trantor T128/T128F/T228 SCSI

UltraStor 14F/34F

UltraStor SCSI

VMware PVSCSI driver

Workbit NinjaSCSI-32Bi/UDE

USB support

Cypress C67x00 HCD

Datafab Compact Flash Reader

Freecom USB/ATAPI Bridge

ISD-200 USB/ATA Bridge

ISP 1760 HCD

ISP116X HCD

ISP1362 HCD

Lexar Jumpshot Compact Flash Reader

OXU210HP HCD

Olympus MAUSB-10/Fuji DPC-R1

R8A66597 HCD

SL811HS HCD

SanDisk SDDR-09 (and other SmartMedia, including DPCM)

SanDisk SDDR-55 SmartMedia

USB 2.0

USB Mass Storage

USB Monitor

USBAT/USBAT02-based storage

xHCI HCD (USB 3.0)

Block devices

Compaq SMART2

Compaq Smart Array 5xxx

Mylex DAC960/DAC1100 PCI RAID Controller

Normal floppy disk

Promise SATA SX8

IEEE 1394 (FireWire) support

Legacy alternative FireWire driver stack

Storage devices (SBP-2 protocol)

PCMCIA network device support

3Com 3c574 PCMCIA

3Com 3c589 PCMCIA

Asix AX88190 PCMCIA

COM20020 ARCnet PCMCIA

Fujitsu FMV-J18x PCMCIA

NE2000 compatible PCMCIA

New Media PCMCIA

SMC 91Cxx PCMCIA

Xircom 16-bit PCMCIA

Other devices

Microsoft Hyper-V Utilities driver

Microsoft Hyper-V client drivers

Microsoft Hyper-V virtual block driver

Microsoft Hyper-V virtual network driver

Microsoft Hyper-V virtual storage driver

Ethernet (10 or 100Mbit)

3c501 `EtherLink`

3c503 `EtherLink II`

3c505 `EtherLink Plus`

3c507 `EtherLink 16`

3c509/3c529 (MCA)/3c579 `EtherLink III`

3c515 ISA `Fast EtherLink`

3c590/3c900 series (592/595/597) `Vortex/Boomerang`

3cr990 series `Typhoon`

AMD 8111 (new PCI lance)

AMD LANCE and PCnet (AT1500 and NE2100)

AMD PCnet32 PCI

AT1700/1720

Adaptec Starfire/DuraLAN

Ansel Communications EISA 3200

Apricot Xen-II on board Ethernet

Atheros L2 Fast Ethernet

Broadcom 440x/47xx ethernet

CS89x0

Cabletron E21xx

DECchip Tulip (dc2114x) PCI

Dave ethernet support (DNET)

Davicom DM910x/DM980x

Early DECchip Tulip (dc2104x) PCI

EtherExpress 16

EtherExpressPro support/EtherExpress 10 (i82595)

Generic DECchip & DIGITAL EtherWORKS PCI/EISA

HP 10/100VG PCLAN (ISA, EISA, PCI)

HP PCLAN (27245 and other 27xxx series)

HP PCLAN+ (27247B and 27252A)

ICL EtherTeam 16i/32

Intel(R) PRO/100+

LP486E on board Ethernet

Myson MTD-8xx PCI Ethernet

NE2000/NE1000

NI5010

NI5210

NI6510

National Semiconductor DP8381x series PCI Ethernet

OpenCores 10/100 Mbps Ethernet MAC

PCI NE2000 and clones support (see help)

RDC R6040 Fast Ethernet Adapter

RealTek RTL-8129/8130/8139 PCI Fast Ethernet Adapter

RealTek RTL-8139 C+ PCI Fast Ethernet Adapter

SEEQ8005

SMC 9194

SMC EtherPower II

SMC Ultra

SMSC LAN9420 PCI ethernet adapter

SiS 900/7016 PCI Fast Ethernet Adapter

Silan SC92031 PCI Fast Ethernet Adapter driver

Sun Cassini

Sun GEM

Sun Happy Meal 10/100baseT

Sundance Alta

TI ThunderLAN

ULi M526x controller

VIA Rhine

WD80*3

Winbond W89c840 Ethernet

Zenith Z-Note

nForce Ethernet

Ethernet (1000 Mbit)

Alteon AceNIC/3Com 3C985/NetGear GA620 Gigabit

Atheros L1C Gigabit Ethernet

Atheros L1E Gigabit Ethernet

Atheros/Attansic L1 Gigabit Ethernet

Broadcom CNIC

Broadcom NetXtremeII

Broadcom Tigon3

DL2000/TC902x-based Gigabit Ethernet

IP1000 Gigabit Ethernet

Intel(R) 82575/82576 PCI-Express Gigabit Ethernet

Intel(R) 82576 Virtual Function Ethernet

Intel(R) PRO/1000 Gigabit Ethernet

Intel(R) PRO/1000 PCI-Express Gigabit Ethernet

JMicron(R) PCI-Express Gigabit Ethernet

National Semiconductor DP83820

New SysKonnect GigaEthernet

Packet Engines Hamachi GNIC-II

Packet Engines Yellowfin Gigabit-NIC

QLogic QLA3XXX Network Driver Support

Realtek 8169 gigabit ethernet

SiS190/SiS191 gigabit ethernet

SysKonnect Yukon2

VIA Velocity

Ethernet (10000 Mbit)

Broadcom NetXtremeII 10Gb

Chelsio 10Gb Ethernet

Chelsio Communications T3 10Gb Ethernet

Chelsio Communications T4 Ethernet

Cisco VIC Ethernet NIC Support

Intel(R) 10GbE PCI Express adapters

Intel(R) PRO/10GbE

Mellanox Technologies 10Gbit Ethernet

Myricom Myri-10G Ethernet

NetXen Multi port (1/10) Gigabit Ethernet NIC

Neterion X3100 Series 10GbE PCIe Server Adapter

QLOGIC QLCNIC 1/10Gb Converged Ethernet NIC Support

QLogic QLGE 10Gb Ethernet Driver Support

S2IO 10Gbe XFrame NIC

ServerEngines' 10Gbps NIC - BladeEngine

Solarflare Solarstorm SFC4000/SFC9000-family

Sun Neptune 10Gbit Ethernet

Tehuti Networks 10G Ethernet

Token Ring driver support

3Com 3C359 Token Link Velocity XL adapter

Generic TMS380 PCI

Generic TMS380 Token Ring ISA/PCI adapter

IBM Lanstreamer chipset PCI adapter

IBM Olympic chipset PCI adapter

IBM Tropic chipset based adapter

Madge Smart 16/4 PCI Mk2

Proteon ISA

SMC ISA/MCA adapter

SysKonnect TR4/16 ISA

USB Network Adapters

ASIX AX88xxx Based USB 2.0 Ethernet Adapters

CDC EEM

CDC Ethernet support (smart devices such as cable modems)

Davicom DM9601 based USB 1.1 10/100 ethernet devices

GeneSys GL620USB-A based cables

Host for RNDIS and ActiveSync devices

MosChip MCS7830 based Ethernet adapters

NetChip 1080 based cables (Laplink, ...)

Prolific PL-2301/2302 based cables

SMSC LAN95XX based USB 2.0 10/100 ethernet devices

Sharp Zaurus (stock ROMs) and compatible

Simple USB Network Links (CDC Ethernet subset)

USB CATC NetMate-based Ethernet device

USB KLSI KL5USB101-based ethernet device

USB Pegasus/Pegasus-II based ethernet device

USB RTL8150 based ethernet device


R-Studio Agent Emergency

R-Studio Agent Emergency это вспомогательная утилита, позволяющая загрузить удаленный компьютер с поврежденным загрузочным диском и восстановить данные с его жестких дисков по сети.

R-Studio Agent Emergency имеет следующий принцип работы: необходимо загрузить удаленный компьютер при помощи загрузочного устройства R-Studio Agent Emergency, при необходимости вручную сконфигурировать сетевой интерфейс R-Studio Agent Emergency. После загрузки жесткие диски удаленного компьютера станут доступными для R-Studio , инсталлированного на другом компьютере в сети.

Контакты и Техническая Поддержка

Инсталляция R-Studio Agent Emergency Startup Media Creator

Создание Загрузочных Устройств

Загрузка Компьютера при помощи Загрузочного Устройства R-Studio Agent Emergency

Список Поддерживаемых Устройств

Контроллеры Дисков

Сетевые Карты


Контакты и Техническая Поддержка

Для загрузки последней версии R-Studio Agent Emergency посетите официальный сайт:

Сайт Продукта: http://www.r-tt.com

Отдел Продаж: sales@r-tt.com

R-Studio Специалисты нашей круглосуточной службы технической поддержки ответят на ваш запрос в течение ближайших 4 часов.

Техническая Поддержка: support@r-tt.com

Запрос технической поддержки: http://www.r-tt.com/Support_request.html

Форум R-tt: http://forum.r-tt.com/ru


Инсталляция R-Studio Agent Emergency Startup Media Creator

Внимание пользователей Windows NT/2000/XP/2003/Vista/2008/Windows 7! Вам необходимы права администратора для инсталляции R-Studio Agent Emergency Startup Media Creator.

Обратитесь за помощью к вашему системному администратору, если вам неизвестно, обладаете ли вы правами администратора на вашем компьтере.

1. Запустите инсталляционный файл.
2. Следуйте указаниям на экране вашего компьютера.

Вы можете создать загрузочное устройства даже до завершения процесса инсталляции.


Создание Загрузочных Устройств

Вы можете создать

· Загрузочный CD/DVD диск. Вы можете создать ISO образ для загрузочного CD/DVD диска или создать CD/DVD диск прямо из R-Studio Agent Emergency Startup Media Creator, если у вас имеется устройство записи CD/DVD.

или

· Загрузочный съемный диск, форматированный в FAT/FAT32 (BIOS компьютера должен поддерживать загрузку с такого диска). Размер данного диска должен быть более 10 МБ.

или

· 4 загрузочные дискеты

Просмотрите Список Поддерживаемых Устройств.

При запуске R-Studio Agent Emergency Startup Media Creator откроется диалоговое окно Приветствия:

Диалоговое окно Приветствия R-Studio Agent Emergency Startup Media Creator

Диалоговое окно Приветствия

нажмите кнопку Далее чтобы увидеть список возможных загрузочных устройств.

Диалоговое окно Выбор загрузочного устройства

Чтобы создать загрузочный CD/DVD диск прямо из R-Studio Agent Emergency Startup Media Creator (если имеется устройство записи CD/DVD):

1. Запустите R-Studio Agent Emergency

2. В диалоговом окне Выбор загрузочного устройства выберите устройство записи CD/DVD и нажмите кнопку Далее

3. Прочтите и примите Лицензионное Соглашение, введите регистрационный ключ R-Studio Agent в диалоговом окне Активация R-Studio Agent Emergency и нажмите кнопку Далее

Обратите внимание: Вы должны ввести регистрационный ключ R-Studio Agent, а не R-Studio.

Диалоговое окно Лицензионное Соглашение R-Studio Agent Emergency
Диалоговое окно Активация R-Studio Agent Emergency

если вы не введете регистрационный ключ, то R-Studio Agent Emergency продолжит работу в Демонстрационном режиме. Регистрационный ключ можно ввести позже, при подключении R-Studio Agent Emergency и R-Studio

4. Вставьте чистый CD/DVD диск в устройство записи CD/DVD и нажмите кнопку Далее

Диалоговое окно Вставьте загрузочный диск
> R-Studio Agent Emergency Startup Media Creator начнет создавать загрузочный CD/DVD диск, процесс создания будет отображаться в диалоговом окне Создание загрузочного устройства
Диалоговое окно Создание загрузочного устройства

После окончания создания загрузочного CD/DVD диска появится диалоговое окно R-Studio Agent Emergency Создание Загрузочного Устройства Завершено

Вы можете либо выйти из R-Studio Emergency Startup Media Creator, нажав кнопку Готово, либо создать другое загрузочное устройство, нажав кнопку Назад.

Диалоговое окно Создание Загрузочного Устройства Завершено

Чтобы создать ISO образ для загрузочного CD/DVD диска

1. Запустите R-Studio Agent Emergency

2. Выберите ISO образ для загрузочного CD/DVD в диалоговом окне Выбор загрузочного устройства и нажмите кнопку Далее

3. Прочтите и примите условия Лицензиаонного Соглашения, введите регистрационный ключ в диалоговом окне Активация Активация R-Studio Agent Emergency и нажтите кнопку Далее

Обратите внимание: Вы должны ввести регистрационный ключ R-Studio Agent, а не R-Studio.

если вы не введете регистрационный ключ, то R-Studio Agent Emergency продолжит работу в Демонстрационном режиме. Регистрационный ключ можно ввести позже, при подключении R-Studio Agent Emergency и R-Studio

4. Выберите местоположение и имя файла ISO образа для загрузочного CD/DVD и нажмите кнопку Сохранить

> Когда R-Studio Bootable Startup Media Creator закончит создание файла ISO, появится диалоговое окно R-Studio Agent Emergency Создание Загрузочного Устройства Завершено

Вы можете либо выйти из R-Studio Bootable Startup Media Creator, нажав кнопку Готово, либо создать другое загрузочное устройство, нажав кнопку Назад.

Диалоговое окно R-Studio Agent Emergency Создание Загрузочного Устройства Завершено

5. Создайте загрузочный CD/DVD, используя любую программу записи ISO образа на CD/DVD диск

Загрузите ISO образ в программу записи ISO образа на CD/DVD диск. Для получения более подробной информации воспользуйтесь справкой к данной программе.

Чтобы создать загрузочный диск FAT/FAT32

1. Запустите R-Studio Agent Emergency

2. Выберите Съемный Диск в диалоговом окне Выбор типа загрузочного устройства и нажмите кнопку Далее

3. Прочтите и примите условия Лицензионного Соглашения, введите регистрационный ключ в диалоговом окне Активация R-Studio Agent Emergency и нажмите кнопку Далее

4. Проверьте, что съемный диск, форматированный в FAT/FAT32, готов и нажмите кнопку Далее

Диалоговое окно Вставьте загрузочное устройство
> R-Studio Agent Emergency Startup Media Creator начнет создавать загрузочный диск, процесс создания будет отображаться в диалоговом окне Создание загрузочного устройства

Когда R-Studio Agent Emergency Startup Media Creator закончит создание загрузочного устройства, появится диалоговое окно R-Studio Agent Emergency Создание Загрузочного Устройства Завершено

Вы можете либо выйти из R-Studio Emergency Startup Media Creator, нажав кнопку Готово, либо создать другое загрузочное устройство, нажав кнопку Назад.

Диалоговое окно Создание Загрузочного Устройства Завершено

Чтобы создать комплект из загрузочных дискет:

Вам понадобятся четыре отформатированные дискеты.

1. Запустите R-Studio Agent Emergencyun R-Studio Agent Emergency

2. Выберите Дискета в диалоговом окне Выбор типа загрузочного устройства и нажмите кнопку Далее

3. Введите регистрационную информацию и регистрационный ключ в диалоговом окне Регистрация и нажмите кнопку Далее

Если вы оставите данные поля незаполненными, то R-Studio Agent Emergency продолжит свою работу в Демонстрационном режиме

4. Вставьте дискету и нажмите кнопку Далее в диалоговом окне Вставьте загрузочное устройство

Диалоговое окно Вставьте загрузочное устройство
> R-Studio Agent Emergency Startup Media Creator начнет создавать первую загрузочную дискету, процесс создания будет отображаться в диалоговом окне Создание загрузочного устройства
Диалоговое окно Создание загрузочного устройства

5. Вставьте вторую загрузочную дискету и нажмите кнопку OK, когда появится сообщение Вставьте форматированную дискету #2 в дисковод A:

Далее сделайте то же самое со следующими двумя дискетами.

> Когда R-Studio Startup Media Creator закончит создание загрузочных дискет, появится диалоговое окно R-Studio Agent Emergency Создание Загрузочного Устройства Завершено. Вы можете либо выйти из R-Studio Agent Emergency Startup Media Creator, нажав кнопку Готово, либо создать другое загрузочное устройство, нажав кнопку Назад.
Диалоговое окно Создание Загрузочного Устройства Завершено


Загрузка Компьютера при помощи Загрузочного Устройства R-Studio Agent Emergency

Рекомендуется распечатать данную страницу справки и всегда иметь ее под рукой, выполняя описанные здесь действия.

Прежде чем загружать компьютер, вам нужно узнать о том, есть ли в вашей сети DHCP сервер или же знать IP адрес и маску подсети вашего компьютера.

Если у вас не IDE жесткий диск или вы собираетесь использовать сетевые диски или внешние устройства, то прежде ознакомьтесь со Списком Поддерживаемых Устройств.

Если вы собираетесь использовать внешние устройства, то включите их прежде, чем загружать компьютер.

Если материнская плата вашего компьютера поддерживает устройства Serial ATA (SATA), но у вас также есть IDE диски, то установите в BIOS вашего компьютера Enhanced Mode только для SATA устройств.

Чтобы загрузить компьютер при помощи загрузочного устройства R-Studio Agent Emergency

1 Проверьте, чтобы первым загрузочным устройством в BIOS было установлено то устройство, с которого вы планируете загружать компьютер (CD/DVD, съемный диск или дискета (A))

Для получения более подробной информации обратитесь к руководству вашего компьютера.

2 Вставьте R-Studio Agent Emergency загрузочный CD/DVD, съемный диск или дискету и загрузите ваш компьютер
> Запустится R-Studio Agent Emergency и на экране вашего компьютера появится следующий текст

Если вы загружаете компьютер при помощи дискеты, то на экране компьютера появится сообщение вставить следующую дискету

-----------------------------------------------------------------

Booting R-Studio Emergency. Please wait...

Waiting 8 seconds for PCMCIA devices to settle

Booting R-Studio Agent Emergency. Now you may remove floppy.

-----------------------------------------------------------------

Querying DHCP to configure network interfaces...

Press ENTER within 10 seconds to configure them manually.

Если в вашей сети есть DHCP сервер

Компьютер, на котором запущен R-Studio Agent Emergency, получит IP адрес автоматически

На экране компьютера появится сответствующее сообщение с адресом IP. Вам необходимо его запомнить, чтобы получить доступ к данному компьютеру по сети.

Если в вашей сети нет DHCP сервера

Вам необходимо вручную сконфигурировать интерфейс и IP адрес.

1. На экране компьютера появится сообщение о выборе интерфейса. Введите выбранный интерфейс и нажмите клавишу Enter.

2. На экране компьютера появится сообщение о вводе IP адреса и маски подсети. Введите IP адрес и маску подсети (опционно) и нажмите клавишу Enter.

------------------------[ List of Interfaces ]--------------------------------

Name IP Address NETMASK Vendor

------------------------------------------------------------------------------

re0 Unconfigured RealTek 8139C+

------------------------------------------------------------------------------

# Enter interface name, 'gw' for default gateway or just press ENTER to finish

#>re0

# Enter IP address and optional NETMASK delimited by space

#>192.168.0.10 255.255.255.0

3. На экране компьютера появится сообщение о конфигурации другого интерфейса или завершении конфигурации интерфейса. Введите gw, введите IP адрес и нажмите клавишу Enter

------------------------[ List of Interfaces ]--------------------------------

Name IP Address NETMASK Vendor

------------------------------------------------------------------------------

re0 Unconfigured RealTek 8139C+

------------------------------------------------------------------------------

# Enter interface name, 'gw' for default gateway or just press ENTER to finish

#>re0

# Enter IP address and optional NETMASK delimited by space

#>192.168.0.10 255.255.255.0

------------------------[ List of Interfaces ]--------------------------------

Name IP Address NETMASK Vendor

------------------------------------------------------------------------------

re0 192.168.0.10 255.255.255.0 RealTek 8139C+

gw Unconfigured Default gateway

------------------------------------------------------------------------------

# Enter interface name, 'gw' for default gateway or just press ENTER to finish

#>gw

# Enter default gateway IP Address

#>192.168.0.1

------------------------[ List of Interfaces ]--------------------------------

Name IP Address NETMASK Vendor

------------------------------------------------------------------------------

re0 192.168.0.10 255.255.255.0 RealTek 8139C+

gw 192.168.0.1 Default gateway

------------------------------------------------------------------------------

# Enter interface name, 'gw' for default gateway or just press ENTER to finish

#>

4. Нажмите клавишу Enter для завершения конфигурации интерфейса или введите имя следующего конфигурируемого интерфейса.

> На экране компьютера появится сообщение о том, что R-Studio Agent Emergency готов принимать соединения

* R-Studio Agent started and ready to accept connections...

* You may press ENTER to start to remote R-Studio...

Теперь компьютер доступен для R-Studio, инсталлированного на другом компьютере в сети.

Подключение при помощи R-Studio Agent Emergency к R-Studio

Если необходимо подключить R-Studio и R-Studio Agent Emergency через Интернет, то может потребоваться установить подключение при помощи R-Studio Agent Emergency .

Чтобы установить подключение с R-Studio Agent Emergency к R-Studio

1. Нажмите клавишу Enter и введите IP адрес компьютера с R-Studio в следующем виде: IPaddress:port.

* R-Studio Agent started and ready to accept connections...

* You may press ENTER to start connection to remote R-Studio...

# Enter R-Studio IP address or just press ENTER to cancel> 192.168.0.25:80

Порт по умолчанию 8080, указывать его не нужно.

2 Введите при необходимости пароль и нажмите клавишу Enter.

* R-Studio Agent started and ready to accept connections...

* You may press ENTER to start connection to remote R-Studio...

# Enter R-Studio IP address or just press ENTER to cancel> 192.168.0.25:80

# Enter password or just press ENTER to connect without one>PaSsWoRd1234
> После успешного подключения вы увидите соответствующее сообщение на экране компьютера.

* R-Studio Agent started and ready to accept connections...

* You may press ENTER to start connection to remote R-Studio...

# Enter R-Studio IP address or just press ENTER to cancel> 192.168.0.25:80

# Enter password or just press ENTER to connect without one>PaSsWoRd1234

Connection with 192.168.0.25:80 is established successfully.


R-Studio Agent Emergency Список Поддерживаемых Устройств

Контроллеры Дисков

Сетевые Карты

R-Studio Agent Emergency

Контакты и Техническая Поддержка

Инсталляция R-Studio Agent Emergency Startup Media Creator

Создание Загрузочных Устройств


Контроллеры Дисков

R-Studio Agent Emergency основан на ядре FreeBSD 5.3 и поддерживает устройства из списка, опубликованного на http://www.freebsd.org/releases/5.3R/hardware-i386.html.

*: Поддерживаются в дискетной версии

Контроллеры дисков

IDE/ATA контроллеры ( ata драйвер) *

Адаптеры, поддерживаемые aic драйвером:

Adaptec AHA-1505 (ISA)

Adaptec AHA-1510A, AHA-1510B (ISA)

Adaptec AHA-1520A, AHA-1520B (ISA)

Adaptec AHA-1522A, AHA-1522B (ISA)

Adaptec AHA-1535 (ISA)

Creative Labs SoundBlaster SCSI host adapter (ISA)

Adaptec AHA-1460, AHA-1460B, AHA-1460C, AHA-1460D (PC Card)

Adaptec AHA-1030B, AHA-1030P (PC98)

NEC PC-9801-100 (PC98)

Драйвер aha поддерживает следующие SCSI host адаптеры:

Adaptec AHA-154xB

Adaptec AHA-154xC

Adaptec AHA-154xCF

Adaptec AHA-154xCP

Adaptec AHA-1640

Adaptec AHA-174x in 154x emulation mode

DTC 3290 SCSI controller in 1542 emulation mode

Tekram SCSI controllers in 154x emulation mode

Адаптер ahb поддерживает следующие SCSI host адаптеры:

Adaptec AHA-1740

Adaptec AHA-1742

Adaptec AHA-1740A

Adaptec AHA-1742A

Драйвер ahc поддерживает следующие чипы SCSI host адаптеров и карты SCSI контроллеров:

Adaptec AIC7770 host adapter chip

Adaptec AIC7850 host adapter chip

Adaptec AIC7860 host adapter chip

Adaptec AIC7870 host adapter chip

Adaptec AIC7880 host adapter chip

Adaptec AIC7890 host adapter chip

Adaptec AIC7891 host adapter chip

Adaptec AIC7892 host adapter chip

Adaptec AIC7895 host adapter chip

Adaptec AIC7896 host adapter chip

Adaptec AIC7897 host adapter chip

Adaptec AIC7899 host adapter chip

Adaptec 274X(W)

Adaptec 274X(T)

Adaptec 284X

Adaptec 2910

Adaptec 2915

Adaptec 2920

Adaptec 2930C

Adaptec 2930U2

Adaptec 2940

Adaptec 2940J

Adaptec 2940N

Adaptec 2940U

Adaptec 2940AU

Adaptec 2940UW

Adaptec 2940UW Dual

Adaptec 2940UW Pro

Adaptec 2940U2W

Adaptec 2940U2B

Adaptec 2950U2W

Adaptec 2950U2B

Adaptec 19160B

Adaptec 29160B

Adaptec 29160N

Adaptec 3940

Adaptec 3940U

Adaptec 3940AU

Adaptec 3940UW

Adaptec 3940AUW

Adaptec 3940U2W

Adaptec 3950U2

Adaptec 3960

Adaptec 39160

Adaptec 3985

Adaptec 4944UW

NEC PC-9821Xt13 (PC-98)

NEC RvII26 (PC-98)

NEC PC-9821X-B02L/B09 (PC-98)

NEC SV-98/2-B03 (PC-98)

Поддерживаются многие материнские платы со встроенным SCSI

Драйвер ahd поддерживает следующие:

Adaptec AIC7901 host adapter chip

Adaptec AIC7901A host adapter chip

Adaptec AIC7902 host adapter chip

Adaptec 29320 host adapter

Adaptec 39320 host adapter

Поддерживаются многие материнские платы со встроенным SCSI

Контроллеры, поддерживаемые aac драйвером:

Adaptec AAC-364

Adaptec SCSI RAID 2120S

Adaptec SCSI RAID 2130S

Adaptec SCSI RAID 2200S

Adaptec SCSI RAID 2410SA

Adaptec SCSI RAID 2810SA

Adaptec SCSI RAID 5400S

Dell CERC SATA RAID 2

Dell PERC 2/Si

Dell PERC 2/QC

Dell PERC 3/Si

Dell PERC 3/Di

Dell PERC 320/DC

HP NetRAID 4M

Драйвер adv поддерживает следующие SCSI контроллеры:

AdvanSys ABP510/5150

AdvanSys ABP5140

AdvanSys ABP5142

AdvanSys ABP902/3902

AdvanSys ABP3905

AdvanSys ABP915

AdvanSys ABP920

AdvanSys ABP3922

AdvanSys ABP3925

AdvanSys ABP930, ABP930U, ABP930UA

AdvanSys ABP960, ABP960U

AdvanSys ABP542

AdvanSys ABP742

AdvanSys ABP842

AdvanSys ABP940

AdvanSys ABP940UA/3940UA

AdvanSys ABP940U

AdvanSys ABP3960UA

AdvanSys ABP970, ABP970U

AdvanSys ABP752

AdvanSys ABP852

AdvanSys ABP950

AdvanSys ABP980, ABP980U

AdvanSys ABP980UA/3980UA

MELCO IFC-USP (PC-98)

RATOC REX-PCI30 (PC-98)

@Nifty FNECHARD IFC-USUP-TX (PC-98)

Драйвер adw поддерживает следующие SCSI контроллеры:

AdvanSys ABP940UW/ABP3940UW

AdvanSys ABP950UW

AdvanSys ABP970UW

AdvanSys ABP3940U2W

AdvanSys ABP3950U2W

Драйвер bt поддерживает следующие BusLogic MultiMaster серий ``W'', ``C'', ``S'' и ``A'' и совместимые SCSI host адаптеры:

BusLogic BT-445C

BusLogic BT-445S

BusLogic BT-540CF

BusLogic BT-542B

BusLogic BT-542B

BusLogic BT-542D

BusLogic BT-545C

BusLogic BT-545S

BusLogic/BusTek BT-640

BusLogic BT-742A

BusLogic BT-742A

BusLogic BT-747C

BusLogic BT-747D

BusLogic BT-747S

BusLogic BT-757C

BusLogic BT-757CD

BusLogic BT-757D

BusLogic BT-757S

BusLogic BT-946C

BusLogic BT-948

BusLogic BT-956C

BusLogic BT-956CD

BusLogic BT-958

BusLogic BT-958D

Storage Dimensions SDC3211B / SDC3211F

AMI FastDisk Host Адаптеры, являющиеся true BusLogic MultiMaster clones, также поддерживаются bt драйвером.

Драйвер dpt обеспечивает поддержку следующих RAID адаптеров:

DPT Smart Cache Plus

Smart Cache II (PM2?2?, PM2022 [EISA], PM2024/PM2124 [PCI]) (Gen2)

Smart RAID II (PM3?2?, PM3021, PM3222)

Smart Cache III (PM2?3?)

Smart RAID III (PM3?3?, PM3332 [EISA], PM3334UW [PCI]) (Gen3)

Smart Cache IV (PM2?4?, PM2042 [EISA], PM2044/PM2144 [PCI]) (Gen4)

Smart RAID IV

Драйвер asr в настоящее время поддерживает следующие адаптеры:

Adaptec Zero-Channel SCSI RAID 2000S, 2005S, 2010S, 2015S

Adaptec SCSI RAID 2100S, 2110S

Adaptec ATA-100 RAID 2400A

Adaptec SCSI RAID 3200S, 3210S

Adaptec SCSI RAID 3400S, 3410S

Adaptec SmartRAID PM1554

Adaptec SmartRAID PM1564

Adaptec SmartRAID PM2554

Adaptec SmartRAID PM2564

Adaptec SmartRAID PM2664

Adaptec SmartRAID PM2754

Adaptec SmartRAID PM2865

Adaptec SmartRAID PM3754

Adaptec SmartRAID PM3755U2B / SmartRAID V Millennium

Adaptec SmartRAID PM3757

DEC KZPCC-AC (LVD 1-ch, 4MB or 16MB cache), DEC KZPCC-CE (LVD 3-ch, 64MB cache), DEC KZPCC-XC (LVD 1-ch, 16MB cache), DEC KZPCC-XE (LVD 3-ch, 64MB cache) -- rebadged SmartRAID V Millennium

Драйвер amr поддерживает следующие:

AMI MegaRAID 320-1

AMI MegaRAID 320-2

AMI MegaRAID 320-4X

AMI MegaRAID Series 418

AMI MegaRAID Enterprise 1200 (Series 428)

AMI MegaRAID Enterprise 1300 (Series 434)

AMI MegaRAID Enterprise 1400 (Series 438)

AMI MegaRAID Enterprise 1500 (Series 467)

AMI MegaRAID Enterprise 1600 (Series 471)

AMI MegaRAID Elite 1500 (Series 467)

AMI MegaRAID Elite 1600 (Series 493)

AMI MegaRAID Elite 1650 (Series 4xx)

AMI MegaRAID Express 100 (Series 466WS)

AMI MegaRAID Express 200 (Series 466)

AMI MegaRAID Express 300 (Series 490)

AMI MegaRAID Express 500 (Series 475)

Dell PERC

Dell PERC 2/SC

Dell PERC 2/DC

Dell PERC 3/DCL

Dell PERC 3/QC

Dell PERC 4/Di

HP NetRAID-1/Si

HP NetRAID-3/Si (D4943A)

HP Embedded NetRAID

Обратите внимание: Поддерживается загрузка с данных контроллеров. Адаптеры EISA не поддерживаются.

Контроллеры, поддерживаемые mlx драйвером:

Mylex DAC960P

Mylex DAC960PD / DEC KZPSC (Fast Wide)

Mylex DAC960PDU

Mylex DAC960PL

Mylex DAC960PJ

Mylex DAC960PG

Mylex DAC960PU / DEC PZPAC (Ultra Wide)

Mylex AcceleRAID 150 (DAC960PRL)

Mylex AcceleRAID 250 (DAC960PTL1)

Mylex eXtremeRAID 1100 (DAC1164P)

RAIDarray 230 controllers, aka the Ultra-SCSI DEC KZPAC-AA (1-ch, 4MB cache), KZPAC-CA (3-ch, 4MB), KZPAC-CB (3-ch, 8MB cache)

Поддерживаются все основные прошивки (2.x, 3.x, 4.x и 5.x), однако всегда рекомендуется установить самую последнюю версию прошивки контроллера. Совместимые Mylex контроллеры, отсутствующие в списке, также должны работать, однако они не тестировались.

Обратите внимание: Поддерживается загрузка с данных контроллеров. Адаптеры EISA не поддерживаются.

Контроллеры, поддерживаемые mly драйвером:

Mylex AcceleRAID 160

Mylex AcceleRAID 170

Mylex AcceleRAID 352

Mylex eXtremeRAID 2000

Mylex eXtremeRAID 3000

Совместимые Mylex контроллеры, отсутствующие в списке, также должны работать, однако они не тестировались.

Драйвер twe поддерживает следующие ATA RAID контроллеры:

AMCC's 3ware 5000 series

AMCC's 3ware 6000 series

AMCC's 3ware 7000-2

AMCC's 3ware 7006-2

AMCC's 3ware 7500-4LP

AMCC's 3ware 7500-8

AMCC's 3ware 7500-12

AMCC's 3ware 7506-4LP

AMCC's 3ware 7506-8

AMCC's 3ware 7506-12

AMCC's 3ware 8006-2LP

AMCC's 3ware 8500-4LP

AMCC's 3ware 8500-8

AMCC's 3ware 8500-12

AMCC's 3ware 8506-4LP

AMCC's 3ware 8506-8

AMCC's 3ware 8506-8MI

AMCC's 3ware 8506-12

AMCC's 3ware 8506-12MI

Драйвер twa поддерживает следующие PATA/SATA RAID контроллеры:

AMCC's 3ware 9500S-4LP

AMCC's 3ware 9500S-8

AMCC's 3ware 9500S-8MI

AMCC's 3ware 9500S-12

AMCC's 3ware 9500S-12MI

Драйвер ncr поддерживает следующие чипы NCR/Symbios SCSI контроллеров:

53C810

53C810A

53C815

53C820

53C825A

53C860

53C875

53C875J

53C885

53C895

53C895A

53C896

53C1510D

Поддерживаются следующие известные платы расширения:

I-O DATA SC-98/PCI (PC-98)

I-O DATA SC-PCI (PC-98)

Драйвер sym обеспечивает поддержку следующих Symbios/LSI Logic PCI SCSI контроллеров:

53C810

53C810A

53C815

53C825

53C825A

53C860

53C875

53C876

53C895

53C895A

53C896

53C897

53C1000

53C1000R

53C1010-33

53C1010-66

53C1510D

Контроллеры SCSI , поддерживаемые sym, могут быть либо встроенными в материнскую плату, либо находиться на одной из следующих плат расширения:

ASUS SC-200, SC-896

Data Technology DTC3130 (all variants)

DawiControl DC2976UW

Diamond FirePort (all)

I-O DATA SC-UPCI (PC-98)

Logitec LHA-521UA (PC-98)

NCR cards (all)

Symbios cards (all)

Tekram DC390W, 390U, 390F, 390U2B, 390U2W, 390U3D, and 390U3W

Tyan S1365

Следующие устройства в настоящее время поддерживаются ncv драйвером:

I-O DATA PCSC-DV

KME KXLC002 (TAXAN ICD-400PN, etc.), KXLC004, and UJDCD450

Macnica Miracle SCSI-II mPS110

Media Intelligent MSC-110, MSC-200

NEC PC-9801N-J03R

New Media Corporation BASICS SCSI

Qlogic Fast SCSI

RATOC REX-9530, REX-5572 (SCSI only)

Следующие устройства в настоящее время поддерживаются ncv драйвером:

Adaptec 2920/A

Future Domain SCSI2GO

Future Domain TMC-18XX/3260

IBM SCSI PCMCIA Card

ICM PSC-2401 SCSI

MELCO IFC-SC

RATOC REX-5536, REX-5536AM, REX-5536M, REX-9836A

Обратите внимание, что Adaptec 2920C поддерживается ahc драйвером.

Карты, поддерживаемые isp драйвером:

ISP1000

PTI SBS440

ISP1020

ISP1040

PTI SBS450

Qlogic 1240

Qlogic 1020

Qlogic 1040

Qlogic 1080

Qlogic 1280

Qlogic 12160

Qlogic 2100

Qlogic 2102

Qlogic 2200

Qlogic 2202

Qlogic 2204

Qlogic 2300

Qlogic 2312

PTI SBS470

Antares P-0033

Контроллеры, поддерживаемые amd драйвером:

MELCO IFC-DP (PC-98)

Tekram DC390

Tekram DC390T

Контроллеры, поддерживаемые nsp драйвером:

Alpha-Data AD-PCS201

I-O DATA CBSC16

Adaptec AIC-7110 Parallel to SCSI interfaces ( vpo driver)

Следующие контроллеры, поддерживаемые ida драйвером:

Compaq SMART Array 221

Compaq Integrated SMART Array Controller

Compaq SMART Array 4200

Compaq SMART Array 4250ES

Compaq SMART 3200 Controller

Compaq SMART 3100ES Controller

Compaq SMART-2/DH Controller

Compaq SMART-2/SL Controller

Compaq SMART-2/P Controller

Compaq SMART-2/E Controller

Compaq SMART Controller

Контроллеры, поддерживаемые ciss драйвером:

Compaq Smart Array 5300

Compaq Smart Array 532

Compaq Smart Array 5i

HP Smart Array 5312

HP Smart Array 6i

HP Smart Array 641

HP Smart Array 642

HP Smart Array 6400

HP Smart Array 6400 EM

HP Smart Array 6422

HP Smart Array V100

HP Modular Smart Array 20 (MSA20)

HP Modular Smart Array 500 (MSA500)

Контроллеры, поддерживаемые iir драйвером:

Intel RAID Controller SRCMR

Intel Server RAID Controller U3-l (SRCU31a)

Intel Server RAID Controller U3-1L (SRCU31La)

Intel Server RAID Controller U3-2 (SRCU32)

All past and future releases of Intel and ICP RAID Controllers.

Intel RAID Controller SRCU21 (discontinued)

Intel RAID Controller SRCU31 (older revision, not compatible)

Intel RAID Controller SRCU31L (older revision, not compatible)

На SRCU31 и SRCU31L можно установить обновленные прошивки с сайте Intel.

Promise SuperTrak ATA RAID controllers (pst driver)

Драйвер hptmv поддерживает HighPoint RocketRAID 182x SATA контроллеры.

Контроллеры, поддерживаемые ips драйвером:

IBM ServeRAID 3H

ServeRAID 4L/4M/4H

ServeRAID Series 5

ServeRAID 6i/6M

Следующие контроллеры, поддерживаемые mpt драйвером:

LSI Logic 53c1030 (Dual Ultra320 SCSI)

LSI Logic FC909 (1Gb/s Fibre Channel)

LSI Logic FC909A (Dual 1Gb/s Fibre Channel)

LSI Logic FC919 (2Gb/s Fibre Channel)

LSI Logic FC929 (Dual 2Gb/s Fibre Channel)

Чип SCSI контроллера, поддерживаемый mpt драйвером, расположен на плате многих систем, включая:

Dell PowerEdge 1750

IBM eServer xSeries 335

SCSI контроллеры, поддерживаемые trm драйвером:

Tekram DC-315 PCI Ultra SCSI adapter without BIOS and internal SCSI connector

Tekram DC-315U PCI Ultra SCSI adapter without BIOS

Tekram DC-395F PCI Ultra-Wide SCSI adapter with flash BIOS and 68-pin external SCSI connector

Tekram DC-395U PCI Ultra SCSI adapter with flash BIOS

Tekram DC-395UW PCI Ultra-Wide SCSI adapter with flash BIOS

Tekram DC-395U2W PCI Ultra2-Wide SCSI adapter with flash BIOS

Для Tekram DC-310/U и DC-390F/U/UW/U2B/U2W/U3W PCI SCSI host адаптеров используйте драйвер sym.

Драйвер wds поддерживает WD7000 SCSI контроллер.


Сетевые Карты

R-Studio Agent Emergency основан на ядре FreeBSD 5.3 и поддерживает устройства из списка, опубликованного на http://www.freebsd.org/releases/5.3R/hardware-i386.html.

*: Поддерживаются в дискетной версии

Ethernet NICs

Адаптеры, поддерживаемые sf драйвером:

ANA-62011 64-bit single port 10/100baseTX adapter

ANA-62022 64-bit dual port 10/100baseTX adapter

ANA-62044 64-bit quad port 10/100baseTX adapter

ANA-69011 32-bit single port 10/100baseTX adapter

ANA-62020 64-bit single port 100baseFX adapter

Драйвер ti поддерживает адаптеры Gigabit Ethernet, работающие на чипах Alteon Tigon I и II. Драйвер ti тестировался со следующими адаптерами:

3Com 3c985-SX Gigabit Ethernet adapter (Tigon 1)

3Com 3c985B-SX Gigabit Ethernet adapter (Tigon 2)

Alteon AceNIC V Gigabit Ethernet adapter (1000baseSX)

Alteon AceNIC V Gigabit Ethernet adapter (1000baseT)

Digital EtherWORKS 1000SX PCI Gigabit adapter

Netgear GA620 Gigabit Ethernet adapter (1000baseSX)

Netgear GA620T Gigabit Ethernet adapter (1000baseT)

Следующие адаптеры также должны поддерживаться, но еще не тестировались:

Asante GigaNIX1000T Gigabit Ethernet adapter

Asante PCI 1000BASE-SX Gigabit Ethernet adapter

Farallon PN9000SX Gigabit Ethernet adapter

NEC Gigabit Ethernet

Silicon Graphics PCI Gigabit Ethernet adapter

Драйвер pcn поддерживает адаптеры и встроенные контроллеры, работающие на чипах AMD PCnet/FAST, PCnet/FAST+, PCnet/FAST III, PCnet/PRO и PCnet/Home Fast Ethernet:

AMD Am53C974/Am79C970/Am79C974 PCnet-PCI *

AMD Am79C970A PCnet-PCI II *

AMD Am79C971 PCnet-FAST *

AMD Am79C972 PCnet-FAST+ *

AMD Am79C973/Am79C975 PCnet-FAST III *

AMD Am79C976 PCnet-PRO *

AMD PCnet/Home HomePNA

Allied-Telesis LA-PCI

Contec C-NET(98)S (PC-98)

NEC SV-98/2-B05, B06

Драйвер lnc поддерживает следующие адаптеры:

Novell NE2100 *

Novell NE32-VL *

Isolan AT 4141-0 (16 bit)

Isolan BICC

Isolink 4110 (8 bit)

Diamond HomeFree

Digital DEPCA

Hewlett Packard Vectra 486/66XM

Hewlett Packard Vectra XU

Также поддерживаются адаптеры, работающие с драйвером pcn. Драйвер lnc работает в данном случае в режиме эмуляции, поэтому более предпочтителен драйвер pcn.

SMC 83c17x (EPIC)-based Ethernet NICs (tx driver)

Драйвер ed поддерживает следующие Ethernet NICs:

3Com 3c503 Etherlink II

AR-P500 Ethernet

Accton EN1644 (old model), EN1646 (old model), EN2203 (old model) (110pin) (flags 0xd00000)

Accton EN2212/EN2216/UE2216

Allied Telesis CentreCOM LA100-PCM_V2

Allied Telesis LA-98 (flags 0x000000) (PC-98)

Allied Telesis SIC-98, SIC-98NOTE (110pin), SIU-98 (flags 0x600000) (PC-98)

Allied Telesis SIU-98-D (flags 0x610000) (PC-98)

AmbiCom 10BaseT card

Bay Networks NETGEAR FA410TXC Fast Ethernet

CNet BC40 adapter

Compex Net-A adapter

Contec C-NET(98), RT-1007(98), C-NET(9N) (110pin) (flags 0xa00000) (PC-98)

Contec C-NET(98)E-A, C-NET(98)L-A, C-NET(98)P (flags 0x300000) (PC-98)

Corega Ether98-T (flags 0x000000) (PC-98)

Corega Ether PCC-T/EtherII PCC-T/FEther PCC-TXF/PCC-TXD

CyQ've ELA-010

DEC EtherWorks DE305

Danpex EN-6200P2

D-Link DE-298, DE-298P (flags 0x500000) (PC-98)

D-Link DE-650/660

D-Link IC-CARD/IC-CARD+ Ethernet

ELECOM LD-98P (flags 0x500000) (PC-98)

ELECOM LD-BDN, LD-NW801G (flags 0x200000) (PC-98)

ELECOM Laneed LD-CDL/TX, LD-CDF, LD-CDS, LD-10/100CD, LD-CDWA (DP83902A)

HP PC Lan+ 27247B and 27252A

IBM Creditcard Ethernet I/II

ICM AD-ET2-T, DT-ET-25, DT-ET-T5, IF-2766ET, IF-2771ET, NB-ET-T (110pin) (flags 0x500000) (PC-98)

I-O DATA LA/T-98, LA/T-98SB, LA2/T-98, ET/T-98 (flags 0x900000) (PC-98)

I-O DATA ET2/T-PCI

I-O DATA PCLATE

Kansai KLA-98C/T (flags 0x900000) (PC-98)

Kingston KNE-PC2, KNE-PCM/x Ethernet

Linksys EC2T/PCMPC100/PCM100, PCMLM56

Linksys EtherFast 10/100 PC Card, Combo PCMCIA Ethernet Card (PCMPC100 V2)

Logitec LAN-98T (flags 0xb00000) (PC-98)

MACNICA Ethernet ME1 for JEIDA

MACNICA ME98 (flags 0x900000) (PC-98)

MACNICA NE2098 (flags 0x400000) (PC-98)

MELCO EGY-98 (flags 0x300000) (PC-98)

MELCO LGH-98, LGY-98, LGY-98-N (110pin), IND-SP, IND-SS (flags 0x400000) (PC-98)

MELCO LGY-PCI-TR

MELCO LPC-T/LPC2-T/LPC2-CLT/LPC2-TX/LPC3-TX/LPC3-CLX

NDC Ethernet Instant-Link

NEC PC-9801-77, PC-9801-78 (flags 0x910000) (PC-98)

NEC PC-9801-107, PC-9801-108 (flags 0x800000) (PC-98)

National Semiconductor InfoMover NE4100

NetGear FA-410TX

NetVin 5000

Network Everywhere Ethernet 10BaseT PC Card

Networld 98X3 (flags 0xd00000) (PC-98)

Networld EC-98X, EP-98X (flags 0xd10000) (PC-98)

Novell NE1000/NE2000/NE2100

PLANEX ENW-8300-T

PLANEX EN-2298-C (flags 0x200000) (PC-98)

PLANEX EN-2298P-T, EN-2298-T (flags 0x500000) (PC-98)

PLANEX FNW-3600-T

RealTek 8029

SMC Elite 16 WD8013

SMC Elite Ultra

SMC EtherEZ98 (flags 0x000000) (PC-98)

SMC WD8003E/WD8003EBT/WD8003S/WD8003SBT/WD8003W/WD8013EBT/WD8013W and clones

Socket LP-E

Surecom EtherPerfect EP-427

Surecom NE-34

TDK LAK-CD031, Grey Cell GCS2000 Ethernet Card

Telecom Device SuperSocket RE450T

VIA VT86C926

Winbond W89C940

Также поддерживаются устройства C-Bus, ISA, PCI и PC Card.

Адаптеры, поддерживаемые драйвером rl:

Accton ``Cheetah'' EN1207D (MPX 5030/5038; RealTek 8139 clone)

Allied Telesyn AT2550

Allied Telesyn AT2500TX

Belkin F5D5000

BUFFALO(Melco INC.) LPC-CB-CLX(CardBus)

Compaq HNE-300

CompUSA no-name 10/100 PCI Ethernet NIC

Corega FEther CB-TXD

Corega FEtherII CB-TXD

D-Link DFE-530TX+

D-Link DFE-538TX (same as 530+?)

D-Link DFE-690TXD

Edimax EP-4103DL CardBus

Encore ENL832-TX 10/100 M PCI

Farallon NetLINE 10/100 PCI

Genius GF100TXR,

GigaFast Ethernet EE100-AXP

KTX-9130TX 10/100 Fast Ethernet

LevelOne FPC-0106TX

Longshine LCS-8038TX-R

NDC Communications NE100TX-E

Netronix Inc. EA-1210 NetEther 10/100

Nortel Networks 10/100BaseTX

OvisLink LEF-8129TX

OvisLink LEF-8139TX

Peppercon AG ROL-F

Planex FNW-3800-TX

SMC EZ Card 10/100 PCI 1211-TX

SOHO(PRAGMATIC) UE-1211C

Драйвер wb поддерживает Winbond W89C840F based Fast Ethernet адаптеры и встроенные контроллеры:

Trendware TE100-PCIE *

Драйвер vr поддерживает VIA Technologies Rhine I, Rhine II и Rhine III based Fast Ethernet адаптеры:

D-Link DFE530-TX

Hawking Technologies PN102TX

AOpen/Acer ALN-320

Драйвер sis поддерживает Silicon Integrated Systems SiS 900 * и SiS 7016 * based Fast Ethernet адаптеры и встроенные контроллеры, также Fast Ethernet адаптеры, работающие на чипе National Semiconductor DP83815 (MacPhyter). Поддерживаемые адаптеры:

@Nifty FNECHARD IFC USUP-TX

MELCO LGY-PCI-TXC

Netgear FA311-TX (DP83815)

Netgear FA312-TX (DP83815)

SiS 630, 635, and 735 motherboard chipsets

Драйвер nge поддерживает National Semiconductor DP83820 * и DP83821 based Gigabit Ethernet адаптеры:

SMC EZ Card 1000 (SMC9462TX)

D-Link DGE-500T

Asante FriendlyNet GigaNIX 1000TA и 1000TPC

Addtron AEG320T

LinkSys EG1032 (32-bit PCI) и EG1064 (64-bit PCI)

Surecom Technology EP-320G-TX

Netgear GA622T

Netgear GA621

Ark PC SOHO-GA2500T (32-bit PCI) и SOHO-GA2000T (64-bit PCI)

Trendware TEG-PCITX (32-bit PCI) и TEG-PCITX2 (64-bit PCI)

Драйвер ste поддерживает Sundance Technologies ST201 based Fast Ethernet адаптеры и встроенные контроллеры:

D-Link DFE-530TXS

D-Link DFE-550TX

Адаптеры, поддерживаемые драйвером sk :

3COM 3C940 single port, 1000baseT adapter

Belkin F5D5005 single port, 1000baseT adapter

Linksys EG1032 single port, 1000baseT adapter

SK-9521 SK-NET GE-T single port, 1000baseT adapter

SK-9821 SK-NET GE-T single port, 1000baseT adapter *

SK-9822 SK-NET GE-T dual port, 1000baseT adapter *

SK-9841 SK-NET GE-LX single port, single mode fiber adapter *

SK-9842 SK-NET GE-LX dual port, single mode fiber adapter *

SK-9843 SK-NET GE-SX single port, multimode fiber adapter *

SK-9844 SK-NET GE-SX dual port, multimode fiber adapter *

SMC 9452TX single port, 1000baseT adapter

Драйвер tl поддерживает Texas Instruments ThunderLAN based Ethernet и Fast Ethernet адаптеры, включая большое число Compaq PCI Ethernet адаптеров. Также поддерживаются:

Olicom OC-2135/2138 10/100 TX UTP adapter

Olicom OC-2325/OC-2326 10/100 TX UTP adapter

Racore 8148 10baseT/100baseTX/100baseFX adapter

Racore 8165 10/100baseTX adapter

Драйвер tl также поддерживает встроенные Ethernet адаптеры различных Compaq Prosignia серверов и Compaq Deskpro настольные компьютеры:

Compaq Netelligent 10

Compaq Netelligent 10 T PCI UTP/Coax

Compaq Netelligent 10/100

Compaq Netelligent 10/100 Dual-Port

Compaq Netelligent 10/100 Proliant

Compaq Netelligent 10/100 TX Embedded UTP

Compaq Netelligent 10/100 TX UTP

Compaq NetFlex 3P

Compaq NetFlex 3P Integrated

Compaq NetFlex 3P w/BNC

Драйвер dc обеспечивает поддержку следующих чипсетов: *

DEC/Intel 21143

ADMtek AL981 Comet, AN985 Centaur, ADM9511 Centaur II and ADM9513 Centaur II

ASIX Electronics AX88140A and AX88141

Conexant LANfinity RS7112 (miniPCI)

Davicom DM9009, DM9100, DM9102 and DM9102A

Lite-On 82c168 and 82c169 PNIC

Lite-On/Macronix 82c115 PNIC II

Macronix 98713, 98713A, 98715, 98715A, 98715AEC-C, 98725, 98727 and 98732

Xircom X3201 (cardbus only)

Известно, что следующие NICs работают с драйвером dc:

3Com OfficeConnect 10/100B (ADMtek AN985 Centaur-P)

Abocom FE2500

Accton EN1217 (98715A)

Accton EN2242 MiniPCI

Adico AE310TX (98715A)

Alfa Inc GFC2204 (ASIX AX88140A)

Built in 10Mbps only Ethernet on Compaq Presario 7900 series desktops (21143, non-MII)

Built in DE500-BA on DEC Alpha workstations (21143, non-MII)

Built in Sun DMFE 10/100 Mbps Ethernet on Sun Netra X1 and Sun Fire V100 (DM9102A, MII)

Built in Ethernet on LinkSys EtherFast 10/100 Instant GigaDrive (DM9102, MII)

CNet Pro110B (ASIX AX88140A)

CNet Pro120A (98715A or 98713A) and CNet Pro120B (98715)

Compex RL100-TX (98713 or 98713A)

D-Link DFE-570TX (21143, MII, quad port)

Digital DE500-BA 10/100 (21143, non-MII)

ELECOM Laneed LD-CBL/TXA (ADMtek AN985)

Hawking CB102 CardBus

IBM EtherJet Cardbus Adapter

Intel PRO/100 Mobile Cardbus (версии, в которых используется читсет X3201)

Jaton XpressNet (Davicom DM9102)

Kingston KNE100TX (21143, MII)

Kingston KNE110TX (PNIC 82c169)

LinkSys LNE100TX (PNIC 82c168, 82c169)

LinkSys LNE100TX v2.0 (PNIC II 82c115)

LinkSys LNE100TX v4.0/4.1 (ADMtek AN985 Centaur-P)

Matrox FastNIC 10/100 (PNIC 82c168, 82c169)

Melco LGY-PCI-TXL

Microsoft MN-120 10/100 CardBus (ADMTek Centaur-C)

Microsoft MN-130 10/100 PCI (ADMTek Centaur-P)

NDC SOHOware SFA110A (98713A)

NDC SOHOware SFA110A Rev B4 (98715AEC-C)

NetGear FA310-TX Rev. D1, D2 or D3 (PNIC 82c169)

Netgear FA511

PlaneX FNW-3602-T (ADMtek AN985)

SMC EZ Card 10/100 1233A-TX (ADMtek AN985)

SVEC PN102-TX (98713)

Xircom Cardbus Realport

Xircom Cardbus Ethernet 10/100

Xircom Cardbus Ethernet II 10/100

Адаптеры, поддерживаемые драйвером aue :

Abocom UFE1000, DSB650TX_NA

Accton USB320-EC, SpeedStream

ADMtek AN986, AN8511

Billionton USB100, USB100LP, USB100EL, USBE100

Corega Ether FEther USB-T, FEther USB-TX, FEther USB-TXS

D-Link DSB-650, DSB-650TX, DSB-650TX-PNA

Elecom LD-USBL/TX

Elsa Microlink USB2Ethernet

HP hn210e

I-O Data USB ETTX

Kingston KNU101TX

LinkSys USB10T адаптеры, содержащие чипсет AN986 Pegasus, USB10TA, USB10TX, USB100TX, USB100H1

MELCO LUA-TX, LUA2-TX

Planex UE-200TX

Sandberg USB to Network Link (model number 133-06)

Siemens Speedstream

SmartBridges smartNIC

SMC 2202USB

SOHOware NUB100

Драйвер cue поддерживает CATC USB-EL1210A based USB Ethernet адаптеры:

Belkin F5U011/F5U111

CATC Netmate

CATC Netmate II

SmartBridges SmartLink

Драйвер kue поддерживает Kawasaki LSI KL5KLUSB101B based USB Ethernet адаптеры:

3Com 3c19250

3Com 3c460 HomeConnect Ethernet USB Adapter

ADS Technologies USB-10BT

AOX USB101

ATen UC10T

Abocom URE 450

Corega USB-T

D-Link DSB-650C

Entrega NET-USB-E45, NET-HUB-3U1E

I/O Data USB ETT

Kawasaki DU-H3E

LinkSys USB10T

Netgear EA101

Peracom USB Ethernet Adapter

SMC 2102USB, 2104USB

Драйвер axe поддерживает ASIX Electronics AX88172 based USB Ethernet адаптеры:

Buffalo (Melco Inc.) LUA-U2-KTX

D-Link DUBE100

LinkSys USB200M

Netgear FA120

System TALKS Inc. SGC-X2UL

Драйвер rue поддерживает RealTek RTL8150 based USB Ethernet адаптеры:

Buffalo (Melco Inc.) LUA-KTX

Green House GH-USB100B

LinkSys USB100M

Billionton 10/100 FastEthernet USBKR2

Драйвер udav поддерживает следующие адаптеры:

Corega FEther USB-TXC

Адаптеры, поддерживаемые драйвером de :

Adaptec ANA-6944/TX

Cogent EM100FX and EM440TX

Corega FastEther PCI-TX

D-Link DFE-500TX

DEC DE435, DE425, DEC DE450 и DEC DE500

ELECOM LD-PCI2T, LD-PCITS

I-O DATA LA2/T-PCI

SMC Etherpower 8432, 9332 и 9334

ZNYX ZX3xx

Контроллеры и карты, поддерживаемые драйвером fe :

Allied Telesis RE1000, RE1000Plus, ME1500 (110-pin)

CONTEC C-NET(98)P2, C-NET (9N)E (110-pin), C-NET(9N)C (ExtCard)

CONTEC C-NET(PC)C PCMCIA Ethernet

Eiger Labs EPX-10BT

Fujitsu FMV-J182, FMV-J182A

Fujitsu MB86960A, MB86965A

Fujitsu MBH10303, MBH10302 Ethernet PCMCIA

Fujitsu Towa LA501 Ethernet

HITACHI HT-4840-11

NextCom J Link NC5310

RATOC REX-5588, REX-9822, REX-4886, and REX-R280

RATOC REX-9880/9881/9882/9883

TDK LAC-98012, LAC-98013, LAC-98025, LAC-9N011 (110-pin)

TDK LAK-CD021, LAK-CD021A, LAK-CD021BX

Ungermann-Bass Access/PC N98C+(PC85152, PC85142), Access/NOTE N98(PC86132) (110-pin)

Адаптеры, поддерживаемые драйвером fxp:

Intel EtherExpress PRO/10

Intel InBusiness 10/100

Intel PRO/100B / EtherExpressPRO/100 B PCI Adapter *

Intel PRO/100+ Management Adapter

Intel PRO/100 VE Desktop Adapter

Intel PRO/100 M Desktop Adapter

Intel PRO/100 S Desktop, Server and Dual-Port Server Adapters

Contec C-NET(PI)-100TX (PC-98)

NEC PC-9821Ra20, Rv20, Xv13, Xv20 internal 100Base-TX (PC-98)

NEC PC-9821X-B06 (PC-98)

Многие встроенные сетевые интерфейсы на материнских платах Intel

Драйвер ex поддерживает следующие Ethernet адаптеры:

Intel EtherExpress Pro/10

Intel EtherExpress Pro/10+

The Olicom OC2220

Драйвер ie поддерживает следующие 8 и 16 битные ISA Ethernet карты, основанные на чите Intel i82586:

3COM 3C507

AT&T EN100

AT&T Starlan 10

AT&T Starlan Fiber

Intel EtherExpress 16

RACAL Interlan NI5210

Драйвер ep поддерживает Ethernet адаптеры, основанные на 3Com 3C5x9 Etherlink III Parallel Tasking чипсете:

3Com 3C1 CF

3Com 3C509-TP, 3C509-BNC, 3C509-Combo, 3C509-TPO, 3C509-TPC ISA

3Com 3C509B-TP, 3C509B-BNC, 3C509B-Combo, 3C509B-TPO, 3C509B-TPC ISA

3Com 3C529, 3C529-TP MCA

3Com 3C562/3C563 PCMCIA

3Com 3C569B-J-TPO, 3C569B-J-COMBO CBUS

3Com 3C574-TX, 3CCFE574BT, 3CXFE574BT, 3C3FE574BT PCMCIA

3Com 3C579-TP, 3C579-BNC EISA

3Com 3C589, 3C589B, 3C589C, 3C589D, 3CXE589DT PCMCIA

3Com 3CCFEM556B, 3CCFEM556BI PCMCIA

3Com 3CXE589EC, 3CCE589EC, 3CXE589ET, 3CCE589ET PCMCIA

3Com Megahertz 3CCEM556, 3CXEM556, 3CCEM556B, 3CXEM556B PCMCIA

3Com OfficeConnect 3CXSH572BT, 3CCSH572BT PCMCIA

Farallon EtherMac PCMCIA

Драйвер el поддерживает 3Com 3c501 8bit ISA Ethernet карту.

Драйвер xl поддерживает следующее оборудование:

3Com 3c900-TPO *

3Com 3c900-COMBO *

3Com 3c905-TX *

3Com 3c905-T4 *

3Com 3c900B-TPO *

3Com 3c900B-TPC *

3Com 3c900B-FL *

3Com 3c900B-COMBO *

3Com 3c905B-T4 *

3Com 3c905B-TX *

3Com 3c905B-FX *

3Com 3c905B-COMBO *

3Com 3c905C-TX *

3Com 3c980, 3c980B и 3c980C server адаптеры

3Com 3cSOHO100-TX OfficeConnect адаптеры

3Com 3c450 HomeConnect адаптеры

3Com 3c555, 3c556 и 3c556B mini-PCI адаптеры

3Com 3C3SH573BT, 3C575TX, 3CCFE575BT, 3CXFE575BT, 3CCFE575CT, 3CXFE575CT, 3CCFEM656, 3CCFEM656B и 3CCFEM656C, 3CXFEM656, 3CXFEM656B и 3CXFEM656C CardBus адаптеры

3Com 3c905-TX, 3c905B-TX 3c905C-TX и 3c920B-EMB встроенные адаптеры

CardBus карты семейства 3C656 и MiniPCI карты семейства 3C556 имеют встроенный модем. Драйвер xl, как и любой другой драйвер, не поддерживают этот модем.

Драйвер vx поддерживает следующие карты:

3Com 3c590 EtherLink III PCI *

3Com 3c592 EtherLink III EISA

3Com 3c595 Fast EtherLink III PCI in 10 Mbps mode *

3Com 3c597 Fast EtherLink III EISA in 10 Mbps mode

Crystal Semiconductor CS89x0-based NICs (cs driver)

Драйвер sn поддерживает SMC9xxx based ISA и PCMCIA карты:

3Com Megahertz X-Jack Ethernet PC-Card CC-10BT

Драйвер xe поддерживает следующие карты:

Xircom CreditCard Ethernet (PS-CE2-10)

Xircom CreditCard Ethernet + Modem 28 (PS-CEM-28)

Xircom CreditCard Ethernet + Modem 33 (CEM33)

Xircom CreditCard 10/100 (CE3, CE3B)

Xircom CreditCard Ethernet 10/100 + Modem 56 (CEM56)

Xircom RealPort Ethernet 10 (RE10)

Xircom RealPort Ethernet 10/100 (RE100)

Xircom RealPort Ethernet 10/100 + Modem 56 (REM56, REM56G)

Accton Fast EtherCard-16 (EN2226)

Compaq Netelligent 10/100 PC Card (CPQ-10/100)

Intel EtherExpress Pro/100 PC Card Mobile Adapter 16 (Pro/100 M16A)

Другие подобные устройства, использующие такую же аппаратную часть, также могут поддерживаться.

Адаптеры, поддерживаемые lge драйвером:

SMC TigerCard 1000 (SMC9462SX) *

D-Link DGE-500SX *

Драйвер txp поддерживает следующие карты:

3Com 3CR990-TX-95 *

3Com 3CR990-TX-97 *

3Com 3cR990B-TXM *

3Com 3CR990SVR95 *

3Com 3CR990SVR97 *

3Com 3cR990B-SRV *

Драйвер bge обеспечивает поддержку различных NICs, основанных на семействе Broadcom BCM570x Gigabit Ethernet controller чипов, включая:

3Com 3c996-T (10/100/1000baseTX) *

Dell PowerEdge 1750 integrated BCM5704C NIC (10/100/1000baseTX) *

Dell PowerEdge 2550 integrated BCM5700 NIC (10/100/1000baseTX) *

Dell PowerEdge 2650 integrated BCM5703 NIC (10/100/1000baseTX) *

IBM x235 server integrated BCM5703x NIC (10/100/1000baseTX) *

HP ProLiant NC7760 embedded Gigabit NIC (10/100/1000baseTX) *

HP ProLiant NC7770 PCI-X Gigabit NIC (10/100/1000baseTX) *

HP ProLiant NC7781 embedded PCI-X Gigabit NIC (10/100/1000baseTX) *

Netgear GA302T (10/100/1000baseTX) *

SysKonnect SK-9D21 (10/100/1000baseTX) *

SysKonnect SK-9D41 (1000baseSX) *

Драйвер em поддерживает Gigabit Ethernet адаптеры, основанные на Intel 82540, 82541PI, 82542, 82543, 82544, 82546, 82546EB и 82547 controller чипах:

Intel PRO/1000 CT Network Connection (82547)

Intel PRO/1000 F Server Adapter (82543)

Intel PRO/1000 Gigabit Server Adapter (82542)*

Intel PRO/1000 GT Desktop Adapter (82541PI)

Intel PRO/1000 MF Dual Port Server Adapter (82546)

Intel PRO/1000 MF Server Adapter (82545)

Intel PRO/1000 MF Server Adapter (LX) (82545)

Intel PRO/1000 MT Desktop Adapter (82540)

Intel PRO/1000 MT Desktop Adapter (82541)

Intel PRO/1000 MT Dual Port Server Adapter (82546)

Intel PRO/1000 MT Quad Port Server Adapter (82546EB)

Intel PRO/1000 MT Server Adapter (82545)

Intel PRO/1000 T Desktop Adapter (82544)

Intel PRO/1000 T Server Adapter (82543)

Intel PRO/1000 XF Server Adapter (82544)

Intel PRO/1000 XT Server Adapter (82544)

Драйвер gx поддерживает Gigabit Ethernet адаптеры, основанные на Intel 82542 и 82543 controller чипах:

Intel PRO/1000 Gigabit Server Adapter (82542)

Intel PRO/1000 F Server Adapter (82543)

Intel PRO/1000 T Server Adapter (82543)

Драйвер hme поддерживает встроенные Ethernet интерфейсы многих Sun UltraSPARC моделей рабочих станций и серверов. Карты, поддерживаемые драйвером hme:

Sun PCI SunSwift Adapter

Sun SBus SunSwift Adapter ``( hme'' и ``SUNW,hme'')

Sun PCI Sun100BaseT Adapter 2.0

Sun SBus Sun100BaseT 2.0

Sun PCI Quad FastEthernet Controller

Sun SBus Quad FastEthernet Controller

Драйвер my обеспечивает поддержку различных NICs, основанных на Myson чипсете. Среди поддерживаемых моделей:

Myson MTD800 PCI Fast Ethernet chip

Myson MTD803 PCI Fast Ethernet chip

Myson MTD89X PCI Gigabit Ethernet chip

Broadcom BCM4401 based Fast Ethernet адаптеры (bfe драйвер) *

Драйвер re поддерживает RealTek RTL8139C+, RTL8169, RTL8169S и RTL8110S based Fast Ethernet и Gigabit Ethernet адаптеры:

Alloy Computer Products EtherGOLD 1439E 10/100 (8139C+) *

Compaq Evo N1015v Integrated Ethernet (8139C+) *

Corega CG-LAPCIGT Gigabit Ethernet (8169S) *

Gigabyte 7N400 Pro2 Integrated Gigabit Ethernet (8110S) *

PLANEX COMMUNICATIONS Inc. GN-1200TC (8169S) *

Xterasys XN-152 10/100/1000 NIC (8169) *

Драйвер ixgb поддерживает следующие карты:

Intel PRO/10GbE LR Server Adapter *

Intel PRO/10GbE SR Server Adapter *


BlockRAIDbuttons

Кнопки управления объектами RAID

Определить | Нажмите данную кнопку чтобы идентифицировать выбранный объект RAID на панели Диски .
Добавить отсутствующий диск | Нажмите данную кнопку чтобы добавить объект Пропущенный диск/Свободное пространство
Удалить | Нажмите данную кнопку чтобы удалить выбранный объект из конфигурации RAID
Вверх | Нажмите данную кнопку чтобы сместить выбранный объект RAID выше
Вниз | Нажмите данную кнопку чтобы сместить выбранный объект RAID ниже
Синхронизировать смещения | Нажмите данную кнопку чтобы установить одинаковое смещение для всех объектов RAID