Primo (VSuite) Ramdisk

Primo (VSuite) Ramdisk Ultimate Edition 5.5.0

Primo Ramdisk является преемником популярного продукта Ramdisk VSuite. Программа обладает новыми возможностями и улучшенной производительностью, а также дружественный пользовательский интерфейcом. Программа для создания виртуальных дисков в оперативной памяти. Современная оперативная память выигрывает в плане производительности у винчестеров и твердотельных накопителей (SSD). Благодаря Primo Ramdisk часть оперативной памяти вашего компьютера может быть зарезервирована под виртуальный раздел, на котором вы сможете хранить данные наиболее ресурсоемких приложений. Таким образом, вы сможете существенно сократить время доступа к ним. Primo Ramdisk может быть настроена таким образом, чтобы сохранять содержимое виртуального жесткого диска на винчестер при выключении компьютера.

Это программа, которая создаст виртуальный жесткий диск в оперативной памяти вашего компьютера. Вы выбираете его размер (конечно, в пределах доступной оперативной памяти), букву диска и файловую систему и работаете с ним как с обычным диском - можете копировать, перемещать и удалять файлы на нем. RAM-диск также может быть доступен по сети.
Данная технология, вернее данное решение давно и активно используется в ОС Linux и других серверных операционных системах для обеспечения записи и чтения временных файлов, на сервере cwer.ru, например, таблиц баз данных.
Использование RAM-диска, кроме молниеносной скорости доступа, обеспечивает также и небывалую (как для обычного жесткого диска) долговечность, а также отсутствие шума, что позволяет размещать на нем файлы, доступ к которым осуществляется наиболее часто. И, конечно же, RAM-диск предоставляет исключительную безопасность и конфиденциальность данных.

Оказалось, что самое лучшее решение - это "VSuite Ramdisk".
1) Видит весь объём доступной памяти (для Standard Edition - в пределах 8Гб, для Pro-версии - до 32Гб, для Ultimate/Server Edition - без ограничений).
2) Не нужно форматировать диск после перезагрузки Windows (причём без всяких выгрузок/загрузок его образа с HDD).
3) И что ещё особо приятно, после перезагрузки Windows букву Z: на N: не меняет.

Ключевые особенности:
- RAM-диски полностью идентичны физическим жёстким дискам и распознаются MMC-оснасткой Disk Management или любым другим диспетчером дисков/томов.
- Доступ к большим объёмам ОЗУ, в том числе к памяти выше 4 Гбайт.
- Доступ к памяти, невидимой для ОС. Например, если у вас установлено 4 Гбайт оперативной памяти, а Windows видит только 3 Гбайт, VSuite Ramdisk позволит использовать оставшийся "невидимый" гигабайт целиком.
- Поддержка файла подкачки.
- Поддержка файловых систем FAT, FAT32, NTFS.
- Оптимизация размера кластеров файловой системы.
- Поддержка файлов-образов RAM-дисков. Автозагрузка образа в RAM-диск при запуске системы и автосохранение данных RAM-диска в образ при завершении работы системы, а также различные варианты сохранения и загрузки образов в разных форматах.
- Размер RAM-диска может достигать 2048 Терабайт.
- Создание в системе до 128 RAM-дисков.
- WDM-драйвер, поддержка перетаскивания.
- Интерфейс программы на разных языках, включая русский.

RAMDisk включает в себя такие возможности, как:
- Единая 32-битная версия, которая работает на всех 32-битных версиях Windows 2000, XP, Server 2003 и Vista (однопроцессорных или многопроцессорных).
- Единая 64-битная версия, которая работает на всех 64-битных версиях Windows XP (с Service Pack 2), Server 2003 и Vista (однопроцессорных или многопроцессорных).
- Автоматическое форматирование в FAT12, FAT16, FAT32 или NTFS / NTFS со сжатием.
- Автоматическое изменение размеров RAM-диска до максимально доступного (или разрешённого) размера.
- Точная настройка доступной памяти, позволяющая сбалансировать максимальный размер RAM-диска и стабильность ОС.
- Лёгкость в использовании и конфигурировании RAM-диска из дерева Диспетчера устройств.
- Увеличенные максимальные размеры RAM-диска, теоретически до 64 ГБ с использованием PAE, если это поддерживается операционной системой (с установленным в boot.ini переключателем /PAE на системах, использующих более 4 ГБ физической памяти).
- Возможность загрузки сохранённого образа диска и заполнения содержимого RAM-диска в момент инициализации драйвера (скорость загрузки - около 30 секунд на 1 ГБ при условии, что образ сохранён на жёстком диске с режимом 4 IDE ATA при процессоре с частотой 1,2 ГГц).
- Возможность сохранения содержимого в образ диска при завершении работы, а также через регулярные интервалы или в заданные моменты времени.
- Отсутствие конфликтов с другими существующими программами RAM-дисков. RAMDisk Enterprise может быть установлен вместе с любым другим RAM-диском при условии, что RAM-диски смогут получить соответствующее количество свободного пространства в оперативной памяти.

Поддерживаемые ОС:
Windows 2000/XP/2003 (32-бит) – бесплатная версия программы (Free Edition).
Windows 2000/XP/2003/Vista/7/2008 – версии Standard, Professional и Server.

Регистрация: запустите файл Register.reg из папки Crack. Можете использовать файл FancyRd.exe из папки Crack заменив им исходный.

Настройка:
1. Если в системе установлено до 3Гб оперативной памяти, система Windows 32bit видит всю доступную оперативную память, тогда в меню выбираем "Создать новый диск" и после создания больше ничего не делаем.
2а. Если в системе установлено 4Гб и выше оперативной памяти, по желанию, разрешаем RAM-диску использовать невидимую оперативную память, для этого в программе меняем параметры RAM-диска Параметры оперативной памяти -> ставим галку Использовать невидимую память.
2б. Если в системе установлено 4Гб и выше оперативной памяти, система Windows 32bit видит не всю доступную оперативную память (3,0-3,7Гб в зависимости от материнки), тогда открываем настройку программы (в нижнем левом углу в виде гаечного ключа) Управление невидимой памятью (НП) -> Разрешить НП + обязательно включить РАЕ (постраничная адресация памяти выше 4Гб, поддержка не гарантируется... но в большинстве случаев работает). Т.е., доступная память может быть организована как странички по 4Гб. При этом "невидимая" ("затеняемая" устройствами) область памяти из первых 4Гб будет доступна по пункту "Разрешить НП", вся память выше 4Гб - как следующая "страничка" с "невидимой памятью". Ограничения зависят от используемой версии программы .
Для включения РАЕ необходимо вручную отредактировать находящийся в корне загрузочного раздела диска скрытый файл boot.ini:
для WinXP открыть файл C:\boot.ini и заменить в нём строку:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
на
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /execute /pae /fastdetect
или
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /execute /pae /fastdetect /usepmtimer (для процессоров AMD)
Для этого запустите boot_normal.exe или boot_normal_amd.exe (для процессоров AMD) он автоматом пропишет новый boot.ini с выключенным DEP и включенным PAE.
для Win7 c командной строки изменить BCD:
BCDEdit /set PAE forceenable

Динамическое управление памятью
Это выделение памяти под RAM-диск в зависимости от занятого места на нем, для этого в настройках RAM-диска Параметры оперативной памяти -> ставим галки Динамическое управление памятью и Компактный режим. Допустим у нас в системе 2Гб оперативной памяти. Мы выделяем, скажем, 1Гб из своих двух. Пока RAM-диск незаполнен, системе доступно 2Гб, по мере его заполнения система получает меньше. Причем память может освобождаться после удаления файлов, только нужно поставить галку "Компактный режим", чтобы RAM-диск "отдавал" свой свободный (освободившийся) объем обратно в оперативную память. При создании RAM-диска, в окне "Параметры файловой системы" выбираем "Файловая система: NTFS". Если FAT "сжиматься" не будет. С одной стороны - более рациональное использование памяти, с другой - стабильность и скорость такой системы будет ниже.

Небольшой мануальчик для тех, у кого памяти больше 4Гб. Казалось бы, оптимальное её использование - установить х64-систему...
Но есть и другие варианты:
Вариант 1. Можно установить... 2003 Server Enterprise. Он поддерживает (в страничном режиме - РАЕ) до 64Гб и GPT-диски (хотя, вроде, создавать и загружаться из них не умеет). И при этом обычно никаких проблем с совместимостью с Windows ХР нет. Ай да "старичёк".
Вариант 2. Можно и на х86-системах (Windows ХР/7) использовать память оптимально. Ставим обычную ОС х86, потом устанавливаем драйвер Primo Ramdisk (желательно найти Pro или выше, поддерживающие больше 8Гб памяти). После перезагрузки (не забываем включить РАЕ!) запускаем управление Primo и создаём на незадействованной виндой памяти RAM-диск. Например, у меня на 8Гб под Windows ХР получилось 4,7Гб (по привычке назначил ему букву В:\, FAT32 /или при необходимости NTFS/). Скорость работы такого диска - порядка 2-4Гб/с (против максимум 150Мб/м для харда). Этот диск можно использовать по-разному: например, для обработки данных, требующих быстрый доступ к диску (так, обработка звуковой дорожки к фильму заняла вместо 30мин /с довольно шустрого винта/ примерно полторы - /если файл находился на RAM-диске). Многие программы умеют использовать "свой" ТЕМР-вый каталог (ищем/указываем в настройках программы). Второй вариант - использовать как ТЕМР-овый каталог (который будет автоматически очищен после перезагрузки!). Третий - закачка/раздача торрент-файлов с него (чтобы не гробить винт постоянными обращениями!). Главное, не забывать до перезагрузки забрать оттуда данные. Ну, и самое интересное применение - размещение на нём файла подкачки (фп). Последний вариант позволяет значительно ускорить, например, тяжёлые программы - ведь фп - это "продолжение" памяти при её нехватке, а размещение фп на RAM-диске означает, по сути, увеличение доступной памяти до полного её размера. Кроме того, такой вариант отлично дополняет ОС на SSD-диске (на этих носителях фп держать КРАЙНЕ не рекомендуется - быстро угробим!). Есть, правда, один нюанс: средствами ОС создавать фп на этом диске бесполезно, поскольку он монтируется уже после загрузки ОС. Но выход есть. Вначале назначаем минимальный файл подкачки 32Мб (без возможности увеличения) на обычном харде (это нужно, чтобы винда впоследующем сама его не создавала). Потом берём файлик SetPageFile.exe и закидываем его в любой удобный каталог (я забросил его в системный). Создаём ярлычёк с командой: C:\WINDOWS\system32\SetPageFile.exe B:\pagefile.sys 1024 2048
где C:\WINDOWS\system32\SetPageFile.exe - путь к SetPageFile; B:\pagefile.sys - путь к файлу подкачки; 1024 - минимальный размер фп; 2048 - максимальный (размеры выбираем, исходя из объёма RAM-диска, можно указать 4096/4096 если позволяет). Этот ярлычёк добавляем в "Автозагрузка" меню "Пуск" или на рабочий стол (если нужно запускать только по желанию). Все. Теперь при загрузке фп будет автоматически (вручную) подключен на RAM-диске. Можно проверять.
Сама MicroSoft не очень жалует РАЕ-режим памяти, рекомендуя использовать х64-версии ОС (кто бы сомневался!)... но я за год такого использования памяти ни разу не пожалел! Что самое "вкусное" - совместимость с х86 программами (и кряками), более рациональное использование памяти для х86-версий программ (для тех, кто не в курсе: х86-программы под х64 ОС потребляют почти в два раза больше памяти!). И - шустрый "винт", которому не страшна дефрагметация и износ. Если честно, я всерьёз подумываю о увеличении объёма ОЗУ до 16Гб для обычной Windows ХР (или 7х86).

Создаем в системе RAM-диск

Изменяем настройки RAM-диска

Разрешаем RAM-диску использовать "Динамическое управление памятью"

Разрешаем RAM-диску использовать невидимую оперативную память

Разрешаем системе использовать невидимую оперативную память

Помещаем файл подкачки pagefile.sys на RAM-диск

Помещаем папку TEMP на RAM-диск

Сайт: http://www.romexsoftware.com/en-us/vsuite-ramdisk/index.html