NirSoft Suite

NirSoft Suite Portable

Портабельная версия в оболочке - NirLauncher.
Представляет из себя самораспаковывающийся rar-архив (распаковывается во временную папку).

Пакет из более чем 100 небольших бесплатных утилит для продвинутых пользователей и системных администраторов, наподобие популярного Sysinternals Suite. Включает программы для восстановления паролей, инструменты для работы с сетью, средства для разработчиков, системные утилиты и многое другое. Большинство утилит переведено на русский язык.

Внимание!
Большинство антивирусных программ сигнализируют о наличии в пакете троянов, malware и потенциально опасного ПО, однако разработчик заявляет, что NirLauncher не содержит в себе вирусов и срабатывания защиты являются ложными.

Включает в себя:
• AlternateStreamView - Найти все скрытые альтернативные потоки, хранящиеся в вашей системе.
• AltStreamDump - Список дампов альтернативных потоков NTFS.
• AppCrashView - Показывает детали обо всех приложениях, аварийно завершивших работу.
• Asterisk Logger - Показывает пароли скрытые в поле звездочками ('***').
• AdapterWatch - Отображает полезную информацию о ваших сетевых адаптерах.
• ActiveXHelper - Отображает существенную информацию об установленных компонентах ActiveX.
• BatteryInfoView - Показывает информацию о батарее ноутбуков и нетбуков.
• BlueScreenView - Показывает информацию о "синих экранах смерти".
• BluetoothCL - Показывает список bluetooth устройств.
• BluetoothView - Мониторит активность Bluetooth устройств возле вас.
• BulkFileChanger - Изменение даты/времени/атрибутов нескольких файлов.
• BulletsPassView - Показывает пароли скрытые за маркерами.
• ChromeCacheView - Просмотр кэша браузера Chrome.
• ChromeCookiesView - Альтернатива стандартной программе просмотра куков Google Chrome.
• ChromeHistoryView - Показывает историю посещенных страниц браузера Chrome.
• ChromePass - Утилита восстановления пароля для веб-браузера Google Chrome.
• CleanAfterMe - Чистит файлы и записи реестра в вашей системе.
• Clipboardic - Маленький и простой менеджер буфера обмена.
• CurrPorts - Отображает список всех открытых в настоящее время TCP/UDP портов.
• CurrProcess - Отображает список всех процессов, запущенных в данный момент на компьютере.
• CSVFileView - Просмотр и конвертирование .txt и .csv файлов.
• CustomizeIE - Добавить / удалить кнопки панели инструментов и пункты меню в Internet Explorer.
• CustomExplorerToolbar - Добавит кнопки Копировать/Вырезать/Вставить и др. на панель инструментов Проводника Windows 7.
• DeviceIOView - Просмотр переданных данных между программой или службой и драйвером устройства.
• DevManView - Альтернатива стандартному Диспетчеру устройств Windows.
• Dialupass - Восстанавливает Dial-Up пароли во всех версиях Windows.
• DiskCountersView - Показывает счетчики операций чтения/записи жесткого диска.
• DiskSmartView - Извлекает SMART информацию из IDE / SATA дисков.
• DLL Export Viewer - Списки экспортируемых функции DLL и их адресов в памяти - для отладки.
• DNSDataView - Получение DNS-записей (MX, NS, A, SOA) из указанных доменов.
• DomainHostingView - Показывает подробную информацию о домене.
• DotNetResourcesExtract - Извлекает внедренные ресурсы из .NET приложений.
• DownTester - Тест скорости интернет загрузки.
• DriveLetterView - Показывает и изменяет букву диска.
• DriverView - Отображает список всех драйверов устройств, загруженных в настоящее время.
• FastResolver - Разрешает несколько host узлов в IP / MAC-адресах и наоборот.
• FavoritesView - Отображает список всех закладок/избранного.
• FileTypesMan - Альтернатива менеджеру Windows 'Типы файлов'.
• FirefoxDownloadsView - Отображается список загруженных файлов в Firefox.
• FlashCookiesView - Показывает Flash куки, хрянящиеся в вашем компьютере.
• GDIView - Отображает список GDI handles, открытых каждым процессом.
• HashMyFiles - Рассчитывает хеш суммы ваших файлов по алгоритмам MD5/SHA1.
• HeapMemView - Показывает содержимое всех блоков памяти, размещенных в heap.
• HTMLAsText - Конвертация HTML документа в простой текст.
• HtmlDocEdit - Простой HTML дизайнер/редактор.
• HTTPNetworkSniffer - Захват и отображение HTTP-запросов/ответов.
• IconsExtract - Извлекает иконки и курсоры из исполняемых файлов (EXE, DLL, OCX, CPL и др.).
• IECacheView - Список всех файлов, хрянящихся в кэше Internet Explorer.
• IECookiesView - Отображает cookies, которые Internet Explorer хранит на компьютере.
• IEHistoryView - Отображает список всех недавно посещенных веб сайтов.
• IE PassView - Восстановление паролей, сохраненных Internet Explorer (версии 4.0 - 8.0).
• InsideClipboard - Отображает содержимое всех форматов, хранящихся в буфере обмена.
• InstalledCodec - Список установленных кодеков и фильтров DirectShow.
• IPInfoOffline - Показывает информацию о стране по IP адресу.
• IPNetInfo - Легкий поиск всей доступной информации об IP адресе.
• LiveContactsView - Показывает детальную информацию по всем контактам Windows Live Messenger.
• LSASecretsDump - Дамп LSA секретов из реестра.
• LSASecretsView - Показывает список всех LSA секретов, хранящихся в реестре вашего компьютера.
• MACAddressView - Инструмент поиска по MAC адресу.
• Mail PassView - Восстановление паролей электронной почты.
• MonitorInfoView - Отображает важную информацию о вашем мониторе.
• MozillaCacheView - Список всех файлов, хранящихся в кэше браузера Firefox/Mozilla.
• MozillaHistoryView - Показывает список веб-страниц, посещенных в браузерах Firefox/Mozilla/Netscape.
• MessenPass - Восстановление паролей программ обмена мгновенными сообщениями.
• MUICacheView - Изменить/удалить MUICache элементы вашей системы.
• MetarWeather - Расшифровывает METAR отчеты о погоде о отображает их в простой таблице прогноза погоды.
• MyEventViewer - Простая альтернатива стандартному просмотру событий Windows.
• MyLastSearch - Показывает ваши последние поисковые запросы через Google, Yahoo и MSN.
• MyUninstaller - Альтернатива стандартному апплету "Установка и удаление программ".
• MozillaCookiesView - Альтернатива стандартному 'Менеджеру Cookie' браузеров Netscape и Mozilla.
• Network Password Recovery - Восстановление сетевых паролей на Windows XP/2003/Vista.
• NetResView - Отображает список всех сетевых ресурсов.
• NetRouteView - GUI альтернатива стандартной утилите маршрутизации Windows.
• NetworkTrafficView - Показывает статистику сетевого трафика по вашему сетевому адаптеру.
• NirCmd - Решаем много полезных задач из командной строки.
• NK2Edit - Редактор автозаполнения Microsoft Outlook.
• NTFSLinksView - Показывает список символических ссылок/переходов NTFS в выбранной папке.
• OfficeIns - Показывает подробную информацию обо всех установленных надстройках Microsoft Office.
• OpenedFilesView - Отображает список всех открытых файлов.
• OpenWithView - Отключить/включить пункты в диалоге 'Открыть в'.
• OperaCacheView - Просмотр кэша веб-браузера Opera.
• OperaPassView - Утилита восстановления паролей для веб-браузера Opera.
• OutlookAttachView - Извлечение нескольких вложений из Outlook.
• OutlookStatView - Показать общую статистику вашей электронной почты Outlook.
• PasswordFox - Показывает пароли, сохраненные в веб-браузере Firefox.
• Password Security Scanner - Отображает информацию о безопасности паролей, хранящихся в вашей системе.
• PCAnywhere PassView - Показывает пароли, сохраненные в программе Symantec pcANYWHERE.
• PingInfoView - Пинг нескольких host узлов и IP-адресов.
• ProcessActivityView - Показывает все файлы и папки, используемые текущим процессом.
• ProcessThreadsView - Показывает подробную информацию обо всех потоках процесса, который вы выбрали.
• ProduKey - Показывает CD-Keys для установленных MS-Office/Windows.
• PstPassword - Восстанавливает потерянный пароль из PST файла Outlook.
• Remote Desktop PassView - Показывает пароль, хранящийся утилитой удаленного рабочего стола от Microsoft.
• RecentFilesView - Показывает список недавно открытых файлов.
• RegDllView - Небольшая утилита отображающая список всех зарегистрированных файлов.
• RegFileExport - Экспорт автономного файла реестра в .reg файл.
• RegFromApp - Создает файл реестра .reg из изменений, внесенных приложением.
• RegScanner - Сканирование и поиск значений в реестре.
• ResourcesExtract - Извлекает ресурсы из dll / ocx / exe-файлов.
• RouterPassView - Восстановление паролей из конфигурационного файла маршрутизатора.
• RunAsDate - Запуск программы с указанной даты.
• RunFromProcess - Запуск программы под другим процессом, который вы выберете.
• SafariCacheView - Просматровщик/экстрактор кеша браузера Safari Web.
• SafariHistoryView - Показывает историю для веб-браузера Safari.
• SearchFilterView - Показывает фильтры поиска, установленные в вашей системе.
• SearchMyFiles - Альтернатива стандартному модулю "Поиск файлов и папок".
• SeqDownload - Загрузить последовательность изображений из Сети и создать из них анимацию.
• ServiWin - Отображает список установленных драйверов и служб.
• ShellBagsView - Отображает список всех папок, настройки которых сохранены в Windows.
• ShellMenuNew - Отключает/включает новые подпункты в Проводнике.
• ShellExView - Отображает детали об установленных расширениях оболочки.
• ShortcutsMan - Списки всех ярлыков на вашем Рабочем столе и меню Пуск.
• ShellMenuView - Отключает/включает статические элементы меню в контекстном меню Проводника.
• SiteShoter - Сохранить скриншот любой веб-страницы в файл.
• SkypeLogView - Показывает log файлы, созданные Skype.
• SmartSniff - Захват TCP/IP-пакетов и отображение полученные данные в виде последовательности.
• SniffPass - Захват паролей, которые проходят через ваш сетевой адаптер.
• SocketSniff - Просмотр Windows Sockets (WinSock) деятельности выбранного процесса.
• SpecialFoldersView - Легкий переход в специальные папки вашей системы.
• SysExporter - Извлекает данные, хранящиеся в списке-просмотре, дереве-просмотре, выпадающих списках и полях.
• TableTextCompare - Сравнение .txt или .csv файлов.
• URLProtocolView - Показывает/отключает/включает установленные URL протоколы.
• URLStringGrabber - Захват URL строки веб-сайтов через Internet Explorer.
• USBDeview - Списки всех установленных USB-устройств, которые ранее использовались.
• USBLogView - Выдаст отчет с подробной информацией о любых устройств USB, который были подключены/отключены в вашей системе.
• UserAssistView - Эта утилита расшифровывает и отображает список всех записей UserAssist.
• UserProfilesView - Показывает информацию о профилях пользователей.
• VideoCacheView - Извлекает из кэша веб-браузера просмотренные на сайтах видео файлы.
• VNCPassView - Восстановление паролей, хранящихся инструментом VNC.
• Volumouse - Регулировка громкости динамиков колёсиком мыши.
• WakeMeOnLan - Удаленное включение одного или нескольких компьютеров путем отправки Wake-on-LAN (WOL) пакета.
• WebBrowserPassView - Восстановление потерянных паролей из вашего веб-браузера.
• WebCamImageSave - Захват неподвижных изображений с веб-камеры.
• WebCookiesSniffer - Захват и отображение в простой таблице cookies веб-сайта.
• WebSiteSniffer - Захват и сохранение на ваш жесткий диск файлов веб-сайта.
• WebVideoCap - Захват Flash Video файлов и RTSP потоков во время просмотра их в браузере.
• WhatInStartup - Отключает/включает/удаляет программы из автозагрузки.
• WhatIsHang - Показывает информацию о "зависших" приложениях Windows.
• WhoisCL - Получение WHOIS информации о зарегистрированых доменах из командной строки.
• WhoisThisDomain - Получить информацию о зарегистрированном домене с сервера WHOIS.
• WhosIP - Находит всю доступную информацию об IP адресе в командной строке.
• WinCrashReport - Показывает отчет о аварийно завершившем работу приложении Windows.
• WinFontsView - Показывает образцы всех установленных шрифтов.
• WinLister - Показывает список открытых окон.
• WinPrefetchView - Показывает Prefetch файлы (.pf), хрянящиеся в вашей системе.
• WirelessKeyDump - Список дампов всех ключей беспроводных сетей, хранящихся в Windows.
• WirelessKeyView - =Восстановление потерянных ключей беспроводных сетей (WEP / WPA), сохраненных на вашем компьютере.
• WirelessNetConsole - Показывает информацию о беспроводных сетях (консольное приложение).
• WirelessNetView - Отслеживает активность беспроводных сетей вокруг вас.
• Wireless Network Watcher - Показывает, кто подключен к беспроводной сети.
• WinUpdatesList - Показывает список всех обновлений Windows (Service Packs and Hotfixes).

CurrPorts
Крошечная бесплатная утилита, которая выводит список всех открытых на локальной машине TCP/IP и UDP-портов. Для каждого порта отображаются сведения об инициализирующем процессе (имени, пути, версии, файле и т.д.), времени запуска и соответствующем пользователе. Подсветка опасных портов. Также CurrPorts позволяет завершать нежелательные TCP-соединение, убивать процессы, сохранять информацию в HTML, XML или текстовый файл.
Какое обязательное условие для червей, троянов и прочей зловредной нечисти? Наличие на зараженной машине интернета. Интернет - это основной и главный способ передачи собранной информации. Без него вся "полезность" сводится на нет. Для защиты своей системы необходимо использовать пару - антивирус + брандмаузер. Но это не все! К этому комплекту неплохо было бы иметь еще и умную голову, которая грамотно настроит эти инструменты. Неплохо помогает и обычный мониторинг - постоянная проверка "все ли в порядке".
Для проверки можно использовать утилиту CurrPorts. После запуска Вы увидите кто активно "рвется" в сеть. CurrPorts покажет процесс, открытый порт, удаленный ip-адрес и многое другое. При необходимости можно отметить и закрыть соединения. Программа ведет журнал и может предоставить при необходимости HTML-отчет.

USBDeview
Небольшая утилита, которая показывает список всех когда-либо подключенных к Вашему компьютеру USB устройств. Для каждого USB устройства отображается расширенная информация: имя, описание, тип устройства, серийный номер (для mass storage устройств), дата/время первого и последнего подключения, VendorID, ProductID и т.д. USBDeview также позволяет удалять (деинсталлировать) ранее подключенные USB устройства и отключать подключенные сейчас. Она будет маленьким, но полезным дополнением для "Безопасного извлечения устройств". Вы можете, использовать USBDeview на удалённых компьютерах, если вы залогинены на них с правами администратора.

WirelessNetView
Небольшая утилита, производящая мониторинг доступных беспроводных сетей. Для каждой обнаруженной сети программа отображает массу полезной информации: идентификатор сети (SSID), качество сигнала (Last Signal Quality), среднее качество сигнала (Average Signal Quality) число обнаружений, возможность подключения, аутентификация, шифрование, MAC-адрес, мощность сигнала, частота канала (ГГц) и его номер.

Wireless Network Watcher
Крошечная утилита, выводящая список подключенных к вашей беспроводной сети устройств. Для каждого обнаруженного компьютера или девайса выводится IP, MAC-адрес, имя компьютера, производитель сетевого адаптера. Пользователь приложения может экспортировать список устройств в файл (html/xml/csv/txt) или просто скопировать в буфер обмена.
Если у вас возникают подозрения, что кто-то пользуется вашей сетью Wi-Fi, то установите программу Wireless Network Watcher, которая после сканирования покажет все устройства, подключенные к вашему беспроводному модему или роутеру.
К сожалению, утилита чисто информационная - нет кнопки «отключить устройство» и тем более «убить гада». Но, в любом случае, вы можете просто сменить пароль доступа или выключать модем.

Сайт: http://www.nirsoft.net/
Сайт: http://launcher.nirsoft.net/