BootIt Bare Metal (BootIt BM)

BootIt Bare Metal (BootIt BM) 1.28

BootIt Bare Metal - это программный комплекс утилит для работы с винчестерами: разбивка диска, бекап, перенос Windows на другое железо, менеджер загружаемых ОС, текстовый редактор, файловый менеджер и прочие скрипты. Возможности аналогичны Acronis или Pаragon, а размер и время загрузки значительно меньше.

Возможности:
- Совместимость со всеми версиями Windows (9x/Me/NT/2000/XP/2003/Vista/2008/Win7/Win8/Servers).
- Совместимость с x64 (AMD64/EM64T) и 64-бит Windows.
- Поддержка и возможность преобразования MBR, EMBR, GPT таблиц разделов.
- Прямая поддержка PATA / SATA жестких дисков и USB устройств (в обход BIOS).
- Создание, перемещение, удаление и восстановление разделов/томов.
- Надёжное удаление разделов/томов.
- Изменение размеров и преобразование разделов FAT/FAT32/NTFS, Ext2/3/4 без потери данных.
- Создание более 200 основных разделов на дисках с EMBR.
- Поддержка выравнивания разделов согласно Windows 7.
- Полный контроль геометрии дисков.
- Прямое редактирование Windows BCD (меню загрузки) для исправления ошибок, без установочного диска Windows.
- Редактирование небольших текстовых файлов на дисках, в том числе и скрытых.
- Поддержка больших жёстких дисков - 16 екзабайт и более.
- Создание/восстановление бекапов (в т.ч. непосредственно на CD-R/RW и DVD±R/RW).
- Поддержка устройств IEEE1394/USB 2.0/eSATA для снятия образов и работы с разделами.
- Загрузка ОС с любого раздела на любом жёстком диске (через BIOS).
- Загрузка ОС с CD/DVD-накопителя (через BIOS).
- Загрузка нескольких ОС с одного раздела.
- Защита по имени пользователя и паролю и др.

В образ включены: BootIt BM + Image for DOS (GUI) + все скрипты от TeraByte OS Deployment Tool Suite.
По умолчанию глобальные настройки геометрии дисков выставлены на создание разделов со смещением 2048 и MBR 7 (это стандартные настройки для ОС Vista и старше). Опция LimitPrimaries записывается уже ПОСЛЕ инсталляции бута поскольку для MBR и так существует ограничение в 4 основных раздела на диск, а для EMBR - настройки считываются из EMBR каждого диска те которые есть в данный момент. Все эти настройки можно изменить в глобальных или в настройках для каждого диска.

Функции значков на рабочем столе:
Resume - Загрузка с выбранного винчестера, рейда, флешки и их разделов, загрузка следующего устройства биоса.
Settings - Глобальные настройки BootIt BM, устройств, геометрии дисков.
Partition Work - Работа с дисками (создание, изменение, удаление, перемещение разделов) и таблицей разделов.
Boot Edit - Создание меню загрузки ОС и устройств (актуально только когда BootIt установлен на жесткий диск или флешку).
Disk Imaging - Работы с бекапами (создание, развертывания, проверка или клонирование дисков).
Run - Запуск скриптов.
Help - Помощь.
Text Editor - Текстовый редактор.
Scripting - Командная строка + возможность запуска скриптов (для вызова справки по командам набрать help).
Reboot - Перезагрузка ПК.

Случай №1 Нужно было изменить рамеры разделов. Загрузился с LiveCD на WinPe с помощью акрониса изменил размеры разделов, на тот раздел где установлена виндовс вместо буквы C была назначена F. Не обратил на это внимания, подумал что LiveCD и пусть называет их себе как угодно, на ту виндовс что на винчестере это не влияет. В итоге акронис сменил размеры разделов и синхронизировал их не с LiveCD а с ОС на винчестере, при попытке загрузки ОС зависла перед "приветствием". Загрузив BootIt запустил SETWINDL.TBS и скрипт показал - радел с системой имеет букву F вместо положенной С, аналогично и со вторым разделом на винчестере. Изменил буквы и система нормально загрузилась.

Случай №2 В связи с апгрейдом нужно было перенести системный раздел на SSD диск, загрузил BootIt и выбрал Disk Imaging (Image for DOS (GUI)) - Copy. При копировании выбило ошибку записи на 2%, начал тестировать SSD на чтение/запись и копируемый раздел винчестера на целостность раздела, данных и т.д. Причем при аналогичной операции на ноутбуке (решил для начала на нем протестировать SSD) все прошло хорошо. Потом вспомнил про "BIOS (Direct)" это когда обращение идет на прямую к контроллеру дисков, в обход биоса. В итоге копирование прошло без сбоев, плюс сама скорость копирования возросла примерно в 2 раза. В последнем меню копирования указал увеличить копируемый раздел до рамера SSD, сделать его активным, и назначить Std MBR иначе бы поставило Win7 MBR так как он указан по умолчанию в глобальных настройках.

Std MBR - это стандартный MBR от ХР/2003.
Win7 MBR - это стандартный MBR от Vista/7/2008.
P.S. Можно использовать BootIt вместо консоли восстановленния (что есть в установочном дистрибутиве виндовс) для востановления MBR:
MBR Partition Work -> View MR -> Std MBR/Win7 MBR

Сайт: http://uahub.info/forum/showthread.php?t=14427


Создание обновляемого эталонного образа

Миграция Windows на новое железо с помощью TeraByte OSDTOOL

Создание обновляемого эталонного образа операционных систем Windows 5x (2000/XP/XP64/2003), Windows 6x (Vista/7/2008/8/2012) с нужным софтом, а также восстановление и адаптация этого образа для работы на любом железе в HDD/SSD, VHD и UFD (USB-HDD/Flash и т.п.)

Что получим в результате?
Получим эталонный образ ОС Windows 2000/XP/XP64/2003/Vista/7/2008/8/2012 с любимыми программами, который можно:
• Восстановить и адаптировать для работы на любом железе на SSD/HDD/VHD/VMDK/RAW диске.
• Восстановить и адаптировать Windows для работы на любом железе на USB Flash или USB-HDD накопитель.
• Восстановить и адаптировать на VHD/VMDK для работы на виртуальной машине в любом гипервизоре.
• Через некоторое время обновить ОС и любимый софт и использовать опять, как уже обновленный эталонный образ.

Рекомендуемый софт для миграции Windows. [?]

Теория - Принципы создания и миграции образа Windows с нужным софтом http://rghost.ru/43720044
Теория - Сборка через аудит и сиспреп http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=3521&limit=1&m=1#1 [?]
Практика - IFL/IFD c скриптами для запуска прямо из Windоws http://forum.ru-board.com/topic.cgi?forum=5&topic=35257&start=640#15 [?]
Oбраз TBI для быстрого создания загрузочной флешки с бутом BootIt BM v1.17 + IFD v2.81 + IFL v2.81 http://forum.ru-board.com/topic.cgi?forum=35&topic=2993&start=440#14 [?]
Как сделать заливку (сборку под себя) Win7/8/2008R2/2012 и ничего не сломать и беспроблемно перенести и активировать на любом новом железе http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=1783&limit=1&m=1#1 [?]

Задачей данной темы является усовершенствование работы OSDTOOL. То есть хочется в результате загрузить винду на новом железе с установленными ТОЛЬКО НУЖНЫМИ для этого железа драйверами, а не скармливать ей сотни ненужных драйверов [?]...

1. Имеем эталонный образ Windows и он уже развёрнут любым способом на целевом диске с помощью IFW/IFL/IFD, Acronis и т.д.
2. Имеем скрипт OSDTOOL.TBS с интерпретатором TBOSDTS.
3. Имеем папку с критическими MassStorage драйверами. Например эти http://driverpacks.net/driverpacks/latest
Далее так http://forum.ru-board.com/topic.cgi?forum=62&topic=25742#11 [?]
Документация интерпретатора TBOSDTS и версии для DOS, Windows и Linux http://rghost.ru/42977919
 Подробнее... [?]

Несколько видеоруководств http://forum.ru-board.com/topic.cgi?forum=62&topic=25742&start=20#9 [?]

Инфа от kenny5705
Kлонирование Windows XP
 Удаление и интеграция драйверов с помощью скрипта OSDTOOL

Сайт: http://forum.ru-board.com/topic.cgi?forum=62&topic=25742


Драйвера самых распространённых AHCI-контроллеров

Драйвера для AMD, Intel, JMicron, Marvell, nForce, SiS и VIA-контроллеров, под x86 и x64.

В архивах находятся аддоны для UpdatePack-WinXPSP2/3-Rus и UpdatePack-WinXP-SP2_X64-EN.
Также они могут быть интегрированы в любой другой дистрибутив Windows XP или Windows Server 2003 - для этого достаточно запустить MassStor.exe из любой папки нужного аддона и указать дистрибутив.

Очень желательно отписываться о любых удачных/неудачных установках на эти контроллеры. Также пишите, какие контроллеры система с этим аддоном не увидела, кроме RAID, если есть возможность переключения в режим AHCI/IDE.

Версии драйверов:

12.5.22:
AMD - 3.3.1540.26
Intel - 11.1.0.1006
JMicron - 1.17.63.1
Marvell 61xx - 1.2.0.8300
Marvell 91xx - 1.2.0.1019
nForce - 10.3.0.46
SiS - 5.1.1039.3020
VIA - 5.1.7600.601

Сайт: http://forum.oszone.net/thread-135321.html


Migrate-OS-FAQ

Help and FAQ
 Содержание
  • Создание обновляемого эталонного образа
  • Создание обновляемого эталонного образа (полное описание в PDF)
  • Как сделать сборку Windоws методом audit+sysprep
  • Рекомендуемый софт для миграции Windows
  • BootIt Bare Metal
  • TeraByte Image
  • TeraByteOS-DTS (TBOSDTS)
  • Paragon Hard Disk Manager
  • Как сделать заливку (сборку под себя) Win7/2008R2
  • Как сделать заливку (сборку под себя) WinXP
  • Клонирование Windows XP
  • Инструкция по созданию универсального образа WinXP SP3
  • InfToReg
  • Интеграция AHCI драйверов в универсальный образ WinXP SP3
  • Интеграция AHCI драйверов в уже установленную Windows XP
  • Драйвера самых распространённых AHCI-контроллеров
  • Универсальный образ Windows XP Pro SP3 Acronis
  • Универсальный образ Windows 7 Pro SP1 Acronis x86
  • Универсальный образ Windows 7 Pro Acronis x64


InfToReg

InfToReg 1.7.0.434

Инструмент для установки SATA/RAID драйверов вручную XP/Vista/Seven/WinRE/WinPE/Boot(установщик NT6.x) с целью сделать первую или ранее невозможную загрузку ОС, путём добавления файлов *.sys и информации в Registry (в существующий куст реестра SYSTEM), а также многое другое. Работает как с LiveCD (неограниченный доступ ко всему) так и с cамой ОС (ограниченный доступ). Позволяет делать просмотр/редактирование reg файлов. Не требует установки.

Дополнительные возможности:
Установка драйвера в работающий Windows не имея 'железа' (используется devcon.exe).
Интеграция драйверов IDE/SCSI/SATA/RAID в txtsetup.sif. Для совместимости с интеграцией PEBuilder-а добавлен CheckBox "sif PEBuilder like" в закладке Tools.
Удаление Network adapters и т.п.
Удаление записи HAL при переносе систем на PC с различными CPU.
Поиск драйверов по имени = usb*.inf.
Поиск компонент программ (ActiveX/Handler и т.д.).
Функция индексации драйверов.
Конвертирование Inf-ов типа WinPE.
Сохранение информации выбранных элементов с целью переноса в другую OС минуя установку программ (например для интеграции программ в Windows PE).
Copy Mounted Devices from SYSTEM, то есть, копирует информацию о назначенных логическим дискам Drive Letter из текущей системы в выбранную, что поможет избежать путаници с дисками. Drive Letter назначаются с помощью Disk Management.

Применение:
1. Коррекция систем после копирования на другой HDD или раздел.
2. Перенос системы на другую мат. плату/ы.
3. Расширение возможностей загрузки/установки RE/PE/Boot на современные или проблемные ПК.
4. Создание Windows Live.
5. Подготовка Windows для установки за 3-5 минут с помощью Acronis.
6. Перенос ПО.
7. Обслуживание ПК.

Рекомендуется:
1. Изучить/посмотреть/"поиграться" с файлами inf, SYSTEM из разных OС (Vista/7/PE) до и после установки.
2. Всегда делать копию SYSTEM!
3. Скачать и работать в VistaPE (с Explorer.exe) т.к. даёт неограниченный доступ ко всему.

Функция индексации драйверов:
Командная строка: InfToReg.exe scann полный_путь_драйверпак полный_путь_файл_результат [x84/amd64]
Пример:
InfToReg.exe scann "x:\Wlan_x86_8.12.3\" "x:\Wlan_x86_8.12.3\Driver.idx"
или
InfToReg.exe scann "x:\Wlan_x86_8.12.3\" "x:\Wlan_x86_8.12.3\Driver.idx" x86

Инструкция по интеграции драйверов

1. Качаете драйверы для SATA-контроллера: http://forum.oszone.net/thread-135321.html
2. Запускаете программку InfToReg.
3. Загружаете реестр или sif.
4. Выбираете изготовителя драйвера и открываете inf.
5. Отмечаете галочками то, что вы хотите добавить.

Для добавления в реестр нажимаете "Add to Registry".
Для добавления в txtsetup.sif нажимаете "Copy -> to sif".
Для сохранения результатов работы в файл типа *.reg нажимаете "Save to file"
и/или в Windows Registry работающей системы путь = HKEY_LOCAL_MACHINE\System\ControlSet001
или Registry hive выбранный вручную (файл SYSTEM) путь = HKEY_LOCAL_MACHINE\любые буквы\ControlSet001
Затем в текстовом редакторе открываете файл *.reg меняете параметр
ControlSet001
на
CurrentControlSet и сохраняете изменения.

6. Скопировать файлы из папки "system32 drivers" в C:\WINDOWS\system32\drivers\

7. Папку "I" - скопировать в C:\WINDOWS\,
где
"I" - имя папки,
C:\WINDOWS\ - адрес папки "I",
Имя папки, а также адрес можно отредактировать в файле DevicePath.cmd.

8. Выполнить все файлы типа *.reg.
Прописывает драйвера в реестр.

9. Выполнить DevicePath.cmd (требуется наличие spdrvscn.exe)
Команда DevicePath.cmd прописывает путь к inf файлам в реестр:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
параметр DevicePath (смотрим фото)
значение c:\windows\inf;...

10. Проверить параметр DevicePath
Windows XP при установке ищет драйвера указанные в DevicePath.

После установки SATA/SCSI/RAID запускаем программку DisSata.exe, которая поможет перевести неиспользуемые SATA/SCSI/RAID в состояние Disabled.
После установки SATA/SCSI/RAID запускаем файл реестра DevicePath.reg, который поможет восстановить параметр DevicePath.
По окончании установки можно удалить файлы DisSata.exe, DevicePath.reg, а также папку "I" из каталога C:\WINDOWS\.


Интеграция AHCI драйверов в универсальный образ WinXP SP3
Интеграция AHCI драйверов в универсальный образ системного раздела

Интеграция драйверов при помощи Acronis Universal Restore

Скачать с сайта производителя контроллера -> скопировать на карту памяти или добавить на CD -> при восстановлении выбрать Acronis Universal Restore:
а) драйвера лежат на карте памяти - вручную указать путь.
б) драйвера лежат на CD - установка драйверов проходит автоматически.

Интеграция драйверов при помощи DriverInjection и InfToReg

В сборках LiveCD SV-MicroPE 2k10 и LiveCD RusLive by NIKZZZZ есть инструмент для интеграции AHCI драйверов - это две программки DriverInjection и InfToReg.

Интеграция AHCI драйверов (на примере InfToReg)
Пример с добавлением AHCI драйверов, нужны в основном для ноутбуков, там где нет опции переключения в режим IDE

1. Качаете драйверы для SATA-контроллера: http://forum.oszone.net/thread-135321.html
2. Запускаете программку InfToReg.
3. Загружаете реестр.
4. Выбираете изготовителя драйвера и открываете inf.
5. Отмечаете галочками то, что вы хотите добавить.

Для сохранения результатов работы в файл типа *.reg нажимаете "Save to file"
и в Windows Registry работающей системы путь = HKEY_LOCAL_MACHINE\System\ControlSet001
Затем в текстовом редакторе открываете файл *.reg меняете параметр
ControlSet001
на
CurrentControlSet и сохраняете изменения.

6. Скопировать файлы из папки "system32 drivers" в C:\WINDOWS\system32\drivers\

7. Папку "I" - скопировать в C:\WINDOWS\,
где
"I" - имя папки,
C:\WINDOWS\ - адрес папки "I",
Имя папки, а также адрес можно отредактировать в файле DevicePath.cmd.

8. Выполнить все файлы типа *.reg.
Прописывает драйвера в реестр.

9. Выполнить DevicePath.cmd (требуется наличие spdrvscn.exe)
Команда DevicePath.cmd прописывает путь к inf файлам в реестр:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
параметр DevicePath (смотрим фото)
значение c:\windows\inf;...

10. Проверить параметр DevicePath
Windows XP при установке ищет драйвера указанные в DevicePath.

После установки SATA/SCSI/RAID запускаем программку DisSata.exe, которая поможет перевести неиспользуемые SATA/SCSI/RAID в состояние Disabled.
После установки SATA/SCSI/RAID запускаем файл реестра DevicePath.reg, который поможет восстановить параметр DevicePath.
По окончании установки можно удалить файлы DisSata.exe, DevicePath.reg, а также папку "I" из каталога C:\WINDOWS\.

Интеграция доп. драйверов

1. Распаковать все драйвера в C:\Windows\I\,
где
"I" - имя папки,
C:\WINDOWS\ - адрес папки "I",
Имя папки, а также адрес можно отредактировать в файле DevicePath.cmd.

2. Выполнить DevicePath.cmd (требуется наличие spdrvscn.exe)
Команда DevicePath.cmd прописывает путь к inf файлам в реестр:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
параметр DevicePath (смотрим фото)
значение c:\windows\inf;...

3. Проверить параметр DevicePath
Windows XP при установке ищет драйвера указанные в DevicePath.

После установки SATA/SCSI/RAID запускаем файл реестра DevicePath.reg, который поможет восстановить параметр DevicePath.
По окончании установки можно удалить файл DevicePath.reg, а также папку "I" из каталога C:\WINDOWS\.


Интеграция AHCI драйверов в уже установленную Windows XP

Вы купили новый винчестер. Конечно, с интерфейсом Serial ATA. И, конечно, много слышали о новой интересной функции, реализованной в последних моделях - NCQ (Native Command Queuing). Предвкушая заметный прирост скорости загрузки Windows и программ, а также снижение шума винчестера, вы подключаете винчестер, устанавливаете операционку и... Теперь вам потребуется проделать дополнительные манипуляции, чтобы включить поддержку AHCI и установить подходящие драйверы. Иначе технология NCQ, равно как и другие интересные функции, останется незадействованной.

Как включить AHCI (Advanced Host Controller Interface)

Способ первый, классический. Как и при создании RAID, вы используете установочную дискету, идущую в комплекте с материнской платой или созданную самостоятельно. Начинаете установку Windows, доходите до первой перезагрузки, а когда появляется надпись "Press F6..." внизу синего экрана, нажимаете F6 и предлагаете дискету. Следует выбрать правильный вариант драйвера и продолжить установку Windows. Впоследствии, когда установка успешно завершится, будет нелишним еще раз установить драйверы и утилиты - они позволят проделать некоторые настройки и убедиться, что NCQ включена.

Второй способ сложнее, но он позволяет обойтись и без дискеты, и без переустановки Windows. Для этого в BIOS вашего компьютера должна быть возможность отключения AHCI (или Native Mode, что в данном случае синонимы). При включенном режиме эмуляции вы проводите установку Windows, а потом устанавливаете драйверы от производителя контроллера (чипсета материнской платы). Если они не ставятся автоматически, делаете это вручную. Потом включаете AHCI в BIOS, и система начинает использовать преимущества NCQ.

В этом материале описан способ включения режима AHCI без переустановки и без встраивания драйверов SATA в дистрибутив Windows. Этот материал предназначен для тех, кто при установке Windows XP включил в BIOS опцию IDE-mode и теперь желает переключить режим работы контроллера на AHCI.

Примечание: разница между AHCI и IDE-mode сводится к NCQ (технология упорядочивания очереди комманд).

ВНИМАНИЕ!
Если у Вас чипсет от AMD серии 78x (780,785), то пропускайте первые два шага и сразу переходите в конец статьи, там описано как добавить SATA драйвер для вашего чипсета:
"Интеграция SATA драйверов для чипсетов серии 78x (780,785) от AMD".

Интеграция AHCI драйверов

Шаг 1:
Качаем драйверы для SATA-контроллера:
http://asusfans.ru/engine/download.php?id=14.

Шаг 2:
Устанавливаем драйверы:
1) Идем в Мой компьютер -> Свойства -> вкладка Оборудование -> Диспетчер устройств -> раздел IDE ATA/ATAPI-контроллеры.
Нас интересуют два первых контроллера.
2) Выбираем первый контроллер -> Обновить драйвер…

3) Выбираем Нет, не в этот раз и жмем Далее.

4) Выбираем Установка из указанного места и жмем Далее.

5) Выбираем Не выполнять поиск. Я сам выберу нужный драйвер. и жмем Далее.

6) Убираем галочку с Только совместимые устройства и жмем Установить с диска…

7) Жмем кнопку Обзор… и выбираем драйвер.

8) Получаем, что-то вроде этого и жмем Далее.

9) Если выскочит предупреждение, то жмем Да.

10) Драйверы установятся, будет выдано сообщение, жмем Готово. На вопрос перезагрузиться или нет отвечаем нет.

11) Повторяем пункты 2-10 только для второго контроллера. После - перезагружаемся.
12) Заходим в BIOS (F2 при загрузке, для S2 нажимаем Alt+F2) в Advanced -> IDE Configuration -> параметр SATA Operation Mode меняем на Enhanced или AHCI -> жмем F10.
Windows теперь загрузится в этом режиме. После загрузки пройдет установка нового устройства. Вот и все.

 Интеграция AHCI драйверов для чипсетов серии 78x (780,785) от AMD

Шаг 1:
Качаем SATA драйверы:
http://asusfans.ru/engine/download.php?id=17.
Шаг 2:
Устанавливаем драйверы:
1) Копируем из папки SATA драйверы файл ahcix86.sys в директорию C:\WINDOWS\system32\drivers.
2) Запускаем файл AHCI.REG, тем самым добавляем необходимые данные в реестр.
3) Перезагружаемся и в BIOS выставляем SATA (AHCI) режим работы с жестким диском.
4) Если Windows XP загрузилась и вылез мастер установки нового оборудования, то драйверы успешно добавлены. В мастере выбираем Установка из указанного места -> ставим галку только на Включить следующее место поиска, жмем Обзор -> указываем папку SATA драйверы и жмем Далее.
Все, установка драйверов закончена.

Сайт: http://forum.ru-board.com/topic.cgi?forum=84&topic=0792
Сайт: http://forum.ru-board.com/topic.cgi?forum=62&topic=0965
Сайт: http://asusfans.ru/28-kak-postavit-drajvery-sata-na-uzhe-ustanovlennuyu.html


Как сделать сборку Windоws методом audit+sysprep

Как сделать сборку Windоws методом audit+sysprep с любыми программами и устанавливать её потом в любой компьютер

Для тех, кто в танке - этот метод (с небольшими своими непринципиальными фирменными отличиями) применяют OEM производители (Samsung, SONY и т.д.), крупные организации и продвинутые сборщики говносборок.

Постараюсь описать (если хватит сил и желания) как сделать сборку Windоws "под себя любимого" и как её использовать - поставить на любое железо и получить после установки сразу настроенную "под себя" Windоws с любимыми программами.

1. Что будет использоваться и немного теории

Самый основной этап - это подготовка. Нужно обозначить какое ПО будет использоваться и зачем и минимальные знания! Также отмечу свои фирменные отличия, о которых расскажу - сборка (Win+Office) будет активирована автоматически после заливки на новый комп.

Для всего этого дела понадобится виртуальная машина (желательно Hypеr-V) и прямые руки.
Итак нужны минимальные начальные знания:
- Что такое виртуальная машина и иметь хоть минимальный опыт работы с конкретной VM (желательно использовать Hypеr-V, но можно также VMware или VirtualBox)
- что такое режим аудита Windоws
- что такое sysprep
- что такое DISM
- Что такое Image for Windоws (желательно, но необязательно, он просто упрощает жизнь и ускоряет "заливку" уже готовой сборки куда-нибудь).

Объясню сразу почему желательно использовать Hypеr-V (он не нужен ОБЯЗАТЕЛЬНО, просто с ним удобнее). В Hypеr-V есть возможность делать контрольные точки. Контрольная точка на самом деле это дифференциальный VHD диск. Его ещё называют ласково дочкой, потому что он создаётся в пару к другому диску, который является родителем. Смысл такой - при создании контрольной точки наш родительский VHD диск становится ТОЛЬКО для чтения. Изменения на нём сделать уже невозможно. Это своеобразный мгновенный бэкап. Изменения пишуться в новый созданный дочерный дифференциальный диск.
Например поставили обновы. Если всё плохо - можно вернуться назад (в Hypеr-V называется Возврат), если всё хорошо, то можно сделать:
- Опять контрольную точку и работать дальше.
- Объединить дочерный и родительский диск в один (происходит только после выклюения VM) и работать дальше (в Hypеr-V называется Удалить контрольную точку - да именно удалить это объединить, во как).
Делать бесконечно контрольные точки нежелательно - это плохо сказывается на производительности. Я использую максимум 3-4, хотя временно (для разобраться с чем-то) их можно налепить большую кучу без проблем и после разбора полётов повыкидывать лишнее. Создаются они почти мгновенно.
То есть Hypеr-V позволяет мгновенно делать бэкапы и именно из-за этой особенности и удобства стОит использовать именно Hypеr-V. Хотя честно скажу - я редко делаю контрольные точки (иногда вообще не делаю, использую частенько другой метод, а именно делаю бекап не диска, а реестра, расскажу чуть позже об этом прекрасном способе), но иногда и бывает пожалею, что не нажал пимпу "Контрольная точка" вовремя

Домашнее задание:
- Прочитать и понять в общих чертах что такое режим аудита винды, что такое sysprep, DISM. Инфы очень много на русском есть - гугл в руки. Без фанатизма - просто ознакомиться.
- Прочитать и понять что такое VHD диски и какие бывают VHD диски - гугл в руки. Без фанатизма - просто ознакомиться.
Размусоливать не буду. В следующем посте уже будем устанавливать винду в режиме аудита и приступим к установке софта, поэтому важно уяснить вышенаписанное!

2. Где будем это всё делать и что будем делать

Во первых особых требований нет, можно делать где угодно. Например необязательно на виртуалке, можно и на реальном компе. НО. Виртуалка очень сильно всё упрощает - поэтому далее будем говорить об этом варианте.
Во вторых виртуалка требует памяти. На компе с 2 ГБ я сомневаюсь, что это будет комфортно - будут бесконечные затыки. Практика показывает, что требования к железу просты - нужно иметь минимум 4 ГБ памяти ОЗУ (RAM), тогда можно делать всё легко и без геморра.
В третьих как говорилось ранее проще всего юзать Hypеr-V по причинам обозначенным выше. НО. Это не догма.
В четвёртых нужно всё это делать на правильной ОС. Оптимальней всего на Win 8/8.1 Pro/Ent x64 c 4 гигами памяти и выше (лучше на Server 2012/2012r2). Почему именно на этих редакциях ОС? Потому что они нативно поддерживает Hypеr-V, VHD(X) и упрощают все телодвижения ...
И последнее - для такого дела стОит поставить новую незагаженную чистенькую оригинальную (по поводу оригинала особо подчеркну - это важно!) Win 8.1 x64 Pro и не имеет значения активирована или нет ваша свежеустановленная ОС и стоят ли обновления для неё... Не нужно этим заморачиваться. Она нам нужна временно для создания своей сборки. Потом после создания сборки можно будет легко заменить уже ненужную ОС на нужную OC со всеми прибамбасами.
Впрочем тут догмы никакой нет - вы можете запустить VM (виртуальную машину) и делать сборку на любой ОС - FreeBSD, Linux, MAC или Windоws, конечный результат будет одинаков, хотя на винде всё-таки проще многим будет...

Наконец что будем делать. Будем делать сборку Windоws 7/8/8.1. Конкретную редакцию (Pro, Ent и т.д.) не указываю - вам виднее, это не особо важно. Где это важно - буду указывать по ходу. Сразу отмечу, что для Windоws XP всё ниже- и вышенаписанное тоже применимо, НО есть нюансы и поэтому не всё применимо напрямую в лоб, как написано. Впрочем вопросы можно задавать...

3. Диски GPT/MBR. Зарезервированный MBR раздел и режим аудита OC Windоws

GPT/MBR. Эти ругательные аббревиатуры указывают какой HDD будет использоваться, а если точнее тип организации разделов на HDD. Подробнее есть тут и тут. Ещё год назад вариантов было мало - в 99,9% случаев это был MBR. Сейчас ситуация меняется с приходом UEFI вместо BIOS, для UEFI началось внедрение GPT. НО. Даже в случаях UEFI есть режим поддержки MBR (при соответствующих настройках). Поэтому ниже будем рассматриваться только вариант MBR дисков. Для пользователей GPT сообщу, что в всё ниже- и вышеописанное тоже работает и поддерживается прозрачно, кроме специально указанных случаев.

Зарезервированный MBR раздел. Только для MBR дисков (для GPT дисков этот пункт неприменим, у них другая организация разделов, впрочем зарезервированный раздел тоже есть). Есть один нюанс при установке Windоws 7/8/8.1. По умолчанию Windоws создаёт дополнительный зарезервированный основной активный раздел (хотя ради инфы скажу, что например на некоторых Embedded это не происходит по-умолчанию, ). Дополнительный раздел создаётся автоматически на этапе указания куда установить Windоws. Для чего он нужен? Он нужен для случая, если раздел с Windоws отформатирован в NTFS c нестандартным размером кластера (стандартный равен 4 kB), в случаях сжатия этого раздела, при шифровании раздела Windоws c помощью BitLocker™ и некоторых других. На нём располагается загрузчик bootmgr и загрузочные записи BCD (в Windоws 8 и выше там также находится WinRE). Большинству пользователей зарезервированный раздел не нужен. В нашем случае пойдём по пути наименьшего сопротивления, то есть не будем его создавать и соответственно упростим себе жизнь в дальнейшем - а именно на этапе установки сборки. Что жмакнуть при установке чтобы Windоws его не создавала - смотрите ролик ниже.

Windоws в режиме аудита. Кто первый раз прочитал про режим аудита на сайте производителя MS - зачем он нужен и как он используется, наверное ничего не поняли или поняли, но с трудом. Да. Слишком много ненужной инфы там. Всё запутано и неясно. Расскажу проще. Режим аудита - это режим Windоws при котором Windоws работает в спецрежиме, который придумали специально для сборщиков и OEM производителей. Самое основное отличие его - нет пользователей, есть только суперадминистратор. В этом режиме администратор настраивает Windоws под будущих пользователей. В этом режиме можно и нужно добавлять драйвера, программы, настраивать внешнее оформление и параметры Windоws и т.д. Короче это именно то что доктор прописал - можно делать изменения для того, чтобы после установки вашей сборки Windоws были ваши конкретные настройки и программы.

Есть как минимум 3 способа зайти в режим аудита:
- С помощью файла ответов (не будем рассматривать - тема не та, да и задача не та).
- С помощью команды из комстроки %SystemRoot%\system32\sysprep\sysprep.exe /audit /reboot или из графического интерфейса %systemroot%\system32\sysprep\sysprep.exe (обычно не используется, нужно в редких случаях).

- Просто нажать Ctrl+Shift+F3 при установке Windоws на экране приветствия Windоws (наш вариант - потому что мы делаем всё с нуля и красиво).

4. Установка ОС Windоws 7/8/8.1 на VM в режиме аудита

Пора приступить к установке ОС в режиме аудита. Для примера я буду устанавливать в VM Hypеr-V OC Windоws 7 x64 Professional.

Хм.. Давно писал и тут увидел эту ссылку.
Ускорюсь в темпе вальса. Ибо лень писать.
Поставили ОС в режиме аудита, активировали, сделали обнoвление ОС, поставили нужные проги и сделали сиспреп с файлом ответов копирования профиля. Закатали ОС в архив и ставим её всем желающим...
Чем закатывать в архив - дело каждого. Я закатываю с помощью Image for Windоws в tbi, а иногда просто копирую в виде vhd или vmdk на USB-HDD. Раскатываю на новом железе из архива tbi или vhd или vmdk c помощью Image for Linux.
Активация Windоws/Office тут http://forum.ru-board.com/topic.cgi?forum=35&topic=52278&start=280#2 [?]
Как сделать сиспреп с файлом ответов копирования профиля тут Создание обновляемого эталонного образа (полное описание в PDF)
Как обновить Win 8.1 в режиме аудита тут http://www.outsidethebox.ms/16603/

P.S. Чтобы IFL/IFW понимал ваш VHD(X) и VMDK необходимо, чтобы VHD(X) был монолитным, то есть без "дочек" (при необходимости нужно сделать объединение "дочек" и "родителя"), а VMDK должен был однофайловым (подробнее тут Создание обновляемого эталонного образа (полное описание в PDF)

Сайт: http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=3521&limit=1&m=1#1


Обзор Paragon Hard Disk Manager

Paragon Hard Disk Manager 2012

Paragon Hard Disk Manager - многофункциональное и удобное решение, осуществляющее полный цикл обслуживания жесткого диска. С помощью этой программы вы сможете управлять процессом загрузки, производить разбиение диска на разделы, проделывать операции копирования и восстановления, обеспечивать безопасность системы и данных, выводить диск из эксплуатации. Программа является удобным и практичным инструментом для работы с жесткими дисками и архивирования данных для пользователей любого уровня подготовки. Она одинаково хорошо может сохранять данные как персонального пользователя, так и на предприятии. Удобный и простой в использовании интерфейс, несколько Мастеров программы (Smart Wizards) и набор дополнительных утилит обеспечивают решение любых задач связанных с жестким диском понятным даже обычным пользователям. Hard Disk Manager включает в себя функции таких программ, как Partition Manager, Drive Backup, BootManager, Disk Wiper и других.

Paragon Hard Disk Manager Server объединяет корпоративные версии наших бестселлеров: Drive Backup и Partition Manager.

Paragon Домашний Эксперт (Paragon Home Expert) - объединяет в себе все наши новейшие технологии и инструменты для работы с жестким диском в одном удобном решении. Данный продукт поможет вам решить весь комплекс каждодневных и аварийных задач, необходимых каждому пользователю компьютера: резервное копирование, сегментация диска, миграция, оптимизация и дефрагментация, надежное затирание данных, восстановление данных и системы. В английской редакции продукт Домашний Эксперт имеет название Hard Disk Manager (HDM) Suite.

Paragon Partition Manager - программа для простого и надежного управления разделами жесткого диска - позволяет создавать, форматировать, удалять партиции, делать их активными, неактивными, прятать и т.д. Поддерживается работа с FAT, FAT32, FAT16x, FAT32x, NTFS, Ext2FS, HPFS, Linux Swap разделами. Paragon Partition Manager позволяет изменять размеры разделов всех указанных типов, конвертировать без потери данных FAT32 в FAT16, а также NTFS в FAT/FAT32 и наоборот; допускается копирование/перемещение разделов всех перечисленных выше типов. Одна из особенностей Paragon Partition Manager состоит в том, что при обнаружении поврежденных секторов программа, сделав необходимую корректировку, продолжит копирование/перемещение разделов. Paragon Partition Manager может работать с большими жесткими дисками. Встроенная в Paragon Partition Manager функция безопасности защищает от системных сбоев, включая отключение питания при модификации разделов.

С программой вы сможете:
- Выполнять любые операции с разделами.
- Изменять параметры разделов: скрыть/показать, сделать активным /неактивным, присвоить/удалить букву логического диска, изменить метку тома, конвертировать файловую систему и др.
- Перераспределять дисковое пространство между томами.
- Копировать диски или их разделы.
- Создавать резервные архивы системы и данных на локальном или сетевом диске перед выполнением важных операций.
- Загружать компьютер с Recovery CD, восстанавливать диски или их разделы, а также отменять любую операцию с разделами в случае ошибки пользователя.
- Быстро просматривать разделы FAT, FAT32, NTFS, Ext2 или Ext3 FS, редактировать или копировать файлы и директории с помощью файлового менеджера (полностью встроенное приложение).
- Дефрагментировать разделы и оптимизировать размер их кластеров.
- Настраивать и управлять операционными системами на одном ПК.
- Легко создать загрузочный диск на базе WinPE/Linux/DOS на USB флэш носителе для возможностей быстрого и надежного обслуживания и восстановления.
- Работать с Windows 7, 64-битными версиями Windows XP, Vista и 7, новыми жесткими дисками GPT (используемыми в Windows 7, Vista, Mac OS X и Linux), а также с последним ядром Linux.
- Установить Windows 7 или Vista на ваш Mac на платформе Intel.
- Протестировать поверхности, просмотреть и отредактировать сектора, сжать MFT (Главная файловая таблица) на всех типах динамических томов.

Основные возможности:
• Изменение размера, перемещение, сокрытие, слияние, восстановление и конвертирование разделов без какого-либо ущерба для данных.
• Быстрое и безопасное увеличение производительности вашей рабочей станции.
• Конвертирование файловых систем.
• Дефрагментация разделов и оптимизация размера их кластеров.
• 27 стратегий дефрагментации, дефрагментация и сжатие MFT, дефрагментация при минимуме свободного пространства (необходимо менее 1% свободного места)
• Автоматическое выравнивание разделов в соответствии с секторами физического диска для повышения производительности жесткого диска (Автоматическое выравнивание работает во время создания/перемещения раздела, во время перераспределения свободного пространства на диске/изменения размера раздела, только когда затрагивается левая граница раздела, во время копирования/восстановления с изменением размера раздела).
• Исправляет большинство проблем с загрузкой системы, которые могут возникнуть в результате ошибки человека, программного сбоя, либо вирусной атаки.
• Резервное копирование жесткого диска в режиме реального времени.
• Быстрое и надежное восстановление системы.
• Просмотр резервных архивов и восстановление отдельных файлов и папок, целых жестких дисков и/или их разделов.
• Клонирование жесткого диска.
• Автоматизация операций по управлению жестким диском.
• Полное стирание всего содержимого жесткого диска, его раздела или просто затирание свободного дискового пространства.
• Поддержка широкого диапазона программного и аппаратного обеспечения.
• Поддержка RAID массивов, динамических томов Windows, IDE, SCSI, SATA, USB, FireWire жестких дисков.
• Делает процесс добавления новых драйверов простым и быстрым.
• Поддержка локальных и сетевых резервных носителей.
• Файло-уровневое резервирование.
• Создание резервной копии файлов в образ.
• Исключение файлов из образа резервной копии.
• Поддержка Blu-ray дисков.
• Поддержка GPT-форматированных жестких дисков.
• Поддержка Apple® BootCamp™.
• Создание загружаемого восстанавливающего USB флэш диска.
• Загрузочный корректор с поддержкой BCD для решения общих проблем загрузки.
• Мастер установки новой ОС.
• MSI пакетирование: удаленная и автономная установка, развертывание ПО.
• Выполнение любых операций в Windows 7 и Windows Server 2008 R2.

Адаптивное восстановление Adaptive Restore (Р2Р)
При разворачивании образов хорошо помогает функция Adaptive Restore (P2P) в Paragon HDM/Paragon HE: Мастера -> Р2Р настройка ОС (в линукс-версии присутствует до версии Paragon 2009 и после Paragon 2014 с названием Жесткий диск -> Настроить жесткий диск для загрузки на новом оборудовании), которая позволяет добавить (интегрировать) нужный драйвер в систему, и отключить старый. Применяется как на этапе разворачивания образов так и на уже развернутой системе.

Обзор Paragon Hard Disk Manager

Paragon Hard Disk Manager - программа для разбиения диска и восстановления данных. Для любого пользователя, желающего быть с компьютером на "ты", без утилит разбиения диска и восстановления данных не обойтись. Список этих программ достаточно большой, есть из чего выбирать. Если вы призадумались над приобретением для себя или организации утилиты этого класса, то присмотритесь к Paragon Hard Disk Manager от компании Paragon Software Group (System Utilities), у которого совсем недавно вышла новая версия. Среди многих других достоинств этой версии - поддержка новой операционной системы Windows 7.

Paragon Hard Disk Manager - программа, осуществляющая полный цикл обслуживания жесткого диска:
- Управление процессом загрузки.
- Разбиение диска.
- Операции копирования и восстановления.
- Обеспечение безопасности системы и данных.
- Вывод диска из эксплуатации.

Paragon Hard Disk Manager вышел в трех редакциях: персональной, профессиональной и серверной. Нам на тестирование досталась персональная версия, а об отличиях ее от профессиональной мы расскажем ниже.

Главное окно программы

Hard Disk Manager имеет приятный современный интерфейс, в котором, впрочем, есть недостатки по мелочам. В частности, при создании разделов на больших дисках возникает проблема задания точных размеров дисков. Размер задается ползунковым регулятором, который не позволяет точно задать требуемый раздел, а полей для численного ввода размера нет. Особенно это неудобство заметно на современных жестких дисках большой емкости. И чем больше диск по объему, тем труднее попасть в нужные размеры. Конечно, можно потом воспользоваться функцией изменения размера разделов и подкорректировать эти размеры, но это лишние телодвижения.

И еще одно легкое замечание. Смена видов работ реализована в виде вкладок в главном окне программы. Первой вкладкой разработчики выбрали "Панель дисков". Работа по разметке HDD - важная, но разовая. Главное же в Paragon Hard Disk Manager - выполнение операций архивирования в текущей работе, а также восстановление данных из архива. Переключиться на новую вкладку - не проблема, но лучше все же было бы первой сделать вкладку "Файловый менеджер". Или пусть бы программа открывалась с последней использовавшейся вкладкой. А может, это просто я такой излишне привередливый?

Уведомление об отложенном режиме

Создание дисков выполняется в отложенном режиме. Это означает, что пользователь может осуществлять форматирование жесткого диска в виртуальном режиме, без внесения реальных изменений на HDD. После создания всего цикла операций можно проверить правильность выбранных команд, а затем нажать на одну единственную кнопку "Применить", и программа начнет выполнение всех заданных операций, которые выполняются довольно быстро. После перезагрузки все диски станут видны в системе.

Выполнение заданий по разметке жесткого диска

Теперь архивирование. Алгоритм выполнения архивирования типичен: выбирается объект для архивирования, затем место для хранения архива, затем параметры процесса. И выполняется само архивирование. В новой версии персональной редакции добавлена возможность инкрементного архивирования (то есть копирование лишь тех секторов, которые были изменены с момента получения последней копии). Это существенно повышает скорость процедуры архивирования, что особенно важно при ежедневной операции сохранения данных.

Первый шаг в создании архива данных

Со временем у любого персонального пользователя собирается целый пакет архивов разных дат. (Что уж тут говорить о корпоративном использовании программы?) Порой бывает трудно разобраться в том, что уже можно удалить, а какую копию нужно попридержать. Для удобства пользователей в обеих редакциях (персональной и профессиональной) реализована функция "База архивов". Также в новой версии появилась возможность создавать обширный текстовый комментарий к каждому из архивов. Теперь вы сможете, не надеясь на свою память, фиксировать в текстовом виде все необходимые заметки для каждого из архивов.

В механизме восстановления данных тоже есть несколько важных нововведений. Прежде всего надо отметить возможность восстановления данных из архивной капсулы без создания аварийных дисков. Как известно, программы восстановления данных могут восстанавливать архивные копии даже при "убитой" операционной системе. Но для этого им нужно включить в БИОС загрузку с CD и иметь сам аварийный компакт-диск.

При использовании Paragon Hard Disk Manager для восстановления теперь уже не нужно будет менять настройки параметров загрузки, а также беспокоиться о сохранности аварийного диска. Да и сам CD-привод иметь уже не обязательно. Загрузка компьютера и выполнение любых операций восстановления в случае повреждения операционной системы или иных проблем с загрузкой может осуществляться непосредственно из архивной капсулы.

Другая особенность - функция "Сжать". В некоторых случаях приходится восстанавливать данные на разделы, которые по размеру меньше изначальных, но обладают достаточным местом для восстановления самих данных. В этой ситуации восстановление данных раньше было невозможно. Но теперь это можно сделать без труда.

Восстановление раздела целиком - это, в общем-то, тоже редкая операция, как и разметка диска. Гораздо чаще возникает необходимость в восстановлении каких-то конкретных, частных данных, а не целого образа. Для такого восстановления используется функция подключения архива раздела. При таком подключении архива все дальнейшие операции по восстановлению можно выполнять средствами операционной системы Windows - простая функция копирования.

Все операции в программе выполняются с помощью мастеров. Некоторые из них могут работать в расширенном, для опытных пользователей, режиме. Мастера помогут пользователю правильно и в нужной последовательности выполнить операции по работе с диском и работе с архивами.

Профессиональная версия

Изменения в профессиональной версии числом поменьше, чем в персональной. Потому что часть нововведений (в частности, инкрементное копирование) уже присутствовали в профессиональной редакции. Но и здесь разработчикам есть чем похвастать:
- Функция "Циклическое резервное копирование", позволяющая регулярно создавать резервные архивы и автоматически управлять ими.
- Технология Hot Backup для динамических томов.

Резюме

Paragon Hard Disk Manager - удобный и практичный инструмент работы с жесткими дисками и архивирования данных для пользователей любого уровня подготовки. Он одинаково хорошо может сохранять данные как персонального пользователя, так и на предприятии. Особо ценным новшеством в новой версии можно назвать возможность восстановления данных без создания аварийного диска, функцию инкрементного копирования, а также поддержку новой операционной системы Windows 7.

Сайт: http://www.paragon.ru/
Сравнение версий: http://www.paragon.ru/corporate/hdm-server/comparison.html


Рекомендуемый софт для создания, захвата, восстановления и адаптации эталонного образа

Любой гипервизор с поддержкой VHD или VMDK, например VirtualBox или VMWare Workstation для создания эталонного образа.
IFW – Image for Windows, программа для онлайн/оффлайн захвата и восстановления эталонного образа http://www.terabyteunlimited.com/image-for-windows.htm
IFL – Image for Linux, программа для оффлайн захвата и восстановления эталонного образа http://www.terabyteunlimited.com/image-for-dos.htm
IFD – Image for DOS, программа для оффлайн захвата и восстановления эталонного образа http://www.terabyteunlimited.com/image-for-linux.htm
TBOSDTS – TeraByte OSD Tool Suite Pro, интерпретатор скриптов для задач адаптации ОС и других http://www.terabyteunlimited.com/tbosdt.htm

IFW/IFL/IFD - это утилиты для резервного копирования файловой системы раздела(ов) или целого диска. Текущая версия 2.79.
Кратко возможности:
• Каждая из программ может работать как в своей операционной системе, так и в версии с загрузочным CD/DVD/Flash.
• Утилиты используют для архива разделов и диска свой файловый формат TBI.
• Архив может быть снят с любого жёсткого диска, включая сетевые диски и виртуальные диски форматов RAW, VHD и VMDK.
• Поддерживают инкрементные и дифференциальные (разностные) архивы.
• Поддерживают дробление большого архива на несколько меньших фиксированных размеров 4GB, 2GB, 700MB и 650MB.
• Кроме архивации и восстановления также поддерживается прямое копирование между HDD, RAW, VHD и VMDK.
• Умеют создавать (без драйверов и прокладок) виртуальные диски форматов VHD/ VMDK/RAW.
• Программы работают с FAT, FAT32, NTFS, EXT 2/3/4, ReiserFS, XFS и другими файловыми системами (без драйверов и прокладок) по шинам USB 1/2/3, FireWire, ATAPI /ASPI, IDE, SATA, SCSI, iSCSI и стандартам AHCI/ RAID.
• Умеют создавать загрузочные CD/ DVD для автоматического восстановления.
• Выпускаются в консольной CUI и графической GUI версии.

Интерфейс у программ линеек IFW/IFL/IFD идентичный . Достаточно попробовать IFW и можно работать с IFL_GUI/IFD_GUI. Я советую использовать английскую версию IFW (хотя русский модуль для IFW и есть на офсайте), так как у IFL/IFD русификатора нет и вряд ли будет.

В комплект IFW входит утилита TBIView – для просмотра и извлечения файлов из архивов TBI, утилита TBIMount – для монтирования TBI в качестве логического диска, TBOSDTS с скриптами и некоторые другие малоинтересные. Есть поддержка GPT, UEFI, сети и т.д.

В комплект IFL входит TBIView и TBOSDTS с скриптами, Midnight Commander, TrueCrypt, куча консольных утилит, в которых может разобраться только линуксоид, плюс поддержка GPT, UEFI, iSCSI, SSH, Samba, NFS, PXE boot , многоядерности и ещё много чего, о чём я не догадываюсь. Интерфейс IFL_GUI аналогичен IFW.

Про IFD напишу ещё пару слов. Если Image for Linux и Image for Windows для работы SATA/SCSI/SAS AHCI/RAID требуют соответствующих драйверов, то для Image for DOS они не нужны. IFD работает напрямую с контроллерами дисков через BIOS, также у неё есть возможность работать напрямую с контроллерами дисков минуя BIOS и плюс напрямую c шинами USB/FireWire. И у меня было пару случаев, когда только IFD увидел “железный” RAID массив, а IFL/IFW видели отдельные HDD, и им требовался драйвер для корректной работы с RAID. А ведь размер IFD всего 1 MB! Иногда незаменимая ничем вещь. Интерфейс IFD_GUI аналогичен IFL_GUI и IFW.

IFW/IFL/IFD архивируют файловую систему с любого носителя и и восстанавливают файловую систему на любой носитель:
VHD < –> TBI <–> VMDK VHD < –> TBI <–> HDD VMDK < –> TBI <–> HDD HDD <-> TBI <->HDD
Утилиты IFW/IFL/IFD также позволяют делать прямое копирование между VHD, VMDK и HDD/UFD:
HDD <– > VHD VHD <–> VMDK VMDK <–> HDD HDD <-> HDD

IFW/IFL/IFD поддерживают инкрементные и дифференциальные (разностные) архивы. Инкрементные архивы поддерживаются начиная с версии IFW/IFL/IFD 2.78.

TeraByte OSD Tool Suite Pro (TBOSDTS) - это интерпретатор скриптов и в нём используется мощный оригинальный скриптовый язык. Текущая версия 1.34a. Интерпретатор TBOSDTS есть пяти видов - для DOS, Linux, Windows x86, Windows x64 и BootItBM (спецверсия с расширенными возможностями менеджера разделов). А скрипт уже является платформонезависимым (за редким исключением) и выполняется одинаково в любой среде. В данный момент доступно 10 стандартных скриптов (поставляются вместе с TBOSDTS Pro версии). Пока на данном этапе нас интересует только 3 скрипта.

OSDTOOL.TBS
Интерактивный скрипт для решения задач адаптации операционных систем Windows к новому железу. Может использоваться с файлом ответов для автоматизации.
Работает в DOS, Linux и Windows. Применяется для оффлайн образа, расположенного на HDD/UFD или на виртуальном диске VHD/ VMDK. Не требует IFW/IFL/IFD. Делает автоматический бекап реестра Windows перед своей работой.

TBIDTOOL.TBS
Интерактивный скрипт для восстановления эталонного образа из архивов TBI на целевой диск и адаптации операционных систем Windows к новому железу. Может также использоваться с разными файлами сценариев для полной автоматизации.
Работает в DOS, Linux и Windows. Применяется для архива TBI. Tребует наличия IFW или IFL или IFD. Архив восстанавливается на HDD/UFD с помощью IFW или IFL или IFD.

SAVEREG.TBS
Скрипт для резервного архивирования реестра Windows, BCD и настроек всех пользователей.
Работает только в Windows и архивирует реестр только той Windows из которой запущен скрипт. Возможно создание, замена и удаление 9 архивов (от 1 до 9). Архивы сохраняются в папке %SYSTEMDRIVE%\SaveReg\Windows\ с номером архива. Архивы имеют дату создания и можно им присвоить имя.
При восстановлении архива через скрипт RESTOREG.TBS актуальный реестр автоматически архивируется в номер 0.

OSDTOOL.TBS более гибкий и не требует наличия IFW/IFL/IFD. То есть его можно использовать отдельно от других продуктов Terabyte и для работы его требуется всего 2 файла - сам скрипт и интерпретатор TBOSDTS. Скрипт OSDTOOL.TBS может быть применён к виртуальному или физическому диску. До или после создания архива TBI, а также без необходимости создания архива. Перед работой OSDTOOL.TBS автоматически создает бекап состояния системы. То есть всегда есть возможность вернуться в состояние до его использования.

База знаний Terabyte http://www.terabyteunlimited.com/kb/
Инструкции и видео из офсайта http://www.terabyteunlimited.com/howto/index.htm

Сайт: http://forum.ru-board.com/topic.cgi?forum=62&topic=25742&start=0&limit=1&m=2#1


TeraByte Image for Windows

TeraByte Image for Windows (IFW) 2.90
TBIView - для просмотра образов
TBIMount - для монтирования и просмотра образов

TeraByte Image for Windows (IFW) - это мощная утилита от компании TeraByte Unlimited для резервного копирования и восстановления файловой системы диска с помощью технологии PHYLock™. Резервная копия может быть снята с любого жёсткого диска, включая сетевые и внешние с интерфейсами USB2 и IEEE1394. Программа получает прямой доступ к файловым системам FAT, FAT32, NTFS, а также USB2, IEEE1394, ATAPI или ASPI (диски CD-R/RW или DVD+RW/+R/-R/-RW). Резервные копии можно записывать на CD/DVD/BD, имеется возможность создания загрузочных дисков для автоматического восстановления. Программа поддерживает интерфейс RAID, работает под управлением Windоws (в том числе серверных версий), но может применяться для резервного копирования или восстановления разделов в сторонних программах, в том числе DOS и Linux. Для автоматизации операций копирования и восстановления поддерживается управление из командной строки. Выпускается в обычной и GUI версии.
Образ диска совместим со всеми образами дисков TeraByte той же версии (например, все продукты версии 1.x совместимы с другими продуктами версии 1.x). Благодаря этому очень легко восстанавливать образы дисков, даже если Windows недоступен.
Посмотреть свой образ TBI можно в Windows в бесплатной программе TBIView™ или смонтировать как диск в TBIMount™. Там и будет видно сколько разделов, файлы и т.д.
Бонус: Каждая покупка Image for Windows содержит также Image for DOS (IFD) и Image for Linux (IFL). Image for DOS и Image for Linux поддерживают ту же мощную функциональность без необходимости установки Windows.
Также программа содержит лицензированную копию набора инструментов TeraByte OS Deployment Tool Suite (TBOSDTS). TBOSDTS обладает среди прочего рядом мощных утилит, которые помогут вам использовать Windows для абсолютно другого аппаратного обеспечения. Например, для адаптации ОС под новое железо применяется очень мощная функция OS Deployment Tool: программа не только позволяет удалить/добавить драйвера HAL/Mass Storage, но и позволяет сделать Sysprep (полную подготовку к "обезличиванию" ОС, сменить ID, имя пользователя и т.п.), что может быть очень важно в сетях предприятий.

Возможности:
• Надёжность. Позволяет проверить каждый байт резервной копии.
• Удобство. Запускается непосредственно из под Windows, а при использовании с PHYLock можно создать точный образ раздела Windows без перезагрузки.
• Безопасность. Резервные копии могут быть защищены с помощью паролей или 256-битного AES-шифрования.
• Резервное копирование изменённых данных. Опция дифференциального резервного копирования позволяет создавать резервные копии только тех данных, которые изменились с момента создания последней резервной копии.
• Простой, пошаговый интерфейс. Прост и интуитивно понятен в использовании.
• Максимальное сжатие. Сжатие применяется по умолчанию к каждому созданному образу.
• Максимальная скорость. Если важна скорость резервного копирования, то можно обойтись без сжатия.
• Поддержка оптических дисков. Можно записать образ непосредственно на CD, DVD, DVD-DL и BD диски.
• Спасательный загрузочный диск. При каждом сохранении образа непосредственно на CD, DVD, DVD-DL и BD диски, они становятся восстановительными загрузочными дисками.
• Поддержка дисков большой ёмкости. Поддерживаются GPT-совместимые диски ёмкостью более чем 2 терабайта.
• Восстановление отдельных файлов и папок. Используя бесплатные дополнительные компоненты TBIView и TBIMount, можно просмотреть содержимое файлов образа, а при необходимости восстановить отдельные файлы или папки.
• Автоматически распознаёт и выполняет резервное копирование используемой области FAT16, FAT32, NTFS, Ext2, Ext3, Ext4, ReiserFS и XFS разделов. Разделы с другими типами файловой системы также могут быть архивированы. Поддержка всех стандартных разделов в MBR, EMBR или GPT.
• Windows Server. Поддержка рабочих станций и серверов Windows.
• Экономичность. Без дополнительной платы с пакетом поставляются Image for DOS, Image for Linux и TBOSDT, что делает данное решение уникальным, полным и доступным.
• Гибкость. Позволяет восстанавливать разделы, независимо от файловой системы на восстанавливаемом разделе, что предоставляет возможность восстановления NTFS-разделов из под Windows 98 или даже DOS.
• Поддержка различных устройств. Совместимость с внешними накопителями USB 2 и IEEE 1394. Более того, эти драйвера поддерживает Image for DOS, без необходимости сложной установки драйвера (Image for DOS использует драйверы, уже доступные под Windows).
• Мощь. С использованием версий Image for DOS и Image for Linux (каждая из которых поставляется с Image for Windows) у пользователей появится возможность восстановления данных, даже если Windows не запускается.
• Сетевая поддержка. Сохранение резервных копий на любой диск, доступный для самой операционной системы Windows.
• Поддержка RAID. Простая работа с аппаратными и программным RAID.
• Поддержка командной строки. Встроена полная поддержка командной строки, что позволяет автоматизировать процесс восстановления или резервного копирования.
• Планирование. Для этого используется встроенный планировщик Windows, нужно всего лишь нажать на кнопку 'Schedule Backup'.
• Проверка образа. Функция позволяет проверить целостность файлов образа, либо в качестве части процесса резервного копирования, либо в любое другое удобное время. Решения TeraByte славятся кропотливым и точным процессом проверки.
• Восстановление раздела с расширением. При восстановлении с образа, можно расширить восстанавливаемый раздел.
• Выбор размера образа. При желании, можно задать максимальный размер образа. Это позволит подогнать размер образа под соответствующий съёмный носитель.
• Аппаратно-независимое восстановление. Позволяет восстанавливать Windows на машинах с совершенно различным аппаратным обеспечением, а затем при помощи набора для развёртывания TBOSDT Pro установить необходимые драйвера.

Варианты использования Image for Windows
Образ в IFD/IFL/IFW может быть одного раздела или нескольких разделов (например четырёх - то есть всего диска).
Ну с одним основным разделом всё понятно - раздел восстанавливается на раздел не меньшего раздела или на незанятое место (на незанятое место получится, только если основных разделов не более 3 уже есть или не более 2 плюс дополнительный раздел - потому что более 4 основных разделов или 3 плюс дополнительный не бывает в MBR в принципе).
Если делался бэкап логического тома (или нескольких томов) дополнительного раздела, то ограничения MBR на количество разделов конечно нет.
Можно также восстанавливать основной раздел на логический том дополнительного раздела и наоборот. Правда зачем это нужно - не очень ясно.
Если несколько разделов восстанавливается, то здесь вариантов больше. Бэкап может быть одним файлом или несколькими файлами (задаётся при бэкапе) и восстанавливать можно на диск (если разделов хватает) или выборочно раздел на раздел или незанятое место.
Если перефразировать всё выше описанное, то IFD/IFL/IFW не даст сделать недопустимую операцию и похоронить таблицу разделов в MBR - поэтому если восстановление возможно, то оно начнётся, если невозможно по-какой либо причине (например мало места или уже есть на диске 4 основных раздела, а вы хотите на свободное место влепить пятый), то выдаст предупреждение и опишет причину неудачи и будет ждать более корректных действий пользователя.
При использовании IFD/IFL/IFW обычно восстанавливают не диск, а раздел. Представим себе, что есть диск и на нём 1 основной активный раздел с виндой. При бэкапе можно бэкапнуть или весь диск или только раздел. Вроде бы разницы особой нет. Но на самом деле есть. При бэкапе раздела и восстановлении раздела на пустой диск (но с кодом MBR) код MBR не будет переписываться на этом диске. И раздел в некоторых случаях не станет активным. Поэтому нужно отметить опциии Set Active и Write Standart MBR Code (если хочешь переписать код MBR на стандартный от MS). Если диск полностью пустой (все нули во всех секторах), то стандартный код MBR запишется автоматически.
Если же бэкапировать диск и восстанавливать диск, то и активность и код MBR перепишется из бэкапа.
Есть и третий вариант - бэкапировать диск, а восстанавливать раздел.

IFD/IFL/IFW не пишут при бэкапе файлы. Они используют посекторный бэкап. Если точнее, то всё немного сложнее - не полностью посекторный, а только в местах занятых файлами (хотя это можно и изменить в опциях). Поэтому ни размер ни хэш не используется. Всё проще - регистрируются и пишутся изменения секторов диска. И после восстановления вы будете иметь идентичный слепок-клон.
Поэтому IFD/IFL/IFW бэкапируют любую файловую систему - и линуксовские и винды и мака и даже незнакомые ФС.
Например если взять 2 диска с полностью идентичными файлами, но которые на первом разбросаны по диску, а на втором сгруппированы или дефрагментированы, то для IFD/IFL/IFW это будут оооочень разные диски и изменений запишеться ооооочень много.
Именно поэтому дефрагментация при дифференциальном или инкрементном бэкапе нежелательна.
Отсюда возникает кстати ещё один малоизвестный нюанс. Бэкап диска с 512 байтным сектором нельзя восстановить на диск с 4096 байтным сектором. Такие диски с 4096 байтным сектором хоть и редко, но встречаются в виде USB-HDD. Уж не помню какой фирмы - это результат ошибки производителя переходника USB-SATA. Приходится вынимать их из кармана USB и подключать напрямую в SATA. Cами диски там имеют стандартный 512 байтный сектор.

!!!Внимание. IFD/IFL/IFW без галки Validate Byte-for-Byte не проверяет ЧТО он записал - поэтому образ может быть тоже битый, если диск для бэкапа сыпется.
Поэтому советую:
- Указать в свойствах путь к лог-файлу для контроля корректности при бэкапе/восстановлении, можно и высылать на почту вроде его.
- Задать контроль корректности при бэкапе/восстановлении с помощью опции Validate Byte-for-Byte для того, чтобы быть на все 100% уверенным в операциях (хотя это и увеличивает время операции в 2 раза). Эта опция крайне необходима для критически важных данных и разделов ОС поскольку позволяет выявить проблемы источника данных, диска для архива или целевого диска на ранней стадии. При ошибках в логе главное отделить что важно и как исправить, и чем можно пренебречь.
Если отметить галку Validate Byte-for-Byte при бекапе, то будет проверять исходный диск\раздел и архив на полное соответствие.
Если отметить галку Validate Byte-for-Byte при восстановлении, то будет проверять архив и целевой диск\раздел на полное соответствие.
Например, если на целевом диске будет нечитаемый сектор, то напишет номер сектора. На фтп есть утилита для определения соответствия сектора -> файлу.
Если хочется несмотря на нечитаемый сектор сделать бекап или восстановление, то есть опция - Ignore IO Errors.

Работаем в IFL/IFD при помощи клавиатуры
Delete - удаление выбранного раздела (осторожно!).
F1 - Details просмотр детальной информации о разделе (сколько занято, сколько свободно и сколько нужно места при восстановлении).
F3 - Compact (только для FAT/FAT32 и NTFS) используется для уменьшения места, нужного для восстановления этого раздела (если по F1 нужное место для восстановления большое, а занятое место на разделе маленькое). Что-то наподобие дефрагментации.
Для работы с помощью клавиатуры используем стрелки, пробел, Tab, Enter.
Переход в папку через Tab (как в винде). Переход между папками - стрелками. Вход в папку - Enter. Имя файла набираем в клавиатуре (для доступа ввода имени - несколько раз Таb).

При использовании Image for Windows оптимальным по скорости и надёжности считаю следующий метод
- Делать бекап OC из под Windows с включенным PHYLock или из под загрузочного СD/Flash IFL.
- Восстановление из под загрузочного СD/Flash IFL/IFD/IFW-WinPE.

PHYLock
PHYLock нужен только при резервном копировани системного раздела, если IFW запущен из винды, которую он же и бэкапирует. Он блокирует и разблокирует доступ к файловой системе на время бэкапа. Как альтернатива может использоваться служба теневого копирования тома VSS (нужно запустить, если не включена и поставить галку в глобальных настройках IFW: Use VSS When Available). Поэтому, если нет монопольного доступа - например как у IFL/IFD/IFW-WinPE желательно включать в настройках галку проверки: Validate/Validate Byte-for-Byte или использовать PHYLock.

Глобальные настройки
Use New Windows MBR - отмечаем при записи MBR Windows 7/8 (для MBR Windows XP это не актуально). Для включения записи стандартного MBR кода Windows XP/7/8 нужна другая галка в настройках восстановления раздела: Write Standart MBR Code.
Automatic Scaling Restrictions - вероятно подгоняет размер восстанавливаемого раздела под размер раздела при бэкапе.
Automatic Boot Partition Update - корректирует всю информацию об начальном загрузочном разделе (это актуально в основном для линукса и Windows 7).
Align Partitions on 2048 Sectors - применяется для Advanced Format HDD, флешек, SSD. А так как никто не знает наперёд какой диск будет для восстановления, то лучше включить (это важно только для восстановления, для бэкапа это не имеет значения). В IFL нельзя задать Align Partitions on 2048 Sectors в GUI меню при создании. Поэтому при необходимости делаем вручную после его загрузки.

Настройки при создании резервной копии
Validate - проверка резервной копии. Применяется при резервном копировании системного раздела, если IFW запущен из винды, которую он же и бэкапирует, при отключенном PHYLock.
Validate Byte-for-Byte - побайтовая проверка резервной копии. Применяется при резервном копировании системного раздела, если IFW запущен из винды, которую он же и бэкапирует, при отключенном PHYLock.
Сжатие резервной копии:
Enhanced Size F - минимальный размер/максимальное сжатие (дольше упаковывает).
Enhanced Speed B - максимальный размер/минимальное сжатие (быстрее упаковывает).

Настройки при восстановлении раздела из резервной копии
Set Active - сделать раздел активным.
Update BOOT.INI - можно отмечать, если восстанавливаем образ Windows XP/2003. Программа сама корректирует в этом случае файл boot.ini.
Update Boot Partition - похожа на предыдущую. Она корректирует всю информацию об начальном загрузочном разделе (это актуально в основном для линукса и Windows 7).
Write Standart MBR Code - запись стандартного MBR кода. Какой именно записывается от Windows XP или от Windows 7/8 определяет другая галка в глобальных настройках: Use New Windows MBR. Хотя по большому счёту код почти одинаков и работает одинаково.
Restore First Track - восстановление с полным копированием первой дорожки. Это нужно, если используется нестандартный MBR, который занимает более одного сектора. Это изменит код MBR и таблицу разделов диска на такой же код MBR и таблицу разделов диска, который использовался при бэкапе. То есть в результате восстановления останется только раздел с размером, что и при бэкапе. Хотя при определенных настройках этого не произойдет.
 Validate Before Restore - проверка резервной копии. Применяется при восстановлении системного раздела.
Validate Byte-for-Byte - побайтовая проверка резервной копии. Применяется при восстановлении системного раздела.
Wipe Unused Sectors - неиспользуемые сектора (в файлах) в архивируемом разделе будут игнорироваться и будут писаться нули на их место.
Move to Original MBR Entry - восстановить раздел на "своё" место. Например архивировался раздел, который в исходном MBR был на 2 месте. С этой галкой он и станет на второе место.
Изменить размер после восстановления - размер раздела можно указать при его восстановлении. Минимальный размер ограничивается размером образа TBI, а максимальный - размером восстанавливаемого раздела. По умолчанию размер восстанавливаемого раздела на диске будет равен размеру раздела при бэкапе, поэтому, если размер восстанавливаемого раздела больше чем размер раздела при бэкапе нужно вручную указать максимальный размер в настройках восстановления.

TeraByte OS-DTS - запускаем TeraByte Image for DOS

TeraByte Image for Windows

Глобальные настройки

Создание резервной копии (образа)

Восстановление раздела из резервной копии (образа)

Дополнительная инфа в документации...

Сайт: http://www.terabyteunlimited.com/index.htm
Свежая версия TBI: http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=2240#6


TeraByte OS Deployment Tool Suite Pro (TBOSDTS)
Краткое описание доступных скриптов TBEXPLO.TBS, INISTART.TBS, OSDTOOL.TBS, TBIDTOOL.TBS, COPYP2V.TBS, SAVEREG.TBS/RESTOREG.TBS, SETWINDL.TBS, MOVEUSER.TBS, USBBOOT.TBS из TBOSDTS

TeraByte OS Deployment Tool Suite Pro (TBOSDTS) - это интерпретатор скриптов и в нём используется мощный оригинальный скриптовый язык. Интерпретатор TBOSDTS есть пяти видов - для DOS, Linux, Windows x86, Windows x64 и BootItBM (спецверсия с расширенными возможностями менеджера разделов). А скрипт уже является платформонезависимым (за редким исключением) и выполняется одинаково в любой среде. В данный момент доступно 10 стандартных скриптов (поставляются вместе с TBOSDTS Pro версии).

TBEXPLO.TBS Script
Этот скрипт является мини файл-менеджером, позволяющий:
- Просматривать файлы и каталоги.
- Копировать, удалять, переименовывать файлы и каталоги.
- Управлять атрибутами файлов и каталогов.
- Копировать защищенные файлы Windows (удобно для bootmgr, BCD и подобных файлов). Чтобы увидеть системные и скрытые файлы - смотрите Нelp по F1 - Options Ctrl+O.
- Производить поиск файлов и каталогов.
- Монтировать как диски файлы ISO, IMA, IMG, BIF, VHD, RAW, VMDK и подобные и просматривать/редактировать их и файлы внутри их.
- Просматривать реестр Windows: в том числе выполнять удаление, переименование, создание, а также копирование ключей и значений реестра, искать ключи и значения, и т.д.

OSDTOOL.TBS Script
Скрипт миграции Windows на другое железо
Интерактивный скрипт для решения задач адаптации операционных систем Windows к новому железу. Может использоваться с файлом ответов для автоматизации.
Работает в DOS, Linux и Windows. Применяется для оффлайн образа, расположенного на HDD/UFD или на виртуальном диске VHD/ VMDK. Не требует IFW/IFL/IFD. Делает автоматический бекап реестра Windows перед своей работой.

OSDTOOL.TBS гибкий скрипт и не требует наличия IFW/IFL/IFD. То есть его можно использовать отдельно от других продуктов TeraByte и для работы его требуется всего 2 файла - сам скрипт и интерпретатор TBOSDTS. Скрипт OSDTOOL.TBS может быть применён к виртуальному или физическому диску. До или после создания архива TBI, а также без необходимости создания архива. Перед работой OSDTOOL.TBS автоматически создает бекап состояния системы. То есть всегда есть возможность вернуться в состояние до его использования.

Этот интерактивный скрипт обеспечивает удобный способ осуществления следующих задач, связанных с развертыванием операционных систем Windows на HDD/VHD/VMDK:
- Удаление установленных драйверов.
- Установка любых драйверов, в том числе с фильтрацией по "железу".
- Изменение HAL.
- Изменение имени компьютера.
- Настройка сервисов Windows.
Типичный сценарий использования OSDTOOL.TBS - это перенос существующей ОС Windows XP/2003R2/Vista/7/2008/2008R2 на новое или изменённое оборудование или виртуальную машину.

Краткий ролик по использованию OSDTOOL.TBS: OSDTOOL - видеоролик.exe.
 Видео из офсайта - миграция Windows Server 2003 из платформы Dell R610 на платформу HP GL360 с помощью Image for Linux и встроенного в него скрипта OSDTOOL.TBS: OSDTOOL - sample.wmv.

TBIDTOOL.TBS Script
Интерактивный скрипт для восстановления эталонного образа из архивов TBI на целевой диск и адаптации операционных систем Windows к новому железу. Может также использоваться с разными файлами сценариев для полной автоматизации.
Работает в DOS, Linux и Windows. Применяется для архива TBI. Tребует наличия IFW или IFL или IFD. Архив восстанавливается на HDD/UFD с помощью IFW или IFL или IFD.

COPYP2V.TBS Script
Скрипт для автоматизации преобразования физической машины на виртуальную машину в виртуалные диски VHD/VMDK.

SAVEREG.TBS/RESTOREG.TBS Script
Эти скрипты используются для резервного копирования и восстановления реестра Windows.
SAVEREG.TBS - скрипт для резервного архивирования реестра Windows, BCD и настроек всех пользователей.
Возможно создание, замена и удаление 9 архивов (от 1 до 9). Архивы сохраняются в папке %SYSTEMDRIVE%\SaveReg\Windows\ с номером архива. Архивы имеют дату создания и можно им присвоить имя.
При восстановлении архива через скрипт RESTOREG.TBS актуальный реестр автоматически архивируется в номер 0.

INISTART.TBS Script
Этот скрипт для включения значений служб и настроек по умолчанию при запуске Windows. Это может быть полезно, когда система была изменена с помощью вирусов, шпионского ПО и других приложений.

SETWINDL.TBS Script
Этот скрипт используется для назначения буквы логических дисков для Windows. Это может пригодиться, когда система не загружается или вы не можете войти в систему из-за неправильной или измененой буквы раздела Windows.

MOVEUSER.TBS Script
Интерактивный скрипт перемещения/копирования профилей пользователя. MOVEUSER.TBS работает только в Windows версии TeraByte OS Deployment Tool.

- Скрипт работает на любых клиентских/серверных ОС семейства Windows начиная с Windows NT 4.0 (интересно кто-то помнит ещё о такой ОС?) архитектур x86/x64.
- После запуска будут найдены все доступные Windows, в том числе и в оффлайне. ОС на виртуальных дисках VHD/VMDK в этом скрипте напрямую не поддерживаются, только после монтирования VHD/VMDK.
- Перемещения/копирования профилей доступно только для Windows с присвоенной буквой, в том числе и в оффлайне. То есть, если разделу не присвоена буква или раздел скрыт (например, через идентификатор раздела 17h), то скрипт такую ОС увидит, но работать с ней откажется.
- Клавиши управления Up/Down, Enter (выбор пункта в меню) , ESC (возврат в предыдущее меню/выход из скрипта).

Если будет выбрана текущая ОС, то появится предупреждение. Это сделано для того, чтобы вы не запутались.

Выбираем конкретный профиль или все сразу.

Далее выбираем логический том куда будем переносить.
Обратите внимание! Если была выбрана ОС в оффлайне, то скрипт покажет слева (1 на рис.) буквы лог. томов текущей ОС, справа (2 на рис.) буквы лог. томов выбранной ОС, которые были на момент её выключения. Это сделано для того, чтобы вы не запутались.

Будет предложено:
- Скопировать и грохнуть оригинал (переместить).
- Скопировать и оставить оригинал.

Вроде всё. При необходимости скрипт предложит перегрузиться. Если профиль бооооольшой по размеру, то рекомендую такой способ - проводником скопировать папку профиля на другой логический том (про пути к папке нового профиля не забудьте!) и на все предупреждения о невозможности копирования нужно ответить Пропустить. Затем запустить скрипт и он скорректирует новый профиль.

Важно! Не прерывайте принудительно работу скрипта закрытием окна. Если просит нажать клавишу - жмите. Выходите из скрипта или в предыдущее меню через ESC.

Если вы передумали и захочете вернуть всё на старое место и оригинал остался (то есть был выбран ранее Keep previous user folders), то получим такое меню:

Удалить старый профиль (имеется ввиду, тот что лежит в папке назначения) и переместить профиль
Копировать только новые файлы и переместить профиль
Переместить профиль без копирования файлов
Присвоить новое имя папке профиля
Отменить операцию

Кто сообразительный - я думаю уже догадался, что используя пункт Присвоить новое имя папке профиля можно иметь несколько профилей для одного пользователя и переключаться между ними. Пункт Переместить профиль без копирования файлов фактически является восстановлением старого профиля, а пункт Копировать только новые файлы и переместить профиль фактически является обновлением старого профиля.

USBBOOT.TBS Script
Скрипт позволяет скопировать на USB девайс любую уже инсталлированную на HDD винду от XP/2000 до 8/2012 (включая x64 версии) и сделать её загрузочной. Можно также скопировать Windows из VHD/VMDK на USB устройство и заставить её загрузиться.

Первый пункт скрипта Copy a Windows installation to a USB drive требует установленной IFW/IFL или IFD. Он скопирует установленную на HDD Windows в USB устройство (это может быть текущая Windows или установленная на другой раздел или диск) и сделает её загрузочной.

Далее будет ещё вопрос удалять ли установленные драйвера (нужно для запуска на другой машине) или оставить их. Скрипт запустит IFW и начнётся копирование. Вроде всё.

Второй пункт скрипта Enable Windows already installed on USB drive to boot не требует установленной IFW/IFL или IFD. Предназначен для включения загрузки Windows из USB. Например, этот пункт актуален для Windows, скопированной вручную через IFW из VHD/VMDK на USB устройство или раскатанный на USB через imagex+bcdboot или... Для таких случаях рекомендую обратить внимание на ещё один скрипт OSDTOOL.TBS. Его описание есть выше.

Если будет использоваться флешка, то советую её предварительно очистить через clean в diskpart или обнулить первые сектора в bootice. Это крайне необходимо, если флешка не имеет MBR. В дальнейшем на все вопросы Windows по поводу форматирования нужно отказаться.
USBBOOT.TBS скрипт работает в DOS, Linux и Windows для Windоws 6x и в DOS, Windows x86 для Windows 5x. То есть из скрипта запущенного из Windows x64 нельзя сделать бутовый USB образ Windows 5x x86.

INFOHD.TBS Script от dialmak
Добавил свой скрипт INFOHD.TBS. Видит ВСЕ разделы на ВСЕХ дисках, даже если ОС их не видит. Поддерживает EMBR/MBR/GPT на шинах. SCSI,PATA,USB,ASPI,1394,SPTI,SG,SATA,eSATA,VIRT,SAA,Fibre,RAID,ISCSI,SAS,SD. В DOS среде некоторая инфа (название устройства и тип шины) в нём недоступна. В Windows среде есть полная инфа. В Linux не тестировал.

Пример простого кроссплатформенного скрипта INFOHD.TBS http://rghost.ru/43759134
Скрины в Windows из него:

Варианты запуска скриптов из Windоws можно посмотреть в ролике - Install TBOSDTS Windоws.mp4 http://forum.ru-board.com/topic.cgi?forum=62&topic=25742&start=20#9 [?]

Подробности о IFW/IFL/IFD/TBOSDT можно посмотреть в теме Миграция Windows на новое железо с помощью TeraByte OSDTOOL [?]

Дополнительная инфа в документации...

Сайт: http://forum.ru-board.com/topic.cgi?forum=5&topic=35257&start=71&limit=1&m=2#1


Как сделать заливку (сборку под себя) Win7/2008R2

 Как сделать заливку (сборку под себя) Win7/2008R2 и ничего не сломать и беспроблемно перенести и активировать на любом новом железе (проблемы с активацией будут в случаях неполного слика только - это около 5% от общего числа активаций и они легко решаются применением MBR_SLIC [?] или MAK ключём [?])

1. Ставишь VMware.
2. Ставишь на VMware Windows 7 Professional/Enterprise/Embedded POSReady/Thin PC - на вкус и цвет... Главное корпоративную - с ней меньше возни при активации на разных машинах.

VMware tools ставить нельзя (или поставить и удалить в конце работы с виртуалкой).
Снапшоты в VMware тоже не используйте!

Важно! При установке не нужно создавать зарезервированный раздел, если быть точнее, то создать его можно (он необходим только в случаях сжатия раздела или шифрования раздела Windows c помощью BitLocker™, также он нужен в случае использования NTFS c размером кластера >4k), но гемора с ним потом немного будет - прийдётся переносить на новое железо 2 раздела. Заставить винду не создавать зарезервированный раздел можно прямо через установщик - нажать Shift+F10 и просто создать и отформатировать раздел для винды в diskpart перед установкой http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=629&limit=1&m=1#1 [?] см. пункт Как создать основной активный раздел на приоритетном жёстком диске при установке Windows 7.
3. Ставишь офис.
13.02.2013. 4 пункт - устарел. Сейчас есть похожий метод, но с модификацией.
4. Активируешь офис и винду через ZWT кейген [?]. Перед запуском в брандмауэр и антивирус добавляешь исключения для него!!!
Советую активацию сделать ручками без применения всяких навороченных комбайнов и автоактиваторов. ZWT кейген лучше в виде службы не ставить.
Просто в планировщике добавить запуск его раз в неделю или месяц и принудительную активацию винды.
Задание для планировщика (с наивысшими правами) - запуск такого батника:

Код:

netsh advfirewall firewall add rule name="ZWT keygen" dir=in action=allow protocol=TCP localport=1688 открываем в брандмауэре порт 1688
start /D "%SYSTEMROOT%" ZWT_keygen.exe запуск ZWT кейгена (предполагается, что он находится в папке Windows)
timeout /T 1 /NOBREAK пауза 1 сек
"%SYSTEMROOT%\system32\cscript.exe" "%SYSTEMROOT%\system32\slmgr.vbs" /ato принудительная активация винды
timeout /T 1 /NOBREAK пауза 1 сек
"%SYSTEMROOT%\system32\cscript.exe" "%PROGRAMFILES%\Microsoft Office\Office14\ospp.vbs" /act принудительная активация офиса (для 32 битного офиса на 64 битной винде нужно использовать %PROGRAMFILES(x86)%)
taskkill /F /IM "ZWT_keygen.exe" удаление процесса уже ненужного ZWT кейгена
netsh advfirewall firewall delete rule name="ZWT keygen" закрываем в брандмауэре порт 1688

Есть ещё одна маловидимая, но в реальности очень важная деталь. Запуск задания планировщика можно настроить от имени любого пользователя. А значит и SYSTEM. То есть ZWT keygen будет запускается от имени системы. Я заметил, что в этом варианте ошибки при активации вида 0x8007000D [?] практически не появляются (хотя в последнее время было мало практики на кошках - работа заела, будет со временем видно ... пока хз). В любом случае это комфильнее, чем служба по моему мнению.
У кого проблема с работой в планировщике заданий - пишите в личку. Вышлю файл для импорта.
Впрочем хозяин барин - можно и службу.

Если хочется поставить что-то из редакций Starter/HomeBasic/HomePremiun/Ultimate, то активировать её прийдётся уже на новом железе. Перенос на новое железо активированной лоадерами ОС в 70% случаев закончится неудачей...

5. Обновляешь винду и офис, доставляешь нужное ПО. Если что-то доставилось из антивирусов и брандмауэров, то не забываем добавить исключения для ZWT кейгена!!! Никакие твикеры ОС не не ставь - сломать OC легко. В конце не лишним будет сделать дефрагментацию раздела с ОС.
6. Всё готово. Теперь нужно подготовить винду к всеядности - то есть чтобы её можно было грузить на любом железе.
И тут появляется несколько вариантов. Поэтому для начала выключаешь виртуалку и делаешь копию виртуального диска - файла .vmdk. Эта копия пригодится потом.

1 вариант. Выключаешь виртуалку и используешь программу TBOSDTS - вернее один скрипт из неё OSDTOOL.TBS Script.
Краткое описание скрипта и видео тут http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=1370&limit=1&m=1#1 [?].
Для подготовки Win7/2008R2 к заливке в скрипте нужно выполнить только 1 пункт:
Remove installed drivers -> Remove all installed drivers except IDE/AHCI drivers.
Всё. ОС готова к переносу на новое железо. Как запустить OSDTOOL.TBS Script и заставить всё это сделать на виртуальном диске-файле .vmdk я напишу ниже.

2 вариант. Включаешь виртуалку и используешь сиспреп. Эта утилита обезличивает винду и подготавливает её для возможности переноса на любое железо. Стандартная MS утилита.
Запуск из cmd от имени админа.

Код:

C:\Windows\System32\Sysprep\Sysprep.exe /oobe /generalize /shutdown

Подробнее - можешь почитать пункт Клонирование Windows 7/Vista/Server2008 http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=0&limit=1&m=6#1 [?].
Утилита сиспреп отработает и выключит виртуальную машину. Её теперь включать нельзя пока не снимешь архив или образ раздела с виндой.
При запуске Sysprep\Sysprep.exe получим графическую версию сиспреп.

Оба варианта приводят почти к одному и тому же результату при загрузке ОС на новом железе. Хотя есть и различия. Мне с OSDTOOL.TBS более комфортно (сиспреп сбивает некоторые настройки юзера и заставит добавить ещё одного нового юзера, хотя нового юзера можно потом удалить). Описывать все нюансы облом - лучше один раз увидеть. Поэтому на копию .vmdk можешь натравить OSDTOOL.TBS, а на исходник .vmdk сиспреп. Достаточно поставить один раз на комп и первый и второй вариант и поймёшь, что лучше конкретно тебе и что комфортнее.

Итак винда подготовлена. Осталась одна проблема. Она у нас на виртуальном диске и её как то нужно перенести на другую машину на физический диск. Можно подключить .vmdk к физическому диску - это возможно сделать прямо в VMware в свойствах виртуального диска - (очень плохой вариант! практика показала, что толку от него не будет! поэтому только через IFW/IFL/IFD!).

1. Можно закатать раздел с виндой в файл WIM (например загрузив LiveCD с утилитой gimagex или imagex и там сделать .wim) и потом заменить им в дистре 7/2008R2 DVD файл install.wim. И потом можно будет ставить этот DVD как стандартный дистр 7/2008R2. Хотя это уже будет сборка.

Можно также wim сделать из среды восстановления http://www.outsidethebox.ms/9951/#imagex. Но всё это долго и неоптимально и к тому же есть ограничения в использовании.

Внимание! Размер образа install.wim, включаемого в состав установочного диска 32-разрядной операционной системы, не должен превышать 4 Гб (2^32 байт). В противном случае установка завершится с ошибкой. Это ограничение не распространяется на развертывание образа с помощью утилиты imagex.

Поэтому проще сделать архив раздела с виндой и раскатывать этот архив на голую машину или ещё проще поставить эту заливку по сети.

2. Помогут в этом утилиты IFW/IFD/IFL/BootIt BM.
IFW 2.65b http://forum.ru-board.com/topic.cgi?forum=35&bm=1&topic=11112&start=160#lt [?] можно установить в основную винду (в которой работает виртуальная машина) и что самое замечательное, что IFW умеет архивировать (создавать бэкап) виртуальных дисков .vmdk и .vhd. Этот бэкап затем можно восстановить уже на реальном физическом диске. Она также умеет работать с сетью и может скопировать виртуальный диск в физический. Ещё более замечательно, что в составе ретайл версии IFW включена программа TBOSDTS с скриптом OSDTOOL.TBS Script. То есть всё в одном месте. Есть один правда минус - загрузочная версия IFW довольно громоздка (около 170 МБ). Если точнее, это я указал размер не IFW, а LiveCD WinPE с IFW.

Недостаток IFW компенсируется программой IFL_GUI 2.68 http://forum.ru-board.com/topic.cgi?forum=35&bm=1&topic=15688&start=80#lt [?]. Она имеет все те же функции, что и IFW (в том числе имеет на борту OSDTOOL.TBS Script) плюс малого размера и мобильна - дистрибутив её позволяет создать загрузочную флешку c IFL_GUI (через утилиту makedisk.exe) и на ту же флешку можно скинуть бэкап нашей заливки и затем развернуть бэкап. Доступно также развёртывание бэкапа по сети и копирование виртуальных дисков в физичекие.

Отдельно TBOSDTS с скриптами можно взять здесь - win (без IFW) и дос версия, в дос версию включен IFD_GUI (с сетью он не работает) http://www.box.com/s/qziqdgcsu2p9n5u92r2m.

Последний важный момент! После загрузки винды на новом железе нужно проверить два параметра:
- Включена или выключена служба восстановления. Пуск -> правой кнопкой мыши на Компьютер -> Свойства -> Защита системы -> Настроить. Если выключена, то лучше включить и задать размер для неё около 3-7 % объёма раздела.
- Включен или выключен файл подкачки. Пуск -> правой кнопкой мыши на Компьютер -> Свойства -> Дополнительные параметры системы -> Быстродействие-Параметры -> Дополнительно -> Виртуальная память -> Изменить. Если она выключена, то её следует включить или в режим Автоматически выбирать объём файла подкачки или вручную ввести размер в пункт Указать размер - обычно хватает дать около двух размеров ОЗУ/RAM.

P.S. Активация этой сборки на новом железе - это запуск задачи из планировщика автоматически или если не терпится - вручную.
P.P.S. Иногда на нестандартной конфигурации железа необходимо подсунуть какие-то драйвера, например RAID/AHCI/SCSI. Это можно сделать через OSDTOOL применительно к уже развёрнутой на новом HDD ОС, если драйвера расположить, например, на флешке или другом носителе.
Плюс у OSDTOOL есть возможность включить при загрузке на новом железе тучу предустановленных драйверов RAID/AHCI/SCSI из Windows 7/8 (они находятся в папке C:\Windows\System32\DriverStore\FileRepository). Доступ к ним в меню:
Install Drivers -> Install Windows provided storage drivers.

P.P.P.S. При установке Win7x86 на eee PC столкнулся с проблемой. Ни сборка препарированная OSDTOOL ни сборка после сиспреп не захотела ставиться. Проблема оказалась в HAL. Пришлось через OSDTOOL его менять. Но решить раз и навсегда эту проблему можно довольно просто. Достаточно добавить,ещё перед работой OSDTOOL или сиспрепа естественно, в BCD строчку detecthal on.

Внимание! Насколько мне известно, в Win7x64 только один HAL. Поэтому всё нижеописанное относится только к Win7x86.

Вначале в cmd от имени админа нужно дать команду для просмотра GUID.

Код:

bcdedit /v

Затем включить detecthal.

Код:

bcdedit /set GUID detecthal on

Вместо GUID нужно подставить свой идентификатор раздела - в данном случае на картинке выше {92dc0932-f1af-11e0-a2d2-001fd0d6fb2f}
И в конце проверить изменение

Код:

bcdedit /v

Ссылки по теме
http://forum.ru-board.com/topic.cgi?forum=35&topic=47389&start=1538&limit=1&m=1#1 [?]
 http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=820#18 [?]
 http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=1261&limit=1&m=1#1 [?]
 http://forum.ru-board.com/topic.cgi?forum=5&bm=1&topic=35257&start=0 [?]
 http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=1760#5 [?]
 http://forum.ru-board.com/topic.cgi?forum=27&topic=13070&start=1060#14 [?]
 http://forum.ru-board.com/topic.cgi?forum=27&topic=13070&start=1060#19 [?]
 http://forum.ru-board.com/topic.cgi?forum=27&topic=13070&start=1040#19 [?]
TBOSDTS, IFW, IFL, IFD, BootIt BM включены в известный LiveCD/DVD RusLive by NIKZZZZ [?].

Удачи!

Сайт: http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=1783&limit=1&m=1#1


Как сделать заливку (сборку под себя) WinXP

Основная задача - создать универсальный образ для разворачивания в офисе на компьютерах с самым разным железом с легальной системой Windows XP Home (настроенную и со всеми программами).

Поготовка
1. Поставить XP на виртуалку.
2. Поставить все нужные проги.
3. Очистить корзину, лишние точки восстановления и сделать дефрагментацию (всё остальное удалит sysprep).
4. Сделать sysprep и выключиться.
5. Сделать копию жёсткого диска виртуалки (её будем редактировать для нового железа).

Установка на другое железо
1. Посмотреть что за железо через любой LiveCD.
2. Подготовить драйвера SATA и слить их на флешку (если нужно, хотя для большинства случаев достаточно Intel и ATI подготовить зараннее).
3. Загрузиться через CD или флешку [?] в Image for Linux (на новом железе).
4. Выбрать пункт OSD Tool Script и указать ему путь к виртуальному жёсткому диску (можно на CD/DVD/BD, можно на флешке, можно на HDD, можно по сети - естественно настроить предварительно сеть в меню Network Configuration, если нет DHCP, и выбрать шару в меню Mount Network Shares).
5. Поставить/удалить драйвера, выбрать hal и т.д.
6. Сделать имидж и развернуть имидж через пункт Image for Linux на физический HDD.

Всё то же можно проделать и с физическим диском. То есть поменяются местами пункты 5 и 6 с 4.
Установка на другое железо с предварительным разворачиванием образа
1. Посмотреть что за железо через любой LiveCD.
2. Подготовить драйвера SATA и слить их на флешку (если нужно, хотя для большинства случаев достаточно Intel и ATI подготовить зараннее).
3. Загрузиться через CD или флешку [?] в Image for Linux (на новом железе).
4. Сделать имидж виртуального жёсткого диска и развернуть имидж через пункт Image for Linux на физический HDD.
5. Выбрать пункт OSD Tool Script и указать ему путь реального физического HDD.
6. Поставить/удалить драйвера, выбрать hal и т.д.

Как последний вариант подготовку ОС и установку прог можно делать и на реальном железе. Снять потом образ через самозагружаемый диск или флешку IFD, IFL или IFW и далее развернуть образ и выполнить OSD Tool Script.

Сделать имидж и развернуть имидж XP (около 1,5 Gb) через IFL занимает у меня 2 минуты (минута бэкап и минута восстановление). Сам имидж занимает около 800 Mb места.
Достаточно удалить CPU драйвер (хотя я удаляю обычно ВСЕ драйвера кроме IDE/AHCI) и поставить стандартный IDE (для SATA AHCI/RAID внешние из флешки) и можно пробовать грузить свежеиcпечённую XP. Огромный плюс, что все действия бэкапируются в OSD Tool Script и вернуться назад нет проблем. Так что экспериментировать можно до упора.
Также можно использовать OSD Tool Script для случая переключения в BIOS IDE на AHCI в уже установленной XP.
Если не важны SIDы и другие админовские заморочки, то sysprep необязателен, хотя с ним корректнее по-моему и правильней (особенно, если поставлена галочка mini установки). Всякие трудности типа номер вводить и т.д. ленивые могут решить автоматом через создание Sysprep.inf.

Если sysprep не используется, а драйвера SATA будут ставиться, то после первой загрузки начнётся выполнение скрипта OSD Tool Script и установка драйвера, затем перегрузка и вот здесь желательно нажать F8 и один раз загрузиться в безопасном режиме (будут определяться устройства и ставиться другие драйвера). Затем после ещё одной перегрузки - можно грузиться в нормальном режиме.

И последнее.
Желательно перед sysprep сделать бэкап (для виртуалки просто копию виртуального диска сделать, для физ. диска сделать имидж и кинуть на другой раздел). Потому что если захочется подправить образ, то заметил, что после sysprep повторный sysprep некорректно работает. Поэтому восстановить - подправить, бэкапнуть опять и можно делать sysprep.

Всё вышеописанное подходит и для Win2003/Vista/7/2008/2008R2. Для желающих делать свои скрипты OSD Tool Script Pro 1.29 отдельно c документацией можно взять здесь.
Для желающих поставить любую винду на флешку доступен скрипт USBBoot TBS script to enable booting XP from a USB drive на офсайте http://www.terabyteunlimited.com/tbosdt.htm
Дополнительные скрипты и скрины можно посмотреть здесь http://forum.ru-board.com/topic.cgi?forum=62&topic=18466&start=1220#13 [?]

Сайт: http://forum.ru-board.com/topic.cgi?forum=27&topic=13070&start=880#14


Перенос системы на другую материнскую плату или клонирование Windows XP
[Make universal image Windows XP]

Зачем всё это нужно?
Начнем с первой части темы, а это перенос системы, т.е. если вам понадобилось сменить материнскую плату, но хочется сохранить систему без перестановки. И если просто подключить жесткий диск с ОС, у вас скорей всего будет BSOD, либо возникнут различные конфликты драйверов и оборудования. Значит необходимо провести некоторые манипуляции над ОС о которых напишу ниже.
Второе, хочется создать настроенный образ ОС с нужным ПО, который можно было бы устанавливать на различном железе, с минимальными затратами времени на его разворачивание(заливку).
В интернету полно инструкций по данной теме, но ничего актуального, простого, и понятного я не нашел, поэтому решил пойти своим путем, используя, конечно же, опыт и наработки других людей, и специализированный софт.
С целью определились, идем дальше.

Что нам потребуется сделать, чтобы ОС удачно запустилась?
 Если просто требуется перенести систему на другое железо:
1. Подчистить систему, чем чище система - тем лучше.
2. Удалить уникальные драйверы используемых устройств.
3. Перенести систему на другое железо.
4. Импортировать уникальный драйвер контроллера дисков, если требуется.
5. Загрузиться на новом железе.
6. Установить остальные драйвера стандартным путем.

Если требуется создать универсальную заливку (пп.3-7 такие же):
1. Отключить все лишние устройства, чем меньше устройств - тем лучше.
2. Установить ОС, софт, и пр (дрова не ставим). Активировать и обновить систему, если нужно.
3. Удалить уникальные драйверы используемых устройств.
4. Перенести систему на другое железо.
5. Импортировать уникальный драйвер контроллера дисков, если требуется.
6. Загрузиться на новом железе.
7. Установить остальные драйвера стандартным путем.

Что для этого потребуется?
1. Удалялка драйверов - TeraByte OS Deployment Tool Suite.
2. WinPE с MassStorage драйверами - Hiren's BootCD.
3. Вставлялка SATA/AHCI/RAID драйвера - FixHDC (в Hiren's BootCD присутствует).
4. Снятие и перенос образа диска (системы) - IFW (в Hiren's BootCD присутствует), можно любое, если вам в нем удобней работать.
5. Виртуальная машина для создания заливки - VMWare Workstation, можно VirtualBox и пр.

Почему я выбрал именно эти программы, а не другие?

  • 1. ПО для просмотра установленных драйверов. Думаю понятно, чем меньше драйверов уникальных устройств остается в системе, которую вы собрались переносить, тем лучше, тем будет меньше конфликтов, различных ошибок и сбоев. Для того чтобы узнать какие драйвера сейчас находятся в системе, использовалась программа от компании NirSoft - DevManView - альтернативный менеджер устройств в Windows, позволяет увидеть список установленный драйверов в табличном понятном виде, может быть запущена из другой ОС. Все результаты моих тестов созданы с помощью этой программы. Альтернативы не нашел.
  • 2. ПО для удаления установленных драйверов. Для удаления драйверов были испробованы 2 утилиты. DevCon от компании Microsoft, и OS Deployment Tool от компании TeraByte.
    DevCon - представляет собой консольную утилиту, для работы устройствами и драйверами, в том числе умеет удалять драйвера. С ее помощью, запустив ее с параметром remove (    devcon remove * - для удаления всех устройств), можно удалить драйвера из системы. Но она как оказалась делает это не достаточно хорошо...
    Изначально в установленной системе было 193 драйвера (или 103 PnP).
    После отработки DevCon количество драйверов снизилось до 97 (или 36 PnP), но в ней все еще остались драйвера дисковода гибких и оптических дисков, и других устройств, что не есть хорошо.
    OS Deployment Tool - одна коммерческая утилита, тоже предназначена для удаления драйверов, и не только, но в отличии от DevCon удаляет гораздо больше драйверов, и может удалять драйвера без запуска самой ОС.
    Результат ее работы следующий:
    Изначально в установленной системе было 190 драйвера (или 100 PnP).
    После применения OSD Tool стало 47 драйверов (или 15 PnP). Как вы можете видеть остались только стандартные драйвера, общие для всех конфигураций.
    Вывод: OSD Tool работает гораздо лучше DevCon, но он распространяется на платной основе, если для вас это проблема можете использовать DevCon, работать будет, я же буду использовать OSD Tool.
  • 3. ПО для добавления новых драйверов. Перед запуском ОС на новом железе необходимо добавить драйвер контроллера дисков, иначе можете лицезреть BSOD 0x0000007b, и загрузиться не удастся. Если на старых компьютерах было достаточно переключиться на "Стандартный IDE ATA/ATAPI контроллер" и загрузится на новой конфигурации, то новые компьютеры требуют уникальных SATA/AHCI/Raid драйверов. Но зато на новых компах нету заморочек с HAL'ом. Достаточно выбрать "Однопроцессорный компьютер с ACPI", ACPI APIC UP HAL (Halaacpi.dll) и в случае чего Windows сама поменяет его на "Многопроцессорный компьютер с ACPI", ACPI APIC MP HAL (Halmacpi.dll).
    Итак, задача ясна, какие же существуют утилиты для ее решения.
    Многие наверно слышали про Acronis Universal Restore и Paragon Adaptive Restore (P2P). Но я не рекомендую их использовать для переноса ОС на новую конфигурацию, по разным причинам которые требуют написания целой статьи. Скажу, что используемый мною способ намного лучше и проще.
    OS Deployment Tool позволяет добавить драйвер контроллера, но он мне не нравится потому, что нужно точно знать какой драйвер нужен для данного ПК, и иметь базу для каждого контроллера в отдельности или каждый раз лезть в интернет и скачивать нужный, хотя кончено их не так уж и много, но все равно данная программа требует достаточно много телодвижений для добавления драйвера. Есть способ попроще, а именно:
    FixHDC - является плагином к BartPE, и запускается соответственно из нее. Присутствует на диске Hiren's BootCD. Может добавить уникальный драйвер для контроллера, буквально в 2 щелчка, если запустилась BartPE.
    Еще для добавления MassStorage-драйвера существуют следующие программы и способы:
    OfflineSysPrep, DriverInjection, DriverPacks with Sysprep HOWTO, Набор инструментов для клонирования (развертывание из образа) Windows XP, или вручную добавлять и править реестр.
    Если у вас получилось запуститься через один из выше перечисленных способов, и он существенно лучше моего, то буду рад, если вы поведаете мне о нем подробней.
    Вывод: будет использоваться FixHDC.
  • 4. ПО для снятия и переноса образа системы. Для этих целей существует довольно много софта от разных производителей. У каждого свои плюсы и минусы. Приведу основные из них: Acronis Software, Norton Ghost (Symantec) TeraByte Image for DOS/Windows/Linux, Paragon Software, Clonezilla, EaseUS Todo Backup, DriveImage XML, Miray HDClone, Macrium Reflect. Наиболее полный список ПО для клонирования можете посмотреть на Википедии. Какой будете использовать, решать вам, я же буду использовать Image for Linux.
  • 5. Виртуальная машина, или эмулятор компьютера, или реальный компьютер. Microsoft Virtual PC, QEMU, VirtualBox, VMware Workstation.
    Мне удобней устанавливать и тестировать ОС на виртуальной машине VMware Workstation

    Последовательность действий по клонированию Windows XP

    Часть 1. Установка ОС на виртуальную машину VMWare Workstation

    1. Запускаем VMWare Workstation.
    Примечание: используемая версия VMWare Workstation 7.0.1 build-227600.
    2. Создаем новую виртуальную машину (Ctrl+N). Выбираем "Typical".

    3. Выбираем "I will install operation system later".

    4. Выбираем "Other" - "Other".
    ВАЖНО! Иначе придется удалять WMware Tools.

    5. Выбираем имя.

    6. Выбираем размер жесткого диска в виртуальной машине.
    Примечание: Много лучше не ставить, и мало не стоит делать. 8-12 ГБ более чем достаточно.

    7. Смотрим что получилось:

    8. Жмем "Customize Hardware" для изменения размера ОЗУ, и конфигурирования других устройств.

    9. В строке "New CD/DVD (IDE)" выбираем ISO образ устанавливаемой системы, или дисковод с которого должна устанавливаться система.

    10. Жмем "Finish".
    11. Запускаем виртуальную машину зеленой стрелкой VMWare наверху.
    Возможна следующая ситуация. Вы настроили загрузку с ISO, но при запуске виртуальной машины не появляется надпись "Press any key to boot from CD...", и машина не загружается с CD. В таком случае надо выставить загрузку с CD-ROM в BIOS, точно также как на обычной машине. Перезапустите виртуальную машину и нажмите F2. Вы должны войти в настройки BIOS виртуальной машины, которые выглядят примерно так:
    VMWare

    Используйте стрелки Вправо/Влево на клавиатуре, чтобы перейти в меню Boot
    VMWare

    Используйте стрелки Вверх/Вниз на клавиатуре, чтобы выбрать CD-ROM, а затем жмите на клавишу "+" до тех пор, пока CD-ROM не окажется в списке над Hard Drive.
    VMWare

    Теперь при помощи стрелок Вправо/Влево выберите меню Exit, затем выделите "Exit Saving Changes" и жмите Enter. Подтвердите запрос на изменение настроек, и виртуальная машина перезагрузится с новыми настройками.
    Использован материал oszone.net.
    12. Устанавливаем систему, софт.
    Не ставим драйвера, антивирусы, DaemonTools'ы, и Алкоголи - они ставят свои драйвера в систему, и скорей всего не будут работать, после переноса и удаления всех драйверов.
    Не используем "Снапшоты"(Snapshots), т.к. нам нужен целый, не разбитый на части виртуальный диск.

    Часть 2. Удаление драйверов с помощью OS Deployment Tool

    1. Запускаем TeraByte OS Deployment Tool Suite и выбираем OSDTOOL.TBS.
    Если нету, можете взять здесь.
    (Извлекаем на диск С, и запускаем с помощью ярлыка).
    2. Выбираем "Virtual Drive" ищем файл жесткого диска (.vmdk) для созданной виртуальной машины, или выбираем "Physical Drive", если Windows находится на физ.диске.

    3. Выбираем установленную ОС.

    4. Проверяем правильно ли выбрали. Жмем Enter.
    5. Выбираем "Remove installed drivers".

    6. Выбираем "Remove all installed drivers".

    7. Соглашаемся с предупреждением. Жмем "Continue".

    8. Дожидаемся успешного завершения. Жмем Enter.

    9. Выходим в главное меню. Выбираем "Ghange HAL":

    10. Смотрим. Должен стоять halaacpi.dll. Если нет - меняем.
    Примечание: в довольно редких случаях, например на очень древнем железе, требуется другой HAL, и если у вас не получается загрузить систему, нужно попробовать изменить HAL на другой, до тех пор пока не заработает.

    11. Если есть подготовленные драйвера (файлы .inf и .sys) можете установить их, с помощью OSDTool, если нет - идем дальше. Подробнее, используя скрипты, описал в этой статье.
    Дальше, не запуская системы, нужно снять ее образ и развернуть на другом HDD, я буду использовать Image for Windows из Hiren's BootCD.
    Примечание: Так же вы можете запустить OSDTool из загрузочной версии Image For Linux.

    Часть 3. Перенос на другой жесткий диск с помощью Image for Window

    IFW может перенести всю информацию с виртуального диска на физический, значит нам не понадобиться снимать образ системы, следует всего лишь скопировать на внешний носитель файл виртуального диска (.vmdk).
    Примечание: если у вас недостаточно места на внешнем носителе, можете все же снять образ, тогда места потребуется меньше.

    1. Копируем виртуальный диск (.vmdk) на внешний носитель.
    2. Подключаемся к новому железу и загружаем WinPE из Hiren's BootCD.
    Если нету, можете взять здесь. Отдельно IFW2.68 - здесь.
    3. Запускаем IFW. Меню HBCD -> Programs -> Backup -> Image for Windows.

    4. В окне IFW выбираем "Copy".

    5. Ставим галочку на "Virtual Drives". Нажимаем "Add Virtual Drive". Прописываем путь до виртуального диска.

    6. Выбираем что будем восстанавливать, раздел или полностью диск. Я выбрал диск.
    Примечание: если требуется сохранить разметку (другие разделы) на диске-приемнике, то нужно выбирать раздел.
    7. Выбираем куда восстанавливать.
    8. Выбираем параметры восстановления.
    Примечание: Подробности можете узнать в документации.

    9. Жмем Next. Проверяем параметры восстановления. Ждем когда закончится процесс переноса.
    10. Выходим из IFW.
    11. Проверяем правильно ли восстановилось. Смотрим какой активный раздел, код MBR, PBR, редактируем boot.ini если требуется.
    Примечание: BootICE и блокнот в помощь.

    Часть 4. Установка драйвера контроллера дисков с помощью FixHDC

    1. Загружаем WinPE с диска Hiren's BootCD.
    Если нету, можете взять здесь. Отдельно FixHDC0.02 - здесь.
    2. Запускаем FixHDC. Меню HBCD -> Programs -> Registry -> Fix hard disk controller (fix_hdc.cmd).

    3. Выбираем папку назначения (C:\Windows). Жмем "T".

    4. Жмем "М" для обновления MassStorage драйвера.

    5. Всё драйвер добавлен. Можно закрывать и загружаться в основную систему, и устанавливать остальные драйвера.

    • Сайт: http://gromr1.blogspot.ru/2012/02/windows-xp-make-universal-image-windows.html


Инструкция по созданию универсального образа WinXP SP3
Инструкция по созданию универсального образа системного раздела

Подготовка образа на реальном железе
Для создания образа используем активный/загрузочный раздел не менее 7Гб и второй раздел не менее 3Гб.
Устанавливаем Windows + Update (к примеру сборку Microsoft Windows XP Professional SP3 VL), Office + Update (по желанию), Soft.
Интегрируем по желанию необходимые AHCI драйвера. Если была произведена интеграция AHCI драйверов, тогда скопируйте на Рабочий стол файлы DisSata.exe, DevicePath.reg.
Отключаем восстановление системы. Запускаем CCleaner производим очистку системы от мусора.
Не устанавливаем драйвера.
Не устанавливаем Alcohol и т.п.
Не подключаем виртуальные CD-Rom-ы.
Отключаем все лишние устройства.
В BIOS отключаем все onboard устройства (звук, сеть, usb и др.).

Д алее загружаемся с LiveCD
Удаляем C:\System Volume Information\. Запускаем CCleaner производим очистку системы от мусора. Выполняем п.11.
Перегружаемся.

1. Установка драйвера IDE-контроллера - "Стандартный двухканальный контроллер PCI IDE"
Если уже стоит такой драйвер, тогда пропускаем.
Панель управления -> Система -> Оборудование -> Диспетчер устройств -> IDE ATA/ATAPI контроллеры -> правой кнопкой по установленному IDE-контроллеру (например - Intel(R) 82801EB Ultra ATA Storage контроллеры - 24DB) -> Обновить драйвер -> Нет, не в этот раз -> Установка из указанного места -> Не выполнять поиск. Я сам выберу нужный драйвер -> Стандартный двухканальный контроллер PCI IDE -> Далее -> Готово!
Перегружаемся.

2. Установка драйвера (HAL) - "Стандартный компьютер"
Если уже стоит такой драйвер, тогда пропускаем.
Панель управления -> Система -> Оборудование -> Диспетчер устройств -> Компьютер -> правой кнопкой по установленному драйверу HAL (например - Однопроцессорный компьютер с ACPI) -> Обновить драйвер -> Нет, не в этот раз -> Установка из указанного места -> Не выполнять поиск. Я сам выберу нужный драйвер -> Стандартный компьютер -> Далее -> Готово!
Не даем компьютеру перегрузиться.

3. Выполняем действия по установке семи файлов
1.HAL-SP3.exe - помещает оригинальные необходимые файлы халов и кернелов SP3RU в %WinDir%\system32\
2.Dtecthal.exe - помещает dtecthal.inf в %windir%\inf
3.С.exe - меняет boot.ini и ntldr
4.IDEdrivers.exe - добавляет драйверы необходимые для MergeIDE.reg
5.Setup.exe - помещает в автозагрузку файл запуска замены стандартными boot.ini и ntldr
6.Back_del.exe - помещает в WINDIR файл удаления из автозагрузки
7.Original.exe - копирует оригинальные файлы из дистриба в %windir%\system32\dllcache

4. Импортируем файл реестра CLONNING_and_MergeIDE.reg

5. Проверяем не остался ли Microsoft ACPI-Compliant System
Если остался - удаляем.
Панель управления -> Система -> Оборудование -> Диспетчер устройств -> Системные устройства -> правой кнопкой по Microsoft ACPI-совместимая система -> Удалить.
Не даем компьютеру перегрузиться.

6. Запускаем файл Reset-Hardware.exe для удаления устройств
Это батник зашитый в sfx на основе DEVCON.EXE.

7. Запускаем CCleaner и производим очистку системы от мусора.

8. Включаем восстановление системы на диске C, автоматически создается стартовая точка отката. Дефрагментируемся.

Д алее загружаемся с LiveCD

9. Удаляем разделы реестра (ключи HAL)
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\ACPI_HAL
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\ACPI_HAL
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\ACPI_HAL
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\Root\ACPI_HAL

10. Запускаем CCleaner и производим очистку системы от мусора. Выполняем п.11.

11. Удаляем мусор
Очистить C:\WINDOWS\system32\dllcache\
Очистить С:\WINDOWS\Installer\
Очистить C:\WINDOWS\Prefetch\
Очистить C:\WINDOWS\Temp\
Очистить C:\Documents and Settings\<user>\Local Settings\Temp\
Очистить C:\Documents and Settings\<user>\Local Settings\Temporary Internet Files\
Очистить C:\Documents and Settings\<user>\Local Settings\History\
Очистить C:\Documents and Settings\<user>\Cookies\
Очистить C:\Documents and Settings\<user>\NetHood\
Очистить C:\Documents and Settings\<user>\Recent\
Очистить C:\RECYCLER\
Удалить C:\WINDOWS\Windows Update.log (при обращении на WindowsUpdate в логе пишется дата и версия BIOS)
Удалить C:\pagefile.sys
Категорически не рекомендуется удалять папки оставшиеся после установки Update и Office.

12. Создаем образ!!!

ВНИМАНИЕ!!! ВАЖНО: Если нужно развернуть систему на винчестер подключенный к контроллеру требующему установки драйверов на ранней стадии установки Windows (нажмите F6 для установки...) то есть способ решения и этой проблемы. Делаем следующее:
Подрубаем винт к контроллеру не требующему драйверов, развертываем на него систему и ставим Windows-драйвера для того контроллера к которому подключен винт на который нам необходимо развернуть систему. Теперь эту ОС можно спокойно копировать на винт подключенный к проблемному контроллеру. После копирования, возможно, потребуется установить драйвера для него (контроллера) ещё раз.

Сайт: http://forum.ru-board.com/topic.cgi?forum=55&topic=6444
Сайт: http://forum.ru-board.com/topic.cgi?forum=27&topic=13070
Сайт: http://forum.ru-board.com/topic.cgi?forum=62&topic=25742
Сайт: http://v398.do.am/load/instrukcija/instrukcija_po_sozdaniju_universalnogo_obraza_windows_xp_sp3/6-1-0-10


Windows 7 Pro SP1 Acronis x86
MyBackup_ALL_Win7_Pro_x86.tib - "Образ Win7 Pro SP1"

Стадия разработки: Release
Дата выпуска: 2011
Версия: 6.5
Разрядность: 32bit
Язык интерфейса: Русский
Таблэтка: Не требуется

Системные требования:
Процессор: от 1 GHz
Оперативная память: от 1 Gb
Свободное место: от 16 Gb
Рекомендуемое разрешение экрана: 800x600 и выше.

Универсальный образ системного раздела для восстановления на любой компьютер, вне зависимости от того, какое оборудование в нем установлено. Содержит только критические обновления. Полностью автоматическая установка и активация, у программы установки нет никаких вопросов. Быстрая установка операционной системы с помощью образа Acronis. Образ подготовлен в True Image Echo Workstation 9.7 [8.206].

Этот файл-образ с установленной cистемой Win7 SP1 можно спокойно копировать на винчестер и затем можно будет развернуть на любом железе, при помощи загрузочного диска, созданного Acronis True Image. Возможно потребуется (заново) установить драйвера для контроллера материнской платы, которые есть в Вашем CD-диске (идущем в комлекте с материнской платой) или в дистрибутиве установленной операционной системы.

Установка:
1. Разворачиваем образ tib с помощью True Image Echo Enterprise Server на жесткий диск.
2. Загружаемся первый раз и ожидаем приглашения на перезагрузку и соответствено перезагружаемся. Если система отказывается загружаться, то пробуем загрузится через Safe Mode (кнопка F8).
3. Проверяем установленное оборудование и устанавливаем необходимые драйвера.

Внимание:
1. На ноутбуках часто бывает первый скрытый аварийный раздел для восстановления системы, перед восстановлением образа его нужно удалить, т.к. по умолчанию загрузка прописана на первый раздел.
2. Windows 7 при чистой установке, с нуля, создаёт раздел объёмом 100 Mb, он остаётся скрытым и зарезервирован операционной системой. На нём находятся файлы загрузки операционной системы Win7, перед восстановлением образа его нужно удалить.

Изменения:
- Пакет обновления SP1.1.
- Критические обновления до 11.06.2011.
- Автоматический механизм активации.
- Учетная запись "Admin".
- По умолчанию русская раскладка клавиатуры.
- Контроль учетных записей отключен.
- В операционной системе ничего не урезано.
- В интерфейсе изменений нет.
- Образ можно развернуть через True Image Echo Enterprise Server/Workstation 9.7 [8.206].

Отключены:
- Контроль учетных записей.
- Брандмауер Windows.
- Автоматические обновления.


Windows 7 Pro Acronis x64
MyBackup_ALL_Win7_Pro_x64.tib - "Образ Win7 Pro"

Стадия разработки: Release
Дата выпуска: 2010
Версия: 6.3
Разрядность: 64bit
Язык интерфейса: Русский
Таблэтка: Не требуется

Системные требования:
Процессор: от 1 GHz
Оперативная память: от 1 Gb
Свободное место: от 16 Gb
Рекомендуемое разрешение экрана: 800x600 и выше.

Универсальный образ системного раздела для восстановления на любой компьютер, вне зависимости от того, какое оборудование в нем установлено. Содержит только критические обновления. Полностью автоматическая установка и активация, у программы установки нет никаких вопросов. Быстрая установка операционной системы с помощью образа Acronis. Образ подготовлен в True Image Echo Workstation 9.7 [8.206].

Этот файл-образ с установленной cистемой Win7 можно спокойно копировать на винчестер и затем можно будет развернуть на любом железе, при помощи загрузочного диска, созданного Acronis True Image. Возможно потребуется (заново) установить драйвера для контроллера материнской платы, которые есть в Вашем CD-диске (идущем в комлекте с материнской платой) или в дистрибутиве установленной операционной системы.

Установка:
1. Разворачиваем образ tib с помощью True Image Echo Enterprise Server на жесткий диск.
2. Загружаемся первый раз и ожидаем приглашения на перезагрузку и соответствено перезагружаемся. Если система отказывается загружаться, то пробуем загрузится через Safe Mode (кнопка F8).
3. Проверяем установленное оборудование и устанавливаем необходимые драйвера.

Внимание:
1. На ноутбуках часто бывает первый скрытый аварийный раздел для восстановления системы, перед восстановлением образа его нужно удалить, т.к. по умолчанию загрузка прописана на первый раздел.
2. Windows 7 при чистой установке, с нуля, создаёт раздел объёмом 100 Mb, он остаётся скрытым и зарезервирован операционной системой. На нём находятся файлы загрузки операционной системы Win7, перед восстановлением образа его нужно удалить.

Изменения:
- Критические обновления до 16.07.2010.
- Автоматический механизм активации.
- Учетная запись "Администратор".
- По умолчанию русская раскладка клавиатуры.
- Контроль учетных записей отключен.
- В операционной системе ничего не урезано.
- В интерфейсе изменений нет.
- Образ можно развернуть через True Image Echo Enterprise Server/Workstation 9.7 [8.206].

Отключены:
- Контроль учетных записей.
- Брандмауер Windows.
- Автоматические обновления.


Windows XP Pro SP3 Acronis

Windows XP Pro SP3 Acronis x86
 MyBackup_ALL_WinXP_Pro.tib - "Образ WinXP Pro SP3"
MyBackup_ALL_WinXP_Pro_AHCI.tib - "Образ WinXP Pro SP3 + AHCI"

Стадия разработки: Release
Дата выпуска: 2013
Версия: NT5.1
Разработчик: Viktor_Kisel
Разрядность: 32bit
Язык интерфейса: Русский
Таблэтка: Не требуется

Системные требования:
Процессор: от 233 MHz
Оперативная память: от 256 Mb
Свободное место: не менее 7 Gb
Рекомендуемое разрешение экрана: 800x600 и выше.

Универсальный образ системного раздела для восстановления на любой компьютер, вне зависимости от того, какое оборудование в нем установлено. Содержит только критические обновления. Полностью автоматическая установка, у программы установки нет никаких вопросов. Быстрая установка операционной системы с помощью образа Acronis. Образ подготовлен в True Image Echo Workstation 9.7 [8.398].

Этот файл-образ с установленной cистемой WinXP SP3 можно спокойно копировать на винчестер и затем можно будет развернуть на любом железе, при помощи загрузочного диска, созданного Acronis True Image. Возможно потребуется (заново) установить драйвера для контроллера материнской платы, которые есть в Вашем CD-диске (идущем в комлекте с материнской платой) или в дистрибутиве установленной операционной системы.

За основу сборки взят оригинальный дистрибутив Microsoft Windows XP Professional SP3 VL Simplix Edition.
Система была установлена затем "отвязана от железа" и запакована с помощью True Image Echo Enterprise Server 9.7 [8.398].
Распаковывается на любой ПК за 5-10 минут.

В сборке присутствует два образа:
1. Образ без интегрированных AHCI драйверов - MyBackup_ALL_WinXP_Pro.tib
Подходит если нет необходимости в AHCI драйвере или при использовании функции Universal Restore от Acronis или Adaptive Restore (Р2Р) от Paragon с возможностью добавить (интегрировать) нужный драйвер на этапе развёртывания. Кроме добавления драйвера на этапе разворачивания, можно внедрить драйвер в уже развёрнутую ОС с помощью отдельной версии Universal Restore (присутствует только в Acronis Backup & Recovery) или функции Adaptive Restore от Paragon HDM/Paragon HE: Мастера -> Р2Р настройка ОС (в линукс-версии присутствует только до версии Paragon 2009). Драйверпаки для Universal Restore/Adaptive Restore можно взять на специальных сайтах, например, http://driverpacks.net/driverpacks/latest, понадобятся пакеты "Mass Storage" под требуемые ОС (необходимо их предварительно распаковать). При разворачивании нужно указать папку с нужным драйвером (или набором драйверов), и тогда он автоматически будет интегрирован в ОС.
Кроме упомянутых функций от Акрониса и Парагона, есть и другие варианты адаптации ОС под новое железо. В частности, хорошие результаты показывает китайский новичок - SkyIAR (драйвера для ходовых чипов уже включены в программу!), программа практически "однокнопочная". Также очень мощными возможностями обладает TeraByte OS Deployment Tool Suite с функцией OS Deployment Tool: программа не только позволяет удалить/добавить драйвера HAL/Mass Storage, но и позволяет сделать Sysprep (полную подготовку к "обезличиванию" ОС, сменить ID, имя пользователя и т.п.), что может быть очень важно в сетях предприятий. Можно использовать совместно с любой программой по разворачиванию образа, т.е., разворачиваем образ (Acronis/Paragon/Ghost/R-Drive/HDClone/...) без применения UR Acronis/AR Paragon, а потом доводим лежачую ОС до кондиции с помощью функции OS Deployment Tool.
Есть и аппаратное решение проблемы: можно просто зайти в BIOS и переключить режим работы SATA-контроллера с AHCI на IDE-mode (названия могут иметь и другой вид, например, Compitability mode), тогда драйвера для успешной загрузки не понадобятся. Потом, после загрузки, если работа в IDE-режиме по каким-то причинам нежелательна, нужно добавить необходимый драйвер SATA-контроллера в систему, перезагрузить ОС (включив попутно в BIOS AHCI-режим), и загрузить ОС в AHCI-режиме с добавленным драйвером.
2. Образ с интегрированными AHCI драйверами - MyBackup_ALL_WinXP_Pro_AHCI.tib
Включает набор ходовых АHCI-драйверов (они интегрированы в данную сборку), что позволяет запустить систему без необходимости использованиия Universal Restore/Adaptive Restore (P2P). Если загрузка прерывается BSOD (неподходящий драйвер), используем Adaptive Restore от Paragon. Потом, при первой загрузке, по F8 выбираем "Загрузить последнюю удачную конфигурацию". Как правило, такой вариант позволяет загрузить систему даже с "неправильным" драйвером.

Установка:
1. Разворачиваем образ tib с помощью True Image Echo Enterprise Server на жесткий диск.
2. Загружаемся первый раз и ожидаем приглашения на перезагрузку и соответствено перезагружаемся. Если система отказывается загружаться, то пробуем загрузится через Safe Mode (кнопка F8).
3. Проверяем установленное оборудование и устанавливаем необходимые драйвера.
4. После установки SATA/SCSI/RAID на Рабочем столе запускаем программку DisSata.exe, которая поможет перевести неиспользуемые SATA/SCSI/RAID в состояние Disabled.
5. После установки SATA/SCSI/RAID на Рабочем столе запускаем файл реестра DevicePath.reg, который поможет восстановить параметр DevicePath. По окончании установки можно удалить на Рабочем столе файлы DisSata.exe, DevicePath.reg, а также папку "I" из каталога C:\WINDOWS\.
P.S. Пункты 4-5 применяются только к образу с интегрированными AHCI драйверами.

Внимание:
1. На ноутбуках часто бывает первый скрытый аварийный раздел для восстановления системы, перед восстановлением образа его нужно удалить, т.к. по умолчанию загрузка прописана на первый раздел.
2. Windows 7 при чистой установке, с нуля, создаёт раздел объёмом 100 Mb, он остаётся скрытым и зарезервирован операционной системой. На нём находятся файлы загрузки операционной системы Win7, перед восстановлением образа его нужно удалить.

В созданном образе используется следующая информации о зарегистрированном владельце и организации, которая может применяться для регистрации различных программ:
Пользователь: User
Организация: Computer
Для изменения информации о зарегистрированном владельце и организации, которая показывается в свойствах системы необходимо изменить данную опцию. За хранение этой информации отвечают следующие ключи реестра:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
"RegisteredOrganization"="Computer"
"RegisteredOwner"="User"

При необходимости меняем установки в региональных настройках на нужные:
"Панель управления" -> апплет "Язык и региональные стандарты" -> вкладка "Дополнительно" -> "Язык программ, не поддерживающих Юникод" -> установите язык "Русский".
Если это не помогло, то добавьте:
"Панель управления" -> апплет "Язык и региональные стандарты" -> вкладка "Региональные параметры" -> "Языковые стандарты и формы" -> установите язык "Русский".
Изменения вступят в силу только после перезагрузки компьютера!

Особенности:
- Пакет обновления SP3.
- Критические обновления до 15.01.2013
- Драйвера самых распространённых AHCI-контроллеров AMD, Intel, nForce, JMicron, Marvell, SiS, VIA.
- Подготовка системы без использования утилиты SysPrep.
- Учетная запись "Admin".
- По умолчанию украинская раскладка клавиатуры.
- В операционной системе ничего не урезано.
- В интерфейсе изменений нет.
- Восстановление системы включено.
- Образ можно развернуть через True Image Echo Enterprise Server/Workstation 9.7 [8.398].

Применен твик реестра для оптимизации работы системы:
Включены:
- переключение на русскую раскладку клавиатуры в DOS-приложениях
- переключатель клавиатуры Num Lock при загрузке
Отключены:
- кэширование изображений (thumbnails)
- функция Prefetch
- Помощник очистки рабочего стола
- приглашение Знакомство с Windows
- отладчик Доктор Ватсон
- сообщения об ошибках
- запись отладочной информации (дамп памяти)
- обновление времени последнего доступа к файлам и папкам для NTFS
- автоматическое обновление системы
- сообщения Центра безопасности
Изменен путь к папке TEMP на %SystemRoot%\Temp (С:\WINDOWS\Temp)
И многое другое...

Патчи:
tcpip.sys - количество одновременных полуоткрытых исходящих TCP соединений увеличено до 1000.
uxtheme.dll - позволяет устанавливать темы без цифровой подписи.
kbdur.dll - исправленная украинская раскладка клавиатуры с апострофом [ ` ] ставится кнопкой "Ёё" и гривною ставится кнопкой Shift+[ ` ].

Драйвера AHCI-контроллеров:
AMD - 3.3.1540.26
Intel - 11.1.0.1006
JMicron - 1.17.63.1
Marvell 61xx - 1.2.0.8300
Marvell 91xx - 1.2.0.1019
nForce - 10.3.0.46
SiS - 5.1.1039.3020
VIA - 5.1.7600.601

Программы:
.NET Framework 1.1-4.0
Microsoft Visual C++ 2005-2012
RuntimePack Lite 12.8.20
Windows Media Format 11
WMV-9 VCM RTW
Java 1.6.0.38
7-Zip 9.20
Adobe Flash 11.5.502.146 ActiveX
Adobe Flash 11.5.502.146 Plugin
Adobe Reader 9.4.7
BizzOn 3.15
CCleaner 3.27
Download Master 5.14.2.1329
FastStone Capture 7.0
FastStone Image Viewer 4.2
FileMenu Tools 5.8.1
Firefox 17.0.2esr
MediaInfo 0.7.33
Microsoft Office 2003 SP3 Rus-Ukr (Word, Excel, PowerPoint, FrontPage)
Miranda IM Portable HotCoffee 0.9.48
Nero 6.6.1.4
nnCron 1.91.1083
Opera 12.12
Opera Portable 9.64 v3.24
Pragma 6.0.101.9
Primo Ramdisk Ultimate Edition 5.5.0
Skype 4.2.0.187
TeamViewer 6.0.11656
The KMPlayer 3.5.0.773
Total Commander 8.00 Podarok Edition
Unlocker 1.8.5
uTorrent Portable 2.2.1
WinDjView 0.5
WinRAR 4.20
Заставки
Темы