GimageX

Все права на данный документ принадлежат сайту WST-Place

Warning!!!

Перед использованием программы GimageX необходимо установить wimfltr (wim-фильтр), иначе при попытке монтирования образа появится такое сообщение:

Wimfltr можно установить несколькими вариантами:

1. Запустить программу vLite (если есть) и нажать кнопку "Install"

2. В папке – диск:\путь к папке GimageX\ wimfltr\ wimfltr.inf – правый клик на этом файле и во всплывающем меню, команда "Установить".

3. Командой установки из командной строки (это единственный вариант установки wim-фильтра в среде Win PE).

%SystemRoot%\system32\rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 \путь к папке\GimageX\wimfltr\wimfltr.inf

Например:

%SystemRoot%\system32\rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 D:\Soft\GimageX\wimfltr\wimfltr.inf

rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 E:\Soft\GimageX\wimfltr\wimfltr.inf

Общая информация для закладок

В Windows 7 при работе с образом, Флаг редакции устанавливать не обязательно, оставьте поле пустым.

Имя редакции: – на английском, выводится в программах и на экран при установке, если не заполнено Выводимое имя:

Выводимое имя: – обязательно для локализованных версий, именно это выводится на экран при установке, если удалить файл ei.cfg в папке "Sources" дистрибутива.

Флаг – Загрузочный, помечает образ тома как загружаемый. Доступно только для образов Windows PE. В WIM-файле можно пометить как загружаемый только один образ тома.

Флаг – Проверить, включение проверки файлового ресурса путем проверки на наличие ошибок и дублирования файлов.

Флаг – Выбрать во время установки, выбор редакции по умолчанию, но не работает эта фигня.

Захват – Захват с диска в WIM-файл

Имя wim-файла: – путь куда будет создан wim-файла и его имя.

Захват диска: – диск, с которого будет произведен захват (диск с установленным в аудите Windows).

Имя редакции: – название редакции, например Windows 7 ULTIMATE.

Описание: – (необязательно) описание образа, например Windows 7 x64 Lite.

Степень сжатия: – выбираете нужную степень сжатия, обычно "Максимум".

Флаг редакции: – должен соответствовать редакции Windows, например "ULTIMATE" или оставить пустым.

Выводимое имя: – (обязательно для локализованных версий) имя образа, например Windows 7 ULTIMATE.

Описание вывода: – (необязательно) описание образа, например Windows 7 x64 Lite.

Заполнили все эти поля, жмите кнопку "Создать", начнется захват образа в wim-файла.

Флаг – "Показать исключения и Config.ini", по умолчанию при захвате исключаются некоторые файлы, их список выводится на экран, если есть Config.ini с добавочным списком исключений, то флаг означает вывести этот список на экран.

Окно "Файл Config.ini" – не обязательный пункт, здесь указываете свой конфигурационный файл с исключениями. Какие папки и файлы не захватывать в образ.

Окно "Временная папка" – не обязательный пункт. Определяет путь хранения временных файлов. Использовать при запуске с LiveCD, там временная папка в памяти очень маленькая, не хватает.

Применение – Применение образа тома к диску (извлечение файлов из образа на диск)

Равноценно извлечению из архива (.wim и есть архив). Потом можно опять захватить (упаковать), вкладка Захват, точно также как при захвате после Аудита.

Извлеченный имидж является полностью автономным, не привязанным к wim-файлу, из которого его извлекли, в противоположность режиму монтирования.

В извлеченный дистрибутив легко добавлять, а для удаления или изменения нужны права "Trustedinstaller".

Путь к wim-файлу: – указываем нужный wim-файл.

Путь назначения: – указываем диск или папку, куда будет извлечен выбранный имидж.

Индекс редакции: – индекс, имидж который подвергнется истязаниям.

Выбрать редакцию… – тоже самое, но нагляднее.

Можно извлечь имидж на свободный раздел жесткого диска, программой EasyBCD прописать этот раздел в загрузчик Windows, произвести загрузку компа с этого раздела, винда установится и настроится буквально за три минуты.

При нажатии кнопки "Выбрать редакцию…" появится окно с редакциями Windows в wim-файле.

Это относится ко всем закладкам программы GimageX, где есть кнопка "Выбрать редакцию…"

Сведения – Информация о содержимом WIM-файла

Путь к wim-файлу: – к нопкой "Обзор" выбираем нужный файл xxxxx.wim и нажимаем кнопку "Получить сведения из файла образа", отобразятся сведения обо всех имиджах в образе.

Правка – Изменение атрибутов/описания редакции

Изменение названия и описания редакций в образе.

Имя редакции: – название редакции, например Windows 7 ULTIMATE.

Описание файла: – (необязательно) описание образа, например Windows 7 x64 Lite.

Выводимое имя: – (обязательно для локализованных версий) имя образа, например Windows 7 ULTIMATE.

Описание вывода: – тоже, что Описание файла: – (необязательно).

Монтаж – Монтаж содержимого wim-файла в пустую целевую папку для просмотра/изменения

Исходный wim-файла: – указываете wim-файл, над которым будете измываться.

Целевая папка: – папка в которую будет смонтирован выбранный wim-файла.

Индекс редакции: – индекс, имидж который подвергнется истязаниям.

Выбрать редакцию… – тоже самое, но нагляднее.

Разрешить изменение содержимого в целевой папке – нужно поставить галочку, иначе не сможете ни чего сделать с монтированным образом.

Когда все выбрано и установлено разрешение, нажимаете кнопку "Монтировать в целевую папку".

Образ смонтирован, теперь приступайте к издевательству.

После всех издевательств не забудьте поставить галочку "Сохранить изменения содержимого в wim-файл при демонтаже", выделите строку wim-файла (как на скрине) и жмите кнопку "Демонтировать".

Если по каким-то причинам решили отказаться от внесения изменений, то нажмите кнопку "Демонтировать", не ставя, галочки на пункте "Сохранить изменения содержимого в wim-файл при демонтаже", образ будет отсоединён без внесения изменений, то есть останется в первоначальном виде.

Образ демонтирован, жмите кнопку "Закрыть".

Удаление – Удаление редакций из WIM-файла

Путь к wim-файлу: – кнопкой "Обзор" выбираем нужный файл xxxxx.wim.

Индекс редакции: – индекс, имидж который хотите удалить.

Выбрать редакцию… – тоже самое, но нагляднее.

Выбрать во время установки –

После того, как указали необходимые wim-файл и редакцию, нажимаете кнопку "Удалить", начнется удаление не нужной вам редакции.

Экспорт – Экспорт редакций в другой WIM-файл

Исходный WIM файл – wim-файл из которого будет производится экспорт нужной редакции.

Путь к wim-файлу: – кнопкой "Обзор" выбираем нужный файл xxxxx.wim.

Индекс редакции: – индекс, имидж который хотите экспортировать.

Конечный WIM файл – wim-файл который будет создан при экспорте или в который будете экспортировать.

Путь к wim-файлу: – кнопкой "Обзор" выбираем нужный файл xxxxx.wim или создаете новый.

Степень сжатия: – выбираете нужную степень сжатия, обычно "Максимум".

Имя образа: – имя образа, который экспортируете, например Windows 7 ULTIMATE.

После того, как все выбрано и прописано, нажимаете на кнопку "Экспорт".