О Dism++

 Top Next

Программа Dism++ - создана разработчиком из Китая – Zifeityzyicq. Перевод Alecs962.

Про DISM ++ можно сказать, что это GUI версия системы Dism, но не зависима от Dism, основана на нескольких базовых CBS (Component Based Servicing Reference - менеджер пакетов).

Добавлено для ознакомления:

Что такое система DISM?

Система обслуживания, развертывания и управления образами. DISM.exe - это средство командной строки, которое может использоваться для обслуживания образа Windows® или для подготовки образа среды предустановки Windows (Windows PE). Оно заменяет диспетчер пакетов (Pkgmgr.exe), PEimg и Intlcfg, которые включались в Windows Vista®. Функциональные возможности этих средств собраны в одном инструменте (DISM.exe).

Функции Dism++

• Не содержит компоненты системы Dism, совместима со всеми версиями ОС! Хотя Microsoft Dism имеет три версии.

• Перекрывает функции системы Dism, обеспечивая полностью работы с образами, поддерживает практически все функции системы Dism, а также большое количество функций, которых нет в системе Dism. Управление обновлениями, драйверами, функции Appx, дополнительные функции, управление службами, сжатие системных файлов Compact/WIMboot , ремонт системы и т. д.

• Обеспечивает полную поддержку формата образа диска WIM (включая захват ESD, ESD конвертация в ISO, архивы разделов ESD и прямая поддержка ISO). Стоит отметить, что при ESD конвертации в ISO Dism ++ расшифровывает данные непосредственно в памяти без изменения данных на жестком диске.

• Очистка, а также функции оптимизации, пользователь может настроить правила Dism ++, создавать эксклюзивные системные инструменты.

Спонсорство Dism++

Спонсорский взнос будет использоваться для покрытия расходов на сервер, если вы поможете оплатить арендную плату. Для того чтобы извлечь пользу из проблематики мы предлагаем небольшие субсидии один раз в год около 20 юаней.

Пояснение: Спонсорство это не платная поддержка, программа является личным хобби и имеет любительское техническое обслуживание. При отсутствии обратной связи и идей по улучшению не гарантирует 100% своевременное реагирование и доработку. Так что это важно не только для службы поддержки и спонсорства Dism++.

Системные требования

Минимальная платформа: NT 6.0 и выше, память 512 МБ

Рекомендуемая рабочая платформа: NT 6.1 и выше, amd64 архитектура системы, 8ГБ физической памяти, + 8 ГБ виртуальной памяти или больше.

• Работает только с процессорами платформы x86 и AMD64, IA64, ARM и ARM64 системы поддерживает только автономный режим.

• В 64-бит среде, где отсутствует поддержка 32-бит приложений без WOW64 (например, чистые 64 PE), Dism++ не сможет обрабатывать в автономном режиме 32-бит системы.

• На платформах Windows Vista или Windows 2008, некоторые функции не будут работать, например: CompactOS, WIMBoot.

Список файлов DISM++

В следующем списке приведены все файлы Dism++, может потребоваться удалить те, которые не требуются.

Имя файла | Описание функции
Dism++x64.exe | 64-битная система пользовательского интерфейса, на 64-битных системах запускайте этот файл, пользователи 32-бит системы могут удалить этот файл.
Dism++x86.exe | 32-битная система пользовательского интерфейса, если запустить этот файл в 64-бит системе, то произойдет автоматическое перенаправление в Dism++x64.exe. Пользователи 64-бит системы могут удалить этот файл.
Config\amd64\bcdboot.exe | Обеспечивает восстановление загрузчика, этот файл поставляется с оригинальной версией ОС, удаление его не буде иметь никакого эффекта. Пользователи оригинальной и 32-бит систем могут удалить этот файл.
Config\x86\bcdboot.exe | Обеспечивает восстановление загрузчика, этот файл поставляется с оригинальной версией ОС, удаление его не будет иметь никакого эффекта. Пользователи оригинальной и 64-бит систем могут удалить этот файл.
Config\amd64\CBSHost.dll | DISM ++ модуль поддержки API, после его удаления 64-бит система не сможет использовать Dism ++. Пользователи 32-бит ОС могут удалить этот файл.
Config\x86\CBSHost.dll | DISM ++ модуль поддержки API, после его удаления 32-бит система не сможет использовать Dism ++, 64-бит система не работает с 32-бит системами. Автономный режим не обрабатывает 32-бит системы и пользователи 64-бит систем могут удалить этот файл.
Config\amd64\NCleaner.dll | 64-бит NCleaner - программа для очистки диска. Если этот файл отсутствует некоторые передовые функции очистки будут недоступны. Пользователи 32-бит систем могут удалить этот файл.
Config\x86\NCleaner.dl | 32-бит NCleaner - программа для очистки диска. Если этот файл отсутствует некоторые передовые функции очистки будут недоступны. Пользователи 64-бит систем могут удалить этот файл.
Config\amd64\wimgapi.dll | Модуль поддержки операции файлов WIM (Windows Imaging Format — файл-ориентированный формат образа диска). Пользователи 32-бит систем и те, кому не нужны функции, связанные с WIM, могут удалить этот файл.
Config\x86\wimgapi.dll | Модуль поддержки операции файлов WIM (Windows Imaging Format — файл-ориентированный формат образа диска). Пользователи 64-бит систем и те, кому не нужны функции, связанные с WIM, могут удалить этот файл.
Config\amd64\wofadk.sys Config\x86\wofadk.sys | Обеспечивает поддержку для функции Compact (сжать системные файлы). Пользователи Win10 могут удалить этот файл. Пользователям других ОС настоятельно рекомендуется не удалять эти файлы.
Config\Plugins | Поддержка плагинов Dism++ , пользователям, которым не требуются плагины, могут удалить этот файл.
Config\Languages | Языковой файл Dism++, для Китая, например, сохраняем только zh-Hans.zip.
Config\Data.zip | В этом файле сохраняются правила очистки, ESD расшифровка ключей и т. д. Этот файл нельзя удалять.
Config\winapp1.ini | Этот файл хранит правила очистки CCleaner, при удалении этого файла Dism ++ не сможет использовать правила CCleaner. Рассмотрите сами возможности его удаления.
Config\UpdateInfo.zip Config\UpdateInfoBeta.zip | Файл для обновления метаданных, для определения, есть ли новая версия и предотвращение понижения до версий старей, чем текущая. Рекомендуется сохранить этот файл или удалите после загрузки обновлений.
Config\default.ui.zip | Этот файл сохраняет пользовательский интерфейс Dism++. Файл нельзя удалять.
Config\wsusscn2.cab | Файл базы данных Центра обновления Windows, используется для проверки наличия обновлений. Рассмотрите сами возможность его удаления.
Config\include\Dism++.h | Существует только тестовая версия этого файла, файл поддержки сценариев C Script, если этот файл отсутствует скрипт C Script не будет работать.
Config\amd64\CScript.dll | Существует только бета-версия этого файла, 64-бит механизм синтаксического анализа C Script, если файл отсутствует сценарий C Script не будет работать, пользователи 32-бит систем могут удалить этот файл.
Config\x86\CScript.dll | Существует только бета-версия этого файла, 32-бит механизм синтаксического анализа C Script, если файл отсутствует сценарий C Script не будет работать, пользователи 64-бит систем могут удалить этот файл.


1. Начало работы

 Top Previous Next

1.1 Начало работы

1.2 От Dism переход к Dism++


1.1 Начало работы

Основное назначение программы оптимизация работы системы, очистка от мусора, ненужных приложений, устаревших драйверов. Присутствует работа с обновлениями для Windows и так называемое сжатие системы.

Интерфейс

Как показано на рисунке, верхняя вкладка позволяет переключаться между различными системами (если у вас несколько операционных систем). Слева находится список функций, вы можете выбрать необходимые функции. Прямо из главного окна можно перезагрузить систему в режиме восстановления.

Очистка системы от ненужного мусора

Советуем вам не делать слишком частую уборку мусора, особенно SSD! Как правило, рекомендуется чистить раз в месяц.

После запуска программы нажмите на "Очистка", вы увидите этот интерфейс. Затем выберите элементы, которые нужно очистить, после нажатия кнопки "Анализ" (показать размер освобождаемого пространство) или нажмите "Очистка" (не оценивать размер, а удалить мусор). Наконец, если у вас есть проект лучшей очистки нажмите на "Помощь" или "Отчет об ошибке" и отправьте ваши правила очистки.

Совет: проект риска с оранжевым логотипом, кроме того некоторые элементы имеют некоторые побочные эффекты, при выборе параметра программа покажет всплывающее окно предупреждения, обязательно перепроверьте эти пункты!

Резервное копирование системы

Есть“альтернатива” избежать риск, теперь Dism++ может непосредственно делать резервное копирование текущей системы в WIM, ESD, вам не нужно запускать PE. Очень простое в использовании, выберите текущую систему, нажмите в меню функцию "Восстановление" -- "Бэкап системы".

Затем введите путь WIM файла и нажмите кнопку OK.

Если WIM файл уже существует происходит автоматическое приращение к существующему файлу WIM, выполняется инкрементное резервное копирование.

Кроме того, если невозможно запустить процесс восстановления системы необходимо в меню "Опции" - "Настройки" отметить "Интеграция в меню загрузки BCD", после открытия записи BCD (файл данных конфигурации загрузки) Dism++ будет иметь дополнительный элемент запуска, вы можете использовать эту опцию для восстановления системы в случае необходимости.

Восстановление системы

В случае возникновения проблем с системой вы можете использовать резервную копию системы для быстрого восстановления системной среды. Dism++ нужна для того, чтобы уменьшить сложность восстановления системы, программа поддерживает режим горячего восстановления. Пользователям не нужно запускать PE, а можно восстановить напрямую из системы. Вы можете запустить Dism++, нажмите в меню "Восстановление" - "Восстановление" системы. После того, как вы выберите путь к файлу WIM, нажмите кнопку OK, как показано на следующем рисунке.

Совет: если ваша система не загружается, через меню BCD системы Dism++ (необходимо открыть "Интеграция в меню загрузки BCD") и из PE начать вышеуказанные шаги.

Тема "Начало работы" завершена, если вы хотите обратиться к углубленному изучению последующих документов, желаю вам получить удовольствие.


От Dism переход к Dism++

Dism ++ во многом схожа с системой Dism. Это потому, что Dism и Dism++ имеют почти одинаковую базовую реализацию. Можно сказать, что в Dism ++ скопировано большинство кода от Dism. Но в Dism++ есть и много различий, далее в статье будет описана разработка Dism++ и функциональные различия от Dism.

Совместимость платформы DISM++

Dism++ поддерживает Vista, Windows 10 ~ все системы (включая серверные, планшетные, мобильные телефоны, ограниченные настольные платформы и другие системы), нет никаких отдельных требований. Dism++ не делает отдельную обработку для различных платформ. Это отличается от Dism, нет необходимости разрабатывать несколько версий Dism++ для совместимости с различными системами. Также нет оснований беспокоиться, допустим о какой-то ограниченной настольной платформе, что программа не в состоянии справиться с проблемой.

Образы WIM/VHD, обработка команд

По сравнению с Dism - Dism ++ поддерживает форматы образов включая WIM, SWM, ESD, UUP и ISO. Обратите внимание, что Dism++ не поддерживает VHD, VHDX, FFU и SFU. DISM не полностью поддерживает ESD, но Dism++ обеспечивает полную поддержку ESD. В Dism++ можно ESD конвертировать в WIM или сохранить непосредственно в ESD, ниже описаны подробно рабочие режимы.

/Apply-CustomDataImage применение пользовательских данных Wimboot

Согласно оценке использования этой функции она не добавлена в Dism++. Если вам нужна эта функция обратитесь в службу поддержки.

/Capture-CustomImage захват пользовательских данных WimBoot

Согласно оценке использования этой функции она не добавлена в Dism++. Если вам нужна эта функция обратитесь в службу поддержки.

/Get-WIMBootEntry информация о WimBoot

Наведите мышь на соответствующую систему на верхней вкладке, программа выведет записи конфигурации WIMBoot для определенного тома диска.

/List-Image просмотр списка файлов WIM

DISM++ не поддерживает эту функцию, если нужно посмотреть откройте с помощью архиватора 7z файл WIM/ESD.

/Append-Image инкремент (добавление, прирост) к существующее образу

В меню выберите "Файл" - "Сохранить образ как". Где:

/ImageFile в нижней части окна нажмите кнопку "Обзор", для выбора пути к файлу образа

/CaptureDir вы можете переключиться клавишей Tab на вкладку настройки выбора системы

/Name /Description в Dism++ автоматическое распознание, если вы не удовлетворены, щелкните дважды для изменения.

/ConfigFile можно настроить параметры конфигурации - детальные настройки - установить список исключений.

/WIMBoot автоопределение, объектные файлы автоматически сжимаются при использовании WimBoot

/Bootable автоопределение, когда используется система PE, параметр можно изменить в режиме эксперта, но нельзя изменить в режиме новичка.

/CheckIntegrity не поддерживается, так как эта опция снижает производительность захвата.

/Verify не поддерживается, потому что проверяет файл WIM и этим снижает производительность.

/NoRpFix параметр не поддерживается, так как редко используется, при необходимости можно добавить.

/EA параметр автоматический, поскольку нет никаких побочных эффектов при сохранении расширенных атрибутов.

/Capture-Image захват образа

Используется так же, как в /Append-Image, в меню "Файл" - "Сохранить образ как". Где:

/ ImageFile в нижней части окна нажмите кнопку "Обзор", для выбора пути к файлу образа

/CaptureDir вы можете переключиться клавишей Tab на вкладку настройки выбора системы

/Name /Description в Dism++ автоматическое распознание, если вы не удовлетворены, щелкните дважды для изменения.

/ConfigFile можно настроить параметры конфигурации - детальные настройки - установить список исключений.

/WIMBoot автоопределение, объектные файлы автоматически сжимаются при использовании WimBoot

/Bootable автоопределение, когда используется система PE, параметр можно изменить в режиме эксперта, но нельзя изменить в режиме новичка.

/CheckIntegrity не поддерживается, так как эта опция снижает производительность захвата.

/Verify не поддерживается, потому что проверяет файл WIM и этим снижает производительность.

/NoRpFix параметр не поддерживается, так как не используется, при необходимости можно добавить.

/EA параметр автоматический, поскольку нет никаких побочных эффектов при сохранении расширенных атрибутов.

Совет: если вы сохраняете существующий образ опцией "Сохраненить образ", Dism++ автоматически настраивается на логику /Append-Image, поэтому, если вам нужно сохранить образ, а не дописать к нему, удалите существующий файл.

/Apply Image применение образа

Выбрать в меню "Файл" - "Применить образ", где:

/ImageFile в нижней части окна нажмите кнопку "Обзор", для выбора пути к файлу образа (поддержка WIM, SWM, ESD, UUP, ESD и ISO).

/ApplyDrive путь установки, для выбора нажмите кнопку "Обзор".

/Index можно выбрать параметры , щелкните на целевой образ в раскрывающемся окне.

/SFUFile не поддерживается.

/SkipPlatformCheck не поддерживается.

/CheckIntegrity ухудшает параметры производительности, не поддерживаются.

/Verify снижает производительность, не поддерживаются.

/NoRpFix не используется, не поддерживается.

/SWMFile автоопределение, автоматическое использование SWM.

/ConfirmTrustedFile не поддерживаются.

/WIMBoot параметр, установите флажок WimBoot. Разница с Dism заключается в том, что Dism ++ позволяет быстро сжатие. WimBoot сжатие - это сжатие файлов с помощью этого атрибута, поддержка Windows 7 и выше (включают в себя), Dism ++ автоматически добавляет драйвер и извлекает файлы ядра.

/Compact параметр, установите флажок "Compact". Функция поддерживает Windows 7 и выше (включают в себя). Dism ++ автоматически добавляет драйвер и извлекает файлы ядра.

/EA используется автоматически.

Кроме того, Dism++ поддерживает WindowsToGO (позволяет создавать рабочие среды Wind 8, расположенные на загрузочных USB-носителях. При этом каждая из систем может содержать определенный набор необходимого ПО. Достаточно подключить такой портативный накопитель к компьютеру и дождаться загрузки полностью настроенной и готовой к использованию ОС.), добавить загрузку и отформатировать раздел, при необходимости пользователи могут использовать.

/Apply-SiloedPackage пользовательские настройки

Dism++ не поддерживает эту функцию.

/Split-Image

Выберите в меню "Файл" - "WIM <-> ESD / SWM", затем выберите целевой файл SWM. В отличие от Dism, Dism++ позволяет разделять на части ESD.

/Get-MountedWimInfo или /Get-MountedImageInfo просмотр смонтированных образов

Dism++ непосредственно при запуске будет показывать все образы, в том числе смонтированные образы. Вы можете кликнуть на Tab для переключения нужного вам образа.

Dism++ не поддерживает VHD/ или VHDX, следовательно, невозможно просматривать в программе VHD/VHDX, необходимо решить, если вам нужно монтировать VHD/VHDX добавьте путь к образу вручную, в меню "Файл" - "Добавить путь".

/Get-WimInfo или /Get-ImageInfo просмотр данных образов

В меню "Файл", нажмите "Открыть файл образа". Dism++ поддерживает сегментирование образов ISO и UUP. Кроме того, дважды щелкнув на информацию образа можно непосредственно изменить ее описание.

Dism++ не поддерживает VHD/и VHDX, поэтому вы не можете использовать функцию для просмотра VHD/VHDX образов.

/Commit-Wim или /Commit-Image сохранить изменения

В закладке выберите образ, который вы хотите сохранить и нажмите в меню "Файл" -> "Сохранить образ" или нажмите сочетание клавиш Ctrl + S.

Dism++ поддерживает инкрементное сохранение (только тех данных, которые добавились), если вы выберете этот метод сохранение. В исходный WIM будет добавлен новый модифицированный индекс.

/Unmount-Wim или /Unmount-Image размонтировать образ

Выберите сохраненный образ на вкладке, затем в меню "Файл" -> "Размонтировать образ". Также можно нажать клавишу быстрого доступа Delete.

Dism ++ не поддерживает при размонтировании сохранение изменений. Если вам нужно сохранить, сначала сохраните образ, а затем используйте функцию размонтирование.

/Remount-Wim или /Remount-Image восстановить точку монтирования

DISM++ при запуске автоматически определяет, был ли поврежден подключенный образ и спросит вас, нужно ли его исправить, если вам нужно использовать эту функцию, просто нажмите кнопку ОК и никаких дальнейших действий.

/Cleanup-Wim или /Cleanup очистить точки монтирования

Dism++ не поддерживает эту функцию, но вы можете вручную удалить точки монтирования по одной.

/Delete-Image удалить индекс образа

В меню "Файл" - "Открыть файл образа", выберите индекс, который вы хотите удалить, затем нажмите кнопку "Удалить".

/Export-Image экспорт образа

Есть два способа:

Способ 1: "Файл" - "Открыть файл образа", выберите индекс, который вы хотите экспортировать, затем нажмите кнопку "Экспорт". Вам будет предложено выбрать файл образа, если файл существует, автоматически добавляется к нему без удаления исходных данных. Если не существует, будет создан новый.

Способ 2: "Файл" - "WIM <-> ESD / SWM", затем выберите местоположение файла образа. Эта функция будет экспортировать все индексы и перезаписывать существующий файл. Когда требуется полное преобразование этот вариант более подходящий.

Команды служб Windows

Dism ++ не поддерживает эту функцию.

Команды автоматических служб

Dism ++ не поддерживает эту функцию.

Команды обслуживания драйверов

Выберите пункт "Драйверы". Разница от Dism заключается в том, что Dism++ доступна онлайн обработка.

/Remove-Driver удаление драйверов

Dism ++ по умолчанию в режиме новичка не отображает эту функцию, откройте режим Expert, выберите драйвер, который вы хотите удалить, нажмите кнопку "Удалить".

/Add-Driver добавить драйверы

Вы можете нажать на кнопку "Добавить", от Dism различие в том, что Dism++ позволяет выбрать папку. После выбора, Dism ++ автоматически добавит в эту папку все драйверы, которые будут добавлены потом в систему.

/recurse автоматический параметр, поэтому в DISM ++ можно выбрать только папку.

/ForceUnsigned автоматический параметр, добавление неподписанных драйверов не возвращая ошибку.

Следует отметить, что, Dism++ проверит системный драйвер, например добавление 32-бит драйвера на 64-бит систему возвращает ошибку. Это отличает Dism++ от всех Dism.

/Get-DriverInfo информация о драйвере

После выбора слева драйвера, щелкните на нем, автоматически будет показано справа сведения о драйвере.

/Get-Drivers вывести список драйверов

Список автоматически отображается при включении управления драйверами.

/all установите флажок на "Предустановленные" драйвера. Обратите внимание, внутренний драйвер не может быть удален, если он отображает зараженное программное обеспечение.

/Export-Driver экспорт драйверов

Выберите драйвер, который вы хотите экспортировать, затем нажмите кнопку "Экспорт".

Команды региональных параметров

В Dism++ это название региона и язык, далее просмотрите соответствующие команды.

/Set-UILang язык интерфейса системы

Выбор языка по умолчанию устанавливается в раскрывающимся окне и вам необходимо установить соответствующий язык заранее.

/Set-UserLocale пользовательские региональные параметры

Настройте конфигурацию пользователя под новой учетной записью пользователя (формат, раскладка клавиатуры и т. д.).

/Set-SysLocale настройка локали системы

Настройте пользовательский интерфейс (формат, раскладка клавиатуры и т. д.), под экраном приветствия (системная учетная запись) в указанной области.

/Set-TimeZone настройка часового пояса

Измените настройку часового пояса на нужный часовой пояс.

/Set-SKUIntlDefaults или /Set-AllIntl разовая корректировка настроек языка по умолчанию

Используйте параметр, чтобы привести все региональные параметры автономного образа в соответствие со значениями по умолчанию, определенными в ходе установки. Чтобы использовать эту функцию, сначала установите соответствующий языковой пакет. В Dism++ также рекомендуется использовать эту опцию, а не индивидуальные настройки.

/Get-Intl сведения о региональных параметрах

Когда эта функция включена, автоматически отображаются региональные параметры.

Другие параметры

Для того, чтобы пользовательский интерфейс был практичным и эстетичным, не используйте /Set-SKUIntlDefaults или /Set-AllIntl, нет необходимости индивидуального отображения.

Команды Службы приложений

Не принимая во внимание практическую ценность, эта функция не поддерживается, но Dism++ использует функции Центра обновления Windows для проверки обновлений для Office.

Команды обслуживания пакетов обновлений

Эта функция распределена по нескольким функциям Dism++.

/Get-Packages получить обновления

В пункте "Обновления" нажмите кнопку "Анализ", чтобы обновить список обновлений.

/Get-PackageInfo сведения об обновлении

Вся информация обновляется автоматически, отображая список установленных обновлений.

/Add-Package добавить обновления

Намите кнопку "Добавить" и выберите локальное обновление (удерживайте Shift для выбора нескольких файлов обновлений сразу). Из которых:

/PackagePath путь к файлам обновления, поддержка пакетного выбора файлов, вы можете нажать клавишу Shift, чтобы выбрать несколько обновлений сразу, поддержка файлов cab, msu и exe (частично).

/IgnoreCheck не поддерживается, Dism++ обеспечивает адаптивную проверку.

/PreventPending не поддерживается.

Dism++ может использовать базу данных для проверки наличия обновлений, нажмите кнопку "Анализ", нажмите "Установить". Это устраняет необходимость вручную собирать обновления, рекомендуется этот способ установки обновления

/Remove-Package удалить обновление

Нажмите на "Установленные" обновления, затем выберите обновления, которые хотите удалить и нажмите кнопку "Удалить".

/Get-Features просмотр специальных функций

Щелкните на пункте "Компоненты Windows".

/Get-FeatureInfo сведения о специальных функциях

Щелкните на пункте "Компоненты Windows", автоматически будет показано состояние всех функций.

/Enable-Feature включить специальную функцию

В списке компонентов выберите нужную функцию, включите, затем нажмите кнопку "Применить", где:

/LimitAccess не поддерживается.

/Source укажите путь к локальному источнику, обычно D:\Sources\sxs. Если вы не знаете, как использовать, можете смонтировать ISO, Dism++ автоматически распознает.

/All параметр автоматический.

/Disable-Feature отключить специальную функцию

В списке компонентов выберите необходимую функцию, отключите, затем нажмите кнопку "Применить", где:

/Remove корректировать статус обновления для x.

/Get-Capabilities просмотр дополнительных возможностей

Нажмите кнопку "Дополнительные возможности".

В DISM++ для оптимизации производительности сетевой запрос отключен по умолчанию, если вы хотите увидеть все функции (включая сетевые) установите флажок "Показать все возможности".

/Get-CapabilityInfo сведения о дополнительных возможностях

После нажатия кнопки "Дополнительные возможности" автоматически будет показана информация.

/Add-Capability добавить возможности

Если вам нужно использовать эту функцию, сначала в дополнительном интерфейсе нажмите "Показать все возможности" и затем нажмите "Включить". Где:

/Source и /LimitAccess не поддерживаются, если вам нужно добавить локальную функцию, нажмите на пункт "Обновления", добавьте вручную файл cab.

/Remove-Capability удалить возможность

В интерфейсе Дополнительные возможности вы можете удалить функцию, нажмите кнопку "Удалить".

/Cleanup-Image /RevertPendingActions отменить внесенные изменения

Dism++ не поддерживает эту функцию.

/Cleanup-Image /spsuperseded использование исправлений SP (от английского service pack, SP)

Эта функция включена в /StartComponentCleanup. Где:

/hidesp использование автоматически.

/Cleanup-Image /StartComponentCleanup использование очистки папки Winsxs

Нажмите пункт "Очистка" - "Временные файлы" - " WinSxS временные файлы", проверьте галку на элементе (она должна стоять по умолчанию), затем нажмите кнопку "Очистка". Кроме того, эта функция уже включена в /spsuperseded (удаляет файлы, оставшиеся от установки сервис паков).

/ResetBase обновление программного обеспечения автоматически. Кроме того, обратите внимание, Dism блокирует эту функцию в Windows 10, параметр автоматически игнорируются. Но Dism++ (версии 10.1.25.1 и выше) не будет игнорировать этот параметр, немного изменено поведение. Кроме того, Dism++ также поддерживает Vista и Windows 7.

/Defer отложенная очистка до следующего технического обслуживания, не поддерживается этот параметр.

/Cleanup-Image /AnalyzeComponentStore анализ очистки пространства

Нажмите пункт "Очистка" - "Временные файлы" - " WinSxS временные файлы", затем нажмите кнопку "Анализ", программа покажет сколько пространства будет освобождено.

/Cleanup-Image /CheckHealth проверка поврежденных компонентов

Dism++ не поддерживает эту функцию.

/Cleanup-Image /ScanHealth анализ системных повреждений

В меню нажмите на функцию "Восстановление" -" Проверить".

/Cleanup-Image /RestoreHealth исправление поврежденний

В меню нажмите "Восстановление" - "Исправить". Где:

/Source не поддерживает пользовательские локальные источникии и программные параметры.

/LimitAccess блокирование доступа в сеть, не поддерживается.

Способность восстановливать повреждения, программы и капитальный ремонт системы обычно терпит неудачу, мы не даем большой процент надежды.

Команды обслуживания APPX

Нажмите "Управление Appx" и далее нажмите на "Provisioned Appx".

/Get-ProvisionedAppxPackages просмотр установленных приложений

При запуске интерфейса отображаются сведения, относящиеся к Appx.

/Set-ProvisionedAppxDataFile использование пользовательских данных

Функция не поддерживается.

/Remove-ProvisionedAppxPackage удалить установленное приложение

Отметьте приложение, которое вы хотите удалить, нажмите кнопку "Удалить".

/Add-ProvisionedAppxPackage добавить пакеты приложений (Appx)

Dism++ не поддерживает эту функцию, он в основном сосредоточен на удаление и т.д. Например, Microsoft собирается добавить эту функцию.

PROVISIONING PACKAGE SERVICING COMMANDS

Эта функция не поддерживается.

Команды ассоциации по умолчанию

Нажмите для просмотра функций ассоциации файлов. Разница от DISM в том. что с Dism++ пользователи Vista и Windows 7 также могут использовать эту функцию.

/Remove-DefaultAppAssociations убрать ассоциации в приложениях по умолчанию

Нажмите кнопку «Удалить» под ассоциацией в приложениях образа Windows по умолчанию.

/Import-DefaultAppAssociations импорт ассоциации в приложениях по умолчанию

Нажмите кнопку «Импорт» ниже ссылки на образ по умолчанию для Windows.

/Get-DefaultAppAssociations просмотр ассоциации в приложениях по умолчанию

Нажмите кнопку "Экспорт" ниже образа приложения Windows по умолчанию, затем используйте программу для просмотра текста, просмотрите только что экспортированный файл конфигурации.

/Export-DefaultAppAssociations экспорт конфигурации программы для текущего пользователя

Нажмите на стандартное приложение образа Windows по умолчанию и нажмите на кнопку "Экспорт" в нижней части.

Команды WINDOWS PE

Нажмите команды WinPE , чтобы посмотреть функции.

/Get-ScratchSpace или/Get-TargetPath или/Get-PESettings просмотр параметров

При открытии этой функции автоматически отображаются настройки

/Set-ScratchSpace настройка рабочего пространства

Скорректируйте размер рабочего пространства образа Windows PE (МБ) этой настройкой, затем нажмите кнопку "Применить".

/Set-TargetPath настройка пути назначения PE

Укажите целевой путь образа Windows PE в настройках параметра, затем нажмите кнопку "Применить".

/Get-Profiling просмотр файла конфигурации

Эта функция не поддерживается.

/Apply-Profiles использование файла конфигурации приложения

Эта функция не поддерживается.

/Disable-Profiling отключить использования файла конфигурации

Эта функция не поддерживается.

/Enable-Profiling включить использования файла конфигурации

Эта функция не поддерживается.


2. Расширенные дополнения

2.1 Термины DISM++

2.2 Скрытые параметры DISM++

2.3 Пользовательские правила

2.4 Структура правил


2.1 Термины DISM++

Настоятельно рекомендую не пропускать эту страницу документа, иначе вы не поймете последующего содержания!

Dism++ совместим с Dism с точки зрения терминологии, так что если в этой статье есть упущения, рекомендуется ссылаться на конкретные страницы, где есть описание этой функции, также можете обратиться к документации MSDN корпорации Microsoft.

Образ

Представляет собой операционную систему, например C: установленная система, мы можем назвать ее C: образ..

Файл образа

Файл носитель, в котором можно сохранить образ системы. Dism++ работает с файлами образов WIM, SWM, ESD и ISO.

Онлайн образ (online)

Текущая операционная система, обычно система на диске C: является текущей системой, система - C: это онлайн-образ. Команда для Dism, чтобы быстро открыть образ - Dism /Online …... Для Dism++ онлайн-образ в имени будет иметь символ - *.

Автономный образ (offline)

Значение является полной противоположностью онлайн образа ("находящийся в состоянии подключения"), при условии, что текущая система - диск C:, а все остальные местоположения образов (например, D:, F:\Mount) называются оффлайн образами ("отключенный, автономный").

Целевой образ

Представляет собой образ, обрабатываемый в настоящее время, например, вы работаете в образе D: добавляете обновление, вот этот образ D: - целевой образ.

Текущий узел - хост (host)

Представляет операционную платформу Dism++, которая является текущей системой, как и ее путь с онлайн - образом. Если предположить, что текущая система Windows 7, а вы работаете с Windows 10, то вы можете сказать, что Windows 7 хост, в то время как Windows 10 - это целевой образ.

Для ознакомления:Хост (от англ. host — «хозяин, принимающий гостей») — любое устройство, предоставляющее сервисы формата «клиент-сервер» в режиме сервера.

Пояснение: возможно, вы задаетесь вопросом, почему появилась эта концепция Хост/Целевой? Это связано с тем, что некоторые низкопрофильные хост-системы не могут обрабатывать системы с более высокой версией. Например, Win7 хост принимая для Win 10 интегрированное обновление очень часто терпит неудачу.

WinPE

Мини-система, как правило небольшая, около 300 МБ. Используется для установки системы или для устранения проблем с системой.

WinRE

Почти как WinPE, просто WinRE больше сосредоточена на восстановлении системы. Система Windows Vista начала поставлятся с WinRE, так что среда WinRE сделана на основе WinPE.

Для ознакомления: Windows Recovery Environment (WinRE) - платформа восстановления, основанная на Windows Preinstallation Environment (WinPE), имеет две основные возможности:

1. Автоматическая диагностика и исправление проблем загрузки – инструмент под названием Startup Repair.

2. Централизованная платформа для инструментов восстановления.

WinRE впервые дебютирует в Vista (скрытый раздел для восстановления), полностью заменяя там консоль восстановления из XP.

Архитектуры систем

Каждая программа имеет свою собственную систему, операционная система не является исключением. Системы есть x86, amd64. Системе amd64 требуется подсистема Wow64 для запуска программ архитектуры x86. Поэтому системы, не имеющие подсистемы Wow64, не могут обрабатывать образы x86.

Dism++ поддерживает системы x86, amd64, IA64, arm и amr64 в качестве целевых образов, но Dism++ хост может работать только с x86 или amd64.


2.2 Скрытые параметры DISM++

Здесь показаны параметры Dism++, которые не отображаются в пользовательском интерфейсе, их можно изменить в Config\Config.ini, чтобы эти параметры вступили в силу.

Включен режим | Функция
[Dism++] NotLoadWofadk=1 | Dism++ не загрузит драйвер wofadk.sys по умолчанию, только в Win8 и выше Dism++ автоматически загрузит драйвер wofadk.sys. Если ваша среда специфичная, вы можете включить эту опцию. При включеной функции возможности WIMBoot и Compact могут быть ограничены.
[WUA] DisableInstallUpdate=1 | Dism++ будет пропускать процесс установки обновлений Windows Update, а будет только загружать обновления. Пользователи, которым нужно просто собрать файлы обновлений, могут включить эту опцию.
[WUA] MaxDownloadThread=10 | Настройка количества одновременных сеансов загрузки Windows Update до 10, можно настроить по собственным условиям, в Dism++ по умолчанию задано 10 потоков.
 | Скрыть смонтированные образы, некоторые PE могут иметь встроенную точку монтирования. При запуске Dism++ дает пользователю возможность подавления. Вы можете задать этот ключ для PE.
Добавить значение в реестр HKEY_LOCAL_MACHINE\SOFTWARE\Dism++\Hide | [HKEY_LOCAL_MACHINE\SOFTWARE\Dism++\Hide] "D:\7"=dword:00000000
 | После импорта ключа Dism++ не будет отображать по умолчанию смонтированный образ указанный в ключе, в данном случае это D:\7
Параметры командной строки: /ScratchDir "D:\Temp" | Dism++ настроен на временный каталог D:\Temp, вы можете задать свой каталог в соответствии с конкретной ситуацией. Рассмотрите возможность расположения временного каталога по умолчанию, например, недостаточного свободного места на этом разделе диска.


2.3 Пользовательские правила

DISM++ имеет ограниченные возможности для удовлетворения всех потребностей пользователей. Таким образом, в программу добавлена ​​специальная функция создание пользовательских правил, позволяющая продвинутым пользователям создавать собственные эксклюзивные инструменты.

Создать пустой файл пользовательских правил

Нам нужно просто создать новый Custom*.xml файл в каталоге Config (* любое название Custom1.xml или Custom.xml, мне например нравится my home.xml, файл сохраните в кодировке Юникод или UTF8). Содержимое исходного файла следующее:

<CleanCollection4>

<!--Здесь напишите правила для очистки-->

</CleanCollection4>

<SystemOptimization>

<!--Здесь напишите правила оптимизации системы-->

</SystemOptimization>

</Data>

После того, как все работы выполнены, xml-файл сжимается в zip-архив, например Custom1.zip, Custom.zip или my home.zip

Сжатие в zip нужно для уменьшения размер файла.

Правила очистки мусора, начнем с пяти правил

Ниже мы шаг за шагом пойдем от простого к сложному, скажем так, от новичка до продвинутого. Конечно, мы также приветствуем, чтобы вы предоставили ценные советы.

Простые правила очистки

Мы знаем, C:\Windows\Logs является каталогом системных журналов. Во время работы системы здесь создается большое количество журналов и они не во всех случаях удаляются автоматически. Поэтому, нам необходимо периодически удалять эти файлы. Как мы реализуем эту функцию через правила?

<Data>

<CleanCollection4>

<!--Имя правила очистки-->

<Item Name="Каталог системных журналов">

<!--Description Раздел представляет собой описание правил очистки-->

<Description>Каталог хранения системных журналов</Description>

<!--Group Раздел представляет собой группу правил, та же самая группа сохраняет аналогичные правила-->

<Group>Временные файлы</Group>

<Scan>

<Activate>

<!--GeneraПравило, очистка всего содержимого папки C:\Windows\Logs, но не удаляет саму папку-->

<General RootPath="C:\Windows\Logs"/>

</Activate>

</Scan>

</Item>

</CleanCollection4>

</Data>

Думаю, что вы должны понять, как писать правила. Для полного использования общих правил обратитесь к справочным документам..

Правила очистки с помощью переменных сред

Для простых правил есть серьезная проблема, может оказаться, что путь для очистки отсутствует или может оказаться только пустым каталогом C:\ Windows\Logs. Системный диск не обязательно C\ ......, так что это правило является ошибочным и мы улучшим версию правил. Используем переменные среды.

<!--Улучшенная версия-->

<Data>

<CleanCollection4>

<Item Name="Каталог системных журналов">

<Description>Каталог хранения системных журналов</Description>

<Group>Временные файлы</Group>

<Scan>

<Activate>

<General RootPath="%SystemRoot%\Logs"/>

</Activate>

</Scan>

</Item>

</CleanCollection4>

</Data>

% SystemRoot% является переменной средой, которая указывает на C:\Windows. Для ознакомления с поддерживаемыми переменными средами обратитесь к следующим документам - переменное среды (список переменных сред Windows можно узнать, набрав в командной строке: set или нажав кнопку «Переменные среды» на вкладке «Дополнительно» в диалоговом окне «Свойства системы» («Мой компьютер»→"Свойства")). Теперь адаптивность правил значительно расширилось.

Общие правила очистки

Мы знаем, что системные журналы находятся более, чем в одном месте. Мы можем их включить в правила. Например, в каталоге Windows различные файлы журналов, это: windowsupdate.log, Setuperr.log, setupact.log и т. д. Общий синтаксис обеспечивает функциональность запроса на их удаление.

<Data>

<CleanCollection4>

<Item Name="Каталог системных журналов">

<Description>Каталог хранения системных журналов</Description>

<Group>Временные файлы</Group>

<Scan>

<Activate>

<General RootPath="%SystemRoot%\Logs"/>

<!--GeneralСинтаксис перечисления файлов в папке %SystemRoot%, затем удалить 3 файла: WindowsUpdate.log、setuperr.log、setupact.log-->

<!--FlagsФильтр, поддерживает значение для файлов и каталогов, если нет флага - одновременно не перечислять файлы и папки. Только перечислять файлы-->

<General RootPath="%SystemRoot%" Flags="File">

<Query>WindowsUpdate.log</Query>

<Query>setuperr.log</Query>

<Query>setupact.log</Query>

</General>

</Activate>

</Scan>

</Item>

</CleanCollection4>

</Data>

Использование групповых символов

Вы должно быть почувствовали глупость этого правила, что делать, если добавиться новый файл журнала? Запрос поддерживает простые символы, суффикс *.log удалит все файлы. Таким образом, можем использовать маску, чтобы скорректировать правило.

<Data>

<CleanCollection4>

<Item Name="Каталог системных журналов">

<Description>Каталог хранения системных журналов</Description>

<Group>Временные файлы </Group>

<Scan>

<Activate>

<General RootPath="%SystemRoot%\Logs"/>

<!--GeneralСинтаксис перечисления файлов в %SystemRoot%, затем удалить все файлы *.log-->

<General RootPath="%SystemRoot%" Flags="File">

<Query>*.log</Query>

</General>

</Activate>

</Scan>

</Item>

</CleanCollection4>

</Data>

С подстановочными знаками также могут возникнуть проблемы, если мы не хотим удалять %SystemRoot%\WindowsUpdate.log. Мы можем использовать исключение, если конечно не хотим удалять содержимое. Исключение также поддерживает подстановочные знаки.

<Data>

<CleanCollection4>

<Item Name="Каталог системных журналов">

<Description>Каталог хранения системных журналов</Description>

<Group>Временные файлы</Group>

<Scan>

<Activate>

<General RootPath="%SystemRoot%\Logs"/>

<General RootPath="%SystemRoot%" Flags="File">

<Query>*.log</Query>

<!--Исключить WindowsUpdate.log-->

<Excluded>WindowsUpdate.log</Excluded>

</General>

</Activate>

</Scan>

</Item>

</CleanCollection4>

</Data>


2.4 Структура правил

В этом разделе подробного описаны правила Dism++, если вы не заинтересованы, можно игнорировать содержание этого раздела.

Эталонная структура правил очистки

У многих могут возникнуть вопрос, Dism++ правила - это что такое? В этом разделе подробно описан синтаксис правила очистки. Правила очистки имеют версию V1 и V2, это связано с историческими причинами.

Dism++ поддерживает две версии, вы можете выбрать версию в соответствии с потребностями.

Структура правила очистки V1

Структура простой версии V1

<!--Структура версии V1-->

<element name="Item">

<!--Название правила-->

<attribute name="Name" type="строка" use="обязательно"/>

<!--Уровень безопасности правил формируется от 0 до 3, чем больше число, тем безопасней степень риска. Рекомендуется не удалять, но можно удалить, предложений удалить четыре уровня. Уровень риска не отображается в режиме новичка, в режиме "Эксперт" пункт окрашен в оранжевый фон. Если рекомендации сохранить и можно удалить имеют один и тот же равный уровень, Dism++ по умолчанию это не чистит. Это ход причинного фактора, не запутаться, почему существует два уровня - образец примера. Можно исключить пункт Dism++ очистка по умолчанию, но использование этого уровня, для обеспечения безопасности не рекомендуется-->

<attribute name="Level" type="формирование" use="необязательно" default="2"/>

<!--Описание правила-->

<element name="Description" type="строка" use="необязательно"/>

<element name="Scan">

<complexType>

<!--Процент выполнения задачи - целое число больше 0. Полезно в вычислении прогресса.-->

<attribute name="Work" type="формирование" use="необязательно" default="1"/>

<!--Текст предупреждения в всплывающем окне, когда это правило включено-->

<element name="Warning" type="строка" use="необязательно"/>

<!--Название группы, если нет, сгруппировано в категорию «Другие»-->

<element name="Group" type="строка" use="необязательно" default="другие"/>

<!--Правило адаптивного тестирования, отображать только платформы 8.1 и выше, можно использовать правило адаптивного тестирования-->

<element name="Applicable" type="XML" use="необязательно" default="<True/>"/>

<element name="Activate">

<complexType>

<!--Повторно определять адаптивные правила при выполнении очистки или анализа. Могут использованы требования к адаптивности и своевременности для более сложных проектов.-->

<attribute name="Rescan" type="логические значения" use="необязательно"/>

<!--10.1.25.2 поддержка перезапуска соответствующего программного обеспечения. Пока значение доступно только для проводника Explorer -->

<attribute name="Restart" type="строка" use="необязательно"/>

<sequence>

<!--Здесь заполните правило поддержки механизма выполнения действий-->

</sequence>

</complexType>

</element>

</complexType>

</element>

</element>

Структура правила очистки V2

Структура версии V2 включает ScanCollection, поддержка нескольких узлов сканирования

<!--Структура версии V2-->

<element name="Item">

<!--Название правила-->

<attribute name="Name" type="строка" use="обязательно"/>

<!--Уровень безопасности правил формируется от 0 до 3, чем больше число, тем безопасней степень риска. Рекомендуется не удалять, но можно удалить, предложений удалить четыре уровня. Уровень риска не отображается в режиме новичка, в режиме "Эксперт" пункт окрашен в оранжевый фон. Если рекомендации сохранить и можно удалить имеют один и тот же равный уровень, Dism++ по умолчанию это не чистит. Это ход причинного фактора, не запутаться, почему существует два уровня - образец примера. Можно исключить пункт Dism++ очистка по умолчанию, но использование этого уровня, для обеспечения безопасности не рекомендуется-->

<attribute name="Level" type="формирование" use="необязательно" default="2"/>

<!--Описание правила-->

<element name="Description" type="строка" use="необязательно"/>

<element name="ScanCollection">

<sequence>

<element name="Scan">

<complexType>

<!--Процент выполнения задачи, целое число больше 0. Полезно при расчете прогресса-->

<attribute name="Work" type="формирование" use="необязательно" default="1"/>

<!--Имя правила, с тем же описанием свойств элемента, приоритет в названии при сканировании-->

<element name="Name" type="строка" use="необязательно"/>

<!--Описание правил, с тем же описанием свойств элемента, только более высокий приоритет-->

<element name="Description" type="строка" use="необязательно"/>

<!--Текст предупреждения в всплывающем окне, когда это правило включено.-->

<element name="Warning" type="строка" use="необязательно"/>

<!--Название группы, если нет, сгруппировано в категорию «Другие»-->

<element name="Group" type="строка" use="Необязательный" default="другое"/>

<!--Правило адаптивного тестирования, отображать только платформы 8.1 и выше, можно использовать правило адаптивного тестирования-->

<element name="Applicable" type="XML" use="необязательно" default="<True/>"/>

<element name="Activate">

<complexType>

<!--Повторно определять адаптивные правила при выполнении очистки или анализа. Могут использованы требования к адаптивности и своевременности для более сложных проектов-->

<attribute name="Rescan" type="логическое значение" use="необязательно"/>

<!--10.1.25.2 поддержка перезапуска соответствующего программного обеспечения. Пока значение доступно только для проводника Explorer-->

<attribute name="Restart" type="строка" use="необязательно"/>

<sequence>

<!--Здесь заполните правило поддержки механизма выполнения действий-->

</sequence>

</complexType>

</element>

</complexType>

</element>

</sequence>

</element>

</element>

Структура правил оптимизации системы

Ядро выполнения

RegWrite

Запись в реестр.

<! -

1: Создайте в реестре HKEY_LOCAL_MACHINE\SOFTWARE\Test и создайте значение 1 в REG_DOWRD с именем 123.

<RegWrite Key = "HKEY_LOCAL_MACHINE \ SOFTWARE \ Test" Тип = "REG_DWORD" Value = "123" Data = "1" />

2: Создайте в реестре HKEY_LOCAL_MACHINE\SOFTWARE\Test и создайте дочернее значение с именем 123 в REG_BINARY значение 0xCC 0x10

<RegWrite Key="HKEY_LOCAL_MACHINE\SOFTWARE\Test" Type="REG_BINARY" Value="123" Data="CC10"/> -->

<element name="RegWrite">

<complexType>

<!--Пути реестра, пример "HKEY_LOCAL_MACHINE\SOFTWARE\Test"-->

<attribute name="Key" type="строка" use="требуется"/>

<!--Тип регистрации, пример REG_SZ、REG_DWORD、REG_QWORD、REG_BINARY、REG_EXPAND_SZ-->

<attribute name="Type" type="строка" use="необязательно"/>

<!--Имя значения-->

<attribute name="Value" type="строка" use="необязательно"/>

<!--значения данных-->

<attribute name="Data" type="строка" use="необязательно"/>

<!--Тип операции, пример =, |, & и ^-->

<attribute name="Operator" type="строка" use="необязательно" default="="/>

<!--Значения по умолчанию. Значения по умолчанию обязательно | (, &, ^) есть оператор.-->

<attribute name="Default" type="строка" use="необязательно"/>

<!--True или False, указывает, включена ли переадресация Wow64 и 32-бит системы автоматически игнорируются-->

<attribute name="Wow64" type="строка" use="необязательно" default="False"/>

</complexType>

</element>

RegDelete

Удаление в реестре

<element name="RegDelete">

<complexType>

<!--Пути реестра, пример "HKEY_LOCAL_MACHINE\SOFTWARE\Test"-->

<attribute name="Key" type="строка" use="обязательно"/>

<!--Имя значения. Если это свойство не существует, то удалить все дерево реестра, если есть, то удалить только значение-->

<attribute name="Value" type="строка" use="Необязательный"/>

<!--True или False, указывает, включена ли переадресация Wow64 и 32-бит системы автоматически игнорируются-->

<attribute name="Wow64" type="строка" use="необязательно" default="False"/>

</complexType>

</element>

<!--

1：Удалить все HKEY_LOCAL_MACHINE\SOFTWARE\7-Zip

< RegDelete Key=” HKEY_LOCAL_MACHINE\SOFTWARE\7-Zip”/>

2：Удалить HKEY_LOCAL_MACHINE\SOFTWARE\7-Zip Значение пути

<RegDelete Key=”HKEY_LOCAL_MACHINE\SOFTWARE\7-Zip” Value=”Path”/>

RegMove

Перемещение в реестре

<element name="RegMove">

<complexType>

<!--Сведения об исходном ключе будет прочитана здесь, например "HKEY_LOCAL_MACHINE\SOFTWARE\Test"-->

<attribute name="Key" type="строка" use="требуется"/>

<!--Сведения о целевом ключе будут перемещены сюда, например "HKEY_LOCAL_MACHINE\SOFTWARE\NewTest"-->

<attribute name="NewKey" type="строка" use="требуется"/>

<!--Если это значение существует, только информация о значении перемещается из источника-->

<attribute name="Value" type="строка" use="необязательно"/>

<!--Новое имя значения. Если этот атрибут не присутствует, то имя остается неизменным.-->

<attribute name="NewValue" type="строка" use="необязательно"/>

<!--True или False, указывает, включена ли переадресация Wow64 и 32-бит системы автоматически игнорируются-->

<attribute name="Wow64" type="строка" use="необязательно" default="False"/>

</complexType>

</element>

<!--

1：Перемещение в реестре 7-zip

<RegMove Key=” HKEY_LOCAL_MACHINE\SOFTWARE\7-Zip” NewKey=” HKEY_LOCAL_MACHINE\SOFTWARE\7-Zip2”/>

2：Переместить значение пути для 7-zip в реестре OldPath

<RegMove Key=” HKEY_LOCAL_MACHINE\SOFTWARE\7-Zip” NewKey=” HKEY_LOCAL_MACHINE\SOFTWARE\7-Zip2” Value=”Path” NewValue=“OldPath”/>

-->

FileMove

Перемещение пути к файлу. Поддержка переменной среды для пути

<element name="FileMove">

<complexType>

<!--Исходный каталог-->

<attribute name="Src" type="строка" use="требуется"/>

<!--Каталог целевого файла-->

<attribute name="Dst" type="строка" use="требуется"/>

</complexType>

</element>

<!--

1： Переместить test.xml системного диска в test.bak

<FileMove Src="%SystemDrive%\test.xml" Dst="%SystemDrive%\test.bak"/>

-->

FileCreateByZIP

Распаковать файл из архива, поступившего в указанный каталог

<element name="FileCreateByZIP">

<complexType>

<!--Необходимо создать каталог-->

<attribute name="Path" type="строка" use="требуется"/>

<!--zip каталог файлов и подкаталогов-->

<attribute name="ZIPFile" type="строка" use="обязательно"/>

</complexType>

</element>

<!--

Распаковать Config\default.ui.zip в Data\Blank.ico файл для %systemroot%\Blank.ico

<FileCreateByZIP Path="%systemroot%\Blank.ico" ZIPFile="Config\default.ui.zip/Data/Blank.ico"/>

-->

SetServiceStart

Изменить состояние службы

<element name="SetServiceStart">

<complexType>

<!--Название службы-->

<attribute name="Name" type="Строка" use="Обязательно"/>

<!--Тип запуска службы должен быть из следующих значений:

0：Драйвер элемента автозагрузки

1：Загрузка системы

2：Автоматически

3：Вручную

4：Отключить

5：Автоматическая задержка

-->

<attribute name="Type" type="формирование" use="обязательно"/>

</complexType>

</element>

<!--

Служба aaa отключена

<SetServiceStart Name=”aaa” Type="4"/>

ExplorerNotify

Изменить параметры уведомлений системы

<element name="ExplorerNotify">

<complexType>

<!--Тип уведомления может быть только AssocChanged (обновлены ассоциации файлов) Cmd (выполнение

команды Cmd) Custom (пользовательские)-->

<attribute name="Type" type="строка" use="обязательно"/>

<!--Указывает на то, что действие асинхронное,True или False-->

<attribute name="Async" type="логическое значение" use="необязательно" default="False"/>

<!--Cmd команда, которая будет выполнена, если тип Cmd позволяет сделать следующие атрибуты.-->

<!--Необходимо выполнить команду Cmd-->

<attribute name="Cmd" type="строка" use="обязательно"/>

<!--Если тип настраиваемый, затем позволяет следующие атрибуты-->

<!--Тип сообщения-->

<attribute name="msg" type="Формирование(шестнадцатеричное)" use="Обязательно"/>

<!--Параметры WPARAM, начиная с # указывают шестнадцатеричные

#FF шестнадцатеричное число

TraySettings строка,TraySettings

-->

<attribute name="wParam" type="Строка/Формирование (шестнадцатеричная)" use="необязательно" default="NULL"/>

<!--Параметры LPARAM, начиная с # указываются шестнадцатеричные

#FF шестнадцатеричное число

TraySettings строка,TraySettings

-->

<attribute name="lParam" type="Строка/Формирование (шестнадцатеричноя)）" use="необязательно" default="NULL"/>

<!--Уведомления только в обозревателе Explorer-->

<attribute name="Explorer" type="логическое значение" use="необязательно" default="False"/>

</complexType>

</element>

<!--

1： Скрыть в Win10 6 папок после нужно обновить конфигурацию проводника, может быть так

<ExplorerNotify Type="Custom" msg="111" wParam="#A220" Explorer="true"/>

2：Скрыть небольшой значок, обновить файл ассоциаций для отображения нового значка.

<ExplorerNotify Type="AssocChanged"/>

3：Закрыть службу netprofm

<ExplorerNotify Type="Cmd" Cmd=”net stop netprofm”/>

4：Обновить настройки проводника Explorer

<ExplorerNotify Type="Custom" msg="1A" lParam="TraySettings"/>

-->

General

Характеристики, используемые для удаления указанных файлов, обычно для удаления мусора.

<element name="General">

<complexType>

<!--Имя пути, вспомогательные функции и переменные среды-->

<attribute name="RootPath" type="строка" use="обязательно"/>

<!--Соответствие типу файла или каталога.-->

<attribute name="Flags" type="строка" use="необязательно" default="Directory|File"/>

<sequence>

<!--Соответствия пути, если нет данного объекта, затем все соответствующие файлы-->

<element name="Query" use="необязательно" default="*"/>

</sequence>

<sequence>

<!--Необходимо исключить путь. Если объект отсутствует, то без список исключений.-->

<element name="Excluded" use="необязательно"/>

</sequence>

</complexType>

</element>

<!--

Пустой каталог C:\123（папка 123 зарезервирована）

<General RootPath= C:\123"/>

Удалить каталог C:\123（не сохранять папку 123）

<General RootPath= C:\">

< Query>123</Query >

</General>

Удалить все файлы *.txt в C:\Temp и защищеные 123.txt и 456.txt

<General RootPath= C:\ Temp" Flags=”File”>

< Query >*.txt</ Query >

< Excluded>123.txt</Excluded>

< Excluded>456.txt</Excluded>

</General>

-->

CScript

Используйте Си сценарии очистки мусора, синтаксические правила Си, обратитесь к Си языку программирования спецификации C99 (доступна только бета-версия).

<element name="CScript">

<complexType>

<!--Сценарий функции исполнения, прототип должен быть

HRESULT WINAPI MyCleanup(DismSession Session, DWORD Flags, UINT64 *CleanUpSpace, DismCallBack CallBack, LPVOID UserData);

-->

<attribute name="ProcName" type="Строка" use="Обязательно"/>

</complexType>

</element>

<!--

< CScript ProcName =” MyCleanup”/>

Добавьте код функции в XML Data/CScript

<Data>

<CScript>

<![CDATA[

#include <Dism++.h>

HRESULT WINAPI MyCleanup(DismSession Session, DWORD Flags, UINT64 *CleanUpSpace, DismCallBack CallBack, LPVOID UserData)

{

If(CleanUpSpace)

{

//Анализ доступных элементов для очистки

//…

//После завершения анализа, вернуться к очистке записей, блока байтов

* CleanUpSpace=1024;

}

else

{

//Запустить очистку

}

//Возвращает 0 если успешно, любое другое значение означает, что операция не удалась

return 0;

}

]]>

</CScript>

<Data>

-->

Custom

Пользовательская очистка, если общие условия не удовлетворены. Нужно написать собственный DLL.

<element name="Custom">

<complexType>

<!--

Необходимо вызвать имя функции

Прототип должен быть

HRESULT (WINAPI*)(DismSession Session, DWORD Flags, UINT64 *CleanUpSpace, DismCallBack CallBack, LPVOID UserData);

-->

<attribute name="ProcName" type="строка" use="обязательно"/>

</complexType>

</element>

Параметры функции обратного вызова:

DismSession Session: сессия образа, эту сессию можно использовать для получения информации об образе.

DWORD Flags：в Dism++ теперь этот параметр не используется, не обращайте внимание.

UINT64 *CleanUpSpace： если CleanUpSpace имеет значение 0, то функция выполняет действия по очистке. Если не 0, только анализ очистки пространства. В конце приблизительный размер использования переменной для возврата.

DismCallBack CallBack： функции Dism++ для отображения прогресса, пути файлов и т. д. Если этот параметр 0, то это указывает на то, что нет обратного вызова.

Функция обратного вызова поддерживает следующие сообщения:

DISM_MSG_PROGRESS - для обработки обратной связи прогресса, текущая информация о ходе процента выполнения, если не используется LPARAM, можно установить в 0.

DISM_MSG_PROCESS - обрабатываемый путь к файлу, отображает строку состояния, wParam = (PWSTR) pszFullPath, LPARAM значение 0.

DISM_MGS_RemoveInfo - отчет пользовательский о файлах, которые необходимо удалить. Сканирование только тогда, когда это сообщение доступно и будет игнорироваться при чистке. WPARAM значение 0, LPARAM = (LPCWSTR) FilePath представляет собой путь, по которому нужно удалить файл. После полученного сообщения, путь к файлу будет отображаться в деталях.

LPVOID UserData: часть функции обратного вызова, обязательно нужно передать в функцию CallBack.

Возвращаемые значения обратного вызова:

Если функция завершается успешно, возвращается S_OK, любое другое значение указывает на ошибку.


3 Передовые методы

3.1 Dism ++ использовать для установки системы

3.2 Интегрирование обновлений в ISO


3.1 Установка системы с Dism++

Установка системы - простой и сложный варианты. Все, что вам нужно для установки системы, это сначала конвертировать ESD в ISO. Поскольку установить систему из ESD - файла нельзя, нужно конвертировать в WIM. Или извлечь в ISO… Основная проблема заключается в том, что многим сложно гибко использовать существующие инструменты. В этом разделе будет приведено несколько примеров, чтобы помочь вам использовать Dism++.

Для ознакомления: Если вы интересуетесь инсайдерскими сборками Windows (начиная с 8.1), то знаете, что большинство таких сборок поставляется через центр обновления в специальном формате Electronic Software Distribution или сокращенно ESD. Расшифровывается формат ESD как электронная система распределения программного обеспечения, а предназначается он для распространения электронных дистрибутивов Windows. Установить систему из ESD-файла нельзя, для этого его сначала необходимо конвертировать в загрузочный образ.

Предисловие

Загрузка в режиме RE

Возможно вы знакомы с PE, но не имели дело с RE. Об RE можно сказать - это почти то же самое PE, что может сделать PE - может сделать и RE. Начиная с Vista и выше системы имеют встроенные RE и мы можем использовать RE для разрешения проблем с неполадками системы без использования PE.

В Dism++ для упрощения использования процесса RE, внедрили режим RE. Его роль - перезапустить систему, затем запустить RE и запустить Dism++.

Режим прост в использовании, нажмите "Меню" - "Восстановить" - "Запуск в среде восстановления Windows". Первое время будет происходить настройка параметров, далее появится диалог "Dism++ будет запущен в среде восстановления Windows. Выполнить

пезагрузку сейчас?", перезагрузка компьютера после того, как вы нажмете ОК.

В режиме RE, Dism++ может отформатировать системный диск. Если вам необходимо установить новую систему, вы не хотите использовать PE, вы можете использовать этот режим.

Поддержка загрузки

Поддержка традиционного BIOS и UEFI

Dism++ полностью поддерживает стандартную традиционную загрузку BIOS и UEFI. Но не поддерживает некоторые нестандартные, типичная система, использующая MBR - диск, не поддерживает загрузку UEFI.

Это связано с тем, что Dism++ автоматической логикой обнаруживает, что системный диск является MBR - форматом и автоматически добавляет загрузку в соответствии с традиционным режимом загрузки BIOS. Вместо этого найден раздел GPT загружен UEFI.

Так, что системный диск является диском MBR, но загружен через UEFI или системный диск является диском GPT, но загружен системой запуска BIOS. В этих случаях результат обработки Dism++ будет неудовлетворительным, в таких случаях рекомендуется вручную настроить загрузку.

Т. е. стиль разделов вашего жесткого диска должен быть настроен для поддержки режима UEFI или традиционного режима совместимости с BIOS.

Загрузка нескольких жестких дисков

Dism++ поддерживает загрузку нескольких жестких дисков со встроенной загрузкой на одном компьютере . Можно настроить индивидуальную загрузку нескольких дисков или использовать общую загрузку. Настройка загрузки нескольких жестких дисков требует ручного вмешательства, потому, что программа не знает, что вам нужно - раздельную или общую загрузку.

Dism++ использует по умолчанию режим раздельной загрузки, для общей загрузки - пользователю необходимо настроить режим, нажмите "Дополнительно" и затем вручную отрегулируйте.

Загрузка скрытого раздела

DISM++ поддерживает загрузку скрытого раздела, пользователям не нужно вручную назначать букву диска. Когда вы добавляете информацию о загрузке, программа может напрямую манипулировать скрытым загрузочным разделом, не назначая букву диска. Особенно подходит пользователям UEFI.

Загрузка VHD/VHDX

DISM++ поддерживает загрузку конфигурации VHD, когда программа обнаруживает, что системный диск является виртуальным диском VHD, автоматически переключится в режим VHD. Стоит отметить, что Windows 7 Ultimate поддерживает загрузку виртуального диска VHD. Кроме того, только системы Windows 8 и более могут использовать VHDX (новый формат виртуальных жестких дисков, появившийся в Windows Server 2012).

Для запуска на классическим BIOS и UEFI нужно, чтобы тип разделаVHD должен быть согласован с типом загрузочного раздела диска, иначе Dism++ не сможет должным образом настроить загрузку. Например, VHD является GPT, запуск диска также должен быть GPT и наоборот.

Установка системы из ISO

ISO является наиболее распространенным носителем систем, DISM++ обеспечивает прямую поддержку ISO. Вы можете использовать ISO напрямую для установки системы, без необходимости монтирования ISO или извлечения из ISO.

Dism++ имеет встроенную технологию виртуализации файлов, может виртуализировать файловый поток в файл. Таким образом Dism++ может непосредственно запустить в ISO install.wim.

Метод использования прост, в меню выберите пункт "Файл" - "Применить образ". Не забудьте отметить "Добавить загрузку". "Формат" - эту опцию используйте в соответствии с вашими потребностями, если вы выберете эту опцию, системный диск будет отформатирован.

На фото выше, система из ISO будет установлена на диск D и диск D будет отформатирован.

Нажмите на правой стороне раскрывающегося окна на целевой образ, вы можете переключить систему, подтвердите и нажмите OK.

Если нужно отформатировать текущий системный диск, вышеуказанные операции должны быть выполнены в RE или других системах, таких как PE.

Установка системы из ESD (включая зашифрованные ESD или UUP ESD)

В последнее время во всех дистрибутивах Windows 8.1 и выше вместо файла install.wim находится файл-образ операционной системы install.esd, также обновления от Windows Update будет на регулярной основе в ESD. В ESD содержатся файлы, необходимые для установки, мы можем напрямую использовать установку системы из ESD. Даже если ESD зашифрован или UUP (Unified Update Platform) сегмент ESD.

Dism++ имеет встроенную технологию виртуализации файлов, расшифровать зашифрованные ESD в памяти и после развертывания системы этот процесс не изменяет исходный файл ESD.

Использование простое, в меню выберите "Файл" - "Применить образ". Не забудьте отметить "Добавить загрузку". "Формат" - эту опцию используйте в соответствии с вашими потребностями, если вы выберете эту опцию, системный диск будет отформатирован.

После развертывания UUP ESD, выберите папки UUP ActionList web.xml (рекомендуется), вы можете напрямую выбрать нужный ESD (например, Professional_zh-cn.esd).

Как показано выше, установка с ISO слегка отличается, в целевом образе необходимо выбрать операционную систему, как показано на рисунке, сделайте выбор установки Windows.

Нажмите на правой стороне раскрывающегося окна на целевой образ, вы можете переключить систему, подтвердите и нажмите OK.

Если нужно отформатировать текущий системный диск, вышеуказанные операции должны быть выполнены в RE или других системах, таких как PE.

Установка системы с использованием технологии Compact

В Windows 10 представлена новая технология сжатия загрузки Compact. С помощью этой технологии происходит сокращение на 1/3 занимаемого пространства, при этом почти не влияя на производительность.

В Dism++ можно использовать монтирование с помощью Compact всех систем от Widows 7 и выше. Программа автоматически настроит диск и извлечет основные загрузочные файлы.

Следует отметить, что при использовании технологии Compact, хост - система должна быть Windows 7 и выше. Кроме того, по умолчанию в Windows 7 не загружается драйвер WofAdk. Перед использованием технологии Compact пользователи Win7 должны зайти в "Опции" - "Настройки" и отметить пункт "Загрузить WofADK драйвер", затем нажать кнопку OK.

Comacpt технология проста в использовании, когда образ будет развернут (поддержка WIM、SWM、ESD、UUP ESD и ISO), отметьте пункты "Compact" и "Добавить загрузку", как показано на следующем рисунке:

После завершения операции, перезагрузите систему, чтобы начать установку системы с Compact технологией.

Установка системы с использованием технологии WIMBoot

Технология WIMBoot позволяет сократить объем занимаемого пространства и в полной мере использовать область резервного копирования и поскольку файл хранится централизованно, это обеспечивает лучшую производительность. Казалось бы, все в порядке, но есть фатальная проблема, длительное применение WIMBoot вызывает рост объема системного диска. И наконец, коэффициент производительности у технологии Compact выше.

Технология WIMBoot является предшественником Compact, поскольку существует проблема растущего объема, пришлось отказаться от дальнейшего использования. В Dism++ рекомендуется использовать приоритетный Compact.

В Dism++ вы можете использовать технологию WIMBoot для установки всех систем, от Widows 7 и выше. Программа автоматически настроит диск и извлечет основные загрузочные файлы.

Следует отметить, что при использовании технологии WIMBoot, хост - система должна быть Windows 7 и выше. Кроме того, по умолчанию в Windows 7 не загружается драйвер WofAdk. Перед использованием технологии WIMBoot пользователи Win7 должны зайти в "Опции" - "Настройки" и отметить пункт "Загрузить WofADK драйвер", затем нажать кнопку OK.

Технология WIMBoot имеет немного больше проблем, чем Compact, сначала вам нужно подготовить wim-файл с типом сжатия WIMBoot.

PS: Хотя Dism++ поддерживает быстро и максимально сжатые wim-файлы в режиме запуска WIMBoot, однако Dism++ должен преобразовать сжатый WIMBoot, а затем продолжить работу, для получения более высокой производительности.

Как показано на скриншоте выше, мы отметили внутри образа ISO Windows 7 Ultimate, выберите сжатый образ WIMBoot и затем экспортируйте в G:\Win7 WIMBoot.wim.

После завершения преобразования в меню нажмите "Файл" - " Применить образ" и разверните WIMBoot, как показано ниже:

Мы только что получили G:\Win7 WIMBoot.wim с использованием технологии WIMBoot, чтобы установить на диск D с опциями "Форматировать" диск и "Добавить загрузку".

Все готово, после завершения операции и перезагрузки вы увидите загруженную систему WIMBoot.


3.2 Интегрирование обновлений в ISO

 Top Previous

Вы устали от того, что каждый раз нужна установка исправлений, также хотелось бы знать коэффициент эффективности обновлений - вам не приходило чувство, что лучше эти заплатки ставить накоплением?

Dism использует обновления от Microsoft и должен собрать свой собственный пакет, выходят новые обновления почти каждый месяц и необходимо заменить ими старые.

Теперь Dism++ настроен на Центр обновления Windows, экспортирует обновления базы данных непосредственно с сервера WSUS, автоматический получает последние обновления, удаляет устаревшие, CBS определяет, требуется ли данное обновление системе.

Давайте посмотрим на то, как это использовать.

Извлечение ISO

Для того, чтобы иметь дело с ISO внутри install.wim сначала нужно разархивировать файл ISO на жестком диске. Можно использовать программы сжатия, такие как 7z, щелкните правой кнопкой мыши и в всплываюзем меню выбрать "Разархивировать". Предположим, что мы извлекаем в D:\Temp.

Смонтировать install.wim

Чтобы Dism++ идентифицировал систему нужно смонтировать install.wim. Монтировать образ очень просто, в меню выберите "Файл" - "Монтировать образ".

Путь к файлу образа задаем D:\Temp\Sources\install.wim. Путь монтирования, который мы установили D:\Mount (должен существовать). Если вам нужно настроить образ, выполните щелчок на целевом образе и включите монтирование.

(Например, я выбрал Win7 Ultimate, смотрите ниже)

Далее нажмите кнопку ОК.

Поиск и установка обновлений

Откройте сессию, затем нажмите кнопку управления обновлениями, нажмите "Анализ". Когда сканирование завершится программа выдаст список всех доступных обновлений, выберите нужные обновления, выделите строку, появятся советы по установке: DISM++ обновит кэш в папке программы "Config\UpdateCache", во время установки Dism++ будет непосредственно использовать последнее кэширование.

Первая открытая сессия.

В пункте "Обновления" щелкните "Анализ".

После завершения сканирования, выберите пункты установки обновления, затем нажмите установку, далее терпеливо ждите завершения установки ......

Советы:

1: Если вам не нравится, что Win10 поставляется с кучей Appx, вы можете удалить устаревшие Аррх. Appx удаляется из пакета установки системы, после установки системы в ней также не будет Appx

2: После установки обновлений повторите сканирование. Потому, что обновление поставляется пакетами, требуется несколько раз сканировать установку, чтобы убедиться в завершении установки обновлений.

3: После установки обновлений попытка очистка папки WinSxS может привести к неудаче. Это происходит потому, что обновление зависает (находится в ожидании), так как оно может быть установлено только на виртуальную машину.

Сохранение install.wim

После того, как операция прошла успешно, вы можете нажать в меню "Файл" - "Сохранить образ" и выбрать перезапись сохранения. Нажмите "Размонтировать образ" после завершения.

Оптимизация размера файла Wim

Как сохранить образ от введения нежелательных данных, которые увеличивают размер файла. Чтобы сохранить оптимальный размер, нажмите в меню «Файл» - «Открыть файл образа». Экспортируйте обработанный образ в D:\Temp\Sources\install2.wim, затем переименуйте D:\Temp\Sources\install2.wim в install.wim..

Сохранить в ISO

Frog plug-in Dism++ предоставляет собой генератор ISO, он может создавать ISO-образы с двойной загрузкой (также поддерживает традиционную загрузку BIOS и UEFI).

Как показано на рисунке, мы ставим D:\Temp, сохранить содержимое D:\Win7 new.iso.

Совет: Если вы хотите работать с Win7 Home Edition, Professional Edition и Ultimate, то я предлагаю вам работать с домашней версией Home Edition, а другие версии можно сделать обновлением версии системы. Обновления можно интегрировать в несколько версий одновременно, Dism++ поддерживает одновременное интегрирование обновлений в несколько образов.