Award-BIOS

Здесь описываются практически все параметры, устанавливаемые в программе SETUP для BIOS фирмы «AWARD Software International Inc.», которая в начале 1999 года стала частью фирмы «Phoenix Technologies Ltd». В конкретной материнской плате каких-то из описываемых параметров может и не быть. Одни и те же параметры могут называться по разному в зависимости от производителя материнской платы, поэтому здесь в некоторых случаях приведено несколько вариантов. Для просмотра и корректировки установок «Setup BIOS» вашего компьютера можно воспользоваться программой «TweakBIOS». С помощью этой программы можно изменять установки в BIOS в процессе работы, а также увидеть, правильно ли программа «Setup BIOS» выполнила установки. Скачать её можно также здесь (vers. 1.53beta).

ПРИМЕЧАНИЕ: Программа запускается и под различными «Windows», но использовать ее можно ТОЛЬКО в DOS.

Начиная с «PhoenixBIOS 4.0 revision 6» изменился вид окна SETUP BIOS на ряде моделей материнских плат. Так как при этом изменились названия разделов и в них созданы подразделы, нельзя дать однозначные соответствия между старыми и новыми разделами. Поэтому в новых BIOS'ах следует искать просто названия параметров, которые в основном не изменились. Немного изменилась и звуковая индикация ошибок в системе (см. «Ошибки и сигналы»).

СОДЕРЖАНИЕ

  • Раздел «STANDARD CMOS SETUP» («MAIN»)

    • Primary Master

    • Type

    • Translation Method

    • Cylinders

    • Head

    • Sector

    • CHS Capacity

    • Maximum LBA Capacity

    • Multi-Sector Transfers

    • SMART Monitoring

    • PIO Mode

    • ULTRA DMA Mode

    • Set Device As

    • Primary Slave

    • Secondary Master

    • Secondary Slave

    • Halt On

  • Раздел «BIOS FEATURES SETUP» («ADVANCED»)

    • Virus Warning

    • Boot Virus Detection

    • CPU Internal Cache/External Cache

    • CPU Level 1 Cache/CPU Level 2 Cache

    • CPU Level 2 Cache ECC Check

    • BIOS Update

    • CPU Fast String

    • HDD S.M.A.R.T Capability

    • Deturbo Mode

    • Quick Power On Self Test

    • Boot Sequence

    • Boot Up System Speed

    • Gate A20 Option

    • Swap Floppy Drive

    • Boot Up Floppy Seek

    • Boot Up NumLock Status

    • Typematic Rate Setting

    • Typematic Rate (Chars/Sec)

    • Typematic Delay (Msec)

    • OS/2 Onboard Memory > 64MB

    • PS/2 Mouse Function Control

    • PCI/VGA Palette Snoop

    • Video ROM BIOS Shadow

    • Floppy Disk Access Control (R/W)

    • Report No FDD For WIN 95

    • Delay IDE Initial

    • MPS 1.4 Support

  • Раздел «CHIPSET FEATURES SETUP» («CHIP CONFIGURATION»)

    • Установка параметров для FPM DRAM, EDO DRAM и Synchronous DRAM

    • AUTO Configuration

    • DRAM RAS# Precharge Time

    • DRAM R/W Leadoff Timing

    • DRAM RAS to CAS Delay

    • DRAM Read Burst Timing

    • Speculative Leadoff

    • Turn-Around Insertion

    • Data Integrity (PAR/ECC)

    • DRAM ECC/PARITY Select

    • Fast RAS# to CAS# Delay

    • SDRAM Configuration

    • SDRAM RAS Precharge Time

    • SDRAM (CAS Lat/RAS-to-CAS)

    • SDRAM CAS# Latency

    • SDRAM CAS to RAS Delay

    • SDRAM Banks Close Policy

    • DRAM Idle Timer

    • Snoop Ahead

    • Host Bus Fast Data Ready

    • Refresh RAS# Assertion

    • MA Wait State

    • SDRAM Speculative Read

    • Spread Spectrum Modulated

    • Установка параметров кэширования

      • System BIOS Cacheable

      • Video BIOS Cacheable

    • Конфигурирование шин PCI, AGP, портов ввода/вывода и установка параметров IDE контроллера

      • Video Memory Cache Mode

      • Graphics Aperture Size

      • PCI 2.1 Support

      • 8 Bit I/O Recovery Time

      • 16 Bit I/O Recovery Time

      • Memory Hole At 15M-16M

      • Peer Concurrancy

      • Chipset Special Features

      • Passive Release

      • PCI Delayed Transaction

      • Parallel Port Mode (ECP+EPP)

      • Parallel Port Mode

      • ECP DMA Select

      • Onboard PCI IDE Enable

      • Onboard FDC Controller

      • Выбор режима работы каждого диска

  • Раздел «PnP/PCI CONFIGURATION SETUP»

    • PNP OS Installed

    • Resources Controlled By

    • Reset Configuration Data

    • IRQ n Assigned to

    • DMA n Assigned to

    • PCI IRQ Activated by

    • PCI IDE IRQ Map to

    • PCI Slot IDE 2nd Channel

    • IRQ n Used By ISA

    • DMA n Used By ISA

    • ISA MEM Block BASE

    • Onboard AHA BIOS

    • ONB AHA BIOS First

    • ONB SCSI SE Term

    • ONB SCSI LVD Term

    • SYMBIOS SCSI BIOS

    • PCI Latency Timer

    • USB IRQ

    • VGA BIOS Sequence

    • USB Keybord Support Via

  • Раздел «POWER MANAGEMENT SETUP»

    • Power Management

    • ACPI function

    • Video Off Option

    • Video Off Method

    • Suspend Switch

    • Doze Speed

    • Stby Speed

    • HDD Power Down

    • Doze Mode

    • Standby Mode

    • Suspend Mode

    • IRQ 3 (Wake-up)

    • IRQ 4 (Wake-up)

    • IRQ 8 (Wake-up)

    • IRQ 12 (Wake-up)

    • IRQ 3 (COM2)

    • IRQ 4 (COM1)

    • IRQ 5 (LPT2)

    • IRQ 6 (Floppy Disk)

    • IRQ 7 (LPT1)

    • IRQ 8 (RTC Alarm)

    • IRQ 9 (IRQ2 Redir)

    • IRQ 10 (Reserved)

    • IRQ 11 (Reserved)

    • IRQ 12 (PS/2 Mouse)

    • IRQ 13 (Coprocessor)

    • IRQ 14 (Hard Disk)

    • IRQ 15 (Reserved)

    • PWR Button < 4 Secs (он же Soft-of By PWR-BTTN)

    • PWR Up On Modem Act (он же Resume by Ring)

    • IRQ8 Resume by Suspend

    • ZZ Active In Suspend

    • Wake On LAN

    • AC PWR Loss Restart

    • Automatic Power Up

    • Chassis Fan Speed (xxxxRPM)

    • CPU Fan Speed (xxxxRPM)

    • Power Fan Speed (xxxxRPM)

    • CPU Temperature

    • MB Temperature

    • Voltage Monitor

    Раздел «STANDARD CMOS SETUP» («MAIN»)

    Определение параметров устройств, подключенных к IDE контроллеру: (В ряде вариантов BIOS это просто установка геометрии жесткого диска. В BIOS, появившихся после августа 1999 года, параметры определяют несколько установочных значений в зависимости от типа IDE устройства. Здесь приводится описание этих параметров именно для новых BIOS.)

    Primary Master (Master на первом канале IDE) — в ряде вариантов BIOS просто установка геометрии жесткого диска. В BIOS, появившихся после августа 1999 года, параметр определяет несколько установочных значений в зависимости от типа IDE устройства. После выбора Primary Master возможна установка следующих параметров (их количество и названия могут изменяться в зависимости от типа IDE устройства):

    • Type (тип устройства) — указывается тип IDE устройства. Может принимать значения:

      • Auto — автоматическое определение BIOS типа IDE устройства

      • None — запрещает любое IDE устройство

      • User Type HDD — разрешает установку параметров жесткого диска пользователем

      • CD-ROM — сообщает BIOS'у о подключении CD-ROM

      • LS-120 — сообщает BIOS'у о подключении LS-120

      • ZIP-100 — сообщает BIOS'у о подключении ZIP-100

      • MO — сообщает BIOS'у о подключении IDE магнитооптического накопителя

      • Other ATAPI Device — сообщает BIOS'у о подключении не указанного выше устройства

    • Translation Method (метод трансляции геометрии) — определяет метод преобразования аппаратной геометрии IDE накопителя в геометрию, понятную для различных операционных систем. Может принимать значения:

      • LBA — Logical Block Addressing (логическая адресация блока) — наиболее популярный метод, обязательный для дисков объемом более 504 MBytes

      • Match Partition Table (в соответствии с таблицей раздела) — этот параметр следует выбрать в том случае, если к данному IDE каналу подключается жесткий диск с уже установленной операционной системой и способ трансляции, примененный для этого жесткого диска, неизвестен.

      • Normal (обычный) — оставляет аппаратную геометрию жесткого диска без изменений.

      • Large (большой) — метод трансляции, используемый достаточно редко и применяемый, в частности, для некоторых вариантов UNIX.

      • Manual (ручная установка) — позволяет установку параметров жесткого диска вручную.

    • Cylinders (цилиндры) — здесь указывается количество цилиндров жесткого диска. Параметр может быть изменен только в случае установки значения Manual в Translation Method.

    • Head (головка) — здесь указывается количество головок жесткого диска. Параметр может быть изменен только в случае установки значения Manual в Translation Method.

    • Sector (сектор) — здесь указывается количество секторов жесткого диска. Параметр может быть изменен только в случае установки значения Manual в Translation Method.

    • CHS Capacity (емкость диска, определенная как произведение количества цилиндров на количество головок и на количество секторов) — здесь указывается емкость жесткого диска. Параметр не может быть изменен.

    • Maximum LBA Capacity (максимальная емкость диска в режиме LBA) — здесь указывается емкость жесткого диска как если бы метод трансляции был LBA. Параметр не может быть изменен.

    • Multi-Sector Transfers (передача данных с нескольких секторов диска) — параметр определяет количество секторов, передаваемых как блок данных. Как правило, чем больше секторов в блоке, тем выше скорость обмена. Может принимать значения:

      • Disabled — запрещает блоковую передачу. Обмен идет по одному сектору.

      • 2, 4, 6, 8, 16, 32 — возможные значения количества секторов в блоке

      • Maximum — оставляет определение количества секторов в блоке на усмотрение BIOS

    • SMART Monitoring (Возможность S.M.A.R.T. диагностики) — позволяет разрешать/запрещать возможность диагностики состояния жесткого диска в соответствии с требованиями стандарта S.M.A.R.T. При разрешении параметра и нарушении нормального функционирования жесткого диска BIOS выдает на экран соответствующее сообщение до появления таблицы с характеристиками компьютера. Следует учесть, что разрешение этого параметра снизит производительность компьютера на несколько процентов. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • PIO Mode (режим программируемого ввода/вывода) — здесь можно указать режим PIO для данного накопителя. Как правило, BIOS правильно определяет максимально быстрый режим для устройства. Изменение параметра иногда бывает необходимо при подключении старых накопителей, не всегда выполненных в полном соответствии со стандартами. Обычно в этом случае значение PIO следует уменьшить. Параметр может принимать значения от 0 до 4.

    • ULTRA DMA Mode (режим Ultra DMA) — параметр аналогичен PIO Mode, только для режимов UltraDMA. Параметр может принимать значения от 0 до 4, а также Disabled (режим UltraDMA запрещен).

    • Set Device As (установить устройство как ...) — параметр позволяет указать BIOS, какой вид накопителя на сменном диске он должен представить операционной системе. Это поле появляется только при выборе соответствующего устройства в параметре Type. Может принимать значения:

      • Auto — BIOS сам определяет представление устройства

      • Floppy — устройство представляется как гибкий диск

      • Hard Disk — устройство представляется как жесткий диск

    Primary Slave (Slave на первом канале IDE) — все значения аналогичны Primary Master.

    Secondary Master (Master на втором канале IDE) — все значения аналогичны Primary Master.

    Secondary Slave (Slave на втором канале IDE) — все значения аналогичны Primary Master.

  • Halt On (остановка на ...) — здесь указывается, нужно ли останавливать запуск компьютера в случае некоторых, обнаруженных BIOS, ошибок. Может принимать значения:

    • All Errors (все ошибки) — выбор этого значения приводит к остановке при любой ошибке.

    • No Errors (без ошибок) — выбор этого значения не вызывает остановки при любой ошибке.

    • All but Keyboard (все ошибки, кроме клавиатуры) — выбор этого значения приводит к остановке при любой ошибке, кроме отсутствия или неисправности клавиатуры.

    • All but Disk (все ошибки, кроме диска) — выбор этого значения приводит к остановке при любой ошибке, кроме отсутствия или неисправности жесткого диска.

    • All but Disk/Keyboard (все ошибки, кроме клавиатуры и/или диска) — выбор этого значения приводит к остановке при любой ошибке, кроме отсутствия или неисправности клавиатуры и/или диска.

    Раздел «BIOS FEATURES SETUP» («ADVANCED»)

    • Virus Warning (Предупреждение о вирусе) — разрешение этого параметра запрещает любую запись в загрузочный сектор жесткого диска без разрешения пользователя. Он введен для защиты от так называемых boot-вирусов, поражающих загрузочный сектор. Рекомендуется всегда разрешать этот параметр, но следует учесть, что, например, Windows 95 при установке "зависает", если Virus Warning установлен в Enable (при этом на экране появляется черный квадрат). Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Boot Virus Detection (Определение вируса в загрузочном секторе) — смысл этого параметра сильно отличается от Virus Warning. Идея заключается в следующем — если этот параметр запрещен, то до загрузки операционной системы BIOS переписывает загрузочный сектор во флэш-память и сохраняет его там. После установки параметра в значение Enabled BIOS не будет загружать систему с жесткого диска, если содержимое boot-сектора отличается от сохраненного в памяти. Далее, по усмотрению пользователя, возможно либо загрузить систему с жесткого диска, либо с дискеты. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • CPU Internal Cache/External Cache (Внутренний/Внешний кэш процессора) — разрешается/запрещается внутренний или внешний кэш процессора. Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • CPU Level 1 Cache/CPU Level 2 Cache (Кэш процессора первого уровня/Кэш процессора второго уровня) — разрешается/запрещается кэш первого уровня или кэш процессора второго уровня для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • CPU Level 2 Cache ECC Check (Включить ECC для кэш-памяти процессора 2 уровня) — параметр может присутствовать только для плат с процессорами архитектуры Pentium II. Разрешать его есть смысл только в том случае, если установленный процессор класса Pentium II имеет кэш-память второго уровня с возможностью ECC контроля. В некоторых процессорах допущена ошибка и включение этого режима может привести к нестабильной работе компьютера. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • BIOS Update (Обновление BIOS) — процессоры семейства P6 (Pentium Pro, Pentium II, Celeron, Xeon и т.д.) имеют особый механизм, называемый "программируемым микрокодом", который позволяет исправить некоторые виды ошибок, допущенных при разработке и/или изготовлении процессоров за счет изменения микрокода. Обновления микрокода остаются в BIOS и загружаются в процессор после включения компьютера и запуска программы BIOS. Именно поэтому BIOS для материнских плат с Pentium II и выше необходимо регулярно обновлять. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • CPU Fast String (Быстрые операции со строками) — Разрешение этого параметра позволяет использовать некоторые специфические особенности архитектуры семейства Pentium Pro (Pentium II, Deshutes и т.п.), в частности, возможность кэширования операций со строками. Надо только понимать, что и в самой программе должны быть выполнены условия для включения этого механизма. Эти условия указаны в документации на любой процессор данного семейства. Параметр рекомендуется оставлять в состоянии "Разрешено". Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • HDD S.M.A.R.T Capability (Возможность S.M.A.R.T диагностики) — позволяет разрешать/запрещать возможность диагностики состояния жесткого диска в соответствии с требованиями стандарта S.M.A.R.T. Авторы BIOS, к сожалению, не раскрывают механизма функционирования S.M.A.R.T диагностики в BIOS, поэтому не совсем понятно, каким образом обрабатывается информация от жесткого диска, так как граничные значения параметров жесткого диска зависят от конкретного производителя. При разрешении параметра и нарушении нормального функционирования жесткого диска BIOS выдает на экран соответствующее сообщение до появления таблицы с характеристиками компьютера. Следует учесть, что разрешение этого параметра снизит производительность компьютера на несколько процентов. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Deturbo Mode (Режим deturbo) — при разрешении этого параметра сигнал FLUSH# становится активным и никакие данные после этого не кэшируются процессором в свой внутренний кэш (кэш первого уровня) процессорами архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Разрешение этого параметра следует использовать только при необходимости сознательно замедлить работу компьютера. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Quick Power On Self Test (быстрый тест компьютера после включения питания) — разрешение этого параметра приводит к значительному сокращению времени на начальное тестирование компьютера BIOS'ом, особенно при значительных объемах оперативной памяти. Следует только учесть, что память, например, в этом случае не тестируется, а только проверяется ее размер. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Boot Sequence (последовательность загрузки) — параметр устанавливает последовательность опроса устройств, с которых может быть загружена операционная система. Эти устройства обозначаются либо буквами для физических жестких дисков и обычных дисководов, либо названием устройства — CD-ROM для накопителей CD-ROM, LS для накопителей a:drive на 120 Mb или ZIP для накопителей ZIP IDE на 100 Mb. Для современных версий возможные значения могут выглядеть так: A,C; C only; CD-ROM, C; C, A; D, A; LS/ZIP, C.

    • Boot Up System Speed (скорость системы после загрузки) — скорость системной шины и соответственно, процессора после включения компьютера. Параметр используется для искуственного снижения скорости компьютера из-за старых программ и/или плат расширения. Может принимать значения:

      • High — номинальная скорость процессора и номинальная частота системной шины

      • Low — пониженная скорость процессора и частота системной шины

    • Gate A20 Option (вариант включения шины A20) — параметр позволяет управлять способом включения адресной шины A20 и, тем самым, обращаться к памяти за 1 мегабайтом. Этот параметр в современных платах не управляется пользователем и всегда в значении Fast. Может принимать значения:

      • Fast — управление осуществляется chipset, что повышает скорость работы

      • Normal — управление осуществляется через контроллер клавиатуры

    • Swap Floppy Drive (перестановка дисководов) — если разрешен, то дисководы A и B как бы меняются местами. Имеет смысл только при наличии 2-х дисководов в компьютере. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Boot Up Floppy Seek (поиск загрузочного дисковода после включения компьютера) — если этот параметр разрешен, то BIOS обращается к каждому дисководу на предмет распознавания его формата (40 или 80 дорожек он поддерживает). Поскольку уже с 1993 года дисководы на 40 дорожек не выпускаются, не следует разрешать этот параметр, так как BIOS каждый раз будет тратить несколько секунд на выяснение формата дисковода. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Boot Up NumLock Status (включение цифровой клавиатуры по включению компьютера) — разрешение этого параметра включает индикатор NumLock и цифровая клавиатура генерирует коды цифр и знаков, в противном случае генерируются коды стрелок, Ins, Del и т.д. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Typematic Rate Setting (установка скорости ввода символов) — разрешает или запрещает установку скорости повторения ввода символов клавиатурой при нажатой клавише. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Typematic Rate (Chars/Sec) (частота повторения симв/сек) — параметр оказывает действие только в том случае, если разрешен Typematic Rate Setting. Частота повторения имеет ряд фиксированных значений, которые и может принимать этот параметр:

      • 6, 8, 10,12, 15, 20, 24 или 30

    • Typematic Delay (Msec) (задержка повторения в msec) — устанавливает значение задержки от момента нажатия клавиши до начала повторения символа клавиатурой. Оказывает действие только в том случае, если разрешен Typematic Rate Setting. Значение может быть выбрано из ряда:

      • 250, 500, 750 или 1000

    • PS/2 Mouse Function Control (управление функциями порта мыши PS/2) — разрешение этого параметра отдает IRQ12 только для порта мыши PS/2. В противном случае, при отсутствии подключенной к компьютеру мыши с интерфейсом PS/2, IRQ12 свободно для других устройств. Рекомендуется устанавливать значение Auto. Может принимать значения:

      • Enabled — разрешено и IRQ12 занято.

      • Auto — BIOS определяет присутствие или отсутствие PS/2 мыши.

    • OS/2 Onboard Memory > 64MB (выбор значения для OS/2, если памяти больше, чем 64 Mb) — требует разрешения при выполнении двух условий — в компьютере установлено больше, чем 64 Mb памяти и используется OS/2 в качестве операционной системы. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • PCI/VGA Palette Snoop (корректировка палитры VGA видеокарты на PCI) — параметр следует разрешать только в том случае, если на экране некорректно отображаются цвета. Как правило, этот эффект может возникать при использовании таких нестандартных устройств, как MPEG карты, 3D ускорители и т.п. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Video ROM BIOS Shadow (видео BIOS в память) — разрешение этого параметра приводит к переносу видео BIOS из ПЗУ (постоянного запоминающего устройства) на видеокарте в основную память компьютера, что значительно ускоряет работу с видео BIOS (это необходимо и видно в DOS). Ускорение объясняется как и тем, что обращение к ПЗУ намного медленнее, чем к ОЗУ, так и тем, что обращение к ПЗУ, как правило, выполняется в 8-ми разрядной сетке, а к ОЗУ — 32-х или 64-х сетке. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Floppy Disk Access Control (R/W) (управление чтением/записью на гибкий диск) — разрешение этого параметра позволяет записывать информацию на дискету, в противном случае дискету можно читать. Параметр следует использовать для защиты от несанкционированного копирования с компьютера. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Report No FDD For WIN 95 (сообщение об отсутствии накопителя на гибких дисках для Windows 95) — параметр используется, как правило, в сетевых компьютерах без флоппи-дисковода или в случае необходимости размещения в компьютере устройства, для которого не хватает прерывания. При выборе Yes и одновременном выборе Disable в параметре Onboard FDC Controller, Windows 95 освободит IRQ 6, занимаемое контроллером флоппи-дисковода, для использования другими устройствами. Совместное разрешение этих параметров обязательно в компьютерах без дисководов (используемых как сетевые в организациях) для уменьшения времени запуска Windows 95. Может принимать значения:

      • Yes — освободить IRQ 6

      • No — не освобождать (независимо от того, есть ли флоппи-дисковод или нет)

    • Delay IDE Initial (задержка инициализации IDE устройства) — в данном параметре устанавливается значение времени (в секундах) в течении которого IDE устройство не будет опрашиваться BIOS'ом после включения питания или сброса. Ненулевое значение параметра рекомендуется устанавливать только в случае применения каких-либо старых жестких дисков или приводов CD-ROM. Параметр принимает значения в диапазоне от 0 до 30 сек., в зависимости от производителя материнской платы.

    • MPS 1.4 Support(поддержка режима MPS 1.4) — параметр появляется только в BIOS материнских плат, допускающих установку нескольких процессоров. Выбор режима влияет на распределение ресурсов компьютера. При запрещении устанавливается режим MPS 1.1. Строго говоря, для различных Windows можно устанавливать любое значение (даже лучше Disable), а для Novell Netware рекомендуется Enable. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    Раздел«CHIPSET FEATURES SETUP» («CHIP CONFIGURATION»)

    Установка параметров для FPM DRAM, EDO DRAM и Synchronous DRAM

    • AUTO Configuration (автоматическая конфигурация) — имеет 3 значения

      • :

      • 60 ns — устанавливает парамеры доступа для DRAM с быстродействием 60 ns

      • 70 ns — то же для памяти с быстродействием 70 ns

      • Disabled (запрещена) — позволяет установить любые возможные параметры доступа к DRAM памяти

    • DRAM RAS# Precharge Time (время предварительного заряда по RAS) — Эта функция позволяет определить количество тактов системной шины для формирования сигнала RAS. Уменьшение этого значение увеличивает быстродействие, но чрезмерное для конкретной памяти уменьшение может привести к потере данных. Принимает значения:

      • 3

      • 4

    • DRAM R/W Leadoff Timing (число тактов при подготовке выполнения операции чтения/записи) — определяет число тактов на шине до выполнения любых операций с DRAM. Параметр может принимать значения:

      • 8/7 — восемь тактов для чтения и семь тактов для записи

      • 7/5 — семь тактов для чтения и пять тактов для записи

    • DRAM RAS to CAS Delay (задержка между RAS и CAS) — Во время доступа к памяти обращения к столбцам и строкам выполняются отдельно друг от друга. Этот параметр и определяет отстояние одного сигнала от другого. Параметр может принимать значения:

      • 3 — три такта задержки

      • 2 — два такта задержки

        • Уменьшение значения увеличивает быстродействие.

    • DRAM Read Burst Timing (время пакетного чтения памяти) — Запрос на чтение и запись генерируется процессором в четыре раздельные фазы. В первой фазе инициируется обращение к конкретной области памяти, а в оставшихся происходит собственно чтение данных. Параметр может принимать значения:

      • x2222 — два такта задержки

      • x3333 — три такта задержки

      • x4444 — четыре такта задержки

        • Уменьшение суммарного количества тактов увеличивает быстродействие.

    • Speculative Leadoff (опережающая выдача сигнала чтения) — разрешение этого параметра позволяет выдавать сигнал чтения немного ранее, чем адрес будет декодирован. Этот прием снижает общие затраты времени на операцию чтения. Другими словами, процессор будет инициировать сигнал чтения одновременно с генерацией того адреса, где находятся необходимые данные. Сигнал чтения воспринимается контроллером DRAM и, если параметр Speculative Leadoff разрешен, то контроллер выдаст сигнал чтения до завершения декодирования адреса. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Turn-Around Insertion (задержка между циклами) — Если этот параметр разрешен (Enabled), то между двумя последовательными циклами обращения к памяти включается один дополнительный такт. Разрешение уменьшает быстродействие, но увеличивает достоверность при операциях чтения/записи. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Data Integrity (PAR/ECC) (целостность данных) — разрешает/запрещает контроль памяти на ошибки. Вид контроля устанавливается параметром DRAM ECC/PARITY Select. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • DRAM ECC/PARITY Select (режим коррекции ошибок/проверка по четности) — Параметр появляется только в тех материнских платах, в которых chipset поддерживает ECC и только в том случае, если установлены модули памяти с истинной четностью. В некоторых вариантах BIOS этим параметром может устанавливаться только вид проверки, а разрешение на проверку устанавливается параметром Data Integrity (PAR/ECC). Такие планки часто называют также 36-разрядными. Может принимать значения:

      • Parity — в случае возникновения ошибки на монитор выдается сообщение о сбое по четности в памяти и работа компьютера останавливается

      • ECC -Error Control Correction — в случае возникновения одиночной ошибки она исправляется и работа продолжается. Если имеет место не одиночная ошибка, то работа компьютера также прекращается. Следует только учесть, что по данным Intel, скорость обмена с памятью при включении этого режима уменьшается приблизительно на 3%

    • Fast RAS# to CAS# Delay (интервал между RAS и CAS) — При регенерации памяти строки и столбцы адресуются отдельно, поэтому этот параметр устанавливает интервал между сигналами RAS и CAS.

    • SDRAM Configuration (Конфигурация SDRAM) — параметром определяется, должна ли программа BIOS сама определять временные характеристики доступа к памяти на основании информации из блока SPD или разрешить это сделать пользователю. Может принимать значения:

      • By SPD — параметры доступа устанавливаются по SPD

      • 7 ns (143 Mhz) — параметры доступа устанавливаются BIOS как для памяти с временем доступа 7 ns и частотой шины 143 MHz

      • 8 ns (125 Mhz) — параметры доступа устанавливаются BIOS как для памяти с временем доступа 8 ns и частотой шины 125 MHz

      • Disabled — устанавливаются пользователем

    • SDRAM RAS Precharge Time (Cинхронная память — время предварительного заряда) — параметр позволяет определять быстрое или медленное накопление заряда по RAS до начала цикла регенерации памяти. Установка значения Fast увеличивает быстродействие, но Slow повышает стабильность работы компьютера, поэтому значение Fast следует устанавливать в случае уверенности в качестве памяти. Может принимать значения:

      • Fast — быстро

      • Slow — медленно

    • SDRAM (CAS Lat/RAS-to-CAS ) (Cинхронная память — задержка CAS/От RAS к CAS) — этот параметр позволяет комбинировать между длительностью сигнала CAS и задержкой между сигналами RAS и CAS. Значение этого параметра зависит от характеристик SDRAM, примененной в материнской плате и от быстродействия процессора. Поэтому изменять этот параметр стоит крайне осторожно. Может принимать значения:

      • 2/2

      • 3/3

    • SDRAM CAS to RAS Delay (задержка между CAS и RAS) — параметр определяет значение задержки после выдачи сигнала RAS до появления сигнала CAS для синхронной памяти. Чем меньше это значение, тем быстрее доступ к памяти. Тем не менее изменять его следует осторожно. Параметр может принимать значения:

      • 3 — три такта задержки

      • 2 — два такта задержки

    • SDRAM CAS# Latency (задержка CAS для SDRAM) — Устанавливает значение задержки выдачи сигнала CAS для SDRAM. Меньшее значение увеличивает производительность системы. Рекомендуется устанавливать меньшее значение для SDRAM с быстродействием 10 nc или лучше.Может принимать значения:

      • 2T

      • 3T

    • SDRAM Banks Close Policy (правила закрытия банков SDRAM памяти) — параметр был введен для плат с набором 440LX из-за того, что память с 2-х банковой организацией некорректно работает в этих платах, если параметры доступа к банкам памяти установлены по умолчанию. В наборе 430TX этого не требовалось, так правила доступа для различной памяти были одинаковы. Изменять установки BIOS по умолчанию для этого параметра следует только в случае нестабильной работы памяти. Может принимать значения:

      • Page Miss — используется для двухбанковой памяти

      • Arbitration — для памяти из 4-х банков

    • DRAM Idle Timer (Таймер пассивного состояния памяти) — этим параметром устанавливается время (в тактах) до закрытия всех открытых страниц памяти. Влияет как на EDO так и на SDRAM память. Может принимать значения 0, 2, 4, 8, 10, 12, 16, 32.

    • Snoop Ahead (Предвидение) — разрешение этогопараметра позволяет потоковый обмен данными между PCI и памятью. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Host Bus Fast Data Ready (Быстрая готовность данных на шине) — разрешение этого параметра позволит снимать данные с шины одновременно с их выборкой. В противном случае данные будут удерживаться на шине один дополнительный такт. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Refresh RAS# Assertion (задание RAS для регенерации) — Этим параметром устанавливается количество тактов (т.е. длительность RAS) для цикла регенерации. Принимаемые значения определяются качеством памяти и набором микросхем (chipset). Меньшее значение увеличивает производительность.

    • MA Wait State (такты ожидания до чтения памяти) — параметр позволяет установить или снять дополнительный такт ожидания до начала чтения памяти. Для памяти типа EDO один такт всегда есть по умолчанию и установка значения Slow добавляет еще один такт ожидания. Для SDRAM нет такта ожидания по умолчанию и установка Slow один такт вводит. Может принимать значения:

      • Slow — добавляется один такт

      • Fast — нет дополнительного такта ожидания

    • SDRAM Speculative Read (SDRAM опережающее чтение) — разрешение этого параметра позволяет выдавать сигнал чтения немного ранее, чем адрес будет декодирован. Этот прием снижает общие затраты времени на операцию чтения. Другими словами, процессор будет инициировать сигнал чтения одновременно с генерацией того адреса, где находятся необходимые данные. Сигнал чтения воспринимается контроллером DRAM и, если параметр SDRAM Speculative Read разрешен, то контроллер выдаст сигнал чтения до завершения декодирования адреса. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Spread Spectrum Modulated (Спред модулированного спектра) — разрешение этого параметра позволяет уменьшить электромагнитное излучение от компьютера за счет уменьшения значения выбросов сигнала тактового генератора. Уменьшение может достигать 6%. Следует заметить, что это может отрицательно отразиться на работе чувствительных к форме сигнала устройств, например, жестких дисках с интерфейсом Fast Wide SCSI, поэтому параметр рекомендуется разрешать только при испытаниях компьютеров на электромагнитную совместимость. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    Установка параметров для кэширования

    • System BIOS Casheable (кэширование области BIOS системы) — Разрешение этого параметра приводит к появлению возможности кэширования области памяти по адресам системного BIOS с F0000H по FFFFFH в кэш-память. Параметр будет использован только в том случае, если использование кэш-памяти разрешено в разделе BIOS Features Setup. Если какая-либо программа попытается выполнить операцию записи в эти адреса, то система выдаст сообщение об ошибке. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Video BIOS Cacheable (кэширование области BIOS видекарты) — Разрешение этого параметра приводит к появлению возможности кэширования области памяти по адресам BIOS видеокарты с C0000H по C7FFFH в кэш-память. Параметр будет использован только в том случае, если использование кэш-памяти разрешено в разделе BIOS Features Setup. Если какая-либо программа попытается выполнить операцию записи в эти адреса, то система выдаст сообщение об ошибке. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    Конфигурирование шин PCI, AGP, портов ввода/вывода и установка параметров IDE контроллера

    • Video Memory Cache Mode (Режим кэширования для видеопамяти) — параметр действителен только для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). В процессоре Pentium Pro была предусмотрена возможность изменять режим кэширования в зависимости от конкретной области памяти через специальные внутренние регистры, называемые Memory Type Range Registers — MTRR. С помощью этих регистров для конкретной области памяти могут быть установлены режимы UC (uncached — не кэшируется), WC (write combining — объединенная запись), WP (write protect — защита от записи), WT (write through — сквозная запись) и WB (write back — обратная запись). Установка режима USWC (uncached, speculative write combining — не кэшировать, режим объединенной записи) позволяет значительно ускорить вывод данных через шину PCI на видеокарту (до 90 MB/c вместо 8 MB/c). Следует учесть, что видеокарта должна поддерживать доступ к своей памяти в диапазоне от A0000 — BFFFF (128 kB) и иметь линейный буфер кадра. Поэтому лучше установить режим USWC, но в случае возникновения каких-либо проблем (система может не загрузиться) установить значение по умолчанию UC. Может принимать значения:

      • UC — uncached — не кэшируется

      • USWC — uncached, speculative write combining — не кэшировать, режим объединенной записи.

    • Graphics Aperture Size (размер графической апертуры для AGP) — в этом параметре указывается максимальный размер области памяти для использования видеокартой с интерфейсом AGP. Значение по умолчанию, устанавливаемое по включению питания или сбросу, 4 MB. После инициализации BIOS'ом принимает значение, выбранное производителем материнской платы (как правило, 64 MB). Разрешенный ряд значений графической апертуры 4 MB, 8 MB, 16 MB, 32 MB, 64 MB, 128 MB и 256 MB.

    • PCI 2.1 Support (поддержка спецификации шины PCI 2.1) — при разрешении этого параметра поддерживаются возможности спецификации 2.1 шины PCI. Спецификация 2.1 имеет два основных отличия от 2.0 — максимальная тактовая частота шины увеличена до 66 MHz и вводится механизм моста PCI — PCI, позволяющий снять ограничение спецификации 2.0, согласно которой допускается установка не более 4-х устройств на шине. Запрещать этот параметр имеет смысл только при возникновении проблем после установки PCI платы (как правило, они возникают только с достаточно старыми платами). Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • 8 Bit I/O Recovery Time (время восстановления для 8-ми разрядных устройств) — Параметр измеряется в тактах процессора, и определяет, какую задержку система будет устанавливать после выдачи запроса на чтение/запись устройства (или, как принято у Intel — порта) ввода/вывода. Эта задержка необходима, так как цикл чтения/записи для устройств ввода/вывода существенно дольше, чем для памяти. Кроме этого 8-ми разрядные устройства ввода/вывода сами по себе, как правило, медленнее 16-ти разрядных устройств ввода/вывода. Значение этого параметра по умолчанию 1 и его следует увеличивать только в случае установки в компьютер какого-либо медленного 8-ми разрядного устройства. Может принимать значения от 1 до 8 тактов.

    • 16 Bit I/O Recovery Time (время восстановления для 16-ми разрядных устройств) — Параметр измеряется в тактах процессора, и определяет, какую задержку система будет устанавливать после выдачи запроса на чтение/запись устройства (или, как принято у Intel — порта) ввода/вывода. Эта задержка необходима, так как цикл чтения/записи для устройств ввода/вывода существенно дольше, чем для памяти. Значение этого параметра по умолчанию 1 и его следует увеличивать только в случае установки в компьютер какого-либо медленного 16-ти разрядного устройства. Может принимать значения от 1 до 4 тактов.

    • Memory Hole At 15M-16M ("дырка" в памяти внутри 15-го мегабайта памяти) — Разрешение этого параметра позволяет обращаться к устройствам ввода/вывода как к памяти и за счет этого увеличить скорость доступа к таким устройствам. Для функционирования этого механизма необходимо исключить для всех обычных программ возможность использования определенной области памяти (15-ый мегабайт), что и делает BIOS при разрешении этого параметра. Разрешать этот параметр следует в том случае, если это требуется в документации на установленную в данном компьютере плату. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Peer Concurrancy (паралельная работа) — Этот параметр разрешает или запрещает одновременную работу нескольких устройств на шине PCI. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Chipset Special Features (специальные возможности chipset) — Данный параметр разрешает/запрещает все новые функции, появившиеся в наборах HX, VX или TX по сравнению с FX. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Passive Release (пассивное разделение) — Этот параметр включает/выключает механизм паралельной работы шин ISA и PCI. Если этот параметр разрешен, то доступ процессора к шине PCI позволен во время пассивного разделения. Необходимость запрещения данного параметра может возникнуть при использовании плат ISA, активно использующих каналы DMA. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • PCI Delayed Transaction (задержанная транзакция на PCI) — Присутствие этого параметра означает, что на материнской плате есть встроенный 32-битный буфер для поддержки удлинненного цикла обмена на PCI. Если этот параметр разрешен, то доступ к шине PCI разрешен во время доступа к 8-ми разрядным устройствам на шине ISA. Это существенно увеличивает производительность, так как цикл такого обращения на ISA занимает 50-60 тактов шины PCI. При установке в компьютер платы, не поддерживающей спецификации PCI 2.1, этот параметр следует запретить. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Parallel Port Mode (ECP+EPP) (режим работы параллельного порта) — параметр позволяет задать режимы работы параллельного порта в соответствии со стандартом IEEE 1284. Следует учитывать, что скорость обмена для некоторых устройств может быть существенно увеличена при правильной установке режима работы порта принтера, например, для внешних устройств хранения информации типа Iomega ZIP Drive LPT. Может принимать значения:

      • Normal — обычный интерфейс принтера, также называется SPP

      • ECP — порт с расширенными возможностями

      • EPP — расширенный принтерный порт

      • ECP + EPP — можно использовать оба режима

    • Parallel Port Mode (режим работы параллельного порта) — параметр аналогичен Parallel Port Mode (ECP+EPP), но с некоторыми расширениями. Дело в том, что существуют устройства, выполненные с отклонениями от стандарта IEEE 1284, например, некоторые платы от фирмы Xircom. Для совместимости с такими платами в некоторых BIOS существуют параметры установки версии варианта ECP+EPP порта. Какую версию выбрать — необходимо "выловить" из документации на подключаемое устройство или проверить экспериментально. Может принимать значения:

      • SPP — обычный интерфейс принтера, также называется SPP

      • ECP — порт с расширенными возможностями

      • EPP — расширенный принтерный порт

      • EPP 1.9 — версия 1.9 исполнения интерфейса

      • EPP 1.7 — версия 1.7 исполнения интерфейса

    • ECP DMA Select (выбор канала DMA для режима ECP) — параметр появляется только при разрешении режима ECP или ECP+EPP в Parallel Port Mode (ECP+EPP). Для нормальной поддержки режима ECP требуется задействовать канал DMA, который выбирается из каналов 1 или 3. Может принимать значения:

      • 1 — канал 1

      • 3 — канал 3

      • Disabled — запрещено использовать DMA

    • Onboard PCI IDE Enable (разрешение работы интегрированного контроллера IDE) — Этот параметр управляет разрешением/запрещением работы каждого из двух каналов контроллера IDE, установленного на материнской плате. Может принимать значения:

      • Primary — разрешена работа только первого канала

      • Secondary — разрешена работа только второго канала

      • Both — разрешена работа обеих каналов

      • Disable — запрещена работа обеих каналов

    • Onboard FDC Controller (разрешение работы контроллера накопителя на гибких дисках) — Этот параметр управляет разрешением/запрещением работы контроллера накопителя на гибких дисках, установленного на материнской плате. Может принимать значения:

      • Enable — контроллер разрешен

      • Disable — контроллер запрещен

    • Выбор режима работы каждого диска — Эти четыре параметра позволяют устанавливать режимы работы каждого диска индивидуально или разрешить BIOS автоматическую установку самого высокоскоростного режима для диска. Для каждого диска допустимые параметры одинаковы. Например, для IDE 0 Master Mode допустимые значения: 0, 1, 2, 3, 4 и AUTO. Параметр UDMA может иметь значение Auto или Disable.

    Раздел «PnP/PCI CONFIGURATION SETUP»

    • PNP OS Installed (установлена ли операционная система с поддержкой режима Plug&Play?) — Установить Yes, если операционная система поддерживает Plug&Play (например, Windows 95) и No в противном случае.

    • Resources Controlled By (как управляются ресурсы) — Если выбрано AUTO, то BIOS сам автоматически назначит прерывания и каналы DMA всем устройствам, подключенным к шине PCI и эти параметры не будут появляться на экране. В противном случае все эти параметры следует установить вручную. В некоторых вариантах BIOS этот параметр может устанавливаться индивидуально для каждого PCI слота и выглядеть так: Slot1 IRQ, Slot 2 IRQ и т.д.

    • Reset Configuration Data (сброс конфигурационных данных) — Рекомендуется устанавливать его в Disabled. При установке Enabled BIOS будет очищать область Extended System Configuration Data (Расширенные данные о конфигурации системы — ESCD), в которой хранятся данные о конфигурировании BIOS`ом системы, поэтому возможны аппаратные конфликты у "брошенных" таким образом на произвол судьбы устройств.

    • IRQ n Assigned to (прерывание с номером n назначено на...) — Каждому прерыванию системы может быть назначен один из следующих типов устройств:

      • Legacy ISA (классические ISA карты) — Обычные карты для ISA, такие как модемы или звуковые карты без поддержки Plug&Play. Эти карты требуют назначения прерываний в соответствии с документацией на них.

      • PCI/ISA PnP (устройства для шины PCI или устройства для шины ISA с поддержкой Plug&Play) — этот параметр устанавливается только для устройств на шине PCI или ISA карт с поддержкой Plug&Play.

    • DMA n Assigned to (канал DMA с номером n назначен на...) — Каждому каналу DMA системы может быть назначен один из следующих типов устройств:

      • Legacy ISA (классические ISA карты) — Обычные карты для ISA, такие как модемы или звуковые карты без поддержки Plug&Play. Эти карты требуют назначения каналов DMA в соответствии с документацией на них.

      • PCI/ISA PnP (устройства для шины PCI или устройства для шины ISA с поддержкой Plug&Play) — этот параметр устанавливается только для устройств на шине PCI или ISA карт с поддержкой Plug&Play.

    • PCI IRQ Activated by (прерывания активизируются по ...) — Параметр может принимать значения:

      • Level (уровень) — контроллер прерываний реагирует только на уровень сигнала.

      • Edge (перепад) — контроллер прерываний реагирует только на перепад уровня сигнала.

    • PCI IDE IRQ Map to (прерывания контроллера IDE на PCI отображаются на...) — позволяет освободить прерывания, занимаемые контроллером IDE на шине PCI в случае его отсутствия (или запрещения) на материнской плате и отдать их устройствам на шине ISA. Стандартные прерывания для ISA — IRQ 14 для первого канала и IRQ 15 для второго канала. Может принимать значения

      • :

      • PCI IDE IRQ mapping (используется для PCI IDE)

      • PC AT (ISA) (используется для ISA)

    • PCI Slot IDE 2nd Channel (2-ой канал контроллера PCI IDE) — разрешает или запрещает 2-ой канал контроллера IDE. Запрещение параметра используется для освобождения прерывания, занятого 2-ым каналом в том случае, если ко второму каналу ничего не подключено.Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ n Used By ISA (прерывание n используется на шине ISA) — Параметр совпадает с IRQ n Assigned to и может принимать значения:

      • No/ICU (нет/конфигурационная утилита для ISA) — если установлено это значение, то BIOS может распоряжаться этим прерыванием по своему усмотрению. Для DOS настройка параметров в этом случае может также выполняться с помощью программы ISA Configuration Utility от Intel.

      • Yes (да) — означает принудительное освобождение прерывания для какой-либо карты на шине ISA, не поддерживающей режим Plug&Play. Рекомендуется всегда указывать Yes для таких карт и нужных им прерываний, так как в противном случае BIOS может назначить прерывание, жестко используемое какой-либо картой на ISA, другой карте, что может вызвать даже прекращение нормальной работы компьютера.

    • DMA n Used By ISA (канал DMA n используется на шине ISA) — Параметр совпадает с DMA n Assigned to и может принимать значения:

      • No/ICU (нет/конфигурационная утилита для ISA) — если установлено это значение, то BIOS может распоряжаться этим каналом DMA по своему усмотрению. Для DOS настройка параметров в этом случае может также выполняться с помощью программы ISA Configuration Utility от Intel.

      • Yes (да) — означает принудительное освобождение канала DMA для какой-либо карты на шине ISA, не поддерживающей режим Plug&Play. Рекомендуется всегда указывать Yes для таких карт и нужных им каналом DMA, так как в противном случае BIOS может назначить канал, жестко используемый какой-либо картой на ISA, другой карте, что может вызвать даже прекращение нормальной работы компьютера.

    • ISA MEM Block BASE (базовый адрес блока памяти для ISA) — Некоторые карты для шины ISA требуют доступа к памяти, расположенной на такой карте по определенным адресам. Поэтому и возникла необходимость в этом параметре BIOS. Может принимать значения:

      • No/ICU (нет/ICU) — оставляет управление этим параметром на усмотрение BIOS или программы ICU.

      • C800, CC00, D000, D400, D800 и DC00 — указывается адрес блока памяти. Кроме этого, появляется дополнительный параметр ISA MEM Block SIZE (размер блока памяти), который нужен в том случае, если таких ISA карт несколько и этот параметр может принимать значения 8K, 16K, 32K, 64K

    • Onboard AHA BIOS (BIOS встроенного SCSI контроллера Adaptec) — параметр разрешает/запрещает выполнение BIOS встроенного SCSI контроллера и тем самым разрешает/запрещает работу встроенного SCSI контроллера. Параметр может принимать значения:

      • AUTO (автоматически) — Разрешен поиск SCSI контроллера Adaptec и запуск BIOS для него.

      • Disabled (запрещено) — Устанавливается в это значение при отсутствии SCSI карты.

    • ONB AHA BIOS First (Запуск BIOS контроллера Adaptec первым) — параметр разрешает/запрещает запуск BIOS встроенного контроллера Adaptec до запуска любого другого SCSI контроллера. Может принимать значения:

      • Yes — разрешено

      • No — запрещено

    • ONB SCSI SE Term. (Терминаторы встроенного контроллера SCSI) — параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном контроллере SCSI. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • ONB SCSI LVD Term. (Терминаторы встроенного контроллера SCSI LVD) — параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном контроллере SCSI LVD. Управление этим параметром позволяет увеличить длину соединительного SCSI кабеля до 25 метров. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • SYMBIOS SCSI BIOS или NCR SCSI BIOS — Разрешение на поиск SCSI контроллера на базе микросхемы NCR 810, используемого, например, в карте ASUS SC-200. Параметр может принимать значения:

      • AUTO (автоматически) — Разрешен поиск SCSI контроллера и запуск BIOS для него.

      • Disabled (запрещено) — Устанавливается в это значение при отсутствии SCSI карты.

    • PCI Latency Timer (таймер задержки на PCI) — Устанавливает максимальное время (в тактах частоты шины) в течении которого устройство на шине PCI может удерживать шину в том случае, если другое устройство требует доступа к шине. Допустимый диапазон изменения этого параметра — от 16 до 128 с шагом, кратным 8. Значение параметра следует изменять осторожно, так как оно зависит от конкретной реализации материнской платы.

    • USB IRQ (прерывание шины USB) — параметр разрешает или запрещает назначение прерывания для контроллера шины USB. Поскольку в компьютере часто не хватает прерываний, разрешать этот параметр следует только при наличии устройства на шине USB в системе. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • VGA BIOS Sequence (последовательность загрузки BIOS видеокарт) — определяет, BIOS какой видеокарты будет загружаться первым, AGP видеокарта или PCI. Устанавливать значение этого параметра имеет смысл только в случае установки в компьютере нескольких видеокарт. Может принимать значения:

      • PCI/AGP — сначала BIOS PCI видеокарты, затем AGP

      • AGP/PCI — сначала BIOS AGP видеокарты, затем PCI

    • USB Keybord Support Via (поддержка USB клавиатуры через ...) — параметр позволяет установить, на кого возлагается поддержка USB клавиатуры — на BIOS или операционную систему. Поскольку не все операционные системы поддерживают USB, рекомендуется оставлять значение BIOS. Может принимать значения:

      • OS — поддержка через операционную систему

      • BIOS — поддержка через BIOS

    Раздел «POWER MANAGEMENT SETUP»

    • Power Management (управление энергопотреблением) — позволяет либо разрешать BIOS'у снижать энергопотребление компьютера, если за ним не работают, либо запрещать. Может принимать значения:

      • User Define (определяется пользователем) — при установке этого параметра вы можете самостоятельно установить время перехода в режим пониженного энергопотребления.

      • Min Saving (минимальное энергосбережение) — при выборе этого параметра компьютер будет переходить в режим пониженного энергопотребления через время от 40 мин. до 2 часов (зависит от конкретного BIOS материнской платы)

      • Max Saving (максимальное энергосбережение) — компьютер перейдет в режим пониженного энергопотребления через 10 — 30 с. после прекращения работы пользователя с ним.

      • Disable (запрещение энергосбережения) — запрещает режим энергосбережения.

    • ACPI function (функционирование ACPI) — разрешает или запрещает поддержку BIOS стандарта ACPI. Следует помнить, что по состоянию на конец 1998 года только Windows 98 поддерживает этот стандарт. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

      Video Off Option (в каком режиме выключать монитор) — позволяет устанавливать, на какой стадии "засыпания" компьютера переводить монитор в режим пониженного энергопотребления. Может принимать значения:

      • Susp, Stby -> Off (выключение в режиме Suspend И Standby) — монитор перейдет в режим пониженного энергопотребления при наступлении либо режима Suspend, либо Standby.

      • All modes -> Off (выключение во всех режимах) — монитор будет переведен в режим пониженного энергопотребления в любом режиме.

      • Always On (всегда включен) — монитор никогда не будет переведен в режим пониженного энергопотребления

      • Suspend -> Off (выключение в режиме Suspend) — монитор перейдет в режим пониженного энергопотребления при наступлении режима Suspend.

      Video Off Method (способы выключения монитора) — устанавливается способ перехода монитора в режим пониженного энергопотребления. Может принимать значения:

      • DPMS OFF — снижение энергопотребления монитора до минимума

      • DPMS Reduce ON — монитор включен и может использоваться

      • DPMS Standby — монитор в режиме малого энергопотребления

      • DPMS Suspend — монитор в режиме сверхмалого энергопотребления

      • Blank Screen — экран пуст, но монитор потребляет полную мощность

      • V/H SYNC+Blank — снимаются сигналы разверток — монитор переходит в режим наименьшего энергопотребления.

      Suspend Switch (переключатель режима Suspend) — параметр разрешает или запрещает переход в режим suspend (временной остановки) с помощью кнопки на системном блоке. Для этого необходимо соединить джампер SMI на материнской плате с кнопкой на лицевой панели. Как правило, для этого используется либо специальная кнопка Sleep, либо кнопка Turbo. Режим suspend является режимом максимального снижения энергопотребления компьютером. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Doze Speed (частота процессора в режиме Doze) — определяет коэффициент деления тактовой частоты в режиме Doze (засыпание).

    • Stby Speed (частота процессора в режиме Standby) — определяет коэффициент деления тактовой частоты в режиме Standby (ожидания работы).

    PM Timers — в этой секции устанавливаются времена перехода в различные стадии снижения энергопотребления.

    • HDD Power Down (выключение жесткого диска) — устанавливает либо время, через которое при отсутствии обращения жесткий диск будет выключен, либо запрещает такое выключение вообще. Параметр не оказывает влияние на диски SCSI. Может принимать значения:

      • От 1 до 15 минут

      • Disabled — запрещено

    • Doze Mode (режим засыпания) — устанавливает время перехода или запрещает переход в первую стадию снижения энергопотребления. Может принимать значения:

      • 30 Sec, 1 Min, 2 Min, 4 min, 8 Min, 20 Min, 30 Min, 40 Min, 1 Hour — время перехода (Sec — секунды, Min — минуты, Hour — час)

      • Disabled — запрещено

    • Standby Mode (режим ожидания работы) — устанавливает время перехода или запрещает переход во вторую стадию снижения энергопотребления. Может принимать значения:

      • 30 Sec, 1 Min, 2 Min, 4 min, 8 Min, 20 Min, 30 Min, 40 Min, 1 Hour — время перехода (Sec — секунды, Min — минуты, Hour — час)

      • Disabled — запрещено

    • Suspend Mode (режим временной остановки) — устанавливает время перехода или запрещает переход в третью стадию снижения энергопотребления. Может принимать значения:

      • 30 Sec, 1 Min, 2 Min, 4 min, 8 Min, 20 Min, 30 Min, 40 Min, 1 Hour — время перехода (Sec — секунды, Min — минуты, Hour — час)

      • Disabled — запрещено

    PM Events — в этой секции указываются те прерывания, от обращения к которым компьютер должен "просыпаться", если к устройствам, использующим эти прерывания, есть обращения.

    • IRQ 3 (Wake-up) — разрешение этого параметра приведет к "пробуждению" компьютера от модема или мыши, подключенных к COM2. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 4 (Wake-up) — разрешение этого параметра приведет к "пробуждению" компьютера от модема или мыши, подключенных к COM1. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 8 (Wake-up) — разрешение этого параметра приведет к "пробуждению" компьютера от часов реального времени. Рекомендуется оставить его запрещенным, так как некоторые программы могут использовать функцию "будильника" часов компьютера для своих целей. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 12 (Wake-up) — разрешение этого параметра приведет к "пробуждению" компьютера от мыши, подключенной к порту PS/2. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    В следующей секции указываются те устройства, при активности которых компьютер "засыпать" не должен.

    • IRQ 3 (COM2) — при разрешении этого параметра компьютер не "засыпает", если подключенное к порту COM2 устройство используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 4 (COM1) — при разрешении этого параметра компьютер не "засыпает", если подключенное к порту COM1 устройство используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 5 (LPT2) — при разрешении этого параметра компьютер не "засыпает", если подключенное к порту LPT2 устройство (как правило, принтер) используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 6 (Floppy Disk) — при разрешении этого параметра компьютер не "засыпает", если к накопителю на гибких дисках происходит обращение. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 7 (LPT1) — при разрешении этого параметра компьютер не "засыпает", если подключенное к порту LPT2 устройство (как правило, принтер) используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 8 (RTC Alarm) — при разрешении этого параметра компьютер не "засыпает", если RTC (часы реального времени) используются как таймер. Рекомендуется оставить его запрещенным, так как некоторые программы могут использовать функцию "будильника" часов компьютера для своих целей. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 9 (IRQ2 Redir) — при разрешении этого параметра компьютер не "засыпает", если подключенное к порту COM2 устройство используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 10 (Reserved) — при разрешении этого параметра компьютер не "засыпает", если устройство, занимающее 10 прерывание, используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 11 (Reserved) — при разрешении этого параметра компьютер не "засыпает", если устройство, занимающее 11 прерывание, используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 12 (PS/2 Mouse) — при разрешении этого параметра компьютер не "засыпает", если подключенное к порту COM2 устройство используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 13 (Coprocessor) — при разрешении этого параметра компьютер не "засыпает", если сопроцессор используется. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 14 (Hard Disk) — при разрешении этого параметра компьютер не "засыпает", если к жесткому диску на первом канале IDE есть обращения. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ 15 (Reserved) — при разрешении этого параметра компьютер не "засыпает", если к жесткому диску или CD-ROM на втором канале IDE есть обращения. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    Power Up Control — параметры в этой секции определяют виды управления источником питания и применяются для источников питания в стандарте ATX и материнских плат, допускающих подключение к такому источнику.

    • PWR Button < 4 Secs (он же Soft-of By PWR-BTTN) (кнопка питания нажата менее 4 секунд) — управляет функциями кнопки Power на системном блоке компьютера. Может принимать значения:

      • Soft Off (программное выключение) — кнопка работает как обычная кнопка включения/выключения питания компьютера, но при этом разрешается программное выключение компьютера (например, при выходе из Windows 95).

      • Suspend (временная остановка) — при нажатии на кнопку питания на время менее 4 секунд компьютер переходит в стадию Suspend снижения энергопотребления.

      • No Function (нет функций) — кнопка Power становится обычной кнопкой включения/выключения питания.

    • PWR Up On Modem Act (он же Resume by Ring) (включение питания при звонке на модем) — разрешение этого параметра поволяет включить компьютер при звонке на модем. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • IRQ8 Resume by Suspend (пробуждение по IRQ8) — разрешение этого параметра позволяет "разбудить" компьютер, соответствующим образом запрограммировав Alarm Time (время тревоги) в Real Time Clock (RTC — часы реального времени), так как сигнал от RTC заведен на IRQ8. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • ZZ Active In Suspend (активность сигнала ZZ в режиме Suspend) — контроллер на материнской плате имеет сигнал ZZ, эмулирующий в режиме Suspend (временной остановки) тактовую частоту 8.32 MHz. Как правило, в большинстве материнских плат этот сигнал не используется, но если в SETUP он есть, то следует придерживаться рекомендаций по его установке от производителя материнской платы. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Wake On LAN (Пробуждение от сети) — при разрешении этого параметра компьютер включается по сигналу от локальной сети. Такое включение возможно только при установке в компьютер сетевой карты, поддерживающей этот режим. Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • AC PWR Loss Restart (включить компьютер после пропадания питания) — разрешение этого параметра позволяет включить компьютер после пропадания питания. В противном случае после восстановления питания компьютер не включится и необходимо будет снова нажать кнопку подачи питания (Power). Может принимать значения:

      • Enabled — разрешено

      • Disabled — запрещено

    • Automatic Power Up (автоматическое включение) — используя этот параметр, можно включать компьютер ежедневно в указанное время или включить его в указанный день и час. Может принимать значения:

      • Everday (ежедневно) — при вводе времени компьютер будет включаться ежедневно в назначенное время. Время вводится в поле Time (hh:mm:ss) Alarm в порядке часы:минуты:секунды либо клавишами PgUp, PgDn, либо непосредственным вводом чисел.

      • By Date (по дате) — компьютер включится в заданный день и в заданное время. При выборе этого параметра появляется поле для ввода времени (такое же, как и для Everyday) и поле для ввода дня месяца Date of Month Alarm — день месяца — в этом поле вводится число в месяце. Это автоматически означает, что запрограммировать включение компьютера можно только внутри одного месяца.

      • Disabled — запрещено

    В следующих секциях BIOS только сообщает характеристики некоторых устройств компьютера. Разрешение параметров в этих секциях позволяет отслеживать BIOS'у эти параметры и сообщать об их выходе за пределы допустимого.

    Секция Fan Monitor (наблюдение за вентиляторами)

    • Chassis Fan Speed (xxxxRPM) (наблюдение за скоростью вращения дополнительного вентилятора в корпусе компьютера) — если выбрано Ignore, то скорость вращения этого вентилятора отслеживаться не будет. Этот параметр будет индицироваться только при использовании специального вентилятора с дополнительным выводом, подключаемого к специальному разъему на материнской плате. В противном случае, при остановке или критическом уменьшении скорости вращения, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.

    • CPU Fan Speed (xxxxRPM) (наблюдение за скоростью вращения вентилятора охлаждения процессора) — если выбрано Ignore, то скорость вращения этого вентилятора отслеживаться не будет. Этот параметр будет индицироваться только при использовании специального вентилятора с дополнительным выводом, подключаемого к специальному разъему на материнской плате. В противном случае, при остановке или критическом уменьшении скорости вращения, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.

    • Power Fan Speed (xxxxRPM) (наблюдение за скоростью вращения вентилятора блока питания) — если выбрано Ignore, то скорость вращения этого вентилятора отслеживаться не будет. В противном случае, при остановке или критическом уменьшении скорости вращения, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы. Использование этого параметра возможно при наличии соответствующего блока питания.

    Секция Thermal Monitor (наблюдение за температурой) — параметры изменению не подлежат.

    • CPU Temperature (температура процессора) — показывает темпераратуру процессора в градусах Цельсия и Фаренгейта. При выборе Ignore температура отслеживаться не будет. В противном случае, при критическом повышении температуры, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.

    • MB Temperature (температура материнской платы) — показывает темпераратуру процессора в градусах Цельсия и Фаренгейта. При выборе Ignore температура отслеживаться не будет. В противном случае, при критическом повышении температуры, BIOS будет выдавать сообщение на экране перед загрузкой операционной системы.

    Секция Voltage Monitor (наблюдение за напряжениями питания). В этой секции индицируются как напряжения питания, подаваемые на материнскую плату источником питания, так и вырабатываемые на материнской плате. Разъяснения эти параметры не требуют, кроме VCORE — это напряжение питания ядра процессора. Это напряжение вырабатывается, как правило, на материнской плате.


BIOS

БИОС
• Вступление
• Ознакомление с BIOS
• Оптимизация BIOS
• Увеличение производительности
• Уменьшение времени загрузки
• Ошибки и сигналы
Прошивка БИОС
• Прошивка - вступление
• Прошивка в режиме командной строки
• Прошивка в диалоговом режиме

Вступление

BIOS («basic input/output system» — базовая система ввода/вывода) — это встроенное в компьютер специальное программное обеспечение, которое ему доступно без обращения к жёсткому диску. Оно предназначено для сбора информации о системе и определения подключенного оборудования.
BIOS содержит инструкции по управлению клавиатурой, дисплеем, дисковыми накопителями, портами ввода/вывода, а также множеством дополнительных функций. Как правило, эти данные не могут быть изменены. Выполняемые на компьютере программы могут только их считывать.

Обычно, BIOS находится в микросхеме ПЗУ (постоянное запоминающее устройство), она же ROM («read only memory» — память только для чтения). Размещается на материнской плате компьютера (этот чип часто называют ROM BIOS).

BIOS энергонезависима и всегда доступна, несмотря на повреждения, например, дисковой системы. Это также позволяет компьютеру загружаться автоматически. Поскольку доступ к RAM («read only memory» — память только для чтения или оперативная память) осуществляется значительно быстрее, чем к ROM, поэтому многие производители компьютеров создают системы таким образом, чтобы при включении компьютера выполнялось копирование BIOS из ROM в оперативную память. Задействованная при этом область памяти называется «Shadow Memory» (теневая память). Во время загрузки компьютера центральный процессор считывает x86- инструкции из BIOS. Данные инструкции запускают последовательности тестирований, POST (Power On Self Test).

BIOS начинает проверять работоспособность системных устройств:

  • инициализирует системные ресурсы и регистры чипсетов;

  • систему управления электропитанием;

  • тестирует оперативную память (RAM);

  • включает клавиатуру;

  • тестирует последовательные и параллельные порты;

  • инициализирует дисководы и контроллеры жестких дисков;

  • отображает итоговую системную информацию.

    В процессе этих тест- последовательностей BIOS сравнивает данные системной конфигурации с информацией, хранящейся в CMOS («complementary metal-oxide semiconductor» — полупостоянная память). CMOS-чип обновляет информацию, хранящуюся в нем, всякий раз, когда устанавливается какой-либо новый компонент компьютера. Таким образом, он всегда содержит самые последние сведения о системных компонентах.

    После того как все POST-задания завершены, BIOS приступает к поиску программы загрузки операционной системы и ждет ответа от нее. Когда ответ получен, программа помещается в память, откуда происходит загрузка системной конфигурации и драйверов устройств. И в завершение, когда операционная система загружена, если компьютер работает под управлением «Windows», запускаются программы папки «Автозагрузка» .

    В BIOS содержится также программа настройки конфигурации компьютера «Setup» . Она позволяет установить некоторые характеристики устройств компьютера (типы видеоконтроллера, жёстких дисков и дисководов, режимы работы с оперативной памятью, запрос пароля при начальной загрузке и т.д.). Мы будем рассматривать параметры, влияющие на производительность компьютера. Программа настройки вызывается при нажатии клавиши <Del> в начале загрузки.

    Производя изменения настроек «Setup» записывайте прежние значения, чтобы можно было к ним вернуться. Но, в любом случае, Вы сможете восстановить предыдущие настройки, войдя в «Setup» и выбрав в меню «Exit» пункт «Discard Changes» . Можно восстановить настройки принятые по умолчанию — пункт «Load Setup Defaults» (клавиша <F5>).

    Аналогичного результата можно добиться, если обнулить CMOS, замкнуть специальные контакты или переставить соответствующий джампер на мать- плате (посмотрите в документации), вынуть батарейку на материнской плате.

    Внимание! Перед любыми монтажными работами - выключить компьютер и вынуть вилку из розетки.

    Ознакомление с BIOS

    С чего начинается компьютер? Конечно же, с BIOS. Если вы всерьез решили постичь устройство своей ПК - без этих знаний не обойтись.
    Как известно, прежде операционной системы в компьютере запускается встроенная в чип материнской платы программа BIOS (Base Input/Output System, базовая система ввода/вывода). Назначение этого (256 Кб) программного кода - свести к "общему знаменателю" аппаратные различия компьютерного оборудования.
    Надежная и эффективная работа ПК невозможна без правильно сконфигурированного BIOS. Конфликт между новейшим оборудованием и устаревшим кодом чипа - вещь довольно частая. В этом случае выход один: пере прошивка. Но если замена BIOS требует определенных навыков и знаний, то первичная настройка под силу среднему пользователю. Кроме того, понимание правил включения компьютера необходимо для грамотного его использования.
    BIOS представляет собой программу, записанную в микросхему по технологии ROM и, следовательно, не требующую питания даже после выключения компьютера. В современных чипах используется технология Flash ROM, позволяющая перезаписывать BIOS без дополнительного оборудования. Но, в любом случае, перезапись BIOS - операция серьезная. Другое дело - настройка (SETUP) BIOS. Настройка позволяет "подогнать" стандартную версию BIOS под конкретную конфигурацию компьютера или ОС. Менять настройку BIOS можно хоть по несколько раз в день.
    Параметры настройки BIOS хранятся в энергозависимой CMOS RAM, которая питается от батарейки на материнской плате. Отсюда вывод: если у вас часто "слетают" установки компьютера или "вредничают" часы - скорее всего, пора менять батарейку.

    Роль BIOS при загрузке ПК
    После включения питания напряжение подается на центральный процессор и другие микросхемы материнской платы. "Проснувшись", CPU запускает из микросхемы программу BIOS - и начинается процедура POST (Power On Self Test, инициализация при первом включении). Ее задача - просканировать и настроить все "железо".
    Прежде всего формируется логическая архитектура компьютера. Подается питание на все чипсеты, в их регистрах устанавливаются нужные значения. Затем определяется объем ОЗУ (этот процесс можно наблюдать на экране), включается клавиатура, распознаются LPT- и COM-порты. На следующем этапе определяются блочные устройства - жесткие диски IDE и SCSI, флоппи-дисководы. Для устройств SCSI процедура несколько усложняется наличием собственной BIOS, которая берет на себя работу с соответствующим оборудованием и имеет собственную программу настройки. На заключительной стадии происходит отображение итоговой информации.
    После окончания работы POST BIOS ищет загрузочную запись. Эта запись, в зависимости от настройки, находится на первом или втором жестком диске, флоппи-диске, ZIP или CDROM. После того как загрузочная записи найдена, она загружается в память - и управление передается ей.
    Если в настройках SETUP BIOS есть ошибки, то они могут проявиться уже на этих стадиях, и до запуска ОС дело не дойдет. Но возможны и другие проявления неправильной настройки BIOS - медленная или нестабильная работа системы, внезапные перезагрузки. Поэтому давайте посмотрим что такое BIOS.

    BIOS SETUP
    Прежде всего, сразу после включения питания, посмотрите на нижнюю часть экрана. Здесь находится идентификационная запись о версии BIOS, пример:

    Press DEL to enter SETUP 04/19/2001-i815-W83627HF-6169RAB9C-00

    Это означает, что, своевременно нажав клавишу <Del>, мы попадем в SETUP BIOS. Единого стандарта интерфейса этой программы не существует. Некоторое логическое единообразие - следствие единой выполняемой задачи - все же имеется. На сегодняшний день подавляющее большинство настольных ПК оснащено AWARD BIOS, поэтому при описании настройки мы будем опираться на этого производителя. Впрочем, приведенные сведения можно без затруднений использовать для настройки AMI или Phoenix SETUP BIOS.
    Программа настройки BIOS разделена на функциональные блоки, каждый из которых выполняет свой класс задач. Обычно это следующие блоки (в скобках указано, как может называться этот раздел):

    • общие параметры (STANDARD CMOS SETUP, MAIN);
    • свойства самой BIOS (BIOS FEATURES SETUP, ADVANCED);
    • свойства других чипсетов (CHIPSET FEATURES SETUP, Chip Configuration);
    • свойства интегрированных устройств (INTEGRATED PERIPHERALS, I/O Devices Configuration);
    • свойства слотов PCI (PNP/PCI CONFIGURATION, PCI CONFIGURATION);
    • управление питанием (POWER MANAGMENT SETUP, POWER);
    • пароли системы (SUPERVISOR PASSWORD, USER PASSWORD);
    • сохранение и восстановление настроек (SAVE SETUP, LOAD BIOS DEFAULT, LOAD SETUP DEFAULTS);
    • выход и сохранение (EXIT).

    Следует иметь в виду, что это деление довольно условно: в каждом компьютере могут быть свои варианты распределение функций по группам.
    Для того чтобы активировать некоторую группу, следует навести на нее с помощью клавиш <Up> и <Down> курсорную рамку и нажать <Enter>. Изменять свойства можно клавишами <Page Up> и <Page Down>, а также <+> и <->. Описание управляющих клавиш обычно приводится в нижней информационной строке. Для выхода из блока используется клавиша <Esc>.
    Остановимся на каждом разделе подробнее.

    Общие свойства
    В этом разделе устанавливается системное время, настраиваются IDE- и флоппи-дисководы, выбирается реакция системы на ошибки. Здесь же приводится размер инсталлированной в компьютере RAM. Обычно указывать время и дату приходится только при первом включении компьютера или при переходе на зимнее/летнее время. Впоследствии правильное значение поддерживается встроенными часами, питающимися от аккумулятора. В современных ОС неправильно идущие часы могут оказать плохую услугу, предоставляя ложную информацию о времени доступа к файлу и прочее.

    Что такое LBA MODE

    При настройке дисков IDE, помимо геометрии, требуется указать тип адресации секторов. Это связано с тем, что файловая система FAT не способна зайти дальше 1023-го сектора, что ограничивает объем винчестера размером 512 Mб. Чтобы обойти это ограничение, была введена технология линейной адресации блоков - LBA. Она заключается в том, что BIOS указывает ОС "неправильные" параметры винчестера, намеренно уменьшая количество секторов, так чтобы оно не превышало 1024, и пропорционально увеличивая число цилиндров. Современные файловые системы (NTFS, EXT2) лишены этого недостатка. Но если Windows 9x ОС после установки на новый жесткий диск не запускается, возможно, стоит активировать LBA.

    Как известно, к стандартному компьютеру можно подключить до четырех IDE-устройств. Существует два способа их настройки: автоматическое обнаружение при каждом включении и жесткое задание параметров. Например, если в компьютере установлен мастер-диск на первом IDE-порту, то, найдя в SETUP соответствующий пункт (Primary Master), можно выбрать для него один из двух режимов обнаружения - Auto или User Default. В последнем случае предполагается, что пользователь сам укажет геометрию винчестера - количество цилиндров, головок и секторов. Эта информация приводится на этикетке диска или может быть определена подручными средствами самого SETUP BIOS - IDE HDD AUTO DETECTION. Если конфигурация ПК изменяется редко, то разумным будет ввести параметры вручную. Тем самым процедура POST ускорится на одну-две секунды. Установив для отсутствующих IDE- устройств режим None, вы еще более ускорите загрузку компьютера.

    Настройка флоппи-дисководов производится с помощью параметров Drive A и Drive B. Для них нужно выбрать тип - обычно 1,44 M или None, если дисковод отсутствует. Другие форматы флоппи-накопителей используются крайне редко. А вот если не указать None для отсутствующего устройства, то при начальной загрузке будут возникать ошибки. От Floppe 3 Mode Support - последствия одной из многих неудачных попыток "вытянуть за уши" 3-дюймовые диски - рекомендуется отказаться.

    Диски С, D, E

    Если жесткий диск разбит на несколько логических дисков, то подключение дополнительного винчестера может вызвать осложнения. Диски D, E и остальные "сдвинутся", и место привычного диска D займет новый диск. Кроме прочих неудобств, нарушатся связи программ и ярлычков. Чтобы избежать этого явления, установите в SETUP BIOS для подключаемого винчестера тип None. Теперь BIOS его не "увидит" - и диск "появится" только после загрузки Windows. ОС обнаружит винчестер своими методами и добавит его в конец списка дисков.

    Загрузка компьютера может сопровождаться ошибками. Как система должна на них реагировать, определяет параметр Halt On:

    • All Errors - останавливать загрузку при любой ошибке;
    • No Errors - продолжать загрузку в любом случае;
    • All, But Keyboard - прекращать загрузку при любой ошибке, кроме отсутствия клавиатуры (этот режим часто используется в серверных ПК, настроенных на удаленное управление);
    • All, But Diskette или All, But Disk/Key - прерывать загрузку при любых ошибках, кроме отсутствия дисковода или дисковода и клавиатуры.

    Оптимизация BIOS

    В базовой системе ввода/вывода скрыты многие настройки компьютера, которые позволят оптимизировать его работу. С помощью BIOS возможен разгон и оптимизация, то есть повышение производительности компьютера. Сейчас мы займёмся тонкой оптимизацией с помощью BIOS. Здесь можно встретить следующие параметры (в скобках указаны различные варианты названий).

    Параметры

    • CPU Internal Frequency. Конструкция некоторых материнских плат позволяет указать здесь частоту процессора. Однако будьте осторожны - "разгон" процессора может привести к его повреждению.

    • CPU Level 1 Cache, CPU Internal Cache. Включение\отключение кэша первого уровня (внутреннего). Отключать эту опцию полезно только в целях поиска неисправности.

    • CPU Level 2 Cache, CPU External Cache. Включение\отключение кэша второго уровня (внешнего). Отключать эту опцию полезно только в целях поиска неисправности.

    • CPU L2 Cache ECC Checking. Попытка коррекции ошибок в кэше второго уровня. Хотя полезность этой опции достаточно сомнительна, ее активация никак не сказывается на производительности системы.

    • Processor Number Feature. Начиная с Pentium III, Intel предоставила возможность программного определения серийного номера процессора. Выключить этот режим имеет смысл, например, из соображений сохранения конфиденциальности.

    • Boot Up NumLock Status. Автоматическое включение цифровой клавиатуры, полезно для индивидуальной настройки.

    • Typematic Rate Setting. Переход в режим повторов постоянно нажатой клавиши. Частота повторов определяется параметрами Typematic Rate (Keyboard Auto Repeat Rate) и Typematic Rate Delay (Keyboard Auto Repeat Rate).

    • BIOS Update. Разрешает или запрещает перепрошивку Flash BIOS. После появления вируса Chine, разрушающего системный BIOS, эту опцию стоит включать только перед самой перезаписью Flash ROM.

    • Video BIOS Shadow. Современные ОС не пользуются этим свойством, предпочитая работать с видеокартой напрямую.

    • Gate A20 Option. Если присвоить этому параметру значение Fast, то Windows будет быстрее переключаться в защищенный режим и обратно.

      Опции раздела BOOT:

    • Quick Power On Self Test. Ускоряет загрузку, пропуская некоторые тесты, в том числе тройную проверку ОЗУ.

    • Virus Warning, Boot Virus Detection. Контролирует доступ к загрузочной записи жесткого диска; следует отключать при инсталляции ОС.

    • Swap Floppy Drive. Меняет местами дисководы A и B.

    • Boot Up Floppy Seek. Производит поиск дисковода при загрузке. Этот режим можно отключить, ускорив тем самым выполнение POST.

    • Boot Sequence. Последовательность просмотра дисков для загрузки ОС. Этот режим может быть представлен и другим способом - в виде списка из четырех устройств. Обычно первым загрузочным устройством удобно ставить диск C. Система, настроенная на загрузку с дискеты, у неопытных пользователей вызывает иногда затруднения. Если по окончании работы дискета оставляется в дисководе, то при следующем включении система будет безуспешно пытаться с нее загрузиться. Кроме жестких дисков и дисководов, современные системы могут загружаться с CD-ROM и ZIP-дисков.

    Свойства чипов
    Это свойства чипов памяти и видео. Правильная их настройка необходима для повышения производительности системы или устойчивости работы.
    В отдельную группу можно выделить параметры, относящиеся к циклам чтения/записи в RAM. Вы знаете, что процессы обращения к памяти привязаны к тактам процессора и регулируются так называемыми синхронизирующими импульсами. С помощью SETUP BIOS пользователь может изменять величину задержки между импульсами и длину циклов.
    Следующие параметры этого типа имеют такую особенность: чем меньше их значение, тем интенсивнее работает память. Но, как вы понимаете, при повышении производительности снижается стабильность работы электроники. Поэтому рекомендуется оптимизировать систему постепенно, внося мелкие изменения и возвращаясь к рабочим режимам при первых проявлениях ошибок в работе памяти. Вот эти параметры:

    • SDRAM CAS Latency Time (время задержки SDRAM CAS);

    • SDRAM Cycle Time Tras/TrcTras/Trc (время цикла памяти SDRAM);

    • SDRAM RAS-to-CAS Delay (задержка SDRAM RAS-to-CAS);

    • SDRAM RAS Precharge Time (время предварительного заряда RAS SDRAM).

    Если ПК оснащен шиной AGP, то среди настроек наверняка можно встретить следующие параметры:

    • AGP Aperture Size MB. Технология AGP позволяет видеокарте "черпать" для своих нужд память из системной RAM. Эти параметры определяют не размер физической памяти, а адресное пространство. В современных компьютерах рекомендуется устанавливать размер апертуры в промежутке 64-128 Мб. Впрочем, строгих правил относительно этого не существует. Увеличив размер выделяемой памяти, вы не ухудшите производительность системы;

    • AGP2X Mode. Использовать режим AGP2X, позволяющий значительно увеличить пропускную способность шины, можно только в том случае, если и чип материнской платы, и видеокарта поддерживают AGP2x;

    • AGP4X Mode. Поскольку этот режим не совместим с AGP2X и AGP1X, по умолчанию производители материнских плат его отключают. Но при необходимости вы можете его включить.

    Свойства интегрированных устройств

    Как правило, в материнскую плату встроен ряд контроллеров периферийных устройств: контроллер IDE, контроллер последовательных и параллельных портов, клавиатуры, флоппи-дисковода и пр. Иногда возникает необходимость отключения некоторых устройств - например, для отладки или освобождения прерываний. В разделе INTEGRATED PERIPHERALS обычно можно встретить следующие пункты:

    Onboard IDE-1 Controller - первый контроллер IDE-дисков; если используются SCSI устройства, его можно отключить и тем самым освободить 14-е прерывание;

    Onboard IDE-2 Controller - если в компьютере установлено только одно IDE-устройство, а прерываний катастрофически не хватает, то, отключив IDE-2 Controller, можно освободить INT 15;

    Master/Slave Drive PIO Mode - этот параметр привязан к конкретному IDE-устройству и отвечает за режим передачи данных; обычно лучше предоставить BIOS самой подобрать нужное значение (режим Auto). Пропускная способность зависит от выбранного PIO следующим образом:

    PIO | Скорость, Мб/с
    0 | 3,3
    1 | 5,2
    2 | 8,3
    3 | 11,6
    4 | 16,6

    • Master/Slave Drive UltraDMA - этот параметр разрешает\запрещает включать UltraDMA и тоже привязан к конкретному контроллеру. Лучше удовлетвориться значением, присваиваемым ему по умолчанию; рекомендуется также проследить, чтобы сама ОС тоже использовала нужный режим для устройства;

    • USB Controller. Если в системе нет устройств USB, то в целях экономии прерываний можно присвоить этому параметру значение Disable;

    • USB Keyboard support. Как известно, шина USB поддерживается средствами ОС. Таким образом, до загрузки Windows клавиатура работать не должна. Режим USB Keyboard support позволяет BIOS самостоятельно, на этапе загрузки, обрабатывать события, поступающие от клавиатуры;

    • USB Keyboard Support Via BIOS/OS. В продолжение предыдущего замечания следует обратить внимание на то, что Windows может переключаться в режим, где устройства USB не работают. Включив поддержку клавиатуры через BIOS, пользователь получает возможность работать с клавиатурой в приложениях DOS. Но все же рекомендуется, за исключением описанного случая, использовать поддержку клавиатуры средствами ОС - как более функциональную;

    • Init Display First (AGP, PCI). Если в ПК установлено две видеокарты, этот режим помогает BIOS разобраться, какую из них использовать на стадии загрузки компьютера;

    • Onboard FDD Controller - с помощью этого параметра можно отключить интегрированный в материнскую плату контроллер флоппи-дисковода. Такая необходимость возникает в случае, если для этих целей используется отдельная плата MIO или дисковода вообще нет;

    • Report No FDD For Win95. Даже если у вас нет дисковода и вы отключили с помощью предыдущей опции контроллер FDD, Windows все равно будет отображать дисковод в списке устройств. Для устранения этой проблемы установите переключатель Report No FDD For Win95 в положение Enabled;

    • Onboard Serial Port 1/2. Этот параметр позволяет отключить порты COM1 и COM2, а также подобрать подходящие сочетания номеров порта ввода-вывода и прерывания. Если в компьютере не используются последовательные порты COM1 или COM2, то их можно отключить, освобождая соответствующие прерывания; в противном случае рекомендуется использовать режим Auto для автоматической настройки портов;

    • Onboard Parallel Port - этот параметр имеет такое же назначение, что и предыдущий, но относится к порту принтера;

    • Parallel Port Mode - позволяет настроить режим работы параллельного порта. Если вы пользуетесь современными принтерами или сканером, подключенным к принтерному порту, надо выбрать режим ECP+EPP (или тот, который рекомендован производителем периферии), реализующий двунаправленный обмен данными. Режим Normal предназначен для более старых моделей принтеров.

    Свойства слотов PCI

    В функции этого раздела входит правильное распределение системных ресурсов. Согласно этой технологии карта PCI может быть настроена на работу с определенным прерыванием и с определенным портом ввода-вывода. Более того: одно и то же прерывание может совместно использоваться несколькими устройствами PCI.
    Информация о распределении ресурсов хранится в специальной таблице - ESCD (Extended System Configuration Data). Но это не все. ОС, поддерживающая PnP, позже может перераспределить ресурсы по своему усмотрению. Считается, что Windows справляется с этой задачей эффективнее, чем BIOS компьютера. Однако все портят карты ISA, не поддерживающие PnP. Они настраиваются с помощью перемычек или специальных утилит. Поэтому может возникнуть необходимость закрепить за ISA- слотом определенное прерывание. Для этой цели служат следующие параметры:

    • PnP OS Installed. Это сложный параметр. Для Windows 95/98 рекомендуется установить значение Yes. Windows 2000 использует новейшую технологию ACPI, поэтому для нее Microsoft рекомендует значение No. Linux не является полностью PnP-системой, но при наличии PnP-карт ISA значение Yes может понадобиться для ISAPNPTOOLS. Здесь совет один: пока все в порядке, не трогайте этот параметр. Если же возникли проблемы, сверьте таблицы прерываний - ту, которую выводит BIOS после процедуры POST, и ту, которую использует Windows. Если существуют различия в неработающих платах - придется "поковыряться" в настройках BIOS и Windows;

    • Reset Configuration Data, Force Update ESCD. Бывает, что компьютер не распознает плату, установленную вместо старой. Присвоив параметру Reset Configuration Data значение Enabled, вы заставите BIOS "забыть" прежние установки и заново проанализировать конфигурацию;

    • Resource Controlled By. Как поступить с распределением ресурсов? Оставить это функциям BIOS (режим Auto) или же сделать вручную (Manual)? Если выбрать режим Manual, то активируются пункты, описанные ниже;

    • IRQ-X assigned to. Этот параметр позволяет прерыванию X назначить тип устройства. Режим Legacy ISA требует отдельных IRQ и DMA. Режим PCI/Pnp ISA позволяет использовать эти ресурсы совместно с другими платами. Например, для старой платы ISA, работающей, скажем, на прерывании 9 IRQ, можно во избежание конфликтов выбрать режим Legacy ISA;

    • Delayed Transaction и PCI 2.1 Compliance. Оба параметра отвечают за согласованность работы шин PCI и ISA. Если их активировать, то данные между этими шинами будут передаваться через буфер. Пока данные накапливаются в буфере, более быстрая PCI получит возможность обрабатывать транзакции.

    Управление питанием

    Современные BIOS позволяют оперировать четырьмя состояниями энергопотребления компьютера: работа на "полных оборотах", режим сниженной частоты центрального процессора (Doze), режим ожидания Standby (обычно заключающийся в отключении видео и жестких дисков), "спящий" режим Suspend (максимально низкое энергопотребление, отключение устройств).

    Система контролируется с помощью счетчика простоя определенных устройств. Если эти устройства бездействуют в течение определенного времени, система переходит в то или иное состояние пониженного энергопотребления.

    В начале раздела BIOS, управляющего режимами питания, пользователю предлагается выбрать схемы энергосбережения: две стандартные (Min saving и Max Saving) и настраиваемую. Возможно, вам подойдет одна из готовых схем. В противном случае выберите режим User define и введите вручную следующие уточняющие значения:

    • PM Control by APM. Advanced Power Management позволяет управлять питанием устройств средствами ОС;

    • Video off Method. В режиме DPMS монитор отключается сигналом от видеокарты. Если последняя не поддерживает протокол DPMS, то после очередного "засыпания" компьютер уже не "проснется". В любом случае, для современных мониторов лучше выбирать режим V/H SYNC + Blanc;

    • Video off After. Здесь нужно выбрать стадию энергосбережения, на которой будет отключаться монитор - Doze, Suspend или Standby;

    • Doze mode, Standby и Suspend. Вводятся временные интервалы, по истечении которых компьютер будет переходить в режимы Doze, Standby и Suspend;

    • HDD Power Down - если к жесткому диску давно не обращались, его тоже можно отключить.

    Пароли

    Если вы системный администратор, то ваше желание перекрыть посторонним доступ к настройкам SETUP можно понять: у некоторых пользователей любопытства больше, чем опыта. Кроме прочего, установка пароля на загрузку ПК с Windows 9x - единственный способ обеспечения конфиденциальности. В этом случае вам пригодятся следующие параметры SETUP:

    • Security. В режиме System требуется ввести пароль для запуска компьютера, в режиме Setup - только для входа в SETUP BIOS;

    • User Password - здесь можно установить пароль для пользователя, которому разрешены некоторые действия по простейшей настройке, такие как запуск компьютера, установка системного времени и некоторыми другими. Ввод "пустого" пароля отключает проверку пароля;

    • Supervisor Password - этот пароль предназначен для администрирования SETUP. Он позволяет изменить или отменить пользовательский пароль.

    Опции:

    Процессор

    CPU Mstr post WR Burst mode
    Опция включает пакетный режим передачи данных но, ЦП должен быть в режиме Bus-master. Значительно повышает производительность.
    Значение опции:
    *Enabled - включено;
    *Disabled - отключено.

    CPU Priority
    Устанавливает приоритет ЦП над другими устройствами, работающими в режиме master.
    Значение опции:
    *Always Last - приоритет ПЦ над другими устройствами;
    *CPU 2nd - ПЦ по приоритету на втором месте;
    *CPU 3nd - ПЦ по приоритету на третьем месте;
    *CPU 4nd - ПЦ по приоритету на четвёртом месте.

    Cache Timing Control
    Данная функция контролирует скорость чтения/записи данных кэш-памяти второго уровня.
    Значение опции:
    *Fast (Turbo) - быстрый режим, высокая производительность;
    *Medium - средняя скорость;
    *Normal - Нормальная скорость, низкая производительность, устанавливается по умолчанию.

    Видео карта

    Display Cache Window Size
    Функция устанавливает размер кэшируемой системой памяти, которая используется для видеосистемы.
    Значение опции:
    *32MB - размер кэшируемой памяти составляет 32 Мбайт;
    *64MB - размер кэшируемой памяти составляет 64 Мбайт.

    AGP Capability
    Позволит выбрать режим работы видеокарты. Оказывает прямое значение на производительность.
    Значение опции:
    *1X Mode - стандартный режим работы, данный режим устарел.
    *2X Mode - удвоенный режим передачи данных.
    *4X Mode - утроенный режим передачи данных. Самый быстрый.
    Возможно, на самых новых видеокартах есть режим *8X Mode - самый быстрый из всех предыдущих.

    AGP Master 1WS Read;
    AGP Master 1WS Write
    Количество тактов чтения/записи данных с шины AGP.
    Значение опции:
    *Enabled - включено, количество тактов равно 1. Производительность максимальная, но есть шанс не стабильной работы.
    *Disabled - отключено. Количество тактов равно 2. Работа - стабильна.

    VGA 128K Range Attribute
    Между видеопамятью и ЦП включает буфер, увеличивается производительность.
    Значение опции:
    *Enabled - включено;
    *Disabled - отключено.

    Оперативная память

    FSB/SDRAM/PCI Freq. (MHz)
    Функция позволит выбрать значение частот FSB, SDRAM и PCI.

    Memory Hole At 15-16M
    Копирует медленную память устройств ISA в оперативную память.
    Значение опции:
    *Disabled - отключено, используется, если в системе нет ISA - устройств;
    *Enabled - включено, используется, если в системе есть ISA - устройства.

    Memory Read Wait State
    Функция контролирует задержку при чтение данных из оперативной памяти. Маленькая задержка - большая производительность, но есть шанс не стабильной работы.
    Значение опции:
    *0, 1, 2, 3 - задержка в тактах системной шины.

    Optimization Method
    Функция увеличивает скорость обмена данными с оперативной памятью. Повышает производительность.
    Значение опции:
    *Normal - стандартные параметры обмена;
    *Turbo 1 - ускоренные параметры обмена;
    *Turbo 2 - максимально быстрые параметры обмена.

    SDRAM CAS Latency Time;
    SDRAM RAS-to-CAS Delay;
    SDRAM RAS Precharge
    Данные опции оказывают прямое значение на производительность. Чем меньше значение - тем больше производительность, но есть шанс не стабильной работы.

    Жёсткий диск

    HDD SMART Capability
    Опция включает SMART. При этом понижается общая производительность системы.
    Значение опции:
    *Enabled - включено;
    *Disabled - отключено.

    IDE Burst Mode
    Опция включает буфер данных, имеющийся на любом современном HDD интерфейса IDE. Значительно повышает производительность.
    Значение опции:
    *Enabled - включено;
    *Disabled - отключено.

    IDE Burst for DOS & Windows
    Опция включает буфер для интерфейса IDE упреждающего чтения и отложенной записи.
    Повышается пропускная способность канала IDE. Повышает общая производительность.
    Значение опции:
    *Enabled - включено;
    *Disabled - отключено.

    IDE HDD Block Mode Sectors
    Режим поблочной многосекторной передачи данных с HDD. Значительно повышает производительность.
    Значение опции:
    *HDD MAX - авто определение;
    *Своё значение - обратитесь к инструкции HDD.

    Несколько интересных опций

    Automatic Power Up
    Включить компьютер в определённое время.
    Значение опции:
    *Everyday - каждый день в определённое время;
    *By date - в определённую дату, время, месяц, и другое.
    *Disabled - отключено.

    Wake On PS/2 KB/Mouse
    Включает компьютер при нажатие на <пробел> или ЛКМ.
    Значение опции:
    *Enabled - включено;
    *Disabled - отключено.

    Выход и сохранение параметров

    Внесенные изменения следует сохранить. Для этого существует команда Save and Exit. Если вы не уверены, что сделали все правильно, и хотели бы отменить изменения, воспользуйтесь режимом Discard and Exit (Do not save and Exit).

    Load Setup Default. Она восстанавливает заводские установки. Как правило, это самая надежная и универсальная комбинация параметров, которой можно воспользоваться, если по-другому компьютер не запускается.

    Load Bios Default. По ней загружается сам код BIOS, сохраненный в специальной области памяти. Такая операция может понадобиться, если BIOS выдает сообщение об ошибке контрольной суммы, что свидетельствует о нарушении структуры информации в Flash BIOS.

    Комментарии пользователей

    Прошу вас исключить из настроек bios "AGP Capability" или предупредить ЧТО НА ВИДЕОКАРТАХ RIVA TNT возможна не корректная работа. Женя <proverka@roki.com>

    Увеличение производительности

    (Аналогично для соответствующих параметров DRAM-памяти.)

  • «SDRAM Configuration» или «Auto Configuration» (конфигурация SDRAM-памяти) — параметрами опций определяется, должна ли BIOS устанавливать временные характеристики доступа к памяти на основании информации из SPD-модуля («By SPD» ) или же пользователь проведет конфигурирование доступа самостоятельно («User Defined» ).
    В качестве фиксированных значений могут быть предложены параметры:
    «7 ns (143 Mhz)» и «8 ns (125 Mhz)» как для памяти с временем доступа «7 нс/8 нс» и соответственно частотой шины «143 МГц/125 МГц». Если Вы хотите произвести какие-либо изменения в настройках, то следует поставить «User Defined» для «SDRAM Configuration» или выключить опцию «Auto Configuration» (значение «Disabled» ).
    «SDRAM CAS# Latency» (задержка CAS для SDRAM) — максимальное быстродействие памяти достигается при минимальных значениях величин «CAS Latency», соответственно поставьте её значение поменьше, если это не нарушит стабильность работы компьютера.
    • Значение «3T» соответствует времени доступа «8ns»,
    • Значение «2.5T» соответствует времени доступа «7ns»,
    • Значение «2T» соответствует времени доступа «6ns».

    «SDRAM CAS to RAS Delay» (задержка CAS для SDRAM) — параметр определяет значение задержки после выдачи сигнала RAS до появления сигнала CAS для синхронной памяти. Чем меньше это значение, тем быстрее доступ к памяти и производительность системы.
    Может принимать значения:
    • «3» — три такта задержки,
    • «2» — два такта задержки.

    «SDRAM (CAS Lat/RAS-to-CAS)» (Cинхронная память — задержка CAS/От RAS к CAS) — этот параметр позволяет комбинировать между длительностью сигнала CAS и задержкой между сигналами RAS и CAS. Значение этого параметра зависит от характеристик SDRAM, примененной в материнской плате и от быстродействия процессора. Поэтому изменять этот параметр стоит крайне осторожно.
    Может принимать значения:
    • «2/2»
    • «3/3»

    «SDRAM RAS Precharge Time» или «SDRAM RAS Precharge Delay» (синхронная память — время предварительного заряда или задержка предварительного заряда) — параметр позволяет определять быстрое или медленное накопление заряда по RAS до начала цикла регенерации памяти.
    Может принимать значения:
    • «Fast» увеличивает быстродействие,
    • «Slow» повышает стабильность работы компьютера,
      или аналогично:
    • «2T»
    • «3T»

    «SDRAM Banks Close Policy» (правила закрытия банков SDRAM памяти) — параметр был введен для плат с набором 440LX из-за того, что память с 2-х банковой организацией некорректно работает в этих платах, если параметры доступа к банкам памяти установлены по умолчанию. В наборе 430TX этого не требовалось, так правила доступа для различной памяти были одинаковы. Изменять установки BIOS по умолчанию для этого параметра следует только в случае нестабильной работы памяти. Может принимать значения:
    • «Page Miss» — используется для двух банковой памяти
    • «Arbitration» — для памяти из 4-х банков

    «SDRAM Idle Timer» (таймер пассивного состояния страницы памяти) — этим параметром устанавливается время (в тактах) до закрытия всех открытых страниц памяти. Влияет как на EDO так и на SDRAM память. Для увеличения быстродействия устанавливается минимальное значение данного параметра, однако при этом возможна нестабильная работа системы. Оптимальный вариант устанавливается опытным путем.
    Может принимать значения:
    • 0, 2, 4, 8, 10, 12, 16, 32; или
    • 1T, 2T, 4T, 8T.

    «Delayed Transaction» (задержанная транзакция на PCI) — присутствие этого параметра в BIOS означает, что на материнской плате есть встроенный 32-битный буфер с задержанной записью для поддержки удлиненного цикла обмена на PCI-шине. Если этот параметр разрешен, то доступ к шине PCI разрешен во время доступа к 8-разрядным устройствам на шине ISA. Это существенно увеличивает производительность системы, так как цикл такого обращения на ISA-шине занимает 50-60 тактов шины PCI. Если компьютер укомплектован материнской платой, не поддерживающей спецификацию PCI 2.1, этот параметр следует запретить, поскольку данная опция включает режим совместимости с этой спецификацией с одновременным включением в "северном" мосте упомянутого выше специального буфера. Может принимать значения:
    • «Enabled» — разрешено,
    • «Disabled» — запрещено.
    Опция может называться также «PCI Delayed Transaction», «Delayed Transaction Optimization» или «Delayed Transaction Timer» с теми же значениями (включено/отключено).
    «Video ROM BIOS Shadow»(видео BIOS в память) — разрешение этого параметра приводит к переносу видео BIOS из ПЗУ (постоянного запоминающего устройства) на видеокарте в основную память компьютера, что значительно ускоряет работу с видео BIOS (это необходимо и видно в DOS). Ускорение объясняется как и тем, что обращение к ПЗУ намного медленнее, чем к ОЗУ, так и тем, что обращение к ПЗУ, как правило, выполняется в 8-ми разрядной сетке, а к ОЗУ — 32-х или 64-х сетке. Может приниматьзначения:
    • Enabled — разрешено
    • Disabled — запрещено

    «Video BIOS Cacheable» («System BIOS Casheable») (кэширование области BIOS видеокарты) — Разрешение этого параметра приводит к появлению возможности кэширования области памяти по адресам BIOS видеокарты с «C0000H» по «C7FFFH» в кэш-память. Параметр будет использован только в том случае, если использование кэш-памяти разрешено в разделе «BIOS Features Setup» . Если какая-либо программа попытается выполнить операцию записи в эти адреса, то система выдаст сообщение об ошибке. Может принимать значения:
    • Enabled — разрешено
    • Disabled — запрещено

    • Уменьшение времени загрузки

    «Quick Power On Self Test» (быстрый тест компьютера после включения питания) — Разрешение этого параметра приводит к некоторому сокращению времени на начальное самотестирование компьютера (POST), особенно при значительных объемах оперативной памяти. Следует только учесть, что память, например, в этом случае не тестируется, а только проверяется ее размер. Сокращение времени тестирования происходит также за счет пропуска некоторых пунктов проверки. Если при работе ПК возникают какие-либо проблемы, то лучше при его включении осуществлять полный тест. Может принимать значения:

    • «Enabled» — разрешено
    • «Disabled» — запрещено (по умолчанию)

  • «Boot Up Floppy Seek» (поиск дисковода при загрузке компьютера) — при включении («Enabled» ) этой опции BIOS проверяет, есть ли в компьютере дисковод и идет ли речь при этом о 40- или 80-тидорожечном дисководе. При этом обеспечивается проверка его работоспособности. Поскольку все современные дисководы имеют 80 дорожек (с 1993 года 40-дорожечные, поддерживавшие формат 360 КБ, не выпускаются), то эта функция необязательна, тем более, что BIOS не может определить разницу между 720K, 1.2M, 1.44M или 2.88M типами дисководов, т.к. все они имеют 80 дорожек. Имеет смысл отключить эту опцию («Disabled» ), что позволит сократить общее время тестирования ПК после включения.

  • «Boot Sequence» (последовательность начальной загрузки системы) — определяется последовательность опроса накопителей для загрузки операционной системы. Эти устройства обозначаются либо буквами для физических жестких дисков и обычных дисководов, либо названием устройства. Поддерживаются устройства: LS-120, Iomega ZIP, ATAPI CD-ROM, IDE- и SCSI-диски. Может принимать значения:
    • «A,C» — такой выбор оправдан только для случая загрузки с дискеты и встречается в старых моделях ПК
    • «A,C,SCSI»
    • «C only»
    • «C,A»
    • «C,A,SCSI»
    • «C,CDROM,A»
    • «CDROM,C,A»
    • «D,A,SCSI» (предназначено при использовании минимум двух IDE-жестких дисков)
    • «E,A,SCSI» (аналогично для 3-х дисков)
    • «F,A,SCSI» (аналогично для 4-х дисков)
    • «LS/ZIP,C»
    • «SCSI,A,C»
    • «SCSI,C,A»

    В некоторых версиях BIOS опция «Boot Sequence» трансформировалась в несколько самостоятельных опций, с большей возможностью отбора и большей гибкостью: «First Boot Device», «Second Boot Device», «Third Boot Device», «Boot Other Device» (соответственно «первое», «второе», «третье» и «другое» загрузочные устройства). Могут принимать следующие значения:

    • «Floppy»
    • «HDD-0»
    • «HDD-1»
    • «HDD-2»
    • «HDD-3»
    • «LAN»
    • «SCSI»
    • «LS/ZIP»
    • «CDROM»
    • «Enable»
    • «Disable»
    Обычно, следует выбирать вариант, в котором первым опрашиваемым устройством является жесткий диск, чтобы система не тратила время на опрос других накопителей.

    «Boot Virus Detection» (определение вируса в загрузочном секторе) — если этот параметр выключен («Disabled»), то до загрузки операционной системы BIOS переписывает загрузочный сектор во флэш-память и сохраняет его там. После включения («Enabled») параметра — BIOS не будет загружать систему с жесткого диска, если содержимое boot-сектора отличается от сохраненного в памяти. Далее, по усмотрению пользователя, возможно либо загрузить систему с жесткого диска, либо с дискеты.
    Включение этой опции лишь незначительно увеличивает время загрузки, поэтому отключать её не следует.

    «Auto» (автоматическое определение параметров дисков и выбор режима, в котором они будут работать) в меню «Main», в разделах «Primary Master» и «Secondary Slave», куда, обычно, подключены HDD и CD-ROM.
    Полученные после процедуры автоматического определения параметры следует оставить без изменения, но включить режимы «User Type HDD» и «CD-ROM» . Это ускорит загрузку компьютера на несколько секунд, которое тратиться на автоматическое определение этих же параметров. Режим «Auto» необходимо включить при замене жёсткого диска или привода компакт-дисков.

    «Ultra DMA(UDMA)» (прямой доступ к памяти) — регулируется в тех же разделах, что и предыдущий параметр. Обозначение «UDMA 5» соответствует режиму UDMA 100 (ATA 100), «UDMA 4» — UDMA 66 (ATA 66) и т.д.
    Этот режим поддерживается практически всеми современными жесткими дисками и позволяет повысить производительность системы в целом.

    • Ошибки и сигналы

    Аварийные звуковые сигналы, издаваемые Award-БИОС при загрузке

    Количество сигналов | Проблема | Решение
    1 короткий во время показа логотипа. | Тестирование POST пройдено успешно. | Всё в порядке.
    Длинный непрерывный сигнал. | Не обнаружена или неисправна оперативная память. | Переинсталлируйте оперативную память. Проверьте оперативную память. Замените оперативную память.
    1 длинный 3 коротких | Не обнаружена видеокарта или неисправна видеопамять. | Переинсталлируйте видеокарту. Проверьте видеопамять. Замените карту.
    Частые бессистемные сигналы во время нормальной работы. | Принудительный перевод CPU не более низкую частоту, как правило, вследствие перегрева. | Вызвать окно "Подключение сетевого диска"

    Сообщения об ошибках, выдаваемые Award-БИОС при загрузке

    Cообщение | Проблема | Решение
    CMOS BATTERY HAS FAILED. | Села батарейка. | Замените батарейку.
    CMOS CHECKSUM ERROR. | Неправильная контрольная сумма CMOS. Данные в CMOS повреждены. Возможно, батарейка села. | Проверьте батерейку и замените ее в случае необходимости.
    DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER. | Не найден загрузочный диск. | Загрузитесь с дискеты и проверьте системные файлы на жестком диске.
    DISKETTE DRIVES OR TYPES MISMATCH ERROR — RUN SETUP. | Типы дисководов, фактически установленных в системе и их описания в CMOS не сходятся. | Запустите «Setup BIOS» и введите правильный тип дисковода
    DISPLAY SWITCH IS SET INCORRECTLY. | Неправильно выставлен тип монитора (цветной или моно) на материнской плате. | Переставьте джампер в правильное положение.
    DISPLAY TYPE HAS CHANGED SINCE LAST BOOT. | Изменился тип дисплея со времени последней загрузки. | Запустите «Setup BIOS» и введите правильный тип дисплея.
    ERROR ENCOUNTERED INITIALIZING HARD DRIVE. | Не инициализируется жесткий диск. | Проверьте установку контроллера жестких дисков и соединительные кабеля.
    ERROR INITIALIZING HARD DRIVE CONTROLLER. | Контроллер жестких дисков не инициализируется. | Проверьте установку контроллера, и параметры жесткого диска, указанные в «Setup BIOS». Также проверьте джампера на жестком диске.
    FLOPPY DISK CNTRLR ERROR OR NO CNTRLR PRESENT. | Невозможно инициализировать контроллер гибких дисков. | Проверьте установку контроллера, и параметры дисковода, указанные в «Setup BIOS».
    DISPLAY SWITCH IS SET INCORRECTLY. | Неправильно выставлен тип монитора (цветной или моно) на материнской плате. | Переставьте джампер в правильное положение.
    KEYBOARD ERROR OR NO KEYBOARD PRESENT. | Невозможно инициализировать клавиатуру. | Проверьте подключение клавиатуры и ее тип. В крайнем случае отключите контроль клавиатуры при загрузке.
    Memory Address Error at XXXX. | Ошибка памяти. | Замените память.
    Memory parity Error at XXXX. | Ошибка контроля четности. | Замените память.
    MEMORY SIZE HAS CHANGED SINCE LAST BOOT. | Размер памяти изменился со времени последней загрузки. | Войдите в «Setup BIOS».
    Memory Verify Error at XXXX. | Ошибка при тестировании памяти. | Замените память.
    OFFENDING ADDRESS NOT FOUND. | Неисправен контроллер памяти. | Замените контроллер памяти.
    OFFENDING SEGMENT: Неисправен контроллер памяти. Замените контроллер памяти.
    PRESS A KEY TO REBOOT. | Сообщени возникает при обнаружении ошибок и необходимости перезагрузки. | Нажмите любую кнопку.
    PRESS F1 TO DISABLE NMI, F2 TO REBOOT. Проблемы с немаскируемыми прерываниями. —
    RAM PARITY ERROR — CHECKING FOR SEGMENT. Ошибка четности в RAM. —
    SYSTEM HALTED, (CTRL-ALT-DEL) TO REBOOT .... | Обозначает остановку процесса загрузки. | Нажмите <Ctrl-Alt-Del>.

    Прошивка БИОС

    Прошивка - вступление

    BIOS («Basic Input-Output System» – «Базовая Система Ввода-Вывода») – это программа, доступная компьютеру без обращения к диску и содержащая код, необходимый для управления ключевыми устройствами системы (клавиатурой, видео картой, дисками, портами и другими устройствами). Логично предположить, что, если BIOS не нуждается в дисковых накопителях, то для его хранения используется принципиально другой носитель информации, всегда доступный независимо от состояния дисковой системы, что, собственно, и позволяет компьютеру самостоятельно загружаться.

    • PROM («programmable read-only memory» — «программируемая память только для чтения») — это чип памяти, данные в который могут быть записаны только однажды. То что записано в PROM, не вырубишь топором :) (хранится в нем всегда). В отличии от основной памяти, PROM содержит данные даже когда компьютер выключен.
    • Отличие PROM от ROM («read-only memory» — «память только для чтения») в том, что PROM изначально производятся чистыми, в тот время как в ROM данные заносятся в процессе производства. А для записи данных в чипы PROM, применяются специальные устройства, называемые программаторами.
    • EPROM («erasable programmable read-only memory» — «стираемая программируемая память только для чтения») — специальный тип PROM, который может очищаться с использованием ультрафиолетовых лучей. После стирания, EPROM может быть перепрограммирована. EEPROM — по сути похожа на PROM, но для стирания требует электрических сигналов.
    • EEPROM («electrically erasable programmable read-only memory» — «электрически стираемая программируемая память только для чтения») — специальный тип PROM, который может быть очищен электрическим разрядом. Подобно другим типам PROM, EEPROM содержит данные и при выключенном питании компьютера. Аналогично всем другим типам ROM, EEPROM работает не быстрее RAM.
    • Специальный тип EEPROM, называемый «Flash memory» или «Flash ROM» («Flash EEPROM»), может быть перезаписан без применения дополнительных устройств типа программатора, находясь в компьютере.
    Необходимо уточнить, что понятие «Flash ROM» не во всех случаях эквивалентно понятию «Flash BIOS» . Хотя почти всегда эти термины обозначают одно и то же, можно встретить материнские платы, которые не позволяют обновлять BIOS программно, несмотря на то, что на них установлена микросхема «Flash ROM» . То есть возможность модернизации BIOS с помощью программы и без извлечения его из материнской платы должна быть предусмотрена дизайном платы. Как правило, этот момент четко оговаривается в руководстве пользователя к материнской плате. Существует несколько причин, по которым приходится модернизировать BIOS:
    • Появление нового оборудования, поддержки которого просто не могло быть в момент выхода в свет оригинальной версии BIOS. Чаще всего это новые процессоры. Согласитесь, несколько неприятно видеть при загрузке компьютера надпись «Pentium II», в то время как на самом деле у Вас последняя модель «Pentium III Coppermine» . Однако, помимо чисто внешних проявлений совместимости, новый BIOS может нести в себе поддержку новых функций процессора (например, возможность блокировки серийного номера процессора) или же возможность настройки ранее недоступных параметров (изменение латентности кэш-памяти второго уровня у «Pentium III Katmai» ). Кроме процессоров, существует еще масса разнообразного оборудования, поддержка которого в BIOS может стать со временем просто необходимой. Это и жесткие диски, максимальный объем которых очень некстати может быть ограничен со стороны BIOS, и приводы CD-ROM или ZIP-Drive, которые можно использовать в качестве загрузочных устройств и так далее.
    • Выход нового программного обеспечения. Эта проблема была чрезвычайно актуальна тогда, когда появилась операционная система «Windows 95», поддерживающая стандарт «Plug’n’Play» . Для реализации этого стандарта в полной мере необходим совместимый с ним BIOS. В настоящее время эта проблема практически потеряла свою актуальность, так как все современные материнские платы изначально комплектуются PnP BIOS. Но это вовсе не означает, что появление нового программного обеспечения больше не является серьезной причиной для модернизации BIOS. Так, с выходом «Windows 98» и «Windows 2000» появилась необходимость в полноценной поддержке со стороны BIOS стандарта ACPI, регулирующего энергопотребление компьютера.
    • Производительность компьютера, на которую новая версия BIOS может повлиять самым положительным образом. Примером такого изменения может служить уже упоминавшаяся возможность изменения латентности кэш-памяти второго уровня у ранних моделей «Pentium III», появившаяся в BIOS многих производителей материнских плат лишь спустя значительный промежуток времени после выхода этих моделей процессоров в свет. Кроме этого, на производительность системы самым решительным образом могут повлиять изменения, касающиеся инициализации регистров набора системной логики.
    • Расширение возможностей конфигурирования. Обновление BIOS зачастую позволяет значительно разнообразить поведение компьютера. Это может быть и загрузка с любого жесткого диска, установленного в системе, и автоматическое включение компьютера в определенный момент времени, и интеллектуальный мониторинг за состоянием системы, позволяющий, например, регулировать скорость вращения вентиляторов в зависимости от температуры компонентов, и многое другое.
    • Исправления мелких ошибок и недоработок, как правило, не влияющих на работу большинства пользователей, но устраненных в новых версиях BIOS.
    При всех явных преимуществах, которые сулит обновление BIOS, нельзя забывать, что эта операция сопряжена с серьезным риском выхода вашей системы из строя. Кроме этого, нет никакой гарантии, что новая версия BIOS позволит решить все ваши проблемы. В отдельных случаях для возможности полноценного использования новых функций BIOS необходимо переустановить операционную систему. Поэтому, если Ваш компьютер работает стабильно и новая версия BIOS не содержит кардинальных изменений, которые Вам действительно необходимы, категорически рекомендуется воздержаться от модернизации BIOS.

    Что для этого нужно ?

    Как видно из названия статьи, речь пойдет исключительно об обновлении Award-БИОС. Такой выбор обусловлен тем, что этот производитель наиболее популярен среди разработчиков материнских плат.

    Однако, прежде чем приступать непосредственно к модернизации BIOS, необходимо уточнить несколько немаловажных деталей. Нужно узнать, кем произведена ваша материнская плата, какова ее модель и возможно ли программное обновление BIOS.

  • Простейший способ это сделать – заглянуть в руководство пользователя, идущее в комплекте с материнской платой либо с готовым компьютером.
  • Если производителя и название материнской платы определить не удается, их можно определить по идентификационной строке, которую выдает BIOS сразу при включении компьютера.

    Идентификационная строка Award-БИОС имеет вид «2A59CQ1CC»
    и позволяет определить чипсет (первые пять цифр и букв — «2A59C» ), производителя материнской платы (следующие два символа — «Q1») и модель материнской платы (оставшаяся часть строки — «CC»). Далее необходимо посмотреть обозначения чипсетов, производителей и моделей в идентификационных строках.

  • Чтобы определить, что установленный на материнской плате BIOS, прошит во Flash ROM, можно определить тип микросхемы ПЗУ, установленной на материнской плате. Для этого необходимо посмотреть на маркировку чипа ROM (28 или 32-контактная микросхема с наклейкой производителя BIOS), отодрав наклейку. Маркировка означает следующее («ххх» означает три произвольных цифры):
    • «28Fxxx» — 12V Flash память
    • «29Cxxx» — 5V Flash память
    • «29LVxxx» — 3V Flash memory (раритет)
    • «28Cxxx» — EEPROM, почти то же, что и Flash память
    • «27Cxxx» — с окошком. EPROM: только для чтения, требует программатор для записи и ультрафиолетовую лампу для стирания
    • «PH29EE010»: SST ROM чип — перепрошиваемый
    • «29EE011»: Winbond чип — 5V Flash память
    • «29C010»: Atmel чип — 5V Flash память
    Любые другие микросхемы, не имеющие окошка с маркировкой, не начинающейся с цифр «28» или «29», являются, скорее всего не «Flash-памятью» . Если же на микросхеме есть окошко — это верный признак того, что это не «Flash» . Многие производители материнских плат настоятельно рекомендуют соблюдать ряд условий, способствующих успешному обновлению BIOS. Вот они:

    • Обязательно переведите систему в штатный режим, если она у вас разогнана.
    • Отключите («Disable» или «Off» ) в «BIOS Setup» все пункты, в которых встречается слово «Shadow» (раздел «Chipset Features Setup» ). Поскольку доступ к оперативной памяти (RAM) осуществляется значительно быстрее, чем к ROM, многие производители компьютеров помещают в «BIOS Setup» опцию, позволяющую копировать BIOS материнской платы и видео карты из ROM в оперативную память. Соответственно, уменьшается объем доступной оперативной памяти, что может негативно сказаться на процессе обновления BIOS.
    • Отключите в BIOS Setup все функции автоматического управления питанием компьютера (раздел «Power Management Setup» ).
    • Отключите в BIOS Setup функции кэширования системного и видео BIOS (System BIOS Cacheable и Video BIOS Cacheable в разделе «Chipset Features Setup» ), иначе будет выведено сообщение «Insufficient memory» и процесс прошивки не запустится.
    • Включите опцию «Update BIOS» или установите перемычку управления записью BIOS, если таковая имеется на вашей плате, в разрешающее положение (подробнее смотрите в руководстве пользователя к плате).
    Все эти меры необходимы лишь для модернизации BIOS. После ее успешного завершения рекомендуется вернуть все установки в исходное положение.

    Прошивка в режиме командной строки

    Выяснили все необходимые сведения, убедились, что программная модернизация BIOS на вашей плате осуществима, вы можете приступать к обновлению.
    Для этого необходимы два файла – программа «Award Flash» (Flash Memory Writer) и файл с обновлением BIOS, имеющий обычно расширение «*.bin» . Последняя версия «Award Flash» всегда доступна на сайте производителя материнской платы, как и обновления BIOS вашей материнской платы. Это единственный надежный источник обновлений BIOS. Никогда не используйте для модернизации файлы, в происхождении которых вы не уверены.
    Нужно отметить, что «Award Flash» поддерживает как диалоговый режим работы, так и параметры командной строки. В данной статье диалоговый режим работы не рассматривается, так как зачастую он лишь усложняет процесс обновления BIOS и обладает меньшим количеством возможностей по сравнению с режимом командной строки. Более того, параметры командной строки позволяют полностью автоматизировать модернизацию BIOS, избавляя пользователя от ввода каких-либо данных. Поэтому стоит подробно остановиться на параметрах утилиты «Award Flash» .
    «Award Flash», как и большинство других программ для перезаписи Flash BIOS, следует запускать только из реального режима DOS до старта Windows или других многозадачных операционных систем.
    Производители материнских плат, такие как «ASUSTek COMPUTERS» и «Gigabyte Technology» предлагают пользователям возможность обновления BIOS из «Windows» .
    Обновление BIOS с помощью DOS-версии «Award Flash», являющейся универсальным инструментом для модернизации Award Flash BIOS на любой материнской плате.

    В случае использования «Windows 9x» необходимых условий для запуска «AwardFlash» можно достичь, выбрав в меню загрузки системы (вызывается в самом начале загрузки клавишей <F8>) пункт «Safe Mode Command Prompt Only» или же загрузившись с предварительно созданной системной дискеты. Последний вариант предпочтительнее и именно он рассматривается в дальнейшем. Рекомендуется предварительно отформатировать дискету и перенести на нее системные файлы. Затем нужно скопировать на нее утилиту «AwardFlash» и файл с обновлением BIOS. Условно обозначим их как awdflash.exe и newBIOS.bin. Дискету необходимо оставить открытой для записи.
    После этого создайте на дискете файл autoexec.bat следующего содержания:

    @echo off
    if exist oldBIOS.bin goto old
    awdflash.exe newBIOS.bin oldBIOS.bin /py /sy /cc /cp /cd /sb /r
    goto end
    :old
    awdflash.exe oldBIOS.bin /py /sn /cc /cp /cd /sb /r
    :end

    Теперь дискета содержит все необходимые для обновления файлы – awdflash.exe, newBIOS.bin, autoexec.bat и системные файлы (как правило, это msdos.sys, io.sys и command.com). Никаких других файлов на дискете быть не должно. На первый взгляд может показаться, что приведенный autoexec.bat слишком усложнен. Однако такая структура позволяет обойтись созданием одной универсальной дискеты, которую можно будет использовать не только для обновления BIOS, но и для возврата к предыдущей версии в случае неудачной модернизации.
    При первой загрузке с созданной дискеты произойдет обновление BIOS. При этом в файле oldBIOS.bin будет сохранена текущая версия BIOS. Если же загрузиться с этой дискеты второй раз, то будет запрограммирован ранее сохраненный oldBIOS.bin. То есть произойдет откат к старой версии. Поэтому, сразу после обновления BIOS, как только компьютер перезагрузится (а в нашем случае это произойдет автоматически), необходимо обязательно вынуть дискету из дисковода!
    Конечно же, набор параметров утилиты «AwardFlash», использованный в примере, носит лишь рекомендательный характер и призван максимально обезопасить процесс обновления BIOS. Квалифицированный пользователь может добавить или убрать некоторые из них. Но при этом нельзя забывать одно простое правило: не делайте ничего такого, в чем вы не уверены на все сто процентов.
    Безусловно, чтобы убирать или добавлять какие-либо параметры, необходимо знать, что же они означают. Поэтому далее следует достаточно подробное описание всех параметров командной строки утилиты «AwardFlash» .
    Ее синтаксис таков:
      AWDFLASH [Имя Файла1] [Имя Файла2] [/ключ [/ключ]...]
      Имя Файла1:имя файла для программирования
      Имя Файла2:имя файла для сохранения предыдущей версии BIOS
    Значения параметров:
    • «/?» – Помощь. Перед работой с «Award Flash Memory Writer» внимательно ознакомьтесь с возможностями программного обеспечения, пользуясь этим ключом.
    • «/Py» или «/Pn» — Отвечать на запрос программирования BIOS да (Y) или нет (N). Пользуясь ключом «/Pn» можно запретить программирование микросхемы «FlashROM» . Эту опцию можно использовать для того, чтобы сохранить текущую версию BIOS или получить ее контрольную сумму, не обновляя BIOS. Создание резервной копии позволяет восстановить предыдущую версию BIOS. По умолчанию используется значение «/Py» .
    • «/Sy» или «/Sn» — Отвечать на запрос о сохранении предыдущей версии BIOS да (Y) или нет (N). По умолчанию используется значение «/Sy» . В этом случае до программирования микросхемы FlashROM требуется подтвердить процедуру сохранения по запросу: Do You Want To Save BIOS (Y/N) Ключ /Sn рекомендуется к использованию в *.bat файлах для режима автоматического программирования в системах без монитора.
    • «/CC» — Очистить CMOS после программирования. Полезная опция для обновления старых версий BIOS, когда существует риск, что новая версия BIOS формирует массивы данных в CMOS, отличающиеся от уже имеющихся. В такой ситуации возможны проблемы со стартом материнской платы. Программное обнуление CMOS позволяет избежать поиска перемычки «Clear CMOS» на платах с утерянной документацией либо в тех случаях, когда доступ к плате затруднен.
    • «/CP» — Обнулить таблицу «PnP (ESCD) Data» после программирования. Информация о PnP устройствах хранится в блоке данных ESCD. Использование ключа «/CP» эквивалентно использованию параметра «Reset Configuration Data» в меню «PnP/PCI Configuration CMOS SetUp» . Использование ключа «/CP» целесообразно в случае, когда выполняется переход через несколько версий BIOS, либо если установлены новые PnP карты и без обновления блока данных ESCD старт материнской платы будет проблематичным.
    • «/CD» — Обнулить пул «DMI Data» после программирования. DMI – это база данных, содержащая всю информацию о компьютерной системе в целом. Обнуление полезно, как и в случаях описанных при использовании ключей «/CP» и «/СС», так и при замене любого из компонентов компьютерной системы.
    • «/SB» — Не программировать «BootBlock» . Загрузочный блок, первый выполняемый по старту материнской платы модуль, крайне редко претерпевает изменения. Если производителем материнской платы не оговорено противное, нет необходимости перепрограммировать «BootBlock» . В частности, по причине того, что сбой при программировании может привести к невозможности восстановления BIOS программными средствами. Некоторые платы имеют перемычку «BootBlock Protection» . Если перемычка «BootBlock Protection» установлена, без использования ключа «/SB» программирование BIOS будет невозможно или приведет к ошибкам верификации.
    • «/SD» — Сохранить данные DMI пула в файле. Область DMI может быть сохранена для последующего использования программным обеспечением. Несмотря на наличие этого парметра в списке, выводимом с помощью ключа «/?», его использование не дает никакого результата. Попросту говоря, это параметр не работает.
    • «/R» — Выполнение системного «RESET» после программирования. Позволяет автоматически перезагрузить компьютер после окончания программирования «FlashROM» . Опция полезна для работы через *.bat файл.
    • «/Tiny» — Использовать меньше оперативной памяти.
      Утилита «AwardFlash», если не используется ключ «/Tiny», пытается загрузить в оперативную память весь файл BIOS для последующего программирования. Если в процессе выполнении записи, несмотря на все принятые в процессе подготовки к обновлению, меры возникает сообщение «Insufficient Memory», следует использовать ключ «/Tiny» . В этом случае в оперативную память данные из файла BIOS будут загружаться и программироваться блоками.
    • «/E» — Возврат в DOS после программирования. Например, для того чтобы убедится, что правильно сохранена предыдущая версия BIOS.
    • «/F» — Программировать средствами системного BIOS. Большинство современных BIOS содержат процедуры записи «FlashROM» . Используя ключ «/F», программа «AwardFlash» программирует «FlashROM» алгоритмами, которые находятся в текущей версии BIOS. Если материнская плата выполнена с такими конструктивными особенностями, что использование алгоритмов «AwardFlash» Writer не приводит к успешному результату, следует воспользоваться ключом «/F» .
    • «/LD» — Очистить CMOS после программирования и не выводить системное сообщения «Press F1 to continue or DEL to setup» . В отличие от ключа «/CC» данная опция позволит после обнуления CMOS при следующем старте избежать сообщения «Press F1 to continue or DEL to setup», установив параметры по умолчанию.
    • «/CKS» — Отображение контрольной суммы файла XXXXh. Контрольная сумма файла выводится на экран монитора в шестнадцатеричном представлении. Полезно использовать с ключом верификации.
    • «/CKSxxxx» — Сравнить контрольную сумму файла с XXXXh. Если контрольные суммы не совпадают, выводится сообщение: "The program file's part number does not match with your system!». Значение XXXXh для каждого файла обновления BIOS, как правило, публикуется производителем материнской платы на своем сайте.
    Все параметры утилиты допускают ввод как в верхнем, так и в нижнем регистре.
    Изучив параметры утилиты и изменив их по своему желанию (или же оставив все, как в рекомендованном примере), вы можете обновлять BIOS. Для этого вам необходимо просто загрузиться с подготовленной дискеты. Если все сделано правильно, после загрузки компьютера вы увидите на экране процесс обновления (ни в коем случае не прерывайте его!), после завершения которого произойдет перезагрузка системы. Как только это случится, нужно сразу же вынуть дискету из дисковода, чтобы предотвратить повторную загрузку с нее. К чему это может привести, было сказано ранее.
    Вот, собственно, и все. Можно приступать к конфигурированию свеже запрограммированного BIOS. Но не всем, а только для тем, у кого вся процедура прошла без проблем. Остальная же часть статьи посвящена решению этих самых проблем в домашних условиях. Причем проблемы могут быть как совсем незначительные (с них мы и начнем), так и очень серьезные.

    Возможные проблемы.

    Непосредственно в процессе работы программы «AwardFlash», к сожалению, могут возникать ошибки, о которых пользователю сообщается соответствующим сообщением. Подробности:
    «Insufficient memory» (Недостаточно памяти). Это сообщение говорит о том, что не был соблюден ряд условий, на которых мы подробно останавливались ранее. Нужно отключить кэширование системного и видео BIOS, а также все виды «Shadow Memory» . Кроме этого, вообще не должны быть загружены никакие программы (в том числе драйверы, отвечающие за уплотнение диска типа «drvspace.bin» ), кроме, разумеется, «AwardFlash» . Если, несмотря на предпринятые меры, сообщение все равно появляется, используйте параметр «/Tiny» (существует только в версиях 7.xx).
    «The program file's part number does not match with your system» (Программируемый файл не соответствует вашей системе). Сообщение появляется при попытке запрограммировать BIOS, не подходящий для вашей платы. Однако, если применен параметр «/Py» (как в нашем примере), проверка на соответствие не производится. Поэтому всегда пользуйтесь только теми файлами BIOS, происхождение и назначение которых вам известно.
    «Unknown Type Flash» (Неизвестный тип микросхемы). Может возникнуть в случае, если в материнскую плату, которая не поддерживает программирование «FlashROM» напряжением 12В (5В), устанавливается «FlashROM» с напряжением программирования 12В (5В), в случае неисправности микросхемы «FlashROM» и еще в некоторых достаточно специфических случаях.
    «Program Chip Failed» (Ошибка программирования микросхемы). Возникает при программировании микросхем «Intel FlashROM 28F001» . Дело в том, что эта микросхема имеет аппаратно защищенный «BootBlock», размером «8 Кбайт» . Для программирования BootBlock и блока, в котором хранится BIOS, используются различные напряжения. Для того чтобы избежать случайных повреждений как «FlashROM», так и материнской платы, «BootBlock» данного типа микросхем не программируется по аппаратному запрету. Это и служит причиной для появления предупредительного сообщения.
    Однако, подобные сообщения об ошибках – далеко не самое страшное, что может произойти непосредственно во время обновления BIOS. Ситуация может сложиться таким образом, что новый BIOS не будет до конца запрограммирован, а старый к тому времени уже будет стерт. Причиной такой неприятности может стать, например, банальное отключение электроэнергии даже на самый незначительный промежуток времени или же попытка запрограммировать совсем не тот файл, который нужно. После этого компьютер просто не сможет загрузиться. При этом нужно рассмотреть два случая.
    При лучшем исходе удастся сохранить в рабочем состоянии «BootBlock» . Это произойдет, например, если при программировании, как и было рекомендовано, использовался параметр «/SB» .
    Сохранение «BootBlock» обозначает, что загрузиться все-таки можно, но в очень ограниченном режиме. Сразу после перезагрузки будет проверена контрольная сумма BIOS и на экране может появиться предупредительная надпись:
    Award BootBlock BIOS v1.0
    Copyright © 1998, Award Software, Inc.
    BIOS ROM checksum error
    Detecting floppy drive A media…
    Но, в большинстве случаев, чтобы увидеть эту надпись, необходимо использовать ISA видео карту, так как вывод информации на PCI или AGP видео адаптеры далеко не всегда возможен из-за неполной инициализации чипсета. Поэтому рекомендуется процедуру аварийного перепрограммирования FlashBIOS производить с установленной ISA видео картой. Особенно в том случае, если, несмотря на все рекомендации, вы не подготовили ту самую дискету. Если же дискета на месте, нужно просто с нее загрузиться. Именно в этом и состоит ценность сохранения «BootBlock» . Ряд производителей материнских плат рекомендуют до выполнения восстановительных работ отключить в системе все периферийные устройства, кроме видеокарты и дисковода. (Нужно отметить, что не все ISA видеокарты “однаково полезны”. Наилучшие результаты могут быть получены с применением карт на чипе «Cirrus Logic CL-GD5422» ).
    Итак, после загрузки с дискеты произойдет восстановление старого BIOS из предусмотрительно сохраненного файла «oldBIOS.bin» . Дальнейшие действия зависят от того, что послужило причиной сбоя. Если вы вместо нового BIOS случайно запрограммировали текст своей любимой песни, то вам будет достаточно восстановления работоспособного BIOS. Если же сбой произошел не по вашей вине, и все еще есть желание обновить BIOS, то нужно просто удалить с дискеты файл «oldBIOS.bin» (и только его!) и снова с нее загрузиться.
    Это был лучший исход. Прежде чем переходить к худшему, следует сказать о промежуточном варианте. Иногда, если загрузиться с дискеты не удается, можно попробовать подключить дисковод к отдельному ISA MIO контроллеру, что все-таки позволит инициализировать дисковод и, соответственно, восстановить BIOS. Это самый последний шанс избавиться от проблем программным путем.
    Несколько слов о некоторых технологиях, позволяющих относительно безболезненно восстановить работоспособность системы. Первое, некоторые материнские платы производства «Intel» имеют специальную перемычку «Flash Recovery» . Если установить его в положение «recovery mode», то можно будет загрузиться с помощью «BootBlock», даже если компьютер до этого не подавал вообще никаких признаков жизни после неудачного обновления BIOS. Когда все будет восстановлено, надо вернуть «Flash Recovery jumper» в прежнее положение. Второе, фирмой «Gigabyte Technology» была внедрена в производство технология «DualBIOS» . Как видно из названия, материнская плата комплектуется двумя микросхемами «Flash ROM», что позволяет при порче одного из BIOS загрузиться с помощью другого.
    Однако такие конструктивные решения достаточно редки, хотя бы потому, что в угоду потенциальным разрушителям BIOS производитель несет и перекладывает на всех своих потребителей дополнительные расходы.

    • Прошивка в диалоговом режиме

    Утилита «AwardFlash» (Flash Memory Writer), предназначенная для обновления BIOS, позволяет обновлять его, перезаписывая новый BIOS-файл в программируемый Flash ROM чип на материнской плате. Для определения версии BIOS вашей материнской платы проверьте четыре последние цифры кода, отображаемого в верхнем левом углу экрана в процессе загрузки. Большее число означает более новую версию BIOS-файла. Эта программа работает только в DOS-режиме.

  • Перед тем как обновлять BIOS:
    • создайте загрузочную системную дискету набрав [FORMAT A:/S] в командной строке DOS без создания файлов «AUTOEXEC.BAT» и «CONFIG.SYS» .
    • скопируйте файл «AFLASH.EXE» на созданную дискету,
    • загрузите файл с новой версией BIOS из Интернета и сохраните его на созданную дискету,
    • загрузитесь с этой дискеты и запустите «AFLASH.EXE», написав в командной строке DOS «A:\AFLASH.EXE» и нажмите клавишу <Enter>, Обратите внимание, если после надписи «Flash Memory» на экране написано «unknown», то ваша микросхема памяти либо не программируема, либо не поддерживается ACPI BIOS ( Advanced Configuration and Power Interface), и, таким образом, не может быть «перепрошита» с помощью утилиты «Flash Memory Writer» .
    • для сохранения текущей версии BIOS выберите пункт [1.Save Current BIOS to File] в главном меню и затем нажмите <Enter>,
    • в появившемся приглашении введите путь и имя файла, например, [A:\440XX-1_OLD.AWD], нажмите <Enter> и затем подтвердите начало процесса сохранения BIOS нажатием клавиши [Y].
  • Собственно обновление BIOS. Внимание, производите обновление BIOS только в случае крайней необходимости.
    • для обновления BIOS, включая «Boot Block» и блок ACPI ESCD (extended system configuration data), в главном меню выберите пункт [2.Update BIOS Including Boot Block and ESCD] и нажмите клавишу <Enter>.
    • в появившемся приглашении введите путь и имя файла с новой версией BIOS,
      например, [A:\440XX-1_NEW.AWD], нажмите <Enter>.
    • Затем подтвердите начало процесса обновления BIOS нажатием клавиши [Y].
    • Утилита начнет запись информации в программируемый «Flash ROM» . Когда процесс записи завершится, на экране появится сообщение «Flashed Successfully» ("Перепрошито успешно").
    • Далее — следуйте инструкциям на экране.

    ВНИМАНИЕ ! Если вы столкнулись с проблемами в процессе обновления BIOS, НЕ ВЫКЛЮЧАЙТЕ КОМПЬЮТЕР, поскольку после этого ваша система может не загрузиться. Просто повторите процесс, а если проблемы останутся, восстановите оригинальную версию BIOS из файла, который вы записали ранее на дискету. Если утилита «Flash Memory Writer» не сможет успешно восстановить файл BIOS, ваша система, возможно, не будет загружаться.

            •


BIOS Beeps. Сигналы и ошибки BIOS

1.1. Beeps

Если пpи проведении начального самотестирования системы возникают пpоблемы и BIOS не может завершить начальный тест, то можно услышать некоторую последовательность звуковых сигналов. Во многих случаях это помогает локализовать неисправность.

Сокращения: (к - короткий, д - длинный сигнал).

"AMI BIOS":

1д - POST Passed
- тест прошел без ошибок.
1д, 2к - Video failure
- нарушения в работе видеоарты. Возможны две причины:
а) сбой контрольной суммы Video BIOS ROM,
б) ошибка схемы, отвечающей за горизонтальную синхронизацию луча.
1д, 3к - Video failure
- возможны такие причины сбоев:
а) ошибка цифро-аналогового преобразователя,
б) ошибка при проверке локальной видеопамяти,
с) ошибка в процессе определения монитора.
Как правило, ремонт видеокарт малополезен, хотя, если дело касается только видеопамяти, то замена имеет смысл.
1к - DRAM refresh failure
- ошибка схемы регенерации памяти. Проверить правильность установки чипов памяти, при необходимости заменить.
2к - Parity Circuit Failure
- ошибка схемы четности памяти. Ошибка была найдена при проверке первых 64K основной памяти. Проверить правильность установки чипов памяти, при необходимости заменить.
3к - Base 64K RAM failure
- отказ первых 64K основной памяти. Проверить правильность установки чипов памяти, при необходимости заменить.
4к - System Timer Failure
- неисправен системный таймер. Проверить соответствующие модули на материнской плате (с возможной их заменой). В противном случае требуется замена материнской платы.
5к - Processor Failure
- нарушено функционирование процессора. Возможна переустановка процессора для улучшения контакта, а также проверка правильности установки перемычек для данного типа процессора.
6к - Keyboard Controller 8042/Gate A20 error
- ошибка адpесной линии A20 контpоллеpа клавиатуpы. Контроллер клавиатуры (8042) содержит переключатель, позволяющий процессору работать в виртуальном режиме. Это сообщение означает, что BIOS не в состоянии переключить процессор в защищенный режим. Необходимо вначале проверить клавиатуру и соединительный кабель. Необходимо также обратиться к опции "BIOS SETUP" - "Fast Gate A20", поэкспериментировав с ней. Необходимо переустановить чип контроллера клавиатуры либо заменить его. В противном случае потребуется замена материнской платы.
7к - Virtual Mode Exception Error
- ошибка исключения виpтуального pежима. Скорее всего нарушена работоспособность процессора (при этом процессор генерирует специальное прерывание), а возможно и чипсета.
8к - Display Memory Read/Write Test Failure
- ошибка теста чтения/записи памяти дисплея. Процессор не может обратиться к отображаемой видеопамяти графической карты. Проверить установку платы в разъеме, переустановить память на ней. В противном случае потребуется заменить видеокарту.
9к - ROM BIOS Checksum Failure
- ошибка контрольной суммы микросхемы BIOS. Необходимо попытаться переустановить этот чип. В противном случае необходимо перепрошить его или заменить микросхему.
10к - CMOS Shutdown Register Read/Write Error
- обнаружена ошибка при обращении к CMOS-памяти. Вызвать, если это возможно, "BIOS SETUP" и заново сохранить данные. Поскольку в большинстве случаев эта микросхема впаяна, то потребуется замена материнской платы.
11к - Cache Error/External Cache Bad
- неисправна внешняя кэш-память. Проверить правильность посадки модулей памяти. Если они припаяны, то также возможна замена материнской платы.

"AWARD BIOS":

1к - POST Passed
- тест прошел без ошибок.
1д, 2к (3к) - Video failure
- нарушена работа видеоканала. Система не обнаруживает монитор или графическую карту. В этом случае BIOS не может отобразить на экране сообщение об ошибке. Необходимо проверить установку платы в слот, а также исправность разъемов. Все аналогично, как и для "AMI BIOS".
2к
- обнаружена "легкая" ошибка. Например, не найден (или неисправен) жесткий диск. Необходимо, прежде всего, проверить разъемы и параметры диска.

1.2. Errors

В процессе старта системы и проведения POST-теста возможны различного рода аппаратные ошибки, сопровождаемые параллельным выводом на экран монитора соответствующих сообщений. Некоторые из приведенных ниже сообщений несколько утратили свою актуальность. Несколько ограничены сообщения об ошибках с EISA-шиной, SCSI-интерфейсом и "серверные" ошибки. В остальном, этот материал будет несомненно полезен.

Motherboard
BIOS ROM checksum error - System halted
- проверочная сумма при тесте ПЗУ по адресу F0000H-FFFFFH ошибочна. Возможно потребуется восстановление (перепрошивка) микросхемы с Flash BIOS.
BIOS update for installed CPU failed
- нарушение процесса обновления микрокода в процессоре (см. выше опцию "BIOS Update"). Одно из возможных действий - перезапись микросхемы с Flash BIOS. Эта тема в данных материалах не рассматривается.
CH-2 Timer Error
- ошибка второго таймера на системной плате. Большинство систем имеет два таймера.
CMOS battery failed, CMOS Battery Has Failed, CMOS Battery State Low, State Battery CMOS Low, CMOS Battery Low, System battery is dead, System battery is dead - Replace and run SETUP
- эти сообщения в начале загрузки компьютера свидетельствуют о неисправности батареи, ее разрядке или о возможном снижении питающего напряжения CMOS. Отсюда и возможные действия пользователя. Необходимо проверить напряжение на батарее при выключенном ПК (оно должно превышать 3В), необходимо проверить правильность установки соответствующего джампера на плате (если он присутствует) и при необходимости заменить батарею.
CMOS Checksum Error, CMOS Checksum Failure, System CMOS checksum bad, CMOS checksum bad
- неправильная контрольная сумма CMOS. После сохранения конфигурационной информации, в CMOS RAM генерируется контрольная сумма, которая проверяется затем на наличие ошибки. Вывод сообщения об ошибке свидетельствует о повреждении данных в CMOS, возможно из-за сбоя батареи или вирусного вмешательства. Если попытка восстановления "BIOS Setup" окажется неудачной, возможно придется обращаться в сервисный центр со своей материнской платой.
CMOS checksum error - Defaults loaded
- аналогичное сообщение, но с попыткой системы использовать заводские установки при загрузке.
CMOS Display Type Wrong, DISPLAY SWITCH IS SET INCORRECTLY, Display Switch Not Proper, DISPLAY TYPE HAS CHANGED SINCE LAST BOOT, CMOS Display Type Mismatch, Type Display CMOS Mismatch, Monitor type does not match CMOS - RUN SETUP
- неправильно выставлен тип монитора (монохромный или цветной) или изменился тип дисплея со времени последней загрузки. Переставить соответствующий джампер на материнской плате в правильное положение (Color/Mono - для устаревших систем) или исправить тип дисплея в "BIOS Setup".
CMOS Memory Size Mismatch, Memory Size Changed, MEMORY SIZE HAS CHANGED SINCE LAST BOOT
- объем физической памяти на материнской плате, определенный в течение POST-теста, не совпадает с тем, что хранится в CMOS. Или сообщение вызвано тем, что изменился размер памяти со времени последней загрузки. Причиной для этих сообщений может быть как физическое изменение (добавление/удаление модулей памяти), так и неисправность компонентов памяти. Необходимо перезапустить "BIOS Setup" (или "EISA Configuration Utility"), проверить все установки об объемах используемой памяти. После перезагрузки ПК ошибка может исчезнуть, иначе потребуется замена компонентов материнской платы.
Memory Size Decreased, Memory Size Increased
- аналогичные сообщения, но с конретным указанием уменьшения/ увеличения установленной памяти.
CMOS System Options Not Set, CMOS Settings Wrong
- данные в CMOS повреждены или отсутствуют. Действия пользователя аналогичны вышеприведенным.
CMOS Time and Date Not Set, CMOS Date/Time Not Set
- нарушены или не установлены параметры даты и/или времени. Задача сводится к проверке или установке этих параметров в "BIOS Setup".
DISKETTE DRIVES OR TYPES MISMATCH ERROR - RUN SETUP
- типы дисководов, фактически установленных в системе, и их описания в CMOS не совпадают. Необходимо запустить "BIOS SETUP" и ввести правильные типы дисководов.
Real time clock failure, Real time clock error
- ошибка часов реального времени. Необходимо вызвать "BIOS Setup" и попытаться установить правильное время. Если ошибка не исчезнет, то возможно придется обращаться в сервисные службы.
System timer error
- ошибка системного таймера на плате.

NVRAM:
NVRAM Checksum Error
NVRAM Data Invalid
NVRAM Cleared
- конфигурационные данные ESCD будут заново инициализированы, поскольку была выявлена ошибка в контрольной сумме NVRAM (Non-Volatile RAM - энергонезависимая память).
Checking NVRAM
Update OK!
Updated Failed
- производится проверка NVRAM. Данные NVRAM были нарушены, но их обновление прошло нормально. Данные NVRAM нарушены, их обновление оказалось невозможно.

Boot
Boot error Press F1 to retry (Phoenix)
- ошибка указывает на отсутствие жесткого диска или загрузочных областей. Возможно не выбран активный раздел.
CPU ID 0x failed
- ошибка инициализации процессора во время проведения POST-теста. Если такая ошибка появилась в серверной системе, то можно попробовать отключить установки в статусном меню CPU. В остальных случаях требуется вмешательство специалиста.
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER
- не найден загрузочный диск. Прежде такое сообщение указывало на невозможность доступа к загрузочному устройству или на его отсутствие. А в качестве таких устройств могли фигурировать жесткий диск или флоппи-дисковод. Ныне к таким устройствам добавились CD-ROM, сетевые адаптеры с возможностью удаленной загрузки, т.п. (см. выше). Необходимо проверить правильность подключения стандартных дисководов, попытаться загрузиться с дискеты и проверить системные файлы на жестком диске.
Diskette Boot Failure, Invalid Boot Diskette
- дискета в дисководе А: не является загрузочной, т.е. невозможно загрузиться с дискеты в процессе запуска ПК. Дискета может не быть загрузочной, либо системные файлы повреждены.
Invalid Drive Specification
- жесткий диск не разбит на разделы, записи таблицы разделов повреждены или содержат неверные данные. Все действия необходимо начать с помощью программы FDISK.
Invalid Media in Drive D:
- это означает, что жесткий диск еще не разбит на разделы.
Invalid Media Type
- поврежден (или не инициализирован) загрузочный сектор, каталог или таблицы FAT. Диск может быть разбит на разделы, но не отформатирован.
Missing Operation System
- это сообщение, как и некоторые другие, не связано с проведением процедуры POST. Вывод этого сообщения ("Отсутствует операционная система") говорит, в лучшем случае, об отсутствии или нарушении основных конфигурационных файлов системы, а также о возможных нарушениях таблицы разделов жесткого диска. Запись в таблице раздела может указывать на сектор, который не является началом раздела. Причина ошибки может исходить и из главной загрузочной записи.
Для решения проблемы прежде всего необходимо проверить правильность установки параметров в BIOS (возможен сбой из-за разряда батареи). Главную загрузочную запись можно восстановить с помощью команды FDISK/MBR. Либо потребуется переформатирование логических разделов с последующей установкой ОС.
Operating system not found
- почти аналогичное сообщение, но требующее проверки параметров дисководов в "BIOS Setup", в том числе и в опции "Boot Sequence".
Override enabled - Defaults loaded
- если система не в состоянии загрузиться, используя текущую CMOS-конфигурацию, BIOS перезаписывает ее и устанавливает значения параметров по умолчанию.
PRESS A KEY TO REBOOT
- сообщение выводится после вывода информации об обнаружении ошибки в процессе выполнения POST-теста с необходимостью дальнейшей перезагрузки ПК. Нажать любую клавишу.
Press ESC to skip memory test
- предоставляется возможность пропустить полный тест памяти.
PRESS F1 TO DISABLE NMI, F2 TO REBOOT
- проблемы с немаскируемыми прерываниями. Возможно ошибка в работе контроллера прерываний, хотя ошибка может возникнуть и при проверке памяти по четности. Речь идет об обработчике-заглушке немаскируемого прерывания (Non-maskable Interrupt). Это не один из этапов POST, а процедура, на которую указывает вектор немаскируемого прерывания. Если возник запрос NMI, и не удалось идентифицировать причину NMI, в Port80 выводится этот код, на экран выводится сообщение: "Press F1 to disable NMI, F2 to reboot". И ожидаются действия пользователя по блокированию возникшей проблемы или для перезагрузки.
Primary Boot Device Not Found
- не найдено первичное загрузочное устройство (жесткий диск, флоппи, CD-ROM, т.п.). Необходимо проверить правильность подключения соответствующих устройств и установки по ним в "BIOS Setup".
No Boot Device Available
- аналогично.
NO ROM BASIC - SYSTEM HALTED (AMI)
- обозначает остановку процесса загрузки из-за повреждения или отсутствия загрузочного сектора, или главной загрузочной записи на загрузочном диске. Возможна даже ситуация, когда первичный раздел не активизирован. В этом случае надо воспользоваться, например, программой FDISK.EXE. Причиной ошибки может быть и неправильная установка параметров жесткого диска в "BIOS Setup". Но по большому счету речь может идти об отсутствии загрузочного устройства, будь то гибкий или жесткий диск, сетевой адаптер, т.п., с одной стороны, а с другой, об отсутствии интерпретатора BASIC в ПЗУ (прошивался в первых моделях ПК).
Действия пользователя при этом практически те же, что описаны для сообщения "Missing Operation System".
SYSTEM HALTED, (Ctrl-Alt-Del) TO REBOOT
- обозначает остановку процесса загрузки после обнаружения серьезной ошибки. Необходимо перезагрузить ПК с помощью одновременного нажатия трех указанных клавиш либо повторного включения питания. Возможно ошибка исчезнет.

Remote Boot:
After booting, my computer experiences problems
- после успешной удаленной загрузки возникли проблемы на компьютере клиента сети.
Flash device wrong size
- полная версия "Intel Boot Agent" не может загрузиться в память сетевого адаптера, поскольку ее размер составляет менее 64 КБ.
Media test failure, check cable
- определена неисправность в подключении сетевого кабеля к разъему RJ-45 на сетевом адаптере.
My computer does not complete POST
- невозможность загрузки "Intel Boot Agent", вызванная нарушениями в предварительном самотестировании.
PXE-E00: This system does not have free conventional memory. The Boot Agent cannot continue
- "Intel Boot Agent" не может получить в свое распоряжение достаточный объем свободной памяти в пределах первых 640 КБ системного ОЗУ для инсталляции программного обеспечения PXE-клиента.
PXE-E04: The LAN adapter is not functioning correctly or the wrong Boot Agent is installed. The Boot Agent cannot continue
- "Intel Boot Agent" не в состоянии прочитать один или более конфигурационных регистров PCI-адаптера. Адаптер может быть расконфигурирован или имеет место сбой программного обеспечения, инсталлированного на адаптере.
PXE-E06: This system does not support PCI option ROMs. The Boot Agent cannot continue
- не поддерживается распределение в верхней памяти BIOS сетевого адаптера в соответствии с PXE-спецификацией. "Intel Boot Agent" не может функционировать в этой системе. "Intel Boot Agent" возвращает управление основному BIOS системы и отказывается от удаленной загрузки.
This option has been locked and cannot be changed
- это сообщение выводится, когда пользователь пытается изменить конфигурационные установки, заблокированные системным администратором.
When using RPL protocol, the boot does not proceed normally
- невозможность удаленной загрузки при использовании стандартного RPL-протокола. Необходимо изменить тип протокола в "Boot Agent Setup" на PXE.

Chipset
8042 Gate - A20 Error!, GA20 Error
- неисправность работы вентиля линии A20 контроллера клавиатуры (8042). Заменить, если это возможно, контроллер клавиатуры. Ошибка может проявиться и во время переключения в защищенный режим работы процессора в процессе проведения теста POST. В некоторых случаях эту ошибку можно обойти, переведя в "BIOS Setup" опцию управления линии A20 на управление с помощью чипсета.
Address Line Short!
- проблема со схемой декодирования адреса памяти, адресных линий модулей памяти или с самими модулями. Имеет смысл перезагрузиться. Проблема может разрешиться сама собой. В противном случае возможно потребуется замена системных компонентов.
BUS Timeout NMI at Slot X
- ошибка тайм-аута обращения по системной шине для платы расширения в слоте X (EISA).
Fail-Safe Timer NMI
- прерывание от таймера, вызванное превышением допустимой длительности шинного цикла, которая контролируется системой.

Memory
Cache Memory Bad, Do Not Enable Cache!, Cache Memory Bad, System Cache Error
- ошибка внешней кэш-памяти. Возможно потребуется замена соответствующего компонента. Хотя сначала стоит попробовать просто перезагрузиться или отключить кэш в "BIOS Setup".
ECC Error
- некорректируемая ошибка в памяти. Ее адрес не может быть определен. Возможно потребуется обращение в специализированные технические службы.
Expansion ROM Allocation Fail
- ошибка выделения в основной памяти базового адреса для ПЗУ внешнего устройства.
Extended RAM Failed at offset: nnnn
System RAM Failed at offset: nnnn
- ошибка инициализации памяти. Произошел сдвиг начального адреса на nnnn-диапазон.
I/O Card Parity Error at xxxxx
- ошибка по четности по адресу ххххх при проверке отображаемой памяти карты расширения. Если адрес не может быть определен, то сообщение имеет вид
I/O Card Parity Error ????
Memory Address Error at XXXX
- ошибка в одном из модулей памяти с указанием конкретного адреса. Возможно требуется замена модуля.
Memory mismatch, run Setup
- необходимо установить опцию "Memory Relocation" в "Disable" (см. ниже).
Memory Parity Error at XXXX
- ошибка контроля четности при тестировании адреса ХХХХ. Если память поддерживает контроль четности, то требуется ее замена. Если адрес не может быть определен, то сообщение имеет вид
Memory Parity Error ????
Memory test fail
- BIOS сообщает, что при тестировании памяти имелись ошибки. При этом дополнительно сообщается о типе и месторасположении ошибки.
Memory Verify Error at XXXX
- ошибка при тестировании памяти, точнее при попытке записи по определенному адресу. Если ошибка повторяется, то потребуется замена памяти.
Off Board Parity Error, OFF BOARD PARITY ERROR ADDR (HEX) = (xxxx)
- ошибка по четности памяти, установленной на карте расширения.
OFFENDING ADDRESS NOT FOUND, OFFENDING SEGMENT
- это сообщение выводится как конъюнкция (логическое "И") операций проверки "I/O CHANNEL CHECK" и "RAM PARITY ERROR", когда ни одно из устройств, вызвавших проблему, не может быть точно определено. Возможна проблема и с контроллером памяти.
On Board Parity Error
- ошибка контроля четности системной памяти. Ошибка может быть вызвана соответствующей периферией, занимающей адрес, указанный в сообщении об ошибке.
Parity Error
- нелокализованная ошибка по четности при проверке системной памяти.
RAM PARITY ERROR - CHECKING FOR SEGMENT
- ошибка контроля четности памяти.
Uncorrectable ECC DRAM error
- некорректируемая ошибка памяти.

PCI
On Board PCI VGA not configured for Bus Master
- это сообщение выводится, когда интегрированная на системной плате видеокарта не настроена для работы в режиме "захватчика" шины. В "BIOS Setup" необходимо найти опцию "Shared PCI Master Assignment" (или аналогичную), установить значение "VGA".
PCI Error Log is Full
- это сообщение выводится, когда журнал фиксации конфликтных ситуаций содержит более 15 конфликтов, связанных с PCI-шиной. Дополнительные ошибки не будут заноситься в журнал (см. раздел о серверных установках).
Unknown PCI error
- нелокализованная ошибка PCI-устройства. Необходимо проверить все устройства на PCI-шине. Причина может быть и в мостовой схеме.

Resources
Bad PnP Serial ID Checksum
- контрольная сумма идентификационного номера P&P-устройства ошибочна.
DMA #1 Error, DMA #2 Error
- ошибка первого/второго канала DMA. Ошибка может быть вызвана соответствующим периферийным устройством.
DMA Bus Time-out
- устройство, работающее в режиме DMA, удерживает шину (цикл шины) более 7,8 мкс. Проблема в платах расширения или других "съемных" компонентах (модули памяти, например). Необходимо найти такое устройство, которое вызывает эту ошибку, и заменить ее. Причиной может быть и неисправность материнской платы.
DMA Error
- ошибка контроллера DMA. Возможна замена материнской платы.
Equipment Configuration Error
- ошибка конфигурирования ресурсов оборудования системы.
Floppy Disk Controller Resource Conflict
- контроллер флоппи-дисковода запрашивает ресурс, уже используемый.
INTR #1 Error, INTR #2 Error
- первый/второй контроллер прерываний не прошел POST. Необходимо проверить устройства, занимающие IRQ 0-7/IRQ 8-15.
Invalid System configuration Data
- нарушение области ESCD. Необходимо войти в "BIOS Setup" и опцию "Reset Configuration Data" (или аналогичную) установить в "Yes". Возможны также дополнительные действия по конфигурированию ресурсов через "BIOS Setup" или с использованием "ISA configuration utility".
Invalid System Configuration Data - run configuration utility
Press F1 to resume, F2 to Setup
- аналогичный и более полный вариант сообщения.
IRQ Setting Error,
I/O Resource Conflict(s),
Onboard xxx ... Conflict(s),
Onboard Parallel Port Conflict(s), Parallel Port Resource Conflict,
Onboard Parallel Port IRQ Conflict(s),
Onboard Serial Port Conflict(s),
Onboard Serial Port IRQ Conflict(s)
- эти все сообщения о конфликтности выделения ресурсов для конкретных устройств или системном распределении ресурсов требуют от пользователя стандартных действий. Ведь причина конфликта может быть достаточно проста. Устройству, например, выделен ресурс, уже используемый. Надо понять причину конфликта, определить, какой ресурс его вызвал: адрес ввода/вывода или прерывание. Дальнейшие действия - "ручное" изменение ресурса, будь-то установки в "BIOS Setup" или перемычки на плате расширения, и перезапуск системы.
PCI I/O Port Conflict
- два устройства запрашивают один и тот же ресурс.
PCI IRQ Conflict
- два устройства запрашивают один и тот же ресурс.
PCI Memory Conflict
- два устройства запрашивают один и тот же ресурс.
PnP ISA Card(s) Disabled
- неверно определенный ресурс карты расширения не позволяет системе ее использовать.
Primary Input Device Not Found
- назначенное первичное входное устройство (клавиатура, "мышь" или другое) не обнаружено.
Primary/Secondary IDE Controller Resource Conflict
- первичный/вторичный IDE-контроллер запрашивает ресурс, уже используемый.
Serial Port 1 Resource Conflict
- первый последовательный порт запрашивает ресурс, уже используемый.
Serial Port 2 Resource Conflict
- второй последовательный порт запрашивает ресурс, уже используемый.
Static Device Resource Conflict, System Device Resource Conflict
- не-P&P ISA-карта запрашивает ресурс, уже используемый.

Keyboard
K/B Interface Error, Keyboard/Interface Error
- ошибка связи с клавиатурой. Проверить подсоединение клавиатуры, проверить положение переключателя XT/AT на клавиатуре, а также поэкспериментировать с опцией "Halt On". В противном случае возможно неисправен контроллер клавиатуры.
Keyboard controller error
- ошибка контроллера клавиатуры. Необходимо вначале подключить другую клавиатуру.
Keyboard Error
- ошибка клавиатуры. Проверить подключение клавиатуры и соответствие типа клавиатуры контроллеру. А также необходимо проверить "временные" установки в "BIOS Setup". Можно попытаться отключить тестирование клавиатуры при загрузке.
Keyboard error nn
- ошибка клавиши на клавиатуре. В шестнадцатеричном виде указан ее код.
KEYBOARD ERROR OR NO KEYBOARD PRESENT
- ошибка инициализации клавиатуры или клавиатура отсутствует. Все действия аналогичны. Необходимо также удостовериться, что во время включения ПК не нажата какая-либо клавиша, а также проверить соответствие наличия клавиатуры и установок в "BIOS Setup".
Keyboard failure, press [F1] to continue
- причиной такого сообщения могут быть неконтакт (обрыв) кабеля клавиатуры, заедание какой-либо наиболее часто используемой клавиши. Но прежде всего необходимо проверить установки опций "Typematic Rate" и "Typematic Delay", так как может иметь место несовместимость установок клавиатуры в "BIOS Setup".
Keyboard is locked ... Unlock it
- необходимо разблокировать клавиатуру. Причиной такого сообщения может быть блокировка клавиатуры защитным ключом. Возможно потребуется проверить правильность подсоединения ключа к разъему материнской платы.
Keyboard is locked out - Unlock the key, Keyboard Stuck Key Failure
- "Phoenix BIOS" сообщает о залипании клавиши. Вполне возможно случайное удержание какой-либо клавиши (клавиш) во время тестирования системы.
PS/2 Keyboard Interface Error - необходимо проверить правильность подсоединения клавиатуры, возможна неисправность контроллера клавиатуры или интерфейсной схемы ввода/вывода.
PS/2 Keyboard Error or Keyboard Not Connected
- необходимо проверить правильность подсоединения клавиатуры.

Floppy
Diskette drive A/B error, Incorrect Drive A/B - run SETUP
- необходимо проверить правильность установок в "BIOS Setup", а также правильность подсоединения дисководов.
FDD Controller Failure, Floppy Disk Controller Error, FLOPPY DISK CNTRLR ERROR OR NO CNTRLR PRESENT
- ошибка связи с контроллером гибких дисков, невозможность инициализации контроллера, ошибка контроллера. Проверить подсоединение дисковода и его разрешенность на мультикарте (для устаревших систем).
Floppy disk(s) fail
- нельзя найти или инициализировать контроллер или сам флоппи-дисковод. Действия аналогичны.
Floppy disk(s) fail (40)
- это сообщение в конце теста ПК говорит о возможной ошибке в подключении шлейфа. Непрерывно светящийся индикатор также свидетельствует о неправильном подключении. Ошибка может заключаться и в несоответствии типа флоппи-дисковода, установленного в "BIOS Setup".

HD
ERROR ENCOUNTERED INITIALIZING HARD DRIVE, Failure Fixed Disk 0/1, Fixed Disk 0/1 Failure, Hard disk(s) diagnosis fail, C:/D: Drive Error, C:/D: Drive Failure, Hard Disk(s) fail (20)
- не инициализируется жесткий диск (жесткие диски). Проверить установку контроллера жестких дисков (для устаревших систем), соединительные кабеля, проверить установку джамперов на жестком диске, а также параметры "BIOS Setup". Но причина может заключаться и в неисправности диска, и жесткий диск может оказаться неформатированным.
ERROR INITIALIZING HARD DRIVE CONTROLLER, HARD DISK INSTALL FAILURE, HDD Controller Failure, Hard Disk Controller Failure, Fixed Disk Controller Failure, Hard Disk(s) fail (40)
- ошибка связи с контроллером жестких дисков, контроллер жестких дисков не инициализируется, неисправность контроллера. Проверить установку контроллера, подсоединение дисковода, подключение соединительных кабелей к системной плате, т.п. и параметры жесткого диска в "BIOS Setup". Также стоит проверить установку джамперов на жестком диске. Причина может быть и в том, что в ПК имеется диск SCSI, но BIOS материнской платы ожидает также наличия диска IDE. Надо войти в "BIOS Setup" и отключить жесткий диск.
HARD DISK initializing
Please wait a moment
- некоторые старые диски требовали дополнительного времени для инициализации. Понятно, что это сообщение не об ошибке.
HARD DISK INSTALL FAILURE
- нельзя найти или инициализировать контроллер или сам жесткий диск. Действия те же, т.е. проверить все механические установки и подключения, а также правильность установок в "BIOS Setup".
Primary IDE channel no 80 conductor cable installed - "современное" сообщение, и вывод его связан с подключением обычного 40-жильного соединительного кабеля к разъему контроллера с интерфейсом UDMA/66 и выше.
Primary/Secondary master/slave hard disk fail, Pri/Sec master/slave HDD Error, IDE Primary/Secondary Channel Master/Slave Drive Error
- POST определил ошибку в первичном/вторичном "master"/"slave" IDE-жестком диске.
Pri/Sec Master/Slave Drive - POST сообщает, что устройство несовместимо с интерфейсом ATAPI. Необходимо проверить правильность установок в "BIOS Setup".
Resuming from disk, Press TAB to show POST screen
- это сообщение от "Phoenix Technologies" и оно характерно для систем, использующих функцию "save-to-disk" при выключении компьютера. Такое сообщение может быть выведено при рестарте системы, а нажатие указанной клавиши позволяет вывести дополнительную информацию на экран.

EISA
EISA Configuration is Not Complete
- информация о конфигурации EISA-шины и устройств на ней задана не полностью. Система может быть загружена без расширений EISA, т.е. как ISA-система, но это даст возможность выполнить полноценно все процедуры конфигурирования с помощью EISA Configuration Utility (ECU).
EISA CMOS Inoperational
- ошибка доступа (в процессе чтения/записи) к дополнительной CMOS-памяти, предназначенной для хранения конфигурации EISA-устройств. Одной из причин может быть неисправность батареи. Здесь и далее основная рекомендация - запуск ECU-утилиты.
EISA CMOS Checksum Failure, EISA Configuration Checksum Error
- контрольная сумма энергонезависимой памяти EISA некорректна или нельзя прочитать информацию об EISA-слоте. Возможно плата в слот установлена неправильно. Причиной также может быть неисправность батареи.
Expansion Board not ready at Slot X
- BIOS не может инициализировать плату расширения в слоте X. Проверить саму плату и ее конфигурацию.
ID information mismatch for Slot X Wrong Board in Slot X, Wrong Board In Slot
- идентификатор установленной платы расширения EISA не совпадает с записью в CMOS для этого слота. Возможно установлена плата с ошибочным ID.
Invalid Configuration Information for Slot X
- недействительна конфигурационная информация для платы расширения в слоте X.
Invalid EISA Configuration
- недействительна конфигурационная информация EISA. Конфигурация могла быть неправильно запрограммирована, или имеет место ее нарушение.
Slot X Not Empty, Slot X Should Be Empty But EISA Board Found
- слот X, записанный в конфигурации как пустой, занят платой расширения.
Slot X Should Have EISA Board But Not Found
- слот X сконфигурирован под плату расширения, но она не обнаружена.

SCSI
Device connected, but not ready
- "ultra-wide SCSI"-контроллер не получил ответ при запросе данных от инсталлированного SCSI-устройства. Необходимо установить "Send Start Unit Command" в "Yes" в SCSI-конфигурационной программе.
Start unit request failed
- BIOS не может отправить "Start Unit Command" в SCSI-устройство. Необходимо в SCSI-конфигурационной программе "Send Start Unit Command" установить в "No".
Time-out failure during...
- необходимо проверить терминирование SCSI-шины и правильность кабельных подсоединений. Возможно одно из устройств на SCSI-шине неисправно.

Server
Service Processor not properly installed
- неправильно инициализируется контроллер управления сервером.
Storage Extension Group = xy
Configuration error, x Storage Extensions(s) found, configured are y SE(s).
Device List: k1, k2 ...
- несоответствие установок "Server menu - Storage Extensions" найденным коммуникационным устройствам, где:
SEs - storage expansion units (устройства расширения хранения информации). Несоответствие их установленному числу,
xy - номер группы,
x - число SEs, найденных на коммуникационной шине,
y - число SEs, введенных в конфигурацию,
k1, k2 ... - идентификаторы устройств хранения.
Необходимо проверить и исправить установки в "BIOS Setup".


BIOS Beeps Errors. Звуковые сигналы ошибок BIOS

Award BIOS
1 короткий Успешный POST
2 коротких Обнаружены незначительные ошибки. На экране монитора появляется предложение войти в программу CMOS Setup Utility и исправить ситуацию. Проверьте надежность крепления шлейфов в разъемах жесткого диска и материнской платы.
3 длинных Ошибка контроллера клавиатуры.
1 короткий, 1 длинный Ошибка оперативной памяти (RAM).
1 длинный, 2 коротких Ошибка видеокарты.
1 длинный, 3 коротких Ошибка при инициализации клавиатуры.
1 длинный, 9 коротких Ошибка при чтении из ПЗУ.
Повторяющийся короткий Проблемы с блоком питания.
Повторяющийся длинный Проблемы с ОЗУ.
Повторяющаяся высокая- Проблемы с CPU.
низкая частота
Непрерывный Проблемы с блоком питания.

AMI BIOS
1 короткий Ошибок не обнаружено ПК исправен.
1 длинный, 1 короткий Проблемы с блоком питания.
2 коротких Ошибка чётности RAM.
3 коротких Ошибка в первых 64 КБ RAM.
4 коротких Неисправность системного таймера.
5 коротких Проблемы с процессором.
6 коротких Ошибка инициализации контроллера клавиатуры.
7 коротких Проблемы с материнской платой.
8 коротких Ошибка памяти видеокарты.
9 коротких Контрольная сумма BIOS неверна.
10 коротких Ошибка записи в CMOS.
11 коротких Ошибка кэша, расположенного на системной плате.
1 длинный, 2 коротких Ошибка видеокарты.
1 длинный, 3 коротких Ошибка видеокарты.
1 длинный, 8 коротких Не подключён монитор.

AST BIOS
1 короткий Ошибка при проверке регистров процессора. Неисправность процессора.
2 коротких Ошибка буфера клавиатурного контроллера. Неисправность клавиатурного контроллера.
3 коротких Ошибка сброса клавиатурного контроллера. Неисправность клавиатурного контроллера или системной платы.
4 коротких Ошибка связи с клавиатурой. Если замена клавиатуры не помогает, замените микросхему клавиатурного контроллера.
5 коротких Ошибка клавиатурного ввода. Замените микросхему контроллера клавиатуры.
6 коротких Ошибка системной платы. Замените системную плату.
9 коротких Несовпадение контрольной суммы ПЗУ BIOS. Неисправна и должна быть заменена микросхема ПЗУ BIOS.
10 коротких Ошибка системного таймера. Системная микросхема таймера неисправна.
11 коротких Ошибка чипсета. Замените системную плату.
12 коротких Ошибка регистра управления питанием в энергонезависимой памяти. Замените микросхему энергонезависимой памяти или системную плату.
1 длинный Ошибка контроллера DMA 0. Неисправна микросхема контроллера DMA канала 0. Если возможно, замените.
1 длинный, 1 короткий Ошибка контроллера DMA 1. Неисправна микросхема контроллера DMA канала 1. Если возможно, замените.
1 длинный, 2 коротких Ошибка гашения обратного хода кадровой развёртки. Возможно, неисправен видеоадаптер. Замените.
1 длинный, 3 коротких Ошибка в видеопамяти. Неисправна память видеоадаптера. Замените.
1 длинный, 4 коротких Ошибка видеоадаптера. Неисправен видеоадаптер. Замените.
1 длинный, 5 коротких Ошибка памяти 64K. Если возможно, замените микросхему базовой памяти.
1 длинный, 6 коротких Не удалось загрузить векторы прерываний. BIOS не смог загрузить векторы прерываний в память.
1 длинный, 7 коротких Не удалось инициализировать видеооборудование. Сначала замените видеоадаптер. Если не помогло, замените системную плату.
1 длинный, 8 коротких Ошибка видеопамяти. Сначала замените видеоадаптер. Если не помогло, замените системную плату.

Phoenix BIOS
Следует читать как: число сигналов – пауза – число сигналов – пауза – число сигналов
1-1-3 Ошибка записи/чтения данных в/из CMOS-памяти.
1-1-4 Обнаружена ошибка при подсчете контрольной суммы содержимого BIOS.
1-2-1 Ошибка инициализации материнской платы.
1-2-2 или 1-2-3 Ошибка инициализации контроллера DMA.
1-3-1 Ошибка инициализации схемы регенерации оперативной памяти.
1-3-3 или 1-3-4 Ошибка инициализации первых 64 Кбайт оперативной памяти.
1-4-1 Ошибка инициализации материнской платы.
1-4-2 Ошибка инициализации оперативной памяти.
1-4-3 Ошибка инициализации системного таймера.
1-4-4 Ошибка записи/чтения в/из одного из портов ввода/вывода.
2-1-1 Обнаружена ошибка при чтении/записи 0-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-1-2 Обнаружена ошибка при чтении/записи 1-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-1-3 Обнаружена ошибка при чтении/записи 2-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-1-4 Обнаружена ошибка при чтении/записи 3-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-2-1 Обнаружена ошибка при чтении/записи 4-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-2-2 Обнаружена ошибка при чтении/записи 5-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-2-3 Обнаружена ошибка при чтении/записи 6-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-2-4 Обнаружена ошибка при чтении/записи 7-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-3-1 Обнаружена ошибка при чтении/записи 8-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-3-2 Обнаружена ошибка при чтении/записи 9-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-3-3 Обнаружена ошибка при чтении/записи 10-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-3-4 Обнаружена ошибка при чтении/записи 11-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-4-1 Обнаружена ошибка при чтении/записи 12-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-4-2 Обнаружена ошибка при чтении/записи 13-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-4-3 Обнаружена ошибка при чтении/записи 14-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
2-4-4 Обнаружена ошибка при чтении/записи 15-го бита (в шестнадцатеричном представлении) первых 64 Кбайт ОЗУ.
3-1-1 Ошибка инициализации второго канала DMA.
3-1-2 или 3-1-4 Ошибка инициализации первого канала DMA.
3-2-4 Ошибка инициализации контроллера клавиатуры.
3-3-4 Ошибка инициализации видеопамяти.
3-4-1 Возникли серьезные проблемы при попытке обращения к монитору.
3-4-2 Не удается инициализировать BIOS видеоплаты.
4-2-1 Ошибка инициализации системного таймера.
4-2-2 Тестирование завершено.
4-2-3 Ошибка инициализации контроллера клавиатуры.
4-2-4 Критическая ошибка при переходе центрального процессора в защищенный режим.
4-3-1 Ошибка инициализации оперативной памяти.
4-3-3 Ошибка инициализации второго таймера.
4-4-1 Ошибка инициализации одного из последовательных портов.
4-4-2 Ошибка инициализации параллельного порта.
4-4-3 Ошибка инициализации математического сопроцессора.


iXBT: BIOS FAQ

 Часто задаваемые вопросы о BIOS

  1. Что такое BIOS?
  2. Как определить, что установленный на материнской плате BIOS, прошит во Flash ROM?
  3. Зачем необходима перепрошивка новых версий BIOS?
  4. Где можно скачать новые версии BIOS?
  5. Что делать, если производителя и название материнской платы определить не удается?
  6. Как перепрошить Flash BIOS?
  7. Почему прошивальщик Award BIOS выдает сообщение "Insufficient memory"?
  8. Что будет, если запортить BIOS или прошить неправильную версию?
  9. Как восстановить поврежденный BIOS?
  10. Что такое PROM, EPROM и ЕEPROM и чем они отличаются?
  11. Как сбросить установки BIOS (включая пароль) в значения по умолчанию из DOS?
  12. Как подобрать (снять) пароль на Setup (загрузку)?
  13. Как аппаратно сбросить CMOS (вместе с паролями)?
  14. Что означают аварийные звуковые сигналы, выдаваемые AMI BIOS при загрузке?
  15. Что означают аварийные звуковые сигналы, выдаваемые Award BIOS при загрузке?
  16. Что означают аварийные звуковые сигналы, выдаваемые Phoenix BIOS при загрузке?
  17. Как отредактировать Award BIOS?

- Что такое BIOS?

BIOS (basic input/output system) - базовая система ввода-вывода - это встроенное в компьютер программное обеспечение, которое ему доступно без обращения к диску. На PC BIOS содержит код, необходимый для управления клавиатурой, видеокартой, дисками, портами и другими устройствами.

Обычно BIOS размещается в микросхеме ПЗУ (ROM), размещенной на материнской плате компьютера (поэтому этот чип часто называют ROM BIOS). Эта технология позволяет BIOS всегда быть доступным, несмотря на повреждения, например, дисковой системы. Это также позволяет компьютеру самостоятельно загружаться. Поскольку доступ к RAM (оперативной памяти) осуществляется значительно быстрее, чем к ROM, многие производители компьютеров создают системы таким образом, чтобы при включении компьютера выполнялось копирование BIOS из ROM в оперативную память. Задейтвованная при этом область памяти называется Shadow Memory (теневая память).

В настоящее время, почти все материнские платы комплектуются Flash BIOS, BIOSом, который в любой момент может бытть перезаписан в микросхеме ROM при помощи специальной программы.

BIOS PC стандартизирован, поэтому, в принципе менять его, также как, например, операционные системы нет необходимости. Дополнительные возможности компьютера можно использовать только использованием нового программного обеспечения.

BIOS, который поддерживает технологию Plug-and-Play, называется PnP BIOS. При использовании этой технологии BIOS должен быть обязательно прошит во Flash ROM.

- Как определить, что установленный на материнской плате BIOS, прошит во Flash ROM?

Определить тип микросхемы ПЗУ, установленнолй на материнской плате, несложно. Для этого необходимо посмотреть на маркировку чипа ROM (28 или 32-контактная микросхема с наклейкой производителя BIOS), отодрав наклейку. Маркировка означает следующее (ххх означает три произвольных цифры):

  • 28Fxxx - 12V Flash память
  • 29Cxxx - 5V Flash память
  • 29LVxxx - 3V Flash memory (раритет)
  • 28Cxxx - EEPROM, почти то же, что и Flash память
  • 27Cxxx - с окошком. EPROM: только для чтения, требует программатор для записи и ультрафиолетовую лампу для стирания
  • PH29EE010: SST ROM Чип - перепрошиваемый
  • 29EE011: Winbond чип - 5V Flash память
  • 29C010: Atmel Chip - 5V Flash память

Любые другие микросхемы, не имеющие окошка с маркировкой, не начинающейся с цифр 28 или 29, являются, скорее всего не Flash-памятью. Если же на микросхеме есть окошко - это верный признак того, что это не Flash.

- Зачем необходима перепрошивка новых версий BIOS?

Существует несколько причин, по которым это приходится делать. Основная из них - Windows 95 не всегда хорошо конфигурируется, если используются старые версии BIOS.

В настоящее время используются жесткие диски объемом более 528Мбайт. Для работы такого диска в системе необходимо поддержка LBA со стороны BIOS. Если BIOS не поддерживает LBA, то для работы с большими жесткими дисками приходится применять специальные утилиты. Применение таких утилит вызовет работу Windows 95 в compatible mode, что отрицательно сказывается на быстродействии.

Полная поддержка Plug-and-Play со стороны Windows 95 возможна только в случае применения PnP BIOS. Это очень веская причина для перепрошивки BIOS.

Кроме вышеуказанного, в новых версиях BIOS исправляются мелкие ошибки и недоработки. Новые версии могут содержать новые возможности, как то загрузка с CD ROM, SCSI перед IDE и т.п.

- Где можно скачать новые версии BIOS?

Во-первых новые версии BIOS доступны на сайтах их производителей. Во-вторых обычно производители материнских плат предлагают BIOSы для своих изделий. Так что, если знать производителя и название материнской платы, проблем не возникнет.

В принципе, название материнской платы можно и не знать. Обычно допускается прошивка BIOS от других плат, если на них установлен такой же чипсет и контроллер ввода-вывода. Однако такой возможностью следует пользоваться только в случае крайней необходимости, так как возможны другие несоответствия, например в количестве слотов и т.п., а прошивка неправильного BIOS может привести к тому, что материнскую плату придется выкидывать.

- Что делать, если производителя и название материнской платы определить не удается?

Чаще всего, производителя и название материнской платы можно определить по идентификационной строке, которую выдает BIOS сразу при включении компьютера.

Для AMI BIOS эта строка имеет вид, похожий на
51-0102-1101-00111111-101094-AMIS123-P или 40-01S5-ZZ1124-10101111-060691-OPWBSX-F,
где производитель определяется третьей группой цифр. Далее необходимо найти свой идентификационный номер в таблице соответствия номеров и названий производителей. Определить название материнской платы можно по всей идентификациолнной строке, пользуясь тем же документом.

Идентификационная строка Award BIOS имеет вид
2A59CQ1CC
и позволяет определить чипсет (первые пять цифр и букв - 2A59C), производителя материнской платы (следующие два символа - Q1) и модель материнской платы (оставшаяся часть строки - CC). Далее необходимо посмотреть обозначения чипсетов, производителей и моделей в идентификационных строках.

- Как перепрошить Flash BIOS?

Для выполнения этой операции необходимо иметь програму-прошивальщик и файл с BIOS. Программы для перепрошивки обычно поставляются с материнскими платами, в крайнем случае их можно скачать у производителей материнских плат и BIOS.

Далее, загрузившись под чистым DOS (без драйверов - нажав F8 и выбрав Safe Mode Command Prompt only), запустить программу прошивки:

  • awdflash xxx.bin (для Award BIOS)
  • amiflash xxx.bin (для AMI BIOS)
  • mrflash xxx.bin (для MRBIOS)
Замечания:
  • Большинство программ прошивки при запуске спрашивают, сохранить ли текущую версию BIOS. На этот вопрос рекомендуется ответить положительно, так как новый BIOS может работать не так как хотелось бы.
  • Некоторые производители материнских плат могут предлагать свои собственные программы-прошивальщики. В таком случае лучше пользоваться ими.
  • Перед прошивкой новой версии BIOS выключите опцию System BIOS Cacheable в Setup.
  • Если в Вашей системе процессор разогнан, то на время перепрошивки BIOS поставьте его на штатную частоту.

- Почему прошивальщик Award BIOS выдает сообщение "Insufficient memory"?

  1. В Setup в разделе Chipset Features Setup, отключите Video Bios Cacheable.
  2. Выйдете из Setup.
  3. Перезагрузитесь под чистым DOS (нажав F8 и выбрав Safe Mode Command Prompt only)
  4. Перепрошейте BIOS и перезагрузитесь
  5. Войдите в Setup и установите опцию Video Bios Cacheable в Enable.

- Что будет, если запортить BIOS или прошить неправильную версию?

Скорее всего, компьютер не будет грузиться, даже не подавая признаков жизни.

- Как восстановить поврежденный BIOS?

Метод 1 (универсальный):

  1. Беpем любую pаботающую мать, поддеpживающую флэш (совеpшенно необязательно, чтоб она была на том же чипсете, на котоpый pассчитан BIOS, котоpый мы хотим записать). Можно пpосто найти флэш или ПЗУ от матеpи, аналогичной той, флэш из котоpой мы будем пеpеписывать, и вpеменно поставить его (пеpеставив, если нужно, джампеpа типа флэша). Или, если есть пpогpамматоp, только он не умеет писать флэш - найти ПЗУ подходящего pазмеpа и записать его.
  2. Вынимаем флэш или ПЗУ из этой матеpи, обвязываем его с двух концов двумя кольцами нитки (чтоб можно было его легко извлечь) и неплотно втыкаем назад в панельку.
  3. Загpужаемся в "голый" ДОС, выдеpгиваем за эти два кольца стоящий в матеpи флэш или ПЗУ (все pавно он нужен только пpи загpузке), если нужно, пеpеставляем джампеpа типа флэша, и вставляем флэш, котоpый нужно записать. Главное тут - ничего не замкнуть :)
  4. Запускаем пpогpамму записи, pассчитанную на мать, на котоpой пишем, BIOS с котоpым гpузились и флэш, котоpый нужно записать (пpогpамма должна уметь пеpеписывать флэш целиком, напpимеp, из комплекта mr-bios или asusовский pflash). Пишем, выключаем питание и вынимаем готовый флэш. Все.

Метод 2 (для Award BIOS):

  1. Извлечь PCI-видеокарту (все нижеописанное не будет работать с PCI-видео, так как для инициализации PCI необходим BIOS)
  2. Установить старую ISA-видеокарту и подключить монитор
  3. Вставить загрузочную дискету в дисковод А:
  4. Включить компьютер
  5. Компьютер заработает благодаря Award Boot Block
  6. Вставить предварительно созданную дискету с прошивальщиком и правильным BIOS
  7. Перепрошить BIOS
  8. Перезагрузиться
  9. Выключить компьютер и поменять видеокарту обратно. Все - теперь можно работать

Метод 3 (для интеловских матерей):

  1. Установить Flash Recovery jumper в положение recovery mode (к сожалению, такую возможность имеют не все платы)
  2. Вставить загрузочную bootable upgrade дискету, которой комплектуется каждая интеловская плата, в дисковод A:
  3. Перезагрузиться
  4. Во время этой процедуры экран будет оставаться темным, так как в непрошиваемой boot block area не содержатся функции работы с видео. Эта процедура может контролироваться только пищанием спикера и миганием лампочки дисковода. Когда компьютер пискнеть и лампочка дисковода загорится, можно считать, что система копирует необходимые данные во Flash ROM. Как только лампочка дисковода погаснет, прошивка закончится.
  5. Выключить компьютер
  6. Вернуть Flash Recovery jumper обратно в положение по умолчанию
  7. Вынуть дискету из дисковода и включить компьютер

- Что такое PROM, EPROM и ЕEPROM и чем они отличаются?

PROM (programmable read-only memory - программируемая память только для чтения) - это чип памяти, данные в который могут быть записаны только однажды. То что записано в PROM, не вырубишь топором :) (хранится в нем всегда). В отличии от основной памяти, PROM содержит данные даже когда компьютер выключен.

Отличие PROM от ROM (read-only memory - память только для чтения) в том, что PROM изначально производятся чистыми, в тот время как в ROM данные заносятся в процессе производства. А для записи данных в чипы PROM, применяются специальные устройства, называемые программаторами.

EPROM (erasable programmable read-only memory - стираемая программируемая память только для чтения) - специальный тип PROM, который может очищаться с использованием ультрафиолетовых лучей. После стирания, EPROM может быть перепрограммирована. EEPROM - по сути похожа на PROM, но для стирания требует электрических сигналов.

EEPROM (electrically erasable programmable read-only memory - электрически стираемая программируемая память только для чтения) - специальный тип PROM, который может быть очищен электрическим разрядом. Подобно другим типам PROM, EEPROM содержит данные и при выключенном питании компьютера. Аналогично всем другим типам ROM, EEPROM работает не выстрее RAM.

Специальный тип EEPROM, называемый Flash memory или Flash EEPROM, может быть перезаписан без применения дополнительных устройств типа программатора, находясь в компьютере.

- Как сбросить установки BIOS (включая пароль) в значения по умолчанию из DOS?

Так как не все материнские платы оборудованы джампером для сброса установок BIOS или этот джампер может быть недоступен, то существует метод очистки BIOS из DOS, при помощи команды debug. Загрузившись в DOS (не в DOS-box под Windows!) необходимо набрать:

Метод 1 (Award и AMI BIOS):

DEBUG
-O 70 17
-O 71 17
Q

Метод 2 (Phoenix BIOS):

DEBUG
-O 70 FF
-O 71 17
Q

- Как подобрать (снять) пароль на Setup (загрузку)?

Если забыт паpоль на Setup, можно воспользоваться pазличными пpогpаммами для снятия паpоля или одним из заводских паролей.

Заводские пассворды для AWARD BIOS следующие:
 AWARD_SW, TTPTHA, aPAf, HLT, lkwpeter, KDD, j262, ZBAAACA, j322, ZAAADA, Syxz, %шесть пpобелов%, Wodj, %девять пpобелов%, ZJAAADC, 01322222, j256, ?award
Один из этих паролей должен подойти. Однако в новых AWARD BIOS (версии 4.51) инженерные пароли отсутствуют. Однако существует программка для снятия/определения установленных паролей в таких BIOS.

Для AMI BIOS стандартных паролей нету. Единственный случай: если вы только приобрели материнскую плату то пароль может быть AMI.

Существуют программы для определения установленного на Setup пароля. Вы можете скачать здесь эти утилиты для Award BIOS и AMI BIOS.

Hа некотоpых AMI BIOS можно сpазу после включения деpжать нажатой клавишу Ins - пpи этом в CMOS-память загpужаются стандаpтные паpаметpы.

- Как аппаратно сборосить CMOS (вместе с паролями)?

Почти на всех совpеменных системных платах pядом с батаpейкой есть пеpемычка для сбpоса CMOS-памяти (обычно - 4 контакта, ноpмальное положение - 2-3, сбpос - 1-2 или 3-4; иногда - 3 или 2 контакта).

Выпаивать и тем более замыкать батаpейку не имеет смысла - это чаще всего не пpиводит к успеху из-за констpукции схемы питания CMOS-памяти, а замыкание батаpейки сильно сокpащает сpок ее службы.

Если на плате нет батаpейки, нужно поискать пластмассовый модуль с надписью "DALLAS" (это монолитный блок с батаpейкой и микpосхемой CMOS) - пеpемычка может быть возле него.

В случае, если перемычка для очистки CMOS-памяти отсутствует, то сначала попробуйте отключить или отсоединить батарейку. При этом также рекомендуется отключить провода от блоки питания, так как заряд на его конденсаторах может сохраняться и успешно поддерживать питание CMOS RAM (ей очень мало надо) более суток.

Если это не помогло, то остается только замыкать соответствующие ножки у микросхемы CMOS-памяти, добиваясь ее очистки. Найдите, какой из перечисленных ниже чипов установлен у Вас и следуйте приведенным рекомендациям.

P82C206 Chip (квадратный) (старый)
Этот чип включает в себя всю мелкую логику AT - контроллеры DMA, прерываний, таймер а также clock chip. CMOS RAM на этом чипе очищается при замыкании контактов 12 и 32 или 74 и 75 на несколько секунд (при выключенном питании).

          gnd

           74

          _|____________________

  5v 75--|                     |

         |                     |

         |                     |

         |       CHIPS         |

     1 * |                     |

         |       P82C206       |

         |                     |

         |_____________________|

          |||||||||||||||||||||

          |                   |

          | gnd               | 5v

          12                 32

F82C206 Chip (прямоугольный)
Аналогичен предыдущему. CMOS RAM на этом чипе очищается при замыкании контактов 3 и 26 на несколько секунд (при выключенном питании).

      80                           51

       ______________________________

   81 |                              | 50

      |                              |

      |                              |

      |             OPTi             |

      |                              |

      |            F82C206           |

      |                              |

  100 |______________________________| 31

       ||||||||||||||||||||||||||||||

     1 |                      |   30

       |                      |

       3                     26

Dallas DS1287, DS1287A, Benchmarq bp3287MT, bq3287AMT
Dallas DS1287, DS1287A с совместимые Benchmarq bp3287MT и bq3287AMT чипы имеют встроенную батарею. Эта батарея расчитана как минимум на 10 лет. На материнских платах с этим чипом не должно быть дополнительных батарей. Если батарея вышла из сторя, необходимо заманить весть чип.

CMOS RAM может быть очищена на 1287A и 3287AMT чипах закорачиванием ножек 12 и 21 (при выключенном питании).

1287 (и 3287MT) отличаются от 1287A тем, что CMOS RAM не может быть очищена. И в случае если Вы забыли пароль необходимо заменить микросхему. В этом случае рекомендуется заменять на 1287A. Все также применимо к Dallas 12887 и 12887A, однако они содержат вдвое большую CMOS RAM.

              ___________

         1  -| *  U     |-  24 5 volts DC

         2  -|          |-  23

         3  -|          |-  22

         4  -|          |-  21 RCL (RAM Clear)

         5  -|          |-  20

         6  -|          |-  19

         7  -|          |-  18

         8  -|          |-  17

         9  -|          |-  16

         10 -|          |-  15

         11 -|          |-  14

 Ground  12 -|__________|-  13

Motorolla MC146818AP или совместимые
Обычно это прямоугольный 24 контактный DIP chip, обычно в панельке. Совместимые производятся несколькими компаниями, напимер Hitachi HD146818AP или Samsung KS82C6818A. Номер чипа должен оканчиваться на 6818. Хотя этот чип и совместим по выводам с Dallas 1287/1287A, в нем нет встроенной батареи. Это означает, что CMOS RAM может быть очищена просто выниманием чипа из панельки на некоторое время и установкой обратно.

Для уменьшения риска повреждения микросхемы рекомендуется закорачивать ножки 12 и 24 на несколько секунд при выключенном питании

              ___________

        1   -| *  U     |-  24  5 volts DC

        2   -|          |-  23

        3   -|          |-  22

        4   -|          |-  21

        5   -|          |-  20

        6   -|          |-  19

        7   -|          |-  18

        8   -|          |-  17

        9   -|          |-  16

        10  -|          |-  15

        11  -|          |-  14

Ground  12  -|__________|-  13

Dallas DS12885S или Benchmarq bq3258S
CMOS RAM на этом чипе очищается замыканием контактов 12 и 20 при выключенном питании. Также можно попробовать 12 и 24.

(5Volts)

   24          20                   13

    |  |  |  |  |  |  |  |  |  |  |  |

    -----------------------------------

   |                                   |

   |             DALLAS                |

   |>                                  |

   |             DS12885S              |

   |                                   |

    -----------------------------------

    |  |  |  |  |  |  |  |  |  |  |  |

    1                                12

                                  (Ground)

- Что означают аварийные звуковые сигналы, выдаваемые AMI BIOS при загрузке?

Звуковые сигналы

Число сигналов | Описание проблемы | Решение
1 | DRAM refresh failure | Вставьте память еще раз. Если не помогает, то это проблема с памятью.
2 | Parity Circuit Failure
3 | Base 64K RAM failure
4 | System Timer Failure | Материнская плата неработоспособна
5 | Processor Failure
6 | Keyboard Controller / Gate A20 Failure | Вытащите и вставьте чип контроллера клавиатуры. Если не помогает, замените контроллер клавиатуры. Если и это не помогает, проверьте клавиатуру и ее кабель
7 | Virtual Mode Exception Error | Материнская плата неработоспособна
8 | Display Memory Read/Write Failure | Ошибка памяти видеоадаптера. Переисталлируйте видеокарту и память на ней. Если не помогает, замените видеокарту.
9 | ROM BIOS Checksum Failure | Ошибка в микросхеме BIOS. Попробуйте вытащить и вставить заново этот чип. Если не помогает, необходимо перепрошить его содержимое или заменить микросхему.
10 | CMOS Shutdown Register Read/Write Error | Материнская плата неработоспособна
1-2 | Search for option ROM (video configure fails)
1-3 | Video failure | Переинсталлируйте видеокарту. Если не помогает, придется ее заменить
1-2-2-3 | BIOS ROM checksum
1-3-1-1 | Test DRAM refresh
1-3-1-3 | Test keyboard controller
1-3-4-1 | Test 512K base address lines
1-3-4-3 | Test 512K base memory
1-4-1-1 | Test memory bus
2-1-2-3 | Check ROM copyright notice
2-2-3-1 | Test for unexpected interrupts
1 | POST passed. | Все идет по плану

Сообщения об ошибках

Сообщение | Проблема | Решение
CH-2 Timer Error | Не фатально. Может быть вызвано переферией
INTR #1 Error | Первый канал прерываний не прошел POST | Проверьте устройства, занимающие IRQ 0-7.
INTR #2 Error | Второй канал прерываний не прошел POST | Проверьте устройства, занимающие IRQ 8-15.
CMOS Battery State Low | Замените батарейку
CMOS Checksum Failure | Контрольная сумма данных в CMOS-памяти не сходится с вычисленной ранее | Запустите Setup
CMOS Memory Size Mismatch | Размер занятой CMOS-памяти не сходится с тем, что должно быть | Запустите Setup
CMOS System Optons Not Set | Данные в CMOS повреждены или отсутствуют | Запустите Setup
Display Switch Not Proper | Неправильно выставлен тип монитора (цветной или моно) на материнской плате | Переставьте джампер в правильное положение
Keyboard is locked ... Unlock it | Разблокируйте клавиатуру
Keyboard Error | Пороблема с клавиатурой | Проверьте соответствие типа клавиатуры (AT/XT) контроллеру. Можно попытаться отключить тестирование клавиатуры при загрузке в Setup
K/B Interface Error | Проблема с подсоединением клавиатуры к материнской плате
FDD Controller Failure | BIOS не может связаться с контроллером гибких дисков | Проверьте подсоединение дисковода и его разрешенность на мультикарте
HDD Controller Failure | То же, но с винчестером
C: Drive Error | Диск C не отвечает | Либо в Setup выставлен неправильный тип диска, либо диск не отформатирован, либо плохо подключен
D: Drive Error | То же самое, но с диском D | То же
C: Drive Failure | Диск С находится, но не работает. Очень серьезная проблема
D: Drive Failure | То же про диск D
CMOS Time and Date Not Set | Запустите Setup
Cache Memory Bad, do Not Enable Cache! | Действительно плохой кеш, придется заменить. Хотя сначала попробуйте просто перезагрузиться
8042 Gate-A20 Error! | Линия A20 контроллера клавиатуры не работает | Замените контроллер клавиатуры (8042)
Address Line Short | Проблема со схемой адресации памяти | Попробуйте перезагрузиться, (выключив компьютер и подождав секунд 30). Проблема можетразрешиться сама
DMA #1 Error | Ошибка первого канала DMA | Может быть вызвана соответствующим переферийным устройством
DMA Error | Ошибка контроллера DMA
No ROM Basic. | Система не может загрузиться. (например, невозможно найти операционную систему) | Установите загрузочный диск или измените его в Setup
Diskette Boot Failure | Не удается загрузиться с дискеты
Invalid Boot Diskette | Аналогично, но дискета читается
On Board Parity Error | Ошибка контроля четности | Может быть вызвана соответствующей переферией, занимающей адрес, указанный в сообщении об ошибке
Off Board Parity Error | Аналогично | То же
Parity Error | Аналогично | То же
Memory Parity Error at XXXX | Ошибка памяти | То же
I/O Card Parity Error at XXXX | То же | То же
DMA Bus Time-out | Устройство не отвечает в течении 7.8мкс | Проблема в платах расширения (попытайтесь найти ту плату, которая вызывает эту ошибку и заменитеее)
Memory mismatch, run Setup | Установите в Setup Memory Relocation в Disable
EISA CMOS Checksum Failure | Не сходится контрольная сумма EISA CMOS, или села батарейка
EISA CMOS Inoperational | Ошибка чтения/записи в CMOS RAM | Батарейка может быть плохой
Expansion Board not ready at Slot X | AMI BIOS не может найти плату в слоте номер X | Проверьте установку платы в этом слоте
Fail-Safe Timer NMI Inoperational | Ошибка таймера NMI
ID information mismatch for Slot X | ID EISA-карты в слоте X не соответствует ID, записанному в CMOS RAM.
Invalid Configuration Information for Slot X | Конфигурационная информация о карте в слоте Х EISA некорректна | Запустите ECU
Software Port NMI Inoperational | Программный порт NMI не работает
BUS Timeout NMI at Slot X | Карта в слоте Х NMI не отвечает
(E)nable (D)isable Expansion Board? | Выберите E для разрешения использования карты в слоте Х NMI или D в противном случае
Expansion Board disabled at Slot X | Плата расширения в слоте Х NMI недоступна
Fail-Safe Timer NMI | Таймер NMI сгенерировал ошибку
Software Port NMI | Генерируется программным портом NMI

- Что означают аварийные звуковые сигналы, выдаваемые Award BIOS при загрузке?

Звуковые сигналы

Число сигналов | Проблема | Решение
1 длинный 2 коротких | Video error | Переинсталлируйте видеокарту. Проверьте видеопамять. Замените карту
Короткие сигналы | Memory error | Проблемы с памятью. Попробуйте заменить модули памяти.

Сообщения об ошибках

Cообщение | Проблема | Решение
CMOS BATTERY HAS FAILED | Села батарейка | Замените батарейку
CMOS CHECKSUM ERROR | Неправильная контрольная сумма CMOS. Данные в CMOS повреждены. Возможно, батарейка села | Проверьте батерейку и замените ее в случае необходимости
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER | Не найден загрузочный диск | Загрузитесь с дискеты и проверьте системные файлы на жестком диске
DISKETTE DRIVES OR TYPES MISMATCH ERROR - RUN SETUP | Типы дисководов, фактически установленных в системе и их описания в CMOS не сходятся | Запустите Setup и введите правильный тип дисковода
DISPLAY SWITCH IS SET INCORRECTLY | Неправильно выставлен тип монитора (цветной или моно) на материнской плате | Переставьте джампер в правильное положение
DISPLAY TYPE HAS CHANGED SINCE LAST BOOT | Изменился тип дисплея со времени последней загрузки | Запустите Setup и введите правильный тип дисплея
EISA Configuration Checksum Error | Не сходится контрольная сумма EISA non-volatile RAM | Запустите EISA Configuration Utility
EISA Configuration is Not Complete | Информация в EISA - неполная | Запустите EISA Configuration Utility
ERROR ENCOUNTERED INITIALIZING HARD DRIVE | Не инициализируется жесткий диск | Проверьте установку контроллера жестких дисков и соединительные кабеля
ERROR INITIALIZING HARD DRIVE CONTROLLER | Контроллер жестких дисков не инициализируется | Проверьте установку контроллера, и параметры жесткого диска, указанные в Setup. Также проверьте джампера на жестком диске
FLOPPY DISK CNTRLR ERROR OR NO CNTRLR PRESENT | Невозможно инициализировать контроллер гибких дисков | Проверьте установку контроллера, и параметры дисковода, указанные в Setup
Invalid EISA Configuration | Данные о конфигурации EISA не верны | Запустите EISA Configuration Utility
KEYBOARD ERROR OR NO KEYBOARD PRESENT | Невозможно инициализировать клавиатуру | Проверьте подключение клавиатуры и ее тип. В крайнем случае отключите контроль клавиатуры при загрузке
Memory Address Error at XXXX | Ошибка памяти | Замените память
Memory parity Error at XXXX | Ошибка контроля четности | Замените память
MEMORY SIZE HAS CHANGED SINCE LAST BOOT | Размер памяти изменился со времени последней загрузки | Если есть EISA, запустите EISA Configuration Utility. В противном случае войдите в Setup
Memory Verify Error at XXXX | Ошибка при тестировании памяти | Замените память
OFFENDING ADDRESS NOT FOUND | Беда с контроллером памяти
OFFENDING SEGMENT: То же самое
PRESS A KEY TO REBOOT | Сообщени возникает при обнаружении ошибок и необходимости перезагрузки | Нажмите любую кнопку
PRESS F1 TO DISABLE NMI, F2 TO REBOOT | Проблемы с немаскируемыми прерываниями
RAM PARITY ERROR - CHECKING FOR SEGMENT | Ошибка четности в RAM
Should Be Empty But EISA Board Found | ID одной из карт расширения не соответствует конфигурации | Запустите EISA Configuration Utility
Should Have EISA Board But Not Found | Карта не отвечает на запрос по ID | Запустите EISA Configuration Utility
Slot Not Empty | Слот, записанный в конфигурации как пустой, занят | Запустите EISA Configuration Utility
SYSTEM HALTED, (CTRL-ALT-DEL) TO REBOOT ... | Обозначает остановку процесса загрузки | Нажмите Ctrl-Alt-Del
Wrong Board in Slot | Установлена карта не с тем ID | Запустите EISA Configuration Utility

- Что означают аварийные звуковые сигналы, выдаваемые Phoenix BIOS при загрузке?

Звуковые сигналы

Число сигналов | Проблема | Решение
1-1-3 | Real-time clock write/read failure
1-1-4 | ROM BIOS checksum failure
1-2-1 | Programmable Interval Timer failure
1-2-2 | DMA initialization failure
1-2-3 | DMA page register write/read failure
1-3-1 | RAM refreash verification failure
1-3-3 | 1st 64 KB RAM chip or data line failure multi-bit
1-3-4 | 1st 64 KB RAM odd/even logic failure
1-4-1 | 1st 64 KB RAM address line failure
1-4-2 | 1st 64 KB RAM parity test in progress or failure
2-1-1 | Bit 0 1st 64 KB RAM failure
2-1-2 | Bit 1 1st 64 KB RAM failure
2-1-3 | Bit 2 1st 64 KB RAM failure
2-1-4 | Bit 3 1st 64 KB RAM failure
2-2-1 | Bit 4 1st 64 KB RAM failure
2-2-2 | Bit 5 1st 64 KB RAM failure
2-2-3 | Bit 6 1st 64 KB RAM failure
2-3-4 | Bit 7 1st 64 KB RAM failure
2-3-1 | Bit 8 1st 64 KB RAM failure
2-3-2 | Bit 9 1st 64 KB RAM failure
2-3-3 | Bit A 1st 64 KB RAM failure
2-2-4 | Bit B 1st 64 KB RAM failure
2-4-1 | Bit C 1st 64 KB RAM failure
2-4-2 | Bit D 1st 64 KB RAM failure
2-4-3 | Bit E 1st 64 KB RAM failure
2-4-4 | Bit F 1st 64 KB RAM failure
3-1-1 | Slave DMA register failure
3-1-2 | Master DMA register failure
3-1-3 | Master interrupt mask register failure
3-1-4 | Slave interrupt mask register failure
3-2-4 | Keyboard controller test failure
3-3-4 | Screen memory test failure
3-4-1 | Screen initialization failure
3-4-2 | Screen retrace test failure

- Как отредактировать Award BIOS?

Для начала, скачайте набор Awardовских утилит.

Как измененить EPA Logo, читайте здесь.

Для изменения установок по умолчанию:

  1. Необходимо использовать MODBIN v4.50.60
  2. Запустить
    modbin.exe bios.bin
    (имя файла, естественно, необходимо задать таким, какой BIOS вы собираетесь редактировать)
  3. Изменить установки
  4. Сохранить измененный файл
  5. Перепрошить этот файл во Flash ROM
Последнее обновление -- 5 марта 2003 г.


BIOS компьютера
1. Boot

При включении ПК автоматически запускается находящаяся в BIOS программа загрузки BOOT-ROUTINE. Эта программа вызывает подпрограмму самопроверки POST (Power-On Self Test), проверяющую оперативную память, процессор, жесткий диск и т.д.
Далее программа загрузки разыскивает другие BIOS-чипы, которые могут быть встроены, к примеру, в платы расширения. SCSI- контроллеры при этом будут запускать свои собственные тестовые программы.
После этого BIOS берется уже конкретно за платы расширения и расстановку и проверку распределения ресурсов (IRQ, DMA, I/O).
Далее с загрузочных секторов жесткого диска в дело вступает начальный загрузчик, BOOTSTRAP LOADER, - программа, знающая файловую структуру носителя данных. Начальный загрузчик вызывает загрузку загрузочных программ операционной системы.
Этот стандартный алгоритм значительно дополнился и модернизировался с внедрением PnP-технологии и новой PCI-шины, а позже с появлением операционных систем, разработанных с учетом внедрения новейших технологий. Но более подробно об этом будет сказано ниже.

Above 1 MB Memory Test
- при выборе опции "Enabled" в процессе тестирования ОЗУ проверяется область памяти свыше 1 Мб (область памяти XMS - Extended Memory Specification). На это расходуется дополнительное время в процессе загрузки, тем более такой тест является излишним, так как драйвер-менеджер памяти HIMEM.SYS сам осуществляет проверку оперативной памяти и предпочтительнее использовать именно этот тест, так как он работает в реальном рабочем окружении.

BIOS Update
- (обновление BIOS). Процессоры семейства P6 (Pentium Pro, Pentium II, Celeron, Xeon) имеют особый механизм, называемый "программируемым микрокодом", который позволяет исправить некоторые виды ошибок, допущенных при разработке и/или изготовлении процессоров, за счет изменения микрокода. Обновления микрокода остаются в BIOS и загружаются в процессор в процессе выполнения инструкций BIOS. Именно поэтому BIOS для материнских плат с указанными выше процессорами необходимо регулярно обновлять. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
В "AMI BIOS" была встречена аналогичная опция под названием "CPU MicroCode Updation".
Опция может называться и "Pentium II Microcode".

Boot From LAN First
- при установке в "Enabled" BIOS предпримет попытку первоначальной загрузки из сетевого загрузочного модуля, прежде чем пытаться загрузиться с локального носителя.

Boot Sequence
- (последовательность начальной загpузки системы). Определяется последовательность опроса накопителей для загрузки операционной системы. Эти устройства обозначаются либо буквами для физических жестких дисков и обычных дисководов, либо названием устройства, например "CDROM" для накопителей CD-ROM. Поддерживаются устройства LS-120, Iomega ZIP, ATAPI CD-ROM, IDE- и SCSI-диски. Может принимать значения:
"A,C" - такой выбор оправдан только для случая загрузки с дискеты и встречается в старых моделях ПК,
"A,C,SCSI",
"C only",
"C,A",
"C,A,SCSI",
"C,CDROM,A",
"CDROM,C,A",
"D,A,SCSI" (предназначено при использовании минимум двух IDE-жестких дисков),
"E,A,SCSI" (аналогично для 3-х дисков),
"F,A,SCSI" (аналогично для 4-х дисков),
"LS/ZIP,C",
"SCSI,A,C",
"SCSI,C,A".
В некоторых версиях BIOS опция "Boot Sequence" трансформировалась в несколько самостоятельных опций, естественно с большей возможностью отбора и большей гибкостью. Это выглядит следующим образом:
"First Boot Device"
"Second Boot Device"
"Third Boot Device"
"Boot Other Device"
Параметры могут принимать следующие значения: "Floppy", "HDD-0", "HDD-1", "HDD-2", "HDD-3", "LAN", "SCSI", "LS/ZIP", "CDROM", "Enable", "Disable".
А один из вариантов "AMI BIOS" содержит те же опции, но со значениями "Floppy", "Floptical" (RS 120), "CD ROM", "SCSI Device", "Network", "IDE0", "IDE1", "IDE2", а опция "Try Other Boot Devices" через значение "Yes" дает возможность дополнительного выбора варианта загрузки, если имеющиеся варианты не устраивают пользователя.
Другое название опции - "System Boot Sequence".

Boot Up Floppy Seek
- (поиск дисковода при загрузке компьютера). Так можно перевести название этой функции. Но смысл функции значительно шире, поскольку BIOS проверяет, есть ли дисковод для дискет и идет ли речь при этом о 40- или 80-тидорожечном дисководе. При этом обеспечивается проверка работоспособности дисководов гибких дисков. Поскольку все современные дисководы имеют 80 дорожек (с 1993 года дисководы на 40 дорожек не выпускаются. Они поддерживали формат в 360 КБ), то эта функция необязательна. Необходимо заметить, что BIOS не может определить разницу между 720K, 1.2M, 1.44M или 2.88M типами дисководов, т.к. все они имеют 80 дорожек. Имеет смысл установить эту опцию в "Disabled" (иначе - "Enabled"), что позволит сократить общее время тестирования ПК после включения.
Другое название опции - "Floppy Drive Seek At Boot".

Boot Up Numlock Status
- опция, определяющая, в каком режиме после включения компьютера должна работать дополнительная цифровая клавиатура. Разрешение этого параметра включает индикатор "Num Lock", и цифровая клавиатура генерирует коды цифр и знаков, в противном случае генерируются коды стрелок, "Ins", "Del" и т.д. Может принимать значения:
"On" (иногда "Enabled") - включено,
"Off" (иногда "Disabled") - отключено.
Другое название опции - "System Boot Up Numlock Status".
Режим работы в любой момент времени меняется кнопкой <NumLock>.

Boot Up System Speed
- опция выбора тактовой частоты процессора при загрузке. Значение "Low" переводит процессор в режим работы с половинной тактовой частотой и без использования внутренней кэш-памяти. Естественно, что изначально понижается пропускная способность системной шины. Такой режим может потребоваться при работе со старыми программами или платами расширения, а также при возможных проблемах при запуске системы. По умолчанию всегда устанавливается значение "High".
Опция может носить название "System Boot Up CPU Speed".

Boot Virus Detection
- (определение вируса в загрузочном секторе). Смысл этого параметра отличается от "Virus Warning" и заключается он в следующем. Если этот параметр запрещен ("Disabled"), то до загрузки операционной системы BIOS переписывает загрузочный сектор во флэш-память и сохраняет его там. Но при этом никаких последствий для системы и пользователя не возникает. При установке параметра в "Enabled" BIOS не будет загружать систему с жесткого диска, если содержимое boot-сектора будет отличаться от сохраненного в памяти. При этом система выводит сообщение, и пользователю, далее, предоставляется возможность либо загрузить систему с жесткого диска, либо с дискеты.
Опция может носить название "BootSector Virus Detection".

Daylight Saving
- во включенном состоянии ("Enabled") эта опция позволяет автоматически добавлять или вычитать один час при весеннем или осеннем переводе времени (последнее воскресенье апреля и аналогично в октябре). Этот параметр можно отключить, если установлена "Windows 9x", самостоятельно регулирующая этот процесс.

Delay IDE Initial
- (задержка инициализации IDE-устройства). В данном параметре устанавливается интервал времени (в секундах), в течение которого IDE-устройство не будет опрашиваться BIOS после включения питания. Ненулевое значение параметра рекомендуется устанавливать только в случае применения старых жестких дисков. Не все старые приводы способны достичь номинальной скорости вращения за время, которое при включении ПК проходит до начала тестирования жесткого диска. Опция была введена первоначально в "AMI BIOS" для использования старых накопителей и позднее была оставлена для совместимости.
В различных версиях BIOS могут встретиться абсолютно идентичные функции: "Hard Disk Pre-Delay", "Delay For HDD (Secs)". Хотя при этом могут несколько варьироваться значения параметров: от "0" до "15", от "0" до "30", от "1" до "15" и "Disabled".

Flash BIOS Protection
- включение опции запрещает доступ к Flash BIOS вирусам и неопытным пользователям. При этом не может быть произведено обновление содержимого Flash BIOS. Для обновления функцию надо отключить. На некоторых материнских платах функция реализована не в виде опции "BIOS Setup", а в виде перемычки, либо не реализована вовсе. Желательно функцию включить. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

Halt On
- сразу после включения ПК, во время теста самопроверки POST, при нахождении какой-либо аппаратной ошибки система прекращает загрузку и выводит наименование устройства, вызвавшего сбой. Будет ли произведена остановка, и в каких случаях это произойдет, как раз и определяет параметр команды "Halt On". Возможными параметрами являются:
"No Errors" - POST никогда не прерывает работу, какая бы нефатальная для системы ошибка не была обнаружена (нарушение работы устройства или даже его отсутствие),
"All Errors" - остановка работы при возникновении любой критической, но не фатальной, ошибки. Интегрированная опция,
"All, But Keyboard" - остановка при любой критической ошибке, кроме ошибки клавиатуры,
"All, But Diskette" - аналогично, только с игнорированием ошибок дисководов,
"All, But Disk/Key" - игнорирование ошибок клавиатуры и дисководов.
Опция может носить название "Error Halt".

Hit "Del" Message Display
- отключение этой опции не позволит вывести на экран монитора сообщение о том, с помощью какой клавиши возможен доступ к "BIOS Setup" во время загрузки системы. Косвенно эта опция может служить в качестве защитной функции, хотя и весьма сомнительной.

Keyboard
- (клавиатура). Значение "Installed" не вызывает вопросов. Если установить "not installed", эта опция укажет BIOS на отмену пpовеpки клавиатуpы во вpемя стаpтового теста, что позволяет пеpезапускать ПК с отключенной клавиатуpой без выдачи сообщения об ошибке теста клавиатуpы. Это может оказаться необходимым при работе файл-сервера, сервера печати, в т.ч. из соображений безопасности.
Аналогичную задачу решает опция "System Keyboard" (AMI BIOS) с параметрами "Present" (по умолчанию) и "Absent".

Memory Test Tick Sound
- опция, позволяющая сопровождать тест памяти периодическими звуковыми сигналами. Рекомендуется устанавливать в "Enabled" для озвучивания пpоцесса загpузки и дополнительного подтверждения, в частности, правильности установок "CPU clock speed/ Turbo switch".

Numeric Processor Test
- (тест цифрового пpоцессоpа). Речь в данной опции идет о проверке математического сопроцессора (FPU - Floating Point Unit). Хотя эта опция и устарела, но тем не менее парк стареньких ПК еще не исчез бесследно. Устанавливается в "Disabled", если сопроцессор отсутствует (386SX, 386DX, 486SX, 486SLC, 486DLC, более низкие модели). Пpи отключении этого теста сопpоцессоp, если он даже и пpисутствует в системе, не pаспознается и считается отсутствующим.

Processor Number Feature
- опция для установки автоматического считывания и вывода информации о встроенном серийном номере процессора Pentium III в BIOS материнских плат, поддерживающих его установку. Для реализации такой возможности, естественно, требуется значение параметра как "Enabled". Во всех остальных случаях устанавливается значение "Disabled". Оно же устанавливается по умолчанию.
Опция может носить название "Processor S/N".

Quick Power On Self Test
- (быстрый тест компьютера после включения питания). Разрешение этого параметра приводит к некоторому сокращению времени на начальное самотестирование компьютера (POST), особенно при значительных объемах оперативной памяти. Следует только учесть, что память, например, в этом случае не тестируется, а только проверяется ее размер. Сокращение времени тестирования происходит также за счет пропуска некоторых пунктов проверки. Если при работе ПК возникают какие-либо проблемы, то лучше при его включении осуществлять полный тест. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено (по умолчанию).
"AMI BIOS" может содержать аналогичную опцию под названием "Quick Boot".

RTC Y2K H/W Roll Over
- при установке опции в "Enabled" происходит тестирование системы на проблему 2000 года. "Disabled" устанавливается по умолчанию.

Swap Floppy Drive
- (перестановка дисководов). Опция, позволяющая "поменять местами" дисководы A: и B: и сделать загрузочным дисковод B: (или наоборот). Опция имеет смысл только при наличии двух дисководов в компьютере и необходимости сделать загрузочным дисковод 5.25". При этом дисководы меняются местами только логически, а не физически. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено (по умолчанию).

USB Keyboard Support Via
- метод поддержки USB-клавиатуры. Таких методов два: либо поддержка USB-клавиатуры операционной системой на уровне драйверов, либо аппаратное определение через BIOS. Если есть необходимость работы в системе, не поддерживающей USB-шину, то необходимо включить поддержку через BIOS. Может принимать значения:
"OS" - речь идет, например, о "Windows 98",
"BIOS" - такая установка необходима для той же "MS-DOS".

Video
- установка типа видеоадаптера для первичного системного монитора. Хотя вторичный монитор поддерживается и некоторыми ОС, установки в "BIOS Setup" для него отсутствуют. По умолчанию устанавливается "EGA/VGA". Возможны варианты:
"Mono" (Monochrome) - для монохромных видеоадаптеров,
"Hercules" - также для монохромных видеоадаптеров,
"MDA" - для монохромных видеоадаптеров, поддерживающих только текст,
"CGA 80" (Color Graphics Adapter) - для режима 80 колонок,
"CGA 40" (Color Graphics Adapter) - для режима 40 колонок,
"EGA/VGA" (Enhanced Graphics Adapter/Video Graphics Array) - для EGA-, VGA-, SVGA- и PGA-адаптеров мониторов. Последний параметр может называться и "VGA/PGA/EGA".
Опция может иметь название и "Primary Display", а для выбора значений могут быть предложены "Absent" и "VGA, EGA". Вариант с отсутствующим дисплеем также может найти применение, как ни странно, например, в специализированных технологических системах. Во всяком случае, автор с такой ситуацией сталкивался.
Необходимо вспомнить и о применении жидкокристаллических дисплеев. Опция может называться "LCD&CRT", а значения параметра могут быть следующие:
"LCD" (Liquid Crystal Display) - жидкокристаллический дисплей,
"CRT" (Cathode Ray Tube) - дисплей с электронно-лучевой трубкой,
"AUTO" - автоматическое определение устройства,
"LCD&CRT" - объединенный параметр.

Virus Warning
- (предупреждение о вирусе). Разрешение этого параметра ("Enabled") запрещает любую запись в загрузочный сектор жесткого диска или таблицу разделов (partition table). При попытке изменения этих областей BIOS останавливает систему с выводом на экран монитора соответствующего сообщения, а также звукового сигнала. При этом пользователь может либо pазpешить запись, либо запpетить ее.
Технически эта задача решается следующим образом.
На этапе проведения POST-теста перед входом в процедуру обработки дискового сервиса (INT13h) устанавливается транзитный программный модуль, который анализирует входные параметры функции и детектирует две ситуации: попытку записи в BOOT Sector и попытку форматирования 0-й дорожки. Если система условий выполняется, вместо дисковой операции выдается предупреждающее сообщение и звуковой сигнал. На соответствующем шаге теста выполняется перестановка вектора INT13h на транзитный контролирующий модуль, если в "BIOS Setup" включен данный режим. Данный алгоритм, в зависимости от прошивок, может видоизменяться, но суть останется прежней. Подобным образом BIOS отслеживает ситуацию и при работе операционной системы.
Опция введена для защиты от так называемых boot-вирусов, поражающих загрузочный сектор. Стандартные действия при этом - запуск антивирусных программ, прежде всего с защищенных дискет.
Эта опция должна быть обязательно отключена при форматировании жесткого диска, при вводе команды FDISK/MBR, при инсталляции операционных систем, при использовании администpатоpа начальной загpузки OS/2 (OS/2 Boot Manager), котоpый использует запись в загрузочный сектоp. Кроме того, некоторые диагностические программы при обращении к boot-сектору могут вызвать появление сообщения о "вирусной атаке", что не отражает текущую ситуацию. Применение этой функции не имеет смысла в случае использования SCSI- и ESDI-дисков, поскольку они используют собственный BIOS на контpоллеpе.
Еще одним из возможных вариантов параметра может быть значение "ChipAway", с одной стороны это значение - аналог "Enabled", с другой - это один из варинтов встроенного антивируса. При старте машины выводится надпись "ChipAway Virus Enabled", что не должно пугать пользователя.
Опция может называться также "Virus Protection", "BootSector Virus Protection".

Wait for <F1> If Any Error
- если опция включена, BIOS будет ожидать нажатия клавиши <F1> для продолжения загрузки в случае какой-либо неисправности на стадии тестирования POST, но только в случае нефатальной ошибки. Если установлено в "Disabled", система выводит пpедупреждение и пpодолжает загpузку без ожидания нажатия клавиши. Рекомендуется устанавливать в "Enabled". "Disabled" может быть рекомендовано для серверных систем.

Weitek Coprocessor
- (сопpоцессоp Weitek). Если он имеется в системе, следует установить "Enabled". Интересно, что производительность этого сопроцессора в 2-3 раза превышала производительность стандартных интеловских. Сопроцессор Weitek использует (скорее, использовал) некотоpую часть системного ОЗУ, поэтому память из этой области должна была быть отобpажена где-нибудь в дpугих адpесах. Одна из "древних" опций "AMI BIOS".

1.1. Beeps

1.2. Errors

 В процессе старта системы и проведения POST-теста возможны различного рода аппаратные ошибки, сопровождаемые параллельным выводом на экран монитора соответствующих сообщений. Некоторые из приведенных ниже сообщений несколько утратили свою актуальность, некоторые просто отсутствуют. Умышленно выведены, например, из этого перечня сообщения об ошибках с EISA- шиной. В остальном, этот материал будет несомненно полезен.

8042 Gate-A20 Error!
- линия A20 контроллера клавиатуры (8042) не работает. Заменить контроллер клавиатуры.
Address Line Short!
- проблема со схемой декодирования адреса памяти. Имеет смысл перезагрузиться, подождав секунд 30 до повторного включения. Проблема может разрешиться сама собой.
BIOS ROM checksum error - System halted
- проверочная сумма при тесте ПЗУ по адресу F0000H-FFFFFH ошибочна. Возможно потребуется восстановление (перепрошивка) микросхемы с Flash BIOS.
Cache Memory Bad, Do Not Enable Cache!
- ошибка кэш-памяти. Возможно потребуется замена. Хотя сначала стоит попробовать просто перезагрузиться.
CH-2 Timer Error
- ошибка второго таймера. Некоторые системы имеют два таймера.
CMOS battery failed, CMOS Battery Has Failed, CMOS Battery State Low
- эти сообщения в начале загрузки компьютера свидетельствуют о неисправности батареи или ее разрядке. Необходимо заменить батарею.
CMOS Checksum Error, CMOS Checksum Failure
- неправильная контрольная сумма CMOS, что свидетельствует о повреждении данных в CMOS, возможно из-за сбоя батареи. Если попытка восстановления "BIOS Setup" окажется неудачной, возможно придется обращаться в сервисный центр со своей материнской платой.
CMOS Memory Size Mismatch
- объем физической памяти на материнской плате не сходится с тем, что зафиксировалось в CMOS RAM. Необходимо перезапустить "BIOS Setup", проверить все установки. После перезагрузки ПК ошибка может исчезнуть, иначе потребуется замена компонентов материнской платы.
CMOS System Optons Not Set
- данные в CMOS повреждены или отсутствуют. Действия пользователя аналогичны вышеприведенным.
CMOS Time and Date Not Set
- нарушены или не установлены параметры даты и времени. Задача сводится к проверке или установке этих параметров в "BIOS Setup".
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER
- не найден загрузочный диск. Необходимо загрузиться с дискеты и проверить системные файлы на жестком диске.
Diskette Boot Failure
- дискета в дисководе А: не является загрузочной, т.е. невозможно загрузиться с дискеты в процессе запуска ПК. Дискета может не быть загрузочной, либо системные файлы повреждены.
DISKETTE DRIVES OR TYPES MISMATCH ERROR - RUN SETUP
- типы дисководов, фактически установленных в системе, и их описания в CMOS не сходятся. Необходимо запустить "BIOS SETUP" и ввести правильные типы дисководов.
DISPLAY SWITCH IS SET INCORRECTLY, Display Switch Not Proper
- неправильно выставлен тип монитора (монохромный или цветной). Переставить соответствующий джампер на материнской плате в правильное положение или исправить выбор типа монитора в "BIOS Setup".
DISPLAY TYPE HAS CHANGED SINCE LAST BOOT
- изменился тип дисплея со времени последней загрузки. В "BIOS Setup" ввести правильный тип дисплея.
DMA #1 Error, DMA #2 Error
- ошибка первого/второго канала DMA. Ошибка может быть вызвана соответствующим периферийным устройством.
DMA Bus Time-out
- устройство не отвечает в течении 7,8 мкс. Проблема в платах расширения. Необходимо найти плату, которая вызывает эту ошибку и заменить ее.
DMA Error
- ошибка контроллера DMA. Возможна замена материнской платы.
ERROR ENCOUNTERED INITIALIZING HARD DRIVE
- не инициализируется жесткий диск. Проверить установку контроллера жестких дисков (для устаревших систем), соединительные кабеля, а также параметры "BIOS Setup".
ERROR INITIALIZING HARD DRIVE CONTROLLER, HDD Controller Failure
- ошибка связи с контроллером жестких дисков, контроллер жестких дисков не инициализируется. Проверить установку контроллера, подсоединение дисковода и параметры жесткого диска в "BIOS Setup". Также стоит проверить установку джамперов на жестком диске.
Expansion Board not ready at Slot X
- BIOS не может найти плату в слоте номер X. Проверить установку платы в этом слоте.
FDD Controller Failure
- ошибка связи с контроллером гибких дисков. Проверить подсоединение дисковода и его разрешенность на мультикарте (для устаревших систем).
FLOPPY DISK CNTRLR ERROR OR NO CNTRLR PRESENT
- невозможно инициализировать контроллер гибких дисков. Проверить установку контроллера и параметры дисковода, указанные в "BIOS Setup".
Floppy disk(s) fail
- нельзя найти или инициализировать контроллер или сам флоппи-дисковод. Действия аналогичны.
Floppy disk(s) fail (40)
- это сообщение в конце теста ПК говорит о возможной ошибке в подключении шлейфа. Непрерывно светящийся индикатор также свидетельствует о неправильном подключении. Ошибка может заключаться и в несоответствии типа флоппи-дисковода, установленного в "BIOS Setup".
Hard disk(s) diagnosis fail
- ошибка начальной диагностики жесткого диска.
Hard Disk(s) fail (20)
- ошибка инициализации жесткого диска.
Hard Disk(s) fail (40)
- ошибка диагностики Hdd-контроллера.
HARD DISK INSTALL FAILURE
- нельзя найти или инициализировать контроллер или сам жесткий диск. Действия те же, т.е. проверить все механические установки и подключения, а также правильность установок в "BIOS Setup".
INTR #1 Error, INTR #2 Error
- первый/второй канал прерываний не прошел POST. Необходимо проверить устройства, занимающие IRQ 0-7/IRQ 8-15.
Invalid Media in Drive D:
- это означает, что жесткий диск еще не разбит на разделы.
I/O Card Parity Error at xxxxx
- ошибка по четности по адресу ххххх при проверке отображаемой памяти карты расширения.
K/B Interface Error
- ошибка связи с клавиатурой. Проверить подсоединение клавиатуры.
Keyboard Error
- ошибка клавиатуры. Проверить подключение клавиатуры и соответствие типа клавиатуры контроллеру. А также необходимо проверить "временные" установки в "BIOS Setup". Можно попытаться отключить тестирование клавиатуры при загрузке.
KEYBOARD ERROR OR NO KEYBOARD PRESENT
- ошибка клавиатуры или клавиатура отсутствует. Все действия аналогичны. Необходимо также удостовериться, что во время включения ПК не нажата какая-либо клавиша, а также проверить соответствие наличия клавиатуры и установок в "BIOS Setup": опция "Halt On", параметр "All, But Keyboard".
Keyboard failure, press [F1] to continue
- причиной такого сообщения могут быть неконтакт (обрыв) кабеля клавиатуры, заедание какой-либо наиболее часто используемой клавиши. Но прежде всего необходимо проверить установки опций "Typematic Rate" и "Typematic Delay", так как может иметь место несовместимость установок клавиатуры в "BIOS Setup".
Keyboard is locked ... Unlock it, Keyboard is locked out - Unlock the key
- необходимо разблокировать клавиатуру. Причиной такого сообщения может быть заедание какой-либо клавиши (или клавиш) или их случайное удержание во время теста.
Memory Address Error at XXXX
- ошибка в одном из модулей памяти с указанием конкретного адреса. Возможно требуется замена модуля.
Memory parity Error at XXXX
- ошибка контроля четности при тестировании адреса ХХХХ. Если память поддерживает контроль четности, то требуется ее замена.
MEMORY SIZE HAS CHANGED SINCE LAST BOOT
- изменился размер памяти со времени последней загрузки. В "BIOS Setup" ввести правильные данные об объемах используемой памяти.
Memory test fail
- BIOS сообщает, что при тестировании памяти имелись ошибки.
Memory Verify Error at XXXX
- ошибка при тестировании памяти, точнее при попытке записи по определенному адресу. Если ошибка повторяется, то потребуется замена памяти.
Missing Operation System
- это сообщение, как и некоторые другие, не связано с проведением процедуры POST. Вывод этого сообщения ("Отсутствует операционная система") говорит, в лучшем случае, об отсутствии или нарушении основных конфигурационных файлов системы, а также о возможных нарушениях таблицы разделов жесткого диска.
OFFENDING ADDRESS NOT FOUND, OFFENDING SEGMENT
- это сообщение выводится как конъюнкция (логическое "И") операций проверки "I/O CHANNEL CHECK" и "RAM PARITY ERROR", когда ни одно из устройств, вызвавших проблему, не может быть точно определено.
On Board Parity Error
- ошибка контроля четности. Ошибка может быть вызвана соответствующей периферией, занимающей адрес, указанный в сообщении об ошибке.
Override enabled - Defaults loaded
- если система не в состоянии загрузиться, используя текущую CMOS-конфигурацию, BIOS перезаписывает ее и устанавливает значения параметров по умолчанию.
PRESS A KEY TO REBOOT
- сообщение возникает при обнаружении ошибок и необходимости перезагрузки ПК. Нажать любую клавишу.
Press ESC to skip memory test
- предоставляется возможность пропустить полный тест памяти.
PRESS F1 TO DISABLE NMI, F2 TO REBOOT
- проблемы с немаскируемыми прерываниями. Возможно ошибка в работе контроллера прерываний. Речь идет об обработчике-заглушке немаскируемого прерывания (Non-maskable Interrupt). Это не один из этапов POST, а процедура, на которую указывает вектор немаскируемого прерывания. Если возник запрос NMI, и не удалось идентифицировать причину NMI, в Port80 выводится этот код, на экран выводится сообщение: "Press F1 to disable NMI, F2 to reboot". И ожидаются действия пользователя по блокированию возникшей проблемы или для перезагрузки.
Primary master hard disk fail, Primary slave hard disk fail
- POST определил ошибку в первичном "master"/"slave" IDE-жестком диске.
RAM PARITY ERROR - CHECKING FOR SEGMENT
- ошибка контроля четности памяти.
Secondary master hard disk fail, Secondary slave hard disk fail
- POST определил ошибку во вторичном "master"/"slave" IDE-жестком диске.
SYSTEM HALTED, (CTRL-ALT-DEL) TO REBOOT ...
- обозначает остановку процесса загрузки. Необходимо перезагрузить ПК с помощью одновременного нажатия трех указанных клавиш. Возможно ошибка исчезнет.

2. Chipset

Chipset Special Features
- (специальные возможности чипсета). Данный параметр разрешает/запрещает все новые функции, появившиеся в 430-х наборах Intel (HX, VX или TX) по сравнению с FX. Если установлено "Disabled", чипсет функционирует как 82430FX. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

Delayed Transaction
- (задержанная транзакция на PCI). Присутствие этого параметра в BIOS означает, что на материнской плате есть встроенный 32-битный буфер с задержанной записью для поддержки удлинненного цикла обмена на PCI-шине. Если этот параметр разрешен, то доступ к шине PCI разрешен во время доступа к 8-разрядным устройствам на шине ISA. Это существенно увеличивает производительность системы, так как цикл такого обращения на ISA-шине занимает 50-60 тактов шины PCI. Если компьютер укомплектован материнской платой, не поддерживающей спецификацию PCI 2.1, этот параметр следует запретить, поскольку данная опция включает режим совместимости со спецификацией PCI версии 2.1 с одновременным включением в "северном" мосте упомянутого выше специального буфера. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться также "PCI Delayed Transaction", "Delayed Transaction Optimization" или "Delayed Transaction Timer" с теми же значениями (включено/отключено).

Gate A20 Option
- (вариант включения линии A20). Параметр позволяет управлять способом включения адресной линии A20, которая отвечает за доступ к памяти, физические адреса которой превышают 1 Мбайт. Стоит напомнить, что 20-разрядная адресная шина позволяет адресоваться в пределах первого мегабайта памяти. Если быть более точным, то эта линия отвечает за доступ к первым 64 килобайтам верхней памяти, известным как область HMA (High Memory Area). Доступ к HMA требует управления специальным аппаратным узлом, работа которого может быть блокирована или активизирована. При установке опции "Gate A20 Option" в состояние "FAST" работа линии как раз и будет контролироваться специальным набором микросхем на системной плате. Если линия А20 деблокирована, то HMA-область доступна для любой программы, работающей в реальном режиме. Обычно эта область памяти отдается под MS-DOS, а для деблокирования линии используется драйвер HIMEM.SYS.
На старых машинах контролем A20 занимался контроллер клавиатуры, теперь это переложено на системную логику. Но есть категория пользователей, использующих старое программное обеспечение. Для таких и предназначена эта опция. Это означает, что наличие такой опции связано с совместимостью со старым ПО. Необходимо также отметить, что некоторые драйверы MS-DOS, например VDISK.SYS, могут блокировать линию А20, входя в конфликт с драйвером HIMEM.SYS. С другой стороны установка опции в "FAST" может значительно повысить производительность системы под "OS/2" и "Windows". Может принимать значения:
"Fast" - управление осуществляется чипсет, что повышает скорость работы,
"Normal" - управление осуществляется через контроллер клавиатуры.
В некоторых версиях BIOS опция может называться "Fast Gate A20 Option", а параметрами будут стандартные "Enabled"/ "Disabled". Иногда в старых версиях BIOS можно встретить опцию с почти романтическим названием "LOWA20# Select". А речь идет о том, какое устройство управляет низким уровнем сигнала на линии A20: чипсет или контроллер клавиатуры.

2.1. Специальные команды чипсета

 Drive NA before BRDY
- когда выбрано "Enabled", сигнал NA (читай ниже) устанавливается на один такт раньше последнего сигнала BRDY# в каждом цикле чтения/записи, таким образом вызывая генерацию процессором сигнала ADS# в следующем цикле после BRDY#, устраняя один потерянный цикл. С помощью сигнала BRDY# (Bus Ready) чипсет (точнее, т.н. "северный мост") сообщает процессору о том, что данные доступны для чтения или есть готовность для приема данных для их записи.

NA# Enable
- опция включения/отключения сигнала NA (Next Address). Установив "Enabled", мы включаем механизм конвейеризации, при которой чипсет сигнализирует центральному процессору о выдаче нового адреса памяти еще до того, как все данные, переданные в текущем цикле, будут обработаны. Естественно, что включение такого режима повышает производительность системы.
То же содержание заключено в опции под названием "NA# Pin Assertion".

Single ALE Enable
- (pазpешение одиночного сигнала ALE). Немножко информации. Пин B28 на шине ISA - это сигнал BALE (Bus Adress Latch Enable - разрешение защелкивания адреса). Это сигнал стробирования адресных разрядов. Может использоваться устройствами ввода/вывода для заблаговременной подготовки к предстоящему обмену информацией. Эта линия становится активной всякий pаз пpи появлении на шине адpеса. Стоит добавить, что этот сигнал использовался еще во времена 808x-х процессоров. Сигнал этот используется редко.
Устанавливая "Enabled", активизируем одиночный сигнал ALE вместо множественных сигналов-стробов во время ISA-циклов. В какой-то степени выбор параметра был привязан и к скорости системной шины, т.е. пропускной способности системы. Поэтому установка в "Enabled" могла привести к замедлению быстpодействия видеоканала. Эта функция всегда оставалась достаточно "темной" функцией "BIOS Setup". "Disabled" рекомендовано.
Опция может называться также "ALE During Bus Conversion" с возможными вариантами выбора: "Single" (одиночный) или "Multiple" (множественный). Естественно, что при потоковой работе ISA-шины (т.е. множественных циклов чтения/записи) предпочтительнее была бы установка опции в "Multiple". Но какой правильный выбор должен был сделать пользователь, всегда оставалось загадкой.
Некоторые чипсеты имели поддержку усовершенствованного режима, при котором выдача множественных сигналов ALE производилась во время одиночных циклов шины. Функция BIOS при этом называлась "Extended ALE", а параметрами служили "Disabled" и "Enabled".
В наиболее "древних" версиях BIOS весь смысл сказанного выше был заключен в опции под названием "Quick Mode".

3. CPU

 CPU-to-PCI 6 DW FIFO
- опция включения/отключения специального буфера, позволяющего устройствам обращаться к PCI-шине и считывать до 6-х двойных слов (Double Word). Работа с буфером построена по принципу "первым пришел - первым ушел" (First Input - First Output). Естественно, что буферизация передачи информации повышает быстродействие системы, но в таком виде эта опция встречается уже редко.

CPU-to-PCI IDE Posting
- включение данного режима позволяет оптимизировать циклы записи из CPU в интерфейс PCI IDE путем предварительной буферизации. Параметр рекомендуется устанавливать в состояние "Enabled". Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

CPU-to-PCI Read Buffer
- опция включения/отключения специального буфера, позволяющего устройствам обращаться к PCI-шине и считывать до 4-х двойных слов, не прерывая при этом работу процессора. Процессор может работать в это время над другой задачей, что повышает общую производительность. Эта опция должна быть включена обязательно. В отключенном же состоянии буфер не будет использоваться, и циклы чтения процессора не будут заканчиваться до тех пор, пока шина PCI не подаст сигнал о готовности получить данные.

CPU-to-PCI Write Buffer
- во включенном состоянии опции процессор сможет записывать по 4 слова за один такт в буфер записи шины PCI до завершения цикла PCI-шины. При установке параметра в "Disabled" процессор будет находиться в ожидании после каждого цикла записи и до тех пор, пока шина PCI не сообщит процессору о своей готовности к приему данных.
Опция может называться также просто "CPU to PCI Buffer". В этом случае речь идет уже об интегрированной функции с теми же параметрами: включен буфер/отключен буфер.

CPU-to-PCI Write Latency
- определение времени задержки перед операцией записи данных из процессора в шину (в тактах системной шины). Установка меньшего значения позволяет увеличить производительность, однако при этом возможно увеличение нестабильности работы системы. Тогда необходимо будет вернуться к большему значению. Возможный ряд значений: 1T, 2T, 3T.
Опция может называться также "Latency for CPU to PCI write".

4. Memory

4.1. ECC, Parity

 CPU Level 2 Cache ECC Check
- опция включения/отключения коррекции ошибок кэша второго уровня у процессоров архитектуры Pentium II и выше, которые поддерживают эту опцию. К примеру, процессоры Pentium II поддерживает коррекцию ошибок, начиная с частоты в 333 МГц. ECC-коррекция несомненно повышает надежность системы, но при этом ее работа, как правило, несколько замедляется. В некоторых процессорах допущены ошибки, и включение этого режима может привести к нестабильной работе системы. К тому же фактор надежности играет значительную роль только в сетевых средах. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Чуть другие названия этой же опции: "CPU Level 2 ECC checking" и "CPU L2 Cache ECC Checking".

Data Integrity (PAR/ECC)
- (целостность данных). Опция разрешения/запрещения контроля памяти на ошибки. Вид контроля устанавливается параметром "DRAM ECC/PARITY SELECT". Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

DRAM Data Integrity Mode
- опция включения/отключения проверки целостности памяти. Включение опции позволит системе отслеживать и корректировать однобитные ошибки. Так же будут обнаруживаться двухбитные ошибки, но без исправления. Использование режима коррекции ошибок обеспечивает увеличение стабильности и целостности данных в системе, правда, при небольшой потере производительности. Если в системе не используются ECC-модули памяти, то опция должна быть отключена. Может принимать значения:
"ECC" - разрешена коррекция,
"Non-ECC" - коррекция запрещена.
В некоторых случаях опция с тем же названием может иметь другой "набор" параметров: "Parity" и "ECC". При этом меняется и содержание функции.

DRAM ECC/PARITY Select
- опция выбора режима коррекции ошибок/проверки по четности. Эта опция появляется только в BIOS тех материнских плат, в которых чипсет поддерживает ECC, и может быть использована только в том случае, если установлены модули памяти с истинной четностью. В некоторых вариантах BIOS этим параметром может устанавливаться только вид проверки, а разрешение на проверку устанавливается параметром "Data Integrity (PAR/ECC)" или аналогичным. Параметр может принимать значения:
"Parity" (по умолчанию) - в случае возникновения ошибки на монитор выдается сообщение о сбое по четности в памяти и работа компьютера останавливается,
"ECC" - в случае возникновения одиночной ошибки она исправляется и работа системы продолжается. Если имеет место не одиночная ошибка, то работа компьютера также приостанавливается. Следует только учесть, что, по данным "Intel", скорость обмена с памятью при включении этого режима уменьшается приблизительно на 3%.

Memory Parity/ECC Check
- опция разрешения/запрещения проверки целостности данных. Может принимать значения: разрешен контроль памяти на ошибки ("Enabled"), запрещен ("Disabled") и "Auto". Последняя установка активизирует проверку памяти автоматически с автоматическим же определением возможностей модулей памяти, как по четности, так и по коррекции ошибок.

4.2. Shadow

 Extended ROM RAM Area
- наличие этой опции характерно для старых версий "AMI BIOS". Пользователю предоставляется выбор, где хранить данные о жестком диске: в верхнем килобайте системной памяти, начиная с 639-го килобайта, или в адресах нижней памяти в области системного BIOS (0:300). Необходимо помнить, что вторая адресная область может также использоваться звуковыми, сетевыми и т.п. картами расширения. В этом случае конфликтов можно избежать, если система через BIOS может использовать механизмы "затенения", которые впрочем могут отсутствовать в очень старых системах.
Опция может называться и "RAM Area".

Memory Hole At 15M-16M
- (буквально - "дырка" в памяти в диапазоне 15-16 МБ). При включенном состоянии параметра система, для повышения производительности, будет копировать более медленную память устройства, подключенного к ISA-шине, в более быструю основную память. Это происходит за счет выделения специальной области памяти и перемещения в нее данных ROM-памяти карты расширения или устройства сопряжения. Естественно, что действие этой функции представляет собой механизм "эатенения", который позволяет обращаться, в данном случае к устройствам ввода/вывода, как к адресному пространству ОЗУ и за счет этого увеличить скорость доступа к таким устройствам. Для функционирования этого механизма необходимо исключить для всех обычных программ возможность использования указанной области памяти, что и делает BIOS при разрешении этого параметра. При отсутствии ISA-устройств данная опция должна быть отключена. По умолчанию эта опция включена.
И еще одно уточнение. Разрешать этот параметр следует в том случае, если это требуется в документации на используемую в системе плату. Некоторые старые ISA-карты (например, ранние видеокарты высокого разрешения) требуют выделения для них специального адреса памяти, лежащего в некотором диапазоне. Кроме того, это выделение запрещает доступ в старшие адреса памяти, расположенные выше 16 МБ. Поэтому включение данной опции должно быть оправдано. По сути, данная функция сохранена в "BIOS SETUP" по причине фактора совместимости со старыми картами. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
В других версиях BIOS могут встретиться значения: "Disabled", "14M-16M", "15M-16M".
В более "старых" версиях BIOS могут встретиться другое наименование такой функции - "Memory Hole", и значения параметров: "None", "at 512 kB", "at 15 MB". Действие некоторых параметров уже понятно, а для значения "at 512 kB" стоит указать, что для "затенения" используется часть базовой памяти в пределах 512-639 КБ.
Опция может носить название "Local Memory 15-16M" или "Memory Hole at 15M Addr.".

PCI master accesses shadow RAM
- опция включения/выключения возможности копирования ПЗУ шины в более быструю оперативную память для повышения быстродействия системы. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

System BIOS Cacheable
- (кэширование области системного BIOS). Хотя в данной опции речь идет, на первый взгляд, о кэшировании, тем не менее ее нахождение в главе, посвященной функциям и механизмам "затенения", автор считает более оправданным. Разрешение этого параметра приводит к возможности кэширования области памяти по адресам системного BIOS (F0000H-FFFFFH) в кэш-память. Включение параметра будет иметь смысл только в случае разрешения функций кэширования в разделе "BIOS Features Setup" (как правило). Если какая-либо программа попытается выполнить операцию записи в эти адреса, то система выдаст сообщение об ошибке. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться и "System ROM Cacheable".
Но есть и свое "но"! При включении опции кэшированию подлежит часть системной BIOS, содержащей код для запуска системы и основные функции ввода/вывода. Тем не менее возможности ускорения через использование кэша процессора редко используются, т.к. часть кэш-памяти, которой всегда недостаточно, резервируется под BIOS, обращение к которому не происходит постоянно.

Video BIOS Cacheable
- (кэширование области BIOS видекарты). Разрешение этого параметра приводит к возможности кэширования области памяти по адресам BIOS видеокарты (C0000H-C7FFFH) в кэш-память процессора. Параметр будет использован только при включении кэш-памяти в разделе "BIOS Features Setup". Если какая-либо программа попытается выполнить запись в эти адреса, то система выдаст сообщение об ошибке. Пpи наличии видеокаpты с "ускоpителем" необходимо отключить кэширование видеопамяти, дабы центральный процессор мог "отслеживать" любые изменения, пpоизводимые устpойством ввода в буфеp кадpа изобpажения. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Об оправданности включения этой опции можно сказать то же самое, что и по системному BIOS. Опция может называться "Video BIOS Area Cacheable".

4.3. Cache

4.4. Refresh

 Возможны три различных метода регенерации данных.
Регенерация одним RAS (RAS Only Refresh - ROR). Этот метод использовался еще в первых микросхемах DRAM. Адрес регенерируемой строки передается на шину адреса и выдается сигнал RAS (точно так же, как при чтении или записи). При этом выбирается строка ячеек, и данные из них поступают на внутренние цепи микросхемы, после чего записываются обратно. Так как далее сигнал CAS не следует, цикл чтения/записи не начинается. Затем передается адрес следующей строки и так далее, пока не будет пройдена вся матрица памяти, после чего цикл регенерации повторяется. К недостаткам этого метода можно отнести то, что занимается шина адреса, и в момент регенерации блокируется доступ к другим подсистемам компьютера.
CAS перед RAS (CAS Before RAS - CBR) - стандартный метод регенерации. При нормальном цикле чтения/записи сигнал RAS всегда приходит первым, за ним следует CAS. Если же CAS приходит раньше RAS, то начинается специальный цикл регенерации - CBR. При этом адрес строки не передается, а микросхема использует свой внутренний счетчик, содержимое которого увеличивается на 1 при каждом CBR-цикле (т.н. инкрементирование адреса строки). Этот режим позволяет регенерировать память, не занимая шину адреса, что, безусловно, более экономично.
Автоматическая регенерация памяти (Self Refresh - SR, или саморегенерация). Этот метод обычно используется в режиме энергосбережения, когда система переходит в состояние "сна" ("suspend"), и тактовый генератор перестает работать. В таком состоянии обновление памяти по вышеописанным методам невозможно (попросту отсутствуют источники сигналов), и микросхема памяти выполняет регенерацию самостоятельно. В ней запускается свой собственный генератор, который тактирует внутренние цепи регенерации. Такая технология работы памяти была внедрена с появлением EDO DRAM. Необходимо отметить, что в режиме "сна" память потребляет очень малый ток.

Burst Refresh
- при разрешении этой установки чипсет проводит несколько регенераций за один такт. В обычном режиме одна строка регенерируется каждые 15 мкс, в пакетном 4 строки - каждые 60 мкс. Если BIOS позволяет, то рекомендуется конечно установить значение опции в "Enabled". Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться "DRAM Burst at 4 Refresh".

CAS Before RAS Refresh
- метод регенерации памяти, когда сигнал CAS устанавливается раньше сигнала RAS. В отличие от стандартного способа регенерации, этот метод не требует перебора адресов строк извне микросхем памяти - используется внутренний счетчик адресов. Однако, этот способ регенерации должен поддерживаться микросхемами памяти (большинство чипов его поддерживает).Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

CAS-to-RAS Refresh Delay
- действие этой опции возможно при включенном состоянии предыдущей (или аналогичной), так как в данном случае устанавливается время задержки между стробирующими сигналами (в тактах системной шины). Естественно, что установка меньшего значения приводит к снижению времени, затрачиваемого на регенерацию. Большее же значение повышает надежность, т.е. достоверность данных, находящихся в памяти. Оптимальный вариант для данной системы выбирается опытным путем. Может принимать значения: "1T", "2T" (по умолчанию).

Concurrent Refresh
- (паpаллельная pегенеpация). При активизации этой опции как чипсет (т.е. оборудование, требующее регенерации), так и процессор получают одновpеменный доступ к памяти. При этом процессору не нужно будет ожидать, пока произойдет регенерация. При установке опции в "Disabled" пpоцессоp должен будет ждать, пока схема pегенеpации не закончит pаботу.

DRAM RAS Only Refresh
- включение/отключение метода обновления DRAM, альтернативного методу "CAS-before-RAS". Если BIOS содержит другие возможности по регенерации памяти, то эту опцию необходимо отключить. В противном случае придется использовать этот устаревший метод обновления памяти.

DRAM RAS# Precharge Time
- (время предварительного заряда по RAS). Эта функция позволяет установить время (в тактах системной шины) для формирования сигнала RAS (иногда говорят о накоплении заряда по RAS) до начала цикла регенерации памяти. Уменьшение этого значения увеличивает быстродействие. Но если установлено недостаточное время, регенерация может быть некомплектной, что в итоге приведет к потере данных, находящихся в памяти. Возможные значения могут быть представлены в различном виде: в виде цифровых значений - "3", "4" и т.д.; с указанием системных тактов - "3 Clocks" или "1T". А ряд значений, как правило, следующий: 0T, 1T, 2T, 3T, 4T, 5T, 6T.
Опция может иметь множество названий: "DRAM RAS# Precharge Period", "RAS# Precharge Time", "RAS# Precharge Period", "FPM DRAM RAS# Precharge", "FPM RAS Precharge", "RAS# Precharge", "EDO RAS Precharge", "EDO RAS# Precharge Time", "EDO RAS Precharge Timing", "FPM/EDO RAS# Precharge Time".
Как видим, опция не потеряла своей актуальности с появлением EDO-памяти и, что интересно, затем также BEDO- и SDRAM- модулей: "BEDO RAS Precharge", "SDRAM RAS# Precharge", "SDRAM RAS Precharge Time".
Правда, кроме привычных параметров типа "3T" или "2 Clks" в различных версиях BIOS стали "встречаться" новые виды значений, например, "Same as FPM" и "FPM-1T", "Fast" и "Normal", "Fast" и "Slow". Для последней пары параметров "Slow" (медленно) равносильно увеличению количества тактов, что повышает стабильность работы системы, поэтому значение "Fast" следует устанавливать в случае уверенности в качестве модулей памяти.

DRAM Refresh Method
- опция установки метода регенерации. Опция может называться также "Refresh Type", "DRAM Refresh Type" или "Refresh Type Select". При любых вариантах опции среди возможных параметров, как правило, используется только два параметра. Приводим весь возможный ряд: "CAS before RAS", "RAS only", "RAS# Before CAS#", "Normal", "Hidden".

DRAM Refresh Period
- установка периода (частоты повтора), требуемого для регенерации памяти, в соответствии со спецификацией модулей памяти. В новейших версиях BIOS такая опция практически не встречается. Ранее же она предлагала пользователю широкий простор для творчества: в зависимости от версии BIOS и его производителя, чипсета, модулей памяти. Опция могла также носить название "Refresh Cycle Time (us)", "DRAM Refresh Cycle Time", "Memory Refresh Rate" или "DRAM Refresh Rate". Вот неполный перечень таких вариаций:
"For 50 MHz Bus", "For 60 MHz Bus", "For 66 MHz Bus" и даже "Disabled",
"50/66 MHz", "60/60 MHz", "66/66 MHz",
"Disabled", "15.6 us", "31.2 us", "62.4 us", "124.8 us", "249.6 us",
"15.6 us", "31.2 us", "62.4 us", "125 us", "250 us",
"15.6 us", "62.4 us", "124.8 us", "187.2 us",
"1040 Clocks", "1300 Clocks",
"Disabled", "Normal",
"Fast", "Slow".
Остается отметить, что чем реже производится регенерация памяти, тем эффективнее работает система. Но если явно наблюдаются нарушения в работе системы, то частоту обновления необходимо повысить.

Extended Refresh
- (расширенная регенерация). Введение (в свое время) этой опции в BIOS предполагало использование специальных EDO-чипов. Регенерация содержимого ячеек EDO DRAM при этом стала производиться через 125 мкс, а не через каждые 15,6 мкс, как при стандартной регенерации. Это несколько повысило общее быстродействие памяти.

Hidden Refresh
- (скpытая pегенеpация). Когда установлено значение "Disabled", память регенерируется по IBM AT методологии, используя циклы процессора для каждой регенерации. Когда "Hidden Refresh" установлен в "Enabled", контроллер "ищет" наиболее удобный момент для регенерации, независимо от циклов CPU. При этом регенерация происходит одновременно с обычным обращением к памяти. Алгоритм регенерации памяти при этом многовариантен: разpешаются циклы pегенеpации в банках памяти, не используемых центральным процессором в данный момент, взамен или вместе с ноpмальными циклами регенерации, выполняемыми всякий pаз пpи опpеделенном пpеpывании (DRQ0 - каждые 15 мс), вызванном таймеpом.
Для регенерации каждый pаз тpебуется от 2 до 4 мс. В течение этих 4 мс один цикл pегенеpации пpимеpно каждые 16 мкс pегенеpиpует по 256 стpок памяти. Каждый цикл pегенеpации занимает столько же или чуть меньше вpемени, чем один цикл чтения памяти, т.к. сигнал CAS для pегенеpации при этом не тpебуется.
"Hidden refresh" отличается максимальной скоростью и эффективностью, наименьшими нарушениями активности системы и наименьшими потерями производительности, также позволяя поддерживать состояние памяти во время нахождения системы в режиме "suspend". Этот режим более быстрый, чем "Burst Refresh". Но наличие в BIOS этой функции еще не означает ее реализации. После установки опции в "Enabled" стоит тщательно проверить работоспособность компьютера. Некотоpые модули памяти позволяют использовать "Hidden Refresh", некотоpые - нет. В большинстве случаев pекомендуется установить в "Enabled".

Hi-Speed Refresh
- с помощью этой опции чипсет быстрее проведет регенерацию основной памяти. Правда, эффект от этой установки значительно меньше, чем от включения "Slow Refresh". Последний режим регенерации предпочтительнее. К тому же эта функция поддерживается не всеми чипами памяти.

Ref/Act Command Delay
- установка режима работы памяти. Параметром выбирается время задержки между окончанием режима регенерации и началом командного режима. Может принимать значения: "5T", "6T" (по умолчанию), "7T", "8T".

Refresh During PCI Cycles
- опция, разрешающая/запрещающая проведение регенерации памяти во время циклов чтения/записи на шине PCI. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

Refresh RAS# Assertion
- (установка периода активности сигнала RAS). Этим параметром устанавливается длительность сигнала RAS (в тактах системной шины) для цикла регенерации. Принимаемые значения определяются качеством памяти и чипсетом. Меньшее значение увеличивает производительность системы. Может принимать значения:
"4T" (или "4 Clks"),
"5T" (или "5 Clks").
Опция может называться также "Refresh Assertion" или "Refresh RAS Active Time".

Slow Refresh (1:4)
- (медленная pегенеpация). При включении этой опции схема регенерации будет в 4 раза реже регенерировать память (64 мкс против 16), чем в обычном pежиме. При такой установке пpоизводительность системы повышается благодаpя уменьшению конкуpенции между CPU и схемой pегенеpации, однако не все типы динамических ОЗУ могут поддеpживать такие циклы (в этом случае будет получено сообщение об ошибке четности и о сбое системы). Тогда необходимо установить значение "Disabled". Опция в свое время получила распространение с развитием такого типа ПК, как "laptop" (дорожный ПК), в качестве энергосберегающей функции. В современных системах эта опция встречается все реже.
Опция может называться также "DRAM Slow Refresh", "Slow Refresh", "Slow Memory Refresh Divider" или "Slow Refresh Enable".

4.5. DRAM, ...

Auto Configuration
- опция автоматического конфигурирования параметров доступа к основной памяти. Опция обычно находится в разделах "Advanced Chipset Setup" или "Chipset Features Setup" и позволяет настроить время доступа к модулям памяти в автоматическом режиме либо в "ручном" режиме и в соответствии со спецификациями применяемых модулей памяти. Чтобы выйти на режим пользовательской настройки, достаточно установить параметр в "Disabled". Значение "Auto" (автоматическая конфигурация) устанавливается по умолчанию. Среди возможных фиксированных значений обычно встречаются значения "60 ns" и "70 ns" для модулей памяти с соответствующим быстродействием в наносекундах.
Опция может называться также "DRAM Auto Configuration" или "Auto Configure EDO DRAM Tim" ("tim" - это timing). В последней опции параметр "Enabled" заменил "Auto", в остальном отличий нет.
Значительно большие различия оказываются в том случае, когда под опцией "Auto Configuration" "скрывается" настройка параметров доброй половины соответствующего раздела "BIOS Setup". Тогда автоматически конфигурируются параметры кэш-памяти, основной памяти, регенерации и даже скорость ISA-шины. Практически все они будут нами изучены.

CAS# Latency
- (задержка CAS - CL). Важнейшая характеристика чипа памяти, определяющая минимальное количество циклов тактового сигнала от момента запроса данных сигналом CAS (фактически - команда чтения) до их появления и устойчивого считывания с выводов модуля памяти. Возможные значения параметров: 2, 3 или в тактах - 2T, 3T (3 Clks). Значение в 3 такта устанавливается по умолчанию. Уменьшение параметра нужно осуществлять крайне осторожно.
Другое название опции - "CAS# Latency Clocks".
Столь важная характеристика памяти сохранила свою "важность" и с внедрением памяти типа SDRAM, а опция стала называться "SDRAM CAS# Latency" (или реже "SDRAM CAS Latency Time").
Отметим, что меньшее значение увеличивает производительность системы (установка в 2 такта в сравнении с 3-мя ускоряет систему на 1-2%). Рекомендуется устанавливать меньшее значение для SDRAM с быстродействием 10 нс или лучше.

CPU to DRAM Page Mode
- когда опция установлена в "Disabled", контроллер памяти закрывает страницу памяти после доступа к ней. Когда опция включена (по умолчанию), страница памяти остается открытой на случай повторного обращения к ней. Такой режим работы памяти более производителен.
Этот же смысл характерен для множества функций с подобными наименованиями: "DRAM Page Mode", "DRAM Paging", "DRAM Paging Mode", "SDRAM Page Control".
Так же широк и выбор возможных значений параметров. В различных версиях BIOS можно даже найти опции с одинаковыми названиями, но различными значениями параметров. Например, "CPU to DRAM Page Mode" может предоставить для выбора значения "Use Paging" и "No Paging". Возможны и следующие вариации:
"Always Open" и "Closes",
"Page Closes", "Stays Open" и "Closes If Idle",
"Normal" и "Disabled".
В некоторых случаях усовершенствованный (enhanced) механизм работы чипсета и контроллера памяти позволяет с помощью дополнительной информации об открытой странице памяти сохранять ее некоторое время открытой даже при отключенной опции: "DRAM Enhanced Paging", "Enhanced Page Mode", "Enhanced Paging".

DRAM Page Idle Timer
- (таймер пассивного состояния страницы памяти). С помощью этой функции устанавливается время (в системных тактах), в течение которого контроллер DRAM, после перехода процессора в режим ожидания, ждет закрытия всех открытых страниц памяти. Параметр сохранил свою актуальность со времен FPM. Для увеличения быстродействия устанавливается минимальное значение данного параметра, однако при этом возможна нестабильная работа системы. Оптимальный вариант устанавливается опытным путем. Опция может называться "Paging Delay", "DRAM Idle Timer", а возможные значения выбираются из ряда: 1T, 2T, 4T, 8T. Правда, иногда такой ряд может иметь следующий вид: 0, 2, 4, 8, 10, 12, 16, 32.

SDRAM Configuration
- (конфигурация SDRAM-памяти). Установкой параметров опции определяется, должен ли BIOS определять временные характеристики доступа к памяти на основании информации из SPD-модуля ("By SPD") или же пользователь проведет конфигурирование доступа самостоятельно (через установку "Disabled"). Нетрудно увидеть схожесть данной опции с "Auto Configuration". В качестве фиксированных значений могут быть предложены параметры: "7 ns (143 Mhz)" и "8 ns (125 Mhz)" как для памяти с временем доступа 7 нс/8 нс и соответственно частотой шины 143 МГц/125 МГц.

4.5.1. Video, ...

 Из "карты" памяти первого мегабайта системного ОЗУ, что жестко "привязано" к архитектуре IBM PC-совместимых компьютеров, хорошо известно, что адресная область A0000-C7FFF традиционно принадлежит видеопамяти графического адаптера и видео BIOS системы. Собственно под видео BIOS (или, как иногда говорят, ПЗУ видеоадаптера) выделяется 32 кБ памяти в области C0000- C7FFF. Это 768-й - 799-й килобайты памяти. Эта адресная область, в зависимости от установок "BIOS Setup", может и не использоваться.
Для справки! Frame Buffer (буфер кадра) - область памяти видеосистемы, в которой временно хранятся данные, необходимые для отображения одного кадра (в простейшем случае).
Область в 128 кБ (A0000-BFFFF, или 640-й - 767-й килобайты) отведена под видеопамять графической карты расширения. В "древние" времена этого объема хватило бы на размещение в памяти одного графического кадра, пусть и с разрешением 320х200. По аналогии с 64-мя килобайтами верхней памяти область видеопамяти в 128 кБ стала тем "окошком" (или фрэйм-буфером), через которое стал возможным доступ ко всей адресуемой памяти. В свое время использование фрэйм-буферизации активно использовалось такими играми, как "DOOM". Нижеизложенные функции BIOS как раз и затрагивают механизмы работы с видеопамятью.

VGA 128k Range Attribute
- во включенном состоянии ("Enabled") к адресам VGA-памяти (A0000H-BFFFFH) чипсетом могут быть применены свойства, подобные функциям "CPU-TO-PCI Byte Merge" или "CPU-TO-PCI Prefetch", т.е. стандартным режимам буферизации записи от CPU в PCI- интерфейс. Это повышает быстродействие системы, в противном случае используется стандартный VGA-интерфейс.
Этот же смысл характерен для множества функций с непохожими наименованиями: "VGA Performance Mode", "Turbo VGA (0 WS at A/B)", "VGA Frame Buffer", хотя в некоторых случаях "оперативный" диапазон сужается до первых 64 кБ (A0000-B0000).

Дополнительная информация о видеофункциях содержится в опциях:
PCI - "Snoop Ahead".

5. PCI

5.1. Арбитраж, Bus-Master

 Bus Master (хозяин шины, задатчик) - возможный режим работы устройства на любой шине, в том числе и на PCI. Для работы в таком режиме устройство выдает запрос арбитру шины, сообщая о своем требовании на получение управления шиной. Арбитр, в соответствии с приоритетом и/или очередностью арбитража на данной шине, через определенное время после запроса отдает запрашивающему устройству управление шиной. Выполнив все необходимые ему операции, устройство сообщает арбитру об освобождении им шины.
На современных шинах, таких как PCI, для получения доступа к шине ВСЕ устройства проходят процедуру арбитража, в том числе и центральный процессор. Возможность быть "master"-устройством реализуется аппаратно при разработке устройства. Реализация механизма "BusMaster" позволяет общаться между собой только тем компонентам компьютера, которым это в данный момент необходимо. Этот механизм используется, например, для передачи данных TV-тюнером на видеокарту, если они обе находятся на PCI-шине, причем без участия центрального процессора, системной памяти и т.п.
Обычно, система управляет доступом к PCI-шине по фундаментальному принципу - "First-Come-First-Served" (первым пришел, первым обслуживается). Но возможности арбитража значительно шире и сложнее. Существуют и различные режимы действия самого механизма арбитража. Может быть установлен т.н. режим ротации устройств, при котором периодично меняется очередность устройств, т.е. их приоритет. Приоритет может оказаться фиксированным, т.е. какое-либо системное устройство "навсегда" получает наивысший приоритет. При "вращении приоритетов" (rotated) устройству, получившему контроль над шиной, присваивается самый низкий приоритет и любое другое устройство перемещается на шаг вверх в "очереди" приоритетов.
Как же все это реализуется? В состав чипсета входит 8-разрядный ARBITRATION CONTROL REGISTER, позволяющий реализовать свойства, связанные с арбитражем на PCI-шине, а также (у достаточно новых чипсетов) с поддержкой спецификации шины PCI 2.1. (см. ниже)

В современных системах механизмы арбитража, можно сказать, интеллектуализированы, что в итоге привело к изъятию из "BIOS Setup" функций, связанных с пользовательскими установками по арбитражу. "Старые" же версии BIOS вполне могут содержать некоторые из приведенных ниже опций, могущих вызвать душевный трепет у пользователя.

PCI Bus Arbitration
Параметр может принимать значения:
"Rotating",
"Fixed".
Опция с абсолютно таким же названием встретилась и с параметрами: "Favor CPU" и "Favor PCI". Пользователю остается определить своего фаворита. Если речь идет о потоковом видео, то желательно указать PCI-устройство. Выбор центрального процессора во многих случаях может оказаться более безопасным.
С абсолютно такими же возможностями отбора: CPU или PCI, может встретиться и функция "Arbitration Priority".
В свою очередь, функция с таким же названием может предложить более "изощренный" вариант: "PCI First" и "ISA/DMA First". Здесь возможности выбора зависят от применяемых устройств. "Master"-устройство может находиться и на ISA-шине и желать того же самого, а именно передачи данных напрямую по DMA-каналам.
Аналогичные варианты выбора предлагает и функция "DMA/ISA Master Before PCI". В данном случае значение "Disabled" равносильно "PCI First".
Рассмотренные выше варианты выбора параметров могут быть предложены и в функциях "PCI Arbiter Mode", "PCI Arbitration Mode", "PCI Arbit. Rotate Priority".
При этом, правда, могут возникнуть и другие сложности. Например, если для выбора предлагаются параметры: "Mode1" и "Mode2"? Поскольку идея арбитража заключается и в минимизации времени, требуемого для получения устройством контроля над шиной и передачи данных, то возникает вопрос, в каком из вариантов устройство, например, на той же PCI-шине быстрее получит доступ к ней. В случае "Favor PCI" или с выбором "Favor CPU"? Естественно, что первый вариант более оптимален. В данном случае этому значению соответствует "Mode1", устанавливаемый по умолчанию. При возникновении каких-либо проблем в системе необходимо выбрать режим "Mode2", как более безопасный.

CPU Priority
- после вышеизложенного содержание этой опции может быть уже и не покажется странным. Пользователь должен установить, по сути, ранг центрального процессора в иерархии всех возможных "master"-устройств в системе. Если для остальных устройств, допустим, может выдерживаться "режим ротации", то для CPU его место всегда окажется фиксированным. Это место можно выбрать из ряда: "Always Last", "CPU 2nd", "CPU 3rd", "CPU 4th".
Опция с тем же названием была встречена и с обычными "Disabled" и "Enabled". Можно предположить, что "Disabled" запрещает ротацию приоритета для CPU, а "Enabled" ее разрешает.
Ну и наконец, опция "PCI Masters' Priority" предлагает на выбор: "Rotating" и "Fixed".

Bus Mastering
- эта опция предназначалась еще не так давно для разрешения или запрещения работы устройств в режиме "Bus-Master" на шине ISA. Параметр может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.

Enable Master
- установка в "Enabled" позволяет системе придать выбранному устройству статус "master"-устройства на PCI-шине, а также проверить, способно ли это устройство контролировать шину.
Master Retry Timer
- этой опцией устанавливается, как долго центральный процессор, будучи задатчиком PCI-циклов, сможет сохранить свое лидерство. Возможные параметры измеряются в циклах PCI-шины (PCICLKs). Вот этот ряд: 10 (по умолчанию), 18, 34 или 66 PCICLKs.

PCI Bus Parking
- опция включения/выключения режима "парковки" устройств на PCI-шине. Режим "парковки" - одна из разновидностей режима "Bus- Master". Когда этот режим включен ("Enabled"), "запаркованные" на PCI-шине устройства будут иметь полный контроль над шиной в течение некоторого небольшого промежутка времени. Это повышает производительность данного устройства, однако приостанавливает работу остальных. Данный режим неплохо работает с контроллерами жестких дисков.

PCI Master 0 WS Write
- если опция установлена в "Enabled", в системе устанавливается нулевое время ожидания в циклах записи от "master"-устройств на PCI-шине в системную память. Значение "Disabled" устанавливается по умолчанию.

Preempt PCI Master Option
- когда опция включена ("Enabled"), операции чтения/записи на PCI-шине, даже в том случае, когда шиной владеет "master"- устройство, могут быть прерваны некоторыми системными операциями, например, такими, как регенерация памяти. В противном случае может вестись "незапланированная" параллельная работа различных системных компонент, что может привести к сбоям системы, в лучшем случае - к потере информации.

Stop CPU at PCI Master
- когда опция включена ("Enabled"), работа центрального процессора может быть приостановлена в момент инициирования PCI- устройством захвата шины. Установка в "Disabled" (по умолчанию) не позволяет прерывать работу CPU как задатчика шины. Для прерывания тогда может потребоваться использование дополнительных функций "BIOS Setup".

Дополнительную информацию о работе "master"-устройств см. ниже.

5.2. Все о PCI-шине

 Passive Release
- (пассивное разделение). Эта опция появилась в свое время в "BIOS Setup" одновременно со способностью арбитра чипсетов Intel Triton VX/HX отбирать шину у "master"-устройств при отсутствии в течение какого-то времени запросов на передачу с их стороны. Эта опция включает/выключает механизм параллельной работы шин ISA и PCI. Если этот параметр разрешен ("Enabled"), то доступ процессора к шине PCI позволен во время "пассивного разделения" или, как говорят иногда, ее "освобождения". Проще говоря, включение данного режима позволяет шине PCI продолжать работу даже тогда, когда происходит передача данных от ISA- устройств, которые в обычном режиме могут тормозить работу более скоростной PCI-шины. Арбитр чипсета как бы выравнивает работу двух шин с учетом задержек ISA-шины. Необходимость же запрещения данного параметра может возникнуть при использовании плат ISA, активно использующих каналы DMA (звуковые карты, устройства "Arwid"). Запрещение также уместно при отсутствии ISA-карт в системе.
Опция может называться "PCI Passive Release".

PCI 2.1 Support
- (поддержка спецификации шины PCI 2.1). При разрешении этого параметра поддерживаются возможности спецификации 2.1 шины PCI. Спецификация 2.1 имеет два основных отличия от спецификации 2.0: максимальная тактовая частота шины увеличена до 66 МГц и вводится механизм моста PCI-PCI, позволяющий снять ограничение спецификации 2.0, согласно которой допускается установка не более 4-х устройств на шине. Запрещение этого параметра имеет смысл только при возникновении проблем после установки дополнительной PCI-платы (как правило, проблемы могут возникнуть только с достаточно старыми PCI-устройствами). Параметр может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться "PCI 2.1 Compliance".

PCI Clock Frequency
- опция для установки частоты шины PCI. В приведенном виде такая опция была внедрена на первых "пентиумных" машинах, а затем перенесена на 486-е системы с процессорами AMD и PCI-шиной. Частота шины через множитель "привязывалась" к частоте центрального процессора и имела следующий ряд значений: "CPUCLK/1.5" (по умолчанию), "CPUCLK/2", "CPUCLK/3" и фиксированные "14 Mhz".

PCI Dynamic Decoding
- установка в "Enabled" позволяет системе запоминать PCI-команду, которая только что была запрошена. Если последующие команды совпадают с некоторой адресной областью, циклы записи будут автоматически интерпретироваться как PCI-команды.

PCI Latency Timer
- (таймер времени ожидания для шины PCI). Значение этой опции указывает, в течение какого времени (в системных тактах) поддерживающая режим "Busmaster" PCI-карта может сохранять контроль над PCI-шиной, если к шине обращается другая PCI-карта. Фактически это и есть таймер, ограничивающий время занятия PCI-шины устройством-задатчиком шины. По истечении заданного времени арбитр шины принудительно отбирает шину у задатчика, передавая ее другому устройству. Допустимый диапазон изменения этого параметра - от 16 до 128 с шагом, кратным 8.
Значение параметра необходимо изменять осторожно, так как оно зависит от конкретной реализации материнской платы, и только в случае, если в системе установлены по меньшей мере две PCI-карты, поддерживающие режим "Busmaster", например, SCSI- и сетевая карты. Графические карты не поддерживают режим "Busmaster". Чем меньше устанавливаемое значение, тем быстрее другая PCI-карта, требующая доступа, получит доступ к шине. Если требуется выделить для работы, например, SCSI-карты больше времени, то можно увеличить значение для PCI-слота, в котором она находится. Значение для сетевой карты, например, соответственно необходимо уменьшить или вообще установить равным 0, хотя в некоторых случаях установка 0 не рекомендуется. В общем случае, какое значение параметра пригодно и оптимально для данной системы, зависит от применяемых PCI-карт и проверяется с помощью тестовых программ. Необходимо также учитывать, в какой степени "карты-конкуренты" чувствительны к возможным задержкам.
Опция также может носить названия: "PCI Bus Time-out", "PCI Master Latency", "Latency Timer", "PCI Clocks", "PCI Initial Latency Timer". Для последней опции ряд возможных значений имел вид: "Disabled", "16 Clocks", "24 Clocks", "32 Clocks".
Правда, это еще не весь возможный перечень. Функции "Latency Timer Value" и "Default Latency Timer Value" применяются совместно. Если в последней опции установить "Yes" (оно же и по умолчанию), то тогда первая функция будет проигнорирована.
И еще одно очень важное замечание. В свое время эта опция (и ей подобные) вводились с учетом совместного существования PCI- и ISA-шин. ISA-шина позволяла использовать одно "master"-устройство. Это применялось редко как раньше, так и теперь. Зато PCI-шина дала возможность одновременного использования нескольких "master"-устройств. Учитывая различия в скорости шин, а тем более в их пропускной способности, необходимо было решить проблему совместной работы "master"-устройств на PCI-шине и стандартных устройств на более медленной ISA-шине. Особенно это касалось распространенных в то время звуковых и сетевых карт для ISA-шины, обладавших незначительным объемом буферной памяти, т.е. чувствительных к любым задержкам при передаче данных. "AMI BIOS" позволял выбрать значение параметра в диапазоне от 0 до 255 с единичным шагом. Значение "66" устанавливалось по умолчанию, хотя меньшее значение владения шиной PCI-устройством оказывалось более предпочтительным.
Поэтому при конкретном решении стоящей перед пользователем задачи (или проблемы) надо исходить прежде всего из возможностей чипсета, версии BIOS и используемых карт расширения.

PCI Preempt Timer
- (таймер времени вытеснения для шины PCI). На первый взгляд по смыслу эта функция аналогична функции "PCI Latency Timer", возможна даже некоторая путаница, хотя в данном случае кое-что наоборот. Значение этой опции указывает, в течение какого времени (в тактах PCI-шины, или локальных тактах - LCLKs) поддерживающая режим "Busmaster" PCI-карта сможет не контролировать шину, а находиться в состоянии ожидания пока этой шиной владеет другая карта. Арбитр шины отслеживает указанный временной интервал с момента подачи запроса, после чего ожидающее "master"-устройство вытесняет своего товарища.
Для выбора предагаются значения из ряда: 5, 12, 20, 36, 68, 132, 260, в цифровом виде или с отображением единицы измерения - "5 LCLKs" и т.д. Обязательным является параметр "No Preemption" (или "Disabled"). Причем последний, как правило, устанавливается по умолчанию. Эта опция в таком виде уже не применяется, так что встреча с ней на старых машинах может вызвать некоторые трудности. Во всяком случае при наличии хотя бы двух "master"-устройств на PCI-шине значение "Disabled" (или аналогичное) должно быть заменено на более оптимальное.
Опция может называться и "PCI Preemption Timer".

PCI to ISA Write Buffer
- во включенном состоянии ("Enabled") система, не прерывая работы процессора, будет временно записывать данные в специальный буфер для последующей передачи данных в наиболее подходящий момент. В противном случае ("Disabled") цикл записи в шину PCI будет направляться далее напрямую в более медленную ISA шину. Необходимость в такой функции, а точнее в таком буфере, связана с тем, что скорости работы ISA- и PCI-шин различны. Включение буферной памяти позволит PCI-шине не ожидать, пока ISA-шина примет все данные.

Peer Concurrency
- (параллельная работа или, дословно, - равноправная конкуренция). Этот параметр разрешает/запрещает одновременную работу нескольких устройств на PCI-шине. При включении опции включается дополнительное буферирование циклов чтения/записи в чипсете. Но могут возникнуть проблемы, если не все PCI-карты готовы поддерживать такой режим работы. В этом случае работоспособность системы проверяется опытным путем.
Действие этой опции затрагивает и совместную работу PCI- и ISA-шин. Например, шинные PCI-циклы могут перераспределяться и буферизироваться во время ISA-операций, таких как передача по DMA-каналам в режиме "Bus-Master". Параметр может принимать значения:
"Enabled" (по умолчанию) - разрешено,
"Disabled" - запрещено.
Опция может называться и "PCI Concurrency" или "Bus Concurrency". Дополнительные устройства, "жаждущие конкуренции", появляются в опциях "PCI/IDE Concurrency" или "PCI-to-IDE Concurrency".

Snoop Ahead
- (предвидение). Эта опция применима, если в системе включено кэширование. Когда опция установлена в "Enabled", "master"- устройства на PCI-шине могут контролировать регистры VGA-палитры для непосредственных циклов записи и преобразования их в потоковый протокол PCI-формата с целью повышения скоростных характеристик обмена данными между PCI-шиной и памятью. В итоге значительно увеличивается производительность системы в процессе передачи видеоданных. є

6. ISA

16 Bit ISA I/O Command WS
- данная опция используется для компенсации возможной разницы между скоростью работы системных устройств ПК и его периферии. Подобная компенсация необходима, например, если в системе не выделено дополнительное время ожидания/ответа устройства. В таком случае система может решить, что какое-либо неуспевающее ответить устройство вообще не функционирует и перестанет давать запросы на ввод/вывод из этого устройства. Данную опцию необходимо отключать ("Disabled") для повышения быстродействия только в случае, когда все устройства в таком режиме нормально функционируют, в противном случае возможна потеря данных. Естественно отключение опции при отсутствии в системе ISA-карт расширения.
Опция может называться "ISA 16-bit I/O Wait States". При этом появляется возможность установить количество тактов ожидания вручную: 0, 1, 2, 3.

16 Bit ISA Mem Command WS
- данная опция по назначению аналогична предыдущей, с той лишь разницей, что она позволяет нужным образом соотнести скорость работы памяти ISA-устройства с возможностью системы записывать/читать из этой памяти. Параметр может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может называться "ISA 16-bit Mem Wait States". При этом появляется возможность установить количество тактов ожидания вручную: 0, 1, 2, 3.

ISA Bus Clock
- опция установки тактовой частоты ISA-шины. Стандартное значение скорости ISA-шины составляет около 8,33 МГц. В отличие от устаревших систем, ныне скорость ISA-шины напрямую связана со скоростью PCI-шины через т.н. "южный" мост. Можно установить более высокую скорость шины, выбрав соответствующий параметр (делитель). Этот параметр делит действительную скорость PCI-шины и тем самым задает скорость ISA-шины.
Например, тактовая частота PCI-шины составляет 33 МГц. Если изменить делитель с PCICLK/4 на PCICLK/3, то ISA-шина будет работать с частотой 11 МГц. Но необходимо помнить, что повышение тактовой частоты может привести к перегреву элементов ISA-карты и выходу ее из строя. В лучшем случае может возрасти риск ошибок при работе, особенно это опасно для контроллеров дисков (в случае устаревших систем). И хотя многие ISA-устройства работают на более высоких скоростях, необходимо снизить скорость шины, если какое-либо ISA-устройство функционирует неверно.
Из вышесказанного следует, что для правильной установки тактовой частоты ISA-шины необходимо знать тактовую частоту PCI-шины. В данном случае речь идет о том, что в первых системах с использованием PCI-шины частота самой PCI-шины зависила от системной тактовой частоты и поэтому имела ряд значений: 25, 30 и 33 МГц, т.п. В более "старых" системах частота ISA-шины была "привязана" к системной частоте, которая колебалась от 16 до 50 МГц, тем самым давая простор и для ISA-шины
Опция в разное время носила и разные названия: "ISA Clock", "ISA Clock Frequency", "ISA Bus Clock Frequency", "ISA Bus Clock Option", "ISA Bus Speed", "ISA Clock Select", "ISA Clock Divisor", "AT BUS Clock", "AT Bus Clock Frequency", "AT BUS Clock Selection". Наличие в названиях опций сочетания "AT Bus" свидетельствует о "старости" опций. Стоит напомнить, что 8.33 МГц - это "стаpая" тактовая частота шины IBM AT.
Ну и, наконец, ряд возможных параметров для выбора: PCI (или PCICLK, или CLK {для системной шины}) / 2,3,4,5,6,8,10, и даже 12, а также фиксированное значение - "7.159 MHz" (оно может устанавливаться и по умолчанию). Опять необходимо дополнительно отметить, что некотоpые системные интерфейсные ISA-платы разрабатывались для такой фиксированной частоты.
Несколько другое содержание заключено в опции "ISA Clock Select Enable". Установив опцию в "Disabled", мы получаем стандартную частоту ISA-шины (PCI/4), выбрав же "Enabled", получаем возможность поварьировать частотой шины вручную.

7. Peripherals & Resources

Функции "подключенности" периферийных устройств

AGP
- смысл этой опции интуитивно понятен, а возможных параметров всего два: "Enabled" (разрешено) и "Disabled" (запрещено).

Init AGP Display First
- при установке в "Enabled" первичным в системе становится дисплей, подключенный к AGP-карте. Если выбрано значение "Disabled", то тон будет задавать PCI-карта или даже ISA.
Аналогично функционирует и опция "Init Display First" с параметрами "AGP" и "PCI" ("PCI Slot"). При наличии в системе одного видеоадаптера эти опции не вызывают проблем. При установке же двух видеоадаптеров, поддерживаемых на уровне операционной системы, необходимо выбрать не только наиболее производительный, но и, что вполне реально, единственный вариант подключения двух дисплеев. Речь идет о ситуациях, когда PCI-адаптер не сможет работать вторым.
Опять таки аналогично функционирует опция "VGA BIOS Sequence" (последовательность загрузки BIOS видеокарт) с параметрами "PCI/AGP" и "AGP/PCI".
Несколько иной вариант выбора предлагает опция "Init Display First" в случае интегрирования видеоадаптера на материнскую плату. Значения могут такие: "Onboard" и "PCI Slot".
Напоследок более "древний" вариант аналогичной функции под названием "Graphics Adaptor" с параметрами "VL Bus" и "PCI Bus".

Joystick Function
- при наличии в системе джойстика и ...приведенной опции необходимо установить ее в "Enabled".

Onboard FDC (FDD) Controller
- опция, определяющая использование ("Enabled" - по умолчанию) или отключение контроллера флоппи-дисководов, размещенного на материнской плате, т.е. встроенного (onboard).

Onboard PCI IDE Enable
- (разрешение работы интегрированного контроллера IDE). Этот параметр управляет разрешением/запрещением работы каждого из двух каналов контроллера IDE, установленного на материнской плате. Может принимать значения:
"Primary" - разрешена работа только первого канала,
"Secondary" - разрешена работа только второго канала,
"Both" - разрешена работа обоих каналов,
"Disable" - запрещена работа обоих каналов.

Onboard Serial Port 1/2
- опция включения/отключения и установки системных ресурсов (адреса портов и прерывания) для встроенных первого и второго последовательных портов. Если "BIOS Setup" позволяет, рекомендуется установить в "Auto". Стандартные и при этом вполне корректные установки, которые вряд ли будет необходимость потом менять, могут быть получены при начальной установке "BIOS Setup" по умолчанию (defaults). Может принимать значения:
"3F8/IRQ4" - первый последовательный порт,
"2F8/IRQ3" - второй последовательный порт,
"3E8/IRQ4" - первый последовательный порт,
"2E8/IRQ3" - второй последовательный порт,
"Disabled" - запрещено использование последовательных портов (или порта),
"Auto" - система автоматически выбирает I/O-адреса.
Могут быть и дополнительные адреса и прерывания.
Опция также может носить названия: "Onboard Serial Port A/B", "Onboard Serial UART1/2", "Onboard UART 1/2".

PCI IDE 2nd Channel
- (2-й канал контроллера PCI IDE). Опция включения/отключения вторичного канала IDE-интерфейса. При установке опции в "Enabled" (по умолчанию) IRQ15 предназначается для вторичного IDE-канала. Если опция установлена в "Disabled", IRQ15 может использоваться для других устройств. Последняя установка рекомендуется и в случае отсутствия какого-либо устройства на 2-м IDE-канале.
Опция также может носить названия: "PCI Slot IDE 2nd Channel", "On-Chip Secondary PCI IDE".

USB Controller
- опция включения/отключения установленного на материнской плате контроллера USB. Включение USB-контроллера имеет смысл только в случае использования соответствующей периферии. При этом система выделяет специальное прерывание, которое может вызвать конфликт в случае слишком большого количества различных устройств, нуждающихся в собственных ресурсах. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция также может носить названия: "USB Interface", "Integrated USB Controller", "USB Function".

USB Keyboard Support
- подобная функция, предназначенная в данном случае для поддержки USB-клавиатуры. При использовании такой клавиатуры предварительно должна быть активирована поддержка USB-контроллера. Если же USB-клавиатура отсутствует, то возможная установка опции только "Disabled". Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция также может называться "USB Keyboard Legacy Support".

Функции конфигурирования распределения ресурсов

В 1993 г. "Compaq", "Intel", "Phoenix" и "Microsoft", стремясь сделать ПК еще более интеллектуальными, разработали концепцию "Plug & Play". Основная ее идея заключается в следующем: при загрузке ПК BIOS опрашивает все карты на предмет их потребности в ресурсах и распределяет их так, чтобы при работе ПК не возникали конфликтные ситуации. Общение между картой расширения и BIOS можно обеспечить еще эффективнее при использовании PCI-шины. Так, большинство PnP-карт разработаны только для шины PCI. Все PCI-карты отличаются, кроме того, дополнительными способностями. В отличие от своих ISA-родственников они могут работать с переменными ресурсами и посредством точно определенной идентификационной записи отчетливо заявлять о своих ресурсных потребностях. Соответственно этому BIOS, поддерживающий "Plug & Play", сперва проверяет жестко настроенные ISA-карты, а затем раздает оставшиеся ресурсы PCI-устройствам. В результате формируется список распределения ресурсов ESCD (Extended System Configuration Data), помещаемый BIOS'ом в нечувствительной к отсутствию питания области памяти для того, чтобы при каждом старте иметь возможность сравнения и восстановления последней функционировавшей комбинации.

Reset Configuration Data
- (сброс конфигурационных данных). Рекомендуется устанавливать опцию в "Disabled" при условии постоянства всей подключенной периферии и ее конфигурирования. При установке "Enabled" BIOS очистит область памяти ESCD (Extended System Configuration Data - данные расширенной системной конфигурации), в которой хранятся данные о конфигурировании системы, и перезапишет ее в процессе проведения POST. Затем BIOS автоматически переведет значение параметра в "Disabled", предотвращая систему от ошибок пользователя. Естественно, что при постоянстве параметра "Enabled" также постоянно происходило бы переконфигурирование распределения системных ресурсов. Опция может быть включена для перенастройки таблицы ресурсов либо при установке новых устройств.
Опция также может называться "Force Update ESCD".

7.1. IRQ

IRQ | Устройство | Приор. | Комментарии
0 | Системный таймер | * 15 | Системное прерывание. Генерируется 91 раз за 5 сек. В данном качестве применяется со времени первого PC.
1 | Клавиатура | * 14 | Системное прерывание, генерируемое контроллером клавиатуры.
2 | Контроллер прерываний | * 13 | Каскадировано (связано) с IRQ9. Могут возникнуть конфликты, когда одновременно на IRQ2 и IRQ9 должны работать различные устройства. Его использование системой сохраняется для совместимости.
3 | COM 2 | 4 | Используется вторым коммуникационным адаптером (UART2). Какое же устройство будет его генерировать? Это может быть второй последовательный порт COM2 (интегрирован на материнской плате), внутренний модем, настроенный на COM2 или COM4, или инфракрасный адаптер. Можно отключить UART2, но присвоить IRQ3 ничему не удастся. Делит одно и то же IRQ3 с COM4 (при наличии последнего). Возможен конфликт при одновременном использовании.
4 | COM 1 | 3 | Используется первым коммуникационным адаптером. Все практически идентично: генерируется первым последовательным портом COM1, модемом на COM1 или COM3 (за исключением инфрапорта). Делит одно и то же IRQ4 с COM3 (при наличии последнего). В системах с подключенной к COM1 мышью использовать COM3 не следует.
5 | свободен | 2 | Прерывание изначально предназначалось для использования вторым параллельным портом LPT2. Практического применения такое решение не нашло, поэтому IRQ5 перешло в разряд свободных. В IBM XT на IRQ5 "висел" жесткий диск. Через некоторое время "Creative Labs", создавая звуковую карту "Sound Blaster Pro", нашла применение прерыванию. С тех пор IRQ5 стало излюбленным для большинства звуковых ISA-карт. Звуковые PCI-карты также иногда используют это прерывание для эмуляции "SB Pro". IRQ5 можно привязать к слоту PCI.
6 | Контроллер FDD-дисковода | * 1 | Прерывание используется контроллером флоппи-дисковода, начиная с первых ПК. Ныне его можно отключить, если перейти на совместимый с обычными дискетами накопитель LS-120 с интерфейсом EIDE. Однако прерывание все равно не может быть использовано: ISA-карты на работу с ним не рассчитаны, и к слоту PCI привязать его нельзя. Может быть использовано для привода на на магнитной ленте.
7 | LPT 1 | 0 | По умолчанию прерывание первого параллельного порта LPT1. При отключенном порте (если принтер отсутствует или рассчитан на USB) может использоваться различными устройствами: сетевыми, ISDN-картами. Это также "запасное" место для звуковых карт.
8 | Часы реального времени (RTC) | * 12 | Системное прерывание со времени первых IBM AT.
9 | свободен | 11 | Каскадировано с IRQ2. В остальном может использоваться по усмотрению.
10 | свободен | 10 | Может быть использовано по усмотрению. Устаревшие IDE-контроллеры на старых звуковых картах иногда используют это IRQ.
11 | свободен | 9 | Может быть использовано по усмотрению, часто используется видеокартами. В современных ПК обычно резервируется для шины USB. При отключении последней в BIOS может быть задействовано иначе.
12 | свободен или PS/2-мышь | 8 | Если используется мышь, это IRQ в большинстве случаев выдается лишь по разрешению BIOS. Почти всегда прерывание свободно.
13 | Сопроцессор | * 7 | Системное прерывание. Изначально применялось арифметическим сопроцессором, который в первых ПК являлся отдельной микросхемой. Ныне это прерывание зарезервировано для совместимости со старым ПО.
14 | Первичный EIDE-контроллер | 6 | По разрешению BIOS может быть использовано в SCSI- системах.
15 | Вторичный EIDE-контроллер | 5 | Также может использоваться SCSI-интерфейсом, хотя обычно на него "подгружают" дополнительные EIDE-диски. При отсутствии устройств может применяться в любых целях.

Примечания:
15 - наивысший приоритет,
* - эти системные компоненты жестко зафиксированы и их конфигурация не может быть изменена.

: :
: :
------------------------ Slot AGP
----------------------- Slot 1 PCI
----------------------- Slot 2 PCI
----------------------- Slot 3 PCI
----------------------- Slot 4 PCI
------------------------------ Slot 1 ISA
------------------------------ Slot 2 ISA
При установке в слоты карт расширения необходимо помнить о следующем:
- слоту AGP и первому слоту PCI присваивается один и тот же номер прерывания,
- если слотов PCI пять, то один номер разделяют также четвертый и пятый слоты,
- при установке сложного устройства, требующего сразу два IRQ, желательно следующий слот оставлять свободным, иначе возможна достаточно сложная процедура ручного присваивания ресурсов.

IRQ n Assigned to
- (прерывание с номером n назначено на...). Использование этой опции возможно, если установлен "ручной" режим конфигурации устройств. В данной опции каждому прерыванию системы может быть назначен один из следующих типов устройств:
"Legacy ISA" (классические ISA-карты) - обычные карты для ISA-шины, такие как модемы или звуковые карты, без поддержки Plug&Play. Эти карты требуют назначения прерываний в соответствии с документацией на них.
"PCI/ISA PnP" (устройства для шин PCI или ISA с поддержкой Plug&Play) - этот параметр устанавливается только для карт расширения на PCI- или ISA-шинах с поддержкой Plug&Play.

IRQ to PCI VGA
- установка этой опции в "Disabled" позволит сэкономить одно прерывание благодаря тому, что графические карты при работе с обычным набором офисных приложений не используют IRQ. Ситуация меняется при установке 3D-акселератора. Выделение аппаратного прерывания для графической карты требуется уже не только для ее корректной работы в системе, а становится необходимым для организации обработки огромных массивов информации, для взаимодействия между центральным процессором, системной памятью и видеопроцессором. Это же справедливо и для случая, когда карта содержит, например, дополнительный модуль MPEG-декодера. Ведь в этом случае используется режим "Busmastering", при котором карта расширения отбирает у процессора управление потоком данных. Необходимо напомнить, что режим "Busmastering" требует по одному IRQ для каждой из карт, поддерживающих этот режим.
Опция может носить название "Assign IRQ For VGA".

PCI IRQ Activated by
- (прерывания активизируются по ...). Выбор метода, с помощью которого контроллер прерываний будет распознавать запрос на прерывание от устройств на шине PCI. Смысл опции - в минимизации времени "захвата" шины и дальнейшей передачи данных от устройства. По умолчанию предлагается значение "Level", и менять его не следует, если только это не будет необходимо для конкретного случая, о чем должно быть написано в руководстве к устройству. Параметр может принимать значения:
"Level" (уровень) - контроллер прерываний реагирует только на уровень сигнала,
"Edge" (перепад) - контроллер прерываний реагирует только на перепад уровня сигнала.

Report No FDD For WIN 95
- (сообщение об отсутствии накопителя на гибких дисках для "Windows 95"). Параметр используется, как правило, в сетевых компьютерах без флоппи-дисковода или в случае необходимости размещения в компьютере устройства, для которого не хватает прерывания. При выборе "Yes" и одновременном выборе "Disable" в параметре "Onboard FDC Controller" (обычно в разделе "Integrated Peripherals" "BIOS Setup") "Windows 9x" освободит IRQ6, занимаемое контроллером флоппи-дисковода, для использования другим устройством. Может принимать значения:
"Yes" (или "Enabled") - освободить IRQ6,
"No" (или "Disabled") - не освобождать (независимо от того, есть ли флоппи-дисковод или нет).

Trigger Method
- опция, позволяющая оптимизировать установку IRQ для PCI-слотов и могущая принимать значения "Auto" или "Forced". Для PCI- карты необходимо установить значение "Auto". Эта установка проверяет, нуждается ли PCI-карта в IRQ. Если карта не нуждается в IRQ, то система оставляет его для других ресурсов. Установка "Forced" используется в том случае, если BIOS автоматически не определяет, нуждается ли PCI-карта в прерываниях. Если установлено значение "Forced", то выделенный IRQ может использовать только данная PCI-карта.
Примечание! Если используемый в системе SCSI-контроллер с NCR-чипом не работает, то для этого контроллера необходимо установить прерывание IRQ15 и опцию "Level Trigger".

USB IRQ
- (прерывание шины USB). Параметр разрешает/запрещает назначение прерывания для контроллера шины USB. Поскольку в системе может не хватать свободного прерывания, разрешать этот параметр следует только при наличии устройства на шине USB. Также были замечены конфликты при одновременном использовании USB-устройств и звуковых карт на чипах "Aureal", и это было связано с распределением прерываний. Так что требуется внимательность. Может принимать значения:
"Enabled" - разрешено,
"Disabled" - запрещено.
Опция может носить название "Assign IRQ For USB" или "Use An IRQ for USB". Для последней опции параметрами были "No" и "Yes".


Если вдруг забыл пароль BIOS...
Это руководство подскажет, как поступить, если вы забыли пароль.

Естественно, для каждого способа защиты есть способ его обойти, особенно, если у вас есть физический доступ к компьютеру.

В этой статье мы рассмотрим различные методы защиты компьютера с помощью пароля и способы их обойти.

Как "обойти" пароль BIOS?

Пароль BIOS - один из самых старых способов защиты компьютера от несанкционированного доступа и один из самых распространенных. Почему? Это одно из самых эффективных средств, если пользователь не имеет доступа к системному блоку. В противном случае, это все равно, что запереть дом на множество замков и оставить открытым окно.

Установки BIOS по умолчанию во всех системных платах не хранят информацию о паролях. Так что все, что нужно сделать, чтобы убрать пароль BIOS, - просто сбросить текущие установки, восстановив конфигурацию по умолчанию. Но помните, что сброс текущих настроек BIOS уничтожит не только пароль, но и все те настройки, которые вы устанавливали самостоятельно.

Есть два способа сбросить настройки BIOS. У большинства системных плат есть специальный джампер для очистки CMOS (память, в которой хранятся настройки BIOS). Обычно этот джампер находится около батарейки на системной плате, но для полной уверенности желательно обратиться к инструкции от материнской платы. На некоторых материнских платах вместо джампера есть просто два контакта, которые для сброса CMOS нужно замкнуть металлическим предметом, например, отверткой.

Если на вашей плате есть джампер, то для очистки CMOS выключите компьютер, установите перемычку так, чтобы она замыкала контакты джампера, и нажмите кнопку включения компьютера. Ваш компьютер не начнет загружаться, но установки в CMOS будут сброшены. Уберите перемычку и снова включите компьютер. Скорее всего, вы увидите на экране просьбу нажать F1, чтобы произвести установку параметров BIOS. Если вас устраивают установки по умолчанию, нажмите F1, а в меню BIOS выберите пункт 'Save and exit' (сохранить и выйти). После этого компьютер загрузится как обычно, за исключением пароля BIOS.

Если вы не знаете, где на вашей плате находится необходимый джампер или его вообще нет, что вполне возможно, придется пойти другим путем. На каждой системной плате есть батарейка, которая является источником питания для памяти CMOS, позволяя сохранять информацию. Как правило, это стандартная батарейка CR2032.

Чтобы очистить CMOS, выключите компьютер и извлеките батарейку (возможно, вам понадобится тонкая отвертка). Через 5-10 минут установите батарейку на место и включите компьютер. В BIOS будут установлены параметры по умолчанию, а пароля не будет. Для продолжения загрузки нужно будет нажать клавишу F1, и если вас устраивают установки по умолчанию, выбрать в появившемся меню BIOS пункт 'Save and exit'.

Как вы убедились, все это очень просто на настольном компьютере, а вот с ноутбуком пароль BIOS может стать серьезной проблемой. Из-за частых краж портативных компьютеров, производители позаботились о том, чтобы получить доступ, минуя пароль, было практически невозможно. Так что, если вы забыли пароль BIOS у своего ноутбука, скорее всего, вам придется обратиться в сервисный центр производителя.

Как сбросить установки BIOS (включая пароль) в значения по умолчанию из DOS?

Так как не все материнские платы оборудованы джампером для сброса установок BIOS или этот джампер может быть недоступен, то существует метод очистки BIOS из DOS, при помощи команды debug. Загрузившись в DOS (не в DOS-box под Windows!) необходимо набрать:

Метод 1 (Award и AMI BIOS):

DEBUG
-O 70 17
-O 71 17
Q

Метод 2 (Phoenix BIOS):

DEBUG
-O 70 FF
-O 71 17

Как аппаратно сборосить CMOS (вместе с паролями)?

Почти на всех совpеменных системных платах pядом с батаpейкой есть пеpемычка для сбpоса CMOS-памяти (обычно - 4 контакта, ноpмальное положение - 2-3, сбpос - 1-2 или 3-4; иногда - 3 или 2 контакта).

Выпаивать и тем более замыкать батаpейку не имеет смысла - это чаще всего не пpиводит к успеху из-за констpукции схемы питания CMOS-памяти, а замыкание батаpейки сильно сокpащает сpок ее службы.

Если на плате нет батаpейки, нужно поискать пластмассовый модуль с надписью "DALLAS" (это монолитный блок с батаpейкой и микpосхемой CMOS) - пеpемычка может быть возле него.

В случае, если перемычка для очистки CMOS-памяти отсутствует, то сначала попробуйте отключить или отсоединить батарейку. При этом также рекомендуется отключить провода от блоки питания, так как заряд на его конденсаторах может сохраняться и успешно поддерживать питание CMOS RAM (ей очень мало надо) более суток.

Это уникальные ключи, если в предыдущих случаях пароль слетал то в этом он обходится.

Подробнее, вот эти ключи:

Унивеpсальные паpоли к AWARD BIOS:
AWARD_SW
AWARD_WG
AWARD_PW
TTPTHA
BIOSTAR
ZJAAADC
ZAAADA
ZBAAACA
AWARD?SW
t0ch20x
SWITCHES_SW

Унивеpсальные паpоли к AMI BIOS:
AMI
AMI_SW - не унивеpсальный но устанавливается пpи сбpосе CMOS/SETUP'a
SER
Ctrl+Alt+Del+Ins (держать при загрузке, иногда просто INS)
A.M.I.
aammii
AMI!SW
AMI.KEY
AMISETUP
AMIPSWD
BIOSPASS
CMOSPWD
HEWITT
KILLCMOS

PHOENIX:
phoenix, PHOENIX, CMOS, BIOS

VOBIS & IBM: merlin, Dell: Dell, Biostar: Biostar, Compaq: Compaq, Enox: xo11nE, Epox: central, Freetech: Posterie, IWill: iwill, Jetway: spooml, Packard Bell: bell9, QDI: QDI, Siemens: SKY_FOX, TMC: BIGO, Toshiba: Toshiba

Как подобрать (снять) пароль на Setup (загрузку)?

Если забыт паpоль на Setup, можно воспользоваться pазличными пpогpаммами для снятия паpоля или одним из заводских паролей.

Заводские пассворды для AWARD BIOS следующие:
AWARD_SW, TTPTHA, aPAf, HLT, lkwpeter, KDD, j262, ZBAAACA, j322, ZAAADA, Syxz, %шесть пpобелов%, Wodj, %девять пpобелов%, ZJAAADC, 01322222, j256, ?award
Один из этих паролей должен подойти. Однако в новых AWARD BIOS (версии 4.51) инженерные пароли отсутствуют.

Для AMI BIOS стандартных паролей нету. Единственный случай: если вы только приобрели материнскую плату то пароль может быть AMI.

Hа некотоpых AMI BIOS можно сpазу после включения деpжать нажатой клавишу Ins - пpи этом в CMOS-память загpужаются стандаpтные паpаметpы.


BIOS-FAQ

Help and FAQ
 Содержание
  • BIOS
  • BIOS компьютера
  • BIOS FAQ
  • Award-BIOS
  • Хитрые настройки BIOS
  • Настрой свой BIOS на максимум
  • Setting a BIOS Password
  • Если вдруг забыл пароль BIOS
  • BIOS Beeps. Сигналы и ошибки BIOS
  • BIOS Beeps Errors. Звуковые сигналы ошибок BIOS


Setting a BIOS Password

Lockdown.co.uk - The Home Computer Security Centre
LockDown is the source for security information and resources for the home computer user.

Setting a BIOS Password
Make your computer ask for a password without installing anything.

Your computers BIOS is the first program that is run when your computer starts. You can tell the BIOS to ask for a password when it starts, thus restricting access to your computer.

To enter the BIOS setup program, sometimes called CMOS setup:

Turn on or reboot your computer. The screen will display a series of diagnostics and a memory check.

A message like "Hit the <DEL> key to enter the BIOS setup program" will appear.

When you do hit DEL at the right time[1] you'll see a menu screen something like this:

Note: Some BIOS versions use a graphical type menu with icons (a GUI) or have a text interface that appears differt to the one shown, the principle however is exactly the same.

As you can see there are two options that relate to passwords, Supervisor Password and User Password, these relate to controlling access to the BIOS Setup Program and the Machine Boot respectively.

Note that not all BIOS's have this password feature, your bios may not have it in which case you won't be able to restrict access to your computer in this way.

Select USER PASSWORD and you'll be prompted to enter a password:

You should now enter a password of up to eight characters (most BIOS's are limited to eight characters unfortunately). I recommend you use the full eight but take care that you choose something you'll not forget, for help choosing passwords see here.

The BIOS will then prompt you to confirm the password, just type the same thing again.

Now you'll want to set your system to ask for that password every time it boots, so select the BIOS FEATURES SETUP option, to see a menu something like this:

Fairly obviously, it's the Password Check option we're interested in, so select it and change the setting to ALWAYS.

Now navigate back to the main menu and select SAVE & EXIT SETUP. Your machine will then reboot and you'll be prompted for the password.

Each and every time you boot you'll be asked for password you chose.

Please note that this method of restricting access to your computer is not completely foolproof, there are ways around it. But it will stop or at least delay the majority of casual attempts to get access.

If you forget your BIOS password, consult your motherboard manual or if you don't have one, consult the website of the BIOS manufacturer.

[1] It's not always the DEL key some BIOS's use F2 or F10 or anothother key combination, check your motherboard manual.

Thursday 22nd January 2004 21:07


"Хитрые" настройки BIOS

Макс Курмаз

Думаю, большинству читателей известно, что BIOS – это базовая система ввода-вывода, включающая в себя набор подпрограмм, записанных в ПЗУ компьютера. Кроме обслуживания обращений к различным устройствам и проведения начальной диагностики (процедура POST), BIOS также занимается инициализацией всех устройств компьютера, занося в их регистры определенные значения. Очевидно, что от того, как именно настроит BIOS то или иное устройство, зависит быстродействие и стабильность всей системы в целом. Программа Setup, доступ к которой можно получить, нажав “DEL” (или “F2”) при загрузке, как раз и позволяет изменять те значения, которые загружаются в регистры различных устройств, прежде всего чипсета материнской платы. Кстати, хранятся они в памяти, питаемой от батарейки, а память эту называют CMOS (Complimentary Metal-Oxide-Semiconductor, потребляющая небольшую мощность в статическом режиме логика).

Раз BIOS Setup позволяет настраивать систему, интерес к его опциям неизменно проявляется у многих владельцев компьютеров. Конечно, можно спокойно применить к ним «метод тыка» и добиться при этом хорошего результата. Но гораздо лучше знать, что именно затрагивает та или иная опция и производить «твикинг» целенаправленно. Данный цикл статей, построенный на базе нескольких хорошо известных в интернете «BIOS Guides» (см. конец статьи), и будет посвящен самым «хитрым» опциям современных BIOS.

Настраиваем память

Прежде чем начинать описание опций BIOS, затрагивающих работу памяти (обычно они находятся в Advanced Chipset Setup), нужно хотя бы приблизительно разобраться, как именно происходит к ней доступ.

Как известно, у современного компьютера память подключена к системному контроллеру (точнее, к контроллеру памяти) с помощью 64-разрядной шины. По этой шине передаются как адреса, так и данные. Физический адрес определенной ячейки памяти содержит в себе адреса строки (Row) и столбца (Column) в запоминающем массиве. Сигнал RAS (Row Access Strobe) сигнализирует о том, что в данном такте выбирается определенная строка, сигнал CAS (Column Access Strobe) – столбец, а точнее, элемент (слово) из строки. После этого данные в виде пакета (нескольких последовательных слов) выдаются на шину.

Кроме того, современные микросхемы памяти содержат в себе несколько независимых банков. Работа с банком начинается с его активации (открытия) и заканчивается закрытием, после чего данные в нем обновляются (перезаряжаются ячейки динамической памяти, содержимое которых имеет свойство быстро обнуляться).

Итак, работа с памятью происходит по следующему алгоритму:
1. Активируется банк подачей сигнала RAS;
2. Происходит задержка, пока данные поступают из выбранной строки банка в усилитель (задержка RAS-to-CAS);
3. Подается сигнал CAS на выборку первого слова из строки;
4. Данные поступают на шину, при этом происходит задержка (CAS Latency);
5. Следующее слово выдается уже без задержки, так как оно содержится в подготовленной строке;
6. Когда цикл выборки пакета из четырех слов завершен и больше нет обращений к этой строке, происходит закрытие банка; данные возвращаются в ячейки (задержка RAS Precharge).

Важно понимать, что уже открытый банк не требует задержек на активацию, а доступ к данным в нем требует только одну задержку – CAS Latency. Поэтому именно она оказывает наибольшее влияние на производительность подсистемы памяти. Также стоит обратить внимание на тот факт, что банки памяти могут открываться и закрываться независимо друг от друга, что позволяет работать с одним из них тогда, когда другой занят перезарядкой.

SDRAM Cycle Length (CAS Latency, CAS Delay)

Число тактов, требуемых для выдачи данных на шину после поступления сигнала CAS. Самый важный параметр, влияющий на производительность. Если память позволяет, нужно выставлять значение 2.

RAS-to-CAS Delay (Trcd)

Число тактов, необходимых для поступления строки данных в усилитель. Тоже оказывает влияние на производительность. Значение 2 предпочтительнее и подходит в большинстве случаев.

SDRAM RAS Precharge Time (TRP)

Время перезарядки ячеек памяти после закрытия банка. Обычно используется значение 2, хотя чипсеты VIA позволяют установить 3 (см. ниже).

SDRAM RAS Time (TRAS)

Время, в течение которого банк остается открытым и не требует обновления (перезарядки). Как правило, такой отдельной опции нет, она комбинируется с последующей.

SDRAM Cycle Time (TRC, TRAS/TRC)

Время (в тактах), требуемое на полный такт доступа к банку, начиная с открытия и заканчивая закрытием. Обычно задается вместе с параметром TRAS. TRC=TRAS+TRP. Чипсет i815 позволяет устанавливать TRAS/TRC в значения 5/7 и 7/9, чипсеты VIA Apollo и KT – 5/7, 5/8, 6/8, 6/9, изменяя при этом время TRP. Современная память со временем цикла 50 нс и частотой 133 МГц (маркировка 7.5 нс) позволяет работать в режиме 5/7.

SDRAM Idle Cycle

Иногда встречается и такая опция. Она устанавливает время простаивания банка памяти, не занятого обменом данными. Изменять значение по умолчанию не имеет смысла.

RAS Precharge Control (Page Closing Policy)

Управляет процедурой закрытия банков памяти. Если установлено значение Disabled ( Precharge All), то контроллер памяти закрывает сразу все открытые банки памяти при попытке доступа за пределы текущего банка. При необходимости доступа к следующему банку нужно его открыть. Если же поставить Enabled (Precharge Bank), то все банки остаются открытыми до тех пор, пока не потребуется перезарядка их ячеек. Тем самым можно выполнять доступ к нескольким банкам без ожидания их закрытия и последующей активации, что существенно ускоряет работу при чтении больших блоков данных, но замедляет – при активном использовании процессорного кэша (банк приходится закрывать в самый неподходящий момент).

Bank Interleaving

То же самое, но с другой стороны. Включение этого режима позволяет работать с банками по очереди, то есть получать данные из одного в то время, когда другие заняты. Причем выбор значения 2-Way позволяет чередовать пару банков, а 4-Way – четыре банка (они есть у большинства микросхем DIMM-модулей), а это, конечно, выгоднее.

Bank X/Y DRAM Timing

Очень «хитрая» опция, часто встречающаяся в BIOS Setup материнских плат на чипсетах VIA. Список значений этой опции – 8/10/Normal/Fast/Turbo. Какой именно смысл скрывается за всем этим? Какие именно параметры работы контроллера памяти изменяет эта опция? Этот вопрос был прояснен с помощью утилиты WPCREDIT, которая получает доступ к регистрам чипсета. После обследования нескольких материнских плат была составлена такая таблица:

Значение опции | Tras | Trp | RAS-to-CAS | Bank Interleaving
SDRAM 8-10ns | 6T | 3T | 3T | Disabled
Normal | 5T | 2T | 1T | 4 way
Medium | 6T | 3T | 3T | Disabled
Fast | 6T | 3T | 3T | Disabled
Turbo | 6T | 3T | 2T | Disabled

Очевидно, что наибольшая производительность будет достигнута при значении Normal; Turbo отключает чередование банков и устанавливает меньшие значения задержек RCD и Precharge, а все остальные вообще ничем не отличаются. Впрочем, известно, что на платах ASUS эта опция переделана – там Turbo дает минимальные задержки, а Normal – максимальные. Выяснить, изменил ли производитель материнской платы эти опции AwardBIOS, можно либо с помощью тестов (хорошо подойдет Sandra Memory Bandwidth test), либо с помощью уже упомянутой утилиты WPCREDIT.

DRAM Clock

Чипсеты VIA, а также Intel i810/i815 и модификации допускают псевдоасинхронную работу шины памяти и процессорной шины (FSB – Front Side Bus). Данная опция у чипсетов VIA имеет значения Host CLK, CLK+33 и CLK-33 (не все присутствуют), что подается как возможность повышать или понижать частоту памяти относительно процессорной шины на 33 МГц. На самом деле частота не суммируется, просто используется другой множитель относительно частоты шины PCI, которая всегда равна 33 МГц. Например, при FSB=100 (PCIx3) память может работать на частоте 66 (PCIx2) или 133 (PCIx4). Если память позволяет, частоту нужно увеличивать – ставить CLK+33.

Для чипсетов Intel есть возможность выбрать либо частоту 100, либо – 133 МГц. Последняя возможна только в том случае, если и процессор работает на шине 133 МГц. И кроме того, i810/i815 не позволяет использовать три модуля памяти на частоте 133 МГц.

Memory Timing by SPD

Как известно, SPD (Serial Presence Detection) – механизм получения информации о характеристиках модуля DIMM. В небольшой EEPROM-микросхеме хранятся CAS Latency, RAS-to-CAS и множество других параметров. Если эту опцию включить, то BIOS при загрузке автоматически сконфигурирует контроллер памяти, установив наилучший допустимый режим работы, поставит и CAS Latency, и Bank Interleaving, и даже частоту работы памяти. Пользователю уже не нужно беспокоиться о выборе правильных настроек.

Однако не во всех случаях SPD дает положительный эффект. Во-первых, недобросовестные производители памяти могут «зашить» в ППЗУ завышенные значения, и память будет сбоить. Во-вторых, при проблемах с чтением SPD все настройки памяти будут выставлены по минимуму. Поэтому включать данную опцию нужно с осторожностью, будучи уверенным, что микросхемы SPD всех модулей памяти исправны.

Memory Hole at 15-16М

Эта опция изначально предназначена для устранения проблемы несовместимости со старыми ISA-устройствами. Некоторые из них требовали монопольного выделения диапазона адресов в пределах 16-го мегабайта. Сейчас такие устройства найти нелегко, поэтому Memory Hole можно было бы смело считать анахронизмом. Если бы не один непонятный побочный эффект: часто включение этой опции помогает решить проблему нестабильной работы чипсетов VIA со звуковыми картами Creative (SB Live!) и Aureal. Видимо, при этом происходит перераспределение выделяемых устройствам адресов. Правда, можно потерять доступ к памяти за пределами 16 Мб, особенно в Linux, если не принять специальных мер. Но если у вас никаких проблем не наблюдается, то и не включайте эту опцию.

In Order Queue

Эта опция затрагивает только некоторые чипсеты VIA. У них имеется четырехступенчатый конвейерный буфер, предназначенный для обслуживания операций чтения данных из памяти. Конечно, лучше включить все ступени (4 level) и получить дополнительные 5-10% производительности.

PCI-to-DRAM Prefetch

Когда PCI-устройство, работая в режиме захвата шины (Bus Mastering), выполняет обращение к памяти, во внутренний буфер контроллера поступает один байт с заданным адресом. Но если включить эту опцию, в буфер будут считаны несколько последующих байтов, поэтому следующий запрос PCI-устройства будет выполнен без обращения к памяти. Для звуковых карт и FireWire-контроллеров она особенно важна.

Read Around Write

Как известно, большинство (до 90%) запросов к памяти связаны с чтением данных, а не с записью. Тем не менее, запись в память необходима, однако шина не позволяет производить обе операции одновременно. Поэтому при необходимости записи хотя бы одного байта любой процесс чтения будет прерван. Чтобы этого не случалось, существует “Read Around Write”-буфер, в который поступают данные, требующие последующего помещения в память. Таким образом, операция записи производится только тогда, когда в буфере накоплено достаточно данных. Если же данные еще не успели записаться, то вообще можно обойтись без чтения из памяти, используя буфер как кэш. Очевидно, что эту опцию лучше включать. Правда, есть сведения, что при этом не будет работать видеокарта на чипе i740.

Fast R-W Turn Around

Данная опция позволяет уменьшить задержки при смене режимов обращения к памяти – когда за записью следует чтение и наоборот. Очевидно, что нагрузка на память при этом возрастает, что может приводить к нестабильности и появлению ошибок. Включайте и проверяйте.

System ROM Cacheable

Эта опция включает в число кэшируемых диапазон адресов, в которых хранится копия системного BIOS. Нет никакой необходимости кэшировать BIOS, поскольку имеющиеся в его составе подпрограммы во время работы приложений не используются. То же самое можно сказать и об опции Video BIOS Cacheable – отключайте не задумываясь.

Video RAM Cacheable

Видеопамять для текстовых и простых графических режимов располагается в диапазоне адресов 0A000h-0BFFFh. Когда вы работаете в Windows или любой другой графической оболочке, буфер кадра отображается на определенные линейные адреса далеко за пределами первого мегабайта. Значит – отключаем.

Контроллер PCI

Вторая часть моего обзора настроек BIOS связана с работой контроллера шины PCI и совместимых с ней устройств. Нелишне будет немного пояснить механизм работы этой шины. Каждое устройство может выступать в качестве «хозяина» шины на время обмена с памятью (пресловутый режим DMA), забирая ее для своих нужд. Перед этим оно, конечно, должно подать запрос арбитру. Когда обмен закончен, устройство сообщает об этом путем выдачи прерывания (IRQ). На нужды шины выделяется четыре линии прерываний INT#A-INT#D, причем каждый слот имеет разный порядок подключения этих линий. Другими словами, первая линией прерывания на разных слотах будет разной, например, у слота 1 это будет INT#A, у слота 2 – INT#B и т.д., но не обязательно в таком порядке. Тем самым PCI-устройства, использующие обычно первую линию, в разных слотах не всегда работают на одном и том же прерывании. Хотя по теории не должно быть никаких проблем при использовании одной линии прерывания несколькими устройства, на самом деле некоторые звуковые и видеокарты отказываются работать в паре. Тут уж ничего не поделаешь. А вот для того, чтобы не пересечь PCI-устройства с клавиатурой, COM- и LPT-портами и т.д., есть опция присваивания линиям IRQ (еще их называют INT PIN) разных номеров–входов на контроллере прерываний.

Переходим к другим опциям.

CPU to PCI Write Buffer

Когда процессор работает с PCI-устройством (т.е. режим DMA не используется), он производит запись в порты. Данные при этом поступают в контроллер шины и далее в регистры устройства. Если мы включаем эту опцию, задействуется буфер записи, который накапливает данные до того, как PCI-устройство будет готово. И процессор не должен его ждать – он может выпустить данные и продолжить выполнение программы. Я не вижу каких-либо причин выключать эту опцию.

PCI Dynamic Bursting (Byte Merge, PCI Pipeline)

Эта опция тоже связана с буфером записи. Она включает режим накопления данных, при котором операция записи (транзакция шины) производится только тогда, когда в буфере собран целый пакет из 32 бит. Эффект сугубо положительный – пропускная способность 32-битной шины используется на полную мощность, без холостых операций. Включать обязательно.

PCI#2 Access #1 Retry

Тоже опция, управляющая работой буфера записи. Она определяет, что нужно делать в том случае, если буфер уже заполнен, а устройство так и не подготовилось к получению данных и не смогло принять их. Enabled – операция записи будет повторяться, Disabled – генерируется ошибка и процессор (точнее, программа, выполняющая запись в порт) решает, как поступать дальше.

PCI Master 0 WS Write

Данная опция в положении Disabled позволяет добавлять один дополнительный такт перед операцией записи, проходящей по шине. В случае разгона процессора с помощью увеличения частоты шины FSB увеличиваются также частоты всех остальных шин, в том числе и PCI. Тут-то дополнительный такт и спасает. Если с PCI все нормально - частота 33 МГц и «глюков» не наблюдается, то опцию нужно включать.

PCI Latency Timer

С помощью этой опции можно установить количество тактов, отводимых каждому PCI-устройству на осуществление транзакции (операции обмена). Чем больше тактов, тем выше эффективность работы устройств, так как не требуется заново запрашивать разрешение, захватывать и освобождать время и т.д., то есть выполнять операции, требующие определенного времени, но не дающие реального эффекта. Однако при наличии ISA-устройств PCI Latency нельзя увеличить до 128 тактов. Также можно серьезно нарушить работу системы, поэтому аккуратно подходите к этому вопросу.

Delayed Transaction

Эта опция регулирует взаимоотношения ISA- и PCI-устройств в момент, когда им обоим требуется получить доступ к памяти. Как известно, шина ISA тактируется в четыре раза медленнее, чем шина PCI – 8 МГц против 33 МГц. Скорость обмена тоже гораздо ниже. Если PCI-устройство потребует обмена в то время, как работает ISA-устройство, оно просто не получит такой возможности и будет ждать своей очереди. Однако выход есть – задержанная транзакция. При ней данные не поступают на шину, а накапливаются в 32-битном буфере. Когда шина освобождается, происходит транзакция. Но не все ISA-устройства позволяют так обманывать себя, поэтому в случае проблем отложенную транзакцию нужно отключать.

Passive Release

Это – на ту же тему. Пассивное освобождение шины PCI происходит при активности одного из ISA-устройств. Процессор получает возможность не дожидаться окончания транзакции и начинать запись данных. Если с ISA-устройствами возникают проблемы, эту опцию нужно отключать.

PCI 2.1 Compliance

По сути это – включение двух предыдущих опций, так как любое устройство, удовлетворяющее спецификации PCI 2.1, должно поддерживать и отложенную транзакцию, и пассивное освобождение шины.

Вот, собственно, и все, что в BIOS Setup касается шины PCI. Корректность сделанных настроек можно проверить, нагрузив по очереди все PCI-устройства. Особенное внимание следует обращать в том случае, если частота шины PCI вследствие разгона оказалась выше номинала. Следующий раз поговорим о другой шине – AGP.

Контроллер AGP

Теперь речь пойдет о контроллере шины AGP. Сначала нелишне будет в очередной раз вспомнить, что же это за шина. AGP (Accelerated Graphics Port) была создана компанией Intel специально для поддержки видеокарт нового поколения. За основу была взята универсальная шина PCI. По сравнению с ней AGP допускает работу только одного устройства. При неизменной ширине шины (32 бита) частота возросла вдвое и составила 66 МГц. В дальнейшем были предложены режимы AGP 2x и AGP 4x, в которых вдвое и вчетверо соответственно увеличена скорость обмена, а также введено пониженное напряжение (1.5 В). Еще одно отличие AGP – ориентация на новый режим обмена, названный DiME (Direct In-Memory Execution). Это значит, что AGP-контроллер видеокарты может не просто получать большие объемы данных из системной памяти (режим DMA), но и задействовать ее в качестве расширения памяти видеокарты. Тем самым планировалось полностью избавиться от необходимости оснащать видеокарты памятью. Идея не нашла поддержки со стороны разработчиков графических чипов. Объем видеопамять постоянно растет, уже вовсю применяются алгоритмы сжатия текстур и Z-буфера, а AGP-память используется только в редких случаях, так как это приводит к падению производительности.

Initial Display

Эта опция, чаще всего находящаяся в разделе «Peripheral Setup», совершенно ни на что не влияет в том случае, если у вас только одна видеокарта. Если же их две, то BIOS предоставляет возможность выбрать, которую из них назначить первой (Primary).

AGP Aperture Size

Эта опция устанавливает размер апертуры, то есть максимального объема системной памяти, выделяемой для работы в режиме AGP DiME. Заполняться блоками памяти апертура будет только в случае использования больших текстур. Поэтому выбор очень больших значений никак не повлияет на общую производительность видеокарты. Однако если выбрать слишком маленькое значение, то режим AGP DiME, а иногда и DMA, будет полностью отключен, что может помочь в решении проблемы с несовместимостью видеокарты и материнской платы.

Какое все-таки значение лучше устанавливать? Обычно советуют брать за основу половину объема системной памяти. Или еще одна формула: основная_память * 2 / видеопамять. На самом деле во всех случаях нужно устанавливать либо 64, либо 128 Мб.

AGP Driving Control

Эта опция есть у материнских плат с чипсетами VIA. Она позволяет включить режим управления мощностью сигнала, подаваемого на слот AGP. Необходимость в этом возникает в том случае, когда графический контроллер потребляет слишком много энергии. Если материнская плата не способна обеспечивать необходимые параметры, начнутся сбои и зависания при работе в 3D-режиме.

Также эта опция может быть полезной при разгоне процессора шиной, когда вместе с FSB поднимаются частоты всех шин, в том числе и AGP.

AGP Driving Value

Это и есть та опция, которая задает мощность сигнала. Для устранения проблем обычно советуется поставить значение DA. Если не помогает, стоит попробовать E7, EA и выше. Однако экспериментировать с этой опцией очень опасно, поэтому трогайте ее только в случае крайней необходимости.

AGP Master 1WS Read

Эта опция отвечает за установку задержек при работе AGP-контроллера видеокарты в режиме DMA. Обычно начало обращения к памяти происходит по истечении двух холостых тактов. Для увеличения производительности можно включить эту опцию и тем самым вдвое сократить задержки.

AGP Master 1WS Write

Аналогично предыдущей опции, но касательно операций записи в память.


Настрой свой BIOS на максимум

Введение

Хорошо известно, что производительность Вашей материнской платы сильно зависит от временных установок для работы с памятью, выполняемых в BIOS Setup. Название пунктов Setup, в которых устанавливаются эти временные параметры может меняться в зависимости от чипсета и BIOS на Вашей материнской плате. Различные BIOSы предлагают пользователю различный набор возможностей для настройки Вашей системы: в одних (таких как Award или AMI) этих возможностей более чем достаточно, в то время как другие (например Phoenix) таких возможностей не предоставляет вовсе. Вообще говоря, для достижения максимальной производительности нужно стремиться к уменьшению всех временных задержек. Однако установка чрезмерно маленьких значений, не поддерживаемых вашей системой, может приводить к нестабильной работе, зависаниям и невозможности загрузить компьютер. Однако не следует отчаиваться. Достаточно загрузить установки Setup defaults после повторного входа в Setup, и можете быть уверены, что Ваша система вернется в исходное состояние. Изменение установок Setup не может повредить Вашу систему. Но установки по умолчанию не будут обеспечивать максимальной производительности.

В данном документе не рассматриваются основные вопросы взаимодействия с Setup BIOS, информацию о которых можно получить из документации к Вашей материнской плате. Здесь написано, как разогнать Ваш компьютер, не открывая корпуса.

Настройка Advanced Chipset Setup

Все что касается временных задержек и описано ниже, можно найти в разделе Advanced Chipset Setup в Setup Вашего BIOSа. Ниже описаны опции этого раздела, которые влияют на производительность компьютера.

Auto Configuration

Если Вы хотите выполнять какие-либо изменения в настройках, то эту опцию следует выключить. Ее включение приводит к установке всех временных задержек по умолчанию, которые, как Вы уже знаете, не обеспечивают максимального быстродействия.

DRAM Read Timing

Имейте в виду, то что алгоритмы работы современного Pipeline Burst Cache устроены таким образом, что гораздо выгоднее выполнять обмены с памятью не словами или байтами, а группами из четырех или восьми последовательно расположенных двойных слов. В терминах временных диаграмм задержка при обмене с памятью несколькими двойными словами выглядит как x-y-y-y для обычного обращения и x-y-y-y-z-y-y-y для обращения с обратной записью. Здесь первая цифра означает количество тактов процессора, необходимых для чтения первого двойного слова, а остальные цифры - количество тактов процессора, необходимых для чтения последующих двойных слов. Например, для Pipeline Burst Cache RAM это выглядит как 3-1-1-1 или 3-1-1-1-1-1-1-1. Для обычной основной памяти эти цифры не являются жестко определенными и могут варьироваться в зависимости от ее типа и скорости, а также продвинутости пользователя. Поэтому Вы можете пользуясь BIOS Setup изменять параметры x, y и иногда z для увеличения производительности подсистемы памяти. Отсюда напрашивается вывод о том, что для того, чтобы процессор мог быстрее оперировать с памятью, Вы должны уменьшать вышеуказанные значения. Допустимые значения для циклов обращения к памяти - x222 или x333 для EDO RAM, x333 или x444 для FPM RAM и x111 или x222 для SDRAM. Именно эти значения Вы и можете изменить в Вашем Setup. Вы уже наверное догадались, что SDRAM - самый быстрый тип памяти.

Уменьшайте значения циклов ожидания! Это ускорит Вашу работу. Однако имейте в виду, что при уменьшении параметров следует проверять стабильность работы системы под многозадачными операционными системами (например, Windows 95). Причем эту проверку лучше выполнять при активной работе с памятью. Я например, запускаю под Windows 95 две копии Quake и некоторое время интенсивно переключаюсь между ними. Если все работает, то можно Вас поздравить.

DRAM Write Timing

Эта опция, отвечающая за время записи в память, выставляется аналогично предыдущей. Единственное отличие, которое следует иметь в виду, это то, что значения задержек для EDO и FPM устанавливаются одинаковыми, так как скорость обращения к этим типам памяти отличается только при чтении (EDO быстрее).

Также, как и в предыдущем случае, устанавливайте наименьшие возможные значения. Но при этом система должна работать!

RAS to CAS Delay

Сделать толковое объяснение по этому поводу достаточно затруднительно, так как размер моей страницы ограничен провайдером.

Однако, аналогично, старайтесь уменьшить это значение, но имейте в виду, что не все типы памяти будут с ними работать. Поэтому не забудьте проверить работоспособность системы и в этом случае.

DRAM Leadoff Timing

Короче говоря, этот тот "x", о котором говорилось страницу назад (временная диаграмма чтения/записи). Но при установке этого значения имеет место различие между существующими чипсетами. Например, максимум, что может Triton FX при чтении, это 7-y-y-y, а Triton TX или HX позволяет установить 5-y-y-y. Поэтому последние чипсеты будут работать быстрее. При записи же FX позволяет установить 5-y-y-y, а HX и TX могут работать при 4-y-y-y, однако Intel рекомендует эти установки только при внешней частоте 50 или 60 МГц.

Как Вы уже догадались, лучше поставить меньшее возможное значение и проверить работоспособность. Но система будет работоспособна при значении 5, только если используется память со временем доступа 50нс (или быстрее) для EDO или 10ns для SDRAM.

Turbo Read Leadoff

Изменение этого значения позволяет уменьшить "x" еще больше. Но память, которая поддерживала бы эту опцию, встречается достаточно редко.

Вы конечно можете попробовать разрешить эту установку, но имейте в виду, что Ваша система вряд ли будет работать устойчиво, если вообще будет работать. Но если уж Вам повезло, то не забудьте тщательно проверить работоспособность.

Turbo Read Pipelining

Похоже, что изменение этой опции приводит к изменению "z" в описанной выше временной диаграмме.

Если хотите, чтобы ваш компьютер работал быстро, попробуйте включить и эту опцию, хотя нельзя быть уверенным, что система будет работать вообще.

Speculative Lead Off

При включении этой опции, контроллер DRAM может начинать выполнять чтение до того, как полностью будет декодирован адрес, по которому находятся требуемые данные. Это может еще ускорить работу с памятью. Если это не так, то все вопросы к Novations Technologies Inc. Что бы это ни было, производительность системы при включении этой опции возрастает.

Вообще, имейте в виду, что разгон подсистемы памяти - вещь достаточно творческая, которую легко выполнять не зная ничего из того, что написано выше. Достаточно просто скачать какую-либо утилиту, измеряющую скорость работы памяти и экспериментировать. Однако мы надеемся, что приведенные выше рекомендации могут немного помочь.

Дополнительную информацию о других пунктах Setup можно получить из FAQ по материнским платам.